18:07:38 <ennael> #startmeeting
18:07:38 <Inigo_Montoya> Meeting started Thu Aug 11 18:07:38 2016 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:07:38 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:07:50 <ennael> who is around?
18:07:56 * marja is
18:08:01 <Akien> o/
18:08:07 * Latte too
18:08:09 <grenoya> o/
18:08:15 * Son_Goku is here, though he's not a council member
18:08:42 <ennael> ok so let start now
18:08:44 <marja> I've seen wilcal and Luigi12_work
18:09:16 <wilcal> I'm here
18:09:46 <ennael> #topic find some solutions to fill departures
18:09:56 <ennael> ok you may have seen tmb mail
18:10:16 <ennael> because of health pb he needs to leave for now mageia
18:10:24 <marja> yep .... but you're talking about "departures"
18:10:29 <ennael> sorry
18:10:34 <ennael> without s :)
18:10:51 <marja> good :-)
18:11:04 <ennael> so we hope all he will be better and we see him in some weeks/months
18:11:12 <marja> +1
18:11:38 <ennael> our current pb is to find a way to do his job
18:11:50 <Akien> Yeah, we can well imagine that it was a hard decision for him, but let's wish him prompt recovery.
18:11:52 <ennael> especially as we are not that far from final release
18:12:03 <Akien> (I saw him commenting on a bug report today.. bad boy :p)
18:12:20 <ennael> :)
18:12:23 <Son_Goku> he's supposed to be resting! :P
18:12:34 <grenoya> ennael: is there technically easy tasks to distribute ?
18:12:34 <ennael> so we need people on both kernel and live isos
18:12:52 <ennael> I've already asked pterjan and blino about this
18:12:53 <marja> the only person I know (apart from tmb) who has built Live isos is napcok
18:12:58 <wilcal> i think you can seperate the kernel support from the iso builds
18:12:59 <marja> ennael: nice :-)
18:13:13 <ennael> so both are quite busy but can give a hand
18:13:21 <grenoya> good :)
18:13:22 <Akien> To quote him "I have to step down from all my responsibilities, including board,
18:13:22 <Akien> council, sysadm, release manager, iso builder, kernel/glibc/gcc/<various
18:13:22 <Akien> packages> maintainer / ..."
18:13:33 <ennael> still we need more people and in a permanent way
18:13:48 <ennael> I will try to buy rtp with some beers but he is on vacation at thje moment
18:14:06 <ennael> about kernel work
18:14:21 <ennael> as some of you may know I work on Kernel Recipes conference in Paris
18:14:22 <Akien> tmb maintains a lot of drivers too, so we need people to step up for those: http://people.mageia.org/u/tmb.html
18:14:23 <[mbot> [ people.mageia.org: u/tmb ]
18:14:49 <ennael> it will be at the end of september and we have many people looking at it
18:14:59 <marja> ennael: :-)
18:15:10 <ennael> I was wondering if I can send a message about proposing a kernel job in Mageia
18:15:21 <ennael> even for non advanced users
18:15:31 <ennael> wdyt?
18:15:41 <grenoya> you mean a paid job ?
18:15:42 <Son_Goku> that sounds like a good idea
18:15:50 <Son_Goku> the kernel is a very special beast
18:15:52 <ennael> grenoya: no :)
18:16:00 <marja> ennael: I thought I understood what you said, until you said "even for non advanced users"
18:16:02 <ennael> indeed and it's hard to find people
18:16:06 <wilcal> note I think the kernel person also has to handle VirtualBox
18:16:18 <ennael> marja: what I want to say is something like
18:16:29 <ennael> "Mageia is a nice distro and one of the main difference
18:16:31 <wilcal> I've got the testing of both down to a science
18:16:37 <Akien> I think that's a good idea too. As I told ennael in private already, I think that we should really advertise Mageia to power users that might be looking for a Linux distro to contribute to with low entry barrier
18:16:53 <ennael> is we don't need a lot of training and exams before starting contribution
18:17:12 <marja> ennael: I agree with that (it's what made me contribute ;-) )
18:17:12 <Son_Goku> Akien, I completely agree
18:17:13 <ennael> comparing to debian for example
18:17:18 <Akien> Mageia is basically a mature distro, where it's easy to contribute, and you can have some freedom to do your own stuff without having to follow 5000 policies and reviews (though we do have some - too much for some users already :p)
18:17:25 <grenoya> ennael: you text is good imho
18:17:33 <Son_Goku> we're a lot more streamlined than say Ubuntu and Debian
18:17:57 <ennael> so if you are ok I will send a message tonight on social networks about it and on blog of Kernel Recipes
18:17:58 <Son_Goku> and the skills are broadly usable, too, as the top two enterprise distros use the same technology and broadly the same tooling as us
18:18:29 <marja> ennael: please do :-)
18:18:38 <ennael> ok :)
18:18:48 <wilcal> I also suggest these are career building opportunities especially for students
18:18:56 <ennael> the main release critical bugs of tmb were about live isos
18:19:05 <ennael> the only one about kernel is about Raid
18:19:30 <Son_Goku> wilcal, we have several successful folks who could be role models for this
18:19:37 <ennael> #11105
18:20:00 <ennael> somebody here spoke about napcok for live isos
18:20:13 <marja> https://bugs.mageia.org/show_bug.cgi?id=11105
18:20:15 <[mbot> [ Bug 11105 RAID ( ddf / isw ) broken for new install ]
18:20:15 <wilcal> Anyone remember Wilkenson back in Mandrake who went to Red Hat?
18:20:27 <wilcal> williamson i think
18:20:36 <marja> ennael: yeah, I know he built Polish ones (and he offered me to build Dutch ones)
18:21:09 <ennael> marja: could you ping him to ask if he can give a hand?
18:21:11 <Son_Goku> adamw?
18:21:16 <marja> ennael: will do
18:21:19 <ennael> thanks
18:21:31 <Son_Goku> Adam Williamson has done some amazing automation work in Fedora, he might be able to give us a hand
18:21:41 <ennael> #action ennael will post on Kernel Recipes about hiring kernel maintainers for Mageia
18:21:59 <ennael> #action marja will ping napcok about having some help on live isos build
18:22:04 <Akien> Before we post "job" offers and similar, there's a critical thing we haven't done:
18:22:12 <Akien> We need to communicate about this in our own community
18:22:21 <ennael> yes
18:22:22 <Akien> tmb only sent his "bomb" to council@ and board-public@
18:22:36 <Akien> So most contributors and users are not aware of our situation
18:22:51 <ennael> I guess we can send a mail right after on main ML
18:23:12 <ennael> simple one but explaining what is happening and what we are looking for
18:23:24 <ennael> we never know maybe we have people inside wanting to help
18:23:33 <Akien> Yeah
18:23:46 <ennael> are you all ok?
18:23:46 <Akien> shlomi has already helped with the kernel a bit while tmb was away last time
18:23:52 <ennael> great
18:23:53 <Akien> So he might want to step up
18:24:06 <Akien> Ideally if we could have several kernel maintainers, it would be great
18:24:07 <Luigi12_work> I updated a bunch of low-level packages tmb would have updated, but still need more experienced eyes on the binutils package (bug 18987)
18:24:26 <ennael> Luigi12_work: you can ask pterjan for help
18:24:36 <ennael> he may be able to help on that
18:24:36 <Luigi12_work> Akien: that's a good point, the stable release and Cauldron kernel maintainers could very well be different
18:24:36 <Akien> And with enough time, tmb might maybe be able to write down some of his "workflow" to update those things
18:24:47 <ennael> yep
18:24:53 <Akien> e.g. how he decides to pull in kernel patches and which, how to update drivers, etc.
18:25:05 <Akien> Even the rebuild process is not that straightforward I guess :)
18:25:08 <ennael> still we need guys speaking to each other please :)
18:25:25 <Akien> Of course :)
18:25:25 <ennael> having something like a kernel team
18:25:36 <Son_Goku> even if it's a couple of folks
18:25:44 <Son_Goku> having someone on point to talk to is a massive help
18:26:37 <Akien> Yes, I think we really need to have maintainer teams for such things
18:26:43 <Akien> We don't have many tmbs available
18:26:55 <Akien> But we have some willing contributors, less tech-savvy, but ready to learn together I think :)
18:27:57 <ennael> ok
18:28:08 <ennael> anything else about that topic?
18:28:18 <Son_Goku> what about sysadmin bits?
18:28:25 <Akien> Do we want to do a blog post, or is it too much?
18:28:32 <marja> Son_Goku: good question!
18:28:32 <Son_Goku> at least from my perspective, the sysadmin related tasks are the most annoying blockers
18:28:51 <Son_Goku> we don't typically have any responsive sysadmins around often
18:29:09 <marja> and what happened with the disks to be added in DC (I think no one replied to maat)
18:29:38 <ennael> Akien: maybe too much. Let's hope tmb will come back
18:30:12 <Akien> Alright. Let's not push him though.
18:30:26 <ennael> about sysadmins it's a good time to push maat :)
18:30:37 <wilcal> even if he does come back any efforts to help us now will relive pressure on tmb if and when he comes back
18:30:55 <ennael> indeed
18:32:23 <ennael> beers?
18:32:56 <ennael> even this one does not work :p
18:33:06 <Akien> :D
18:33:13 <Latte> already drunk :D
18:33:19 <marja> there was a mail from pterjan on 27-05-16 16:29 CEST about what needed to be done in Marseille, but I didn't refer maat to it, because I thought things might have changed
18:33:25 <grenoya> ennael: on sysadmin tasks, is there technically easy task but that takes time?
18:33:36 <Luigi12_work> maybe something with fruits and vegetables and antioxidants, to keep those of us that remain healthy, instead of beer?
18:33:37 <ennael> grenoya: no idea really :)
18:33:41 <grenoya> I mean to help sysadmin team
18:33:53 <ennael> we may mail sysadmins ML after also
18:34:00 <ennael> after we mail about tmb
18:34:09 <marja> grenoya: adding and removing people from groups .. that does sometimes take long
18:34:19 <Akien> Yeah, also to ask the whereabouts of coling
18:34:23 <Luigi12_work> removing and moving packages in various repos is an easy task
18:34:30 <Akien> He might be able to free a few hours a week to help us
18:34:41 <Luigi12_work> the reason that hasn't been opened up is currently the access you need to do that gives you way more access than you should have
18:35:09 <ennael> we may have a look on a web solution to manage ldap directory
18:35:13 <schultz> Morning all, sorry Im late
18:35:19 <grenoya> seeing the number of freeze push mail today, I thought I could help on something :)
18:35:19 <marja> grenoya: like this one https://bugs.mageia.org/show_bug.cgi?id=17792
18:35:21 <[mbot> [ Bug 17792 please promote lebedov to the alumni group (while removing him from the two packagers groups) ]
18:35:23 <ennael> so that lss experienced people can help on managing people and so
18:35:43 <Akien> Yes maybe another release manager is needed now that tmb is away?
18:35:43 <Latte> I would ike to get into i18n-commiters to help my team
18:35:44 <ennael> neoclus does know that tool
18:35:59 <Akien> I guess ennael will not always be able to cope with Luigi12_work's update frenzy :p
18:36:08 <marja> grenoya: and ghibo should be removed from the alumni
18:36:12 <Luigi12_work> LOL, after today I probably won't have time to do that again any time soon
18:36:16 <ennael> :)
18:36:20 <Luigi12_work> internet at my current job gets cut off tomorrow
18:36:29 <Luigi12_work> my next job will keep me plenty busy doing "real work"
18:36:29 <ennael> okok so it means we need to speak on sysadmins side also
18:37:14 <schultz> Akien: were you volenteering for release manager there?
18:37:30 <ennael> schultz: well done :)
18:37:35 <Luigi12_work> heads of the packaging team are logical candidates to pick up release manager slack
18:37:37 <grenoya> :))
18:37:45 <marja> :-)
18:37:49 <Akien> schultz: Not really as I'm more the kind of guy who asks for freeze pushes :p
18:37:59 <ennael> too late :)
18:38:06 <Akien> But yeah if it's fine with ennael I'm fine with doing that too
18:38:09 <schultz> Well, it seems you might have just been volunteered...sorry
18:38:16 <Akien> I promise I'll read the changelogs before pushing the button :p
18:38:23 <ennael> :)
18:38:24 <marja> Akien: thx :-)
18:38:30 <ennael> I'm trying to ping neoclust
18:38:30 <grenoya> great :)
18:38:34 <ennael> will add this in list
18:38:48 <ennael> ok anything else ?
18:39:03 <marja> not here
18:39:09 <Akien> We can move on I think
18:39:27 <schultz> Did I miss anything important from earlier?
18:39:51 <grenoya> schultz: blog posts to do :)
18:40:01 <schultz> On what?
18:40:04 <ennael> nothing really unless you want to be kernel maintainer :)
18:40:22 <ennael> ok
18:40:24 <schultz> Yeah sure, I hate to think how badly that would turn out :)
18:40:34 <ennael> #topic Mageia 6 release
18:40:43 <ennael> another interesting topic :)
18:40:53 <marja> :-)
18:41:03 <schultz> Other than the one on DNF I wasn't sure what we had coming, oh and the new release manager they make mageia...
18:41:30 <ennael> I will build new classical isos tonight
18:41:37 <wilcal> i have one Plasma, x86_64 running on real hardware that is very useful and updating cleanly
18:41:38 <ennael> including all work done on KDE especially
18:42:08 <marja> I had missed that the KDE stuff had moved from updates_testing to core
18:42:15 <ennael> for now nothing on live isos side we need to figure out how to manage this
18:42:32 <wilcal> I have four Vbox clients Gnome i586 & x86_64, Plasma i586 & x86_64 all running and updating fine
18:42:47 <schultz> I've seem to have a stable install too, at least its survived me making the plymouth theme which is a lot of rebooting, seems to get better with each successive reboot and new initrd too
18:43:31 <wilcal> I work these 5-installs every day
18:43:56 <marja> ah, it's just being pushed to core... nice :-)
18:44:04 <ennael> :)
18:44:10 <ennael> ok so new isos coming
18:44:20 <ennael> let's do for now without live
18:44:24 <marja> ok
18:44:28 <wilcal> for the weekend for sure?
18:44:30 <ennael> do we have QA people around ?
18:44:37 <wilcal> Me
18:45:15 <wilcal> I'll have those new isos shaken'n out by Monday morning
18:45:25 <marja> good :-)
18:45:36 <Akien> My cauldron is good too - the main question is still how well the installs perform.
18:45:56 <Akien> When were the last QA ISOs spinned?
18:45:57 <ennael> indeed
18:46:06 <wilcal> The no auto login bug is a major pain
18:46:11 <schultz> aside for tapping being disabled, it looked good to me a few days ago
18:46:53 <Akien> I think we need a fresh set of ISOs, and restart a big testing effort (maybe proposing on dev@ again that packagers get involved)
18:46:53 <ennael> 22th of july for the last one
18:47:11 <ennael> so there were a lot of updates in between
18:47:30 <Akien> I can imagine that the QA team is starting to be weary with the continuous testing (and lack of updates since 3 weeks)
18:47:33 <schultz> sounds sensible
18:47:39 <Akien> So some fresh testers + a new set should help a lot.
18:48:01 <Akien> Yeah since 22th of July plasma integration has improved a lot, neoclust did a lot of bug fixing
18:48:10 <ennael> yep
18:48:18 <ennael> a good way to close sme bugs
18:48:55 <ennael> so if you are ok we can close this topic and I will start isos. We have to try to go on and finalize RC
18:48:58 <wilcal> the plasma desktop is not perfect but is looking pretty good
18:49:15 <marja> ennael: fine with me
18:49:43 <ennael> unless there is something we need to know about coming RC
18:50:02 <wilcal> ennael: your going to generate the CI's right?
18:50:13 <marja> wilcal: yes, she is
18:50:23 <ennael> yep
18:52:11 <Akien> So I guess we put the lives on hold for now until we get someone to work on them?
18:52:21 <ennael> yep
18:52:33 <ennael> marja: let us know about napcok
18:52:40 <ennael> maybe the best option for now
18:54:32 <Akien> Also, we still need to better re-triage the existing release blockers, or those that should be blockers but aren't yet
18:54:42 <ennael> yep
18:54:51 <Akien> olav made a few good points on the ML, but that's mostly post-mortem stuff, I don't see us changing the workflow too much right now
18:55:41 <Akien> Basically, I see the devs as best suited to check the existing blockers and maybe downgrade if need be
18:56:02 <Akien> And the QA team should not hesitate to mark some bad bugs as release blockers when you find them/confirm them during testing
18:56:32 <Akien> It's better to have bugs upgraded that shouldn't be (and will then be downgraded), than to have critical bugs going unnoticed :)
18:56:53 <Akien> Since we are reaching RC, any showstopper should be a release blocker
18:57:25 <marja> ennael: I mailed him
18:57:32 <ennael> thanks
18:57:41 <ennael> any question, comment ?
18:58:12 <schultz> none from me
18:58:19 <wilcal> not from me
18:58:24 <marja> not here
18:59:13 * Latte has nothing more to say, too
18:59:41 <ennael> so it's  not good news for tmb and again we hope he will be better as soon as possible but Magiea is also our favorite project and we want it to succeed
18:59:54 <ennael> so we will find solution and release Mageia 6 soon :)
19:00:00 <Akien> Definitely :)
19:00:02 <grenoya> :)
19:00:05 <Luigi12_work> definitely in 2016
19:00:07 <marja> :-D
19:00:16 <Akien> Cheers to that, and to tmb :)
19:00:20 <marja> +1
19:00:24 <Luigi12_work> yeah, our favorite sysadmin
19:00:29 <schultz> Yep, sounds good on both counts
19:00:40 * Akien opens a cask of tomate-carrot-apple juice.
19:00:45 <ennael> :)
19:00:56 <Akien> s/tomate/tomato/
19:00:57 <ennael> so thanks for coming and let's go to work :)
19:01:15 <ennael> #endmeeting