20:08:20 <ennael> #startmeeting
20:08:20 <Inigo_Montoya> Meeting started Tue Oct 27 20:08:20 2015 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:08:20 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:08:24 <ennael> hi all
20:08:32 <MrsB> morning
20:08:38 <Akien> Hi everyone
20:08:38 <DavidWHodgins> HiYa
20:10:07 <ennael> ok do we have any specific topic that should be added for tonight's meeting ?
20:10:19 <ennael> except mageia 6, and LTS
20:10:35 <blino> (and ARM!)
20:10:37 <Akien> Status on Infra?
20:10:58 <ennael> tmb is not around
20:11:08 <ennael> still need some feedback
20:11:19 <wilcal> brb
20:11:29 <Akien> Otherwise I personally have some backlog on what I should have been doing, I need to start using post-its like stormi :)
20:11:36 <DavidWHodgins> Can we add https://wiki.mageia.org/en/Updates_policy#Version_Policy regarding the exception?
20:11:47 <ennael> ok
20:11:56 <ennael> let start with this one
20:12:07 <ennael> #topic updating exception policy
20:12:11 <ennael> DavidWHodgins: your turn then
20:13:12 <DavidWHodgins> Was the "exceptions for packages that did not make it into Mga-current" only for Mageia 1, or should new packages that don't impact existing packages still be allowed?
20:13:20 <ennael> (speaking about wolf)
20:13:25 <MrsB> thats left over from mga1 imho
20:14:00 <MrsB> i think with backports unavailable we could relax it maybe, but the wording would need to be specific
20:15:01 <MrsB> "provided they do not impact any other packages" doesn't really specify what can be included
20:15:55 <wilcal> ok back
20:16:31 <DavidWHodgins> There has to be an exception for new packages needed for a needed update.
20:17:00 <DavidWHodgins> Should we allow other new packages in the stable release, as updates? That's the decision we need to make.
20:17:05 <DavidWHodgins> I'm in favour of it.
20:17:18 <Akien> I think this exception can be removed, it sounds like the exact description of a backport.
20:17:29 <MrsB> also "and can pass full QA" suggests it's ok to leave it to QA (and blame it on QA when they break things)
20:18:04 <DavidWHodgins> My understanding is that a backport is a new version of a package already available, in stable
20:18:20 <MrsB> massive lag, sorry :(
20:19:37 <MrsB> in general packages like this should be backports though
20:19:43 <stormi> I don't know if I'm OT but I favour adding new package into updates provided they do not impact anything else
20:19:59 <stormi> and new versions in backports
20:20:11 <Akien> stormi: That's precisely the topic, we're discussing the last point in https://wiki.mageia.org/en/Updates_policy#Version_Policy
20:20:36 <Akien> So the question is: are new leaf packages backports, or only new versions of existing packages?
20:21:05 <MrsB> I've no objection to changing the current policy as long as the wording is precise in it's meaning
20:21:32 <DavidWHodgins> I think backports should be for new versions (likely with new features), that don't qualify as security or bugfix updates.
20:23:31 <wilcal> OpenShot will hopefully transition from Ver 1.x -> 2.x and I would hope that 2.x gets put into backports
20:24:02 <Akien> I'd also be in favour of allowing it (as a packager), but there should be a strict requirement that such packages do _not_ conflict or obsolete anything in the stable distro
20:24:21 <MrsB> or eg. provide updated libs
20:24:34 <DavidWHodgins> Yes. That's what I mean by does not impact existing packages.
20:24:34 <MrsB> it needs to be specific if we decide to change it
20:24:43 <ennael> so maybe add a process for this like a mail on dev before doing it
20:25:12 <MrsB> many QA team don't read dev ML
20:25:14 <DavidWHodgins> Yeah. We have to get the wording right, and have agreement on the restrictions.
20:25:32 <DavidWHodgins> We can cc it to both lists
20:26:08 <MrsB> right, but the wording should be more precise to specify exact restrictions such as those already mentioned
20:26:49 <DavidWHodgins> Yes
20:26:54 <ennael> can we work on it on ML and make some proposal
20:27:02 <DavidWHodgins> Ok with me
20:27:04 <MrsB> leaf packages might be enough, similar to backports wording, with a bit of explanation what those are
20:27:04 <ennael> to avoid spending too much time on this meeting
20:27:24 <stormi> yes
20:27:29 <MrsB> is anybody completely against allowing it?
20:28:35 <ennael> not for me if we are very clear on policy and the way it's managed
20:28:42 <DavidWHodgins> Doesn't look like it. Let's discuss it on the qa list, and when ready, cc the dev list.
20:28:48 <ennael> https://pad.riseup.net/p/policy_rewording
20:28:50 <[mbot> [ Riseup Pad ]
20:28:57 <ennael> let's work on it here
20:29:01 <DavidWHodgins> Ok
20:29:07 <MrsB> yes, council is more the right place
20:29:38 <ennael> let's do it before end of this week
20:29:42 <ennael> is that ok?
20:29:50 * MrsB looks at Dave
20:29:52 <Akien> yep
20:29:53 <DavidWHodgins> I'll start on it after the meeting.
20:29:57 <MrsB> \o/
20:29:58 <ennael> great
20:30:04 <ennael> anything else about this topic ?
20:30:15 <DavidWHodgins> Not here
20:30:17 <Akien> The policy should also feature that such requests will have the lowest priority as far as updates are concerned
20:30:38 <DavidWHodgins> Yes. I'll include that
20:30:38 <Akien> (unless adding such a package really "fixes a bug" and not just answers an enhancement request)
20:30:44 <stormi> I think it does already, but the rewording can include that
20:31:49 <ennael> ok next topic then :)
20:31:56 <ennael> #topic Mageia LTS
20:32:32 <ennael> is remmy around?
20:32:37 <SoulSurvivor> I just came in
20:32:41 <SoulSurvivor> <-- Remmy
20:33:26 <ennael> ok :)
20:33:34 <ennael> so
20:33:43 <ennael> there was a mail some months ago
20:33:59 <ennael> about having a LTS version of Mageia
20:36:01 <ennael> #chair Akien
20:36:01 <Inigo_Montoya> Current chairs: Akien ennael
20:36:11 * Akien hides.
20:36:41 <Akien> ennael has to run for an errand so I'll try to get the meeting moving in her place :)
20:37:07 <Akien> Not sure what is the status regarding LTS, could you give us an update SoulSurvivor (and/or remind us what was the last status)?
20:37:27 <SoulSurvivor> The topic of LTS has come up a few times in the past.
20:37:49 <SoulSurvivor> The consensus at first was that it would come once there was enough support and interest for it
20:37:57 <wilcal> What is the target audience for LTS?
20:38:10 <SoulSurvivor> but that it'd stretch and stress the volunteer community of Mageia too much to offer it now
20:38:21 <wilcal> Same as what Ubuntu does?
20:38:37 <SoulSurvivor> Some months ago oden asked if people were willing to make it possible on a commercial basis and asked for people to express interest
20:38:48 <SoulSurvivor> I'm not sure what the status of his request is.
20:39:14 <SoulSurvivor> Anyways, it had me wonder on how such an offering would fit in with the volunteer community that Mageia is
20:39:21 <SoulSurvivor> I asked the board the following questions:
20:39:34 <SoulSurvivor> - Is it allowed to offer such an offering and call it "Mageia LTS" or
20:39:34 <SoulSurvivor> similar?
20:39:34 <SoulSurvivor> - ...The same for "LTS for Mageia" or similar?
20:39:34 <SoulSurvivor> - ...When clearly indicating the offering is not related to the Mageia
20:39:34 <SoulSurvivor> project but based on/built on the official Mageia release(s), and that
20:39:35 <SoulSurvivor> Mageia is trademarked by Mageia.org?
20:39:37 <SoulSurvivor> - ...Offer this on a commercial basis?
20:39:39 <SoulSurvivor> - ...When possibly restricting access to the RPM's to paying subscribers?
20:39:41 <SoulSurvivor> - ...When providing updated versions of 'invasive changes' such as the
20:39:43 <SoulSurvivor> kernel, rpm, etc.?
20:39:45 <SoulSurvivor> - ...Possibly with enhanced / changed functionality?
20:39:47 <SoulSurvivor> - ...As long as this stays compatible with the official Mageia packages?
20:39:53 <SoulSurvivor> I'd like to get some clarity on these questions.
20:40:08 <SoulSurvivor> Note that I've taken a survey on this too, to get an idea of the interest in this
20:40:18 <SoulSurvivor> and for now I'm not pursuing this further
20:40:30 <SoulSurvivor> but I think the questions do deserve an answer
20:40:56 <SoulSurvivor> wilcal, the target audience would be anyone not wanting to upgrade to a new version every 18 months while still receiving security updates and bugfixes
20:41:05 <MrsB> this is a council meeting though, not board
20:41:51 <wilcal> Could double the testing in QA
20:41:53 <marja11> MrsB yes, but ennael brought it up here
20:42:04 <SoulSurvivor> I reminded ennael on this yesterday and she suggested to discuss it in here today.
20:42:28 <MrsB> Is it right to expect the board to give binding answers to hypothetical questions?
20:42:43 <SoulSurvivor> guiding answers?
20:42:51 <DavidWHodgins> wilcal: I would expect qa of the lts version to be done by the "LTS team", not the Mageia qa team.
20:42:52 <Akien> I guess it does make sense to discuss it in the council which is "making" Mageia, even if only the board should be the one taking a "decision" if a decision must be taken
20:43:54 <SoulSurvivor> There are actually two possible ways LTS support can be offered: On a non official Mageia base (see questions above) or by the Mageia project
20:44:02 <Akien> Regarding the first legal questions, I don't really have a clue personally. I don't even know how strongly we can enforce the Mageia trademark
20:44:13 <DavidWHodgins> I see it as a different project, based on Mageia. Anyone can do that. The main issue is the use of the Mageia name and trademarks.
20:44:34 <SoulSurvivor> The latter would be worthwhile to have too, but I asked my questions on the basis that Mageia does not provide LTS at this time.
20:44:46 <Akien> What's more interesting to me is more the second set of questions, i.e. would it be okay to provide stuff only to paying LTS customers, potentially crippling non-paying users for some of QA's work
20:45:05 <MrsB> binding - meaning firm answers on trademark usage, close commercial association, etc when the questions are only hypothetical at this stage
20:45:11 <Akien> Or would LTS only intervene _after_ the normal support period, and thus only give an added value without loss for non-paying users?
20:45:45 <DavidWHodgins> I think the after normal support period would be best
20:45:46 <stormi> Maybe we should discuss the questions one by one, while making sure that we are just discussing, not giving answers
20:45:51 <SoulSurvivor> MrsB, I do not (did not) want to invest time and money into developing something which gets shot down before it even has a chance to launch.
20:46:29 <MrsB> I can appreciate that remmy, as a board though we have to have our Mageia hats on first and foremost
20:46:44 <stormi> Is it allowed to offer a LTS, yes, of course.
20:46:52 <DavidWHodgins> Just don't poach our volunteers. :-)
20:46:53 <SoulSurvivor> My questions are not as to the merits of such a plan though, merely as to the rules one would have to play by. Whether it would be me, oden, or anyone else.
20:47:12 <stormi> Is it allowed to use Mageia's name, I'd say no, unless an authorization is given
20:47:31 <DavidWHodgins> The board has to decide that one.
20:47:39 <stormi> Yes, we are discussing, not deciding
20:47:49 <stormi> Ennael asked that we discuss it, let's discuss it
20:48:00 <MrsB> they also set precedents, so those decisions are important and far reaching in a community project especially with no details to work with
20:48:23 <stormi> My opinion is that the name Mageia should not be used, unless in a way that makes it clear that it's not from Mageia.Org
20:48:31 <SoulSurvivor> MrsB, what details are you missing in my questions?
20:48:39 <stormi> Such as "Unofficial Mageia LTS" (but not good for a commercial project)
20:49:02 <SoulSurvivor> stormi, what about "LTS for Mageia" instead of "Mageia LTS"?
20:49:27 <stormi> "LTS for Mageia by {someone}" maybe?
20:49:39 <Akien> I guess a "LTS for Mageia" product by "MyCompany" would be fine
20:49:40 <DavidWHodgins> I don't see a problem with LTS for Mageia
20:50:17 <stormi> yes, it would have its own website, a company name that's clearly different from Mageia
20:50:17 <Akien> "Mageia LTS" does sound like it's an official Mageia product on the other hand
20:50:34 <stormi> I'm not even sure that we could legally refuse "LTS for Mageia"
20:50:41 <DavidWHodgins> I'm not a lawyer though, so don't know how that impacts our trademark etc.
20:50:44 <MrsB> Anything of substance really remmy. Who, how, the plans. What's asked is basically, is it OK to call it Mageia LTS but I can't tell you what we plan to do.
20:51:40 <SoulSurvivor> So the consensus seems to be "Mageia LTS" would have to have board blessing (and probably the board want to keep that for Mageia.org to use in the future)
20:51:48 <stormi> SoulSurvivor: yes
20:51:58 <stormi> I think you would probably have to forget about it
20:51:58 <SoulSurvivor> but "LTS for Mageia (by x)" on its own domain, would probably be ok.
20:51:59 <MrsB> the board have made no statement
20:52:19 <stormi> MrsB: it's clear that the board has made no statement, can we discuss or can't we?
20:52:22 <Akien> MrsB: We are _discussing_ _hypothetically_, I think it's clear to everyone.
20:52:38 <stormi> SoulSurvivor: provided that the board agrees, it seems
20:52:39 <MrsB> ok, i'll sit it out :)
20:53:17 <SoulSurvivor> The trademark info on the Mageia website says the board is the gremium to decide on such things. I have brought such things to the board asking for a standpoint on it.
20:53:42 <Akien> Regarding the next question, offering it on a commercial basis, I think it would be completely fine as long as it doesn't influence the normal Mageia QA work.
20:53:46 <SoulSurvivor> And I really would like to know the answer. I think it will be useful, if not now or for me, then for the future.
20:54:22 <Akien> i.e. the LTS product should only be a layer _on top_ of the existing Mageia community work: support for packages not supported by the community during the life cycle, or for everything you want after the life cycle
20:54:27 <DavidWHodgins> As before, I would expect the LTS team to handle their own qa tasks
20:54:29 <stormi> SoulSurvivor: there's a kind of deadlock (thus the discussion here) because the board will need legal advice for a real answer, and they will probably not engage the expense unless someone comes with an actual project, and you need the board answer to maybe start the project :)
20:55:46 <SoulSurvivor> stormi, I was hoping for a position on it, without having a legally binding final decision.
20:56:16 <stormi> SoulSurvivor: That's where I join MrsB in saying it's hard to do that
20:57:00 <stormi> what if the position is given to you, you start the project, then legally the situation is different?
20:57:39 <Akien> Well I guess the board could discuss on its ML a non-binding opinion: "we think that such scenario would be fine". But that would only be the opinion on non-legally competent board members indeed. Then we can maybe ask JudgeFred for a non-binding legal advice :)
20:57:40 <DavidWHodgins> Overall, I'm in favour of it, provided it's clear it's long term support provided by a company separate from Mageia, and doesn't impact the workload of the existing Mageia teams.
20:57:43 <stormi> However your questions are important and I agree that the board should try to answer
20:57:46 <SoulSurvivor> Ok, clear. Can I then ask as to the desirability of such a thing being offered?
20:58:23 <stormi> SoulSurvivor: to whom, us as individuals, council, or (for those who are board members), the board?
20:58:33 <stormi> I think we can answer individually
20:58:41 <SoulSurvivor> Individuals would do for now :)
20:58:47 <DavidWHodgins> I think it's good, as one thing people do complain about is the need to upgrade so often.
20:59:23 <stormi> Desirable for me, although I would prefer an official Mageia.org LTS
20:59:57 <MrsB> as MrsB the regular person I'd love to see an LTS of some variety, see previous blog post
20:59:58 <DavidWHodgins> That would be better, but we don't have the manpower for it.
21:00:05 <stormi> And you would have to think of the upgrade to the next version (should be fine but better not break upgrade path and do actual tests)
21:00:31 <DavidWHodgins> The whole idea of LTS, is never having to do an upgrade
21:00:42 <SoulSurvivor> MrsB, am I right in getting the feeling you would feel it unfair if someone would make money of such a thing built on top of volunteer work?
21:00:48 <stormi> Well, you need to upgrade once, in the end
21:00:49 <SoulSurvivor> DavidWHodgins, well, at least less frequently.
21:00:52 <marja11> DavidWHodgins: lol
21:01:19 <DavidWHodgins> Just install, and then continuous updates
21:01:46 <SoulSurvivor> One of the reasons I was considering this is that I think it would make Mageia more interesting for server use.
21:02:50 <SoulSurvivor> The fact that some of our own servers are or were until recently on Mageia 1 seems indicative of a gap existing between what is currently offered and what is wanted by some.
21:03:57 <MrsB> Remmy, no not at all. I don't want to enter into official board type discussion here though. As regular MrsB - I think how this kind of thing works in other communities is that a company sponsors people to work on an LTS version within the community, rather than as a separate entity making use of the trademark.
21:05:12 <papoteur> I think that the usage of the trademark should be reserved to the community work.
21:05:15 <Akien> But within the community would mean a free LTS version I suppose? Then it becomes harder for Remmy to find clients that will actually find his and his employees' work.
21:05:28 <ennael> back, sorry
21:05:36 <SoulSurvivor> MrsB, I don't think we have a company with those kind of resources though. But one can hope :)
21:05:58 <SoulSurvivor> Akien, I guess on mageia.org it would be free indeed.
21:06:07 <papoteur> If the LTS is ironed outside the project, it should have another name. It's better for everyone.
21:06:13 <SoulSurvivor> Akien, but then that's the risk of doing business.
21:06:34 <SoulSurvivor> papoteur, would you object to LTS for Mageia by x ?
21:07:19 <papoteur> Yes. It's not good for you. You effort will not be recognized.
21:07:24 <Akien> I think personally that "for Mageia" is a fair use, it makes it clear that it's a product for another product named Mageia.
21:07:41 <Akien> It's like "Steam for Windows". It's not a Microsoft product, but it's made for a Microsoft product.
21:08:15 <MrsB> to call it Steam for Windows they would have to ain permission, or call it just Steam
21:08:19 <MrsB> gain*
21:08:48 <stormi> I think it's fair use indeed too
21:09:00 <papoteur> the reference to Mageia is mandatory, but you have take another trademark for a clear distinction of what is from Mageia and what is from you.
21:09:06 <MrsB> We also have to consider Magic OS who asked a similar question before
21:09:08 <stormi> look, lots of projects have a link to Mageia with our logo, for their packages
21:10:06 <Akien> papoteur: You make a good point. The name of the product _without the "for Mageia"_ should be an actual product name
21:10:06 <stormi> papoteur: What's wrong with "LTS for Mageia by Remco Inc" as a name?
21:10:18 <Akien> papoteur: I guess :)
21:10:19 <stormi> product name is LTS, vendor is Remco Inc
21:10:32 <Akien> Yeah but can you name a product LTS?
21:10:57 <DavidWHodgins> Product name "LTSforMageia"
21:11:09 <DavidWHodgins> or similar
21:11:19 <Akien> LTS™ for Mageia by Remco Inc.?
21:11:19 <Luigi12_work> oh a meeting!
21:11:29 <DavidWHodgins> :-)
21:11:31 <stormi> We clearly will need the board to clarify the use of "Mageia" in an external product
21:11:39 <Luigi12_work> just for those who don't know, Debian's LTS is separate from the support of their regular distro, and it's called Debian-LTS
21:11:40 <stormi> Saying what's allowed and what isn't
21:11:45 <papoteur> What happens if in the future Mageia.org irons its own LTS ?
21:11:47 <Luigi12_work> I guess it's still somewhat done within the Debian umbrella
21:12:11 <stormi> papoteur: it will be called Mageia LTS, be in the official repos, no problem
21:12:16 <MrsB> Deban also has Iceweasel
21:12:19 <MrsB> i
21:12:20 <Luigi12_work> also as to the first topic, I'm strongly against adding new packages into core/updates (unless they're needed for updating an existing package, of course, or reviving a package that was previously in Mageia)
21:12:40 <stormi> /o\
21:12:56 <Luigi12_work> as for what an LTS should be called, I really don't know :o)
21:13:36 <ennael> I thought it was interesting to have some feedbacks here from the council
21:13:42 <SoulSurvivor> Thanks for the input guys. I'd like a more definite answer at some point, but as for now it's not a pressing issue for me, I'm satisfied with the opinions given here.
21:13:49 <papoteur> LTS for Mageia by Remco seems acceptable for me.
21:14:05 <Luigi12_work> it's a bit of a mouthful
21:14:15 <SoulSurvivor> I'll just call it Super Linux
21:14:17 <SoulSurvivor> :P
21:14:20 <stormi> :)
21:14:22 <DavidWHodgins> lol
21:14:24 <MrsB> :D
21:14:35 <Luigi12_work> or Mandrake
21:14:36 * Luigi12_work runs
21:14:41 <SoulSurvivor> lol
21:14:49 <stormi> Well, "Long term support for Mageia" could be the subtext of another product name
21:14:58 <stormi> Super Linux - Long term support for Mageia
21:15:11 <stormi> seems totally fair use of the Mageia trademark
21:15:43 <Luigi12_work> whoever brought up MagicOS, you made a really good point though, we do need to be careful
21:15:49 <Luigi12_work> ,wiki commercial
21:15:51 <[mbot> https://wiki.mageia.org/en/Commercial_vendors
21:16:07 <Luigi12_work> we do have that though, I mean we can somewhat officially endorse commercial vendors that provide support for Mageia
21:16:28 <Luigi12_work> so as long as we can reach an agreement on that, we can allow a little bit more flexible use of the trademark without just letting anyone run with it
21:16:45 <Luigi12_work> (an agreement with the vendor, I mean)
21:17:17 <stormi> SoulSurvivor: I know you don't have your answers since only the board (or a lawyer who knows trademark rules) can answer
21:17:34 <stormi> But did it help someway ?
21:17:54 <ennael> we will go on that discussion on board ML :)
21:18:08 <Luigi12_work> fwiw, as long as the program I work on doesn't get eliminated (and it might), I'd be interested in mga5 LTS support for work
21:18:24 <Akien> On this topic though, I must say I have very little hope for building a successful business model on a paid Mageia LTS
21:18:38 <SoulSurvivor> stormi, yes, thank you. And thank you all :)
21:18:48 <Luigi12_work> I dunno, as long as we aren't trying to pay dozens of employees like Canonical, it should be doable
21:18:52 <Akien> We don't have stats so it's just a feeling, but I don't think we have enough users to spawn a big enough customer pool for such a LTS
21:19:10 <SoulSurvivor> Akien, but having the option might build a bigger community
21:19:13 <Luigi12_work> sounds like we only have like three people interested in working on it anyway, that should be enough to handle it too
21:19:13 <stormi> Well, Akien, sometimes you don't need many customers, just the right ones
21:19:30 <stormi> but selling is a full job
21:19:31 <SoulSurvivor> But I agree, it needs a lot of time investment for unknown but probably small pay off
21:19:35 <Akien> stormi: True.
21:19:51 <ennael> for example, we (hupstream) won't go on that way
21:19:58 <ennael> way too much time consuming
21:20:05 <ennael> and risky for us
21:20:10 <Luigi12_work> how many employees does hupstream have?  just curious
21:20:18 <SoulSurvivor> From the survey I took, I'd say there were about 15 or so people interested in paying for it
21:20:20 <Luigi12_work> might be none of my business :o)
21:20:26 <ennael> 3 :)
21:20:30 <Luigi12_work> ok, thanks
21:20:37 <SoulSurvivor> and the median amount was EUR/USD 7/mth
21:20:46 <ennael> we use Mageia on some projects but for now no need of LTS
21:21:25 <SoulSurvivor> I need to hit bed now, thanks again for the input.
21:21:36 <ennael> thanks SoulSurvivor
21:21:49 <Luigi12_work> speaking of this, ennael did you get a chance to speak to oden yesterday?
21:22:16 <ennael> nope I was back from vacation with 6h different to recover :)
21:22:22 <ennael> so head in the clouds :p
21:22:31 <ennael> (not the cloud )
21:22:33 <Luigi12_work> oh, he desperately needed to speak with you
21:22:39 <ennael> oh
21:22:45 <ennael> will try to ping him thanks
21:22:49 <ennael> ok next topic?
21:23:16 <Akien> yep
21:23:26 <ennael> #topic Mageia 6
21:23:35 <ennael> ok I mailed a proposal for the planning
21:23:43 <ennael> and nearly no answer for now
21:23:52 <ennael> so maybe we can speak about it tonight
21:24:24 * Luigi12_work needs to leave in 15 minutes, just fyi
21:24:50 <Luigi12_work> I do need to look at the proposed schedule though, I just kind of glossed over it
21:25:00 <wilcal> I've something to share that may be of interest to Luigi
21:25:06 <Luigi12_work> ok
21:25:13 <Akien> Ah right I forgot to answer, sorry
21:25:30 <Luigi12_work> maybe send a ping reply to that e-mail so we can look at it again
21:25:54 <ennael> https://ml.mageia.org/l/arc/council/2015-10/msg00018.html
21:25:55 <[mbot> [ council - Council discussions - arc_protect ]
21:26:01 <ennael> fyi
21:26:08 <Akien> Development snapshot 1 : 2015/11/09
21:26:08 <Akien> Development snaphot 2 :  2015/12/15
21:26:08 <Akien> Stabilisation snaphot 1 : 2016/01/15
21:26:08 <Akien> Stabilisation snaphot 2 : 2016/02/11
21:26:08 <Akien> RC : 2016/03/21
21:26:09 <Akien> Final release: 2016/04/15
21:26:24 <DavidWHodgins> That would put alpha 1 in just under 3 weeks
21:26:31 <MrsB> dev snapshot 1 - november 9th, seems a little soon. We need an extra step of Agree Features & begin inclusion at the start
21:26:43 <Luigi12_work> I kind of like removing the alpha/beta names
21:26:49 <MrsB> me too
21:26:53 <DavidWHodgins> Ok
21:27:15 <Luigi12_work> instead of whatever snapshot, another alternative would be "milestone."  That's a term that Microsoft (don't laugh) and Eclipse use for their development snapshots.
21:28:01 <Luigi12_work> but yeah that first alpha always seems to come too soon
21:28:09 <Luigi12_work> from what I hear, Cauldron is kind of a broken mess right now
21:28:20 <Luigi12_work> probably needs to be cleaned up a bit before making a snapshot image
21:28:26 <ennael> alpha is not supposed to be stable
21:28:28 <Luigi12_work> I haven't started any packaging for m6 yet :o(
21:28:29 <MrsB> certainly this time, we're slow sorting the feature list
21:28:30 <ennael> just boot
21:28:31 <wilcal> Ya I can't get it to go through a full install with the boot.iso in Vbox
21:28:48 <Luigi12_work> yeah but nobody can get it to boot with a DM and desktop working as expected
21:29:03 <Luigi12_work> lots of broken deps too apparently
21:29:12 <Akien> ennael: Judging by the current cauldron, the first planned snapshot might actually be quite a headache indeed
21:29:20 <wilcal> lots of script errors reported
21:29:27 <MrsB> if it's just a base to install from then it needs little QA attention
21:29:29 <ennael> ok let's delay it for 2 or 3 months then
21:29:34 <Luigi12_work> lol
21:29:43 <Akien> I guess the focus right now should be on deciding on the final list of features, and asking devs to get stuck with cauldron and iron things out
21:29:43 <Luigi12_work> I think just pushing back the first snapshot 2 weeks might help a lot
21:29:47 <Luigi12_work> the rest could stay as-is
21:30:11 <ennael> dev1 and 2 will be too near
21:30:14 <wilcal> I give it a try once a week
21:30:25 <Luigi12_work> ok dev2 can go back one week
21:30:26 <ennael> time too short to test and rebuild
21:30:47 <Luigi12_work> so then it'd be like 3 weeks between each approximately
21:30:58 <ennael> hum before christmas ? :)
21:31:11 <Luigi12_work> I don't think christmas hurts that much
21:31:14 <ennael> if we have some delay then it's dead
21:31:31 <Luigi12_work> yeah we don't need another m5, I'm just not ready yet, still too busy at work
21:31:38 <Akien> Hm, personally I think nothing happens between Dec 22nd and Jan 5th or so :)
21:31:39 <Luigi12_work> should be good to go soonish
21:31:56 <Luigi12_work> Akien: actually a lot happens then
21:32:12 <Luigi12_work> people aren't so crazy with work and can do more Mageia stuff
21:32:16 <MrsB> lots of updates appear over xmas
21:32:31 <Akien> That's true.
21:33:26 <Akien> So I think we can aim for a first snapshot e.g. on Nov 21st
21:33:30 <Akien> That's my birthday :p
21:33:37 <Luigi12_work> ooh birthday present for Akien
21:33:41 <MrsB> if dev1 is just a base to install from then we can push ahead with it but I really feel we should have a feature list before we do our fist release
21:33:47 <Akien> It's still early enough that we don't have time to slack off anymore :p
21:33:53 <Akien> s/we/I/
21:34:07 <ennael> Development snapshot 1 : 2015/11/24
21:34:07 <ennael> Development snaphot 2 :  2016/01/07
21:34:08 <ennael> Stabilisation snaphot 1 : 2016/02/08
21:34:08 <ennael> Stabilisation snaphot 2 : 2016/03/08
21:34:09 <Luigi12_work> ouch, I need to slack off just a wee little bit more (so I can work my tail off on some other stuff of course)
21:34:10 <ennael> RC : 2016/03/29
21:34:13 <ennael> Final release: 2016/04/19
21:34:15 <ennael> another proposal
21:34:33 <Luigi12_work> works for me
21:34:37 <DavidWHodgins> That sounds better to me
21:34:40 <Akien> Looks good.
21:35:01 <ennael> then christmas time is not in dev time
21:35:13 <MrsB> better yes
21:35:29 <Luigi12_work> nice
21:36:09 <ennael> Akien: but then we need a packager meeting next week
21:36:27 <Akien> ennael: Yes.
21:36:35 <Luigi12_work> works for me as long as it's at 3pm Eastern and not 4pm
21:36:46 <Akien> ennael: I'll buy post-its and get started on reviewing feature proposals already.
21:36:53 <ennael> :)
21:36:55 <Luigi12_work> I guess it would be since we'll be on the other side of the time change by then
21:37:14 <Akien> So we settle on 19 UTC for meetings I guess?
21:37:28 <Luigi12_work> sounds right
21:37:35 <wilcal> 19utc is a little better for me
21:37:41 <Akien> i.e. 20h for ennael ;)
21:37:50 <ennael> too early for me sorry
21:38:08 <ennael> but you can start without me
21:38:44 <Akien> Any time is fine for me.
21:38:50 <wilcal> have we settled on Tues or are we going back to Monday
21:38:53 <Luigi12_work> ok, I gotta go.  (yay ARM!)  enjoy the rest of the meeting
21:39:17 <DavidWHodgins> wilcal: Tues is for council meetings now. Not sure about packagers meeting
21:39:32 <wilcal> i'll put my message on the QA meeting to Luigi
21:40:11 <Akien> #info New dev schedule agreed upon by the attendants that gives more time for the first dev snapshot, will be confirmed on the ML.
21:40:44 <Akien> #action Akien and ennael will put some coal in the dev engine to settle on the feature proposals.
21:40:55 <Akien> s/coal/biomass/
21:40:56 <Akien> Sorry
21:41:02 <ennael> :)
21:41:29 <Akien> (or diesel, hm :p)
21:41:48 <MrsB> yes, just fake the readings
21:42:11 <Akien> So as I info'd, I guess we more or less agree but will post about it on the council ML for confirmation
21:42:21 <Akien> Next topic?
21:42:36 <ennael> no more topic on my side
21:42:39 <ennael> someone ?
21:42:50 <wilcal> i got this one thing to share
21:43:04 <ennael> a topic name?
21:43:19 <wilcal> Amazon Web Services and Mageia status
21:43:23 <ennael> ah
21:43:30 <ennael> #topic Amazon Web Services and Mageia status
21:43:40 <wilcal> Amazon Web Services ( AWS ) and Mageia 5. AMI = Amazon Machine Instance
21:43:42 <wilcal> AWS is the leading Cloud Service, dwarfing all the other players.
21:43:43 <wilcal> Glen Ogilvie has built two Mageia 5 AMI's, which are available for test at present.
21:43:45 <wilcal> They are: ami-3b0f4501 and ami-030f4539, both in region ap-southeast-2
21:43:46 <wilcal> ami-3b0f4501 uses the script he wrote for Mageia-4 to install the AWS key and configure the AMI.
21:43:48 <wilcal> He know this approach works, and provides a root login with your AWS key once the instance boots.
21:43:49 <wilcal> ami-030f4539 uses cloud-init, which provides a login as the mageia user, with sudo to root.
21:43:51 <wilcal> This instance needs a bit of testing before he can be sure that cloud-init works properly.
21:43:52 <wilcal> Both public are, so your all welcome to launch either or both of these to have a play.
21:43:54 <wilcal> All this will require more work when he has time, including updating the wiki.
21:43:55 <wilcal> But let me/him know what you think.
21:43:57 <wilcal> Glen Ogilvie: nelg@linuxsolutions.co.nz  nelg@mageia.org
21:43:58 <wilcal> enjoy
21:45:17 <wilcal> I'm no expert at this but I was able to launch the AMI
21:45:18 <MrsB> is there some documentation somewhere how to do so?
21:45:28 <wilcal> We have a wiki
21:46:31 <wilcal> https://wiki.mageia.org/en/Amazon_EC2_Mageia
21:46:49 <wilcal> that's what Glen is going to update
21:46:59 <ennael> great thing
21:47:11 <wilcal> Ya kinda can turn everything upside down
21:47:29 <wilcal> Back to the dumb terminal days
21:47:52 <MrsB> good wiki :)
21:47:59 <wilcal> anyway that's all i got
21:48:54 <ennael> thanks wilcal
21:49:11 <ennael> #topic ARM port
21:49:16 <ennael> I forgot that one :)
21:49:22 <ennael> so work is on the way
21:49:29 <MrsB> oh yes, good to see this
21:49:36 <ennael> pterhan and blino are working on it a lot
21:49:39 <DavidWHodgins> Oliver want's to rent a couple of Scaleway instances
21:49:50 <ennael> I will buy the server right now
21:50:40 <ennael> so we should have something to test quite quickly for what I know
21:50:46 <ennael> blino: any ETA on this?
21:50:58 <blino> usually, Scaleway wants customers to buy by credit card, do you have one for Mageia.Org ?
21:51:32 <ennael> nope I will do for now with mine and get refund
21:51:32 <blino> they also seem to accept transfers, or checks, but that may be slower
21:52:06 <ennael> about port himself any status for now?
21:52:09 <blino> no real ETA, but I think we are a few weeks away only to publish something that's usable by more users
21:52:31 <blino> I started building on top of rtp's mga1 port (since his other work on mga3 was not available when I started)
21:52:33 <DavidWHodgins> Anyone remember what the cost is to rent scaleway instances?
21:52:39 <blino> 3€/month
21:52:58 <blino> I got the basesystem + its buildrequires built for mga6
21:53:09 <DavidWHodgins> I see no reason not to approve renting a couple of instances then.
21:53:14 <blino> and pterjan is in the process of rebuilding the whole cauldron
21:53:23 <Akien> I think one beer/month is worth the expense :)
21:53:25 <ennael> nice
21:53:28 <blino> status is about 55% of clean rebuilds, which is pretty good
21:53:59 <blino> I am working on getting enough of qt4/qt5 ready to be able to do further rebuilds of qt/kde friends
21:54:23 <MrsB> "We accept Visa, MasterCard, CB and American Express."
21:54:24 <blino> so far, it has been tested in headless mode, no graphical interface
21:55:03 <ennael> ok
21:55:10 <blino> but when we publish the port, I guess more devs/users will be interested in ma
21:55:15 <blino> making it work
21:55:18 <ennael> do you think we will have something for tests for first milestone ?
21:55:26 <blino> (sorry, a plane just crossed my keyboard)
21:55:29 <ennael> 24/11
21:55:32 <ennael> :)
21:55:58 <blino> I think a clean basesystem will be available, maybe a few graphical packages, but likely untested
21:56:15 <ennael> ok but we could have a first announcement
21:56:16 <blino> basically, it should be enough to build headless servers, without a Mageia kernel though
21:56:29 <blino> MrsB: there are more payment options here: https://fr-1.storage.online.net/scaleway/terms/CGS-SCALEWAY-FR.pdf
21:56:43 <DavidWHodgins> Is arm 32 bit or 64 bit"
21:56:51 <DavidWHodgins> s "/?
21:57:07 <blino> armv5 for now (32 bits), a bit old-fashioned but compatible with many boards
21:57:14 <blino> next step will be an armv7 port
21:57:29 <blino> aarch64 is probably not urgent, only a few boards are available
21:58:06 <blino> (pterjan just built akonadi, the KDE fun can begin!)
21:58:12 <ennael> :)
21:58:27 <ennael> ok thanks for the news
21:58:34 <MrsB> good to see some progress on arm blino, well done to both
21:58:35 <ennael> any other topic?
21:59:02 <blino> MrsB: ennael : thanks!
21:59:08 <DavidWHodgins> So is the renting of two scaleway servers approved?
21:59:16 <ennael> 1 server for now
21:59:25 <MrsB> i think we discussed it before didn't we
21:59:26 <ennael> and I guess it was already discussed on council :)
21:59:33 <ennael> ML I mean
21:59:50 <wilcal> i'm done
22:00:15 <ennael> last chance to speak?
22:00:16 <MrsB> wilcal: does aws stuff need funding?
22:00:17 <ennael> 5
22:00:19 <ennael> 4
22:00:21 <ennael> 3
22:00:23 <DavidWHodgins> The only thing I see on the council ml is Luigi12_work forwarding Olivers request for two instances
22:00:23 <ennael> 2
22:00:25 <stormi> 1
22:00:28 <stormi> :)
22:00:31 <ennael> done!
22:00:38 <ennael> thanks all for attending
22:00:44 <ennael> #endmeeting