20:11:56 <ennael> #startmeeting
20:11:56 <Inigo_Montoya> Meeting started Mon Jan 19 20:11:56 2015 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:11:56 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:12:01 <ennael> ok let start then
20:12:42 <ennael> #topic quick financial review
20:12:51 <ennael> just a quick word about financial review
20:13:03 <ennael> we have about 13 500€ on bank account
20:13:14 <ennael> and we have paid for all the goodies for FOSDEM
20:13:17 <MrsB> that's pretty good
20:13:20 <ennael> yep
20:13:33 <ennael> we are still expected 650$ from Google
20:13:39 <MrsB> we could afford more goodies really
20:13:40 <ennael> thanks to pterjan
20:13:43 <ennael> yep
20:13:59 <ennael> we missed the USB keys
20:14:00 <DavidWHodgins> We should probably get anonther server. :-)
20:14:31 <ennael> :)
20:14:34 <DavidWHodgins> Let the sysadmins have some fun.
20:14:37 <MrsB> possibly so, i don't think we invest enough in goodies though generallyt
20:15:18 <ennael> yep but still it needs to be done in time
20:15:26 <ennael> and we were short again in time
20:15:29 <DavidWHodgins> MrsB: I don't think "goodies" should be a priority.
20:15:40 <ennael> waiting for stickers and TS for FOSDEM
20:15:58 <MrsB> goodies feed the community
20:16:48 <DavidWHodgins> Given that we are spread across the planet, they only help those in Europe.
20:17:12 <ennael> well we are opened to bring some to other countries
20:17:24 <ennael> providing there is a project and we know it :)
20:18:17 <MrsB> we could do with a store really for sales
20:18:33 <DavidWHodgins> Shipping across the Atlantic or Pacfic would likely cost more than the production costs.
20:18:51 <ennael> MrsB: sure there must be some in the US
20:18:57 <MrsB> we could hold stock in strategic places
20:19:07 <MrsB> all needs volunteers though
20:19:47 <DavidWHodgins> MrsB: Setting up an online sales stor is very complicated, due to tax rules in various juristictians.
20:20:04 <ennael> we should not manage it ourself
20:20:11 <ennael> but rather ask existing shops
20:20:15 <DavidWHodgins> s /stor/store/
20:20:29 * ennael remembers Mandriva store
20:20:33 <ennael> that was a nightmare
20:20:44 <MrsB> was that self fulfilled?
20:21:17 <ennael> nope they asked for a professional to manage all the items and the shipping
20:21:40 <DavidWHodgins> ennael: Yes, that could work, but whoever oversees it will need to have an accountant's background, (or hire one), to be safe.
20:21:44 <MrsB> we ought to look and see how other project manage their goodies
20:21:58 <ennael> we should maybe have a look on existing solutions and check what would be interesting for Mageia
20:22:05 <ennael> MrsB: we can ask people in FOSDEM
20:23:08 <MrsB> it's worth investigating further for sure
20:23:32 <ennael> ok this is for to do list :)
20:23:34 <MrsB> we can also check with sysadmins if they need another server
20:23:56 <ennael> #action check if there are some other needs in teams, especially for sysadmins
20:24:09 <ennael> #action review existing solutions to get a store for Mageia
20:25:26 <ennael> anything else on this topic
20:25:27 <ennael> ?
20:25:53 <DavidWHodgins> Not here.
20:25:57 <wilcal> not from me I'm wait'n for the store
20:26:09 <MrsB> looks like it's going well and google stuff is working well too, thanks to pterjan for that
20:26:16 <ennael> yep :)
20:26:32 <ennael> ok let's move
20:26:41 <ennael> #topic i18n/docteam merge
20:26:47 <ennael> any news on that topic ?
20:27:57 <DavidWHodgins> There have been some discussions in the mailing lists. I think they are ok with it, as long as the mailing lists don't get merged too.
20:28:37 <ennael> so no need to merge these teams :)
20:28:56 <MrsB> marja is coming
20:28:59 <marja11> hi all
20:29:02 <MrsB> morning
20:29:06 <DavidWHodgins> Merging the teams is ok. It's just the mailing lists.
20:29:07 <ennael> marja11: about merge, any news ?
20:29:29 <ennael> DavidWHodgins: imho merging teams without ML will have no effects
20:29:40 <marja11> well, I wrote my ideas to council@group.mageia.org
20:30:09 <lebarhon> nobody really knows if it is a good idea or not!
20:30:21 <ennael> ok so no news really
20:30:29 <ennael> so let's move :)
20:30:32 <DavidWHodgins> The i18n-discuss mailing list is much higher volume, that doc team members likely won't want to see.
20:30:52 <marja11> indeed
20:31:00 <MrsB> not much point to merging though if teams don't actually merge
20:31:01 <ennael> #topic Mgaeia 5 beta 3
20:31:21 <ennael> any feedbacks already from beta 2 release ?
20:31:28 <wilcal> wilcal takes a deep breath
20:31:37 <MrsB> some on the blog saying it's pretty stable
20:31:47 <wilcal> Deep breath. I am going to make a very controversial suggestion.
20:32:02 <wilcal> ready
20:32:22 <wilcal> I suggest that we drop the requirement for EFI in M5 and move that to M6.
20:32:32 <ennael> not possible
20:32:45 <MrsB> some upgrades have been tested and we're seeing script failed for a package which has been fixed now, but the packages shown with the failing script is not actually the failing package. Makes it difficult to debug. TV aware.
20:32:47 <DavidWHodgins> That should be up to tmb.
20:32:51 <wilcal> I see another 3-months delay to release of M5 then
20:33:32 <wilcal> I just wanna get this discussion going
20:33:37 <MrsB> I saw your email wilcal, forgot to reply sorry
20:33:51 <wilcal> No problem
20:34:10 <wilcal> i just don't think our EFI technology is mature enough for prime time
20:34:37 <MrsB> I think EFI is really important though, we lose potential contributors without it and people are kind of expecting it now
20:34:43 <DavidWHodgins> wilcal: If that's what it takes, that's what we have to do. M5 should not be released before it's ready. Better to be late than relase bad systems.
20:34:49 <wilcal> Important is beside the point
20:35:24 <wilcal> IMO Ya it's gonna be really late
20:35:24 <ennael> not providing EFI support will just make Mageia loose a lot of users and contributers
20:35:44 <ennael> tmb told he was on it and he is on it
20:35:53 <MrsB> we're not aiming for secure boot support, just efi
20:35:57 <ennael> yep
20:35:58 <wilcal> Even if it means a June 15 release data?
20:36:12 <ennael> wilcal: come on did he say that?
20:36:23 <wilcal> No but I think it may come to that
20:36:37 <ennael> so you can help him if you know it :)
20:36:38 <DavidWHodgins> Agreed. Restricted boot (aka secure boot) should never be supported.
20:36:56 <ennael> he has averything in hands but just miss time in december
20:37:09 <wilcal> So Mageia will never never tweek the MoBo firmware
20:37:17 <wilcal> under all conditions
20:37:30 <DavidWHodgins> wilcal: What's MoBo?
20:37:32 <MrsB> we've QA team members not testing ISOs yet without it
20:37:43 <wilcal> Motherboard
20:38:27 <DavidWHodgins> I would never install a distro that modifed the motherboard firmware.
20:38:41 <sebsebseb> hi
20:38:45 <wilcal> As I understand it that's what Secure Boot can do
20:38:45 <MrsB> secure boot (signed kernels etc) is a different animal from EFI
20:38:55 <MrsB> sebsebseb
20:38:57 <sebsebseb> MrsB:
20:39:39 <wilcal> I think one of my platforms here supports EFI
20:40:04 <MrsB> lewis is leading the EFI testing for us
20:40:11 <wilcal> One thing I want to be assured of is my testing of EFI won't tweek that Motherboard Firmware
20:40:22 <wilcal> Lewis is doing a super job at that
20:40:28 <MrsB> I've nothing EFI at all
20:40:30 <DavidWHodgins> I destroyed a system by experimenting with burning new bios images. That computer went to the landfill.
20:40:33 <MrsB> yes he's done well
20:41:17 <wilcal> So I think most of our QA team cannot test EFI
20:41:26 <MrsB> ennael: I think we need to start the bugfix push on dev ML now
20:41:47 <MrsB> maybe progress emails every few days?
20:41:48 <ennael> MrsB: I've started directly for tv bugs
20:41:50 <DavidWHodgins> wilcal: Correct. Most of us are using pre EFI systems.
20:41:56 <ennael> to get some help on those
20:42:22 <marja11> wilcal: there are several who test EFI, when they find time, me too
20:42:34 <ennael> I will send a mail as a synthesis after this meeting and ask some bugs and then tomorrow some others...
20:42:42 <wilcal> So I would expect that remaining requirment in M5 but with the risk of really delaying the M5 release
20:42:57 <wilcal> a lot
20:43:10 <Akien> Hi, sorry for being late
20:43:20 <MrsB> we really need to sort out a proper dev team also, we started to before and never followed up. With a leader to help schedule work, share knowledge, gain contributors etc
20:43:42 <ennael> thanks...
20:43:45 <ennael> ok...
20:44:18 <wilcal> IMO this is the right place to discuss this not make a decision today or even next meeting(s)
20:44:50 <ennael> I'm sorry I have many things to do and will not be able to stay here 2h tonight
20:44:58 <wilcal> EFI may become the only gatekeeper for M5
20:45:02 <ennael> so if somebody wants to lead it I'm ok
20:45:47 <MrsB> We can discuss it on ML or board
20:46:25 <wilcal> We'll take a poll on Thursdays QA meeting to see where we're at on testing EFI
20:47:02 <MrsB> vladimir made a nice table on qa-discuss, but beta3 is added to accomodate it really
20:47:24 <DavidWHodgins> In my opinion, if EFI is not working we should delay the release, until it is working.
20:47:44 <sebsebseb> DavidWHodgins: of Beta 3?
20:47:54 * marja11 doesn't have a vote here, but agrees with delaying if needed
20:47:55 <DavidWHodgins> sebsebseb: Yes
20:48:20 <wilcal> Delay rather then removing the requirement for M5
20:48:40 <wilcal> We're 4-weeks from Release Candidate for M5
20:48:49 <DavidWHodgins> Better to delay then to relase iso images that don't work.
20:48:51 <sebsebseb> DavidWHodgins: if things get  delayed like that, I guess there won't be a Magiea 5 untill July or something :d,  but more seriosuly I haven't really been following the EFI /  secure boot stuff,  however  yes  ideally Mageia 5 should work nicely on EFI / secure boot systems
20:48:52 <Akien> I kind of agree with DavidWHodgins, it would be tough for the community if our 2015 release does not support EFI (basically every user who bought a computer since 2013 would have EFI).
20:48:54 <wilcal> Is it all gonna be fixed and testing by then?
20:49:21 <sebsebseb> hopefully get some more non QA testers of that stuff to hmm
20:49:22 <Akien> Then of course we do what we can, and if we can't make it, maybe it's better to release mageia 5 without it than to delay it for many months.
20:49:47 <MrsB> EFI alone isn't as complex as secure boot. I think you're maybe confusing the two wilcal
20:50:03 <Akien> It's an issue that it all relies on tmb's shoulders... but I'm not sure how we can help him.
20:50:13 <DavidWHodgins> Most qa team members have systems from before efi became available, so it's hard to test.
20:50:18 <wilcal> Agreed and like David I've stayed away from EFI. Just now getting up to speed
20:50:55 <wilcal> I'm likely to purchase two new systems here in the next 90days
20:50:56 <DavidWHodgins> Restricted boot (aka secure boot) should never be supported.
20:50:59 <wilcal> both identical
20:51:33 <wilcal> anyway good discussion on this thanks all
20:51:59 <wilcal> It's gotta work in Vbox agreed all??
20:52:15 <wilcal> That way everyone can kinda test it
20:52:20 <DavidWHodgins> I've never yet had a system with ristricted boot, but my understanding is that it can be disabled.
20:52:24 <Akien> wilcal: Can one emulate EFI in vbox?
20:52:30 <Akien> On a non-EFI system I mean?
20:52:35 <DavidWHodgins> Akien: No
20:52:46 <sebsebseb> yeah going to need real hardware for certain things
20:53:09 <wilcal> You got an EFI system sebsebseb?
20:53:27 <sebsebseb> wilcal: no don't think so, al the coputers here are over two years old
20:53:43 <wilcal> I've run it up in Vbox and immediately became confused
20:54:03 <Akien> But based on the feedback from beta2, I think the EFI support still needs more work before tests on all types of hardware would be needed no?
20:54:34 <sebsebseb> (well ok  not that particular Rassbery PI :d, but I meant desktops)
20:54:36 <marja11> Akien: yes
20:54:42 <Akien> I mean, if some blocking bugs were already identified, is it still useful to ask for a wide testing of EFI support by end users? Or will they just get frustrated that it doesn't work?
20:55:09 <Akien> We kind of asked for wide testing of EFI support in the blog post, but I think this was a bit early
20:55:19 <marja11> Akien: they'll just get frustrated, I think, but it is maybe better to ask tmb what he thinks
20:55:22 <sebsebseb> and net book, what's the next topic FOSDEM?
20:55:24 <wilcal> Not a problem with me to release M5 with a partially working EFI
20:55:49 <wilcal> enough on this it's a difficult subject
20:55:54 <Akien> wilcal: If the procedure is simple enough and well documented, it could do yes.
20:56:16 <DavidWHodgins> wilcal: Agreed. It's a beta, not an RC release.
20:56:19 <Akien> Agreed, ennael said she wouldn't be around 2h, so let's move on.
20:57:30 <sebsebseb> looks like ennael went away already
20:57:34 <ennael> well you don't me to speak together :)
20:57:37 <Akien> I guess next topic is lebarhon's "Who gotz power?" :)
20:57:39 <wilcal> I agree Akien but I think we're no where near getting that into the RC
20:58:04 <ennael> wilcal: can you please wait a bit before lighting fire :)
20:58:05 <wilcal> "Who gotz power?" kool
20:58:44 <DavidWHodgins> Yes. Who has wiki/twitter/facebook (etc.) access.
20:58:45 <ennael> (my english is getting worse on late time...)
20:59:27 <ennael> Akien: no answer for that point as it's about sysadmins and we do not have any of them tonight
20:59:43 <DavidWHodgins> That should be on the wiki, so people know who to contact to add comments.
20:59:44 <ennael> the only one thing remaining obscure is blogs
21:00:00 <MrsB> is there a page created for it lebarhon?
21:00:03 <Akien> Maybe we can already list what we need to document, and #action someone to make a wiki page with it
21:00:14 <ennael> I guess tmb has all access as an admin but it should be nice to have somebody else
21:00:17 <lebarhon> MrsB: not yet
21:00:42 <MrsB> Maybe create a page then and we can ask people-who-know to add details there
21:00:58 <Akien> For social media (Facebook, Google +, Twitter), both ennael and I have credentials. (maybe some other non active contributors like rda and trish)
21:01:09 <Akien> MrsB: Yes good idea
21:01:52 <lebarhon> I can start a page if needed
21:02:31 <MrsB> yes i think so, it'll be easier for people to add details to a page if it already exists
21:02:47 <DavidWHodgins> Anything else, or should we call the meeting to an end.
21:02:48 <marja11> lebarhon: about MageiaWelcome, any full packager or packager-committer can push changes to git.... the only thing is that it feels impolite to do that without permission of the owner
21:03:12 <marja11> s/owner/maintainer/
21:03:44 <lebarhon> marja11: OK but I can't join napcop
21:04:12 <MrsB> mail council ML with the page URL when it's ready lebarhon and we can start to get it filled in
21:04:18 <DavidWHodgins> marja11: You beat me to it. I was typing the same thing when the line from you showed up.
21:04:23 <marja11> lebarhon: I'll try to contact kamil (ryoshu), maybe he knows a way to contact napcok
21:04:36 <MrsB> napcok responds on bugzilla
21:04:51 <MrsB> or often on irc, or email probably too
21:05:05 <marja11> lebarhon: is there a bug for MageiaWelcome?
21:05:23 <lebarhon> No, it's only to add the doc page
21:05:42 <marja11> lebarhon: do you have time to file a bug and assign it to napcok?
21:05:44 <lebarhon> nothing urgent since M5 is delayed
21:05:53 <MrsB> best to create a bug, yes
21:05:58 <lebarhon> marja11: OK
21:06:07 <marja11> lebarhon: perfect, thx :-)
21:06:10 <MrsB> you can assign it to napcok then
21:06:22 <MrsB> add doc-discuss as a CC
21:06:28 <MrsB> or dic-bugs rather
21:06:31 <MrsB> doc*
21:06:32 <lebarhon> MrsB: I am not sure I know how?
21:06:32 <marja11> MrsB: indeed, thx
21:06:43 <MrsB> doc-bugs@ml.mageia.org
21:06:48 <marja11> lebarhon: CC doc-bugs@ml.mageia.org
21:06:56 <marja11> lol
21:07:04 <lebarhon> I mean to assign napcok
21:07:12 <MrsB> to assign to napcok, just click assign and it add 'napcok' it should recognise it
21:07:24 <MrsB> -it
21:07:24 <lebarhon> MrsB: Thx
21:07:45 <MrsB> Was there anything else to discuss tonight?
21:07:59 <lebarhon> not for me
21:08:11 <DavidWHodgins> Not here.
21:08:21 <wilcal> I'm done. Many thanks all for the discussion
21:09:03 <ennael> #endmeeting