20:34:43 <ennael> #startmeeting
20:34:43 <Inigo_Montoya`> Meeting started Mon Nov 10 20:34:43 2014 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:34:43 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:34:51 <ennael> who is around ?
20:34:57 <grenoya> o/
20:35:08 * MrsB is
20:35:14 * filip 2
20:35:21 <MrsB> wilcal was
20:35:25 <tmb> hi
20:35:40 <ennael> #chair MrsB grenoya
20:35:40 <Inigo_Montoya`> Current chairs: MrsB ennael grenoya
20:35:49 <MrsB> uhohh
20:35:57 <ennael> let start :)
20:36:08 <ennael> #topic quick financial review
20:36:48 <ennael> ok so a quick sum up about this
20:37:08 <ennael> we have about 12 000€ on bank account and 1 000€ on paypal
20:37:29 <MrsB> that's pretty good
20:37:48 <ennael> hard disks hhave been bought for servers and should be delivered this week or beginning of next week
20:37:50 <grenoya> nice
20:38:03 <MrsB> time for some goodies grenoya
20:38:10 <ennael> finalizing bank change was a bit messy but it's all done now
20:38:24 <grenoya> good too :)
20:38:30 <ennael> also google sponsorship should be finalized soon also
20:38:39 <filip> and time for nice working servers w/o botlenecks ;)
20:38:42 <ennael> setup was a pain but it's now finished
20:38:51 <MrsB> that sounds really promising. I saw your email on board ML
20:39:07 <ennael> we should get about 800$ before end of this year
20:39:13 <ennael> which is nice :)
20:39:25 <MrsB> thank you google
20:39:44 <ennael> so now we need to define other expenses
20:39:51 <ennael> still nothing from atelier
20:39:56 <filip> and thx to ennael and pterjan
20:40:08 <MrsB> yeah thanks for getting it sorted out
20:40:32 <grenoya> ennael: nope, sorry, Akien and I haven't move on enough on that point
20:40:58 <ennael> please do. FOSDEM is in 2,5 months
20:41:04 <leuhmanu> ola
20:41:05 <ennael> and time goes very fast
20:41:07 <grenoya> indeed!
20:41:11 <Akien> Yes I have some work in progress but it takes time, and it's relatively boring :-)
20:41:19 <Akien> But we need it for FOSDEM indeed
20:42:23 <MrsB> Did you get in touch with Pierre from the forum ennael?
20:42:55 <ennael> MrsB: it's in progress we just need to find time to speak more about it
20:43:10 <MrsB> great \o/
20:43:38 <ennael> Akien, grenoya : can we have something ready in 2 coming weeks?
20:45:13 <grenoya> deadline noted
20:45:14 <Akien> I can't promise anything, but we will try to do some progress for the next meeting
20:45:33 <Akien> I'll reach out to other distros / associations to know how they do this, where they buy t-shirts, etc.
20:46:07 <ennael> ok
20:47:34 <ennael> tmb: about servers, do we need anything else ?
20:49:58 <tmb> well, depending on if old valstar still works it will replace broken jonund, otherwise a new buildnode will be needed at some point...
20:51:10 <tmb> and i wonder if we should get a new hosting (or server) for web/blog/... the gandi hosting does not support Mageia...so it's a PITA tu upgrade
20:51:14 <ennael> something to be checked in Marseille then ?
20:51:49 <tmb> jep
20:51:51 <ennael> ok
20:52:03 <ennael> that's all for this topic unless you have question, comment
20:52:19 <MrsB> nothing here, thanks
20:53:01 <ennael> ok next topic then :)
20:53:04 <ennael> #topic beta 1 release and Mageia 5 planning
20:53:11 <ennael> release hell :)
20:53:16 <MrsB> seems that way
20:53:16 <grenoya> :)
20:53:32 <ennael> ok what is the status today on current isos build ?
20:53:39 <Akien> Ready to go.
20:53:49 <MrsB> wilcal said the same
20:53:56 <Akien> The main bug is gnome... But apart from that, it's already fine for a beta :-)
20:54:02 <ennael> great news
20:54:04 <wilcal> IMO the present state of the ISO's are ready to go to the field
20:54:15 <MrsB> dude :)
20:54:17 <wilcal> not perfect, as usual, but time to get'em out there
20:54:25 <ennael> tmb: can you push the isos and torrents?
20:54:27 <DavidWHodgins> Hi everyone. Sorry I'm late.
20:54:39 <tmb> yeah, we seem to get issues with Gnome on every release, but I'm happy they show up at beta1 stage this time...
20:54:45 <wilcal> Hello David, just in time
20:54:45 <ennael> :)
20:55:02 <grenoya> blog post needs technical inputs here: https://pad.riseup.net/p/mga5b1
20:55:04 <[mbot> [ Riseup Pad ]
20:55:05 <wilcal> What you say on the M5 isos David
20:55:07 <MrsB> we can expect bugs, as long as they boot and installa then they're ready for wider testing
20:55:19 <Akien> Yep, some tech stuff would be nice for the blog post draft
20:55:29 <ennael> I will have a look after the meeting
20:55:32 <tmb> ennael, yep, will start signing the isos and fire up the torrents...
20:55:33 <DavidWHodgins> Go ahead and release, so they get wider testing.
20:55:49 <ennael> ok that's done for beta1
20:55:50 <Akien> I know some of it, so I may write a few lines, but feel free to drop juicy details :-)
20:55:56 <wilcal> \0/ time to go
20:56:04 <ennael> now we need to decide the planning until final release
20:56:35 <DavidWHodgins> Either we drop beta 2 and go straight to rc, or we delay everything.
20:56:48 <ennael> droping beta2 is not a good thing
20:56:57 <ennael> given the status of current isos imho
20:56:58 <MrsB> well, I would say rescheduling everything from current date
20:57:03 <wilcal> I think that will depend on how M5B1 does out there
20:57:34 <grenoya> I'm pro rescheduling
20:57:46 <tmb> yeah, we will definately need beta2
20:57:47 <filip> +1
20:57:49 <DavidWHodgins> Beta 1 is roughly 6 weeks late from it's original date.
20:57:59 <wilcal> Ya Holidays are upon us and best we not press people
20:58:16 <MrsB> as long as we explain the reasons behind the set backs I don't see any reason to worry. After xmas period is better for contributions too
20:58:30 <ennael> I would say beta2 in 1 month and RC in the very beginning of january
20:58:34 * tmb thinks about another fosdem release :)
20:58:38 <ennael> then final end of january :)
20:58:39 * tmb hides
20:58:40 * MrsB slaps tmb
20:58:46 <Akien> I've kept people posted about the beta1 delay on social networks, and saw noone complaining about it :-)
20:58:47 <grenoya> :))
20:58:49 <ennael> tmb: you win :)
20:58:52 * tmb too slow to hide
20:59:11 <MrsB> that's good Akien, well done for doing that
20:59:19 <Akien> ennael: Fine by me.
20:59:20 <DavidWHodgins> I agree, it would be better to postpone the rest of the schedule.
20:59:31 <ennael> wdyt about proposal?
20:59:33 <wilcal> This Fosdem release will be better then M4 was
20:59:48 * filip hopes so 2
20:59:59 <grenoya> ennael: I agree
21:00:12 <MrsB> we can *aim* for fosdem
21:00:18 <ennael> let say 16/12 for beta 2
21:00:22 <DavidWHodgins> Should we extend Mageia 3 and 4 support too?
21:00:36 <ennael> 06/01 for RC
21:00:38 <MrsB> preferably not mga3
21:00:48 <ennael> and 27/01 for final
21:00:55 <wilcal> Let M3 go
21:01:10 <filip> I also think that it's to late for mga3
21:01:24 <MrsB> that's going to be rapid fire ISO testing ennael
21:01:33 <Akien> When is fosdem?
21:01:42 <MrsB> start of february
21:01:47 <wilcal> 1st weekend in Feb
21:01:50 <Akien> Ouch
21:01:50 <grenoya> Akien: 31/01 01/02
21:01:59 <Akien> Then I don't like 27/01 for final
21:02:08 <Akien> We should aim for a week before IMO
21:02:16 <ennael> too short for planning
21:02:25 <filip> tmb will be right after all ;)
21:02:30 <ennael> and because we have christmas in between
21:02:35 <MrsB> phone brb
21:02:51 <Akien> Then we should postpone FOSDEM by one week :-)
21:02:58 <filip> ;)
21:03:08 <DavidWHodgins> lol
21:03:10 <ennael> Akien: we let you make the proposal :)
21:03:55 <tmb> well "internal release" could be targeted at Jan 23rd, so there is some "extra time"
21:04:11 <ennael> this let 10 days until FOSDEM
21:04:32 <Akien> Sounds good.
21:04:33 <ennael> one week rather
21:04:49 <ennael> and if it does not work tmb will kill you all
21:05:46 * tmb checks 00 status
21:06:48 * tmb finds double O status valid :)
21:06:48 <ennael> :)
21:07:03 <ennael> so
21:07:04 <MrsB> sorry
21:07:07 <ennael> 16/12 for beta 2
21:07:12 <ennael> 06/01 for RC
21:07:19 <ennael> "internal release" could be targeted at Jan 23rd
21:07:25 <ennael> and final release for fosdem
21:07:33 <wilcal> sounds like a comfortable plan
21:07:42 <ennael> can we vote?
21:08:11 <MrsB> we'll need serious bug fixing early on if we hope to do this
21:08:30 <MrsB> the RC will need to be a proper RC and not beta 3
21:08:31 <Akien> Yes, we need a RC-like beta2
21:08:45 <ennael> MrsB: a RC :)
21:08:51 <MrsB> yeah
21:08:56 <Akien> Not a Mageia 4 RC, that is :-)
21:09:24 <grenoya> ennael: +1
21:09:32 <MrsB> We need to set a target to aim for nd it is doable but it'll need weekly dev meetings :P
21:09:56 <tmb> so we also need dates for artwork/translation/release freeze
21:10:08 <ennael> yep that's next topic :)
21:10:30 <ennael> but if we have final deisgn now it should be done for beta2 release
21:10:42 <ennael> Akien, grenoya : do you think it's possible ?
21:11:01 <MrsB> as we're a month behind where we expected is it worth relaxing version freeze for a few days?
21:11:43 <grenoya> I've not followed artwork developpment on previous release, so I can't be sure
21:11:48 <grenoya> Akien: wdyt?
21:12:16 <Akien> We just got the original artwork on the atelier ML, and the artist is also subscribed and willing to help
21:12:18 <tmb> MrsB, well, we've been allowing pretty much every freeze push for now, so it is "semi-open"
21:12:47 <MrsB> might be worth stating explicitly though
21:13:22 <ennael> we need a date for release freeze
21:13:40 <tmb> well, version freeze is supposed to take effect when we hit beta1, wich is today :)
21:13:51 <Akien> Artwork should be done for beta2
21:14:00 <Akien> tmb: you mean release freeze I guess
21:14:19 <Akien> Ah no, nevermind :-)
21:14:27 <ennael> so release freeze for beta2, in december ?
21:14:49 <MrsB> yes, original planning was release freeze just before beta 2
21:15:13 <MrsB> artwork and translations between beta 1 and beta 2
21:15:34 <tmb> Maybe Dec 9th, so it is in effect when we start building isos
21:15:48 <MrsB> makes sense
21:15:51 <Akien> Sounds good.
21:15:54 <filip> that sounds reasonable for l10n 2
21:15:58 <DavidWHodgins> Agreed
21:16:03 <grenoya> agree
21:16:29 <DavidWHodgins> Should we extend support for Mageia 4 too?
21:16:52 <grenoya> #agreed 16/12 for beta 2 | 06/01 for RC | "internal release" at Jan 23rd | and final release for fosdem
21:17:02 <Akien> We need a "Mageia tools rebuild" for i18n
21:17:08 <MrsB> not at this stage Dave, it's not really related to mga5 release. More something to worry about for mga6
21:17:10 <grenoya> # agreed release freeze on 9th of December
21:18:02 <grenoya> filip: you mean 9th of December for i18n/l10n?
21:18:20 <filip> yeah.
21:18:41 <Akien> I'd say a couple of days before for translation freeze, and then all Mageia tools should be rebuilt to include the latest translations
21:18:59 <Akien> Translators are usually pretty efficient the last 3 days before the freeze :-)
21:19:22 <ennael> ok is it all ok for the planning ?
21:19:22 <filip> grenoya: # agreed w/o space
21:19:28 <grenoya> #agreed artwoek/i18n/l10n freeze 6th of December
21:19:35 <grenoya> #agreed release freeze on 9th of December
21:19:40 <grenoya> filip: thanks :)
21:19:45 <grenoya> ennael: sounds like :)
21:19:54 <Akien> Sounds good.
21:20:02 <ennael> ok :)
21:20:07 <tmb> yeah, we can schedule tranlation update/rebuild for all drakx* after release freeze, before iso build so we get them on isos
21:20:24 <filip> tmb: that would be great
21:20:58 <tmb> it does not take long to roll new tarballs for the tools
21:21:24 <ennael> #topic teams review
21:21:49 <ennael> so let see what is happening in teams at this moment :)
21:21:54 <ennael> MrsB: want to start?
21:22:00 <MrsB> sure, if you like
21:22:43 <MrsB> QA team has new members. It's been mostly ISO testing for a long time so now we need to move them onto testing updates
21:23:14 <MrsB> I'm mostly unavailable for a few weeks which is awkward timing with so much going on
21:23:25 <wilcal> The release today of M5B1 will release QA resources to concentrate on the pile of updates
21:23:43 <MrsB> others have been stepping up though and Akien helping out too
21:23:53 <wilcal> It's a GREAT team
21:24:02 <MrsB> We're looking forward to mga3 EOL now
21:24:28 <MrsB> There are some kernelly things to finx before we can kill it IINm tmb?
21:24:31 <MrsB> fix*
21:24:47 <tmb> MrsB, like ?
21:24:56 <MrsB> the provides in mga4?
21:25:08 <tmb> MrsB, that's fixed :)
21:25:13 <MrsB> ok great :)
21:25:34 <MrsB> so we're looking forward to it's EOL then, officially
21:25:46 <MrsB> it'll half our workload overnight
21:26:08 <MrsB> The updates list has grown recently but is still more or less under control
21:26:30 <MrsB> http://mageia.madb.org/tools/updates
21:26:33 <[mbot> [ Mageia App Db - Current Update candidates ]
21:26:54 <MrsB> If we can convert a good lump of ISO testers into updates testers we'll do well
21:27:24 <MrsB> we need to be fully on top of it though before beta 2
21:28:12 <MrsB> congratulations and thanks to everybody involved with beta 1
21:28:32 <ennael> thanks indeed
21:28:49 <MrsB> anything else wilcal/dave?
21:29:06 <wilcal> We've got a great team right now
21:29:23 <MrsB> just got to keep everybody busy
21:29:35 <wilcal> that won't be hard :-)
21:29:39 <MrsB> :)
21:29:41 <Akien> The beehive is taking shape :-)
21:29:53 <Akien> Even when the Queen is missing :-p
21:30:02 <DavidWHodgins> Nothing else here.
21:30:21 <MrsB> it's been good to see progress continuing while I'm unavailable, you've been a big part of that Akien
21:30:39 <ennael> ok
21:30:59 <MrsB> all done then, thanks :)
21:31:03 <ennael> #info atelier review
21:31:09 <ennael> grenoya, Akien  ?
21:31:23 <grenoya> Artwork is on ot's way
21:31:38 <grenoya> Goodies are a bit late as you already know
21:32:03 <Akien> The team is slow as always, but we'll try to get important things done in time (artwork and FOSDEM material with highest priority).
21:32:20 <grenoya> Web is moving a bit (preparing mga3 EOL and discussing design)
21:32:44 <grenoya> and you are still able to produce blog posts :)
21:32:58 <filip> about web: we had a mockup suggestion for it but no news since then. I'll ping the guy.
21:33:27 <grenoya> the team is indeed a bit slow, but I bet everyone is overbooked by day job or studies :/
21:34:21 <grenoya> Akien: more to say?
21:34:29 <grenoya> filip: same question?
21:34:55 <filip> we have a TODO but as you already said we're slow ;)
21:35:08 <Akien> Not from me :-)
21:35:25 <filip> my focus is i18n part of a web
21:35:32 <MrsB> need more prodding :)
21:36:33 <ennael> thanks :)
21:36:35 <grenoya> MrsB: yeah! but I need that too /o\
21:36:44 <MrsB> :D
21:36:46 <ennael> #info i18n team
21:36:52 <ennael> next !
21:37:16 <filip> we continue as usual
21:37:30 <filip> but I see a lot of new translators in TX
21:37:56 <filip> they tend to forget to notify us to push their work to git
21:38:46 <MrsB> is there any way to email them all?
21:38:47 <filip> so I decided to try to build a semiautomatic tool which will show tx/git differences in statistical meaning
21:39:45 <Akien> We should try again to reach out to them (there is an internal messaging system, but it's not linked to their email account if they don't have notifications enabled I guess)
21:39:49 <filip> MrsB: not that I know of. we tried to notify individualy
21:40:24 <filip> there are literary new languages out there
21:40:37 <filip> so we need to do something
21:40:39 <MrsB> does your tool work ok for you?
21:41:26 <filip> I started to build it yesterday. for now it only curl the tx stat. I need to parse it and compare it to our git
21:41:40 <filip> there is still some work to do
21:41:52 <filip> and I not a developer ;)
21:42:32 <filip> we need to notify ML for l10n freeze
21:42:42 <MrsB> can ask for help on dev ML if you get stuck with it, nice work though
21:42:58 <filip> MrsB: yeah. will do
21:43:44 <ennael> antyhing else ?
21:44:08 <filip> we didn't have a meeting for some time and we need to push l10n/doc team merge forward
21:44:48 <filip> one more important thing
21:45:48 <filip> I would like to better support our l10n/i18n tool better so I'll resign as a team coleader soon
21:46:07 <filip> I'll notify us on ML too
21:46:44 <filip> I just don't have the conditions to continue much longer
21:46:55 <filip> Akien: anything to add?
21:46:58 <MrsB> sorry to hear that filip
21:47:16 <filip> MrsB: I'll contribute more ;)
21:47:27 <MrsB> but you're a good leader
21:47:54 <filip> thx. but money and health situation is really devastating :(
21:48:11 <grenoya> :/
21:48:32 <MrsB> take care of yourself
21:48:43 <filip> MrsB: that's the point ;)
21:48:48 <MrsB> ok :)
21:49:04 <DavidWHodgins> filip: Best of luck!
21:49:09 <filip> thx DavidWHodgins
21:49:23 <Akien> filip: Take care of yourself!
21:49:39 <Akien> Nothing to add about i18n/l10n for today
21:49:49 <ennael> tmb: want to speak for sysadmins?
21:49:57 <filip> thx Akien. can you please conclude merge thread also ;)
21:50:44 <Akien> filip: Yes, it's on my todo list to (growing exponentially tonight :-p )
21:50:54 <Akien> *too
21:51:26 <DavidWHodgins> tmb: Shouldn't all of the servers be upgraded to Mageia 4, so they can keep getting security updates?
21:51:53 <tmb> well, for sysadmins next thing up is to get new valstar up and running so we can start moving forward...
21:52:11 <grenoya> #topic sysadmin review
21:52:14 <ennael> so disks missing is the condition ?
21:52:49 <tmb> yep, and upgrading rest of infra at the DC at the same time when sysadmins are on-site
21:52:59 <ennael> ok
21:53:15 <ennael> can we plan a meeting or a detailed mail to prepare this before maat goes there?
21:54:39 <tmb> yep, that we need to do... and get some timeline when maat can go there... we can do as much as possible remotely, but it's best to do it when we also heve somepne on-site when it breaks :)
21:55:32 <DavidWHodgins> Such an optimist! ☺
21:56:11 <tmb> DavidWHodgins, yep, but some issues such as usr move it in between, and checking BS parts to cope with the changes...
21:57:24 <tmb> and valstar is the most critical one... as long as we get that working, the buildnodes can simply be re-installed, no upgrade needed
21:58:03 <ennael> ok
21:58:06 <tmb> but it's on-site hands-on that is needed to get for example sucuk back.
21:58:22 <ennael> so let set a list of things to be done with maat
21:58:41 <filip> one more question for sysadmins and others: who can give credential for blog translation?
21:58:59 <tmb> and alamut is the second "critical" host (and then we'll split out forum vm from its alamut shield
21:59:45 <MrsB> dams registered on the blog filip, not sure if he's back again
22:00:04 <filip> haven't seen him around for months
22:00:13 <tmb> ennael, can you get hold of dams to get the rest of the info from him
22:00:25 <ennael> tmb: what info do we need?
22:00:34 <filip> and we have a volunter for l10n
22:00:41 <tmb> ennael, admin login info for all blogs
22:01:21 <ennael> I have admin account on en and fr
22:01:36 <filip> we need pl?
22:03:39 <tmb> ennael, well, look at all languages listed on http://blog.mageia.org/en/, we need them all documented
22:03:46 <ennael> yep ok
22:04:28 <tmb> just to ensure we dont get a "hit by bus..."
22:05:11 <ennael> yep sure
22:05:16 <tmb> technically one could hack every one of them, but I rather not  :)
22:05:29 <ennael> :)
22:06:44 <ennael> #info packagers review
22:07:14 <ennael> so meeting are a bit rare at the moment as malo is very busy and so do I with isos, and real life
22:07:22 <ennael> still bug fixing is on the way
22:07:32 <ennael> we may now focus on release critical bugs list
22:08:22 <ennael> so please QA team be carefull with bugs qualification
22:08:33 <ennael> it's now or never to highlight them
22:08:37 <MrsB> noted
22:08:55 <MrsB> also triage leuhmanu ^^
22:09:07 <ennael> also I'd like us to review general status for all the desktops we have in mageia
22:10:00 <ennael> a big work was done recently on LXDE so it seems cleaner now but some may be still buggy
22:10:22 <ennael> and there is no interest to point desktop in installer that just doesn't work properly
22:10:42 <MrsB> good to see lxde getting some love
22:11:11 <leuhmanu> MrsB: ?
22:11:12 <filip> is that lxqt actually?
22:11:53 <MrsB> leuhmanu: just to ensure any release blockers are set release blocker so they are picked up by packagers when they go through them
22:12:53 <ennael> filip: we need things to be clear on that point
22:13:00 <leuhmanu> I have still lot of bugs to review, but as always not all will be corrected
22:13:13 <MrsB> thanks leuhmanu
22:13:38 <leuhmanu> (even these which are blocker since mga2)
22:13:45 <MrsB> Dave will try to help with this
22:15:11 <ennael> ok anything else to add ?
22:15:30 <MrsB> nothing here, thanks
22:15:54 <grenoya> no
22:17:00 <MrsB> i think we're all done :)
22:17:35 <ennael> yep
22:17:39 <wilcal> I'm done
22:17:39 <ennael> thanks all for attending
22:17:41 <tmb> what... already...
22:17:50 <wilcal> :-)
22:17:55 <ennael> oh tmb wants to speak :)
22:18:04 <MrsB> it's not even bedtime
22:18:08 <ennael> :)
22:18:16 <ennael> see you in 2 weeks then
22:18:21 <ennael> #endmeeting