19:35:20 <MrsB> #startmeeting
19:35:20 <Inigo_Montoya`> Meeting started Mon Aug 25 19:35:20 2014 UTC.  The chair is MrsB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:35:20 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:35:45 <MrsB> Hi everybody. Welcome to our council meeting.
19:35:52 <MrsB> we've not had one in a while have we
19:36:12 <MrsB> #info ennael will be 30mins late
19:36:32 <MrsB> what's first on the agenda?
19:36:50 <grenoya> team review
19:36:53 <MrsB> let's start with team's review
19:36:55 <MrsB> yeah
19:36:57 <DavidWHodgins> quick financial report
19:37:04 <MrsB> Who want's to go first?
19:37:24 <Akien> l10n/i18n can be quick
19:37:36 <MrsB> #topic Teams Review - l10n/i18n
19:37:45 <Akien> ping filip_ to correct me if I'm wrong :-)
19:38:18 <Akien> The l10n process is well in place, most contributors find their way with Transifex and notify us about string changes, so that we can push them to git
19:38:43 <MrsB> transifex is nice and easy to use
19:38:51 <Akien> We'll probably have to check whether git and Transifex are really in sync in the coming month, so that all strings can be pushed before the translation freeze
19:39:47 <Akien> Apart from that, the localised wiki is still on hold because of the difficult server upgrades.
19:40:03 <MrsB> https://wiki.mageia.org/en/Mageia_5_Development
19:40:16 <Akien> There is no ETA from the sysadmins team on that as far as I know, but we're okay with waiting :-)
19:40:52 <Akien> There's not much more to say for l10n, things are pretty calm these days
19:40:54 <MrsB> I see there is progress with servers now though
19:41:11 <Akien> Yes I saw some discussion on the sysadmin ML
19:41:45 <MrsB> Maat is the go-to guy at the moment, thanks to him for that
19:42:00 <MrsB> anything to add here tmb?
19:42:40 <tmb> not for now... I'm catching up on a gazillion mails and so on ... :)
19:43:00 <MrsB> lol ok thanks
19:43:10 <MrsB> thanks then Akien
19:43:15 <Akien> yw
19:43:17 <MrsB> Who's next? grenoya?
19:43:24 <grenoya> yes
19:43:34 <MrsB> #topic Teams Review - Atelier
19:44:18 <grenoya> Atelier has publish some blog post
19:44:32 <MrsB> nice one for QA team :)
19:44:54 <DavidWHodgins> Very good, in my opinion.
19:44:55 <grenoya> and we are trying to keep other social network alive but we are missing credential for most of them
19:45:28 <grenoya> yes, Max is very gifted :)
19:46:10 <MrsB> I don't think it's absolutely necessary to have an 'official' poster really. Regular updates to groups and tags etc with news and community stuff helps
19:46:15 <grenoya> on web side, work is going on, end as dead line is still far, we're not worrying
19:46:26 <DavidWHodgins> One problem with too many people having posting access, as per the recent messages in the contact mailing list, is that everyone assumes some one else will answer.
19:46:52 <grenoya> DavidWHodgins: currently is more: noone from the team has access
19:47:08 <DavidWHodgins> Ah. Ok.
19:47:34 <MrsB> I'm not a bit social media user but like G+ it's a group and anyone subscribed can post there
19:47:58 <grenoya> on artwork side, the contest is still open and some nice background have already been seen
19:47:59 <MrsB> twitter is different I guess, and facebook is a mystery to me
19:48:20 * doktor5000 mumbles "facebook stinks"
19:48:25 * grenoya is rubish with social network, it's not helping
19:48:56 <MrsB> just encourage people to post there as themseves for now maybe
19:48:57 <DavidWHodgins> Agreed. I had an account for a few months, but deleted it when they changed the security settings.
19:49:12 <DavidWHodgins> I've never used twitter.
19:49:43 <Akien> I'm on Facebook, so I'll try to get the credentials for it
19:49:50 <MrsB> Damien used to run our twitter etc afaik
19:50:00 <grenoya> the problem with tweeter and facebook is that Mageia account exist, but we can't identify who open them and who has access
19:50:00 <Akien> Facebook users like "official" publications generally :-)
19:50:15 <tmb> ennael should have the credentials afaik
19:50:15 <doktor5000> question is also - how much actual feedback from potential contributors/users do we get? it's pretty OK for google+, but for the others ... ?
19:50:18 <MrsB> try dams/coincoin
19:50:24 <MrsB> or anne
19:50:30 <grenoya> MrsB: good, we'll try to contact Damien then :)
19:51:20 <MrsB> It's sad to see the communities there and not being involved
19:51:36 <Akien> grenoya: It's true that I see posts from Mageia on Facebook from time to time, it would be good to know who's behing it :-)
19:51:58 <grenoya> to go back on the artwork contest: we did fix a deadline for it, which is a bit akward. I think we should stop it soon to choose the winner and start the work
19:52:17 <filip_> hi there
19:52:18 <grenoya> Akien: indeed :)
19:52:49 <Luigi12_work> the contact address mostly just gets spam and crap anyway
19:52:52 <Akien> grenoya: But we should post about a deadline soon enough so that people are not frustrated if we say directly "Ok now it's finished"
19:53:08 <grenoya> Akien: very true
19:53:19 <MrsB> hi filip_ doktor5000 Luigi12_work and anybody who missed the start :) ennael is going to be 30mins late so I'm hosting for now, sorry ;)
19:53:23 <grenoya> I'll send a mail about that
19:53:34 <Akien> Maybe set end of September for the deadline? Or is it too late?
19:54:08 <grenoya> Akien: I propose a date (maybe end of september) but no one commented on it...
19:54:17 <grenoya> I'll ping the guys
19:54:47 <Akien> Yes we need to be poked at in Atelier to get things moving :-)
19:54:59 <grenoya> the last point, that's not moving at all, is making goodies :/
19:55:07 <MrsB> The planning was 'to be determined' but its currently somewhere between beta1  end september and translation freeze 10th october
19:55:28 <DavidWHodgins> That ensures it will not be ready for beta 1. Must be ready for beta 2, in my opinion.
19:55:29 <grenoya> I ask to have information on how it was managed previously, but even on that I had no answer :(
19:55:41 <Akien> DavidWHodgins: Agreed
19:55:53 <grenoya> MrsB: it's artwork work deadline, not contest one
19:56:09 <MrsB> yes, sorry for confusion
19:56:46 <grenoya> work has to be finish for beta2, and I don't know how much work there is to do
19:57:10 <Akien> I'd propose October 19th for the artwork freeze
19:57:16 <grenoya> I'll sent 2 mails : one for artwork and one for goodies
19:57:24 <Akien> Beta2 is October 31st
19:57:36 <Akien> s/st/th/ :-D
19:57:37 <Luigi12_work> spooky
19:57:49 <DavidWHodgins>19:57:56 <grenoya> so contest -> 30th Sept. and artwork ready -> 19th Oct.
19:57:58 <MrsB> Donald has done the integration previously iinm, he could maybe use some help though. It might be a good idea to ask for help with that.
19:58:02 <Akien> This one got me wondering :p
19:58:18 <Akien> I can help with the integration too
19:58:33 <Akien> grenoya: Maybe earlier for the contest then
19:58:39 <Akien> We need at least a week to choose a "winner"
19:59:35 <grenoya> 19th and 19th ?
19:59:36 <DavidWHodgins> Perhaps end the contest shortly before the first council meeting around Oct. 19th.
19:59:40 <Akien> Well the artwork integration should be doable in two weeks, if we have some help from Schultz
19:59:55 <MrsB> Goodies, I'd say work out what is needed and come up with a list and prices and bring it here for an OK.
20:00:09 <Akien> There's not that much to do actually, probably some 5-6 hours work
20:00:39 <Akien> grenoya: I can help for the goodies (starting September 6th, now I'm a bit busy)
20:00:52 <grenoya> Akien: thanks :)
20:00:53 <Akien> s/for/with/
20:01:30 * doktor5000 is afk for a few minutes
20:01:40 <MrsB> #info Proposed artwork dates: contest -> 30th Sept. and artwork ready -> 19th Oct.
20:02:51 <MrsB> Is that everything grenoya?
20:02:55 <tmb> um, wasnt it 19th & 19th ? to allow for delays ?
20:03:09 <MrsB> oh missed that, sorry
20:03:14 <MrsB> #undo
20:03:14 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Info object at 0x867e92c>
20:03:21 <grenoya> 19th of Sept and 19th of Oct
20:03:26 <MrsB> #info Proposed artwork dates: contest -> 19th Sept. and artwork ready -> 19th Oct.
20:04:06 <MrsB> ell done grenoya, you're doing a great job
20:04:07 <MrsB> w
20:04:27 <grenoya> I think that 's all exept 1 request for sysadm:
20:04:51 <filip_> she does. the rest of us are not very helpfull sometimes :(
20:04:57 <grenoya> would it be doable to have the next artwork contest hosted by Mageia? :)
20:05:32 <grenoya> filip_: on web, you're more helpfull than me :)
20:05:58 <tmb> yeah, we need to sort out what's needed and implement it
20:06:17 <MrsB> #info request to have next artwork contest hosted by mageia
20:06:22 <filip_> I guess there are libre platorms for that?
20:06:30 <grenoya> tmb: you have around 6 month for that now :)
20:06:45 <DavidWHodgins> based on http://xymon.mageia.org we may need more disk drives
20:06:45 <tmb> ooohhh ... :)
20:06:46 <[mbot> [ red : Xymon - Status @ Mon Aug 25 22:05:53 2014 ]
20:06:50 <MrsB> sending grapes and chocolates to make tmb better
20:07:36 <filip_> and less work for him ;)
20:08:06 <MrsB> Thanks then grenoya
20:08:12 <MrsB> who's next?
20:08:34 <DavidWHodgins> MrsB: You, I guess.
20:08:41 <MrsB> #topic Teams Review - QA
20:08:44 <MrsB> d'oh!
20:08:49 <DavidWHodgins> :-)
20:09:10 <MrsB> QA is doin better with people testing ISOs
20:09:26 <MrsB> Where we struggle and have always struggled is with people testing updates
20:09:44 <MrsB> as per earlier email to council we have begun testing updates less thoroughly
20:10:05 <MrsB> it's not something we really wish to do but currently need to do
20:10:35 <MrsB> Essentially it means that instead of testing each update 4 times we now test it twice
20:11:09 <DavidWHodgins> 8 times for updates with both free and nonfree versions
20:11:14 <DavidWHodgins> Or tainted
20:11:24 <MrsB> We'll review this later, especially if the people just joining as a result of the very good blog post stay with us
20:11:38 <MrsB> https://blog.mageia.org/en/2014/08/21/we-need-you-to-try-and-break-stuff/
20:11:39 <[mbot> [ We Need You! (to try and break stuff) | Mageia Blog (English) ]
20:12:02 <Akien> Following the blog post, I've also started some discussions on the MLO forum to get the community there more involved with testing updates
20:12:18 <Akien> It's looking good for now, three people have jumped in :-)
20:12:20 <MrsB> we've already had people joining as a result. historically we've found people join and I think find there is more to it than they realised and tend to drift away
20:12:48 <MrsB> there have been several from FR yeah
20:13:08 <Akien> For many of them the biggest issue in English...
20:13:15 <Akien> Ah the French :-D
20:13:20 <MrsB> I checked the wiki though and the documentaion for QA doesn't appear to be translated into FR yet
20:13:39 <MrsB> yes, i would have the same issue if we developed in French
20:13:52 <Akien> Yes I've started to think about writing a "QA for newbies" documentation in French
20:14:14 <Akien> lebarhon gave some interesting feedback, after reading the QA documentation, he had the feeling that one should be a Mageia power user to help QA
20:14:32 <MrsB> The team pages were already translated into German IINM so it might help if they could be translated to French too
20:14:44 <Akien> It's probably partly misunderstanding, but I guess our documentation is maybe too thorough, and beginners might be easily lost and impressed
20:15:09 <Akien> But we can discuss it further on qa-discuss maybe :-)
20:15:09 <DavidWHodgins> Akien: Absolutely not needed. We need all level of users, as something a power user will assume, will not be obvious to a non-power user.
20:15:20 <MrsB> Well, QA is not newbie easy. It's perhaps wrong to market it that way
20:15:40 <MrsB> Dave is right though, all can get involved at some level
20:16:17 <MrsB> The important thing to have is a willingness and eagerness to learn
20:16:27 <MrsB> QA is mostly about learning new stuff
20:16:27 <Akien> MrsB: Precisely. And newbies can have that.
20:16:35 <Akien> But if they can't get started, they can't learn anything.
20:16:40 <MrsB> yeah
20:16:45 <Akien> Hence the "QA for newbies" idea. How to get started.
20:16:56 <Akien> How to managed repos, what is updates_testing, etc.
20:17:09 <MrsB> All that is on the wiki already in EN
20:17:17 <MrsB> it just needs translating
20:17:19 <Akien> In a few days I had to explain the repo organisation and what is the <packagename>-<version>-<release> model.
20:17:52 <doktor5000> Akien: nope, there should be some easy high-level steps, with not much details instead of killing newcomers with useless details they might only need later ...
20:18:27 <Akien> doktor5000: Indeed.
20:18:31 <doktor5000> we have the same problem with packaging documentation, masses and masses of documentation, but no structure and a _lot_ of duplicated stuff that is useless
20:18:38 <MrsB> The most relevant one is https://wiki.mageia.org/en/QA_process_for_validating_updates
20:18:52 <Akien> That's why the QA documentation might seem daunting to some newcomers, because there's _everything_ in there.
20:18:53 <MrsB> it links to pages for setting up your media correctly
20:18:59 <Akien> But they don't need to know everything to get started.
20:19:23 <MrsB> I agree we need a 'how to get started' type of page
20:19:25 <Akien> They need to know: what is an updated candidate, how is it validated, how can I retrieve it and what should I do with it on my system.
20:19:32 <doktor5000> most relevant and easier to read for beginners is https://wiki.mageia.org/en/Updates_policy#Roles
20:19:35 <DavidWHodgins> I used to be good at translating geek talk to layman talk, but not anymore. Been a geek for too long.
20:19:36 <MrsB> that is already there Akien
20:20:19 <MrsB> https://wiki.mageia.org/en/QA_process_for_validating_updates is a step-by-step process explaining what an update candidate is, where to find it, how to get it and what to do with it.
20:20:50 <filip_> MrsB: your email is worth posting in the wiki ;)
20:20:50 <Akien> MrsB: Yes it has pretty much everything that newcomers should know.
20:21:05 <MrsB> i think so filip_!
20:21:06 <Akien> But it also has things that newcomers don't need to know, and that might scare them off.
20:21:19 <MrsB> Which things?
20:21:22 <Akien> Like info about advisories and svn
20:21:37 <MrsB> hmm yeah, it needs updating for our new process
20:21:39 <Akien> Ah maybe not svn
20:21:52 <Akien> Well I'll have a look with newbies eyes and will report back :-)
20:21:58 <DavidWHodgins> That should be moved to a wiki page for qa-committers
20:22:03 <Akien> I'll ask lebarhon for some input too
20:22:09 <MrsB> what's there is usable though, it just omits that we now upload the advisories ourselves
20:24:49 <MrsB> I think what's maybe missing is getting people to jump in with both feet and actually have a go
20:25:41 <MrsB> when i first began it felt unnatural to just do stuff, i felt as if I should be told what to do next
20:26:26 * doktor5000 swears, if you promise beer and/or cookies to newcomers, there will be masses of the joining QA
20:26:31 <Akien> Here are the requirements lebarhon listed after reading the wiki:
20:26:33 <Akien> 1) Good understanding of some advanced computer notions (ex: git/svn, compilation, SRPMs)
20:26:33 <Akien> 2) Good knowledge of the QA tools (Bugzilla, advisory management)
20:26:33 <Akien> 3) Good knowledge of Mageia (and Linux generally), particularly the interfaces between the system, the DE and the applications. How sound and display are managed, where config files are stored
20:26:33 <Akien> 4) Good hardware knowledge
20:26:35 <DavidWHodgins> lol
20:26:41 <doktor5000> and mention later that beer and cookies are no free
20:26:59 <MrsB> doktor5000: :D
20:27:12 <MrsB> Akien: git/svn is not necessary for QA team members
20:27:14 <DavidWHodgins> Akien: #1 is definitely not required for most qa team members
20:27:15 <doktor5000> Akien: that is required for packagers, but NOT for QA
20:27:17 <Akien> I'll ask him what leads him to each point in the wiki, maybe part of it is his own preconception about the QA work.
20:27:25 <Akien> MrsB, DavidWHodgins, doktor5000: Exactly!
20:27:33 <Akien> But he said he gathered that from the wiki.
20:27:45 <malo> Hi, sorry I'm (very) late
20:27:57 <Akien> That's why I said maybe there was too much information for newcomers, and a "Newcomers start here" page could be useful.
20:27:59 <MrsB> I would say only 3 is really needed
20:28:14 <MrsB> morning malo
20:28:59 <doktor5000> Akien: well, I can try to take a look but I've got professional blinkers on, hence might have a hard time writing introductory page fro newcomers ... you know what I mean?
20:29:00 <MrsB> the most important though is a willingness to learn, experiment and find out stuff for yourself
20:29:09 <filip_> hi malo
20:29:12 <Akien> I'd say if you know how to install an update candidate, that's enough to get started. You can always test graphical applications such as Blender or small bugfixes such as trojita, without deep knowledge of the Linux system.
20:29:18 <MrsB> we have that though in EN Akien
20:29:39 <Akien> MrsB: Ok then forget what I said, I need to have a closer look to the portal
20:30:00 <Akien> Maybe lebarhon just misinterpreted the documentation, or went too far.
20:30:11 <MrsB> I agree we need something obvious, but the information on the validating updates page is a step-by-step process to follow
20:30:43 <Akien> But yes as you said, translation of this page at least would be a big +
20:31:09 <MrsB> something similar to the email i've been sending out to people as they join, giving how to get started in the team rather than how to do QA
20:31:59 <Akien> Maybe we should proceed and discuss this in the next QA meeting, there's still a lot on the plate for tonight :-)
20:32:11 <MrsB> yep, good plan :)
20:32:21 <MrsB> Anybody want to add anything?
20:32:44 <MrsB> Who's next then?
20:33:07 <MrsB> who's left?
20:33:17 <MrsB> sysadmin, packagers, forums
20:33:35 <tmb> for sysadmins...
20:33:41 <MrsB> #topic Teams Review - Sysadmins
20:34:25 <tmb> I cant say much for now as I've been somewhat MIA
20:35:00 <MrsB> how are you feeling?
20:35:13 <DavidWHodgins> tmb: Glad to see you are back, even if it is limited in time you can spend on Mageia.
20:35:30 <tmb> but coling has been busy improving updates processing, and maat has been working on installing/upgrading stuff including new valstar
20:36:11 <tmb> we need to plan for doing a switch to new valstar and ensure bs wont break...
20:37:01 <tmb> But I will need to plan/discuss that with other sysadmins before being more specific
20:37:04 <Luigi12_work> and for getting more people in the sysadmin pool?
20:39:02 <malo> Luigi12_work: maat is new
20:39:07 <tmb> that also need to be looked into .. we have added some like neoclust, but end result is no more help... last in is maat who have been doing some good work
20:39:40 <tmb> seems every time we add some, some others go MIA :/
20:39:42 <MrsB> that's always been a problem, the route to sysadmin. Stormi may still be interested too.
20:40:22 <doktor5000> tmb: well, but if you don't spread the load to more shoulders, then this will always be more work for less people ...
20:40:53 <MrsB> I think in some ways part of the answer is to take on less yourself and guide others instead
20:41:09 <doktor5000> exactly, will pay off in the long run
20:41:30 <tmb> yes, but we are also somewhat picky about handing out unlimited root access wich is currently the setup...
20:41:52 <doktor5000> comprehensible :)
20:41:58 <MrsB> what about mentoring, like packagers
20:42:47 <Luigi12_work> I'd like to help, but I wouldn't be able to physically come to the datacenters
20:42:47 <tmb> but I will try to think about it now again when I'm starting back up to share the work load
20:43:06 <tmb> as for my own health...
20:44:00 <tmb> last scan showed "undefined tissue changes" but blood tests are ok so far, so time will tell ...
20:44:10 <coling> tmb, slightly OT for this meeting: if you want to arrange a time for valstar2 discussions we can perhaps arrange that with maybe you, pterjan and myself, and then we can maybe make some progress on that bit? I've still not got a fully clear picture of what needs done, so a meeting + wiki page to track progress seems sensible to me.
20:44:18 <MrsB> that's worrying tmb :\
20:45:25 <tmb> other than that I'm gaining strength every day, so it seems I need to listen more to my body than to my head, as my head want to do more than the body apparently can sustain for now :/
20:46:02 <MrsB> we can maybe explain it as old age ;)
20:46:04 <tmb> but I've learned to better notice when bodys starts protesting so I think I can manage it better
20:46:58 <tmb> yeah, doc said I should have "been more careful" the ~first year of recovery...
20:47:23 <MrsB> It's good that you're noticing things now though and doing what you're told
20:48:07 <MrsB> Is there anything else for sysadmin stuff?
20:48:15 <tmb> yeah, it's been "painful" to leave the computer alone as it's a "oh I want to do this and test that and..." :)
20:48:35 <tmb> nothing more for now
20:48:46 <MrsB> Thanks for that then tmb :)
20:49:07 <MrsB> Who's next, there are packagers, forums teams left?
20:49:14 <MrsB> bugsquad leuhmanu?
20:49:35 <tmb> coling, yeah lets mail on sysadm for that planning
20:49:43 <MrsB> malo ennael?
20:49:52 <MrsB> doktor5000?
20:49:56 <doktor5000> i'd do forums team
20:49:59 <coling> tmb, OK, I'll send that tomorrow.
20:50:04 <MrsB> #topic Teams Review - Forums
20:50:11 <ennael> (back sorry just overloaded)
20:50:39 <doktor5000> as the saying goes for unix: "no message is good message"
20:51:04 <MrsB> #chair ennael
20:51:04 <Inigo_Montoya`> Current chairs: MrsB ennael
20:51:12 <doktor5000> apart from the long runner https://bugs.mageia.org/show_bug.cgi?id=6834 that prevents forum changes not much to say ...
20:51:14 <[mbot> [ Bug 6834 Bug in Mageia infrastructure that leaves forum requests untreated/undetected ]
20:51:28 <doktor5000> would be good if someone could try to work on that:
20:51:56 <doktor5000> 1. a cleansed forums dump of international forum - AFAIK. only maat or rda can help with that
20:52:22 <doktor5000> 2. a forums vm where updates or changes could be tested - sysadmins and/or maat can help with that
20:53:52 <doktor5000> apart from that, would be helpful if more people try to bridge forums <> dev ml and provide feedback on issues to packagers
20:54:36 <doktor5000> like with the infamous nvidia desaster that hit mga4 directly after release
20:55:01 <doktor5000> that would be pretty much it.
20:55:28 <MrsB> I think ml people tend to stay off forums and the other way around. Do you think forum people would be willing to subscribe to dev ml ?
20:55:33 <ennael> I have some credentials but not facebook one
20:55:38 <ennael> oups
20:56:53 <doktor5000> MrsB: well for some topic I try to ping packagers directly, e.g. with coling on pulseaudio, systemd or polkit topics after I did some prequalification - works quite well, but not many packagers visit forums at all :/
20:57:44 <MrsB> #info forums team requests more devs to visit the forums and provide any info/help they can do please
20:57:46 <DavidWHodgins> I prefer mailing lists, or usenet.
20:57:48 <doktor5000> ahmad and adamw were pretty much the only ones that did similar stuff
20:57:59 <MrsB> yeah it's a tricky one to solve
20:58:08 <MrsB> i try to pop on when i remember to
20:58:24 <doktor5000> MrsB: nope, not regularly,but it would be helpful if packagers at least respond to pings about specific topics
20:58:50 <MrsB> yes
20:59:23 <MrsB> is that a recent (holiday/vacation season) issue or regular?
20:59:35 <doktor5000> MrsB: there's a lot of noise and a lot of basic issues/questions, hence reading regularly is not helpful that much
21:00:00 <MrsB> so occasional visits even would be helpful?
21:00:25 <doktor5000> MrsB: probably not
21:00:37 <doktor5000> MrsB: I probably do more then 75% of all issues myself, works quite good and it's more efficient that way
21:00:54 <MrsB> you work miracles there :)
21:00:57 <DavidWHodgins> I only login to the forums if I see a mailing list question about a specific problem, where I know the answer.
21:01:09 <doktor5000> MrsB: mhhm -.-
21:01:43 <ennael> I'm late but I'd like to congratulate QA team fir the blog post
21:01:46 <ennael> impressive result
21:02:09 <MrsB> thanks go to atelier for the blog post
21:02:18 <doktor5000> MrsB: it's easier for me to correlate this with bugs or recent ml topics, and provide feedback via errata entries and so on
21:02:34 <filip_> doktor5000: I see your miracles there too
21:02:56 <MrsB> what would you say you need then doktor5000? just to get people to respond when you ping them for things?
21:03:24 <doktor5000> MrsB: that would be pretty helpful, yes - also for bug reports ...
21:04:08 <MrsB> #info Please respond to pings for information from forums team
21:04:23 <MrsB> ennael: that's maybe something you could help with
21:04:44 <ennael> yep
21:05:01 <ennael> we should formalize a bit more relation between packagers and forums as we did in QA
21:05:33 <malo> doktor5000: feel free to write to -dev directly and saying "Forums issues that need attention" with links to topics, if individuals don't respond
21:06:00 <ennael> doktor5000: as beta is coming maybe we can see together the main iussues from forum
21:06:08 <ennael> as an example we have a meeting tomorrow
21:06:15 <ennael> it can be listed there
21:06:22 <filip_> malo: excellent suggestion
21:06:36 <MrsB> i think we also need to recognise that forums are *the* place community members first get involved with mageia, so it's vital people feel part of a community there
21:06:50 <Akien> MrsB: I agree
21:06:55 <filip_> +1
21:07:11 <Akien> It's not just a matter of taste (ML vs forum), it's not the same demographic on both media
21:07:36 <doktor5000> malo: that's a good idea
21:07:37 <Akien> Most direct user feedback are done on forums as far as I can tell
21:07:43 <Akien> s/are/is/
21:07:44 <ennael> we have QA guys in meeting
21:07:52 <ennael> can we have forum representative ?
21:08:04 <doktor5000> ennael: yo
21:08:05 <ennael> doktor5000 is attending meeting usually
21:08:13 <MrsB> packager meeting doktor5000
21:08:13 <ennael> but not formally as forum representative
21:08:28 <doktor5000> just ping me if I forget :)
21:08:43 <malo> doktor5000: Luigi12_work has been doing these emails to raise attention about packages missing security fixes with some success (right?)
21:09:55 <doktor5000> malo: well, if he didn't do a major part of the security issues himself, list would probably still be much longer yet ...
21:10:45 <malo> doktor5000: sure.
21:11:00 <MrsB> it might be an idea to send regular email to dev ml though in the same way
21:12:01 <tmb> yeah, that would atleast "catch" some comments / helpers I think
21:14:02 <MrsB> Is there anything else doktor5000?
21:16:19 <MrsB> let's go on then, we can come back if we need to
21:16:19 <doktor5000> work on errata and release notes, people :)
21:16:29 <MrsB> oh that's true
21:16:47 <MrsB> #info errata and release notes need improving
21:16:51 <DavidWHodgins> errata pretty much has to wait till the rc is released
21:17:32 <MrsB> afaik major issues are added to the release notes though
21:17:54 <MrsB> Thanks for that then doktor5000
21:18:03 <MrsB> that leaves packagers..
21:18:13 <MrsB> #topic Teams Review - Packagers
21:18:31 <MrsB> ennael malo your turn :)
21:18:44 <ennael> ah ah :)
21:19:02 <ennael> so we will have a meeting tomorrow
21:19:14 <MrsB> #info packager meeting tomorrow
21:19:16 <ennael> summer was a bit tricky to manage because of vacation
21:19:21 <ennael> and babies :)
21:19:38 <ennael> still work is going on
21:19:58 <ennael> next focus is beta1 so ending features development
21:20:49 <tmb> (or beginning...)
21:20:53 <MrsB> ;\
21:20:53 * tmb hides
21:20:57 <ennael> :)
21:20:59 <ennael> indeed
21:21:47 <MrsB> there is still opportunity to reschedule release if it needs it
21:21:52 <ennael> so the other topic will be distro rebuild
21:22:24 <ennael> and I would like to plan another packagers session to start with packaging
21:22:29 <ennael> as malo did some time ago
21:23:24 <MrsB> more videos?
21:23:56 <malo> MrsB: hopefully shorter videos :-P
21:24:00 <ennael> :)
21:24:08 <ennael> and plenty of frenglish :)
21:24:24 <Luigi12_work> yeah the dev team has been really quiet this summer
21:24:33 <Luigi12_work> hard to imagine everyone's really ready for the impending deadlines
21:24:44 <Luigi12_work> or maybe many people just left?  Hard to tell if it's just summer of what
21:24:55 <Luigi12_work> s/of/or/
21:24:57 <malo> Luigi12_work: summer I guess
21:25:03 <ennael> well on my side for example having a break was nice... sometimes you need it to restart in a better way
21:25:14 <malo> There has been more activity in the last 3/4 days as people are back
21:25:16 <Luigi12_work> hope so, but when do people come back and do some work?
21:25:21 <Luigi12_work> ok
21:25:38 <malo> As for apprentices, augier is a new apprentice
21:26:05 <malo> and I've made a request to graduate William Murphy aka diogenese
21:26:14 <MrsB> \o/
21:26:14 <ennael> Luigi12_work: unfortunately a community is made of human beings :) and they may need some break :p
21:26:27 <Luigi12_work> hey that's fine
21:26:38 <grenoya> maybe a mail to remind everyone that the freeze is on 09/09 could warm up the team?
21:26:44 <Luigi12_work> I guess many need a long break :o)
21:26:50 <MrsB> as long as we plan around it. If we need to reschedule things we should do it earlier rather than later
21:26:51 <malo> grenoya: definitely :-)
21:27:08 <grenoya> it worked on me :)
21:27:11 <ennael> :)
21:28:21 <malo> I think that's it for packagers.
21:28:32 <ennael> yep
21:28:47 <MrsB> Thanks guys
21:28:58 <MrsB> I think that concludes the teams review!
21:29:11 <MrsB> ennael do you want to take over?
21:29:21 <ennael> yep ok
21:29:36 <ennael> did you speak about kde and kernel updates ?
21:29:45 <MrsB> not yet, wev've done the reviews
21:29:48 <filip_> not yet
21:29:49 <MrsB> -v
21:29:51 <ennael> ok
21:30:04 <ennael> #topic updates pending: KDE and kernel
21:32:12 <MrsB> Basically we need to decide whether to allow thes updates as exemptions to our updates policy
21:32:43 <ennael> so firt
21:32:48 <ennael> sorry connection pb
21:32:55 <ennael> so first one is about KDE 4.12
21:33:11 <ennael> KDE team would like to switch Mageia 4 to 4.12
21:34:38 <DavidWHodgins> I'm in favour of both the kde and kernel version updates. There was also a request on the dev mailing list for a mate version update, but I'd like more info on that one first.
21:34:38 <ennael> I've spoken with KDE guys
21:34:57 <ennael> and ask about changelog for 4.12
21:35:11 <ennael> this version is 99% bug fixes
21:35:17 <ennael> or kind of
21:35:25 <MrsB> I know there are security fixes included which Luigi12_work is keen to see fixed
21:35:47 <Luigi12_work> yes, the 4.12 naming is mostly for packaging convenience, as the platform and desktop is frozen
21:35:55 <DavidWHodgins> The only change I've noticed is that the systray icons became larger, which I actually prefer.
21:36:01 <ennael> :)
21:36:09 <Luigi12_work> only apps really have new features (and honestly not very many in 4.12)
21:36:42 <Luigi12_work> 4.13 had more significant changes in kdepim, which is why they passed on updating any further
21:37:15 <MrsB> I'm not against a kde update. Some people have been using it for some time now and the most part of testing it will be installing it and daily use. We'll eed to ensure the update applies cleanly and updated applications are specfically tested though..
21:38:39 <tmb> Well, as long as people realize we open up possibility for other DEs to also request version bumps too (and no I dont speak about Gnome, as that is painful enough between mageia releases)
21:38:53 <Luigi12_work> I don't agree with that
21:39:07 <Luigi12_work> this isn't a "DE update" that would be anything comparable to a MATE update or anything else
21:39:16 <Luigi12_work> again, that's just confusion caused by the version numbering
21:39:22 <DavidWHodgins> Each de version upgrade has to be evaluated on a case by case basis.
21:39:24 <Luigi12_work> so this has no bearing on any other DE
21:40:04 <MrsB> IIUC KDE doesn't issue specific releases and updates are incremental
21:40:34 <tmb> well  other DEs also says that it's mostly bugfixes and if you want your bug fixed, do the version bump...
21:40:51 <Luigi12_work> well they might lie to us like that because they want to update it
21:41:01 <tmb> that does obviously not mean we have to ack every request...
21:41:17 <Luigi12_work> exactly
21:41:26 <tmb> but they _deserve_ the same consideration...
21:41:27 <ennael> on my side I've tried to read part of the changelog and took some information
21:41:31 <ennael> indeed
21:41:43 <ennael> the idea is not agree because it's KDE
21:41:51 <ennael> but because it's a bug fix release
21:41:55 <Luigi12_work> I don't see why other deserve the same consideration
21:41:55 <DavidWHodgins> That's why I say case by case.
21:41:57 <MrsB> We cant easily say no it can never happen though as we can never say yes it can always happen. As long as our policies and processes are followed we can make decisions as they arise.
21:42:21 <Luigi12_work> we don't update to new major releases of things for no reason, and I don't see this as really even being an exception to that, it just *sounds* like one at first glance
21:43:06 <DavidWHodgins> Luigi12_work: I thought you were in favour of it, in order to get the security updates.
21:43:16 <Luigi12_work> I am in favor of the KDE update
21:43:25 <DavidWHodgins> Ok
21:43:38 <Luigi12_work> I just said that I don't see this proposed update as an exception to our normal procedures
21:43:39 <ennael> we could work on a blog post to explain how updates work why we choose some and not others
21:43:59 <Luigi12_work> well, it depends on who's doing the complaining that we're not updating things
21:44:01 <ennael> we need some content for the blog and this is important to iunderstand
21:44:11 <tmb> So when another DE get some security issue and the only way to fix it is a version bump, what will we do...
21:44:19 <Luigi12_work> is it the users, is it the developers, is it nobody.  The who affects the how we could address that
21:44:49 <Luigi12_work> tmb: do you have a concrete example of that happening?
21:45:07 <Luigi12_work> sometimes you have to backport a fix.  Sometimes you just have to say WONTFIX
21:45:15 <MrsB> we'll have to make decisions and compromises as the need arises
21:45:31 <DavidWHodgins> tmb: Evaluate how severe not fixing the security problem is, and the probability of regressions.
21:46:47 <Luigi12_work> we've always provided a KDE update for previous Mageia releases, it's just in the past it was from 4.x.y to 4.x.z.  The KDE team determined that 4.12.5 made a lot more sense for various reasons than 4.11.5 as an update in this particular case, and the 11->12 doesn't carry the same meaning as any previous x->y in KDE history
21:46:49 <tmb> MrsB, yeah, thats the point... I'm not suggesting anything goes, but the minute we start "breaking" policies we need to realize consequences...
21:47:03 <DavidWHodgins> Like with the kernel upgrade, if there is no expectation of regressions, and testing goes well, then approve it. If not, don't.
21:47:05 <Luigi12_work> again this isn't a policy break, that's just confusion caused by the numbers
21:47:42 <Luigi12_work> should have said x->(x+1) but I hope the point was clear
21:48:19 <MrsB> tmb:  yes, but we have processes in place which hopefully should minimise the risk. Escalating through dev to decide the technical need and council to make the final decision.
21:48:56 <MrsB> I think council needs more of a pro's/con's type list of issues though ideally
21:49:03 <Luigi12_work> and now that backports are open, if we do get a bunch of "but I want to update $foo" we can point to an alternative solution
21:49:07 <tmb> well, thats still a matter of opinion... in the end "version numbers does not necessarily mean anything" ... different upstream treats numbers differently...
21:49:22 <Luigi12_work> exactly
21:49:53 <MrsB> from a purely QA testing perspective, it's a large update but not difficult to test. I'm not against it *if* it's needed.
21:49:54 <tmb> wich means another DE version bump can also be a "bugfixes mostly"
21:50:06 <Luigi12_work> if it *really* was, then that's fine
21:50:15 <Luigi12_work> if it's just someone claiming that's the case because they want to update it, that's not fine
21:50:38 <MrsB> there has to be good technical reason to do it
21:50:40 <Luigi12_work> you have to look at the development model and not get so hung up on the numbers
21:50:54 <Luigi12_work> MrsB: exactly
21:50:55 <DavidWHodgins> Luigi12_work: There are still decisions to be made about how to handle backports, and their advisories (if any), with changes that might be needed for mgaadv
21:51:23 <Luigi12_work> that's fine (I don't care about backports anyway)
21:51:55 <DavidWHodgins> Backports will need security updates too.
21:52:03 <Luigi12_work> not my problem
21:52:23 <Luigi12_work> that'll be the responsibility of the packagers who do the backports
21:52:34 <MrsB> that's part of the packagers decision to provide the backport yeah
21:53:01 <DavidWHodgins> As long as the developers know that, before they create a backport, fine.
21:53:25 <Akien> Yet another reason for backporters to do QA too, so that they know about security issues :-)
21:53:46 <Luigi12_work> sure, but they really need to pay attention to more than just that
21:53:53 <Luigi12_work> there may be security issues only affecting the backported version
21:54:00 <grenoya> sorry everyone, but I can't stay longer. Have a nice end of meeting
21:54:01 <Luigi12_work> they shouldn't rely on me to tell them that
21:54:15 <tmb> yeah... so to move on... people seem to agree the KDE update is wanted... so lets go for it... and realize we then have to debate other "policy breaks" when/if they show up..  no promises that since one got through the next one will or just becouse one get blocked the next one has too...
21:54:37 <MrsB> I think regarding kde, we're lacking a technical reason here at council for giving the excemption but assuming that was discussed in the packaging team and brought here by the team leaders we can accept there is one.
21:55:30 <Luigi12_work> the reasons were presented.  I forgive you if you forgot since it was discussed months ago
21:55:31 <filip_> grenoya: good night
21:55:36 <DavidWHodgins> MrsB: It was discussed on the dev mailing list.
21:55:43 <MrsB> absolutely no promises tmb. This doesn't open any doors as I see it.
21:55:45 <Luigi12_work> anyway, it sounds like we have a resolution, so that's great
21:55:53 <DavidWHodgins> grenoya: Have a good night!
21:55:54 <Akien> I'm opinion is to trust my fellow packagers and those who dived in the KDE development model to assess that it's indeed a bugfix release and not a big new version.
21:56:03 <MrsB> nite grenoya
21:56:14 <Akien> We'll do the same is another DE claims the same thing, and assess it, taking our time.
21:56:14 <Luigi12_work> yes, I agree it doesn't open any doors.  I think it was overkill that it even had to be discussed here, but it's fine.  I just wish it hadn't taken so long.
21:56:20 <Luigi12_work> anyway, onto the kernel
21:56:32 <MrsB> Let's have a quick vote
21:56:33 <Akien> s/I'm/My/
21:56:49 <MrsB> Please say yes or no to allowing the kde update
21:56:55 <DavidWHodgins> Yes
21:57:01 <ennael> yes
21:57:02 <Akien> Yes
21:57:13 <filip_> yes
21:57:27 <malo> yes
21:57:46 <tmb> Yes
21:57:54 <MrsB> doktor5000: ?
21:58:03 <MrsB> Luigi12_work:
21:58:39 <MrsB> It's Yes from me too
21:59:02 <DavidWHodgins> Same with the kernel update based on tmb's postings to the dev mailing ilst. I trust his judgment.
21:59:12 <filip_> it seems that 2 and a half hour took it tax ;)
21:59:37 <Luigi12_work> yes, of course.  I also trust tmb's judgement on the kernels, as always
21:59:51 <filip_> +1
22:01:12 <MrsB> I think luigi12 made the case previously for yes
22:01:12 <MrsB> #agreed We agree to allowing the KDE update. This opens no doors and any future exemptions to policy will be considered on technical requirement.
22:01:12 <MrsB> ok?
22:01:13 <MrsB> tmb do you wanto to talk about the kernel update then please
22:01:43 <DavidWHodgins> Let's leave the other items on the agenda for the next meeting, and close this one. I'm going to need a nap soon.
22:02:04 <ennael> looks like a split is in the aire, I'm having lag pb also
22:02:04 <ennael> so let's vote
22:02:04 <ennael> yes or no
22:02:05 <ennael> yes for me
22:02:14 <filip_> yes
22:02:20 <Akien> Yes
22:02:42 <malo> yes
22:02:57 <MrsB> I'm happy to follow whatever tmb thinks necessary for the kernel, so Yes from me
22:02:58 <tmb> yes (If I can wote on my own proposal)
22:03:09 <ennael> :)
22:03:12 <DavidWHodgins> :-)
22:03:19 <ennael> DavidWHodgins: ?
22:03:29 <DavidWHodgins> As above, yes.
22:03:38 <doktor5000> MrsB: already said yes on council ml, in case I'd miss the meeting
22:03:45 <ennael> ok :)
22:03:51 <ennael> so ok for the kernel update too
22:03:58 <MrsB> #agreed We agree to allow the kernel update too
22:04:02 <DavidWHodgins> Is there anyone against?
22:04:23 <filip_> \o/ near the end of a looong meeting ;)
22:04:37 <Luigi12_work> I think that was the last item on the agenda
22:04:48 <ennael> ok I will mail coincil about financial review
22:05:08 <MrsB> Thanks ennael
22:05:18 <Luigi12_work> perfect
22:05:44 <ennael> thanks MrsB for driving this meeting that was really chaotic on my side :)
22:05:50 <MrsB> lol yw :)
22:05:58 <ennael> thanks all for being there without sleeping :)
22:06:06 <MrsB> thanks guys!
22:06:11 <DavidWHodgins> Doesn't look like it, so it appears to be unanimous for both kde and the kernel.
22:06:13 <ennael> see you in 2 weeks
22:06:23 <ennael> #endmeeting