19:42:24 <ennael> #startmeeting
19:42:24 <Inigo_Montoya`> Meeting started Mon Apr 14 19:42:24 2014 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:42:24 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:42:28 <ennael> ok let start
19:42:41 <ennael> thanks for those around, thanks for taking some time for it
19:43:03 <MrsB> o/
19:43:11 <ennael> ok so
19:43:17 <ennael> #topic mageia 5 planning
19:43:36 <ennael> so on packagers side we are finalizing specifications
19:43:49 <ennael> we hope to do it tomorrow
19:44:17 <MrsB> It's taken a long time to get to this stage, should we replan the releases?
19:44:40 <ennael> well work has started so we will check it with implied people
19:45:25 <MrsB> it's possible we'll need more time
19:45:27 <Akien> Yes we had quite a long post-mortem, and I feel QA is still deep in it, with the 4.1 ISOs still waiting
19:45:42 <ennael> yep indeed
19:45:50 <MrsB> we're up to our necks still
19:45:59 <sebsebseb> hi
19:46:01 <ennael> while we are speaking about it, is 4.1 finalized?
19:46:26 <Akien> We haven't had much feature proposals either, I feel like a big part of the community has been sleepy since the release
19:46:42 <wilcal> Tired
19:46:49 <ennael> 21:46 < ennael> while we are speaking about it, is 4.1 finalized?
19:46:52 <ennael> MrsB: ?
19:46:54 <Akien> The Cauldron is boiling alright, but I feel there is a lack of impulse
19:46:55 <sebsebseb> Akien: lack of interest?
19:47:03 <Akien> ennael: I don't think so
19:47:08 <leuhmanu> ennael: server is done
19:47:12 <leuhmanu> down
19:47:21 <ennael> server ?
19:47:33 <leuhmanu> rabbit
19:47:33 <ennael> rabbit ?
19:47:42 <ennael> ok so I have to ping people about it
19:48:02 <MrsB> Hard to say, the syslinux bug seems fixed but I personally haven't had opportunity to test them. Reports were previously ok though and Dave was keen to push it before but wouldn't make the call. We could release but I'd not be able to say through personally testing them.
19:48:04 <grenoya> rabbit was having problem latly
19:48:21 <ennael> #actoin check with sysadmins rabbit server status
19:48:23 <sebsebseb> O
19:48:27 <sebsebseb> I
19:48:34 <ennael> #action check with sysadmins rabbit server status
19:48:39 <sebsebseb> I plan to test some 4.1 soon myself, and got a old lap top to test with here
19:48:43 <leuhmanu> tmb and pterjan pinged dams without success iirc
19:49:00 <ennael> while we are on it, we may need to rebuild all isos to include openssl fix...
19:49:25 <MrsB> there will be alot of new fixes probably
19:49:54 <leuhmanu> the iso will never be out if we include all updates :)
19:50:00 <MrsB> we've had to concentrate on updates so 4.1 has very much taken a back seat
19:50:24 <ennael> I'm concerned about that openssl bug
19:50:30 <ennael> it's big enough
19:51:05 <MrsB> yes, if you're going to rebuild them it's a valid reason to do so
19:51:23 <ennael> ok anyway it needs sysadmin action here.
19:51:32 <ennael> so back on mageia 5
19:52:14 <MrsB> I agree with Akien we need to inject some energy
19:52:33 <ennael> just do it :)
19:53:06 <wilcal> What is the most exciting thing going to be about M5?
19:53:41 <leuhmanu> stability ?
19:53:59 <wilcal> "Stability" is never exciting  :-0
19:54:11 <MrsB> not seen the list of features
19:54:12 <Remmy> Never exciting, always good.
19:54:31 <ennael> well maybe all people here should have a look on features first
19:54:42 <ennael> it's hard to speak about things we do not all know
19:54:54 <wilcal> "Marketing" should come up with a one line catch phrase about M5
19:55:23 <leuhmanu> (but yes I didn't read proposed feature)
19:55:52 <sebsebseb> I went through the features myself before, about three weeks or so ago,  nothing that ground breaking sure,  but generally all nice features I think.  h
19:56:04 <sebsebseb> I could see how they could all get accepted then, except for possibly the XFCE ISO
19:56:43 <MrsB> maybe a good stable release without too many whizzy new gadgets would be a good thing
19:56:56 <wilcal> Having been some considerable time in Markekeing if there's nothing exciting about your product create some BS
19:56:58 <ennael> mainly improvment on mageia specificities (drakx*), work on KDE menu, new fs by default
19:57:25 <sebsebseb> yep indeed and BTFS by default :)
19:57:26 <MrsB> do you have a link to the feature list ennael please
19:57:30 <wilcal> Old Drag Racing term - If it don't go chrome it
19:57:38 <MrsB> lol wilcal
19:57:40 <Akien> https://wiki.mageia.org/en/Category:ProposedFeatureMageia5
19:57:50 <MrsB> thanks Akien
19:58:25 <wilcal> Or include something none, or not many, of the other Distros will have
19:58:33 <Akien> philippem: Where is the DefaultToPython3 feature? :-D
19:59:23 <sebsebseb> wilcal: yep
19:59:38 <Akien> wilcal: There's this "optimus" feature, but I'm not sure we have the resources to make it happen. The user requesting it think we could use Ubuntu's "Nvidia Prime", but the latter is no upstream project, it's just a bunch of Ubuntu dirty workarounds to get everything set up
20:00:12 <MrsB> you've got that working haven't you Akien?
20:00:31 <Akien> MrsB: Through bumblebee yes, it works quite okay, though it's not a great software either
20:00:36 <Akien> tmb doesn't like it :-p
20:00:49 <Akien> But the feature would be for "native" support of this optimus technology
20:01:14 <Akien> I'll look into it again and ping some knowledgeable nvidia packagers, to see if something can be done
20:01:22 <Akien> I'll add my input to the feature proposal
20:01:56 <MrsB> Not sure what does what, we'll need to find people with that hardware available for testing
20:02:09 <MrsB> or purchase some
20:02:41 <Akien> MrsB: We are quite a lot to have such hardware, most recent gaming-capable computers have it
20:03:07 <MrsB> is it only new hardware?
20:03:10 <wilcal> Only thing I can think of is including Lightworks in the repo but that may not fit into our community
20:03:33 <wilcal> OpenShot 2.0 is probably not going to be ready before M5 releases
20:03:51 <Akien> MrsB: It's a two/three years old technology from nvidia (that's basically the "intel/nvidia" we got problems with during the mga4 release cycle)
20:03:56 <doktor5000__> MrsB: yep, now
20:03:56 <sebsebseb> also the Yogoslaiva stuff should get sorted out for Mageia 5 really :d  Yougoslavia hasn't exsted for a long time, but yet the time zone stuff and keyboard stuff mentions it
20:04:08 <MrsB> the feature proposals have been created it's about selecting which we can fulfill now wilcal
20:04:21 <Akien> sebsebseb: Is there a bug report for this?
20:04:35 <sebsebseb> Akien: no don't think so
20:04:38 <Akien> I think it's not an issue to have a small feature list.
20:05:05 <MrsB> we've still not fully implemented grub2 or uefi
20:05:17 <Akien> As said previously, we can focus on what we have for now. And I think the current features leave plenty of room for other release-cycle objectives, such as improving our teams and workflows
20:05:29 <sebsebseb> I think colin said he had other stuff to do or something, hence  not many features from him this time, but that's ok
20:05:51 <Akien> Upgrading the wiki, starting sysadmins mentorship, having a development roadmap for the drakxtools
20:06:31 <Akien> Those things are not bound to the mga5 release, but it's also a sort of goal I suppose, as the features are
20:06:45 <grenoya> ennael: how much time was there to propose something? and wasn't there more proposals the other times?
20:06:53 <MrsB> yes I agree Akien, it's better to consolidate what we have
20:07:17 <MrsB> about a month grenoya
20:07:18 <ennael> grenoya: time is over? We had some more but many of them were proposed by non technical guys
20:07:20 <Akien> grenoya: Officially there were only a few weeks, but I guess features that got proposed afterwards got considered too
20:07:30 <ennael> at least non able to take part in implementation
20:08:07 <ennael> also we still have to go inside old specifications that were not implemented to add it in list
20:08:07 <sebsebseb> MrsB: implementing Grub 2 properly and UEFI  secure boot, for Mageia 5 would be good yeah :)
20:08:28 <grenoya> and in terms of needed arms, it's all technical (dev/packagers) for what I can see, isn't it?
20:08:39 <wilcal> I think the GRUB2 thing would be a good idea
20:08:43 <ennael> in my opinion we have enough ork for a release if we do it properly
20:09:09 <ennael> the thing in these last weeks is malo has been very busy moving to the US
20:09:14 <wilcal> Think of one special app or feature to put under a spotlight
20:09:15 <grenoya> ennael: for dev/packagers yes :)
20:09:19 <ennael> and I was also very busy with real life
20:09:27 <sebsebseb> oh he's moved to the US, I didn't  know that, interesting
20:09:42 <ennael> we are getting back in line and will follow much more than we did
20:09:48 <wilcal> Gets people wanting to be involved in whatever they contribute
20:10:08 <MrsB> wilcal: discuss that with atelier if you like, some marketing
20:10:17 <ennael> yep marketing can help on this
20:10:25 <sebsebseb> marketing of what?
20:10:30 <wilcal> I think there's a Marketing meeting right?
20:10:35 <sebsebseb> wilcal: no
20:10:35 <ennael> it can start with non technical messages
20:10:48 <Akien> I agree that UEFI support would be nice, it could make Mageia a really good candidate for install parties
20:10:50 * leuhmanu could suggest to drop all unmaitened mageia tools but well
20:11:02 <sebsebseb> leuhmanu: heh heh
20:11:18 <wilcal> I took part in a Mandriva install party a long time ago
20:11:28 <ennael> we can drop everything it will be easier :)
20:11:32 <wilcal> Probably was the last install of the day being here in San Diego
20:11:45 <Akien> I got feedback from a LUG that tried to install Mageia in install parties, but got issues with UEFI, so they tried something else (maybe they hadn't more luck with other distros, though)
20:12:02 <sebsebseb> yes Grub 2 and UEFI secure boot needs properly implemented
20:12:03 <leuhmanu> not everything, but these that does'nt work anymore/have no contributor
20:12:08 <ennael> ok guys we are speaking about lots of things
20:12:26 <ennael> can we try to sum up and decide some actions?
20:13:31 <sebsebseb> I guess
20:13:39 <sebsebseb> so
20:13:49 <grenoya> ennael: communication compagne to find new contributors what ever the team?
20:14:01 <ennael> what well we need some communication
20:14:09 <ennael> this is next topic but well we can have it now
20:14:15 <ennael> nothing happend on our blog
20:14:18 <ennael> happened
20:14:28 <ennael> let's give some news of the Mageia community
20:14:31 <Akien> We need proper objectives before we request for more contributors
20:14:46 <Akien> If they arrive and we can't tell them what's up, they will lose interest
20:15:05 <grenoya> Akien: good point
20:15:08 <ennael> we have objectives
20:15:09 <wilcal> We had a discussion in the qa-meeting about putting the position of Mageia about Heartbleed in the Mageia Blog
20:15:16 <ennael> even if it does not seem enough for you
20:15:34 <Akien> So we should validate the Features list, and maybe work on a few parallel objectives as stated previously (drakx* dev team, wiki upgrade)
20:15:36 <ennael> could we have a blog post about heatbleed
20:15:48 <ennael> let say thow e handle security update
20:15:48 <MrsB> wilcal started one
20:15:50 <ennael> the tools
20:15:56 <ennael> the people implied
20:16:11 <MrsB> it'll need info from sysadmin regarding status of our servers/certs
20:16:26 <ennael> I guess this can be done in a pad so that we can all contribute if necessary
20:16:35 <MrsB> good idea
20:16:41 <Akien> I think Mageia was not affected by the bug, because our infra was too old :)
20:16:48 <Akien> (I mean the Mageia servers)
20:16:52 <ennael> Akien: you may be right
20:16:55 <wilcal> We need to state that clearly in the Blog
20:16:58 <ennael> but at least we are safe
20:17:14 <ennael> but this can be explained
20:17:18 <sebsebseb> Akien: that sounds a bit hmm,  well we were to uhmm not up to date, so we didn't get effected, that's what that sounds like heh heh
20:17:23 <ennael> we are not the only one to use older distros
20:17:27 <MrsB> not in those words though, something more like mga servers are not succeptable
20:17:32 <Akien> Yes it would be nice to tell our users that identity.mageia.org was not affected
20:17:57 <wilcal> What I would say in the Blog would be too "Corporate" sorry that's the way my brain works
20:18:23 <wilcal> Tell it as simply as possible in the Blog
20:18:28 <sebsebseb> wilcal: maybe you should put something about if peopel should reset their password for any other accounts etc to, j ust a genearl thing.  not Mageia specific,  but still relivent
20:18:46 <Akien> Well it's pretty simple: the bug was introduced on Dec 31, 2011, and IINM Mageia infrastructure was still on mdv2010.1, so our openssl was too old to have the faulty feature
20:18:50 <wilcal> I did and shared it with MrsB, again too corporate
20:18:59 <Akien> But our sysadmins would know better :)
20:19:01 <ennael> Akien: ?
20:19:19 <wilcal> we need something very simple to say
20:19:20 <ennael> could you please be a bit more positive that's not fair for our sysadmins guys
20:19:40 <Akien> ennael: I'm quite positive, maybe my phrasing wasn't good
20:19:56 <Akien> s/would know better/would know better than me/
20:19:56 <ennael> https://pad.riseup.net/p/mageia_openssl
20:19:57 <wilcal> One sentence we are not effected. One sentence why
20:19:58 <[mbot> [ Riseup Pad ]
20:20:01 <ennael> to start with
20:20:16 <ennael> just put everything there we can sort then what should be added or not
20:20:25 <MrsB> paste your one there wilcal
20:20:44 <wilcal> dokto5000 was/is get'n pretty beat up on the Forum about it last Friday
20:20:55 <wilcal> I will
20:21:24 <Akien> ennael: Basically I'm just saying that from my understand, Mageia's server are not subject to the bug. I'm not criticizing anyone
20:21:36 <Akien> s/understand/understanding/
20:21:56 <leuhmanu> but dams updates some one so..
20:22:05 <ennael> we do have pretty recent one
20:22:15 <ennael> on web side
20:22:20 <ennael> but also rabbit was
20:22:23 <ennael> and some others
20:22:51 <Akien> At least identity tests negative there: https://filippo.io/Heartbleed/
20:22:52 <[mbot> [ Test your server for Heartbleed (CVE-2014-0160) ]
20:27:10 * ennael promises she did not use any matches
20:27:25 <ennael> ok mail sent to sysadmins about information we could add in this post
20:27:26 <Akien> :)
20:27:36 <grenoya> :)
20:27:54 <Akien> ennael: To cauterize the wound and stop the heartbleed? :-D
20:28:12 <ennael> that may help :)
20:28:22 <doktor5000__> wilcal: I wasn't beat up, just answered questions
20:28:41 <ennael> I'm working on a blog post explaining the release process
20:29:06 <wilcal> Questions that I don't think you had the resouces to answer, not your fault not Mageia's fault it all happened so fast
20:29:07 <ennael> I may have it ready in about 2 weeks so it would be nice if we can finalize that heartbleed one quickly
20:29:16 <wilcal> It's still happening over here in the press
20:29:41 <Akien> I guess i18n could prepare a blog post about our translation platform on Transifex (for when there's a need for a fill-in article)
20:29:51 <Akien> Transifex is quite simple, so we already got lots of new contributors
20:29:52 <ennael> Akien: nice one
20:30:05 <ennael> go for it :)
20:30:37 <Akien> We get a new translator every other day on Tx! \o/
20:30:55 <ennael> see some motivation :)
20:30:56 <ennael> ok
20:30:57 <MrsB> nice going
20:31:31 <ennael> #action reactivate our blog: heartbleed, release process, i18n translation platform
20:31:45 <ennael> so we may add also a post about specifications and planning
20:32:06 <Akien> Indeed
20:32:11 <Akien> And hopefully soon about Mageia 4.1
20:32:16 <ennael> I'm pretty sure there is a positive way to speak about less "sexy" features
20:32:24 <ennael> and explain why they are important
20:32:47 <MrsB> teams too, what each team is and does and how people can help, find out more and get involved
20:32:54 <ennael> sure
20:33:14 <ennael> mageia is a distro but even more a community and this needs to be reexplained
20:33:20 <Akien> Yes, we can put forward that now would be the perfect time to join a team while things are not too hectic
20:33:35 <Akien> Learn QA little by little before the big ISO testing comes, and so on
20:33:39 <malo> hi, sorry I'm late
20:33:49 <MrsB> morning malo
20:33:51 <ennael> malo: you will be burnt in public place
20:34:05 <MrsB> you have to say y'all now :)
20:34:09 <ennael> :)
20:34:15 <sebsebseb> malo: you move to the US interesting,  to California it seems to going by your...
20:34:26 <malo> howdy all
20:34:29 <sebsebseb> hi malo :)
20:34:31 <ennael> malo: so we have to finalize spec reviews tomorrow so that we can communicate on it
20:34:33 <wilcal> Ah California the land of Fruits and Nuts
20:34:40 <malo> ennael: sure
20:34:44 <MrsB> two nuts present :P
20:34:47 <sebsebseb> malo: maybe your to clever to work in England so you have to go over there instead heh heh
20:35:31 <malo> sebsebseb: 26 degrees today here. That's the reason
20:35:54 <sebsebseb> I don't like being cold either, but ok back on topic then
20:36:16 <MrsB> topic is still mga5 planning
20:36:32 <ennael> you all do not hesitate also to write features about your teams
20:36:36 <wilcal> KInda went far ranging didn't it
20:36:41 <ennael> it can be organization, tools...
20:36:45 <grenoya> ennael: is there a dead line?
20:37:06 <ennael> not really on this side
20:37:15 <ennael> usually you all have some todo list
20:37:28 <ennael> it's a way to make it official and readable easily by everyone
20:38:55 * ennael thinks she is proposing silly things that killed them all
20:39:02 <Akien> :-)
20:39:15 <grenoya> ennael: no, non :)
20:39:34 <ennael> ok let start with these actions then
20:39:47 <ennael> when all features are validated, then please have a look on it
20:40:10 <ennael> we can discuss again about it and see how we can explain it and make it more readable and interesting
20:40:22 <ennael> is that ok ?
20:40:31 <malo> ennael: sounds good
20:41:35 <grenoya> good :)
20:41:59 <ennael> ok anything else on Mageia 5 ? qa, i18n, forums, marcom ?
20:42:08 <ennael> any information for everybody here
20:42:14 <Akien> I'm concerned about how we can track the "broader" objectives that we have, that are not specific to Mageia 5
20:42:33 <ennael> can you explain a bit more?
20:42:36 <Akien> Yep
20:43:12 <Akien> I mean things such as the wiki upgrade, the mentoring programs and so on
20:43:19 <Akien> The setting of the drakx dev team
20:43:42 <Akien> So objectives that are important community-wise, but not directly related to the next release
20:43:55 <MrsB> we have team reviews every so often
20:44:09 <ennael> yep we should do it once a month I guess
20:44:21 <ennael> each team reporting about that kind of objectives
20:44:26 <MrsB> i think so, it helps people to have time targets
20:44:41 <ennael> we can decide all what we have as "broader" objective
20:45:12 <Akien> There was also the artwork and QA server space issue, that got stalled for months; if it were documented somewhere, together with its progress, maybe it would have been done sooner
20:45:21 <ennael> in 1 week for example mail council to list these objectives
20:45:36 <Akien> But yes I agree the team reviews have to handle this at the very least
20:45:54 <ennael> then next meeting we know all of them and team review is based on it
20:46:03 <ennael> is it goo for you?
20:46:06 <ennael> good
20:46:08 <MrsB> good idea
20:46:09 <Akien> Ok
20:46:34 <ennael> #action all teams will post their main objectives in coming week on council ML
20:47:01 <ennael> #action next council meeting will propose team review based at least on the way they work on these objectives
20:47:15 <Akien> Yes actually "team objectives" better conveys what I was trying to say :-)
20:47:32 <ennael> and of course add it on the wiki
20:50:24 <Akien> Should we move on to the next topic?
20:50:27 <MrsB> yep
20:50:28 <ennael> yep
20:50:32 <ennael> so blog is done
20:50:39 <ennael> #topic financial review
20:50:58 <ennael> ok so as you may have seen, we are renewing mageia board
20:51:14 <ennael> in between we have to deal with boklm departure as treasurer
20:51:30 <ennael> so all is in hands but time is going and we need to move on
20:51:51 <ennael> I'd like all teams to have a look on their needs that would require some investment
20:52:13 <ennael> we have some money aside we can use part of it but we need a global action plan for it
20:53:27 <MrsB> infra looks set to use up a big chunk of it
20:53:43 <ennael> sysadmins will list their needs indeed
20:54:15 <Akien> I suppose the needs will mostly be for sysadmins, and maybe a bit for atelier (marketing stuff for events)
20:54:53 <Akien> And if the ARM port is revived, maybe some specific hardware, but I haven't heard about it lately
20:56:12 <ennael> I was also thinking about your needs in term of disk space or VMs or anything else. This should need some more harware ofr example
20:57:15 <MrsB> I'd like to automate some QA testing of updates, that would need some hardware/software/something
20:57:45 <MrsB> VM's would do though
20:58:06 <MrsB> i don't know what system would be the best to use
20:58:14 <ennael> ok so please speak about all this on ML
20:58:18 <malo> MrsB: yes, having some resources to play with various automated QA would be great
20:58:23 <ennael> express your need then admins will check it
20:59:37 <MrsB> i'll put something in an email. Send it to sysadm or council?
21:00:13 <ennael> council first
21:00:58 <MrsB> ok
21:01:58 <ennael> #action mail council about your needs for coming year so that we can plan financial expenses
21:03:47 <MrsB> shall we wrap up then
21:04:21 <wilcal> Yep
21:04:33 <ennael> yep
21:04:41 <ennael> any other topic or comment?
21:05:08 <wilcal> I'm done
21:05:17 <sebsebseb> nope
21:05:21 <ennael> s/done/killed/
21:05:22 <ennael> :)
21:05:32 <MrsB> we'll need to publish the board election results
21:05:36 <ennael> yep
21:06:00 <sebsebseb> and the proposed Mageia 5 release scheduled
21:07:09 <ennael> ok
21:07:18 <ennael> thanks for attending
21:07:20 <ennael> #endmeeting