19:40:35 <ennael> #startmeeting
19:40:35 <Inigo_Montoya> Meeting started Mon Mar 31 19:40:35 2014 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:40:35 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:40:44 <ennael> hi all thanks for joining this meeting
19:41:17 <ennael> before starting can we say we go back to one meeting every 2 weeks ?
19:41:30 <DavidWHodgins> Fine with me.
19:42:13 <filip__> me 2
19:42:15 <MrsB> ok, if it allows to keep momentum going
19:42:22 <wilcal> Is that kinda like the movie "Back to the Future"?
19:42:31 <ennael> ?
19:42:50 <MrsB> we had them every 2 weeks before wilcal and went to one a week in the build up to release
19:42:59 <ennael> yep
19:43:13 <ennael> so that we can follow the last steps of the release
19:43:29 <wilcal> I'm usually available at this time on Monday
19:43:37 <ennael> ok
19:43:40 <coincoin> hello all
19:43:46 <MrsB> morning coincoin
19:43:50 <wilcal> coincoin hello
19:43:59 <ennael> #info council meetings are back every 2 weeks unless something unexpected happens
19:44:12 <wilcal> sounds good to me
19:44:13 <MrsB> kind of working out that way atm anyway
19:44:14 <filip__> hi coincoin
19:44:28 <ennael> ok so let start then
19:44:55 <ennael> #topic teams review: what is currently happening, planning, problems...
19:45:20 <ennael> so it's a long time we did not do it. It will allow everyone to keep things together after release rush
19:45:53 <ennael> who wants to start ?
19:46:07 <MrsB> I'll have a go if you like
19:46:22 <ennael> ok
19:46:27 <ennael> #info qa team review
19:46:50 <MrsB> Release is always busy for QA, the months leading up to release and the month or so after release as updates are pushed
19:47:00 <MrsB> it was particularly hectic this time
19:47:32 <MrsB> We've neglected a bit the post-mortem so will be having one in the QA meeting this Thursday
19:47:52 <wilcal> QA needs extra help just before and after release because of the number of issues
19:48:14 <MrsB> It took us a long time to get back on top of the updates, around a month, with the help of several others
19:48:26 <wilcal> This process is not specific to Mageia it's common in any enterprise at the release of a new product
19:49:06 <wilcal> I've seen entire engineering departments turned into product testers just before release
19:49:25 <MrsB> we're now slowly working on a 4.1 release with updated packages, new kernel etc and also a fix for isolinux which stopped it booting for some people when burned to actual spinning disks
19:50:10 <MrsB> Unfortunately that and some intentional downtime has resulted in a bit of a backlog of updates again at the moment
19:50:45 <MrsB> We're prioritising the updates really for now
19:50:59 <wilcal> And some specific issues can consume some of your best people nearly 100% of their time
19:51:01 <MrsB> if anybody wants to lend a hand it would be very welcome
19:51:19 <MrsB> http://mageia.madb.org/tools/updates
19:51:21 <[mbot> [ Mageia App Db - Current Update candidates ]
19:51:42 <ennael> #info qa team has been overloaded just before and after release with isos testing and updates
19:52:02 <ennael> #action time has come again to give a hand to qa team for updates
19:52:34 <MrsB> We really need more people to regularly test updates, we tend to get on top of things and then have something else to do aswell and the updates suffer again
19:52:56 <ennael> any proposal for having more people ?
19:53:23 <MrsB> It's difficult. It's not interesting to most people it seems
19:53:37 <MrsB> at the same time though most people want it doen thoroughly
19:54:12 <sebsebseb> hi
19:54:17 <ennael> could we work on a blog post to explain the update process and how people can help ?
19:54:18 <DavidWHodgins> I sent a msg to the sysadmin mailing list, asking about changing ldap group setup for qa, so people could be more officially recognized, as being part of the team. No response yet from sysadmins.
19:54:52 <ennael> DavidWHodgins: basically tmb. in vacation but I can ping some people maybe
19:54:56 <MrsB> We do find alot of people join and then disengage when they find out more of what it entails. We could maybe make it clearer what to expect, but then it may not encourage people to join.
19:55:26 <MrsB> colin has been doing alot of ldap stuff recently
19:56:03 <wilcal> Also try to really make the test proceedures in the BUG as easy to follow as possible. We need a book in there "test proceedure for dummies"
19:56:27 <MrsB> I'll put some text together for a blog post, yeah, it might help. The interview I did last year (or year before) did help so publicity does work.
19:56:53 <ennael> yep
19:57:07 <ennael> maybe explain concretely what updates mean and how it's done
19:57:19 <MrsB> we could perhaps do a series of posts explaining the role of each team
19:57:28 <ennael> yep good idea indeed
19:57:45 <MrsB> saying how to get in touch and how people can help
19:57:57 <MrsB> and why we need help
19:57:59 <ennael> #action each team works on a blog post to explain what they are doing in Mageia project
19:58:03 <ennael> yep
19:58:36 <MrsB> It's always busy around release but I must say, mga4 was particularly so
19:59:21 <MrsB> We also lost John Bowden (Led43*) this month.
19:59:44 <ennael> yep...
19:59:55 <MrsB> He wasn't very active in QA but was always supportive and would help out in #mageia when he had a chance
20:01:09 <ennael> do you have any task, work, planning coming you would like to speak about?
20:01:13 <MrsB> Anything you'd like to add Dave, Bill ?
20:02:01 <DavidWHodgins> I kind of over did it during the 4.1 iso testing, so havn't been able to do much the last few days. Should be back to normal soon.
20:02:13 <MrsB> We don't tend to have projects in that way, QA is a bit unpredictable. It would be nice to find time to investigate some automated regression testing though.
20:03:33 <DavidWHodgins> While automated testing can be useful for some things, for most of the updates we get, it would probably cause more time spent on maintaining the testing procedures.
20:04:00 <MrsB> yes it's possible. I think alot could be automated though if there was a system in place to do it with
20:04:54 <ennael> would be nice to list exactly what you need if you know it
20:05:01 <coincoin> there was drakisocheck in the past it should be in SVN I guess
20:05:40 <ennael> it's :ore about installer or some packages
20:05:52 <ennael> maybe for updates also
20:05:52 <MrsB> thinking more for updates, something which would allow us to create testcases for various packages which could run automatically or could be manually triggered to run
20:06:17 <MrsB> iso testing would be difficult to automate as so much changes from one release to the next
20:06:41 <MrsB> stable updates should change less so would be viable i think
20:06:45 <ennael> maybe add this as a proposal in 2005 features
20:07:02 <MrsB> mga5 you mean :)
20:07:12 <ennael> oups
20:07:14 <MrsB> I'll do that yeah
20:07:16 * ennael slaps ennael
20:07:19 <ennael> thanks
20:07:42 <ennael> #action add a feature proposal for automated testing for qa
20:08:42 <MrsB> I think that's all
20:08:48 <ennael> ok thanks :)
20:08:51 <ennael> next team ?
20:10:39 <ennael> grenoya: would you like to speak about your current task in atelier ?
20:11:20 <grenoya> well, I joined atelier to help on the web part of the work
20:11:33 <ennael> #info atelier team review
20:11:35 <grenoya> filip__ and leuhmanu are working on it too
20:12:03 <MrsB> It's great to see :)
20:12:12 <ennael> so what is planned ? :)
20:12:15 <grenoya> filip__ organized us a meeting this week, so we can discuss about plans
20:12:15 * ennael is curious
20:12:29 <leuhmanu> we a meeting this week
20:12:31 <leuhmanu> +have
20:12:45 <sebsebseb> will that meeting be logged?
20:12:47 <sebsebseb> ?
20:12:51 <grenoya> the first thing to say is that filip__ already did a lot of changes to help localisation
20:13:17 <filip__> just a side note for now: conversion of www.mageia.org to gettext is done. so if you notice any bug. lang related or not please report them.
20:13:19 <grenoya> but we have to discuss about a new and common design for the pages
20:14:01 * grenoya 'd like to see someone from artwork at that meeting...
20:14:07 <ennael> #info conversion of www.mageia.org to gettext is done
20:14:53 * filip__ 2. please join us there
20:15:16 <MrsB> Maybe put a call out for artists on the forum
20:15:44 <sebsebseb> artwork?  what artwork sub team of Atelier?  its only really Donald/Shultz making stuff we something needs to be made etc
20:16:12 <grenoya> yeah! that's the main problem
20:16:16 <ennael> grenoya: maybe it's time to look for contributer on design web site for example
20:16:22 <MrsB> external forums (fr, br i think) produced alot of wallpapers which we found out about too late to use
20:16:35 <filip__> sebsebseb: we especialy need a good eye on current web design
20:16:51 <ennael> grenoya: also coling said he has a relative working in design maybe interested to contribute
20:16:59 <sebsebseb> and the website needs a re design.  hey I am in Atelier to, and I don't realy know hat you been making
20:17:15 <filip__> sebsebseb: do you read ML?
20:17:16 <grenoya> it's not only a question of wllpaper, but also time to redo the color panel(?) for Mga5
20:17:21 <sebsebseb> filip__: yep
20:17:47 <MrsB> I think now there's an active web team there to join people might feel more willing to do so
20:18:26 <MrsB> palette
20:18:36 <grenoya> MrsB: thanks :)
20:18:39 <MrsB> :)
20:18:49 <sebsebseb> I would be kind of interestd in Thursday web meeting myself  to an extent,  but  I'll  probably be at a  real in person  thing then.  So I hope it's logged at least :).
20:19:29 <filip__> sebsebseb: you're welcome with your suggestions
20:20:05 <sebsebseb> yeah
20:20:58 <grenoya> to sum up: new people would be ood, but even if you have only a good eye for color and design you're welcome :)
20:21:09 <filip__> +1
20:21:44 <ennael> anything else for web team ?
20:22:20 <grenoya> none from me
20:22:22 <MrsB> When is the meeting btw, did I miss that bit?
20:22:34 <filip__> Thursday 19 UTC
20:22:39 <sebsebseb> MrsB: I think it's on at hte same time as QA or pretty much
20:22:49 <MrsB> ahh ok thanks.
20:22:57 <leuhmanu> btw someone know if we can invite Inigo_Montoya ?
20:23:00 <ennael> #info web meeting will happen on Thursday 19 UTC for web team
20:23:18 <sebsebseb> also the meeting should  be in #mageia-atelier by the way :)  not that old web channel :d
20:23:57 <filip__> leuhmanu: indeed. the bot is missing
20:24:02 <ennael> #action ask sysadmin to get meetbot on the chan
20:24:44 <ennael> ok next team ?
20:24:56 <filip__> ennael: regarding those old channels. why do we keep them?
20:25:16 <ennael> no idea
20:25:30 <ennael> I do not even know who is managing it
20:25:40 <MrsB> rda maybe
20:25:43 <filip__> maybe coincoin?
20:26:05 <leuhmanu> those ?
20:27:17 <sebsebseb> yep everyone should leave the old channels including any bot, then they die
20:27:39 <leuhmanu> I know only -web
20:27:41 <ennael> ok let see that later then :)
20:27:55 <ennael> do we have docteam and i18n around?
20:27:57 <sebsebseb> leuhmanu: #mageia-atelier :)
20:27:58 <sebsebseb> next team
20:28:02 <MrsB> doktor5000: would you be able to add some publicity on the forums for atelier web team meeting please
20:28:24 <lebarhon> do you want to hear some bad news from docteam
20:28:36 <coincoin> I though it was already dead this channel. I will have a look for Inigo_Montoya on #mageia-atelier
20:29:02 <ennael> #info docteam team review
20:29:06 <ennael> lebarhon: your turn then
20:29:22 <lebarhon> well, docteam lost its captain and its padawan captain,
20:29:36 <ennael> who was the padawan ?
20:29:37 <lebarhon> both too busy in real life, so the boat is going nowhere in the fog...
20:29:53 <lebarhon> We miss Marja a lot
20:30:09 <ennael> well ok but it will not help at the moment :)
20:30:11 <lebarhon> Papoteur is the new leader and myself the deputy on an interim basis for now
20:30:21 <ennael> why not joining effort with i18n ?
20:30:30 <lebarhon> I think we need new election and new meeting schedule
20:30:47 <lebarhon> I suggested that long time ago
20:31:02 <ennael> maybe it's the right time now
20:31:15 <ennael> i18n people around tonight ?
20:31:16 <lebarhon> every doc member is also doc member
20:31:36 <ennael> i18n member ?
20:31:43 <lebarhon> Akien was there
20:31:50 * filip__ 2
20:32:17 <filip__> not much is going on in l10n team
20:32:39 <MrsB> is there a list of work that needs doing lebarhon?
20:32:47 <ennael> filip__: what do you think about joining efforts?
20:33:11 <lebarhon> MrsB: We need help to finish the MCC help
20:33:25 <filip__> we'll have a meeting soon but right now I don't remember when exactly
20:33:32 <lebarhon> we need for that people having exotic hardware and network skills
20:34:07 <filip__> there are some common points like translation but doc team also produce docs
20:34:08 <ennael> ok maybe we can organize a common meeting to speak about this?
20:34:14 <leuhmanu> Last time I saw a page about security in the classical installer
20:34:41 <leuhmanu> I feel to the need to write something that nobody will see
20:34:41 <ennael> joining efforts is about organization and maybe ease the link between writting doc and translating it
20:34:46 <leuhmanu> s/the/see
20:35:38 <lebarhon> Writting doc is the problem
20:36:10 <filip__> ennael: it's a good suggestion but I can't do everything
20:36:12 <lebarhon> And doc should be proofread by dev
20:36:37 <ennael> I can give a hand to organize that meeting if needed
20:37:09 <MrsB> Are there specific bits which you can point to, it would help people to help writing if there was something to point them to
20:37:15 <filip__> ennael: that would be nice
20:37:27 <ennael> ok
20:37:45 <MrsB> a list of page titles or parts of mcc not yet covered
20:37:59 <ennael> #action ennael will give a hand to organize a common meeting for i18n and docteam to join efforts
20:39:31 <lebarhon> here is the work to be done https://wiki.mageia.org/en/Calenco_Draktools
20:39:53 <ennael> #action pending work for docteam https://wiki.mageia.org/en/Calenco_Draktools
20:41:06 <ennael> ok anything else for docteam?
20:41:34 <lebarhon> I think not
20:41:40 <ennael> thanks
20:41:51 <ennael> some words for i18n ?
20:43:26 <filip__> I already report some
20:43:58 <filip__> we'll have a meeting soon but right now I don't remember when exactly
20:44:07 <ennael> ok
20:44:28 <filip__> we do miss Yuri
20:44:38 <lebarhon> yes indeed
20:46:12 <ennael> ok anything else ?
20:46:23 <lebarhon> Any news about the multilanguage wiki ?
20:48:12 <ennael> not for now. Let's ping guys about it
20:48:28 <ennael> #action send a reminder for sysadmin team about multilanguage wiki
20:50:04 <lebarhon> What about Solutions Linux in Paris, who is comingĀ ?
20:50:24 <ennael> will send a mail on ML
20:50:47 <ennael> any other team than packagers?
20:50:52 <Luigi12_work> I've been summoned
20:50:52 <MrsB> sec team
20:50:56 <MrsB> :D
20:50:58 <wilcal> Hi ya Luigi
20:51:00 <ennael> erf
20:51:03 <ennael> ok let's go
20:51:10 <ennael> #info secteam review
20:52:00 <Luigi12_work> ok, so officially the team is myself and Oden.  I'm getting busier at work again, and Oden is now working for skysql ab, the mariadb company, so he has very little time to work on security stuff anymore
20:52:20 <MrsB> it's alot of work
20:52:21 <Luigi12_work> at least in some cases, we absolutely need more support from packagers, or some updates won't happen
20:52:37 <Luigi12_work> some packagers are very good and responsive and helpful, so it just varies
20:53:04 <Luigi12_work> but with complicated packages that are well-maintained in Cauldron, sometimes we need support from those packagers
20:53:15 <ennael> so this is a topic for next packager meeting
20:53:26 <ennael> and also a mail on -dev
20:53:38 <Luigi12_work> well I've raised this issue in the last packager meeting, as well as on the -dev list several times
20:53:52 <ennael> not with all these details
20:54:06 <ennael> let us do it this time with matches
20:54:08 <Luigi12_work> one packager in particular I'm concerned about has been good in the past about this, and has recently stopped supporting stable releases completely it seems, with no notice
20:54:21 <Luigi12_work> I've even tried e-mailing directly with no response
20:54:27 <ennael> ok
20:55:36 <MrsB> could you provide some flame related backup ennael
20:55:52 * leuhmanu add some tags on bugs for pkg that should be dropped if nothing change for next release
20:56:18 <Luigi12_work> yes that's a good point leuhmanu
20:56:37 <Luigi12_work> there are many packages that probably should be proposed to be dropped, but we'll ahve to figure out how to organize this
20:56:50 <leuhmanu> (but I have only two for now )
20:57:40 <ennael> ok  that's a proposal
20:58:30 <Luigi12_work> oh I almost forgot, we have no bugzilla packager
20:58:40 <Luigi12_work> I guess Olav used to be or someone was
20:58:51 <leuhmanu> it was olav yes iirc
20:59:12 <Luigi12_work> so bug 10897 is stuck, guillomovitch even made a suggestion, but there's nobody to implement it
20:59:31 <ennael> ok can we keep this for tomorrow's meeting?
20:59:40 <Luigi12_work> I won't be there
20:59:53 <Luigi12_work> in fact I'll miss most meetings the next couple months due to track meets on Tuesdays
21:00:13 <Luigi12_work> almost forgot to mention that too
21:00:22 <ennael> ok but we have the topic now and items to wpeak about it
21:02:04 <coincoin> olav and dmorgan
21:02:35 <Luigi12_work> olav is still around working on gnome stuff, but dmorgan has disappeared
21:03:17 <ennael> ok next team now
21:03:31 <MrsB> thanks Luigi12_work
21:03:36 <ennael> #info packagers team
21:03:38 <Luigi12_work> yep, see ya
21:03:47 <MrsB> o/
21:04:52 <ennael> ok so packagers team is now working on Mageia 5 and not enough on updates (this will be discussed in next meeting)
21:05:18 <ennael> features are in progress and we are starting reviewing it with malo so that we can freeze official features
21:06:58 <ennael> meeting is planned tomorrow and every 2 weeks also
21:07:49 <ennael> we will start again also the mentoring program as malo should be back this week
21:08:06 <lebarhon> What are the topics for tomorrow ?
21:08:09 <MrsB> great, that works really well
21:09:05 <ennael> we are trying also to start a team to work on drakx*
21:09:25 <ennael> and have more people on it to avoid bottleneck as we have since the beginning
21:11:33 <MrsB> we've needed that team I think. There have been people ask what they can do programming stuff.
21:12:36 <MrsB> it would be good to formalise it as a team
21:12:59 <ennael> yep things are just starting so give us some time for it :)
21:13:04 <MrsB> yeah
21:14:53 <malo> ennael: just slowly back :-)
21:15:04 <MrsB> morning malo
21:15:17 <ennael> malo: quick so that I can leave for vacation :p
21:15:24 <malo> ennael: :-)
21:15:33 <ennael> ok so that's all for now for packagers
21:16:35 <MrsB> thanks ennael
21:17:02 <MrsB> forums guys are not around tonight
21:17:26 <MrsB> sysadmins too
21:17:40 <ennael> so I guess that's all for teams
21:17:53 <MrsB> shall we wrap up
21:18:07 <ennael> as we already spoke about mageia 5 and blog we could stop meeting for tonight
21:18:16 <wilcal> I'd like to have a brief chat with coincoin after the meeting
21:18:18 <ennael> before we all fall asleep
21:18:32 <MrsB> yeah it's starting to get quiet
21:18:39 <ennael> :)
21:18:45 <ennael> so thanks all for attending
21:18:52 <MrsB> thanks for hosting :)
21:18:53 <ennael> and see you in 2 weeks here
21:18:55 <leuhmanu> THANKS ennael !
21:19:00 <grenoya> thanks for leading! :)
21:19:00 <wilcal> thks ennael
21:19:05 <DavidWHodgins> Thanks ennael!
21:19:07 <ennael> #endmeeting