20:39:30 <ennael> #startmeeting
20:39:30 <Inigo_Montoya> Meeting started Mon Mar 10 20:39:30 2014 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:39:30 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:39:56 <ennael> hi all and thanks for attending
20:39:59 <sebsebseb> hi
20:40:13 <MrsB> hi :)
20:40:21 <ennael> #topic legal and privacy
20:40:37 <ennael> ok first topic following recent discussions on MLs
20:41:11 <DavidWHodgins> My opinion, drop the tracking.
20:41:13 <ennael> about legal aspect you may have seen mails today about it
20:41:22 <ennael> about CNIL registration
20:41:43 <sebsebseb> I read some even
20:41:49 <MrsB> Didn't fully understand it. It sounded like we don't need to register for certain things but do for others
20:41:55 <ennael> yes
20:42:03 <ennael> so french law says
20:42:26 <ennael> if you are an association and database is *only* about members management then you don't have to register
20:42:55 <trishf42> what are our criteria for membership?
20:42:57 <MrsB> registering means what? having an 'information' official?
20:43:13 <trishf42> if our criteria are that you get a Mageia identity, then...
20:43:17 <ennael> trishf42: membership is you are registered as a member of Mageia.Org
20:43:23 <ennael> association
20:43:37 <trishf42> how does a person register as a member?
20:43:50 <ennael> a form, some fees maybe sometimes
20:44:00 <ennael> and they attend vote and general assembly
20:44:00 <Akien> trishf42: It's part of the statutes, when you are council member and so on
20:44:04 <ennael> yes
20:44:08 <trishf42> ok
20:44:10 <Akien> trishf42: Normal users are not part of Mageia.Org
20:44:10 <DavidWHodgins> So if we drop the tracking, from the websites, everyone we do keep info on would be considered a member.
20:44:14 <ennael> it's a legal membership if I can say it
20:44:20 <trishf42> ok
20:44:29 <ennael> our database is not
20:44:31 <Akien> DavidWHodgins: Not quite.
20:44:49 <ennael> it's about users and access to our applications
20:44:49 <trishf42> so that means, ppl who have only a Mageia identity are *not* members unless they have also completed the registration process
20:44:49 <Akien> There are Mageia.Org association members (current and former council members mostly)
20:45:10 <ennael> so all about bugzilla, bs, wiki, forums...
20:45:24 <Akien> And we have identity.org members who are not part of the association. Their data should be declared.
20:45:34 <trishf42> which means, we have to disclose what details we are keeping on non-members and what they have to do to get that changed or removed
20:45:38 <trishf42> ?
20:45:47 <ennael> np npt for now
20:45:49 <DavidWHodgins> Doesn't getting a mageia identity require completing the registration process?
20:45:54 <ennael> oups no not for now
20:46:10 <trishf42> DavidWHodgins: no
20:46:11 <ennael> please not all at same time :) it's getting hard to follow and answer :)
20:46:25 <Akien> Put in a simpler way, the exception for declaration is only made so that normal associations don't have to declare their keeping track of who's a member of the association
20:46:40 <trishf42> ok
20:46:45 <Akien> But in our case Mageia.Org is just a small part of the Mageia ecosystem
20:46:50 <ennael> so I've checked it by phone this morning with CNIL
20:46:56 <ennael> to be sure about all this
20:46:57 <Akien> What we have to declare, as any website, is the user data we collect on anyone
20:47:16 <ennael> and they confirm it
20:47:16 <MrsB> declare to cnil or declare to users?
20:47:32 <ennael> we are speakng about legal aspect
20:47:37 <ennael> let me finish :)
20:47:54 <ennael> so first step is to declare all aspects of this to CNIL
20:48:14 <ennael> they check all what was filled and if needed they contact us to get some more information
20:48:18 <ennael> that is for CNIL
20:48:42 <ennael> this declaration makes an obligation for us to inform users about their personal data
20:48:59 <ennael> explaining why we got these data
20:49:06 <ennael> and how they can modify/remove it
20:49:26 <ennael> this is the text added in my mail this morning
20:49:41 <ennael> it does not have to be very long and detailed but it has to be done
20:49:48 <ennael> and including a contact inside
20:50:08 <MrsB> Will we need to appoint another official?
20:50:15 <ennael> once the registration is finalized with CNIL they will send us a registration number to be added in this page
20:50:22 <ennael> MrsB: nope
20:50:27 <ennael> that's all
20:50:35 <ennael> so that's not that complicated
20:50:37 <DavidWHodgins> What about forum posts, and mailing list articles, that cannot be deleted, without breaking threading?
20:51:18 <MrsB> I would think that as long as it's stated it can't be removed then it's covered
20:51:21 <ennael> DavidWHodgins: unfortunately on that point it's "just" a technical detail
20:52:14 <DavidWHodgins> I also just checked, and most of the mageia sites also store cookies on the user's system.
20:53:15 <MrsB> This should really have been handled at board level.
20:53:35 <ennael> MrsB: basically it is.
20:53:45 <MrsB> yeah spose so :)
20:53:48 <ennael> what we need now is some texts to be added on web site
20:53:56 <ennael> as said in my mail this morning
20:54:12 <ennael> and I would like some help from web/marcom team
20:54:16 <MrsB> We will need to identify exactly what data is collected first I think
20:54:20 <ennael> and english proofreading
20:55:22 <MrsB> unless just a general 'information provided at time of registering is used o enable login to mageia websites' type text
20:56:10 <ennael> yes as said in mail...
20:56:17 <ennael> here is an example
20:56:18 <ennael> http://www.cnil.fr/vos-obligations/informations-legales/?tx_cnilmention_pi1%5Bprofil%5D=11&tx_cnilmention_pi1%5Bmodele%5D=17&tx_cnilmention_pi1%5Bsubmit2%5D=Valider
20:56:19 <[mbot> [ Modèles de mentions légales - CNIL - Commission nationale de l'informatique et des libertés ]
20:56:22 <ennael> sorry it's french
20:56:24 <DavidWHodgins> Many users can view the site without an id, so we have to ensure we disclose what info is collected for them too, and what cookies are stored on their systems.
20:56:34 <trishf42> ok, we can help sort that out - will we still use the "privacy policy" wiki page?
20:56:48 <trishf42> and put a link from the website?
20:56:56 <trishf42> or do a whole new page?
20:57:17 <Akien> Maybe we should keep the "Privacy policy" name, but redo the whole content, to have something way shorter and simpler
20:57:31 <Akien> * Information collected
20:57:33 <Akien> * What for
20:57:42 <Akien> * How to access/modify them
20:57:47 <DavidWHodgins> We need to clearly identify what is collected, what is stored in cookies, and what it is used for.
20:57:50 <MrsB> * Who to contact
20:58:02 <MrsB> I think that's a good idea akien
20:58:30 <ennael> ok then Akien is doing it :)
20:58:34 <MrsB> :D
20:58:48 <Akien> ;)
20:58:56 <MrsB> I'm happy to help with this
20:59:01 <ennael> ok
20:59:21 <Akien> I'm okay to do a first draft (since I already started listed some data on the ML)
20:59:28 <ennael> #ino Akien and MrsB will work on a wiki page to clearly identify what is collected, what is stored in cookies, and what it is used for.
20:59:37 <MrsB> I can until wednesday anyway, then away for the weekend
20:59:42 <Akien> Maybe DavidWHodgins can provide some input about what is the content of those cookies
20:59:49 <trishf42> I can help off and on
21:00:11 <Akien> In the meanwhile, we can add the legal mention on the website
21:00:21 <trishf42> might need keeping in line as my experience is all in Oz privacy law
21:00:25 <ennael> legal mention is *the* priority
21:00:39 <DavidWHodgins> Most of the content of the cookies is meaningless to me.
21:00:54 <ennael> please this is not the question for now
21:01:11 <Akien> ennael: What should be the legal contact?
21:01:11 <ennael> we need this legal mention this is the very minimum requirement
21:01:17 <Akien> board alias?
21:01:24 <ennael> Akien: I gues so
21:01:27 <ennael> guess
21:01:51 <ennael> then when wiki page is done we can add all the way to modify/remove data
21:02:30 <tmb> and what data cant/wont be removed
21:02:38 <ennael> yesp
21:02:40 <ennael> yep
21:02:41 <Akien> Sounds good. Your draft on the ML was good, it just needs some defrenglishisation
21:02:52 <ennael> yes
21:03:00 <ennael> can this be done before end of this week ?
21:03:06 <Akien> s/isaction/ification/ ? :D
21:03:47 <MrsB> I didn't see a draft :\
21:03:57 <Akien> It's quite small, so maybe trishf42, MrsB, DavidWHodgins can have a look at it this evening, and then filip_, leuhmanu and/or I will add it to the website
21:04:10 <trishf42> do a pad?
21:04:12 <ennael> this is based on CNIL proposal
21:04:17 <MrsB> Oh i see what you mean, yes
21:05:09 <Akien> Here it is: http://bn.parinux.org/p/mgalegal
21:05:10 <[mbot> [ Etherpad Lite ]
21:05:14 <filip_> DavidWHodgins: if we drop GA a lot of cookies will go away ;)
21:05:35 <DavidWHodgins> Good
21:05:35 <Akien> Maybe we should go on and not proofread it right now, though
21:05:42 <ennael> yep
21:05:51 <ennael> ok so legal part is done
21:05:56 <ennael> let see about GA
21:06:20 <ennael> looking at answers by mail it seems everybody agree on removing it
21:06:45 <MrsB> perhaps we should do that at the same time
21:06:47 <DavidWHodgins> I certainly do. I've aliased it to 127.0.0.1 for many years.
21:07:12 <ennael> ok. Who can do this with proper access rights?
21:07:44 <Akien> Ah I thought you spoke about removing the General Assembly at first :-o
21:08:01 <ennael> tsss
21:08:11 <ennael> google analytics
21:08:28 <filip_> I can remove it from www.mageia.org
21:08:46 <filip_> but probably not others
21:09:21 <tmb> and blog admins can probably nuke it from blogs iirc
21:09:45 <MrsB> that leaves the wiki
21:10:00 <sebsebseb> GA can be useful  depending on how it' used,  oh and  have some publi stats without IP's or something, if going to be so fussy about stuff like that :D I have seen that on sites before
21:10:37 <trishf42> sebsebseb: there's not enough people to analyse the data and make use of it, so it's wasted anyway
21:10:51 <trishf42> and people objected to being tracked
21:10:52 <sebsebseb> could be useful to know how many hits the pages get for example, it's the personal  stuff like ip addreses that people  may not be keen on going in any stats on any website and cookes as well
21:11:09 <MrsB> removing it should speed the websites up too :)
21:11:47 <ennael> removed from blog en and fr
21:12:19 <ennael> #action filip_ removes GA from www.mageia.org
21:12:32 <ennael> #action ennael removed GA from blogs en and fr
21:12:50 <ennael> what about wiki ?
21:13:15 <MrsB> it'll need some sysadminning
21:13:31 <tmb> I can probably dig into it and nuke it...
21:14:30 <DavidWHodgins> wiki doesn't seem to be using ga.
21:14:44 <filip_> there is also one important question: what to do with existing data?
21:14:52 <sebsebseb> why is there all this fuss about QA etc, I only read some emails
21:14:58 <filip_> I don't have rights for nuke it
21:15:05 <filip_> rda have them afaik
21:15:29 <ennael> he is in vacation. I can ping him when he is back
21:15:56 <tmb> filip_, since you have access to the data, can you check and list all pages/sites tracked by GA ?
21:16:08 <sebsebseb> GA above interesting, although there's always something QA to :d
21:16:21 <MrsB> only good things sebsebseb :)
21:16:21 <sebsebseb> interesting typo,  whatever I am going to eat :)
21:16:27 <tmb> filip_, just so we dont miss any
21:16:39 <filip_> tmb: just a minute
21:16:46 <ennael> #action filip_ will list all web sites that uses GA
21:16:55 <ennael> #undo
21:16:55 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x8382a4c>
21:16:59 <ennael> #action filip_ will list all web sites that use GA
21:17:13 <MrsB> wiki does, it shows in ghostery
21:17:39 <leuhmanu> well wiki, blog, bugzilla needs admins action
21:17:55 <leuhmanu> for the rest removing the code from analytics.php
21:17:57 <filip_> GA is on www, wiki and bugzilla
21:18:13 <MrsB> are you sure it's on bugzilla?
21:18:29 <filip_> it seems that it's not used
21:18:54 <leuhmanu> it throught is was added one day
21:18:59 <filip_> but is used on the other two
21:19:04 <MrsB> yep
21:19:56 <tmb> ok, I'll take care of wiki
21:20:12 <ennael> #action tmb will remove GA from wiki
21:21:35 <DavidWHodgins> May have to search through the pages. I see it's on the main page, but not on individual pages that I was previously looking at.
21:23:36 <DavidWHodgins> Btw, at least one of the responses agreeing to dropping the user trapping got put into my spam filter by gmail.
21:24:02 <MrsB> conspiracy theory?
21:24:12 <ennael> ok can we switch to next topic?
21:24:18 <DavidWHodgins> Yep
21:24:35 <filip_> DavidWHodgins: greylisting issues
21:24:54 <filip_> I see GA required on 72 pages :(
21:24:59 <MrsB> ok for me ennael, thnaks for covering this and doing the leg-work
21:25:06 <ennael> no pb
21:25:13 <filip_> that's including all localized html pages
21:25:22 <ennael> just hope this will also help to get people cooler :)
21:25:26 <ennael> #topic Mageia 5: planning and specifications
21:25:39 <ennael> so let speak about mageia 5
21:25:52 <DavidWHodgins> 14 days till feature proposals cut-off
21:26:54 <ennael> so about planning
21:26:59 <ennael> as a reminder
21:27:02 <ennael> alpha1 2014/06/03
21:27:02 <ennael> alpha2 2014/07/08
21:27:02 <ennael> alpha3 2014/08/04
21:27:02 <ennael> Versions freeze 2014/08/09
21:27:02 <ennael> New Strings freeze 2014/08/09
21:27:04 <ennael> Distro rebuild 2014/09/15
21:27:07 <ennael> beta1 2014/09/30
21:27:10 <ennael> beta2 2014/10/31
21:27:12 <ennael> translations freeze 2014/10/27
21:27:14 <ennael> releases freeze 2014/10/28
21:27:17 <ennael> RC	2014/11/21
21:27:20 <ennael> internal release 2014/11/12
21:27:22 <ennael> final release	2014/12/19
21:27:39 <sebsebseb> yeah over 9 months
21:28:04 <Akien> RC for my birthday! \o/
21:28:22 <ennael> I will update the wiki just after meeting
21:28:24 <tmb> Akien, dont worry we will miss it :)
21:28:25 <filip_> Akien: dream on
21:28:28 <sebsebseb> Akien: unless delayed of course :d
21:28:30 <Akien> Hehe
21:29:17 <MrsB> releasing just before xmas could be interesting. If we have to postpone we may struggle getting people to invest their time
21:29:19 <sebsebseb> beta 2 for Halloween we'll see, the witches and zombies and vampires etc, made Mageia quite delayed when was going to have a mile stone for Halloween last time
21:29:52 <ennael> MrsB: if this happens we can postpone it after new years day
21:30:07 <tmb> MrsB, well, it might be ready for FOSDEM :)
21:30:15 <MrsB> That'll be a year :O
21:30:22 <ennael> :)
21:30:24 <sebsebseb> yeah true, but would be nice to have the final released in 2014 :)  and idealy without a re done of the final ISO's to :d
21:30:35 <ennael> so any comment on planning?
21:30:50 <DavidWHodgins> For Mageia 5, I think we should be more worried about getting it right, then getting it on time, but still has planned dates, for people to try and meet.
21:31:02 <tmb> no, I think its ok for now.
21:31:03 <DavidWHodgins> s /has/have/
21:31:16 <DavidWHodgins> Otherwise, looks fine to me.
21:31:17 <ennael> so specifications
21:31:18 <MrsB> Only that we need to stick to it this time  (famous last words!)
21:31:38 <tmb> DavidWHodgins, yeah, thats more what we plan, but we always need some timelines or we will start competing with debian :)
21:31:43 <sebsebseb> sure and getting in the correct upstream verisons of  this and that as well :d   GNOME 3.14 for example well that should be September, that's what I mean.
21:31:47 <MrsB> We need to aim to be feature complete-ish by the end of alphas or beta1 at latest
21:31:58 <ennael> deadline for proposals is 25th of march
21:32:00 <DavidWHodgins> Not many features proposed so far, so main thing will be syncing with upstream versions, where possible.
21:32:09 <ennael> as a reminder specifications can be non technical one
21:32:19 <ennael> so feel free to spread it in all teams
21:32:38 <MrsB> We should try to get people from forums involved too
21:33:33 <ennael> do we have forum guys around?
21:34:10 <MrsB> doktor5000_: if you're around ^^
21:34:12 <filip_> they are MIA ;)
21:34:20 <ennael> MIA ?
21:34:29 <DavidWHodgins> missing in action
21:34:40 <ennael> arf ok :)
21:34:42 <tmb> or short for miau :)
21:35:00 <ennael> :)
21:35:04 <doktor5000_> MrsB: yo
21:35:09 <MrsB> yo ! :)
21:35:20 <DavidWHodgins> Not missing now. :-)
21:35:30 <tmb> NMIA ?
21:35:49 <doktor5000_> ennael: sorry, specifications for mga5 ? or what was the topic? * sorry long work day * :/
21:35:59 <MrsB> Could you spread the message about feature suggestions to the forums please
21:36:10 <doktor5000_> MrsB: will do
21:36:39 <ennael> thanks :)
21:36:46 <doktor5000_> should be enough for an explanation to link to https://wiki.mageia.org/en/Features_policy ?
21:36:51 <DavidWHodgins> tmb: Present and accounted for. :-)
21:37:29 <MrsB> Yes, basically. Deadline is 24th/25th March - so a couple of weeks
21:37:47 <MrsB> was 24th in the email
21:38:47 <DavidWHodgins> ennael: Looking at planning above, internal release is before RC?
21:39:13 <Akien> internal release is meant on 2014/12/12 I guess
21:39:16 <ennael> should be 12/12
21:39:23 <ennael> thanks for the notice
21:40:27 <MrsB> I'll send a reminder to QA list tomorrow
21:40:34 <ennael> thanks
21:40:38 <DavidWHodgins> coling: Any plans for major systemd changes in Mageia 5?
21:40:48 <ennael> anything else on that topic ?
21:41:12 <DavidWHodgins> Not here.
21:41:32 <Akien> Nothing here, I'll remind to l10n that they should have a look at this.
21:41:40 <ennael> ok
21:41:48 <ennael> #topic teams and board vote
21:42:41 <ennael> ok so we also have to organize vote in all teams
21:42:41 <DavidWHodgins> Qa team added a second deputy leader - wilcal.
21:42:52 <ennael> yep nice to see him
21:43:00 <ennael> what about other teams?
21:43:47 <doktor5000_> ennael: MrsB: so that I don't forget: https://forums.mageia.org/en/viewtopic.php?f=29&t=7182
21:43:48 <[mbot> [ Mageia forum View topic - Feature planning for Mageia 5 ]
21:44:07 <ennael> thanks :)
21:44:18 <doktor5000_> everybody feel free to proofread :)
21:44:41 <MrsB> looks good doktor5000_
21:44:49 <filip_> in I10n team we lost Yuri due to his country situation. Akien and I received some votes.
21:45:04 <ennael> welcome in hell :)
21:45:27 <Akien> ennael: We were already there :p
21:45:33 * doktor5000_ notes that for forums team there have been no votes yet - due to lack of time partly :/
21:45:38 <ennael> Akien: but new year :)
21:45:46 <ennael> doktor5000_: ok
21:46:07 <doktor5000_> ennael: we have have a vote, but there are no candidates really, maat me and isadora - we can shuffle around if that helps :/
21:46:19 <ennael> for packagers, we will start votes tomorrow
21:46:22 <trishf42> Atelier is still undecided...
21:46:29 <ennael> looks so
21:46:35 <ennael> trishf42: you can ping grenoya
21:46:43 <trishf42> I can?
21:46:49 <ennael> whe told me whe wanted to help marcom
21:46:55 <ennael> rather on web side
21:47:05 <trishf42> ok, that would be cool
21:47:06 <ennael> maybe she can help on team more genrally
21:47:17 <ennael> don't tell her I told you :)
21:47:21 <trishf42> but we still don't have anyone else who can/will step up as leader
21:47:37 <trishf42> ennael: you know these minutes are public, yes? 8-)
21:47:52 <tmb> ennael, meeting is logged so she will know :)
21:48:00 <trishf42> so far I've received the only nominations
21:48:09 <ennael> trishf42: they are ? :p
21:48:31 <trishf42> ennael: alas...
21:48:54 <tmb> ennael, of course if you briba a sysadmin the logs might "disappear" :)
21:48:58 <DavidWHodgins> I think it's pretty safe to assume the people nominating you will also vote for you, when the vote is held.
21:49:06 <ennael> tmb: han :)
21:49:16 <DavidWHodgins>21:49:25 <ennael> on board side we need to renew one third of it
21:49:36 <Akien> trishf42: We still have to hear from Schultz though
21:49:55 <trishf42> Akien: he's gone to ground, I think he felt an election coming
21:50:00 <ennael> as some people do not want to candidate again we will need some fresh blood or reduce the number of people inside
21:50:25 <MrsB> I vote for blood
21:50:37 <ennael> :)
21:50:38 <trishf42> MrsB: good luck with that
21:50:42 <tmb> fresh ore reduced ?
21:50:55 <trishf42> been voting for atelier blood for a while, no results
21:51:30 <DavidWHodgins> What does the board do, that isn't normally visible to the council?
21:51:34 <MrsB> it's difficult to keep the energy going sometime trishf42
21:51:56 <trishf42> MrsB: the more so when my own life is way overcrowded
21:52:31 <MrsB> It's should handle legal and official side of things Dave.
21:52:48 <tmb> DavidWHodgins, https://wiki.mageia.org/en/Org#Mageia_Board
21:52:49 <ennael> DavidWHodgins: it's rather formal part: general assembly, legal part, financial report
21:53:52 <DavidWHodgins> As there is no way I can make it to the general assembly, can I still volunteer?
21:54:07 <MrsB> I'm a bit the same dave, so yes
21:54:41 <tmb> DavidWHodgins, but most of the stuff we have managed to handle at council level so not much extra work usually
21:54:59 <DavidWHodgins> As I am feeling much better now (lot's of sunshine lately is helping), I'm willing to volunteer then.
21:55:15 <ennael> ok
21:55:20 <MrsB> :)
21:55:36 <tmb> ennael, one thing... does treasurer have to be from france ?
21:55:49 <ennael> DavidWHodgins: can you send a mail to board-public we will moderate it, to candidate
21:56:07 <DavidWHodgins> Sure
21:56:11 <ennael> tmb: not really even if there are some relation with bank for example
21:56:11 <tmb> (given that organization home, accounts and mailing address are there)
21:56:22 <ennael> but I have to check to be sure
21:56:40 <doktor5000_> FWIW I also felt free to add https://wiki.mageia.org/en/Mageia_5_Development
21:56:55 <tmb> ennael, ok
21:58:14 <ennael> ok there is no need to be french to apply for it
21:58:16 <DavidWHodgins> ennael: Email sent to board-public ml.
21:58:29 <ennael> so non french can apply
21:59:23 <ennael> so if some people here want to apply please send a mail to board-public before end of this week
21:59:52 <DavidWHodgins> I find http://translate.google.com/ works pretty well. :-)
21:59:53 <[mbot> [ Google Translate ]
22:00:22 <MrsB> #info Anybody wishing to candidate to join the board please send a mail to board-public before the end of the week
22:01:00 <ennael> thanks :)
22:01:10 <ennael> anything else to add ?
22:01:53 <tmb> nope
22:02:04 <MrsB> The more active board members we have, the greater separation there can be between legal board issues and day to day running.
22:02:07 <DavidWHodgins> Not on that topic, though I'd like to add a topic later.
22:02:44 <ennael> ok
22:03:02 <ennael> about artwork I would like to suggest to speak about it on ML
22:03:25 <ennael> the only thing is about finding a victim^w^wdesigner soon enough
22:03:37 <DavidWHodgins> That may have to wait till after their election
22:03:56 <trishf42> the Atelier Election: ringside tickets available, cheap
22:04:05 <DavidWHodgins> :-)
22:04:18 <ennael> :)
22:04:28 <trishf42> the main thing I want for Atelier is some SPACE (not apologising for shouting - it's been a long time coming)
22:04:29 <DavidWHodgins> I'm one of those people who doesn't care much what things look like, as long as it works.
22:04:32 <MrsB> There were late contributions on external forums last time. It would be good to get a central .mageia.org place for artwork to be uploaded.
22:04:54 <ennael> #topic sysadmin needs for teams
22:04:56 <tmb> what, no vip (or vuip) tickets ?
22:05:16 <Akien> ennael: I'll ping a relative who is a recently graduated designer, he might be interested to add a mention to a project such as Mageia to his portfolio :)
22:05:20 <ennael> this was a topic proposed on list
22:05:22 <trishf42> so, SPACE. We've tried sysadmin, devel, council, various and assorted individuals, but it keeps falling off the list.
22:05:24 <DavidWHodgins> tmb: Can you and/or colin setup a git repo for atelier?
22:05:32 <trishf42> Today if possible
22:05:41 <trishf42> and send some people info on how to get at it
22:05:41 <ennael> - Versioned storage space for atelier's files / unversioned storage
22:05:43 <ennael> space for docteam's PDFs and EPUBs
22:05:56 <trishf42> we'd like some unversioned space too
22:06:18 <MrsB> maybe something like owncloud could be configued to fulfill all those needs?
22:06:29 <DavidWHodgins> Perhaps a private ftp server too?
22:06:46 <trishf42> forget owncloud. We've been down that path - we're wanting proper, official, Mageia space. Like we actually belong...
22:07:06 <MrsB> owncloud can be hosted on mageia servers
22:07:14 <trishf42> We're currently using part of my dropbox - did you know, I now have 54GB free space because of Mageia artwork?
22:07:32 <MrsB> it can take ldap auth too i believe
22:07:41 <trishf42> Whatever we get, we need sysadmin support to get up and running, and to help people find out how to use it
22:07:46 <coling> Last time I looked into it there was no proper groups setup for atelier so we couldn't make it work.
22:08:02 <Akien> coling: That's easily fixed though, no?
22:08:33 <MrsB> mediagoblin is maybe another possibility
22:08:36 <Akien> I mean, create a mga-atelier LDAP group, but maybe you meant more than that
22:08:54 <coling> I think I asked for a list at some point, but I forget where it is/if I got it. I can look into it tomorrow if someone can give me a list of the usernames
22:09:13 <trishf42> Could someone please take this on board and own it? Discussion is lovely, but it hasn't helped us for almost 4 years
22:09:20 <coling> Just mail me and I'll try and puzzle it out.
22:09:41 <tmb> we seem to have mga-artwork group
22:09:54 <DavidWHodgins> Which groups were merged to form teh atelier group? Can't the ldap names from those groups be merged into a new atelier group?
22:10:10 <MrsB> I was thinking something more general, where any registered user can contribute potential artwork, same as they can use bugzilla
22:10:44 <Akien> DavidWHodgins: marcom, artwork and web
22:10:49 <MrsB> it would help to bring contributions from the external forums somewhere where everybody could see them
22:10:59 * coling isn't really here right now so mail me if you have a specific thing I can have a poke at tomorrow.
22:11:23 <DavidWHodgins> coling: The sooner the better. Thanks!
22:12:07 <Akien> MrsB: I agree. It would be nice to have both a private space for a given LDAP group, and a "public" space for any Mageia users (registered on identity)
22:12:40 <tmb> and who will monitor so people dont upload crap ?
22:12:49 <Akien> So that we can tell people: please share your artwork on e.g. files.mageia.org/artwork/background
22:13:04 <Akien> A filesquad team? :p
22:13:22 <DavidWHodgins> Perhaps an ftp server, where atelier members can review uploads, before moving them to public space?
22:13:23 <filip_> coling: http://people.mageia.org/g/
22:13:24 <[mbot> [ people.mageia.org: g ]
22:13:46 <MrsB> It would be linked to identity, accounts can be closed as with bugzilla/wiki
22:15:07 <tmb> MrsB, yes, but someone still need to be monitoring so we catch it and lock accounts if needed
22:15:23 <DavidWHodgins> coling: Can you discuss it with the people on the atelier mailing list, and get something done soon?
22:15:33 <MrsB> flickr was used previously, that was as open to abuse but we would have had less control over it
22:15:38 <Akien> tmb: I think it could be part of atelier's attributions
22:15:40 <trishf42> Is there a way to get it to email people a notification if something gets uploaded?
22:15:47 <MrsB> yes atelier probably
22:15:52 <trishf42> if so, Atelier could monitor our own space, no problem
22:16:12 <trishf42> we're all in different timezones, but that won't matter if we get notifications
22:16:33 <Akien> I think the docteam storage need can be covered the same way (and maybe just under Atelier's coordination, if it's simpler LDAP group-wise)
22:16:59 <trishf42> I'd be happier if docteam monitored their own stuff
22:17:11 <MrsB> it could even use a default ldap group which could be removed if abused
22:17:13 <trishf42> we're a tiny group with three areas of responsibility already
22:17:33 <Akien> trishf42: I mean use the same server space, with a doc branch and an atelier branch
22:17:47 <trishf42> Akien: ok, I see
22:18:06 <MrsB> tmb wdyt?
22:18:09 <Akien> trishf42: But yes docteam should manage their uploads themselves (they wouldn't have a case of "anyone can upload content" either, I think)
22:18:21 <trishf42> sure
22:18:34 <tmb> ok, so a chrooted ftp could be done
22:19:16 <DavidWHodgins> One that allows public uploads that have to be reviewed, before being made public, and one that only allows private uploads.
22:20:48 <MrsB> it would be difficult to link public contribution to the contributor maybe
22:21:20 <tmb> yep, for example pure-ftp has that feature builtin... you can upload and it will stay "hidden" until "allowed users" make it available"
22:21:51 <MrsB> can't help but think we need to be more web 2.0 with it
22:22:18 <tmb> like ?
22:22:22 <DavidWHodgins> While old, they are stable.
22:22:36 <MrsB> owncloud/mediagoblin linked to ldap
22:23:18 <MrsB> with atelier able to admin content
22:23:32 <DavidWHodgins> I think it would be better to let things like that stabalize, before using them with infrastructure.
22:24:15 <tmb> could probably be done, but I'd rather not do it before infra is moved to mga4, something that needs to heppend this summer at the latest
22:24:28 <MrsB> yep that's fair enough
22:25:00 <MrsB> the only issue i can see with pub ftp is that somegreatartist uploads his work and we're unable to link the file with somegreatartist
22:26:15 <DavidWHodgins> With an anonymous login, they are supposed to provide their email. We can add something to the login msg, that if they don't use a valid email, the item will not be accepted.
22:27:21 <tmb> DavidWHodgins, but that can be faked unless we do some "call-back" feature that ensures the validity...
22:28:24 <MrsB> could it maybe accept any username and drop into directories of the username
22:28:25 <ennael> sorry network pb...
22:29:02 <DavidWHodgins> That could be a manual step in the review process. If the item looks good, email the supplied address, to confirm the person has the ownership/permission to upload it, before approving it.
22:29:03 <tmb> ok, to move on... I'll set up an ftp this WE (cant do before, as my $dayob is keeping me busy)
22:29:34 <MrsB> that'll be a good start :)
22:29:50 <ennael> ok anything else on that topic?
22:30:02 <MrsB> i think calenco can send to ftp too
22:30:03 * ennael is falling asleep :p
22:30:11 <tmb> and if coling sets up a git for marcom we'll sort out groups (and create new one if needed)
22:30:37 <DavidWHodgins> I'd like to add a topic about mga-security. I'd like all mga-qa ldap members added to the group/mailing list, as well as probably tmb/colin, if not all sysadmin members.
22:30:54 <filip_> ennael: wake up and note that you need to ping rda for GA
22:31:33 <ennael> #topic mga-security
22:32:24 <trishf42> before you get into that, can we please have an action item and deadline for the space issue?
22:32:57 * trishf42 has to start the working day real soon now
22:33:06 <filip_> tmb: who can fix groups? I'm not in mga-web.
22:33:08 <tmb> well, the security group was added for managing embargoed stuff... do we really want all users there (not that we are on any embargo list yet)
22:33:15 <tmb> filip_, I can
22:33:38 <MrsB> mga-qa is only team leaders and stormi/coincoin
22:34:14 <filip_> tmb: these groups need a bit of a review anyway
22:34:17 <DavidWHodgins> Right now, it's only luigi and oden. It would be nice for qa to have advanced warning on pending security problems, so we know how to test, when the updates do become ready. Most qa team members are not in the ldap group.
22:34:43 <MrsB> What are you thinking of dave?
22:34:49 <DavidWHodgins> qa ldap is currently only MrsB, me, and wilcal.
22:35:06 <leuhmanu> security is for outsite list
22:35:15 <leuhmanu> ie http://openwall.com/
22:35:16 <[mbot> [ Openwall - bringing security into open computing environments ]
22:35:32 <tmb> #action tmb will set up ftp for marcom and docteam by end of week (March 16th, 2014)
22:35:37 <DavidWHodgins> When an embargoed update has a poc, it would be nice to be able to test the poc, while waiting for the update, so the update can be tested/validated quicker.
22:35:40 <ennael> sorry all I have to leave meeting for tonight
22:35:45 <ennael> #chair tmb  MrsB
22:35:46 <Inigo_Montoya> Current chairs: MrsB ennael tmb
22:35:52 <MrsB> ninight ennael
22:35:55 <tmb> #action tmb will set up ftp for marcom and docteam by end of week (March 16th, 2014)
22:36:02 <DavidWHodgins> ennael: Have a good night.
22:36:10 <ennael> thanks I will read the logs
22:36:24 <filip_> good night ennael
22:37:03 <tmb> #action coling will set up git space for marcom
22:37:13 <filip_> DavidWHodgins: leuhmanu already removed GA for www. can you check cookies please?
22:37:15 <DavidWHodgins> I have been cc'd privately on embargoed updates in the past, but not always.
22:38:04 <tmb> and I removed GA from mediawiki templates
22:38:25 <DavidWHodgins> I'll have to change remove my aliase of ga to 127.0.0.1 first. I'll test that, after the meeting.
22:38:38 <filip_> tmb: late dinner for Dave ;)
22:38:38 <MrsB> It would be nice to have access to the embargoed info, I think to do that properly requires hidden bugzilla, build server and etc though. If you think it would help to join sec group I'm not against doing so
22:38:55 <DavidWHodgins> 1838 local time right now.
22:39:24 <tmb> anyway, I guess we can add  mga-qa for now unless Luigi12 objects
22:39:43 <MrsB> yep. Have you warned wilcal Dave?
22:40:15 <DavidWHodgins> MrsB: In the past, I've been cc'd privately, tested the poc. On the day the embargo ended, tested the update, and validated it within minutes of it hitting my local mirror.
22:40:16 <leuhmanu> (didn't know it was in the svn, sorry for before) above that here I don't see anymore request to google on web or wiki
22:40:28 <DavidWHodgins> MrsB: Not yet. :-)
22:40:43 <tmb> filip_, whats your identity login
22:40:53 <MrsB> Let's chat to luigi12 and wilcal and do it next time, if that's ok?
22:40:54 <filip_> nasty. there is one visitor on es blog :(
22:41:00 <filip_> tmb: filip
22:41:28 <MrsB> In fact you're in charge this week :D
22:41:31 <filip_> who can take care of other lang blogs
22:41:32 <tmb> filip_, ok, you are now in mga-web
22:41:38 <filip_> thx tmb
22:41:39 <DavidWHodgins> MrsB: Ok. we can discuss it via private email.
22:41:55 <Akien> tmb: btw, do you know about the identity feature to manage groups?
22:41:56 <MrsB> yeah :)
22:42:18 <tmb> Akien, manage how ?
22:42:27 <Akien> misc gave Oliver and I access to a group management form in identity to add/remove members to mga-i18n and mga-i18n-committers
22:43:14 <MrsB> Oh being able to do that would be useful to keep in touch with iso testers too tmb
22:43:19 <tmb> ah, that... shouldnt be hard to find... what do you need ?
22:43:35 <MrsB> mga-iso-testers or some such group
22:43:44 <Akien> tmb: I don't need anything, I just wanted to know if you know about it, now that misc is not hanging around anymore
22:44:15 <Akien> But yes this could be useful if MrsB were to manage a group such as mga-iso-testers
22:44:31 <MrsB> with an alias we could email
22:44:43 <tmb> Akien, ah, ok... I know it's done iirc by ownership in puppet configs, so I can poke it
22:44:55 <filip_> Akien: do you have access on org svn (constitution)?
22:44:57 <DavidWHodgins> MrsB: I have some other ideas about that. We can discuss that via email too. I think that's probably enough for this meeting. :-)
22:45:15 <MrsB> OK dave
22:45:19 <tmb> yep, I see 2 laptops and only own one :)
22:45:34 <tmb> so... anything else ?
22:45:44 <filip_> not today ;)
22:45:47 <Akien> filip_: IIRC, I don't
22:45:47 <DavidWHodgins> Nothing else here.
22:46:04 <MrsB> we covered it all i think
22:46:24 <filip_> Akien: lets talk that some other time
22:46:31 <tmb> ok, se closing meeting then...
22:46:43 <tmb> #endmeeting