20:47:22 <ennael> #startmeeting
20:47:22 <Inigo_Montoya`> Meeting started Mon Jan 13 20:47:22 2014 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:47:22 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:47:32 <ennael> hi all :à)
20:47:37 <MrsB> morning :)
20:47:43 <marja> dvg: she's the most important one
20:48:13 <ennael> so as planned we try to have weekly meeting until final release to review regularly the status of the distro and work in progress
20:48:45 <MrsB> i think it's a good idea
20:49:02 <ennael> #topic Mageia 4 RC, status and planning
20:49:06 <ennael> so here we go
20:49:19 <ennael> we have a lot of new bugs happening recently
20:49:23 <ennael> blocking bugs
20:49:33 <ennael> there was a proposal this afternoon from marja and MrsB
20:49:51 <ennael> to delay final release and in between provide some updated isos for Mageia 3
20:49:51 <MrsB> 'if necessary'
20:49:58 <ennael> yep :)
20:50:16 <ennael> so as said on irc I spoke about it to tmb and we need tonight to take some decision
20:50:27 <MrsB> it would be a shame as the publicity from fosdem would be helpful
20:50:38 <marja> ennael: can't we test coling's patches first?
20:51:13 <marja> oh, but then Gnome would still be a mess, wouldn't it?
20:51:23 <ennael> marja: at least we need to agree on some kind of scenario
20:51:32 <ennael> if so then, if so then...
20:51:35 <marja> ennael: yes, we do
20:51:37 <marja> OK
20:51:40 <tmb> Gnome is always a mess, it only varies in degrees...
20:51:45 <ennael> :)
20:51:49 <marja> tmb: :-þ
20:51:54 <ennael> so waht are the current critical bugs
20:52:02 <MrsB> intel/nvidia issue seems resolved, but it has uncovered all new issues
20:52:03 <ennael> to sum up the current status
20:52:17 <ennael> MrsB: can you list them?
20:52:44 <MrsB> colin's systemctl issue, if it's causing hardware related problems could explain alot of the bugs
20:53:22 <ennael> on that one we have a proposed fix to be tested in next isos right ?
20:53:48 <marja> systemd + chkconfig
20:53:56 <marja> ennael: yes
20:54:04 <ennael> ok
20:54:21 <ennael> #info systemctl issue: fix integrated, to be tested in next isos
20:54:25 <ennael> ok next one :)
20:54:27 <MrsB> but in short, live isos have issues with gnome starting, caused by missing drivers which could be caused by that bug too. Same issue for me at least with kde live isos, missing gpu drivers.
20:54:38 <ennael> ok
20:54:53 <ennael> so next tests will be very important also to take a decision
20:55:11 <ennael> next bug ?
20:55:29 <MrsB> others are several applications, some qt, some gtk which don't start properly, don't open a window, but use 100% cpu.. unless run under gdb. Looks possible that it's theme related
20:55:53 <MrsB> shorewall6 not starting
20:56:13 <dvg> scripts are lacking there
20:56:29 <marja> some of the traditional installer screens are badly rendered
20:56:37 <MrsB> some artwork integration issues
20:56:53 <ennael> ok so
20:57:04 <marja> diskdrake in stage 2 crashes when you want to see what's on a partition
20:57:23 <ennael> on that point new fixes integrated
20:57:31 <ennael> will be for next coming isos
20:57:33 <MrsB> razorqt has replaced lxde on the classic isos and a couple of issues there to do with MCC (not starting from menu & hidden in menu & missing it's icon)
20:58:19 <MrsB> upgrades fail if online medias are added during upgrade, completes ok with just dvd media
20:58:33 <ennael> I take that one to see with tv
20:58:46 <MrsB> release notes are for beta 2
20:59:04 <MrsB> some hangs on reboot, which could be colins bug again
20:59:31 <ennael> coling: around ?
20:59:45 <MrsB> one i've just seen from wilcal - Upgrade Mga3.1 -->4 RC does not carry apache-mod_userdir forward
20:59:48 <ennael> (don't run we can see you)
21:00:03 <coling> ennael, yup
21:00:10 <coling> :)
21:00:15 <sebsebseb> hi back
21:00:32 <ennael> 20:56 < MrsB> some hangs on reboot, which could be colins bug again
21:00:40 <MrsB> numberlock turned on on laptops, which is colins issue again i think
21:00:42 <ennael> MrsB: any specific bug report ?
21:00:53 <MrsB> uhhm one sec
21:01:12 <MrsB> all one the pad here http://bn.parinux.org/p/mageia4rc
21:01:13 <[mbot> [ Etherpad Lite ]
21:01:35 <MrsB> https://bugs.mageia.org/show_bug.cgi?id=11953
21:01:40 <[mbot> [ Bug 11953 First reboot after install hangs forever at "Checking for new hardware" ]
21:01:59 <coling> ennael, there are a few other bugs too e.g. https://bugs.mageia.org/show_bug.cgi?id=12278 and a couple other references.
21:02:05 <[mbot> [ Bug 12278 in runlevel 3, numlock auto-enables itself on laptop without numpad ]
21:02:24 <coling> But I'm hoping the new chkconfig+systemd combo will solve it... fingers crossed at least
21:02:42 <ennael> ok so maybe we can review the general status of all this after next tests
21:03:09 <MrsB> https://bugs.mageia.org/show_bug.cgi?id=12291 reported by dvg this afternoon too seems to fit the bill (pam_nologin)
21:03:13 <[mbot> [ Bug 12291 With one LiveCD I cannot login on first reboot: pam_nologin(8) ]
21:03:52 <coling> Yup, that does look like it.
21:04:02 <ennael> ok
21:04:17 <ennael> so we need to ping razorqt maintener
21:04:22 <MrsB> we'll be in a better position to understand where we are with colins fix included really, it's having odd, slightly unpredictable effects
21:04:50 <ennael> I will ping pterjan for release notes
21:05:09 <sebsebseb> I was having netbook issues so missed some of it, but it seems Magiea 4 may get delayed then?
21:05:23 <ennael> one of the heavy point is GNOME...
21:05:32 <MrsB> something we need to decide sebsebseb
21:05:41 <dvg> GNOME from classical is always ok
21:05:50 <tmb> ennael: for release notes I think it's simply no new mageia-release pushed lately
21:05:58 <MrsB> gnome is actually mostly ok, where it starts
21:06:13 <ennael> pterjan: tmb from beta2?
21:06:21 <MrsB> gnome on live fails due to missing gpu acceleration
21:06:42 <ennael> last one is 3 days ago
21:06:42 <tmb> yeah, last mageia-release is 2013-12-06
21:06:59 <MrsB> might need the wiki page updating, doesn't it parse the wiki?
21:07:26 <MrsB> oh 2013 is a while ago
21:07:51 <ennael> erf ok
21:08:31 * ennael was just checking svn...
21:08:38 <ennael> just submitted
21:08:48 <ennael> let see what happens
21:10:25 <ennael> MrsB: so on GNOME side no more pb?
21:10:25 <MrsB> oh I noticed an sd_festival segfault earlier, was talking to diogenese about it, he's been working on TTS, he says we shouldn't be starting festival server as it's a potential security risk and recommends to either not start the server or use flite instead
21:10:43 <coling> ennael, heavy point gnome?
21:10:54 <MrsB> not really, it would be nice to get MCC into the sidebar menu
21:11:13 <ennael> what about icons on desktop and personal folders ?
21:11:16 <coling> ennael, ahh, read the rest of the backlog nvm
21:11:17 <ennael> xdg one
21:11:34 <MrsB> Oh yes, forgot that one! user dirs with gnome
21:11:46 <MrsB> only ~/Desktop and ~/tmp are created
21:11:51 <MrsB> live or installed
21:12:11 <MrsB> I can't remember offhand whether that's only live or after classic install too
21:13:02 <MrsB> I don't think there is anything insurmountable, assuming everybody gets behind it, once the harware issues are fixed - which could all happen at once with colins bugfix
21:13:47 <ennael> ok so what  propose at that point is to wait until tomorrow to decide anything
21:13:50 <ennael> wdyt?
21:14:30 <marja> sounds good to me
21:14:32 <MrsB> QA is completely overwhelmed with updates waiting so it would be nice to get some time away from isos to work on validatng those, or perhaps lessen our testing to give us a chance to catch up.
21:15:01 <MrsB> i'd like to try the fix ennael before we delay the final
21:15:17 <ennael> ok everybody agree?
21:15:21 <dvg> i agree
21:15:29 <tmb> ok
21:18:12 <MrsB> I've asked Dave when he's feeling up to it to check his lvm/luks setup, he's normally gives that a good check
21:18:36 <ennael> ok
21:18:47 <MrsB> excuse typo/grammar mistakes, getting a bit worn out
21:18:55 <marja> MrsB: np :-)
21:19:03 <ennael> #action final decision for Mageia 4 planning will be taken after the tests of the coming isos
21:19:22 <MrsB> i posted to the G+ group earlier with some info about the delay to the RC
21:19:31 <ennael> yep saw it before diner
21:19:37 <ennael> thanks for that
21:19:53 <marja> ennael: will we meet again same time tomorrow (in case it isn't very clear what the decision should be)
21:20:02 <ennael> yep if it's ok for all
21:20:07 <MrsB> i'll try and remember to post updates, i don't use it other than for that though so don't always remember
21:20:08 <marja> fine for me
21:20:11 <ennael> it will be a quick meeting
21:20:45 <sebsebseb> what's this a fix for, or possible fix?
21:20:55 <ennael> sebsebseb: please read the backlog
21:21:16 <ennael> tmb: when do you plan to finalize next set of isos ?
21:21:39 <MrsB> i can spend another full day tomorrow if they're available in the morning
21:21:54 <MrsB> i have an appointment thursday though
21:21:57 <tmb> ennael: already ~half way through the builds :)
21:22:02 <marja> nice
21:22:19 <ennael> great I will start then classical isos or rabbit may die :)
21:23:09 <marja> ennael: =x
21:23:23 <MrsB> can packagers not working on isos please help with testing updates for mga3
21:23:53 <ennael> we can send a mail explaining this
21:23:59 <ennael> and the current status of RC
21:24:06 <MrsB> I think realistically we'll be reduced to just testing updates install ok, we're absolutely swamped
21:24:06 <ennael> let share our stress
21:24:13 <ennael> and workload
21:24:20 <marja> ennael: rabbit is all green now :-)
21:24:28 <ennael> poor thing :)
21:24:33 <MrsB> green rabbit :D
21:24:43 <ennael> children were green also last week
21:24:49 <marja> :-/
21:24:50 <ennael> not a good sign :)
21:24:53 <marja> poor children
21:25:01 <MrsB> yuck, welcome to keep that
21:25:05 <leuhmanu> ennael: while I plan to make screenshot from mga4 for web, do you need the desktop-*.png http://gitweb.mageia.org/software/drakx/tree/perl-install/install/pixmaps
21:25:06 <[mbot> [ drakx - Mageia Installer and base platform for many utilities ]
21:25:26 <ennael> ?
21:25:45 <MrsB> you mean images of each DE leuhmanu?
21:25:56 <ennael> ah
21:25:56 <leuhmanu> http://gitweb.mageia.org/software/drakx/plain/perl-install/install/pixmaps/desktop-KDE-big.png
21:26:03 <ennael> yep
21:26:12 <ennael> can you commit it ?
21:26:42 <leuhmanu> nop (I'm still on installing desktop)
21:27:07 <ennael> ok but you can do it ?
21:27:16 <leuhmanu> yes
21:27:46 <ennael> ok great thanks for it
21:28:13 <MrsB> let me know if you're short of any leuhmanu
21:28:30 <MrsB> can soon grab a screenshot, assuming they boot :)
21:29:03 * marja doesn't understand that napcok managed to get nice screenshots of screens that are out of shape here
21:29:35 <ennael> ok any other topic we should speak about tnight ?
21:29:39 <ennael> tonight
21:29:51 <marja> MrsB: if I do an upgrade install, all screens are nice, if I do a normal install, all screens starting with doPartitionDisks are wrong
21:30:12 <leuhmanu> marja: even in a vm ?
21:30:14 <marja> tmb: is it possible to set the wireless regulatory domain
21:30:24 <ennael> marja: as said that one should be fixed in next isos
21:30:26 <marja> tmb: so that all the world has wlan out of the box?
21:30:57 <marja> ennael: ah, I thought your referred to diskdrake crashing..... good, thx
21:31:31 <MrsB> what is the best way to report artwork issues?
21:31:53 <MrsB> nobody here from atelier :\
21:31:56 <ennael> bug report + atelier ML ?
21:32:10 <ennael> I reported the one about advertising on ML
21:32:17 <ennael> and it's already nearly fixed
21:33:00 <MrsB> Oh before I forget, plymouth wasn't workign either
21:33:05 <leuhmanu> some of them reads also atelier-bugs@ml.mageia.org
21:33:06 <MrsB> just 3 bars
21:33:31 <ennael> any bug report ?
21:33:48 <MrsB> i didn't notice if it was just grub2, no not yet, mentioned on the pad though
21:34:07 * MrsB one pair of hands
21:34:48 <ennael> ok
21:36:52 <tmb> marja: well, technically setting "US" is closest to "world" CRDA domain ... but we really should get it fixed...
21:37:59 <marja> tmb: if GB is picked, then there are more channels available... and isn't the en_GB locales on all isos (or am I wrong)?
21:39:34 <ennael> anything else for the meeting ?
21:39:39 <marja> not here
21:39:44 <tmb> ennael: nope
21:39:44 <sebsebseb> not here
21:40:27 <ennael> ok so well... let's keep confident, sleep and see you tomorrow for the planning decision :)
21:40:31 <ennael> thanks a lot for attending
21:40:44 <marja> ennael: thanks for chairing :-)
21:40:53 <MrsB> US only uses 11 channels IINM
21:40:55 <ennael> #endmeeting