19:34:08 <ennael> #startmeeting
19:34:08 <Inigo_Montoya> Meeting started Mon Jun 10 19:34:08 2013 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:34:08 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:34:16 <ennael> hi all sorry for the late mail
19:34:20 <sebsebseb> hi
19:34:25 <MrsB> hi!
19:34:26 <DavidWHodgins> HiYa
19:34:47 <ennael> so let start our meeting
19:34:58 <ennael> #topic localized mailing-lists
19:35:32 <ennael> so we have now 2 localized ML
19:35:49 <ennael> as underlined by marja99 in her mail the pt_BR is not working for now
19:36:00 <ennael> 2 registered people
19:36:06 <MrsB> is it not working or nobody really using it?
19:36:22 <ennael> sorry I mean nobody uses it
19:36:42 <MrsB> it maybe needs to be publicised
19:36:44 <ennael> the french one has for now 350 messages and 65 registered
19:37:17 <sebsebseb> the Brazilen one
19:37:23 <sebsebseb> do  the relivent people
19:37:25 <sebsebseb> even know it got started?
19:37:31 <MrsB> is it being used for the right purpose, discuss rather than dev?
19:37:34 <sebsebseb> maybe people don't know?
19:37:41 <ennael> do you know any brazilian who asked for it
19:37:42 <ennael> ?
19:37:45 <ennael> MrsB: support
19:37:49 <ennael> mainly
19:38:07 <remmy_> I think it's not well known yet
19:38:26 <sebsebseb> remmy_: yep  I guess so
19:38:32 <MrsB> We can maybe post to forums about it and email discuss ML
19:38:34 <remmy_> Give it some more time, and find someone to post about it at least in the pt_br fora
19:38:39 <ennael> shall we plan a small blog post about communities
19:38:40 <ennael> ?
19:38:46 <sebsebseb> remmy_: indeed :)
19:38:48 <remmy_> ennael: I think that'd help
19:38:53 <MrsB> yeah blog would help too
19:38:54 <ennael> and ask the main guys implied to answwer some questions
19:38:55 <sebsebseb> what about local communites you mean?
19:39:00 <ennael> interviews
19:39:09 <sebsebseb> oh I get it
19:39:14 <sebsebseb> local communites and there representatives
19:39:17 <sebsebseb> that would be me for the UK then :d
19:39:41 <sebsebseb> and  Umeaboy maybe for Sweden :d  or swecamp for that one for example
19:40:01 <ennael> #action work on a blog post with fr and pt_BR communities and localized ML
19:40:21 <MrsB> We'll need to be prepared to offer other communities when we do
19:40:58 <sebsebseb> I don't think what I just put is what you were suggesting maybe it was, but either way, what I just put, would probably be a good idea :)
19:40:59 <ennael> yepwell not that hard to do but still it has to get some discussions
19:41:22 <ennael> I will try to get the brazilian guy and send some questions
19:41:25 <MrsB> we can maybe include it on the blog post that any new lists will need a moderator and enough people to make it work
19:41:34 <ennael> yep
19:41:44 <ennael> as said in our previous meeting
19:42:14 <ennael> ok anything else to add on these ML ?
19:42:24 <MrsB> be pro-active though i mean, rather than wait to be approached, offer any wanting one to sort out some people and get in touch or create a bug
19:43:11 <ennael> well it means contacting directly the guys listed in local communities page ?
19:43:36 <MrsB> i was thinking just including those details in the blog post/forum post etc
19:43:53 <ennael> oh yes sure
19:43:58 <sebsebseb> To be honest I don't think there are many local communites out there at htis time for Magiea, I mean proper ones, where  proper stuff goes on, but having some interviews with people who are interseted in such communites, would be alright I guess :)
19:44:00 <ennael> we will assist people on this
19:44:27 <MrsB> maybe that' s because they don't have anywhere in their local language to meet others though sebsebseb
19:45:13 <MrsB> it's good to hear the FR one is going well
19:45:51 <sebsebseb> my comment wasn't just online communication, I meant in person stuff to by the way
19:46:04 <ennael> yep well mainly people coming from the mdv fr one
19:46:13 <ennael> it was going well there also
19:47:34 <ennael> ok anything else to add ?
19:47:41 <sebsebseb> nope
19:47:48 <MrsB> nothing here
19:47:49 <DavidWHodgins> Not here.
19:48:06 <ennael> ok
19:48:27 <ennael> the plan was tonight to have team review as it's quite a long time we did not do it
19:48:35 <ennael> let's do it with people around
19:48:43 <ennael> #topic teams review
19:48:52 <ennael> MrsB: want to start ?
19:48:53 <DavidWHodgins> Tired today. :-)
19:48:56 <MrsB> sure
19:49:10 <MrsB> Well, Dave is quite tired today.
19:49:14 <ennael> :)
19:49:37 <MrsB> Since release we've been busy, there was the expected rush of updates
19:49:47 <MrsB> then also new isos
19:50:03 <ennael> about updates is it "on rails" ?
19:50:25 <MrsB> We've been trying to introduce the people who joined us testing ISOs to testing updates
19:50:56 <ennael> how did it go?
19:50:56 <MrsB> One or two have shown an interest but we've run out of easy bugs already
19:51:05 <ennael> ah
19:51:19 <MrsB> It's a steep learning curve without easy ones
19:51:43 <MrsB> Also we've previously neglected our documentation for ISO testing
19:52:06 <MrsB> I've created the bones of a page which we will need to fill
19:52:20 <ennael> ok
19:52:28 <MrsB> hopefully the experince of the new ISO testers will be useful there
19:52:59 <MrsB> We're quite on-top of the updates at the moment though *touch wood*
19:53:22 <ennael> great :)
19:53:37 <ennael> we still need to manage backports
19:53:52 <MrsB> well, might be a good idea to go ahead and do it
19:53:57 <ennael> yep
19:54:01 <sebsebseb> yep backports from Cauldron to Mageia 3?
19:54:19 <ennael> boklm: around ?
19:54:32 <MrsB> at the moment we're down to one update waiting on tests, 2 waiting for work to be done and one waiting to be validated
19:54:43 <ennael> nice result for now
19:55:00 <malo> MrsB: great :-)
19:55:11 <ennael> boklm has automatized advisories publication and is about to finalize a script so that QA can push updates
19:55:16 <MrsB> if we're going to open backports there is not going to be a better time to do so
19:55:31 <ennael> ok so maybe we should work on a blog post first on that topic
19:55:47 <sebsebseb> GNOME 3.8 to Mageia 3 backport? :d  oh I had to put this :d
19:56:04 <MrsB> Dave did you notice the advisories had moved to advisories.mageia.org now?
19:56:20 <blino> sebsebseb: why not, looks like it's running smooth on Cauldron :-)
19:56:28 <DavidWHodgins> Yes. Been watching the sysadmin-discuss.ml
19:56:47 <ennael> #info advisories can now be listed on advisories.mageia.org
19:56:52 <ennael> about backports
19:56:53 <ennael> http://bn.parinux.org/p/mageiabackports
19:56:54 <[mbot> [ Etherpad Lite ]
19:56:59 <sebsebseb> blino: nearly tried in Cauldron, but uhmm.....  anyway the sooner it gets backported to Mageia 3 the better :)
19:57:06 <sebsebseb> oh one thing with backports,  will there be a repo for that or what?
19:57:08 <ennael> to explain what is is and... what it is not
19:57:12 <sebsebseb> people then enable it if htey awtn backports, or how will that work?
19:57:27 <malo> for backports there was the question of an svn branch for them
19:57:52 <sebsebseb> malo: oh? which means what exactly?  it will be like lugui's unoffical Mageia 1 updates after EOL, got to get them from SVN ?
19:57:55 <ennael> anyway nothing will be published before everything is ready
19:58:08 <MrsB> the pad for a blog post ennael?
19:58:12 <ennael> I will mail sysadmin about it
19:58:14 <ennael> MrsB: yep
19:58:17 <MrsB> OK
19:58:30 <MrsB> phone sorry..
19:58:42 <ennael> it can also explain what needs do we have to support it
19:59:27 <DavidWHodgins> The sysadmin and dev teams have to sort out svn branching, then push and advisories procedures have to be setup.
19:59:43 <sebsebseb> What is SVN branching?
20:00:32 <malo> sebsebseb: don't worry about it.
20:00:34 <DavidWHodgins> Keeping the backports source separate from cauldron source, in case further updates are needed.
20:00:50 <sebsebseb> DavidWHodgins: oh ok :)
20:01:11 <sebsebseb> that makes sense I think :)
20:01:33 <ennael> are the mageia 3 vm still in todo list for QA?
20:01:54 <sebsebseb> yeah I guess so :d
20:02:01 <DavidWHodgins> Forgot all about it, but I guess so.
20:02:17 <MrsB> we should keep our promises i think
20:02:27 <sebsebseb> yeah QA's been focussing on ISO's and  updates, I think the vm got forgot about or kind of thing :d
20:02:39 <sebsebseb> MrsB: indeed :)
20:03:31 * sebsebseb thinks helping to test a Mageia 3 VM would probably be quite fun for me, since I like doing stuff in Virtualbox here and there :) testing/trying stuff out
20:03:37 <ennael> what you can do is use firsttime script and use draklive post-install to manage network and users configuraiton
20:03:52 <MrsB> you mean you want us to create it?
20:04:21 <ennael> I thought somebody wanted to but we can do it
20:04:37 <sebsebseb> that's true a vm has to be made,  the OS installed into it or whatever :d
20:04:53 <ennael> MrsB: what vm should we provide?
20:04:59 <ennael> GNOME and KDE ?
20:05:13 <sebsebseb> maybe a few vm's ?  have some with XFCE and LXDE to ?
20:05:41 <ennael> no way to manage zillions of it
20:05:44 <MrsB> We can maybe ask for opinions, maybe just a base one that people can use to expand on and create VMs for specific purposes
20:05:50 <MrsB> sry, brb
20:05:54 <sebsebseb> I thought the vm was just a quick easy download of a pre instaleld Mageia 3
20:05:55 <sebsebseb> or that's the idea ?
20:06:33 <sebsebseb> like how VMware have some already made ones for certian OS's when I looked uhhmm  like three years ago or something like that last time I think it is
20:07:09 <DavidWHodgins> I think all of the vms should use kernel-server-latest, to avoid bug 44.  I don't think vb can run ok on an i586 cpu that doesn't support pae, so we should ignore those.
20:09:23 <sebsebseb> GNOME and KDE vm's, maybe  XFCE and LXDE to.  we don't have Live CD's for  XFCE  and LXDE, but the Mageia implementaitons are very good (well I think so), so we could at least provide vm's for those as well I am thinking.  Depending on what the vm is exactly, but I assume it's just a pre installed  Mageia 3 and that's about it, may add some packages to it, but   basically a default install? or pretty much.   We could ask the community
20:09:25 <sebsebseb> what kind of programs they think should be pre installed though, if any.
20:10:05 <DavidWHodgins> sebsebseb: I think, pretty much the same as the live dvds, but with one more for i586 systems, using lxde.
20:10:30 <DavidWHodgins> So, on i586, two x86_64
20:10:35 <sebsebseb> as for the kernel thing DavidWHodgins  I think well ok,  are you sure about that though?
20:10:46 <DavidWHodgins> Yes.
20:11:02 <sebsebseb> also if someone installs a normal ISO into Virtualbox now, they don't get the server kernel surely?
20:11:30 <DavidWHodgins> It varies depending on how they set it up (ram, etc).
20:11:49 <sebsebseb> oh ok again if you say so :), but I  think by default, it's the normal kernel
20:12:11 <ennael> ok so let say 3 vms ? KDE, GNOME and LXDE sot that we have the 3 main kind of installs
20:12:20 <ennael> using only task packages
20:12:21 <DavidWHodgins> My point is, that it should be, when installing in any type of vm.
20:12:22 <sebsebseb> I would like one with XFCE as well
20:12:33 <sebsebseb> in fact I got asked before  why there wasn't a XFCE Live CD by someone, and then I think again by someone else as well
20:12:42 <sebsebseb> if it's GNOME, KDE, XFCE, and LXDE, that's the four main DE's supported :)
20:12:58 <ennael> no way to manage zillions of vm
20:13:13 <sebsebseb> depending on what hte vm's are I guess :d ,but yeah you said earlier
20:13:35 <DavidWHodgins> Let's keep it managable.  xfce could be included in both the gnome and kde iso images.
20:13:48 <sebsebseb> same with LXDE for that one then
20:14:05 <sebsebseb> could include enightmetn and so on to, i n fact maybe the vm should just be well
20:14:14 <sebsebseb> the classical installer with everything or pretty much :)
20:14:26 <ennael> we cannot include all of them or the size will be too heavy to download
20:14:39 <sebsebseb> only issue  with that is the size and I was thinking that to
20:14:49 <DavidWHodgins> It's a vm, not a live iso, so people can add whatever they want, afterwards.
20:15:08 <sebsebseb> true :)
20:15:38 <malo> KDE and GNOME and one minimal should be sufficient
20:15:42 <sebsebseb> well as long as GNOME and KDE are supported by default, that's  good,  and put XFCE and LXDE in both of them as well or something.  or maybe have a vm, with both GNOME and KDE, and then people can add whatever to it after if they want that ?
20:16:12 <ennael> #action coming: VMs for Mageia 3 to be uploaded on mirrors after QA tests
20:16:26 <sebsebseb> ennael: uhmm doesn't QA have to make the vm first as well?
20:16:29 <sebsebseb> or  who is making the vm ?
20:16:45 <ennael> please can you followthe meeting?
20:16:55 <ennael> I said before I would have a look
20:16:59 <sebsebseb> ok :)
20:17:26 <ennael> ok let see now packagers team
20:17:36 <ennael> malo: want to sum up last events ?
20:17:46 <malo> ennael: ok.
20:18:08 <malo> So in the packager team there are two main things.
20:18:38 <malo> the creation of SIG (Special Interest Groups) to encourage cooperation between packagers
20:19:09 <malo> they are still a bit slow to pick up
20:19:31 <malo> the second thing is the revamp of the mentoring process
20:19:42 <malo> we have 3 new apprentices
20:20:03 <malo> and several apprentices that were dormant are starting again
20:21:11 <leuhmanu> cool
20:21:23 <malo> Finally, people are working on elaborating features for mageia 4. But we should remind them about it.
20:21:30 <ennael> yep
20:21:33 <malo> ennael: that's about it.
20:21:40 <ennael> finalize post-mortem first
20:21:47 <ennael> so that tings are clear before
20:21:59 <ennael> things
20:22:24 <ennael> #info creation of SIG to encourage cooperation between packagers
20:22:47 <ennael> #info new process for mentoring packagers including online tutorial
20:24:00 <ennael> questions?
20:24:06 <ennael> any other team around?
20:26:35 <malo> leuhmanu: bugsquad?
20:26:48 <remmy_> leuhmanu has taken a two week break
20:27:05 <remmy_> and I'm sorry to say that I as his deputy haven't been able to pick up in his absence :(
20:27:32 <malo> remmy_: you two need to hire :-)
20:27:52 <leuhmanu> yes
20:28:00 <sebsebseb> remmy_: maybe you can buy  malo into your team for one euro or pound :d
20:28:13 <leuhmanu> and now I have an intership so less available too
20:28:17 <MrsB> they make mageia: leuhmanu
20:28:29 <leuhmanu> (in a full windows environment)
20:28:29 <malo> MrsB: yes!
20:28:33 <ennael> malo: rmemebr the discussion, include some triage and qa job in mentoring process for packagers
20:28:56 * ennael needs to buy new fingers...
20:29:01 <leuhmanu> and using the patch + junior_job bug
20:30:48 <ennael> MrsB: want to prepare the questions for leuhmanu ?
20:31:11 <MrsB> \o/
20:31:16 <ennael> :)
20:31:22 <ennael> I let you manage it then :)
20:31:27 <MrsB> still on phone sry
20:31:30 <MrsB> ok
20:31:42 <ennael> #action MrsB will work on "they make mageia: leuhmanu "
20:31:52 <leuhmanu> these girls will kill me
20:31:56 <ennael> sure :)
20:32:03 <ennael> this is our secret target
20:32:26 <ennael> anything else to add ?
20:32:32 <ennael> secret or not
20:32:38 <leuhmanu> nop :s
20:33:03 <DavidWHodgins> Nothing here.
20:33:13 <sebsebseb> nope
20:33:43 <ennael> ok let end it for today
20:33:47 <ennael> thanks for attending
20:33:52 <malo> ennael: thanks
20:33:53 <ennael> #endmeeting