19:03:22 <ennael> #startmeeting
19:03:22 <Inigo_Montoya`> Meeting started Mon Apr 22 19:03:22 2013 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:22 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:52 <ennael> hi all
19:03:59 <Schultz> hi
19:04:01 <obgr_netbook> hi there
19:04:09 <DavidWHodgins> HiYa
19:04:14 <tmb> hi
19:04:18 <Schultz> I think this is my first one of these when I'm actually meant to be here :)
19:04:28 <ennael> :)
19:04:32 <ennael> ok first topic
19:04:36 <ennael> #topic mageia 3 RC isos
19:05:08 <ennael> so we have released classical installer isos to avoid being too late and have the first feedbacks
19:06:04 <ennael> tmb: what about live status?
19:06:43 <tmb> I'm still 'live, yes :)
19:06:48 <ennael> :))
19:07:44 <tmb> well, grub2 is fighting us, it tries to be clever during install, but it ends up hurting us when running in live mode, no fix yet.
19:08:11 <ennael> so no release until it's fixed?
19:08:29 <obgr_netbook> do we have to add grub2 to the live media?
19:08:34 <tmb> boot & UEFI issues solved, including vboxvideo
19:08:55 <DavidWHodgins> But still need new build with the fixed uefi, to confirm it's fixed.
19:09:23 <tmb> I'm still thinking out fixes for installer graph starting at 80%
19:09:39 <tmb> DavidWHodgins: yep, currently building
19:10:49 <tmb> obgr_netbook: well, the installer has grub2 as a choice, so it will show up in boot config selection
19:11:00 <obgr_netbook> hm...
19:11:48 <tmb> and it can be installed with a "hack", namely manually chrooting into installed media and install it there with urpmi
19:12:51 <tmb> but I dont think we should hold of RCs for the grub2 issue alone...
19:13:27 <ennael> so the thing is to choose grub legacy to make it work ?
19:13:40 <tmb> even if I'd like RCs to be real RC I think tv needs more time
19:14:08 <ennael> ok
19:15:04 <ennael> tmb: is there anything to do to help you at the moment?
19:16:51 <maat> hi
19:17:32 <tmb> well, if someone could figure out if we are missing some package as progress bar in kde4 install seems to not show up at all, that would help
19:17:39 <DavidWHodgins> tmb: Once the uefi fix is confirmed, let's go ahead and release the RC.  Final is only 2 weeks away.
19:18:05 <ennael> DavidWHodgins: well we will see depending on the release critical bugs
19:19:13 <tmb> I also will do a second test iso for broadcom users, but that will be separate to the RCs
19:19:33 <ennael> #action RC live isos will be released with current grub2 bug to give some time to tv
19:20:10 <ennael> #action need some volunteers to check potential missing packages  as progress bar in kde4 install seems to not show up at all
19:20:47 <Schultz> tmb - for the release notes we were wondering what the likelihood of the broadcomm changes going ahead are?
19:20:57 <ennael> #action tmb plans a second test iso for broadcom users
19:22:22 * tmb goes reading release notes
19:22:30 <ennael> ok
19:22:43 <ennael> DavidWHodgins: anything specific for qa team about RC ?
19:23:08 <DavidWHodgins> Just waiting for next live iso images.
19:23:17 <ennael> ok
19:23:25 <ennael> anything else about RC?
19:23:33 <DavidWHodgins> Not here.
19:23:51 * tmb find nothing in release notes about broadcom...
19:24:01 <ennael> Schultz: ?
19:25:12 <tmb> or was that the question... "what will we add regarding broadcom" ?
19:26:13 <ennael> we killed Schultz :)
19:26:24 <obgr_netbook> Seems so :-)
19:26:37 <Schultz> its not written yet, its more wondering what we can write
19:27:10 <ennael> maybe it will depend on the very last tests as announced by tmb
19:27:30 <Schultz> ok
19:27:49 <ennael> I guess there is enough to write before :)
19:28:32 <Schultz> true
19:28:51 <ennael> ok let see next topic then
19:29:04 <ennael> #topic pending release critical bugs
19:29:24 <ennael> ok that one is important as it will define if we can release on time
19:31:44 <ennael> we have at the moment 39 release critical bugs
19:32:11 <ennael> (only packages not sysadmin ones)
19:33:03 <ennael> among them a lot of old one (unfortunatelly), trackers and todo list
19:33:27 <ennael> still what should be nice is to have a list for the bugs that *must* be fixed before final release
19:33:49 <ennael> wdyt?
19:34:49 <DavidWHodgins> I'll have to dig for the link to the 39.  I'd like to go over them with MrsB, and figure out which we can live with, with errata entries.
19:34:50 <Schultz> sounds good
19:35:06 <maat> yes
19:35:54 <marja> yep
19:36:04 <ennael> https://pad.riseup.net/p/CidqERC75X9m
19:36:07 <[mbot> [ Riseup Pad ]
19:36:24 <ennael> we can write this list here so that everybody agree on it
19:37:00 <ennael> the faster we can write it the faster we can put priorities and try to solve it
19:43:39 <ennael> DavidWHodgins: can you see it with MrsB|away ?
19:43:51 <DavidWHodgins> Yes.
19:44:00 <ennael> ok
19:44:27 <ennael> #action finalize a list of blocking bugs to be fixed before Mageia 3 is out https://pad.riseup.net/p/CidqERC75X9m
19:44:28 <[mbot> [ Riseup Pad ]
19:47:33 <ennael> it would be nice to work on that list before tomorrow evening
19:47:45 <ennael> so that we can review it during packagers meeting
19:48:16 <DavidWHodgins> I'm not sure where MrsB is today.  I'll put together a tenative list, and send it to her, before updating the pad.
19:48:34 <ennael> ok
19:50:16 <ennael> anything else on that topic?
19:50:21 <DavidWHodgins> Not here.
19:51:06 <ennael> ok
19:51:15 <ennael> #topic i18n review
19:51:20 <ennael> obgr_netbook: your turn :)
19:52:05 <obgr_netbook> As far as I see it, we are waiting for release texts from atelier
19:52:38 <ennael> what about distribution ? is everything ok and integrated?
19:52:43 <Akien> We just received them today actually.
19:52:47 <obgr_netbook> And we'd like to know if there will be a rebuild of draktools before release
19:52:56 <ennael> there was one today
19:53:05 <ennael> we can plan one indeed
19:53:07 <obgr_netbook> Ok, then
19:53:27 <ennael> if we keep the current planning very last one could be planned at the end of this week
19:53:36 <obgr_netbook> Akien: Anything from you?
19:53:56 <sebsebseb> hi
19:54:06 <Akien> Hm, so the marketing content has been sent to i18n today, so we'll be working with Atelier on it.
19:54:13 <obgr_netbook> ennael: would be great
19:54:17 <ennael> ok
19:54:41 <Akien> There was an issue raised in doc-discuss about the "Close" button in the installer help remaining without translation.
19:54:41 <ennael> #info marketing content was sent today, i18n team is working on translation
19:54:45 <obgr_netbook> Akien: Ah yes, I remember now, I even wrote a comment on the ml.
19:54:55 <Akien> https://bugs.mageia.org/show_bug.cgi?id=9828
19:54:57 <[mbot> [ Bug 9828 Non-localized button to close drakx-installer-help text ]
19:55:02 * obgr_netbook needs a new brain and at least 48 hours of sleep
19:55:09 <ennael> #action very last rebuild for new translations will be planned for end of this week
19:55:26 <Akien> Okay, we'll relay the info.
19:55:50 * marja will do so, too
19:56:14 <trishf42> Hi, sorry to be late - it's still only 05:55 here 8-/
19:56:29 <marja> trishf42: the more welcome you are :)
19:56:53 * ennael sends a coffee to trishf42
19:57:37 <Akien> Apart from this, I think there are not many other things in i18n with regards to the release.
19:58:04 <ennael> ok please ring the bell if needed
19:58:17 <ennael> #topic documentation review
19:58:20 <ennael> marja: your turn
19:58:26 <Akien> There may be the question of the webpages for Mageia 3, but then it's to see with Atelier (and I fear there is still much to do)
19:58:54 <marja> docteam isn't ready yet, there are some installer translations that aren't up-to-date
19:59:20 <marja> where possible the English good text was put inside the translation
19:59:45 <marja> and about MCC help, we have hope that the French help will be ready to package soon
20:00:30 <marja> we might be late on supplying everything needed for doc.mageia.org, though
20:00:57 <ennael> ok as foir i18n very last build should occur in the end of this week
20:01:18 <marja> yes, I got that :)
20:01:27 <ennael> ok :)
20:01:36 <ennael> still you can plan some updates after 3 is out
20:01:37 <marja> ennael: end of the week is a bit vague
20:01:44 <ennael> sunday night
20:01:47 <ennael> (fever)
20:01:52 <marja> thanks :)
20:02:13 <marja> yes, for doc.mageia.org and mcc help, things can be updated :)
20:02:17 <marja> one question
20:02:20 <ennael> yep
20:02:43 <marja> updating from mageia 1 to 3 has not been tested, correct?
20:02:54 <ennael> yep and it will not
20:03:12 <DavidWHodgins> My understanding is that it is not supported.
20:03:16 <ennael> yep
20:03:42 <obgr_netbook> Mga1 is eol for some time now, so we don't have to support updating from it
20:03:47 <obgr_netbook> do we?
20:03:48 <ennael> #action docteam is a bit late but will be able to update doc if needed after 3 is out
20:03:54 <ennael> obgr_netbook: nope
20:04:26 <ennael> marja: anything else to add ?
20:04:46 <marja> that I'm looking forward to the changes after release :)
20:04:55 <ennael> :)
20:04:55 <marja> ennael: about our translation flow ;)
20:04:59 <ennael> ok
20:05:16 <ennael> #topic artwork review
20:05:22 <ennael> Schultz: your turn :)
20:05:47 <Schultz> ok, I'll do what I can.
20:07:04 <Schultz> pending things that I want to do/check: the ksplash kde icons, I'm still not convinced about they're removal; and I still havn't seen the newest itteration of the background but I hear its good
20:07:54 <ennael> ok
20:08:02 <ennael> any piece missing for now?
20:08:10 <Schultz> I haven't come across any bugs with plymouth yet which is nice
20:08:32 <ennael> there is one from coling
20:08:32 <ennael> https://bugs.mageia.org/show_bug.cgi?id=9822
20:08:34 <[mbot> [ Bug 9822 Backgrounds do not fit monitor on higher resolutions and on multi-desktop setups ]
20:08:48 <Schultz> Similarly for the whole integration yet so I think were done.
20:08:52 <Schultz> or not....
20:09:23 <coling> ennael, that's not specifically with plymouth
20:09:36 <coling> It's only in GNOME.
20:09:41 <coling> (not tested KDE tho')
20:09:47 <leuhmanu> gdm no ?
20:09:54 <leuhmanu> it's a duplicate bugs
20:09:58 <coling> GDM  yeah
20:10:17 <coling> Oh OK, sorry :(
20:10:19 <obgr_netbook> On my netbook in kdm, the logo is sitting below the monitor
20:10:25 <obgr_netbook> You only see half of it
20:10:38 <leuhmanu> cf https://bugs.mageia.org/show_bug.cgi?id=9304
20:10:40 <[mbot> [ Bug 9304 new gnome-shell package wall paper does not fill screen ]
20:11:19 <leuhmanu> maybe we can switch back to the black background
20:11:24 <Schultz> doesn't this always go back to the way that we link the correct resolution image to default.jpg
20:11:55 <leuhmanu> (there is also some related bugs at gnome bugzilla, ie not possibility to have a dynamic background size)
20:11:59 <Schultz> as kdm links by default to the 1024x768 image
20:12:11 <Schultz> I wonder if this is the same issue or related
20:12:45 <obgr_netbook> ah, that explains problems on 1024x600 monitors
20:14:09 <Schultz> yep, that code seems off somehow, I just have never got around to looking into how it actually goes from detecting the screen resolution to linking to defualt.jpg.
20:14:28 <Schultz> I know it happens at install of mga-theme, and it never really works
20:15:00 <ennael> ok can you  guys have a look on it for our favorite systemd maintainer ? :)
20:15:55 <Schultz> can try, but from my memory of mga1 it is a large pain. It will have to wait until after Wednesday for me tho, exams and coursework :(
20:16:04 <ennael> ok no pb
20:16:15 <ennael> #topic marcom review
20:16:21 <ennael> trishf42: your turn :)
20:16:29 <trishf42> 8-) I did arrive in time after all...
20:16:44 <ennael> yep :)
20:16:51 <trishf42> okay, the installer screen texts are done and dusted (hopefully also by i18n);
20:17:06 <trishf42> the press release, blog post are done and gone to i18n;
20:17:28 <trishf42> and the community mailout is with i18n and will be emailed this week (before Friday, hopefully).
20:18:00 <trishf42> I don't know how much response we'll get; I put out preliminary stuff on G+ and FB and the blog a couple-three weeks ago and not much has come back.
20:18:06 <Schultz> just wanted to correct my bit earlier about braodcomm, that was meant to be for release annoucement
20:18:07 <trishf42> BUT it's happening.
20:18:31 <trishf42> Schultz: I ended up taking that line out of the press release
20:19:14 <Schultz> I know, the more I think about it, the more it seems it should go into the release notes
20:19:19 <trishf42> I've also been doing a bit on the wiki in the Atelier space, still more to do but we're a bit more findable now
20:19:29 <ennael> ok
20:19:30 <trishf42> So, what needs doing on the website before release?
20:19:54 <Schultz> 2 --> 3
20:20:09 <trishf42> not too much then - we can get that organised on the ml
20:20:13 <ennael> http://www.mageia.org/en/
20:20:14 <[mbot> [ Home of the Mageia project ]
20:20:20 <ennael> maybe review this page
20:20:25 <ennael> no idea really for now on this
20:21:07 <ennael> ah one thing we should really work on if possible
20:21:11 <trishf42> are we happy with the current layout/colours, or do you want to change (maybe put the new background in)?
20:21:16 <ennael> a release tour for Mageia 3
20:21:31 <Schultz> I would like to add a tab directly linking to the wiki
20:21:40 <trishf42> that's the round-the-world thing I've been working on, without a lot of success
20:21:41 <ennael> meaning kind of release notes for dummies with screenshots inside
20:22:05 <trishf42> Ah
20:22:29 <trishf42> in that case, can we do something based on the release notes?
20:22:43 <trishf42> and where would it link from - front page or downloads page?
20:23:03 <ennael> see for example http://wiki.mandriva.com/en/2010.0_Tour
20:23:08 <ennael> as an example
20:23:31 <ennael> so it's based on release notes but only for visual sides of it
20:23:58 <trishf42> okay - I guess we would need to get some input from dev for the information, if it's not already in the release notes
20:24:06 <ennael> yep
20:24:30 <Schultz> that sounds good
20:24:39 <trishf42> when do we want all this by (release, front page etc)?
20:24:54 <trishf42> (I can do a lot of it, but I don't have access to commit it)
20:24:55 <ennael> for the D day
20:25:00 <ennael> ah
20:25:06 <ennael> some hours before
20:25:12 <trishf42> ok
20:25:14 <ennael> on the wiki it can be started now
20:25:20 <Akien> trishf42: You don't have commit rights?
20:25:26 <trishf42> no 8-)
20:25:39 <ennael> I will ping rda on this
20:25:47 <trishf42> not that I'd know what to do with them if I did - I'm used to git, not svn
20:25:57 <ennael> ok
20:26:56 <Schultz> if you need studd committed, akien and me are here, but i guess that rda would be best as he knows the web stuff
20:27:06 <trishf42> #action atelier to make updates for web front page and release tour for the wiki
20:27:48 <ennael> anything else for marcom?
20:28:29 <Schultz> I think that that is it anyway
20:28:41 <trishf42> No, that's it
20:28:44 <ennael> ok
20:28:53 <ennael> anything else guys to be added?
20:29:13 <DavidWHodgins> Any plan to modify mgaapplet to warn people about the need for mageia-prepare-upgrade?
20:29:26 <leuhmanu> ah yes
20:29:27 <trishf42> shall we do another on-the-dot publishing thing? I need to be pinged, because otherwise I'll be asleep while it's all going on
20:29:51 <ennael> on-the-dot?
20:29:57 <leuhmanu> and the backport fix for mgaapplet+urpmi (directory not root will make the upgrade failling)
20:31:07 <Schultz> ennael - do you are do you know of someone with knowledge of the linking to default.jpg as just having a look at it now some guidance on it would be great
20:31:20 <trishf42> when you say : they're loaded and ready to go, I publish the blog post and send the press emails right then
20:31:27 <ennael> I can try to find somebody Schultz
20:31:34 <ennael> trishf42: ok :)
20:31:41 <trishf42> 8-)
20:31:52 <ennael> anyway I propose you all to have a meeting next week
20:32:12 <DavidWHodgins> Ok here.
20:32:16 <ennael> se it should be the week of the final release
20:32:24 <Schultz> thanks, and yes to the meeting, that would be good
20:32:43 <tmb> yep, we need a review to go/no-go for final
20:32:54 <ennael> #info next council meeting will be no 29th of april
20:32:56 <ennael> indeed
20:33:06 <ennael> and please do not forget the bug list on the pad
20:33:11 <ennael> #endmeeting