19:25:10 <ennael> #startmeeting
19:25:10 <Inigo_Montoya`> Meeting started Mon Apr  8 19:25:10 2013 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:25:10 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:25:21 <ennael> hi all so let start this meeting
19:25:38 <ennael> #topic Mageia 3 review: beta 4, todo list
19:26:07 <ennael> so classical installer isos have been released
19:26:25 <ennael> MrsB: can you make a quick review on pending tests on live isos ?
19:27:02 <MrsB> Well, it's ongoing. I'm not sure if tmb will want to do another build
19:27:44 <MrsB> I started collecting some issues together in the errata section of the pad
19:28:36 <MrsB> At the moment no medias are added after the reboot after installing
19:29:12 <MrsB> that's probably the main issue for the moment
19:29:23 <ennael> ok no other critical one ?
19:30:02 <MrsB> there are a few issues that were raised, network issues with NM/net-applet in gnome
19:30:14 <MrsB> hdmi resolution etc
19:30:52 <MrsB> other things that will need fixing but not necessarily prevent release of the live isos
19:31:20 <ennael> ok
19:31:22 <MrsB> tmb any comment?
19:31:56 <sebsebseb> hi
19:32:02 <MrsB> hi sebsebseb
19:32:23 <ennael> if no specific comment then we should release isos
19:33:11 <MrsB> depends if thee will be a fix for the medias being added, it's a regression
19:33:33 <tmb> yep, I dont see any release blockers for beta4 isos...
19:33:52 <ennael> tmb: any idea on that pb with media ?
19:34:03 <tmb> MrsB: yep, but they can all be added manually like on traditional installs
19:34:19 <MrsB> yep, for now they can.
19:34:29 <ennael> ok so let's go then :)
19:35:18 <ennael> tmb: can you upload the isos ?
19:35:24 <tmb> ennael: yep. because I have added Live Core/Nonfree medias for grub2 / broadcom stugg the finish-install assumes all wanted medias are there and skips the step
19:35:38 <ennael> MrsB: Can I let you post on the blog a quick message about it ?
19:35:53 <MrsB> sure, i guess so yeah
19:35:56 <ennael> :)
19:36:12 <tmb> I've cc'd both blino and tv on that bugreport, so lets see what they suggest...
19:36:21 <ennael> #action tmb will push beta 4 live isos on mirrors and MrsB will post on the blog
19:36:33 <ennael> needs also to add all information on the wiki
19:36:44 <MrsB> there is alot to be done before RC
19:37:48 <ennael> ok is that all for beta4 ?
19:38:00 <tmb> MrsB: yep. hopefully now that we are in release freeze people start review / help with bugs instead of "oh there is a new version..."
19:38:11 <ennael> :)
19:38:34 <malo> tmb: :-)
19:38:41 <MrsB> matches at the ready!
19:38:54 <coincoin> :)
19:39:00 <ennael> \o/
19:39:15 <ennael> ok so tomorrow we will make a review on critical bugs
19:39:44 <MrsB> if people aren't able to work on the critical ones there are plenty of others
19:40:10 <malo> MrsB: yes, there's enough work :-)
19:40:41 <MrsB> http://tinyurl.com/bszn9hf
19:40:43 <[mbot> [ Bug List ]
19:43:02 <ennael> what about the upgrade tests?
19:43:19 <ennael> any status and know issue ?
19:43:19 <MrsB> so far they're going very well
19:43:30 <ennael> at least a good news :)
19:43:46 <MrsB> yeah, it's looking quite reliable
19:43:56 <MrsB> we've people testing at least once a week
19:44:26 <ennael> ok just let us know if some issues arise
19:44:52 <MrsB> yep, *touch wood* it's very promising
19:44:58 <ennael> ok nice
19:45:36 <ennael> MrsB: as usual please stay around tomorrow for packagers meeting
19:45:44 <blino> tmb: drakx-finish-install already automatically configures media, if none is configured in the system
19:46:12 <blino> tmb: you may just need to run some "urpmi.removemedia -a" in a post script
19:46:41 <blino> (if your issue is that media are already configured in the running live system)
19:47:14 <ennael> blino: while you are here, #7317 and #6675 :)
19:47:21 <coincoin> blino: !
19:47:50 <tmb> blino: yes, but I now have two "local medias" on live isos to cope with grub2 and broadcom-wl to be available
19:48:06 <ennael> anybody from atelier around ?
19:48:38 <blino> tmb: then maybe we would have to patch ask_urpmi in drakx-finish-install, to only check if "online" media are configured
19:49:30 <tmb> blino: that would work
19:49:43 <blino> ennael: #6675 is very old and tricky to debug :-/
19:50:39 <blino> ennael: #7317 shoud be pretty easy to fix
19:50:59 <ennael> can you have a look then on it and decrease priority for the first one?
19:52:20 <blino> why decrease the priority? both are important
19:52:23 <ennael> ok so no atelier guy around ?
19:52:32 <ennael> blino: well then ask for help to debug
19:52:54 <ennael> ok I will send matches on atelier ML
19:52:59 <blino> tmb: maybe we could use "urpmq --list-url" and filter out local media (I don't know how they are shown, maybe file://)
19:53:23 <blino> ennael: anybody is welcome to help debugging it, it just requires hours of patience
19:53:36 <ennael> please mail -dev about it
19:54:13 <blino> to ask for what? someone to fire gdb and debug it? :)
19:54:22 <ennael> well ok
19:54:25 <ennael> next topic
19:54:34 <ennael> #topic ML migration
19:54:38 <ennael> boklm: around ?
19:55:06 <ennael> ok
19:55:12 <ennael> anything about that migration ?
19:55:17 <ennael> pb to be reported ?
19:55:51 <tmb> well, it went mostly smooth..
19:56:01 <boklm> yes
19:56:28 <boklm> the main missing part now is gmane I think, but it should be fixed soon
19:56:37 <ennael> ok
19:56:46 <ennael> where do we store the archives ?
19:56:52 <ennael> for the old ML
19:57:00 <Remmy> and when do we shut down the old lists?
19:57:04 <boklm> ah, and we still need to get the archives from the old ML
19:57:10 <ennael> ok
19:57:40 <ennael> #action remaining tasks: gmame configuration, get archives of the old ML to be stored on Mageia servers
19:57:45 <boklm> I will check tomorrow if everything is ok for the migration, and tell guillomovitch he can close the old MLs, and send us the achives
19:58:35 <ennael> I've seen some people asking for modifications for the subject tag
19:58:50 <boklm> ah yes, we need to look at this
19:58:58 <ennael> ok
19:59:35 <ennael> what about having several mail address registered for ML?
19:59:45 <ennael> would be nice to have a definitive pov
20:00:02 <boklm> I think it would be difficult to do with only one account
20:00:28 <ennael> and about changing mail address through sympa interface?
20:00:34 <ennael> maybe we should disable this
20:00:39 <boklm> yes
20:00:41 <ennael> modifying sympa templates
20:00:49 <boklm> yes
20:01:05 <ennael> I can have a look on that one I've already played with sympa templates. I can have a look if you want
20:01:22 <boklm> ok
20:01:46 <ennael> so all this may be added on the wiki page about Mageia ML
20:02:06 <boklm> the updated template file will need to be added to http://svnweb.mageia.org/web/templates/sympa/trunk/
20:02:20 <tmb> well, ldap can store several e-mails, but I dont know if sympa can cope with it
20:03:08 <boklm> I think it would be possible to allow sending from several emails, but allow receiving on different emails I don't think sympa can cope with it easily
20:03:38 <ennael> maybe making it as easy as possible would be also a good alternative :)
20:03:58 <boklm> as easy as possible ?
20:04:11 <ennael> sorry avoid having zillions of options
20:04:15 <boklm> ah yes
20:04:19 <ennael> and make admin simple
20:04:23 <boklm> yes
20:04:29 <tmb> yeah, and I dont think its worth the pain to make a complex setup as most are happy with SSO and single mail
20:04:43 <ennael> yep
20:05:05 <boklm> what we need also is to add a something in identity to change email address that will update the address in sympa database
20:05:09 <Remmy> If people can make as many email addresses as they like, they can make one for Mageia only
20:05:49 <ennael> #action ML will be used *only* with identity account, using several mail addresses or change it through sympa interface will be disabled
20:07:09 <ennael> anything else on that ML migration?
20:08:19 <boklm> other things to do: update mageia-webteam@ mageia-marketing@ mageia-artwork@ bugzilla accounts to use atelier-bugs@ mailing list instead
20:08:32 <boklm> and I think that's all
20:08:39 <ennael> great thanks boklm
20:09:14 <Remmy> I think from bugzilla, it is not possible to assign bugs to sysadm-bugs, other than filing against infrastructure and keeping it at the default
20:09:27 <boklm> Remmy: ah ?
20:10:02 <boklm> Remmy: do you have an example of bug you want to assign to sysadmin-bugs but can't do it ?
20:10:04 <Remmy> boklm: I tried to do that today with an epoll thingy, and it would not let me set the assignee myself, only when I kept the default, did it go to sysadm
20:10:54 <boklm> did you try with sysadm-bugs or sysadmin-bugs ?
20:11:14 <Remmy> https://bugs.mageia.org/show_bug.cgi?id=9660
20:11:16 <[mbot> [ Bug 9660 epoll vote results give internal server error ]
20:11:42 <Remmy> I think I tried both, not sure. Just entering "bugs" as assignee did not show it in the drop down list either.
20:12:19 <leuhmanu> you have to type sysadminat least
20:13:15 <boklm> it worked in this one: https://bugs.mageia.org/show_bug.cgi?id=9669
20:13:17 <[mbot> [ Bug 9669 Test bug ]
20:13:52 <Remmy> Ok, I'll have another look tomorrow. But I think I tried most options today till I kept it at the default and that worked.
20:14:41 <boklm> ok
20:15:12 <leuhmanu> before the bugzilla upgrade it was needed to write the complete mail address
20:16:02 <leuhmanu> now with ajax it shiuld provide name in real time
20:16:41 <leuhmanu> (a bit slow on the smartphone sorry)
20:16:54 <Remmy> I'll test some more and will relay my findings to boklm and leuhmanu
20:17:01 <Remmy> Carry on :)
20:18:06 <boklm> ok, next topic ?
20:18:23 <ennael> well I think it's done as Trisj is not around tonight
20:18:44 <boklm> ok
20:18:50 <ennael> Trish
20:19:06 <ennael> so unless somebody wants to add something we can close the meeting
20:19:48 <tmb> not from me
20:19:52 <boklm> not from me
20:19:58 <ennael> ok
20:20:02 <ennael> thanks for attending
20:20:05 <ennael> #endmeeting