19:04:16 <ennael> #startmeeting
19:04:16 <Inigo_Montoya> Meeting started Mon Oct 15 19:04:16 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:16 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:04:20 <ennael> hi all
19:04:43 <MrsB> hi
19:04:47 <DavidWHodgins> Hi
19:04:50 <tmb> hi
19:04:54 <marja> hi
19:05:01 <ennael> #topic Alpha 2 release
19:05:08 <ennael> so finally it's out
19:05:15 <ennael> many thanks to tmb and QA team
19:05:20 <ennael> that was a real alpha
19:05:41 <MrsB> it was a pain wasn't it
19:05:45 <marja> I admire the perseverence you all showed
19:06:20 <DavidWHodgins> Glad I got my new system.  Made it possible to do a dozen installs in one day.
19:06:27 <sebsebseb> hi
19:06:34 <MrsB> you whizzed through them Dave
19:06:39 <ennael> 2 things for last alpha
19:07:00 <ennael> how should we organize things a bit better (many people registered, very few tested)
19:07:09 <ennael> planning for coming releases
19:07:36 <ennael> as a reminder alpha 3 is planned for 6th of november
19:07:42 <ennael> 3 weeks will be very short
19:08:05 <DavidWHodgins> Any timeframe for the usrmove, so we can start testing upgrading?
19:08:09 <MrsB> maybe we could allow a little more time for testing, I think we had 5 days prior to release this time
19:08:27 <ennael> MrsB: not only for tests but also for devs :)
19:08:33 <MrsB> yep
19:08:55 <MrsB> 7-10 days would be about right imho
19:09:06 <ennael> so beta 1 is 12th of december maybe we can switch to 12th of november for alpha 3
19:09:17 <ennael> then we have 1 month for each
19:09:19 <ennael> wdyt ?
19:09:42 <DavidWHodgins> One change I think would be good, would be to have the iso installers default to adding online repos, at beginning of install, unless network cannot be found, or user says no.
19:10:06 <MrsB> ennael: yes, it gives some extra time to break things before hand
19:10:36 <ennael> #info alpha 3 will be planned for 12th of november
19:10:42 <marja> DavidWHodgins: don't we have bad mirrors anymore (with the belnet mirror I always ran into trouble with online repos)
19:10:57 <tmb> I agree ... and I think we should freeze iso repo ~2-3 Nov.
19:11:05 <ennael> yep
19:11:31 <ennael> or at least start test builds at that time
19:11:43 <DavidWHodgins> marja: The repo adder should only check for up-to-date mirrors.
19:12:06 <ennael> second point is about testers
19:12:14 <marja> DavidWHodgins: OK, then I wouldn't object
19:12:16 <ennael> we had many people registered
19:12:25 <ennael> and very few of them did test isos
19:13:08 <MrsB> Here's the list of people who registered to help with testing: https://wiki.mageia.org/en/QA_ISO_testers
19:13:24 * tmb wonders if some of the ones registered only wanted early access to isos :/
19:13:36 <ennael> tmb: I would say that also
19:13:38 <MrsB> I think 5 or 6 actually did any testing
19:13:39 <coincoin> hello all
19:13:46 <MrsB> hi coincoin
19:13:54 <ennael> MrsB: maybe we can erase this list and start from blank for alpha 3
19:13:55 <marja> tmb: can you check how many different people downloaded the iso's?
19:14:01 <DavidWHodgins> I think some of them got turned off, when they found out how hard it is to figure out why gnome doesn't start, or other show stoppers.  Hopefully that won't happen next time.
19:14:03 <ennael> with real restriected access
19:14:04 <marja> coincoin: hi :)
19:14:15 <ennael> DavidWHodgins: you can't say that
19:14:25 <DavidWHodgins> Lol
19:14:30 <ennael> :)
19:14:36 <DavidWHodgins> I can hope. :-)
19:14:43 <ennael> hope is always possible :)
19:14:52 <ennael> but still we really need to have a better view
19:14:53 <marja> maybe we should discourage testing on bare metal if someone has only one machine?
19:15:08 <MrsB> ennael: I'd sooner leave the list at the moment. I agree with passwords though, it will give some inspiration to get involved if maybe it won't be available next time around.
19:15:53 <ennael> pb is whan isos are provided with fixes it's hard to guess who is testing really
19:15:56 <ennael> when
19:16:08 <ennael> and release time needs some kind of reactivity
19:16:10 <MrsB> We can definitely monitor it though and remove people who show no intention of testing. I think some as Dave said are put off with it being alpha stages and still a bit technical
19:18:36 <MrsB> we can perhaps issue individual passwords to people, it will give them a sense of responsibility then
19:18:54 <ennael> tmb: do you think we ca manage such thing ?
19:19:04 <marja> MrsB: did testers get warned to keep a stable partition, if they tested on bare metal?
19:19:11 <ennael> the point is not to create something too complicated
19:19:26 <MrsB> I think so marja
19:19:34 <marja> MrsB: ah, great :)
19:19:59 <MrsB> ennael: the simpler the better.
19:20:49 <tmb> ennael: I will test locking down rsync for alpha3, shouldn't be hard...
19:20:54 <ennael> ok
19:21:25 <ennael> #action tmb will have a look to lock rsync for alpha3 and MrsB will give access
19:21:26 <MrsB> DavidWHodgins: any thoughts on this?
19:22:07 <DavidWHodgins> I've checked man rsync, and it does support using a password, either through an environment variable, or a file, so simple to set up on our end.
19:22:29 <MrsB> i mean ways to get more people testing
19:22:34 <DavidWHodgins> Don't know what's needed on the rabbit end though.
19:22:59 <DavidWHodgins> I don't think we can do much, other then to try and encourage them on the discuss list, and irc.
19:23:19 <MrsB> yeah, we'll have to try and create some hype
19:23:29 <ennael> one point about sets of isos
19:23:39 <ennael> how do you prefer to work ?
19:23:56 <MrsB> in what way?
19:23:56 <ennael> erase all pad each time a new set is released or not ?
19:24:19 <MrsB> I think so yes, erase for the ones which have been updated. The archive was useful
19:24:27 <ennael> ok
19:24:28 <DavidWHodgins> Keep in mind that live and install are usually updated at different times.
19:24:41 <MrsB> you could clear the tests in progress bit too
19:24:49 <DavidWHodgins> So only the parts of the pad related to what gets updated needs clearing.
19:24:51 <ennael> yep ok
19:24:55 <ennael> DavidWHodgins: sure
19:25:00 <MrsB> well clear the relevant ones anyway
19:25:28 <MrsB> Could we add date.txt to live isos too please
19:25:40 <tmb> yep, and I forgot to update pad with every new release, sorry about that :/
19:26:03 <DavidWHodgins> Yes.  Makes it easier to indicate what's being testing, instead of using md5 hashes.
19:26:07 <MrsB> I think everybody was too tired to notice ;)
19:26:15 <tmb> yep, I'll add a date.txt for next builds
19:26:20 <MrsB> thanks
19:26:59 <MrsB> we can have a post-mortem at qa meeting on thursday with everybody
19:27:32 <ennael> also reports should be more focused on an alpha release
19:27:54 <ennael> it's not very usefull to have things like "movre that button on the right side it's better"
19:28:11 <ennael> we already have zillions of information it does not help
19:28:21 <MrsB> yes, I noticed that. it was somebody testing for the first time. We'll get better :)
19:28:29 <ennael> sure :)
19:28:38 <DavidWHodgins> Agreed. The priority for qa of an alpha, is to get a running system that can then be tested by the public, for the little bugs.
19:28:41 <ennael> but this can be added in a kind of "howto qa isos"
19:28:53 <MrsB> yeah, we can work on that
19:29:12 <ennael> thanks :)
19:29:25 <ennael> #action work on a howto to help new testers for isos
19:29:26 <MrsB> we can work on that.. as long as we get a chance between security updates.. i should add
19:29:36 <ennael> yep sure
19:29:59 <ennael> but we can open a pad or something like that and first list things we have in mind, not only you
19:30:11 <MrsB> great \o/
19:30:27 <marja> :)
19:30:39 <ennael> http://bn.parinux.org/p/howto_qa_iso
19:30:40 <[mbot> [ Etherpad Lite ]
19:30:45 <ennael> to start with :)
19:30:51 <MrsB> yeah, good idea
19:31:35 <ennael> ok
19:31:43 <ennael> anything else on the release ?
19:31:50 <MrsB> only.. Phew!
19:32:07 <tmb> :)
19:32:08 <DavidWHodgins> Now to get back into testing security updates mode. :-)
19:32:20 <marja> :)
19:33:36 <ennael> anything else ?
19:33:43 <DavidWHodgins> Not here.
19:33:44 <tmb> nope
19:33:49 <MrsB> nothing
19:34:02 <marja> how many more teams
19:34:18 <marja> have problems with new contributors not contributing?
19:34:25 <ennael> all ?
19:34:39 <ennael> but let's close that subject first
19:34:53 <ennael> I wanted to speak about forums but oliver is not around
19:34:53 <marja> well, if qa team finds a solution, we can all profit :)
19:34:59 <MrsB> :\
19:35:13 <ennael> so I will mail council ML and ask for it
19:35:19 <ennael> will avoid to loose some time
19:35:45 <ennael> small subject ddg
19:35:53 <ennael> #topic Duckduckgo
19:35:58 <ennael> so contract is now isgned
19:36:01 <ennael> signed
19:36:08 <ennael> no surprise inside
19:36:27 <MrsB> that's good
19:36:31 <ennael> now we need to modify a bit browsers to include what is asked
19:36:40 <ennael> will mail also rather -dev about this
19:37:12 <MrsB> will it be incorporated into mga2 too?
19:37:19 <ennael> would be nice yes
19:37:23 <ennael> so through updates
19:37:52 <MrsB> we'll have to publicise it well to see any benefit I think
19:38:20 <ennael> yep explaining why we think it's a nice thing to have
19:38:51 <MrsB> and asking people to consider going through DDG next time they buy something
19:39:35 <ennael> about upgrade, 21:39 < coling> I'll try and have a look on Sunday (have friends staying but they should be leaving fairly early)
19:40:26 <ennael> so we should be able to have it for alpha 3 release
19:40:26 <coling> I'll certainly have the installer working before too long (it should be quite easy), the mga2 "upgrade preparerererer" will be a little bit more fiddly, but still not a massive nightmare.
19:40:34 <MrsB> I think we have to be careful not to be seen to endorse ddg search but rather explaining the benefits to mageia of using it
19:40:56 <ennael> coling: oh you are here also :)
19:41:12 <tmb> ennael: he is everywhere... :)
19:41:16 <ennael> :)
19:41:30 <MrsB> if you want something doing, ask a busy person!
19:41:43 <ennael> MrsB: indeed when it's ready we can have a blog post explaining this
19:43:26 <ennael> any other topic? question?
19:44:00 <marja> ennael: the brazilian forum can be hosted without having a council decision about it?
19:44:22 <maat|lin> perhaps forums
19:44:29 <ennael> I guess so as we already have other forums
19:44:36 <marja> ennael: great :)
19:45:12 <ennael> questions ? comments ? pizza ?
19:45:13 <doktor5000__> ennael: yep, forums
19:45:53 <MrsB> hi doktor5000 maat|lin
19:46:03 <doktor5000> hi MrsB
19:46:08 <maat|lin> hi all
19:46:12 <maat|lin> hi MrsB
19:46:18 <ennael> mailing council at the moment
19:46:29 <ennael> if there is no other topic we can close this meeting
19:46:38 <doktor5000> ennael: forums?
19:46:43 <MrsB> forums i think
19:47:16 <ennael> #chair doktor5000
19:47:16 <Inigo_Montoya> Current chairs: doktor5000 ennael
19:47:43 <doktor5000> ennael: maybe maat|lin can also have a chair?
19:47:59 <tmb> doktor5000: MrsB: well we are missing obgr_seneca that was checking up some stuff regarding forums...
19:48:06 <doktor5000> we're not that young anymore and can't stant the whole time :)
19:48:15 <maat|lin> ^^
19:48:41 <ennael> obgr_seneca was intended to give some status on technical issues about authentication
19:48:53 <maat|lin> well
19:48:56 <ennael> I've just mailed council about this as we should have his feedback on it
19:49:01 <maat|lin> for authentication
19:49:23 <maat|lin> we could try lemonldap
19:49:23 <doktor5000> #topic forums
19:49:31 <doktor5000> anyways, just wanted to speak up on that part, as for my taste it was not really discussed and decided to fast that forums will be "out-sourced" ...
19:49:51 <ennael> please can we wait for oliver feedback?
19:50:25 <doktor5000> ennael: well, he does the technical feedback, no?
19:50:41 <maat|lin> ennael: tech feedback a bout what ?
19:51:21 <doktor5000> ennael: just to me it seemed like this whole thing was already decided, only implementation details to clear up ...
19:51:30 <ennael> listen guys if you don't read meeting logs I'm not going on my side to repeat all what was said last meeting
19:51:32 <doktor5000> if that is not the case, no problem to wait for oliver ...
19:51:41 <ennael> and we do not have any sysadmins around tonight
19:51:56 <ennael> and I need to leave soon (at least for me)
19:52:12 <doktor5000> ennael: i read the log, that's why i asked ...
19:52:55 <MrsB> I think the intention is to allow the person/people who were willing to admin the forums to do so in a safe environment
19:53:31 <maat|lin> i read the logs
19:53:40 <maat|lin> and i proposed several times lemonldap
19:54:23 <maat|lin> which is an answer to that need
19:54:26 <tmb> doktor5000: it's not really decided yet... the point is we need to fix privilegie separation and secure the forum software regarding logins/passwords... some things that obgr_seneca wanted to look into
19:55:27 <maat|lin> (and already packaged by kharec)
19:56:32 <tmb> so.. can we all agree to wait for obgr_seneca report, and take it from there... is that ok ?
19:56:38 <maat|lin> yes
19:56:50 <doktor5000> tmb: well, the introduction on that topic in last meeting and other parts had a bit of an acussatory sub-tone, and it was not only about security problems ...
19:56:51 <MrsB> seems sensible
19:57:01 <doktor5000> ok, let's wait for oliver
19:57:06 <ennael> mail just sent on coucil ML
19:57:08 <marja> would it be good to put the lemonldap proposal in an #info?
19:57:10 <ennael> council
19:57:37 <marja> for later reference?
19:57:49 <doktor5000> #info lemonldap was proposed as single-sign-on solution
19:57:49 <marja> if needed
19:58:43 <tmb> doktor5000: yeah... but we are trying to get all to "forget bad feelings/interactions" and try to find a way forward that is good for the Mageia project as such...
19:59:14 <tmb> because that is what should be top priority....
19:59:38 <maat|lin> \o/
19:59:52 <ennael> ok so let's go on on that topic on ML as soon as oliver gives feedbacks
20:00:00 <ennael> any other topic ?
20:00:05 <marja> not here
20:00:06 <doktor5000> well, we should also reflect on them and try to not make the same mistakes again and again, but anyways ...
20:00:09 <maat|lin> not for me
20:00:10 <MrsB> Things like this should not be allowed to fester really. We need to be more pro-active about them.
20:00:10 <doktor5000> ennael: nope
20:00:16 <tmb> doktor5000: true
20:00:33 <tmb> not from me
20:00:44 <tmb> MrsB: true
20:00:59 <MrsB> people get hurt and teams fall out and that hurts the mageia as a whole
20:01:06 <MrsB> -the
20:01:19 <ennael> ok thanks for attending
20:01:35 <ennael> #endmeeting