19:08:02 <ennael> #startmeeting
19:08:02 <Inigo_Montoya> Meeting started Mon Oct  1 19:08:02 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:08:02 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:08:08 <ennael> hi all
19:08:19 <MrsB> hi,merci!
19:08:40 <obgr_seneca> Hi all!
19:08:42 <leuhmanu> nothing nothing sorry
19:08:54 <tmb> hi
19:08:55 <ennael> obgr_seneca: welcome back :)
19:09:05 <obgr_seneca> Thx, it's good to be back!
19:09:54 <ennael> ok so first topic
19:10:12 <ennael> #topic Mageia 3 Alpha 2 release
19:10:28 <ennael> so QA tests have started saturday
19:10:44 <ennael> so far no big issue on my side for DVDs and dual
19:10:54 <ennael> tmb: any status on lives ?
19:12:13 <MrsB> broken :P
19:12:28 <tmb> not really besides me forgetting to fix background on boot menu, and I see one report about needing to specify xdriver :/
19:12:54 <MrsB> I don't think much testing has happened on livecd's yet
19:12:56 <ennael> is it for all tests ?
19:13:05 <ennael> MrsB: can you call for it ?
19:13:41 <MrsB> yes. I mentioned in an email but there are other areas not tested yet too, gnome/lxde/etc on the dvd's
19:13:56 <ennael> yep but this bugs is quite annoying
19:14:10 <MrsB> we haven't had much time yet
19:14:21 <MrsB> i'll ask to prioritise livecd's if you like?
19:14:30 <ennael> ok so as DVD are being rebuilt maybe we can switch to live for now
19:14:39 <tmb> well, some issues should be solved with the new systemd too...
19:14:46 <MrsB> ok np, i'll email later
19:15:09 <tmb> I will rebuild new live medias too to get the new fixed stuff
19:15:11 <ennael> tmb: any specific  bug report about this ?
19:15:42 <tmb> should be bug 7664
19:16:10 <MrsB> there were some other bits on the pad too. Could you create sections there for the live's tmb please
19:16:30 <ennael> tmb: is it the systemd one ?
19:18:10 <tmb> ennael: nope, 7664 is about xdriver. the systemd thing I havent seen yet, but will need checking when I rebuild the new isos
19:18:34 <ennael> ok le tus know so that we can ping colin on this if needed
19:18:54 <ennael> #info tests are in progress for alpha2 still some issued on live cds
19:19:50 <ennael> anything else on alpha 2 ?
19:20:23 <tmb> nope
19:20:24 <MrsB> I didn't have time to create bugs for the last things I found (bottom of the pad) I'll do so in the morning though.
19:20:42 <ennael> ok thanks
19:21:04 <ennael> #topic Final set of isos for Mageia 3
19:21:38 <ennael> so as you may know there were some discussions to ask for proposals and ideas for this final set
19:22:45 <ennael> https://www.mageia.org/pipermail/mageia-dev/2012-September/018750.html
19:22:46 <[mbot> [ [Mageia-dev] Mageia 3 final set of isos ]
19:23:17 <ennael> I tried to sum up all the proposals and ideas including also forums as we asked them also
19:23:20 <MrsB> there were alot of different views
19:23:37 <ennael> a lot but finally some common points
19:24:02 <ennael> and basically it looks like tmb proposal
19:24:19 <ennael> on live side
19:24:21 <ennael> 2 liveCDs:
19:24:21 <ennael> - 1 GNOME 700M i586 - english only - for FOSDEM & co
19:24:22 <ennael> - 1 KDE   700M i586 - english only - for FOSDEM & co
19:24:22 <ennael> 4 liveDVDs:
19:24:24 <ennael> - 1 GNOME DVD i586   - all locales-*
19:24:27 <ennael> - 1 GNOME DVD x86_64 - all locales-*
19:24:29 <ennael> - 1 KDE   DVD i586   - all locales-*
19:24:32 <ennael> - 1 KDE   DVD x86_64 - all locales-*
19:25:00 <ennael> as said tmb Doing 2 livecds & 4 livecds would drop live isos from 16 -> 6
19:25:10 <ennael> we provide both CD and DVD
19:25:11 <obgr_seneca> sounds good
19:25:13 <leuhmanu> english only ?
19:25:21 <MrsB> yes, instant time saving
19:25:22 <ennael> on CD side
19:25:35 <MrsB> english only == EU1 ?
19:25:39 <ennael> for classical installer
19:25:57 <ennael> dual + 2 DVDs 32 and 64 including a way to add non-free drivers
19:26:22 <ennael> meaning ask people if they want non-free frivers
19:26:24 <ennael> drivers
19:26:48 <MrsB> would it better to ask people if they want stictly free ?
19:27:11 <ennael> well we will have to work on this indeed :)
19:27:19 <ennael> but the point is to give a way to access it
19:27:21 <DavidWHodgins> Default to including non-free?
19:27:32 <ennael> nope
19:27:35 <sebsebseb> hi
19:27:37 <tmb> nope, we are promoting free software...
19:27:38 <MrsB> hi
19:27:50 <ennael> I spoke with a girl working for Linux Magazine France
19:27:51 <obgr_seneca> I would default to free with a possibilty to add non-free
19:28:01 <MrsB> regarding livecd's tmb, the english only ones are they basically EU1 or literally english only?
19:28:07 <ennael> and ask her what was needed to be included on a magazine
19:28:28 <ennael> they would prefer CD rather than DVD
19:28:43 <tmb> MrsB: literally english only, to gain some space for more full GNOME/KDE env
19:28:48 <MrsB> ok ty
19:28:50 <ennael> and include non free drivers but asking people if they want it
19:29:28 <MrsB> as long as the nonfree is there it will save alot of headaches, whichever way it works
19:29:34 <ennael> yep
19:29:43 <ennael> so does it look reasonable, sensible ?
19:29:56 <MrsB> to me, yes
19:30:08 <obgr_seneca> yep
19:30:13 <MrsB> i think it covers a wide range of what people have been asking for
19:30:14 <leuhmanu> so will the nonfree stuff be in the media ?
19:30:39 <ennael> leuhmanu: it can be yes but tmb is also checking a way to provide as an extra media
19:31:13 <DavidWHodgins> Will we be supporting upgrading from Mageia 2 using iso images?
19:31:25 <ennael> using classical installer yes
19:31:39 <leuhmanu> (that remember me mdv in 3 cds)
19:31:50 <ennael> provided they may have some missing packages as DVD is only 4 Go
19:32:09 <MrsB> the upgrade will ned to check for nonfree then
19:32:19 <MrsB> need*
19:32:19 <ennael> yep
19:32:38 <ennael> if you all agree we can send it to -dev ML to announce it
19:32:49 <leuhmanu> ok for me
19:32:53 <obgr_seneca> ok
19:32:54 <ennael> and try to fix the pending point about non-free drivers management in DVD
19:33:14 <ennael> tmb: is that ok for you ?
19:33:30 <tmb> yep
19:33:32 <ennael> boklm: ok ?
19:33:51 <boklm> ok
19:34:05 <ennael> ok I will ssend the mail after meeting then
19:34:25 <ennael> #action send an email about final set of isos after proposals on -dev ML
19:34:48 <ennael> anything else on this ?
19:35:23 <ennael> we had also some demands for vm of Mageia released for final Mageia3 ?
19:35:30 <ennael> wdyt ?
19:35:48 <ennael> (of course more work for QA but it can be done just after release)
19:35:48 <obgr_seneca> vm image? for what vm soft?
19:36:00 <obgr_seneca> vbox? vmware? qemu?
19:36:32 <ennael> it was not said :)
19:37:05 <tmb> iirc all reads .vdi. so that would probably be best
19:37:27 <obgr_seneca> yep
19:37:32 <ennael> wdyt about this idea ?
19:37:57 <obgr_seneca> I was asked some time ago by some upstream developer, when discussing a bug with him
19:38:06 <obgr_seneca> so it would be good to have such images
19:38:11 <ennael> he asked for a vm ?
19:38:22 <obgr_seneca> yep to test it himself
19:39:17 <MrsB> vmware has a kind of appstore for these things doesn't it
19:39:18 <tmb> of course this adds to the QA then ...
19:39:35 <MrsB> it can be doen after release though can't it
19:40:04 <ennael> yep
19:40:19 <ennael> but it needs proper QA, same as for isos
19:40:26 <MrsB> it's less affected by hardware too, it'll work or not work
19:40:54 <MrsB> it's equivalent to one iso, after release, so no biggy really
19:40:54 <tmb> and then to decide _what_ to add to image, what arch and so on
19:41:01 <ennael> yep
19:44:21 <ennael> ok so can we agree on this but decide later what to add inside ?
19:44:37 <tmb> yep
19:44:39 <obgr_seneca> ok with me
19:44:46 <MrsB> sounds good, yeah
19:44:53 * boklm thinks it can be useful
19:45:06 <ennael> ok
19:45:11 <MrsB> yeah, even if it's just a basis for the community to build their own from
19:45:57 <ennael> #action we will release virtual machine for final release, we still need to decide what to add inside
19:46:10 <MrsB> for final or after final?
19:46:21 <ennael> #undo
19:46:21 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x844436c>
19:46:29 <ennael> #action we will release virtual machine after final release, we still need to decide what to add inside
19:46:32 <ennael> thanks :)
19:46:33 <MrsB> :)
19:48:16 <ennael> anything else on that topic ?
19:51:02 <MrsB> all done i think
19:51:09 <ennael> ok
19:51:17 <ennael> last but not the least
19:51:27 <ennael> #topic solve pending forum situation
19:53:13 <ennael> so here are the facts on my side
19:53:32 <ennael> we have pb on one team, forum since the beginning
19:53:46 <ennael> I spent some time this summer to relaunch this team
19:53:53 <ennael> organize first meetings
19:54:13 <ennael> we were waiting for some results like policies, council meeting attending, meetings
19:54:21 <ennael> for now nothing much happened
19:54:44 <ennael> except troubles and personal ackward mails
19:55:13 <ennael> it seems mixing sysadmins and forum admin cannot work
19:55:26 <ennael> we have to find a solution and switch to other subjects
19:55:34 <ennael> your turn now :)
19:56:02 <MrsB> My understanding is that somebody has offered to sysadmin the forums
19:56:09 <leuhmanu> only forums on mageia.org ?
19:56:16 <leuhmanu> ie en and de ?
19:56:36 <ennael> forums.mageia.org
19:56:41 <obgr_seneca> There are no others on Mageia infra
19:56:58 <boklm> for me, best solution is to separate forums from sysadmin team, and let forums team manage forums on their own
19:57:06 <leuhmanu> (ok no comment my side)
19:57:29 <obgr_seneca> boklm: that would mean an extra account for forums?
19:57:34 <boklm> obgr_seneca: yes
19:58:03 <MrsB> is it a silly question to ask why the volunteer shouldn't be allowed to do so? I realise there are security concerns but there must be ways to work around that.
19:58:19 <boklm> allowed to do what ?
19:58:32 <MrsB> to become sysadmin in charge of forums
19:58:35 <ennael> it seems phpbb database contains all login/password of ldap database
20:00:23 <obgr_seneca> And phpbb stores the passwords itself, not some hash value?
20:00:35 <boklm> it store hash value
20:00:54 <obgr_seneca> So there are no actual passwords in the db?
20:01:14 <boklm> but controling phpbb is the same as having access to passwords of people who log in to the forums
20:02:08 <boklm> and hash values can be used to bruteforce passwords
20:02:46 <MrsB> I would see this as an opportunity to grow sysadmin team and improve the service to the community rather than a reason to separate the community.
20:03:14 <boklm> I think it will grow the problems to sysadmin team
20:03:50 <MrsB> in what way?
20:04:37 <boklm> we will have the same attacks and useless discussions, except it will not only be about forums
20:05:38 <MrsB> i think both sides feel a bit agrieved about this but Im sure if personal feeling can be put to one side a bit then things could be improved
20:06:01 <ennael> well we already tried too many times
20:06:01 <obgr_seneca> would it be possible to keep the forums on the same domain as they are now, but on a different machine?
20:06:26 <obgr_seneca> And keep every data except the passwords, so users can have new passwords for the forums sent to them?
20:06:47 <MrsB> what facts though prevent a volunteer from taking charge of sysadmin'ing the forums, apart from bad personal feelings
20:07:09 <ennael> obgr_seneca: meaning it does not use ldap ?
20:07:31 <MrsB> we can't expect to like everybody in the community but we should be able to work with them with the same goal in mind
20:07:32 <boklm> I think we can provide db dumps, without the passwords, so that forum messages and users can be reimported to the new forums, and users only need to reset password to login
20:07:59 <MrsB> it's looking very much like a decision has already been reached..
20:08:13 <obgr_seneca> ennael: yep, if there are security concerns about passwords in phpbb
20:08:32 <ennael> yep indeed
20:09:03 <MrsB> fragmenting the community is a bad idea imho. We need to be more inclusive if anything.
20:09:07 <obgr_seneca> I still don't like it
20:09:33 <boklm> fragmenting the community is bad, but wasting some much time on this since the beginning of the project is worse
20:09:50 <boklm> s/some/so/
20:10:01 <MrsB> yep, so why not allow the person who is willing to devote their time to doing it, do it
20:10:33 <MrsB> there must be a way to limit their reach so you can monitor them as you would expect to do with any new admin i would guess
20:11:01 <boklm> we can provide a VM where they setup forums themself
20:11:31 <ennael> they still can use git to store it as now
20:11:36 <MrsB> that would allow safety and inclusivity, with same ldap stuff
20:11:40 <boklm> without ldap
20:11:53 <obgr_seneca> So the only thing that would change would be a separate password?
20:11:57 <MrsB> what is the benefit of that? I'm missing something?
20:12:06 <ennael> obgr_seneca: with current situation, yes
20:13:13 <MrsB> one sec pls
20:13:45 <tmb> well, have anyone looked into fixing the phpbb braindamage of storing the pw hashes ?
20:14:34 <obgr_seneca> I didn't but I can try and look into it
20:14:41 <obgr_seneca> If you give me a week
20:14:43 <tmb> I mean I like the idea of SSO, so breaking ldap connection would be backwards, ....
20:16:21 <boklm> if we want secure SSO, I think it would be better to use something like https://login.persona.org/
20:16:22 <[mbot> [ Mozilla Persona: A Better Way to Sign In ]
20:18:38 <tmb> as for the question of adding more sysadmins is that we "dont know them enough", and current setup does not rely on privilegie separation, so they would gain too much power...
20:19:11 <MrsB> wouldn't a VM solve that problem though?
20:19:34 <boklm> not if it's a VM with ldap authentication
20:19:38 <MrsB> i apologise if I'm asking silly questions btw
20:19:57 <ennael> MrsB: be carefull you may have silly answers :)
20:20:08 <MrsB> as long as i don't get shouted at :D
20:20:56 <obgr_seneca> Can't we have some time to look for a way of separating the forums without breaking passwords?
20:21:13 <obgr_seneca> And without giving them to someone outside of sysadmin team?
20:21:25 <ennael> tmb, boklm ?
20:21:38 <tmb> well, the ldap auth should be done with  a restricted and read-only account, so it only can get ack/nack from the server without reading too much info...
20:21:53 <obgr_seneca> tmb: yep
20:22:29 <ennael> can we say we spend the coming week on this if we can get a solution?
20:22:42 <ennael> blingme may be also pinged
20:22:45 <obgr_seneca> I would look into it
20:22:50 <MrsB> from the view of somebody who hasn't been involved in the discussions and only found out about this a week ago, separating the forums completely as proposed would be a bad thing. It fels like pushing the community away and that's just not something we can afford to do.
20:22:56 <obgr_seneca> I'll ping people if I need info
20:23:42 <tmb> well, as for solving it I dont see a need for a "sudden rush" to fix/break/... the forums.. I mean they still work. and this issue has been like this for a long time, so a week or so more does not really make any difference
20:23:43 <boklm> we can maybe use http://www.openid-ldap.org/ and add support for openid in phpbb
20:23:44 <[mbot> [ OpenID-LDAP / Home ]
20:24:39 <obgr_seneca> ok, boklm, I'll come back to you about that these days
20:24:44 <ennael> #action obgr_seneca will have a look on how to keep password not accessible and then find a way to manage forums
20:24:45 <obgr_seneca> But I have to leave now
20:24:57 <ennael> thanks for that obgr_seneca
20:24:59 <MrsB> thankyou obgr_seneca
20:25:15 <ennael> boklm: can you send these urls on sysadmin ML?
20:25:15 <obgr_seneca> ok!
20:25:19 <boklm> ok
20:25:23 <ennael> great
20:25:36 <obgr_seneca> I have to get up early tommorow, so see you!
20:25:39 <ennael> let see the conclusions in next meeting then, next week
20:25:42 <ennael> obgr_seneca: bye
20:25:48 <obgr_seneca> bye
20:25:49 <MrsB> cya
20:25:57 <ennael> fast :)
20:26:04 <MrsB> lets hope so :D
20:26:16 <ennael> so very last topic in fact an information
20:26:23 <ennael> #topic Mageia artwork
20:26:40 <ennael> rda will meet the guy we met in June
20:27:01 <ennael> he is a professional designer and agreed to work on Mageia stuff
20:27:13 <MrsB> is this The guy. The one who's gave his permission for mga2 artwork?
20:27:20 <MrsB> who*
20:27:22 <ennael> nope
20:27:26 <MrsB> another guy
20:27:29 <ennael> yep
20:27:32 <MrsB> great :)
20:27:36 <ennael> yes :)
20:27:40 <leuhmanu> you should said that to artwork team
20:27:47 <ennael> he will give first results next week
20:27:52 <ennael> leuhmanu: they are already informed
20:27:52 <leuhmanu> as max is starting something
20:27:59 <ennael> there was a mail on atelier ML
20:29:06 <leuhmanu> ok
20:30:18 <ennael> so as soon as we get something we will provide it
20:30:44 <ennael> if you don't have any other topic I will on my side go back to isos :)
20:31:01 <MrsB> nothing here, thankyou ennael
20:31:08 <ennael> thanks all for attending
20:31:14 <ennael> see you next week then
20:31:18 <ennael> #endmeeting