19:08:25 <ennael> #startmeeting
19:08:25 <Inigo_Montoya> Meeting started Tue Aug 21 19:08:25 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:08:25 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:08:26 <marja> ennael: yes
19:08:30 <ennael> ah :)
19:08:35 <ennael> hi all
19:08:39 <marja> hi :)
19:08:42 <MrsB> hiya
19:09:06 <sebsebseb> hi
19:09:17 <marja> brb
19:09:43 <ennael> hope you are all fresh and ready :)
19:10:01 <boklm> maybe not fresh
19:10:11 <MrsB> probably not ready
19:10:15 <ennael> :)
19:10:17 <ennael> ok
19:10:22 <ennael> let start then :)
19:10:33 <ennael> #topic teams review
19:12:20 <ennael> so could you just give some information about what happen these last weeks
19:12:34 <MrsB> I can start if you like
19:12:52 <marja> yes please start :)
19:12:56 <ennael> yep
19:13:00 <MrsB> I was away for the last couple of weeks so playing catch-up but..
19:13:15 <ennael> #chair MrsB marja boklm
19:13:15 <Inigo_Montoya> Current chairs: MrsB boklm ennael marja
19:13:50 <MrsB> stormi had a big push at reducing the qa bugs list, he led the charge and did a great job.
19:14:05 <MrsB> we have a new bugs list now and added some features..
19:14:29 <MrsB> finding a link..
19:15:13 <MrsB> sorry, computer is having a fit
19:15:29 <MrsB> http://mageia.madb.org/tools/updates
19:16:01 <MrsB> As you can see this bring everything together nicely and shows alot more information for us at a glance
19:16:49 <MrsB> We've begun utilising the severity setting n bugzilla for security updates too to help priotising the important ones
19:17:07 <MrsB> you can see this on the list too
19:17:55 <MrsB> we've also begun using a 'feedback' keyword in the whiteboard when we ask a question and waiting on packager feedback, those are the grey ones on the list.
19:18:42 <MrsB> We've had a few new volunteers over the last week or so too, which was nice to find when I got back form holiday
19:19:12 <MrsB> also somebody got in touch privately about contributing as a result of the blog post interview
19:19:35 <MrsB> ennael: I CC'd you into the reply, I think he's waiting for you
19:19:50 <MrsB> Thiago
19:20:22 <MrsB> We've validated over 70 updates so far in august
19:20:49 <MrsB> so we owe Stormi a big thankyou :)
19:20:54 <marja> :)
19:21:25 <MrsB> I can't think of anything else right now :\
19:21:37 <marja> MrsB: it is a great review
19:21:45 <ennael> MrsB: yep mail in progress
19:21:58 <ennael> great result indeed
19:22:00 <MrsB> thanks, I've been catching up so it's all still fresh :D
19:22:33 <ennael> #info 70 updates have been pushed in august
19:22:40 <MrsB> so far
19:23:05 <MrsB> it was 90 something in July
19:23:06 <ennael> #info thanks to Stormi qa team is working with new tool to follow updates process http://mageia.madb.org/tools/updates
19:23:44 <ennael> anything else to add ? new comers in team ?
19:23:48 <MrsB> the list is alot shorter  now and the new webpage brings shows all important info at a glance
19:24:43 <MrsB> Not yet, I sent an email yesterday and was mentoring Bullrich but I haven't been on most of today so it's a bit early
19:24:53 <ennael> ok
19:24:59 <ennael> marja ?
19:25:12 <marja> Docteam: It was great to find out that, for the not working help buttons in installer, five filenames papoteur found are the solution.
19:25:27 <marja> We are working on filling those pages with text, but need help with good text for
19:25:35 <marja> http://docteam.mageia.nl/installer/content/setupBootloaderAddEntry.html
19:26:14 <marja> We will also need help with texts for many MCC help pages (many pages are made yet, most pages don't have real text)
19:26:24 <marja> http://docteam.mageia.nl/en/MCC/content/
19:26:31 <ennael> maybe you can ask on -dev for bootloader first
19:26:38 <marja> ennael: OK
19:26:50 <marja> The problem with the wiki upgrade (needed for the translate plugin) hasn't been solved yet
19:27:15 <marja> but I hope that when obgr_seneca finished his thesis, that he'll see a way to solve it
19:27:33 <ennael> yep we should see him back next week
19:28:03 <ennael> #action marja will mail -dev to get more information for doc on bootloader and later on mcc
19:28:17 <ennael> anything else ?
19:28:35 <marja> not that I can think of now
19:28:43 <ennael> ok
19:29:02 <ennael> boklm: ? about sysadmin ?
19:30:04 <boklm> about sysadmin, we received two new servers, to replace rabbit (server to build isos) and ecosse (server for the build system)
19:30:25 <boklm> and it's planned to bring the servers to Marseille datacenter next week
19:30:32 <boklm> https://wiki.mageia.org/en/Marseille_3
19:30:49 <coincoin> maat: will you be there?
19:32:00 <marja> coincoin: he has once said that he works 15 minutes away from the datacenter
19:32:16 <marja> coincoin: but if you'd like him to be there, it might be good to invite him
19:32:34 <coincoin> maat: I know, we invited him
19:32:38 <coincoin> marja: ^
19:32:50 <marja> coincoin: lol
19:32:53 <marja> coincoin: good :)
19:32:55 <coincoin> marja: but he said "perhaps", so, I'm asking again :)
19:33:11 <marja> coincoin: I understand :)
19:36:14 <ennael> #action sysadmins are planning a trip to datacenter next week to bring new servers
19:36:19 <ennael> anything else ?
19:36:46 <boklm> I think that's all, unless coincoin or tmb want to add something more
19:36:56 <coincoin> new servers and new switch
19:37:04 <coincoin> no, all is on the wiki
19:37:49 <MrsB> will the work affect any of the websites or is it just those two affected?
19:38:24 <ennael> current rabbit will be kept until new one is ready
19:38:37 <ennael> so alpha 1 will be built on old server
19:38:42 <boklm> we will have to disconnect the servers to replace the switch
19:38:52 <ennael> should not be long I guess ?
19:38:59 <coincoin> "should not" :�
19:39:10 <MrsB> small downtime then, *probably*
19:39:19 <ennael> you are right
19:39:28 <ennael> release time means some pb must happen :)
19:39:35 <marja> grinz
19:40:09 <ennael> ok about packagers team, we  should have our meeting back tomorrow
19:40:29 <ennael> and coming focus is on this alpha1 release
19:41:26 <ennael> we need to get back to mentoring also
19:43:15 <ennael> will mail after tomorrow's meeting
19:43:49 <ennael> anything else to add ?
19:43:58 <boklm> not for me
19:44:09 <MrsB> nothing here
19:44:14 <marja> ennael: did the simplew problem get solved, or is that to be discussed?
19:44:20 <tmb> not from me
19:44:54 <ennael> nothing new for now will try to investigate
19:45:03 <marja> OK
19:45:06 <sebsebseb> I got somethign
19:45:07 <sebsebseb> I want to mention
19:45:38 <ennael> speak now or never :)
19:45:52 <sebsebseb> right is this otehrwise end of meeting?
19:45:57 <ennael> nope
19:46:02 <ennael> is it a new topic ?
19:46:05 <sebsebseb> yep
19:46:14 <ennael> ok after the one in list then
19:46:19 <sebsebseb> ok :)
19:46:31 <ennael> #topic Mageia 3 alpha 1 release
19:46:41 <ennael> ok back in releases hell
19:47:05 * tmb hides
19:47:09 <ennael> :)
19:47:11 <marja> tmb: lol
19:47:15 <MrsB> i think you summed up that topic nicely
19:47:22 <marja> grin
19:47:29 <ennael> on my side I'm building some isos for rsync purpose only
19:47:52 <MrsB> Did we diecide which ISO's we would be having yet?
19:47:55 <ennael> so that you have only to complete when the one to be tested are ready
19:47:58 <ennael> nope
19:48:09 <ennael> what I propose for alpha1
19:48:37 <ennael> free DVDs, dual and one live KDE + 1 one live GNOME
19:49:10 <MrsB> for an alpha that is probably sufficient. We need to make some decisions for later though
19:49:12 <ennael> time is short now and we can discuss about isos after alpha1 to have decision for alpha2
19:49:22 <sebsebseb> you mean one Live CD for GNOME and KDE, not lots, because of different languages?
19:49:23 <ennael> does it sound reasonable ?
19:49:32 <marja> ennael: yes it does
19:49:38 <coincoin> yes, I agree with it
19:49:41 <marja> sebsebseb: only for alpha1
19:49:47 <sebsebseb> yep that sounds fine :)
19:49:56 <MrsB> yep thats fine, we need this info to plan qa
19:50:36 <MrsB> we're hoping to use a collbaborative spreadsheet. See how it goes.
19:50:44 <MrsB> -b
19:50:45 <tmb> hm, so only i586 livecds then ?
19:52:12 <sebsebseb> that's a point don't need 64bit for alpha 1 I guess,  32bit though yep that's needed
19:52:34 <MrsB> we may even have live dvd's instead later
19:52:44 <sebsebseb> yep :)
19:54:30 <ennael> tmb: do you think you can manage some builds ?
19:55:01 <tmb> well, my thougts for mga3 is 2 i586 livecds (maybe english only) to take to fosdem/and the like, and 4 livedvds 2 arch x 2 DE
19:55:28 <tmb> ennael: I will try to see what rabbit likes building mga3 code :)
19:55:34 <marja> :)
19:55:54 <ennael> I have a 32bit dvd working quite ok
19:56:10 <ennael> except a mouse pb in stage2 which is already reported
19:57:20 <ennael> #action isos to be tested for alpha1: free DVDs, dual and one live KDE + 1 one live GNOME
19:57:39 <ennael> MrsB: I will ping you tomorrow to start rsync
19:58:10 <MrsB> ok thanks. We can discuss it in our meeting then
19:59:27 <MrsB> did you see how we propose to manage the testing?
19:59:28 <ennael> we will mail also -dev so that packagers can push updates for this first alpha to have feedbacks
19:59:39 <ennael> MrsB: using spreadsheet ?
20:00:27 <MrsB> http://www.ethercalc.org/qa we made this some time ago. It needs populating still but we haven't been bale to without knowing which ISO's would be built
20:01:03 <MrsB> s/bale/able
20:01:31 <ennael> ok
20:01:33 <tmb> ennael: when do we freeze iso repo ?
20:01:53 <ennael> tmb: well I'm testing installer at the moment
20:02:07 <ennael> so I guess 4 or 5 days before
20:02:30 <MrsB> morning Dave
20:02:48 <DavidWHodgins> HiYa
20:02:50 <marja> DavidWHodgins: hi :)
20:02:56 <DavidWHodgins> Meeting over already?
20:02:57 <ennael> tmb: so something like 30 or 31/08
20:03:01 <ennael> please
20:03:15 <MrsB> not yet Dave
20:03:26 <tmb> ennael: ok, will do some initial tests before...
20:03:30 <ennael> ok
20:03:42 <ennael> hope it will be a bit easier :)
20:04:13 <ennael> MrsB: also it would be nice not to spread url for isos download
20:04:31 <ennael> to avoid unusefull feedbacks
20:04:43 <MrsB> yes, we could maybe change the url between releases?
20:04:44 <tmb> I guess we should pw protect it
20:04:50 <ennael> yep
20:05:03 <ennael> if we don't spread that passwd :)
20:05:17 <tmb> yeah, lets stick that on the wiki :)
20:05:22 <ennael> :))
20:05:52 <marja> ennael: isn't it possible to use everybody's global identity.... so own username + password?
20:06:06 <marja> ennael: and only let QA have access
20:07:03 <MrsB> we don't want to restrict it too much, to too tight a group or the testing won't be representative. It's a problem we found with mga2, it worked on the ones we were testign with but we found issues on others
20:07:27 <marja> OK
20:07:36 <ennael> well just to avoid having url in blog comment :)
20:07:51 <MrsB> yeah :)
20:08:11 <ennael> and also spread the isos that will be uploaded tomorrow
20:08:27 <ennael> again it's just to start rsync process
20:08:55 <MrsB> yes, ping about those please and I'll make some notes
20:09:00 <ennael> ok
20:09:08 <ennael> anything else to add/ask ?
20:09:19 <sebsebseb> ready for next topic here
20:09:33 <MrsB> nothing I can think of
20:10:03 * marja thinks we could do better with the bugs that are found in alpha's etc
20:10:21 <ennael> well providing we have feedbacks on
20:10:35 <marja> ennael: that is the problem :/
20:10:36 <ennael> the point is to get it before RC :)
20:10:43 * MrsB plans to find some bugs :D
20:10:56 <ennael> ok next topic ?
20:10:57 * tmb plans to introduce some :)
20:11:00 <marja> MrsB: without planning, you'll find them too ;)
20:11:05 * ennael slaps tmb
20:11:09 <marja> tmb:20:11:30 <ennael> ok
20:11:33 <marja> ennael: yes, next topic
20:11:35 <MrsB> we're better prepared this time around
20:11:39 <ennael> #topic users community
20:11:48 <sebsebseb> yay community topic :)
20:11:58 <ennael> ok this is just to start discussion on that one
20:12:18 <ennael> I'm having more and more questions about that point
20:12:45 <ennael> since mageia project has started, we rather focused on developement
20:12:52 <sebsebseb> indeed
20:12:56 <ennael> packaers, i18n...
20:13:10 <sebsebseb> need community people to :) such as myself
20:13:26 <ennael> now that mageia popularity is growing and is getting more visibility it's time also to take care of users
20:13:40 <sebsebseb> yep
20:13:45 <MrsB> i strongly agree
20:13:52 <sebsebseb> same here
20:13:54 <ennael> documentation is a big part for it
20:14:22 <ennael> but we need also to try to organize feedbacks, discussions, various needs
20:14:31 * marja agrees and hides
20:14:35 <sebsebseb> event boxes for loads of counteries etc yep
20:14:35 <ennael> :)
20:15:11 <ennael> so it's a bit late today to go further but still it would be nice to start a workshop on it
20:15:38 <ennael> and imho it should be a transversal work
20:15:50 <MrsB> what does that mean?
20:15:51 <marja> MrsB: what is transversal?
20:15:54 <marja> lol
20:15:54 <MrsB> lol
20:16:07 <ennael> users do not kill even technical guys can deal with :)
20:16:28 <ennael> meaning not having 2 groups: tehcnical and users one going on on their own side
20:16:36 <sebsebseb> yep indeed
20:17:21 <ennael> these are some ideas but it needs to be refined and developed
20:17:30 <MrsB> how do we accomplish that, it might be a question of changing old habits
20:17:32 <sebsebseb> by the way for community buiding I want to recomend a book, that people keep on recommending.  The Art of Community by Jono Bacon (the Ubuntu Community Manager), download it as an Ebook or buy it, I bought it at an event last weekend
20:18:01 <marja> sebsebseb: thx
20:18:13 <sebsebseb> marja: you're welcome :)
20:18:14 <ennael> MrsB: well it can be a way also to differenciate Mageia from other distros
20:18:36 <MrsB> yes, I think it could be one of our greatest strengths
20:19:05 <ennael> so I will create a wiki page for brainstorming
20:19:10 <marja> ennael: how do you think our community should be different (or is different) than other distro's communities?
20:19:14 <ennael> just to start with
20:19:53 <ennael> marja: just as said above... try to have transversal communication between our teams and between users group and devs group
20:20:13 <ennael> not an easy thing
20:20:21 <marja> ennael: I wasn't aware that is missing in other communities (I don't know them) ;)
20:20:36 <marja> ennael: thx, sounds good :)
20:20:48 <sebsebseb> cloest we had to anything community teamswise was the marketing and communications team now Atelier,  but indeed this is a great time to focus more seriously on the Mageia community as in the users, and events and so on.   Magiea is number 3 on distrowatch after all which means there is quite a lot of interest out there :)
20:20:56 <sebsebseb> distrowatch is done on page views not installs
20:21:59 <ennael> #action start brainstorm to add users group in Mageia project and organize it to help Mageia users
20:21:59 <MrsB> i think one major problem we have is people are used to taking their linux distribution as a product now. There are alot of commercial or commercially backed distro's and users feel disconnected
20:22:42 <MrsB> it doesn't come naturally now for them to feel they have a voice
20:22:53 <ennael> well we can't say ubuntu support is commercial one
20:22:56 <sebsebseb> MrsB: or they think they have a voice, in the commerical distro's community for exmaple
20:23:01 <sebsebseb> I mean if they get invovled with it enough
20:23:25 <ennael> anyway if you agree on this we can start brainstorm and discussion
20:23:34 <ennael> I will mail the url tonight
20:23:35 <marja> OK
20:23:46 <MrsB> yep, definitely
20:23:46 <sebsebseb> we need to get
20:23:51 <sebsebseb> local teams sorted out in each country more properly I think
20:24:06 <ennael> ok
20:24:15 <ennael> any other topic ? question ? comment ?
20:24:16 <MrsB> we need to establish lines of communication first I think
20:24:17 <sebsebseb> for example I seem to be the only person in Mageia in the UK, who wants to go to events when there's an oppertunity and promote it, and that's not a good thing, if the only one or pretty much really
20:24:37 <marja> sebsebseb: I felt rotten about that
20:25:17 <marja> sebsebseb: if I had known about that event longer before, I would have tried to arrange to be there
20:25:39 <sebsebseb> also the USA has quite a lot of interest,  people from different states,  quite a few of them come to #mageia-social I am sure local community type things can be arrnaged there, for the different states, when talking to people about that
20:25:42 <marja> MrsB: would you be interested in going to UK events?
20:25:54 <ennael> guys ?
20:25:59 <sebsebseb> marja: well there's next year
20:26:10 <ennael> can we close meeting, yuo can discuss after :)
20:26:19 <sebsebseb> something I want to mention quickly first
20:26:21 <ennael> we have isos to break now :)
20:26:48 <MrsB> money is tight for us marja sadly, maybe though
20:27:03 <sebsebseb> ok so at that event, didn't get to do my talk for various reasons, such as the voting system going down when I needed to do votes. so am now going to do something quite special for hacker public radio instead, with my idea's
20:27:20 <sebsebseb> yep not everyone has money to go to events, even if it's in the same country, that's very true indeed
20:27:58 <sebsebseb> I am ready to close meeting
20:28:02 <ennael> ok thanks for attending tonight I guess we will have tons of idea for users community
20:28:07 <tmb> I have one thing
20:28:11 <ennael> yep ?
20:28:47 <tmb> its regarding mageia 2 kernel :)
20:28:59 <MrsB> ooo have you fixed my laptop?
20:29:16 <sebsebseb> oh what happended with the kernel?
20:29:20 <boklm> about upstream support ?
20:29:30 <ennael> wait
20:29:42 <ennael> #topic maintainance of kernel
20:29:43 <tmb> after we have processed the current 3.3.8 in updates_testing, I plan to start rebasing to 3.4 series wich is a -longterm kernel
20:30:43 <MrsB> i think we're about ready to push that
20:31:39 <tmb> this for a few reasons, like we already use some features backported from 3.4, there are some reports of better working wlans on 3.4 series ann most nicely, all bigger security and stability fixes is done with the help of upstream maintainers...
20:32:19 <marja> nice
20:32:32 <ennael> fyi http://lkml.indiana.edu/hypermail/linux/kernel/1208.2/02624.html
20:32:36 <tmb> and since it's a -longterm one, it means it will be maintained upstream for atleast 2 more years, so it will outlive mga2
20:32:47 <marja> :)
20:33:40 <tmb> and we have had 3.4 series in cauldron for a long time before switching to 3.5 and it seems to have worked wery nice for all
20:33:42 <ennael> #action Mageia 2 will use 3.4 kernel for coming updates as it has been announced as a longterm kernel
20:33:47 <boklm> is there important changes between 3.3 and 3.4 that could cause regressions ?
20:34:03 <MrsB> is it something you'd want to do right away?
20:34:36 <tmb> boklm: nope, not really... the bigger changes starts from 3.5 series and up
20:34:41 <ennael> tmb: could you write a short blog post about this move?
20:34:45 <boklm> ok
20:34:48 <ennael> would be nice to inform about this
20:35:22 <boklm> this will probably require a little more testing that usual kernel updates ?
20:35:43 <MrsB> we take our time with kernel updates anyway
20:36:28 <ennael> tmb: anything else to add on that point ?
20:36:57 <tmb> yep, including verifying dkms drivers to cope with the change, but as most has been tested in cauldron for a long time, surprises should be minimal
20:37:15 <tmb> ennael: nope, that's about it :)
20:37:24 <ennael> ok
20:37:41 <ennael> want to write that blog post or I can do it asking you missing information ?
20:38:16 <tmb> well, we could let 3.3.8 land on updates before posting about it :)
20:38:39 <ennael> yep it's not to be posted now but at least written
20:39:10 <tmb> oh, and we should then build new boot(-nonfree).iso using 3.4 series too
20:39:19 <ennael> yep
20:39:30 <ennael> this needs manual copy in tree
20:39:40 <tmb> (and keep both 3.3 series and 3.4 series isos on mirror)
20:40:05 <tmb> yep, I can manage the tree when we get to that point :)
20:40:12 <ennael> ok
20:40:21 <ennael> anything else ?
20:40:25 <tmb> nope
20:41:25 <ennael> ok taking the opportunity that everyone is sleeping :)
20:41:29 <ennael> thanks for attending
20:41:33 <ennael> #endmeeting