19:06:19 <ennael> #startmeeting
19:06:19 <Inigo_Montoya> Meeting started Mon Jul  9 19:06:19 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:06:19 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:06:38 <ennael> I will change a bit our topics tonight
19:07:25 <ennael> speak first quickly about genereal review, blog posts
19:07:37 <ennael> and then updates management
19:07:50 <ennael> is that ok for all ?
19:07:54 <sebsebseb> yep
19:07:58 <marja11> OK
19:08:05 <MrsB> ok
19:08:14 <Max__> Okay.
19:08:20 <maat|lin> o/
19:08:23 <ennael> ok first out of topic we learnt today this sad news about Eugeni
19:08:34 <marja11> :(
19:08:38 <ennael> a blog post is in progress about this and should be published soon
19:08:50 <sebsebseb> ok
19:08:58 <marja11> good
19:09:08 <ennael> on my side I may not have tons of patience tonight so sorry if I sound a bit rude later
19:09:24 <marja11> we understand
19:09:29 <Max__> Hey, whatever it takes to make these meetings efficient :P
19:09:37 <ennael> so let start
19:09:51 <ennael> #topic general review for Mageia.Org
19:09:57 <ennael> so quickly about this one
19:10:37 <ennael> during last general assembly we proposed to post fresh news about the project life
19:10:43 <ennael> but more often than once a year
19:11:07 <ennael> so I'd like to propose such revies in coming days or weeks
19:11:20 <ennael> including team activity and some figures about Mageia
19:12:10 <ennael> wdyt ?
19:12:30 <MrsB> good idea, qa team activity might get a bit samey though :D
19:12:40 <sebsebseb> sure people generally like being informed quite a bit on the blog, about what's going on with Mageia, I guess
19:13:14 <marja11> how many lines of text about each team, ± ?
19:13:28 <Max__> A good idea. Many other distros do this about halfway through their development cycle, in addition to every time a devel release comes out.
19:13:59 <MrsB> oh you mean every few months or something?
19:14:07 <ennael> you can have a look here
19:14:08 <ennael> http://blog.mageia.org/en/2012/03/13/general-assembly-and-first-year-review-for-mageia-org/
19:14:09 <[mbot> [ General Assembly and first year review for Mageia.Org | Mageia Blog (English) ]
19:14:15 <ennael> attached is the report
19:14:20 <ennael> it can give you an idea
19:14:56 <ennael> the idea is to give the big lines of project life since the last general assembly
19:15:19 <marja11> sounds good
19:15:45 <sebsebseb> ennael: you mean like an update on what's been going on with Mageia, since then?
19:15:49 <ennael> I let you all think about it in your respective teams
19:15:53 <ennael> sebsebseb: yes
19:15:55 <MrsB> good to see that yes
19:16:10 <ennael> then we can speak about his in let say 2 weeks
19:16:17 <marja11> fine
19:16:23 <ennael> we can plan this for august, no rush for it
19:17:09 <MrsB> copy & paste qa but change the year
19:17:38 <sebsebseb> yeah team updates, events maybe something about even, etc I guess
19:17:46 <ennael> anything else on that topic ?
19:17:58 <marja11> not here
19:18:01 <MrsB> nope
19:18:03 <sebsebseb> nope
19:18:04 <tmb> nope
19:18:09 <ennael> ok
19:18:15 <ennael> let's move then
19:18:30 <ennael> #topic blog posts planning
19:19:03 <ennael> so we started some months ago to post in a regular way on Mageia blog
19:19:22 <ennael> so that we can spread Mageia and people can still be focused on Mageia news
19:19:43 <ennael> we need to go back on this, especially now as we don't have development releases
19:20:27 <ennael> so it would be nice to plan a list of subjects for coming weeks
19:20:37 <ennael> and have something like 1 post /week
19:20:47 <ennael> does it sound reasonable ? sensible ?
19:21:15 <MrsB> yes, it's important I think. The community stretches wider than those we see on irc. We need to keep them involved
19:21:15 <marja11> it sounds great...... where do we find the persons to write them?
19:21:30 <ennael> ok
19:21:54 <ennael> so we could start again interviews to speak about people making Mageia
19:21:56 <sebsebseb> MrsB: yeah there are loads of users out there I expect, but users who don't contribute to Mageia teams at the moment,  regular blog post updates could help with this to some extent
19:22:09 <ennael> I sent a mail to MrsB about this asking her to explain everything about her
19:22:19 <marja11> great :)
19:22:22 * MrsB hasn't done it yet
19:22:27 <MrsB> I will tho
19:22:38 <sebsebseb> ennael: ah yes those blog interviews, yeah those were good :)
19:22:56 <Max__> I think also we may want to discuss common bugs, maybe a new tutorial that somebody wrote on the wiki/forum...
19:23:12 <MrsB> i like that idea Max__
19:23:21 <Max__> Talking about the people is good, it adds the human conection, but we need to talk about the distro as well.
19:23:24 <Max__> Maybe alternate?
19:24:40 <marja11> maybe 1 - 3
19:24:45 <ennael> https://wiki.mageia.org/en/Blog_articles_planning
19:24:57 <ennael> we can use something like this
19:25:05 <Max__> Whatever the ratio is, there needs to be both.
19:25:06 <ennael> and add articles proposal on timeline
19:25:11 <ennael> Max__: of course
19:26:05 <ennael> does it looks ok ?
19:26:12 <Max__> Maybe a piece by someone using Mageia in the industry...
19:26:22 <MrsB> good plan ennael
19:26:27 <Max__> ^
19:26:35 <tmb> yep
19:26:43 <marja11> :)
19:26:57 <sebsebseb> MrsB: oh right your done for a they make Mageia soon :d
19:27:00 <sebsebseb> going by that link
19:27:04 <sebsebseb> down for, above
19:27:19 <MrsB> yep, i have a list of questions to fill in :)
19:27:25 <ennael> so it would be nice to have a list for coming 4 weeks at least
19:28:40 <Max__> I'll write an email to -atelier calling for ideas for blog posts for the next month or so.
19:28:48 <marja11> Max__: thx :)
19:29:04 <sebsebseb> some Mageia events happended, but no proper blog post about them yet
19:29:05 <ennael> #action plan blog posts for coming 4 weeks at least
19:29:28 <marja11> sebsebseb: you mean Linuxtag and Solutions Linux
19:29:37 <marja11> sebsebseb: you're right about that
19:29:37 <ennael> sebsebseb: planned but french guys for example are back to another event
19:29:43 <ennael> will see with them
19:29:45 <sebsebseb> marja11: yep indeed, but maybe even the one I did a talk at in a way about Mageia :d
19:29:46 <marja11> RMLL
19:29:50 <ennael> yep
19:29:56 <marja11> sebsebseb: true
19:30:38 <ennael> anything else on this ?
19:30:44 <coincoin> hi all
19:30:55 <MrsB> morning coincoin
19:31:01 <sebsebseb> yep one little thing
19:31:01 <tmb> nope
19:31:40 <sebsebseb> maybe when people go on podcasts to talk about Magiea offically, like coling and me, did not that long ago, it's wroth having a blog post or something, a short one, mentioning that? just an idea
19:32:03 <ennael> just propose it
19:32:18 <marja11> with a link to the podcast :)
19:32:48 <sebsebseb> well this is the link really http://unseenstudio.co.uk/casts/crivins/episode-20  ,but I guess he has started re doing his site, which was planned, so that link doesn't really work as such at the moment
19:33:12 <ennael> ok just post on wiki
19:33:16 <ennael> can we go on ?
19:33:27 <tmb> yep
19:33:29 <marja11> yes
19:33:36 <sebsebseb> post on wiki where?
19:34:07 <MrsB> https://wiki.mageia.org/en/Blog_articles_planning
19:34:12 <ennael> https://wiki.mageia.org/en/Blog_articles_planning
19:34:16 <ennael> arf
19:34:19 <MrsB> lol
19:34:21 <ennael> ok next topic ?
19:34:30 <sebsebseb> ennael: MrsB yep ok thought it was that
19:34:33 <sebsebseb> ok let's move on :)
19:35:01 <ennael> #topic  updates policy and management
19:35:32 <ennael> 1 minute please looking for an url
19:36:06 <Max__> Where did you last have it? Maybe you left it in the car?
19:36:23 <ennael> ok
19:36:55 <ennael> I'd like to explain why I'm adding this topic (btw tmb was going to do it also) and fix some prerequires for discussions
19:37:12 <ennael> first I kindly remind everybody this one: http://www.mageia.org/en/about/code-of-conduct/
19:37:13 <[mbot> [ Code of Conduct - Mageia ]
19:37:27 <ennael> our topic now
19:37:43 <ennael> we have a conflict growing about updates management
19:37:52 <ennael> started on Bugzilla
19:38:13 <ennael> as I did not want to see it growing again and again we spoke about it in last packagers meeting
19:38:40 <ennael> still it seems it's starting again while we thought people were ok on it
19:38:42 <Stormi> we made it grow further :)
19:38:45 <Stormi> which*
19:38:49 <ennael> indeed
19:38:56 <ennael> so before speaking about it
19:39:25 <ennael> I'd like just to remind you all that we *need* cross team work or project is dead
19:39:44 <ennael> whenever a conflict seems to happen council can help making people speaking each other
19:40:02 <ennael> we should not wait people shouting
19:40:38 <ennael> written communication is just really bad in such cases
19:40:47 <marja11> it is
19:40:55 <ennael> as people don't see them each other and just create misunderstandings
19:41:50 <ennael> so on my side I'd like not to see again such discussion this is just calamitous (translation ?) for project image
19:42:05 <ennael> if there is a pb we take time to solve it not to fight about it
19:42:14 <ennael> does all this sound silly ?
19:42:52 <MrsB> not so far
19:42:54 <sebsebseb> nope
19:42:59 <ennael> ok
19:43:16 <ennael> last thing before starting
19:43:24 <marja11> sorry, me is still thinking about "calamitous"
19:43:42 <ennael> keep in mind *all* teams are overloaded and have huge todo lists
19:44:16 <ennael> now I'd like us to have both QA and packagers views on all this
19:44:17 <marja11> true
19:44:17 <Max__> marja11: from the word calamity.
19:44:44 <DavidWHodgins> I think I started it.
19:44:44 <ennael> please keep calm and people speak each other
19:44:52 <marja11> Max__: but I suppose it means "harmful"
19:44:59 <MrsB> I learned something this evening which explains alot of what has happened
19:45:01 <tmb> marja11: destructive, disastrous
19:45:06 <marja11> tmb: thx
19:45:14 <ennael> ok tmb do you want to start ?
19:45:18 <ennael> then we can hear MrsB
19:45:24 <ennael> is that ok ?
19:45:27 <MrsB> k
19:45:31 <tmb> ok
19:46:43 <tmb> well, first of I think QA has gotten way bad treatment for trying to keep and improve Mageia quality
19:48:26 <tmb> we all know security updates are more important than other fixes, but technically if an other fix can be done at the same time (and the packager agrees), it should be done
19:49:37 <tmb> an extra build on buildsystem + mirroring to primary mirrors takes a few hours more so its not much of a delay
19:50:27 <tmb> optimum QA is to get the fix done both in stable and cauldron
19:51:36 <tmb> but as we dont always have resources to fix everything we also have to accept that not all bugs will be fixed on stable.
19:52:44 <tmb> trouble for QA is that many packages are new to them too, so it is a hard learning curve to cope with, wich leads to questions
19:55:28 <tmb> I think QA has done a good job on trying to balance priorities
19:58:26 <tmb> wa also have had known critical fixes being pushed really fast through QA when the update request have been clear with testing procedure, and/or the packager asked for fast QA since he knows the bug is _really_ critical
19:59:57 <tmb> iirc back in mdv days the order to treat stuff was "remote exploits" > "local root exploits" > "other  exploits"
20:02:19 <tmb> So I think the QA making questions on bugs they hit (remember endusers can/will hit the same) even during security validation should be hounored and responded to, either with a "will fix now" or "will fix later"
20:02:44 <DavidWHodgins> Or won't fix and why.
20:02:55 <tmb> yes.
20:03:11 <ennael> so it means also you accept it
20:03:18 <tmb> it does not take many minutes to respond to a mail
20:03:19 <ennael> meaning it will not be fixed now
20:04:28 <tmb> yes.
20:04:41 <ennael> all this *must* be clear
20:04:50 <ennael> meaning no more discussion about this after meeting
20:05:07 <MrsB> this is all good
20:05:25 <tmb> point is that for some "small" fixes, there can be more mess later (remember the msec & sectool bg)
20:05:28 <MrsB> we, both packagers rep and myself must make sure our teams understand it
20:05:28 <DavidWHodgins> I'd like to request all packagers to make sure that they are in the cc for bug reports, so they see any comments qa adds.
20:05:46 <ennael> ok
20:05:54 <tmb> DavidWHodgins: good point
20:05:59 <ennael> meaning also we close all pending discussion about all this
20:06:15 <ennael> no way to start again fighting or so
20:06:27 <DavidWHodgins> Agreed.
20:06:32 <MrsB> we really need to put a lid on it yes
20:06:34 <tmb> thats all from me for now
20:06:41 <MrsB> It has to be fed back to both teams
20:06:48 <ennael> it will be done
20:06:55 <MrsB> :)
20:07:02 <MrsB> problem solved then
20:07:14 <ennael> again no victory for any of our teams
20:07:27 <ennael> we should just not go in another such situation
20:07:43 <ennael> again next time rise topic here
20:08:03 <Stormi> I must admit I was surprised the topic was brought to packager meeting in the first time
20:08:08 <MrsB> the only victory is that mageia is successful, thats why we're all here and what we all want
20:08:20 <Stormi> it made many people aware of a few people's "fight" (if you can call that a fight)
20:08:21 <ennael> Stormi: because we spoke about it with MrsB
20:08:32 <MrsB> i was surprised too tbh
20:08:39 <ennael> and this pb was not about 1 guy only
20:08:44 <ennael> I heard other comments
20:09:04 <MrsB> it was good to air views and see both sides of the equation
20:09:12 <Stormi> I can think of 2 people in the first place, then more *after* the meeting :)
20:09:16 <ennael> so better solve it before it becomes too big
20:09:22 <Stormi> so good it's solved
20:09:31 <tmb> yeah, we need to remember that that all of us are contributing of our own free time, and no ones  time is more "important" than any others
20:10:05 <ennael> MrsB: I'd like to propose a mail about this, we work on it and post it on both ML -dev and qa
20:10:14 <ennael> just based on tonight's meeting
20:10:16 <ennael> is that ok ?
20:10:45 <ennael> no interpretation then on both teams
20:10:49 <MrsB> yes of course, we began to discuss this in qa-d already
20:11:05 <ennael> ok let see that after meeting if you are available
20:11:11 <MrsB> it will be good to see it resolved and move forward
20:11:33 <ennael> ok next topic then
20:11:37 <ennael> #topic Features proposals finalization
20:11:47 <ennael> we are late on that one
20:12:30 <ennael> it would be nice to finalize at least big lines so that we can communicate on it
20:14:28 <ennael> so could you please make a last ping on teams so that people can have a look
20:14:41 <ennael> then we should close this week
20:15:14 <MrsB> do we have a specific deadline this week?
20:15:49 <ennael> let say end of this week
20:18:12 <ennael> ok .
20:18:13 <ennael> ?
20:18:47 <MrsB> yep, do you want to set a specific time to prevent fallouts?
20:18:48 <tmb> yep
20:20:04 <MrsB> say friday 12utc or something
20:20:09 <ennael> yep ok
20:20:31 <ennael> #action teams will have until 12h utc for last reviews for Mageia 3 features
20:21:40 <sebsebseb> Friday 13th
20:21:47 <MrsB> :\
20:22:14 <maat|lin> ph34r
20:23:28 <ennael> \o/!
20:23:57 <coincoin> :)
20:24:06 <ennael> ok anything else to add ?
20:24:13 <coincoin> I advise us to shutdown all servers the day before!
20:24:22 <tmb> nope
20:24:27 <MrsB> what will happen after 12 utc?
20:24:41 <MrsB> they'll be discussed and a list finalised?
20:24:43 <ennael> end of the world ?
20:24:49 <MrsB> lol could be
20:24:59 <ennael> yep we will mail final list
20:25:13 <ennael> again having not a feature in list does not mean it will not be added
20:25:22 <ennael> if we get resources, fine
20:26:10 <ennael> questions? comments ?
20:26:28 <MrsB> all good here.
20:26:47 <marja11> agreed here
20:27:04 <ennael> ok then
20:27:15 <ennael> thanks for attending
20:27:20 <ennael> #endmeeting