19:04:06 <ennael> #startmeeting
19:04:06 <Inigo_Montoya> Meeting started Mon Jun 11 19:04:06 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:06 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:04:11 <ennael> hi all
19:04:17 <ennael> #chair obgr_seneca tmb
19:04:17 <Inigo_Montoya> Current chairs: ennael obgr_seneca tmb
19:05:05 <ennael> first welcome MrsB
19:05:23 <ennael> I guess she will join soon :)
19:05:46 <ennael> MrsB is joining QA team to help managing it
19:05:52 <sebsebseb> hi
19:06:18 <ennael> ok let's go
19:06:22 <ennael> #topic Review of actions for QA team, forum teams, artmarcom
19:06:43 <ennael> We had 3 teams going to have some changes
19:06:47 <obgr_seneca> Considering you wrote 21h UTC in the mail, she still has 2 hours to join us :D
19:06:54 <ennael> outch
19:07:09 <ennael> was a long time I did not made this mistake
19:07:10 <ennael> ...
19:07:15 <ennael> mailing here at the moment
19:07:24 <ennael> do we have forum people around ?
19:07:29 <marja7> ennael: good to see you're a human being too
19:07:33 <obgr_seneca> doktor5000: ?
19:08:02 <doktor5000> obgr_seneca: i've heard my name and i'm around
19:08:18 <ennael> :)
19:08:34 <ennael> ou summarize for everybody what is going on forum side?
19:09:17 <doktor5000> we've made some progress, reorganised/reactived helpers team in forum and found new helpers, now i'm in charge of managing that forum group
19:09:44 <obgr_seneca> #info doktor5000 is in charge of managing helper group in forums
19:10:10 <doktor5000> 3 old helpers reactived, they were like just waiting to get called for, 3 new volunteers and i've added another 4 people who volunteered in forum thread
19:10:35 <ennael> nice
19:10:49 <obgr_seneca> #info helper group is reactivated and gets organized: 10 people all together at the moment
19:11:25 <ennael> do we have leaders or whatever the name ?
19:11:28 <doktor5000> but currently i don't know/forgot status about progress since last (first) meeting about forums, sorry, i'm still swamped with work
19:11:39 <doktor5000> ennael: leaders?
19:11:44 <obgr_seneca> doktor5000: I know the feeling
19:12:01 <marja7> doktor5000: only maat volunteered, no one else
19:12:24 <doktor5000> marja7: nope
19:12:37 <marja7> who else, then?
19:12:44 <marja7> did I miss something ?
19:12:50 <doktor5000> obgr_seneca: currently we have 17 members, but only ~10 active including me
19:13:01 <obgr_seneca> #undo
19:13:01 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x847ae8c>
19:13:13 <obgr_seneca> #info helper group is reactivated and gets organized: 17 people all together at the moment, 10 active
19:13:14 <doktor5000> rest of the helpers received a round mail, and will get pruned at the end of the week if they don't reply
19:13:59 <ennael> ok
19:14:11 <ennael> do we still have some points to be solved
19:14:12 <ennael> ?
19:14:25 <ennael> or can we consider team is now able to work properly ?
19:15:14 <doktor5000> ennael: wait a min
19:15:50 <doktor5000> ennael: http://meetbot.mageia.org/mageia-forums/2012/mageia-forums.2012-06-05-19.06.html
19:15:51 <[mbot> [ #mageia-forums Meeting ]
19:16:34 <doktor5000> ennael: we still need a new team leader, AFAIK only maat applied and said he would be able to dedicate more time to it, so he has my voice
19:16:34 <ennael> yep that was the last meeting
19:16:44 <ennael> ok
19:16:52 <ennael> next meeting is planned for tomorrow I guess
19:16:58 <marja> yes
19:17:23 <obgr_seneca> #info maat applied for forum team leader, saying he has more time to dedicate to the forums in the future, no other candidates
19:17:41 <doktor5000> ennael: https://wiki.mageia.org/en/Forum_Rules still needs some work IMHO
19:17:49 <ennael> ok can we consider forum topic is over ?
19:18:02 <obgr_seneca> doktor5000: at waht time is the meeting?
19:18:16 <marja> obgr_seneca: 19h UTC
19:18:25 <marja> obgr_seneca: so same time as this one
19:18:26 <doktor5000> obgr_seneca: i'm not sure, and also Germ (Stephen Germany) applied, so please undo ^^^^
19:18:40 <obgr_seneca> #undo
19:18:40 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x847a38c>
19:18:58 <obgr_seneca> #info maat applied for forum team leader, saying he has more time to dedicate to the forums in the future, germ applied as well
19:19:14 <obgr_seneca> ok, I'll try to attend  as well
19:19:20 <ennael> ok
19:19:41 <ennael> about marcomart, rda mailed about it
19:19:49 <sebsebseb> yes and there have been many replies
19:20:09 <ennael> https://www.mageia.org/pipermail/mageia-marketing/2012-June/000917.html
19:20:10 <doktor5000> ennael: and also what i proposed earlier, some website which is a TODO list of organisational things, visible for everyone and applies to all teams ...
19:20:11 <[mbot> [ [Mageia-marketing] marcom + artwork + web => atelier ? ]
19:20:26 <marja> doktor5000: sorry, Germs mail was confusing
19:20:27 <sebsebseb> also rda is suggesting atelier as the name of the team, which I think is a bad name, and someone else as well, and I explain why here
19:20:29 <sebsebseb> :
19:20:37 <marja> doktor5000: he only said "sounds good"
19:20:49 <marja> doktor5000: as a reply to maat's mail
19:20:50 <sebsebseb> https://www.mageia.org/pipermail/mageia-marketing/2012-June/000925.html
19:20:51 <[mbot> [ [Mageia-marketing] marcom + artwork + web => atelier ? ]
19:21:19 <ennael> so we will see later how it goes at least next meeting
19:21:46 <doktor5000> marja: ahh, ok sorry, so seems germ only said "sounds good" to maat applying ...
19:21:59 <marja> doktor5000: yep :/
19:22:01 <doktor5000> obgr_seneca: ^^^^ sorry, please re-undo :/
19:22:21 <obgr_seneca> doktor5000: that will cost you a beer :D
19:22:28 <obgr_seneca> #undo
19:22:28 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Link object at 0x827846c>
19:22:33 * doktor5000 thinks on-the-fly backlogging of important mails is a dumb thing to do
19:22:33 <obgr_seneca> #info maat applied for forum team leader, saying he has more time to dedicate to the forums in the future, no other candidates
19:22:41 <doktor5000> obgr_seneca: sure :/
19:23:19 <ennael> (/me waiting for these guys to finish conversation... as chatty as girsl :) )
19:23:26 * doktor5000 hands over beer to obgr_seneca and hides in a corner now
19:23:30 <obgr_seneca> ennael: Germans, you know
19:23:31 <sebsebseb> ennael: yep same here
19:23:56 <ennael> sebsebseb: yep you are chatty also :)
19:24:01 <ennael> ok
19:24:21 <sebsebseb> ennael: no I meant waiting for them to fnnish about forums, we can talk about  artmarcom/arteler/another name
19:24:22 <ennael> so we will wait next meeting for marcom + artwork + web
19:24:42 <sebsebseb> ennael: oh ok
19:24:57 <ennael> about QA I hope MrsB will not kill me and connect before meeting is over
19:25:06 <ennael> let's go to next topic while this
19:25:53 <ennael> #topic Mageia 3 specifications summary
19:26:12 <ennael> so Mageia 3 specifications proposals are in progress
19:26:54 <ennael> deadline is on wednesday
19:27:23 <ennael> https://wiki.mageia.org/en/Category:ProposedFeatureMageia3
19:27:25 <sebsebseb> yeah I should probably suggest Cinnamon or something :D if no one has already
19:27:50 <obgr_seneca> #info deadline for Mga3 proposals is on Wednesday
19:27:54 <ennael> this is not only for packagers, everybody can propose some about all part of Mageia project
19:28:10 <obgr_seneca> sebsebseb: if you find a maintainer
19:28:34 <sebsebseb> obgr_seneca: well yeah that's the only issue with those kind of things,  Cinnamon, Mate, Unity
19:29:07 <ennael> anything to add on this ? question ? comment ?
19:29:46 <obgr_seneca> not right now
19:30:01 <obgr_seneca> I will work with trish on accesibilty
19:30:09 <marja> ennael: yes, you think "big", others come with "small" proposals about e.g the iso's
19:30:19 <ennael> ?
19:30:38 <marja> ennael: why not look at the "small" proposals and see whether they can be merged into a big one
19:30:38 <sebsebseb> ennael: sure I have a question, how to properly suggest something? to me it's unclear by that wiki site
19:31:22 <leuhmanu> read the first sentence
19:31:46 <ennael> marja: we need to have a global view about all this
19:32:00 <ennael> and one may be ok and not the oither
19:32:14 <ennael> we can have that discussion after specifications are out
19:32:20 <ennael> people need to focus on this
19:32:34 <obgr_seneca> and I think "small" proposals like adding this or that package don't need to be defined that way
19:32:35 <ennael> and isos discussion may take some time :)
19:33:21 <ennael> it's not forgotten
19:33:24 <marja> obgr_seneca: this was about avoiding nonfree firmware issues
19:33:31 <sebsebseb> leuhmanu: right got onto the page from that how to add  a feature :)
19:33:56 <sebsebseb> so I need to put my proposals on there before Wednesday I guess, then it's voting on features?
19:37:41 <obgr_seneca> sebsebseb: but do consider, any proposal needs people to work on, so just asking for a feature is only have the work
19:37:54 <obgr_seneca> shall we gon on or are there other comments?
19:38:09 <sebsebseb> obgr_seneca: yep I know can ask for a feature, but won't be done, unless  a packager wants to provide it as well
19:38:23 <sebsebseb> even if there is quite a bit of user demand for it
19:38:35 <sebsebseb> Mageia users that is, or potenial users
19:38:44 <ennael> well whatever the way proposals are made it will always be the same pb in the end
19:39:00 <sebsebseb> that someone needs to maintain it? yep
19:39:39 <ennael> ok let switch to next topic
19:39:43 <sebsebseb> yep :)
19:39:56 <ennael> as a side note planning of Mageia 3 was published today on Mageia blog
19:40:04 <sebsebseb> yep I saw that
19:40:18 <sebsebseb> however I think for Gnome 3.8, it has to be released in April, anyway ok next topic :D
19:41:22 <ennael> #topic Mageia 2 issues
19:41:27 <ennael> ok marja ?
19:41:34 <ennael> can you explain it?
19:41:53 <marja> ennael: the forums issues
19:42:00 <ennael> yes please
19:42:04 <marja> doktor5000: do you want to explain?
19:42:06 <doktor5000> marja: may i?
19:42:10 <doktor5000> ahh yes
19:42:11 <marja> yes :)
19:42:59 <doktor5000> ok, so we had many issues with upgrades which were expected, many about nonfree firmwares and graphics drivers as documented in errata
19:43:07 <doktor5000> https://wiki.mageia.org/en/Mageia_2_Errata#Proprietary_graphics_card_drivers
19:43:28 <doktor5000> we should do something about that in installer, like ask users if they want nonfree stuff
19:43:49 <sebsebseb> Ubuntu do that,  give users the option, than can have the MP3 codec and such installed
19:44:01 <doktor5000> AND the other issue was that the upgrade applet, which many users tried, doesn't use the currently enabled repos, this adds to the problem
19:44:27 <obgr_seneca> people can add repos in the installer, teh applet is another matter
19:44:52 <doktor5000> obgr_seneca: if a default install on most systems doesn't boot, that a serious issue IMHO
19:44:59 <obgr_seneca> and we did explaiun on the download page, that the dvd does only contain free stuff
19:45:42 <doktor5000> obgr_seneca: even fedora has a policy to use nonfree stuff where it leads to unusable systems, the workaround using vesa driver manually is not ok, or at least not properly
19:45:42 <obgr_seneca> doktor5000: I wouldn't say most systems, we got many reports about great work in the blog and elsewhere
19:45:56 <obgr_seneca> so it's just "the loud minority" imho
19:46:02 <doktor5000> pfff *sigh* whatever
19:46:18 <doktor5000> another big issue is https://wiki.mageia.org/en/Mageia_2_Errata#Boot_fails_when_webdav.2C_sshfs_etc._entries_exist_in_fstab and that should have been caught
19:46:45 <marja> obgr_seneca: minority or not, a loud minority can damage how Mageia is seen
19:47:02 <doktor5000> unbootable system due to user-added filesystems, which can be easily fixed if you know the cause, but from the emergency shell that was hard to tell and hard to diagnose, even for me
19:47:38 <obgr_seneca> marja: of course, but we did call for testers several times and I am a bit mad with people not helping in tests but crying afterwards
19:47:57 <marja> obgr_seneca: remind me of this
19:48:11 <doktor5000> and the biggest one IMHO, is networking problems, due to many users who upgraded, having gotten networkmanager in parallel to net_applet, resulting in no wireless connection
19:49:01 <obgr_seneca> yep
19:49:08 <doktor5000> some of those threads are still ongoing without a clear solution, actually there i'd need some help from those who are experienced in networkmanager AND have an actual mga2 install AND who can help to get those issues fixed
19:49:34 <obgr_seneca> remind me to kill the next gnome dev I meet on the spot for adding nm as requirement!
19:50:03 <doktor5000> and a bug, which even adds to this, and was reported LONG before: https://bugs.mageia.org/show_bug.cgi?id=3344
19:50:05 <[mbot> [ Bug 3344 NetworkManager spawns a wpa_supplicant instead even if interface is unmanaged, conflicting with drakx-net tools ]
19:50:45 <doktor5000> so unless we don't get such issues ruled out for next release (unbootable systems, huge networking issues) we shouldn't even care to add much more new features, IMHO
19:51:29 <doktor5000> this seriously drags down or self-set quality standard, at least that's my humble opinion
19:51:39 <doktor5000> and i'm really humble ... :/
19:51:49 <doktor5000> s/or/our/
19:52:12 <ennael> ok about non-free stuff there is a topic pending on packagers side
19:52:29 <ennael> we need to finalize and it was something asking user for adding non-free repo
19:52:31 <doktor5000> so default installations may be ok, but there were a LOT of upgrade issues, we should try to lessen those for next release as much as we can
19:52:50 <obgr_seneca> +1
19:52:54 <doktor5000> ennael: that would be greatly appreciated surely
19:53:00 <obgr_seneca> but that means needing more people on qa
19:53:03 <sebsebseb> could always recommend to do clean installs instead
19:53:08 <sebsebseb> and make it clear to users
19:53:11 <ennael> then we have specific file systems and NM
19:53:11 <sebsebseb> I mean do that as well
19:53:24 <ennael> we can open 2 threads on -dev about that topics
19:53:25 * doktor5000 proposes to help next time if he isn't swamped that much with other stuff :/
19:53:41 <ennael> I will mail just after about these one
19:53:55 <ennael> doktor5000: it will be short mails but start thread
19:54:03 <ennael> feel free to add as many information as needed
19:54:07 <ennael> does it sound ok ?
19:54:49 <doktor5000> ennael: more NM and improving wireless support overall, and for devices which have more than one driver ...
19:55:04 <obgr_seneca> #info network and update issues must be solved asap
19:55:29 <doktor5000> ennael: i'm quite lost at those driver/kernel things, and seems we nearly have only tmb working on that area for the major part, we should get more kernel/hardware guys
19:55:40 <doktor5000> ennael: just clone tmb ;)
19:55:52 <marja> grinz
19:56:03 <obgr_seneca> cp -a tmb tmb_2
19:56:04 <tmb> :)
19:56:07 <doktor5000> ennael: can we have that as #action, please?
19:56:09 <ennael> doktor5000: that's another pb :)
19:56:16 <doktor5000> :D
19:56:18 <ennael> which action
19:56:28 <marja> doktor5000: an action for cloning tmb?
19:56:38 <doktor5000> ennael: #action clone tmb
19:56:43 <ennael> tsss
19:56:51 <ennael> or cut him
19:56:58 <doktor5000> ennael: NOOOO
19:57:03 <ennael> ok
19:57:09 <ennael> anything else on that topic ?
19:57:57 <doktor5000> ennael: as a concensus, we should iron out the kinks for next release, keep quality high, and maybe not add to many features
19:58:17 <ennael> don't worry resources are limited :)
19:58:19 <doktor5000> ennael: as we already did a big switch to systemd, this may be easier now ...
19:58:42 <ennael> ok can we change topic ?
19:58:47 <sebsebseb> yep
19:58:49 <doktor5000> yep
19:58:53 <obgr_seneca> doktor5000: there's always another big switch coming arround the corner :-/
19:59:46 <ennael> mmm
19:59:54 <ennael> what is next topic ?
19:59:57 * ennael is lost :p
20:00:06 <ennael> marja: I guess you had another one
20:00:10 <ennael> ah yes
20:00:11 <obgr_seneca> ennael: you only popsted those three
20:00:30 <ennael> #topic updates management through mgaonline
20:00:31 <marja> ennael: that was the one about most mentioned issues in the forum
20:00:40 <marja> ennael: but MrsB had one
20:00:44 <ennael> that one
20:00:57 <ennael> so are you all aware of that topic?
20:01:03 <marja> ennael: bug 2317
20:01:04 <sebsebseb> ennael: mrs will probably be here soon
20:01:07 <sebsebseb> mrsb
20:01:09 <sebsebseb> yep there she is
20:01:11 <ennael> ah :)
20:01:12 <sebsebseb> I got her to join
20:01:16 <marja> marja: just in time
20:01:19 <marja> oops
20:01:22 <ennael> MrsB: sorry for the mess :)
20:01:23 <marja> MrsB: just in time
20:01:26 <obgr_seneca> Good mornin g MrsB
20:01:27 <MrsB> am I late ;)
20:01:31 <sebsebseb> MrsB: yep
20:01:35 <MrsB> sorry, I just checked email
20:01:35 <marja> MrsB: it is bug 2317 time :)
20:01:42 <MrsB> ohhhh
20:01:42 <doktor5000> ennael: before i forget, here's a bug which may be the cause to many problems, but should be easy to fix: https://bugs.mageia.org/show_bug.cgi?id=6114
20:01:44 <[mbot> [ Bug 6114 urpmi doesn't want to download packages into a user-owned folder ]
20:01:51 <sebsebseb> MrsB: 8pm our current time, these meetings
20:01:56 <ennael> doktor5000: after :)
20:01:58 <sebsebseb> MrsB: actsauly always about 8pm our time
20:02:05 <ennael> sebsebseb: please
20:02:07 <MrsB> yep, email said 10 :\ I just saw Anne's email
20:02:18 <MrsB> sorry to miss it
20:02:19 <ennael> MrsB: sorry... UTC time stroke again
20:02:23 <MrsB> :D
20:02:35 <ennael> MrsB: wo update that bug can you explain more your pov ?
20:02:42 <ennael> and why it's quite an emergency
20:03:20 <MrsB> 2317 is difficult for QA to work around. We have discovered several new scenarios where it occurs
20:04:04 <MrsB> It is likely also to affect backports, if they are set as update media and we don't know the affect it will have on the upgrade process with backports
20:04:37 <MrsB> It is going to be very difficult to keep track of it and to ensure all necessary packages are linked
20:04:49 <MrsB> if we don't catch them all then updates won't install
20:05:16 <MrsB> Our depcheck script is current;y not working properly due to a regression in urpmf
20:05:43 <MrsB> it can be altered to find the required links but not give the media they nee dlinking from
20:06:23 <MrsB> If it could be automated some way instead of fixing 2317 then that would help greatly
20:06:42 <MrsB> ideally though, especially with new people in QA, 2317 should be fixed
20:07:20 <DavidWHodgins> That still won't help for people who use any iso image to upgrade, and don't run urpmi --auto-select, which can't be done with any gui only method.
20:07:40 <MrsB> DavidWHodgins: hi, I didn't see you there
20:07:51 <DavidWHodgins> :-)
20:09:37 <MrsB> we've been petitioning for it to be addressed for a long time now and feel because we have been able to work around it mostly it has been largely forgotten and deemed less important.
20:09:50 <obgr_seneca> so, who could fix the problems here? tv?
20:11:11 <MrsB> I guess. I'm not really sure. It is MageiaUpdate which is affected
20:11:21 <ennael> maybe pterjan can help also, and blino
20:11:44 <obgr_seneca> so should we ping those three?
20:11:55 <ennael> yep
20:12:06 <MrsB> I know it's not very popular so I appologise for that
20:12:13 <obgr_seneca> I do see this is a problem, but we won't solve it by discussing here, will we?
20:12:19 <ennael> nope
20:12:20 <MrsB> it is important to a growing qa team though
20:12:21 <obgr_seneca> MrsB: And don't apologise
20:12:27 <ennael> MrsB: that's not the pb
20:14:08 <ennael> #action mail people about mgaonline so that updates can be properly managed
20:14:15 <obgr_seneca> #action ping tv, pterjan and blino about bug #2317
20:14:21 <obgr_seneca> #undo
20:14:21 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x8454aec>
20:14:29 <ennael> erf :)
20:14:43 <obgr_seneca> ennael: you were faster!
20:14:47 <MrsB> if we could automate the dependency checks, maybe adapt the depcheck script, so it was done automatically at push or something it would help the situatioon if 2317 can't be fixed right now
20:14:58 <MrsB> -o
20:15:36 <ennael> #action work on a workaround for now to  automate the dependency checks so it's done automatically when pushing updates
20:15:52 <MrsB> :) thankyou
20:16:07 <obgr_seneca> MrsB: Where can that dep check script be found?
20:16:14 <MrsB> I attached it to the bug
20:16:47 <MrsB> it doesn't show the links required atm due to the urpmf bug but there is an echo commented out which can be uncommented to show them
20:16:50 <obgr_seneca> #info dep check script is attached to the bug
20:17:34 <DavidWHodgins> https://bugs.mageia.org/attachment.cgi?id=2432
20:17:44 <MrsB> thanks Dave
20:18:26 <obgr_seneca> ok, anything to add?
20:18:38 <MrsB> were backports discussed?
20:18:47 <MrsB> stormi had some points he asked me to mention
20:18:56 <ennael> ok
20:19:00 <ennael> last topic then
20:19:15 <ennael> #topic backports setup
20:19:32 <MrsB> can I paste his comments?
20:19:40 <ennael> so QA team agreed on testing backports, pacakgers are waiting for infrastructure
20:19:53 <marja> MrsB: fine with me
20:19:53 <ennael> boklm: ping ?
20:19:59 <ennael> MrsB: 2 sec please
20:20:01 <boklm> pong
20:20:02 <MrsB> k
20:20:38 <ennael> boklm: any ETA on backports implementation ?
20:20:55 <boklm> we should enable them soon
20:21:02 <boklm> I will try to check this tomorrow
20:21:16 <ennael> great tahnks for that
20:21:17 <ennael> :)
20:21:34 <tmb> I think we need to finalize backports policy before opening it...
20:21:50 <ennael> tmb: I was just asking for technical setup
20:21:55 <ennael> MrsB: your turn ?
20:22:10 <MrsB> I'll paste his comments if that is ok
20:22:22 <ennael> yep
20:22:29 <MrsB> <stormi> my opinion is that we must either :
20:22:42 <MrsB> <stormi> - take backports into account during upgrade (preferred for users, not preferred for devs)
20:22:54 <MrsB> <stormi> - declare that any backport installed after N+1 release can prevent upgrade, and detect it in upgrader
20:23:04 <MrsB> <stormi> and that we must not:
20:23:16 <MrsB> <stormi> - stop supporting backports in Mageia N after Mageia N+1 is released
20:23:30 * blingme wanted to reply on this thread on the ml, but I think we are over-engineering this
20:23:59 <MrsB> <stormi> and also that there must be notifications for newer backports for packages you installed from backports
20:24:20 <DavidWHodgins> Current iso images will not work, for upgrading, if Mageia 1 backports include anything that the iso has versioned requires on.
20:24:41 <ennael> blingme: ?
20:25:20 <blingme> having pushed about 20 releases of openldap to backports for Mandriva, there was only ever once an issue, and never an upgrade problem
20:25:43 <blingme> (noting, that at most times, I was pushing to *3* or more releases, as many as were active)
20:25:53 <ennael> and openldap can be quite sensitive package on a system
20:26:22 <blingme> Just add notes for people using backports, that if they don't keep the repo enabled, they should 'urpmi --auto-select --searchmedia Backports' after an upgrade
20:26:51 <DavidWHodgins> And not to be surprised, if some transactions fail, during the upgrade.
20:26:55 <blingme> (there was *one* issue with openldap in backports, caused by a NMU)
20:27:12 <ennael> blingme: can you add this in wiki ?
20:27:12 <blingme> DavidWHodgins: of course, but really, how serious is it going to be?
20:27:32 <DavidWHodgins> Depends on if it causes a urpmi cascade error.
20:27:36 <blingme> it's not like we're going to push glibc-3 to backports
20:27:46 <DavidWHodgins> What about kernel?
20:27:51 <blingme> DavidWHodgins: provide a bug reference (on Mandriva bugzilla is fine)
20:28:10 <blingme> DavidWHodgins: tmb has been pushing kernels to backports on a bi-weekly basis for years
20:28:16 <boklm> we can have a tool that indicate the list of packages installed more recent than the versions available on enabled repositories, so that people can revert to repository version
20:28:33 <DavidWHodgins> I don't have a current bug report, just thinking about bug 2317, and the types of problems I've seen because of it.
20:28:49 <blingme> boklm: I already proposed some changes to rpmdrake, that, while not exclusively for this, could provide this feature
20:28:53 <MrsB> I think it's also important for users to be able to update backports, and know when an update is available
20:29:08 <DavidWHodgins> blingme: But, as far as I know, upgrading wasn't supported, if backports were enabled.
20:29:10 <blingme> MrsB: AFAIK that is already available for advanced users
20:29:39 <blingme> DavidWHodgins: sure, it's not supported, but I haven't personally seen it break, and of course the intention isn't to ensure it doesn't work
20:29:57 <MrsB> it is, as long as backports are left enabled, which means every backport will appear as an update
20:29:59 <tmb> just as a small note, the trouble with doing an "'urpmi --auto-select --searchmedia Backports'" is that it will upgrade all packages it finds there, and that's not necessary what the user wants after a distro upgrade
20:30:43 <blingme> tmb: sorry, I should have been clear that the list of packages should be reviewed, and possibly manually selected
20:30:58 <blingme> http://www.google.com/search?q=main%2Fbackports+openldap+site%3Alists.mandriva.com
20:30:59 <[mbot> [ main/backports openldap site:lists.mandriva.com - Google-Suche ]
20:31:27 <blingme> (I did try and send a mail, but we have some MTA problems our mail team needs to take care of urgently ...)
20:32:11 <tmb> blingme: ah, ok.
20:32:47 <MrsB> our users are not all going to be knowledgable enough to do that, they will want the new gimp etc but not in a position to select backported libs and openldap's
20:33:27 <blingme> MrsB: right, thus the wiki should have a disclaimer, that if you aren't comfortable with urpmi ... you should carefully consider if using backports extensively is for you.
20:33:44 <MrsB> why are we bothering with qa testing then :\
20:33:48 <blingme> e.g., I don't enable backports on my wife's laptop ...
20:34:07 <blingme> well, that was why I was wondering why QA was blocking backports ...
20:34:24 <blingme> (but, then, I didn't really have problems with the way Mandriva handled backports)
20:34:33 <MrsB> It isn't so much using the backport media which is the problem, it is having to manually select backport updates from normal updates
20:34:41 <MrsB> qa weren't blocking backports afaik
20:34:47 <MrsB> ...
20:34:58 <blingme> right, and that isn't a process issue, it's a feature we should look into for rpmdrake
20:35:03 <tmb> as for "downgrading packages" we hits the next problem, and that it needs stricter versioned requires in packages , and many packages currently use ">=" thinking of upgrade only
20:35:10 <blingme> at which point, we could remove the disclaimer
20:35:55 <blingme> (I sent a mail with a propsal that rpmdrake, for a specific package, show all the versions available in all repos, and allow the user to select a specific one, not just the latest)
20:36:36 <blingme> (actually, this is more of a problem for tainted/updates than backports, but the same issues mostly apply)
20:37:40 <MrsB> i think if we reach a situation where installing a backport is risky then we've failed at backports
20:38:24 <DavidWHodgins> I think our testing can make sure it isn't risky for the current release, but can't make sure it won't affect upgrading later.
20:38:38 <MrsB> that could be my inner qa coming out :)
20:38:39 <doktor5000> ennael: somehow related (rpmdrake/urpmi coding), seems Thierry was/is absent for quite some time ... :/
20:39:07 <ennael> doktor5000: no
20:39:17 <leuhmanu> thierry commited for 2 hours
20:39:40 <ennael> tmb: anything else to add on this.?
20:40:56 <tmb> nope, nothing besides just that all of this shows we need a clear backports policy before opening it...
20:41:08 <ennael> yep
20:41:24 <ennael> can we sump up all this in a mail before going on discussion?
20:41:29 <MrsB> We need to make sure our users understand how to use them too.
20:41:38 <ennael> I'm sorry on my side I'm a bit lost and tired :)
20:41:38 <tmb> as we still have several views of what backports is / should be
20:41:45 <tmb> MrsB:  yep.
20:41:50 <blingme> IMHO, there is very little value (to me) if we only have backports for one release at a time ...
20:41:58 <ennael> I agree too
20:42:10 <ennael> I have a concrete example on my side
20:42:19 <ennael> a client needing backports on Mageia 1
20:42:36 <blingme> and I would prefer not to have to babysit 3 builds in order to actually get the package into the release where I actually *need* the package myself
20:43:04 <ennael> ok who would like to sum up this in a mail ?
20:46:43 <blingme> I would offer, but I have email problems sending from the address I am subscribed on ...
20:46:57 <DavidWHodgins> I think we need a thread started to work out the procedures, rather then a sumary of what's been said here.
20:47:02 <ennael> we can change it if needed
20:47:05 <tmb> well, technically this is still being discussed somewhat on ml, but...
20:47:09 <tmb> #action tmb will try to sum up backports in a mail to -dev
20:47:14 <ennael> thanks :)
20:47:30 <ennael> blingme: please try to answer on this thread
20:47:42 <ennael> your experience is also important to take the right decisions
20:48:20 <blingme> blingme: In order to do so, I need to fix or help fix MTAs for a 600 000 mailbox environment :-(
20:48:39 <ennael> ah blingme il also bugged :)
20:50:31 <ennael> ok can we fix a deadline for this discussion
20:50:39 <ennael> so that it does not take another year :)
20:51:41 <MrsB> end of the week?
20:52:06 <ennael> yep sounds reasonable
20:52:11 <tmb> blingme: I can probably open up a smtp with auth for you if needed (meaning for you personally, not for all 600.000) :)
20:52:29 <ennael> :)
20:52:47 <ennael> #action deadline for backport policy discussion is end of this week
20:52:58 <ennael> ok anything else to add ?
20:53:03 <blingme> tmb: I should be able to via zarb, but last time I tried (briefly, was in a rush) it didn't work
20:53:39 <tmb> it will probably take until tomorrow before I send the mail to -dev ...
20:54:04 <MrsB> I have another topic, it's a brief one tho
20:54:15 <ennael> tmb: ok then
20:54:22 <ennael> MrsB: which is ?
20:54:24 <tmb> blingme: ah, ok. in other case ping me and I'll get you access
20:54:46 <MrsB> We're now using bugs which include updates for both releases..
20:54:53 <ennael> wait
20:54:58 <MrsB> there is no way on bugzilla to show they are for both though
20:54:59 <MrsB> k
20:55:09 <ennael> #topic updates management in Bugzilla
20:55:18 <ennael> shoot :)
20:55:27 <MrsB> We're now using bugs which include updates for both releases..
20:55:33 <MrsB> there is no way on bugzilla to show they are for both though
20:55:38 <marja> MrsB: that is possible in new Bugzilla
20:55:46 <marja> after upgrade
20:56:00 <DavidWHodgins> Timeframe?
20:56:25 <marja> dmorgan asked in january for help on the sysadmin ml
20:56:42 <ennael> boklm answered this afternoon
20:56:49 <marja> boklm said recently it was planned for after Mga 2 release
20:56:50 <MrsB> Should we add a 1& 2 'version' to current bugzilla in the mean time?
20:56:53 <ennael> so maybe we can start on sysadmin list for now
20:57:53 <ennael> #info Bugzilla update is needed, which is planned in coming days/weeks
20:58:09 <marja> MrsB: but then bugsquad has "cauldron & 2" bugs
20:58:12 <leuhmanu> /months
20:58:21 <ennael> leuhmanu: please
20:58:40 <marja> MrsB: and I think we even have some "cauldron & 1 & 2"
20:58:50 <MrsB> Is there another way we could handle it temporarily?
20:59:03 <MrsB> I mention it here because it would need packager cooperation
20:59:38 <MrsB> maybe a keyword?
21:00:32 <marja> MrsB: bugsquad started setting highest version (cauldron>2>1)..... if a bug get fixed for highest version, the one but highest should be set...... the whiteboard we use for "MGA2TOO"
21:00:38 <leuhmanu> you have a tempoty solution yet no ?
21:00:43 <marja> MrsB: or "MGA1TOO"
21:01:13 <MrsB> Ok whiteboard would do
21:01:22 <ennael> ok
21:01:26 <ennael> as a reminder
21:01:27 <ennael> https://www.mageia.org/pipermail/mageia-sysadm/2012-June/004477.html
21:01:28 <[mbot> [ [Mageia-sysadm] New Bugzilla maintainer? ]
21:01:56 <ennael> ok any other topic for tonight
21:01:57 <ennael> ?
21:02:30 <marja> not here
21:02:36 <MrsB> ennael: this would need packagers to apply the whiteboard keyword when they created update bug reports for two releases
21:02:48 <ennael> yep ok
21:02:53 <MrsB> thanks :)
21:02:56 <ennael> please mail -dev for this
21:03:03 <MrsB> ok
21:03:05 <ennael> we will add this to packagers meeting for memory
21:03:13 <MrsB> I'll try to attend
21:03:17 <ennael> ok
21:03:30 <ennael> can we close meeting ?
21:03:38 * marja started adding (MGA2) to installer cauldron bugs
21:03:52 <tmb> yep
21:03:53 <MrsB> yes, sorry to keep finding things
21:04:07 <marja> only to show that the problem was last seen in MGA2
21:04:27 <ennael> ok let close meeting before marja finds 2 or 3 other topics :)
21:04:30 <ennael> #endmeeting