19:15:35 <ennael> #startmeeting
19:15:35 <Inigo_Montoya`> Meeting started Mon May  7 19:15:35 2012 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:15:35 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:15:59 <ennael> #chair tmb
19:15:59 <Inigo_Montoya`> Current chairs: ennael tmb
19:16:13 * tmb hides
19:16:17 <ennael> :)
19:16:18 <ennael> so
19:16:22 <sebsebseb> tmb: found you
19:16:28 <ennael> again this meeting will focus on coming mageia 2
19:16:43 <ennael> #topic RC isos
19:17:05 <ennael> so we are late for RC
19:17:14 <ennael> nearly one week
19:17:18 <sebsebseb> yep
19:17:32 <ennael> tests are going on and we hope it will be the last one
19:17:49 <ennael> DVDs look ok for now
19:17:58 <ennael> tmb: general status for live CDs ?
19:18:28 <tmb> I'd say all 16 of them looks good for now
19:18:34 <leuhmanu> yep
19:18:37 <marja> :)
19:18:41 <sebsebseb> :)
19:18:43 <ennael> great news
19:19:15 <ennael> for next release mageia may offer coffee and red bull for people working on isos :)
19:19:28 <marja> good idea :)
19:19:29 <sebsebseb> Red Bull :)
19:19:35 <ennael> tmb: can we expecte to be able to release tomorrow ?
19:19:36 <tmb> nooo not red bull.... they will fly away...
19:19:47 <ennael> :)
19:20:05 <tmb> for me I think we can
19:20:11 <ennael> nice
19:20:24 <ennael> so finalizing current tests and we can push isos tomorrow
19:20:33 <marja> nice :)
19:20:54 <sebsebseb> awesome :)
19:20:58 <ennael> phew
19:21:17 <ennael> #info RC isos are nearly ready and should be pushed tomorrow on public mirrors
19:21:31 <ennael> then we need to postpone final release
19:21:39 <sebsebseb> final release will be delayed?
19:21:40 <ennael> everybody ok ?
19:21:44 <marja> yep
19:21:50 <boklm> ok
19:21:51 <ennael> one week more
19:21:52 <Stormi> ok
19:22:06 <marja> ennael: is that still before linuxtag?
19:22:07 <sebsebseb> delayed by a week or so, ok
19:22:15 <tmb> yep. we need time for endusers to download rc, test and report
19:22:32 <sebsebseb> marja: no that will be after Linuxtag it seems
19:22:37 <ennael> nope
19:22:42 <ennael> just at the beginning
19:22:52 <ennael> would be 22th
19:22:53 <marja> ennael: that is good enough :)
19:22:54 <ennael> 22d
19:23:17 <marja> ennael: linuxtag starts the 23rd
19:23:22 <ennael> phew :)
19:23:39 <sebsebseb> right so CD's made for it of Mageia 2 the day before I guess then.
19:24:56 <tmb> so. when do we lock down / deny new rpms (even security related)
19:25:24 <ennael> I would say this saturday the latest
19:25:35 <ennael> 12nd
19:25:39 <marja> ennael: is that for documentation, too?
19:25:45 <ennael> yes
19:25:48 <marja> OK
19:26:02 <ennael> at this time we will start isos build for final release
19:26:36 <ennael> does it sound ok for everybody ?
19:26:41 <marja> yep :)
19:26:48 <leuhmanu> so no bugfix during one week ?
19:27:01 <ennael> except blocker bugs
19:27:23 <leuhmanu> ok
19:27:25 <boklm> ok
19:27:53 <ennael> #action ennael will communicate planning for final release on ML
19:28:18 <ennael> #info stop all submits by saturday and final release for 22d of may
19:28:29 <sebsebseb> ok 22nd May the final :)
19:28:42 <tmb> you forgot date for saturday
19:28:54 <tmb> (just to be clear)
19:29:04 <ennael> yes
19:29:06 <ennael> #undo
19:29:06 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Info object at 0x83cb3ac>
19:29:16 <leuhmanu> 22th same as fedora :)
19:29:21 <ennael> #info stop all submits by 12d of may and final release for 22d of may
19:29:23 <ennael> woot
19:29:25 <leuhmanu> https://fedoraproject.org/wiki/Releases/17/Schedule
19:29:31 <marja> lol
19:29:34 <leuhmanu> well 15 was the same :)
19:29:40 <ennael> really ?
19:29:44 <leuhmanu> yep :)
19:29:48 <ennael> erf
19:29:53 <ennael> we will be famous \o/
19:29:56 <ennael> hum
19:30:12 <tmb> "famous last words..."
19:30:15 <ennael> :)
19:30:35 <ennael> so it means i18n and doc have to finalize work before 12d
19:30:54 <ennael> can you mail your teams about this ?
19:31:14 <marja> yep..... who'll do it for i18n?
19:31:36 <ennael> oliver, I will ping him
19:31:41 <marja> ennael: thx
19:32:04 <ennael> #info mail i18n and docteam for final deadline
19:32:23 <sebsebseb> Marcom has to finalise stuff by when? Also I haven't seen Trish active online for a week or so.
19:32:47 <ennael> is that all for planning ? before teams review
19:32:55 <leuhmanu> ah yes the releases notes ?
19:33:04 <leuhmanu> (since it's in the isos)
19:33:11 <ennael> just after about docs
19:33:25 <ennael> ok let's change topic
19:33:33 <ennael> #topic Mageia 2 doc
19:34:01 <ennael> this is about wiki, release notes and AUTHOR (rda reminds me this point )
19:34:20 <rda> which was reminded to me by marja
19:34:51 <leuhmanu> AUTHOR ?
19:34:54 <ennael> :)
19:34:56 <ennael> CREDITS
19:34:59 <leuhmanu> ah
19:35:01 <ennael> from mageia-release
19:35:11 <ennael> would be nice to have all teams proposing updates
19:35:13 <marja> rda: more or less..... something I said reminded you of this ;)
19:35:29 <ennael> a job for team leaders :)
19:35:43 <leuhmanu> http://svnweb.mageia.org/packages/cauldron/mageia-release/current/SOURCES/CREDITS?view=markup
19:35:51 <marja> leuhmanu: thx
19:35:59 <ennael> #action all team leaders will update CREDITS (mageia-release) before 12d
19:36:08 <ennael> is that ok ?
19:36:22 <leuhmanu> yep
19:36:30 <ennael> now Release NOtes
19:36:37 <boklm> for some teams, it can be done from ldap
19:36:43 <ennael> yep
19:36:53 <ennael> maybe we can send a list for each team
19:36:59 <ennael> then people check it's complete
19:37:10 <marja> ennael: yes please
19:37:15 <ennael> boklm: can you provide these lists ?
19:37:17 * boklm can update the file, and people can complete
19:37:21 <ennael> ok nice
19:37:31 <ennael> when can you do it ?
19:37:39 <boklm> I will try to do it tonight
19:37:45 <ennael> great
19:38:09 <ennael> #action boklm will update CREDITS using ldap information then it will be completed byt team leaders if needed
19:38:31 <ennael> Max__: also fo artwork team of course :)
19:39:23 <Stormi> nice, automation! :)
19:39:31 <ennael> now release notes
19:39:39 <ennael> they are part of mageia-release
19:39:48 <ennael> so we need updates quickly
19:39:50 <ennael> if needed
19:39:52 <leuhmanu> https://wiki.mageia.org/en/Mageia_2_Release_Notes
19:40:06 <ennael> thanks
19:40:26 <ennael> #action update release notes for Mageia 2 to finalize mageia-release package
19:40:40 <ennael> #action ennael will mail -dev about release notes
19:42:02 <ennael> anything else on this ?
19:42:47 <tmb> not from me
19:42:53 <boklm> not from me
19:42:57 <marja> ennael: yes
19:43:01 <marja> [21:42] <xochiquetzal> trishf42 was last seen in #mageia-dev 13 days 23 hours ago joining the channel.
19:43:12 <ennael> ?
19:43:38 <marja> sebsebseb said he hadn't seen her in a week
19:43:57 <marja> if she is needed, it might be good of someone tries to contact her
19:44:14 <ennael> she is now in new zealand timezone is much different
19:44:19 <ennael> I will drop her a mail
19:44:33 <marja> ennael: thx
19:45:04 <ennael> #topic release blocker bugs
19:45:33 <ennael> quick update on that topic
19:46:01 <ennael> we have now 12 release blocker bugs
19:46:19 <ennael> including some already solved but waiting for tests to be sure
19:46:33 <ennael> QA/triage: any comment on this ,
19:46:35 <ennael> ?
19:46:52 <leuhmanu> nop seems ok for me
19:48:24 <tmb> what was tracker url ?
19:49:06 <leuhmanu> https://bugs.mageia.org/show_bug.cgi?id=1994 ?
19:49:38 <ennael> ?
19:50:22 <Stormi> do we have an idea of the overall quality of the distribution (non-blocker bugs)?
19:50:23 <sebsebseb> back computer issues
19:50:35 <ennael> one at a time
19:50:42 <ennael> leuhmanu: why this link ?
19:51:18 <tmb> leuhmanu: I was more thinking of release_blocker tracker, but I can search for that
19:51:21 <marja> https://bugs.mageia.org/buglist.cgi?priority=release_blocker&query_format=advanced&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&version=Cauldron&product=Mageia
19:51:33 <ennael> yep that one
19:51:38 <tmb> and there it is, thanks
19:51:43 <marja> yw
19:51:49 <ennael> :)
19:52:15 <ennael> Stormi: we could write a global report about it
19:52:25 <ennael> volunteer ?
19:52:55 <Stormi> I can try tomorrow, without promising
19:53:14 <Stormi> any ideas of how to proceed?
19:53:29 <ennael> using bugzilla ?
19:53:37 <ennael> statistics about opened bugs
19:53:49 <leuhmanu> Stormi: I have added a link in my last post in bugsquad@
19:53:59 <ennael> bugs without anything happening on it for 1 or 2 months
19:54:06 <ennael> closed bugs...
19:54:11 <Stormi> leuhmanu: ok I'll look at it and try to produce some metrics
19:54:55 <leuhmanu> the function for "bugs closed against the time" is not enable in our bugzilla
19:55:05 <ennael> anything else ?
19:55:18 <Stormi> about that topic or other topics?
19:55:26 <ennael> this topic first
19:55:32 <Stormi> ok, nothing then
19:55:52 <ennael> boklm: can sysadmin provide some kind of planning based on todo list for final release ,
19:55:55 <ennael> ?
19:56:36 <leuhmanu> A yes a package in core/updates should be great
19:56:51 <leuhmanu> so we can that it really works in the dvd install
19:56:56 <leuhmanu> can test*
19:57:03 <marja> good idea :)
19:57:21 <boklm> ennael: planning for what ?
19:57:23 <ennael> argh boklm went ti pub
19:57:25 <ennael> oups
19:57:38 <ennael> boklm: todo list in wiki
19:57:48 <ennael> it will help everybody to be on time
19:59:14 <boklm> hmm I will look
19:59:18 <ennael> thanks
19:59:27 <ennael> any other topic ?
20:00:07 <marja> not here
20:00:10 <sebsebseb> nope
20:00:15 <tmb> Stormi?
20:00:16 <boklm> not for me
20:00:21 <Stormi> yes
20:00:44 <ennael> shoot then
20:00:47 <Stormi> once Mageia 2 will be released, there will be an impact on updates for Mageia 1
20:01:04 <marja> how?
20:01:13 <Stormi> namely: we can't update to higher release numbers than that on mageia 2 release media
20:01:19 <Stormi> otherwise upgrade breaks
20:01:22 <marja> of course
20:01:29 <sebsebseb> Stormi: I thought Mageia 1 only really gets security updates now?
20:01:52 <Stormi> sebsebseb: and bugfix
20:01:53 <tmb> so we might break mdv2010.1 upgrades
20:02:12 <sebsebseb> Stormi: ok bug fixes as well :D
20:02:16 <tmb> (to mga1 that is)
20:02:23 <boklm> Stormi: higher than mageia 2 release or updates media
20:02:29 <sebsebseb> tmb: yep
20:02:33 <sebsebseb> I guess
20:02:41 <Stormi> boklm: release, otherwise DVD upgrade doesn't work anymore
20:02:46 <Stormi> unless we release updated media
20:03:12 <boklm> packages will be updated after upgrade
20:03:41 <boklm> in most cases, it should not break upgrade
20:03:48 <leuhmanu> not if you don't run urpmi --auto-update
20:03:57 <Stormi> isn't there a risk that the upgrade in itself breaks if we allow higher versions in mga1 updates than in mga2 release?
20:04:08 <marja> leuhmanu: I always use that
20:04:12 <boklm> it depends on which packages
20:04:14 <Stormi> (I would be glad if this constraint disappeared)
20:04:36 <Stormi> anyway we need a clear policy ready before Mga2 is out
20:04:50 <Stormi> and to watch closely updates in the meantime
20:05:05 <marja> Stormi: is it possible to 10xbump all Mga2 versions before release?
20:05:30 <Stormi> I don't think so
20:05:54 <ennael> uh ?
20:06:09 <tmb> nope, that would mean rebuilding whole mga2 and restart qa from scratch
20:06:13 <Stormi> so the question is twofold: what policy, are there exceptions, and are we ready to enforce it on build system?
20:06:15 <marja> :(
20:06:25 <Stormi> threefold then :)
20:06:33 <Stormi> if this word exists in englihs
20:06:37 <boklm> I don't think it's likely to break upgrade, except if it's in core packages
20:06:58 <Stormi> the best would be automated upgrade tests
20:07:09 <Stormi> which would relieve us from some burden
20:07:15 <Stormi> and let us update freely in mga1
20:07:20 <Stormi> (within the policy)
20:08:53 <Stormi> so, do we allow higher releases in mga1 updates than in mga2 release?
20:09:51 <tmb> Actually I dont think this will be a big problem
20:10:18 <tmb> mdv2010.2 gets EOL by Jul 8th 2012
20:10:30 <marja> that is fast
20:10:43 <boklm> tmb: 20120.2 ?
20:10:49 <sebsebseb> Mandriva 2010 series has been supported since October 2009 or something like that, I think
20:11:16 <boklm> tmb: I think question from Stormi was about upgrade from mageia 1 to mageia 2
20:11:25 <Stormi> yes
20:11:28 <sebsebseb> marja: that was a reply to you, but maybe I misunderstood, anyway nevermind
20:11:47 <Stormi> we seldom need to bump versions in mga1, but it can happen
20:11:51 <marja> sebsebseb: np :)
20:11:52 <tmb> yes, but one of the forcing factor for version bumps have been mdv
20:11:55 <Stormi> we firefox 10 series ends for example
20:12:42 <ennael> can we add this topic for pâckager meeting rather ?
20:12:52 <sebsebseb> ennael: good idea
20:13:01 <Stormi> ok
20:13:19 <boklm> if upgrading from DVD, some packages may stay at mageia 1 version, but this is fixed next time updates are installed
20:13:50 <leuhmanu> boklm: you need to use command line, as mgaonline will nt do it
20:14:06 <boklm> leuhmanu: why ?
20:14:06 <ennael> ok let see that wednesday then
20:14:07 <Stormi> leuhmanu: it will, because we will add those packages in mga2 updates too
20:14:16 <ennael> any other topic ?
20:14:24 <sebsebseb> not for me
20:14:27 <tmb> boklm: yup, but it's when a critical package ends up blocking upgrade it will break d
20:14:42 <leuhmanu> Stormi: really ? that will be 20Go
20:14:48 <ennael> ok can we close meeting ?
20:14:48 <leuhmanu> https://bugs.mageia.org/show_bug.cgi?id=5687
20:14:50 <[mbot> 04Bug 5687: normal, Normal, ---, thierry.vignaud, NEW, Upgrades are incomplete after using dvd or cd., mgaonline-2.77.33-1.mga2.src.rpm
20:14:50 <boklm> tmb: yes, that can be a problem for some packages
20:15:25 <leuhmanu> ennael: yep
20:15:28 <sebsebseb> ennael: yep
20:15:38 <ennael> ok
20:15:41 <marja> OK
20:15:46 <ennael> thanks all for attending
20:15:51 <ennael> #endmeeting