20:04:12 <ennael> #startmeeting
20:04:12 <Inigo_Montoya> Meeting started Mon Dec  5 20:04:12 2011 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:04:12 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:04:30 <ennael> #chair tmb trishf42
20:04:30 <Inigo_Montoya> Current chairs: ennael tmb trishf42
20:04:59 <ennael> #topic FOSDEM 2012
20:05:02 <ennael> misc: ?
20:06:53 <misc> ennael: on my phone, i can only read :/
20:07:09 <ennael> ok let see that later
20:07:11 <ennael> #undo
20:07:11 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Topic object at 0x861550c>
20:07:23 <ennael> #topic Alpha 2
20:08:55 <ennael> ok so here is very basic page
20:09:01 <ennael> https://wiki.mageia.org/en/Mageia_2_alpha2
20:09:36 <ennael> as said in another meeting isos builds will start on 09/12
20:09:47 <obgr_seneca> hi there
20:10:38 <ennael> hi
20:10:51 <ennael> tmb: are you going to work on live isos
20:10:52 <ennael> ?
20:10:55 <tmb> yep, and this time livecds will be built against same frozen tree as dvds
20:11:01 <ennael> ok
20:11:21 <ennael> I will sync tomorrow just to give a try on isos build
20:11:52 <tmb> ok
20:12:24 <ennael> Stormi: it seems coincoin worked today on QA isos
20:12:39 <Stormi> great
20:12:54 <tmb> question... should the alpha2 page list all changes since mageia 1 or only since alpha 1 ?
20:13:23 <Stormi> maybe both in 2 different sections ?
20:13:34 <obgr_seneca> I would use changes since Mga1 so we have an evolvong document
20:13:46 <obgr_seneca> That will one day be fine for Mga2 notes
20:14:35 <ennael> yeo sounds good
20:14:51 <tmb> ok, that would be more logical for "first time testers"
20:15:06 <ennael> also we need to have QA team ready this time
20:15:21 <ennael> find testers and drive tests only with them
20:17:14 <tmb> yep
20:20:20 <Stormi> do you have names in mind for testers ?
20:25:21 <trishf42> while that question's on the table, what do we need from marcom (other than the blog post) for Alpha2?
20:28:16 <tmb> trishf42: afaik nothing for now, unless you have something on your mind
20:28:37 <trishf42> tmb: not at the moment, but yell if you think of anything
20:29:00 <Max___> There was a meeting and I missed it?
20:29:10 <tmb> trishf42: ok
20:29:17 <sebsebseb> Max___: nope still on I think
20:29:31 <ennael> trishf42: maybe it would be nice to have a list of web site to spread Mageia news
20:29:42 <ennael> and how to handle announcements
20:30:02 <ennael> for now we use only blog and twitter/Facebook
20:30:22 <trishf42> and G+
20:30:27 <sebsebseb> well and Identica gets used by people to spread news as well
20:30:38 <ennael> but this can be done only if we have complete wiki page
20:31:29 <trishf42> I noted there's still a mention of alpha1 on the wiki page, I'll fix that (down the bottom)
20:32:09 <trishf42> I'll start putting a list together on the marcom sandbox and get the others to help
20:33:32 <ennael> ok
20:34:07 <ennael> #info tmb will help on live CDs build using frozen repository
20:34:32 <ennael> #action marcom will get a list of web site to spread Mageia news and how to handle it
20:35:34 <ennael> about QA teams any names in mind ?
20:36:36 <tmb> maybe ask for more volunteers on -dev ?
20:36:58 <Stormi> and -qa of course
20:37:12 <Stormi> how many people do we need ?
20:37:14 <tmb> do we have a list of people doing QA on isos for Mageia 1 that is not on qa now ?
20:37:33 <ennael> pb is to choose people to do the right job
20:37:46 <Stormi> tmb: I didn't understand the question :)
20:38:01 <ennael> available for the defined time
20:38:09 <ennael> and kind of advanced people
20:38:20 <obgr_seneca> ennael: You have been following both qa processes, perhaps you could choose some people?
20:39:23 <tmb> Stormi: iirc there were some people doing qa in Mageia1 isos that hasnt been doing qa on alpha1 isos...
20:39:50 <ennael> yep
20:39:56 <ennael> Magnus for example
20:40:04 <ennael> no news from him
20:40:11 <obgr_seneca> I can ask him
20:40:12 <Stormi> I sent him a mail
20:40:24 <leuhmanu> I have see him on irc for 2 weeks
20:40:25 <Stormi> was willing to test, said he was going to see obgr_seneca and test :)
20:40:45 <Stormi> (for alpha 1)
20:41:39 <ennael> we had John also
20:41:51 <obgr_seneca> JohnR?
20:41:57 <ennael> yep
20:42:18 <obgr_seneca> He is active in doc, I can ask him as well
20:42:48 <ennael> we had also a guy named oliver
20:43:01 <obgr_seneca> I saw him this morning
20:43:04 <Stormi> johnR is active on #mageia-qa
20:43:15 <obgr_seneca> And I will do later, shell I sak him?
20:43:22 <ennael> :)
20:43:49 <ennael> all those guys are quite used to work on isos QA and can help to save time for alpha2
20:44:07 <ennael> the work after alpha2 would be to train new one
20:44:14 <obgr_seneca> I was a bit busy with  OpenRheinRuhr and so on, but I'm available now
20:44:32 <ennael> we need also to define a process to report bugs
20:44:48 <ennael> tmb: if you have any idea to improve current one
20:45:51 <ennael> or stormi or any others
20:45:57 <tmb> well, this page is good to follow: https://wiki.mageia.org/en/QA_process_for_testing_installations
20:47:17 <tmb> and since we swith to the more stable piratepad, problems can be reported there too
20:47:42 <ennael> ok
20:48:22 <ennael> one point also is to coordinate tests when a bug is discovered to check it can be reproduce
20:48:25 <ennael> d
20:48:34 <Stormi> indeed
20:48:57 <Stormi> and as I said last time, having the people making the ISOs available during the tests is a big plus
20:49:03 <ennael> sure
20:49:12 <ennael> I'm not planning another personal release this time :)
20:49:18 <ennael> so I will be around
20:49:46 <ennael> but the point is to explain how to organize priorities for tests as it can change when a blocking bug is reported
20:50:07 <leuhmanu> ah yes
20:50:22 <leuhmanu> how can we define a release_blocker bug ?
20:50:34 <tmb> One thing that comes to mind... we should add a wiki page with testers name and what hw available if we need to reproduce a specific bug (is also useful outside the isq qa
20:50:51 <obgr_seneca> that's a really good idea
20:50:53 <tmb> *iso qa)
20:50:57 <ennael> yep
20:51:22 <obgr_seneca> I was thinking about putting up a real user hardware database for people willing to help with qa to sign up
20:51:29 <obgr_seneca> but that's something for later
20:52:01 <ennael> volunteer to create that wiki page ?
20:52:27 <obgr_seneca> yep
20:53:02 <ennael> ok
20:55:37 <ennael> regarding live CDs tests
20:56:08 <ennael> we have a lot of them. Shall we start first tests with one given KDE iso and one GNOME ?
20:56:54 <obgr_seneca> I'd say so, the different language sets shouldn't make so much difference
20:57:50 <tmb> the only difference is what fits on the cd and what does not..
20:58:39 <tmb> but I guess as first test use the Europe1 livecds
20:58:47 <ennael> ok
20:58:59 <leuhmanu> at the moment we have just one bug for scpecific language
20:59:58 <obgr_seneca> which one?
21:00:41 <leuhmanu> (for the isos)
21:02:04 <leuhmanu> https://bugs.mageia.org/show_bug.cgi?id=2415
21:02:57 <obgr_seneca> ah
21:03:43 <tmb> I guess we'll see if we can get it to fit on any iso
21:04:04 <obgr_seneca> europe2?
21:07:10 * ennael will leave meeting now.
21:07:18 * ennael gives her matches to obgr_seneca
21:07:27 <obgr_seneca> ennael: :)
21:07:31 <obgr_seneca> Good night
21:07:35 <ennael> thanks
21:07:50 <tmb> well, current kde4 europe2 is already maxed out  (~711MB) so...
21:08:29 <leuhmanu> arf :/
21:08:29 <obgr_seneca> I just saw, GNOME-europe2 was smaller then 1, but KDE2 larger then 1 for Mga1
21:08:45 <leuhmanu> obgr_seneca: there is missing rpm :p
21:09:47 <tmb> current gnome europe2 is 691MB...
21:10:14 <obgr_seneca> hmpf
21:10:25 <Stormi> maybe we must remove french from Europe 2
21:10:40 <obgr_seneca> Why is it on Europe2?
21:10:50 <obgr_seneca> Shouldn't it be on Europe1?
21:10:56 <tmb> europe1 was probably full
21:11:00 <Stormi> probably to ease frenchies' life :)
21:11:06 <Stormi> it's in europe1 too afaik
21:11:11 <leuhmanu> draklive seems really buggy :/
21:11:18 <Stormi> but maybe I'm mistaken
21:12:10 <leuhmanu> nop http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/iso/cauldron/Mageia-2-alpha1-LiveCD-GNOME-Europe1-Americas-i586/Mageia-2-alpha1-LiveCD-GNOME-Europe1-Americas-i586-CD.langs
21:14:16 <tmb> yep, its only on europe1
21:14:34 <tmb> anyway... anything more about Alpha2 ?
21:14:48 <obgr_seneca> I don't think so
21:15:09 <obgr_seneca> shuffling arround with the space on the isos is something you and blino must do
21:15:16 <tmb> yep
21:16:02 <tmb> so next topic
21:16:18 <tmb> #topic FOSDEM
21:16:25 * trishf42 sits up and pays attention
21:16:40 <obgr_seneca> trishf42: and so you should :D
21:16:44 <trishf42> 8-)
21:17:29 <tmb> I guess this is more of an informational topic as misc is not available now
21:17:40 <trishf42> info! need info!
21:17:51 <misc> well, i have found a pc
21:17:52 <trishf42> do we have a stand booked?
21:17:56 <misc> trishf42: not yet
21:18:08 <trishf42> will we do that?
21:18:09 <misc> ( still didn't look at where to book )
21:18:13 <misc> trishf42: I plan to
21:18:44 <obgr_seneca> misc: I think rda sent the link on -council
21:19:05 <misc> obgr_seneca: well, I have several mail late on several ml, but I will seek
21:19:31 <trishf42> deadline for stand requests is 13/12, according to the fosdem site here http://fosdem.org/2012/call-for-stands
21:19:35 <misc> I sent today my talk proposal, people can look at archive for that
21:19:37 <obgr_seneca> http://fosdem.org/2012/call-for-stands
21:20:15 <blino> tmb: that's the x86_64 which is 711MB, which is normal, since we even have a hard time putting a working i586 set on a CD, and that's also one of the issues that make x86_64 hard to master
21:20:35 <trishf42> marcom will work with whoever, to set up the events box with posters, tablecloth, banners and whatever else
21:20:43 * misc is filling the form
21:21:20 <trishf42> misc: can you let me know how many tables you get so I know how many tablecloths to bring
21:22:32 <tmb> and remember to add your names to: https://wiki.mageia.org/en/Fosdem_2012 if you havent already
21:22:59 <misc> trish42: i guess that we will have what they say on website
21:23:27 <misc> # one (max. two tables) of 1m80 x 80cm each, positioned in the hallways of the Developer Rooms,
21:24:12 <trishf42> down the bottom it says you can ask for an extra table - so should we have 1 table or 2?
21:24:27 <trishf42> Depends how many different things we want to show
21:25:41 <misc> 1 table should be enough I think
21:25:49 <misc> we can let other have more
21:27:41 <tmb> yeah I think one is enough too
21:28:59 <trishf42> ok
21:29:03 <tmb> #info misc applies for a mageia stand on fosdem
21:29:37 <trishf42> do we know if there's anything behind the table where we can hang posters? are we allowed to put them up on the wall?
21:30:57 <misc> I think, yes
21:31:10 <misc> you should look at pictures of fosdem of the last 10 years, since it didn't change :)
21:31:40 <tmb> #info misc intend to send a talk proposal (according to council ml)
21:31:44 <trishf42> ok, I'll do that. Can I ping you with questions?
21:32:53 <misc> tmb: I did
21:33:17 <tmb> misc: the talk proposal ?
21:33:29 <misc> https://lists.fosdem.org/pipermail/distributions/2011-December/000013.html
21:33:38 <misc> tmb: the booth proposal too, i just finished
21:34:06 <misc> so I can now go back to the end of the IRL meeting where i am, EOT for me, send me questions by mail
21:34:30 <tmb> misc: ok, thanks
21:34:45 <tmb> #undo
21:34:45 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Link object at 0x84fee4c>
21:34:55 <tmb> #undo
21:34:55 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x864898c>
21:35:16 <tmb> #info misc has applied for a mageia stand on fosdem
21:36:02 <misc> (asked to have gnome as neighboor for me and olav)
21:37:06 <tmb> #info misc has sent a fosdem talk proposal (https://lists.fosdem.org/pipermail/distributions/2011-December/000013.html)
21:37:19 <tmb> so .. anything else on this topic ?
21:37:30 <trishf42> not atm
21:37:45 <misc> (also suggrsted to spread out the various distribution to avoid diplomatic incidents)
21:38:15 <tmb> :)
21:38:34 <tmb> ok, next topic ?
21:39:28 <leuhmanu> do we have another one ?
21:39:36 <tmb> #topic Backports
21:40:14 <tmb> so here is a suggestion from me...
21:40:44 <tmb> as we still dont have the infrastructure altered to cope with backports from cauldron...
21:42:48 <tmb> what about simply add a updates/1/<package>/branch/backports/[current, pristine,releases] for any package needing backport ?
21:44:09 <Stormi> that's one of the 2 proposals I made in september to "speed things up" :)
21:44:11 <Stormi> https://www.zarb.org/pipermail/mageia-dev/2011-September/008496.html
21:44:14 <tmb> afaik mgarepo only looks for the "updates/1/<package>" part when submitting..
21:44:29 <Stormi> indeed
21:45:27 <Stormi> (my proposal was not exactly the same but had the same reasoning)
21:45:58 <Stormi> anything provided we can open them at last, I refrained from asking and asking, but would be happy to see it happen
21:46:55 <trishf42> if nobody needs anything else from me, I need to go now
21:47:21 <tmb> yeah, and as we are 6 months into Mageia 1, I think we really should open backports too
21:47:40 <Stormi> trishf42: of course, see you :)
21:47:54 <trishf42> thanks! night all, see you on the list
21:48:06 <obgr_seneca> see you
21:48:44 <tmb> so... any objections to "opening" backports this way ?
21:49:14 <Stormi> boklm might have as he was working on the "complete" solution for opening them
21:49:20 <tmb> and try to fix it properly for Mageia 2
21:49:37 <tmb> boklm: ping
21:49:52 <Stormi> in fact, if we start to use branches for backports, this could become a long term solution
21:50:10 <Stormi> IIRC it was not chosen because it was "easier" to submit from cauldron
21:51:20 <tmb> well, I'd be in favour of using a branch even when we "fix it properly" as a backported package might not be the same as a simple rebuild of the cauldron one...
21:51:36 <obgr_seneca> +1
21:51:41 <Stormi> that's my opinion too but not was adopted as a policy for now
21:51:55 <Stormi> althought the policy was meant to be reviewed after some time
21:51:59 <Stormi> and some time has passed :)
21:52:06 <boklm> actually main problem is messing changelogs
21:52:42 <boklm> we can allow backports from "backports/1/<package>"
21:53:06 <boklm> but all changelogs and released from cauldron, 1 updates and 1 backports are mixed
21:54:00 <tmb> boklm: does that happend only on markrel  ?
21:54:45 <boklm> youri currently doesn't know the media when doing the markrelease, so it's always done on cauldron
21:55:12 <boklm> and changelog is generated from cauldron directory for all packages
21:55:23 <tmb> ouch
21:56:07 <obgr_seneca> so changelogs for 1/updates are done from cauldron as well?
21:56:46 <boklm> hmm, I not sure, maybe they are done from 1/updates, but there is no markrelease there
21:56:50 <tmb> how did it work on mdv? I know that I had to run markrel manually on correct svn url, bot other than that I didn't see any mess in the changelog
21:57:30 <boklm> I think it was not working correctly either on mdv
21:58:06 <boklm> there was no markrelease for updates/backports I think
21:58:07 <tmb> well, mdv didn't run any markrel on updates tree done bu contributors
21:58:31 <boklm> it was working for official updates, done with secteam scripts
21:58:42 <tmb> but I did the markrel manually for contrib kernels
21:59:39 <tmb> so... should we as a start allow  "backports/1/<package>" and try to fix the markrel later or ?
21:59:57 <boklm> we can start with this without markrelease for now
22:00:22 <boklm> and work on improving youri/mgarepo to have markrelease done correctly
22:01:31 <boklm> markrelease is currently disabled on mageia 1
22:02:02 <tmb> yeah, I think we should start it that way as it's better than nothing...
22:02:56 <boklm> ok
22:03:56 <tmb> boklm: can you add the  "backports/1/<package>" url to allowed source for Mageia 1 then ?
22:04:14 <boklm> ok, I will do it
22:05:08 <tmb> #info backports will be opened with packages submitted from "backports/1/<package>" url
22:05:24 <misc> mhhh
22:05:46 <misc> am I dreaming or are people sneaking last minute decisoon without announcing it, basically reversing the consensus ?
22:06:36 <tmb> misc ?
22:07:20 <misc> tmb: I left the meeting thinking it was finished since there was no other topic proposed at the beginning on the list, and now, I see people basically adding something at last minutes , to something I disagreed vehemently in the past
22:08:03 <Stormi> ok, then maybe we can forward the discussion to the packagers meeting ?
22:08:21 <obgr_seneca> At least we should find a solution
22:08:32 <misc> well, coding what is missing is the solution
22:08:40 <Stormi> not the only one
22:08:41 <misc> I think we agreed on a solution
22:09:33 <misc> what is the use of discussing policy if people change it each time we have one ?
22:09:46 <tmb> I guess we need to postpone it then again for Mageia X
22:09:48 <tmb> #undo
22:09:48 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x84e2bcc>
22:10:05 <Stormi> and I'll go cry in my bed :)
22:10:24 <obgr_seneca> As long as X is not the roman number
22:10:51 <Stormi> during policy discussions there didn't seem to be a prominent majority for the "submit directly from cauldron, no branch" solution
22:11:03 <tmb> nope, it was intead of "infinity"
22:11:13 <Stormi> so discussing it again when it would *really* allow opening backports is not shocking to me
22:11:56 <misc> Stormi: then this should be at least announced on the list, so people can discuss it
22:12:05 <Stormi> yes, let's do that
22:12:18 <Stormi> althought I tried already 2 months ago
22:12:41 <Stormi> and was just told to be patient
22:13:29 <Stormi> tmb: could you send your proposal to the list?
22:13:46 <tmb> yep.
22:14:16 <tmb> #action tmb will send new backports proposal to -dev ml
22:14:24 <Stormi> then we can have some sleeping and think about it :)
22:14:28 <tmb> so... anything else ?
22:15:29 <tmb> if not we'll end the meeting
22:15:38 <leuhmanu> good night !
22:15:43 <misc> there was nothing announced on the agenda, so I guess we can close , yes
22:16:02 <tmb> #endmeeting