19:06:52 <ennael> #startmeeting
19:06:52 <Inigo_Montoya> Meeting started Mon Oct  3 19:06:52 2011 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:06:52 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:07:02 <ennael> #chair boklm
19:07:02 <Inigo_Montoya> Current chairs: boklm ennael
19:07:43 <ennael> #topic Take  decision about needed hardware
19:07:51 <ennael> hop boklm ?
19:07:58 <boklm> ok
19:08:52 <boklm> so I sent an email about the new hardware that we need for mageia servers, on mageia-sysadm mailing list:
19:08:57 <boklm> http://mageia.org/pipermail/mageia-sysadm/2011-October/003977.html
19:10:06 <boklm> so everybody seems to agree about the ARM board
19:11:27 <ennael> #info ok for buying board from Freescale 122,93 euros
19:11:27 <tmb> yep
19:11:45 <ennael> #url http://fr.mouser.com/ProductDetail/Freescale-Semiconductor/MCIMX53-START/?qs=sGAEpiMZZMspbelMIdDJdKswmyqRD7aG
19:12:01 <boklm> and we need to decide about the backup server, and server for packagers
19:12:17 <ennael> let see first backup server
19:12:36 <coincoin> fiona \o/
19:12:38 <ennael> I'm sure we all agree we need one :)
19:13:00 <ennael> so what are nos the cons / proposal ?
19:13:14 <misc> well, technically, the only thing that need a backup are the database
19:13:24 <ennael> hi misc
19:13:29 <misc> hi
19:13:42 <obgr_seneca> hi
19:13:47 <ennael> so
19:13:47 <boklm> so coincoin proposed a Dell server, at 2200 euros
19:14:35 <boklm> however I think it is quite expensive, and maybe we can find cheaper alternatives
19:14:59 <ennael> any proposal ?
19:15:01 <boklm> tonight Nanar told me that maybe he can find some servers for us with SATA disks
19:15:26 <misc> he told me too, but he went to bed
19:15:42 <Nanar> I think i have server 1U able to handle 3 sata disk
19:15:43 <coincoin> servers he will get from jussieu as his proposal last year?
19:15:43 <boklm> and he can check on wednesday morning what server he can have
19:15:46 <ennael> we just need t be careful with disks and plan maybe to get new one
19:16:03 <boklm> ennael: yes, only for the server
19:16:48 <coincoin> servers recent enough to support 2TB SATA drives?
19:16:57 <tmb> well, a 3-disk sata can cope with 4-6TB of data in raid :) ,so that would be enough
19:16:59 <ennael> any detail about server specs ?
19:17:12 <coincoin> tmb: depending on RAID and HDD size (so price ;))
19:17:36 <Nanar> iirc: 4GB RAM, 2CPU 32bits
19:17:40 <ennael> I guess it would be less than 2200
19:17:42 <ennael> hi Nanar :)
19:18:00 <coincoin> ennael: depending on HDD, garantee and support
19:18:04 <Nanar> I have to check raid support
19:18:14 <tmb> Nanar: we can use mdadm
19:18:15 <coincoin> HDD is about 200� per disk (we need 3 or 4 disk)
19:18:16 <boklm> we can do soft raid
19:18:19 <ennael> Nanar: can you do it and mail about this tomorrow ?
19:18:34 <ennael> or ping boklm on irc
19:18:46 <Nanar> ennael: wenesday, tomorrow I'll be on Jussieu, not where server are stored
19:18:52 <ennael> ok
19:18:57 <coincoin> raid support is not a good idea as HW RAID will stuck us on a chipset for a long time
19:19:15 <ennael> #info Nanar will give detailed specs of the server on wednesday to boklm
19:19:50 <Nanar> I did a mail about it long time ago
19:20:43 <ennael> who did you mail ?
19:21:13 <Nanar> coincoin iirc
19:21:15 <coincoin> don't forget to take bay rail for the server
19:21:24 <coincoin> Nanar: the Jussieu servers? Nec?
19:21:42 <Nanar> coincoin: nec, not at jussieu
19:21:52 <Nanar> but we have also DELL and Transtec
19:21:56 <ennael> okok
19:22:01 <coincoin> hum, I only have the mail about NEC from Jussieu :/
19:22:14 <ennael> so let see what are the specs and we will see then what to do
19:22:15 <coincoin> NEC was very old servers IIRC
19:22:20 <Nanar> and an old rAID ARRAY, scsi, 12 sata disk
19:22:29 <coincoin> I think I can find it and FW it on sysadmin@
19:22:43 <coincoin> SCSI: no way ;)
19:22:50 <ennael> once you have it can you mail council@ ?
19:23:01 <ennael> then we will decide if it can suit or not
19:23:15 <ennael> ok boklm ?
19:23:33 <boklm> ok
19:23:35 <tmb> I think thats ok
19:24:11 <coincoin> Nanar: the NEC I have in my mail is 1U and 2 HDD bay
19:24:16 <ennael> so
19:24:30 <ennael> we have also disks to be bought
19:24:33 <ennael> boklm ?
19:24:51 <Nanar> I'll check, we have several server sleeping
19:25:17 <Nanar> coincoin: the raid array is scsi, not the disk
19:25:33 <boklm> so there is a few disks that we need to buy, 4 for the backup server, and 5 for other servers
19:25:37 <Nanar> coincoin: the raid array is autonomous hardware
19:26:01 <coincoin> Nanar: carefull, we don't have a lot of place left @ieolo ;)
19:26:10 <ennael> anybody against buying new disks ?
19:26:21 <tmb> nope. we need them.
19:26:26 <boklm> 1 disk to replace failing disk on valstar, 1 to replace failing disk on ecosse, 1 for the arm board, and 1 new disk for each build nodes
19:26:31 <misc> what about trying to steal them ?
19:26:41 <ennael> ok
19:27:04 <tmb> ^^ ok to stealing... ??? :)
19:27:05 <boklm> for build nodes, an other option could be to buy a 250GB SSD disk
19:27:26 <ennael> tmb: :)
19:27:32 <coincoin> or 320GB (depending on KDE, LO, ...)
19:27:44 <coincoin> the price is quite the same (100 � more or less)
19:27:52 <ennael> so  basically   2TB (valstar) + 1TB * 4 => 169.99 + 4 * 84.99 = 509.95 euros
19:27:57 <ennael> gives a good idea
19:28:02 <ennael> ?
19:28:21 <boklm> ennael: yes, without the disks for the backup server
19:28:31 <tmb> and backup server would use 3x169
19:28:38 <ennael> ok so at least we can agree on these one
19:28:46 <ennael> will depend what we do / backup server
19:29:19 <ennael> #info ok for buying 2TB (valstar) + 1TB * 4 => 169.99 + 4 * 84.99 = 509.95 euros - disks (without backup server)
19:29:53 <ennael> boklm: now node for packages build tests ?
19:30:10 <coincoin> hum why 4 * 1TB? I can't find them...
19:30:56 <boklm> coincoin: ?
19:31:25 <boklm> 4 * 1TB, for build nodes, and arm board
19:31:36 <tmb> coincoin: 1 failing ecosse, 1 extra ecosse, 1 extra jonund, 1 for arm
19:32:02 <ennael> so build node ?
19:32:04 <coincoin> tmb: no need for to many extra, we will receive 3 new HDD from RMA and we already have 2 spare
19:32:28 <tmb> coincoin: we switch to a raid1 + raid0 layout
19:33:09 <coincoin> hum ok
19:33:13 <boklm> for packagers node, we need a server to allow packagers to use VMs to test package builds, maybe also for QA
19:33:35 <boklm> so we need a fast server
19:34:07 <ennael> proposal was http://www.online.net/serveur-dedie/offre-dedibox-pro-r210.xhtml
19:34:30 <boklm> so one proposal is to rent a server
19:34:31 <misc> boklm: and with ram
19:34:31 <tmb> I dont thin that proposal is enough... only 4 cores...
19:35:08 <boklm> an other proposal is to buy a server, for instance this one: http://www.hupstream.com/~boklm/mageia/server-packagers.pdf
19:35:16 <tmb> This one would be fast: http://www.online.net/serveur-dedie/offre-dedibox-pro-r410.xhtml (but 120€ / month)
19:35:38 <coincoin> dedibox is very small and sloooooooooooooow...
19:36:22 <tmb> boklm: that pdf misses the disks...
19:36:27 <coincoin> boklm: missing SAS on your proposal if you want 'good IO'
19:36:38 <boklm> yes
19:38:06 <boklm> so that would be 670 more if we add 2 * 300GB SAS disks
19:38:27 <coincoin> boklm: including SAS card?
19:38:49 <boklm> coincoin: do we need an additional SAS card ?
19:39:14 <coincoin> boklm: I don't know if there is SAS on onboard chipset, I can't open link now
19:39:42 <boklm> it allows selecting SAS disk, so I think it supports SAS
19:40:04 <tmb> coincoin: there is  the SAS 6/iR
19:40:24 <coincoin> tmb: hum ok, thank you
19:41:36 <ennael> so ?
19:42:18 <boklm> so that's 2852 euros (without taxes and shipping)
19:42:19 <coincoin> (carefull H200 is better than 6/iR if RAID HW is needed as 6/iR is soft raid)
19:43:00 <tmb> will 2* 300GB be enough space ? IIRC mdv bs had 250GB disks, and almost always full...
19:43:11 <boklm> hmm, yes, maybe not enough
19:43:48 <misc> tmb: we can be more agressive when cleaning directory
19:44:10 <boklm> we can have raid 1 for system, raid 0 for data
19:44:27 <ennael> I would suggest not restart as mdv bs with too low resources
19:44:33 <ennael> or we will have same pb
19:44:39 <tmb> misc: true, and if needed add quotas
19:45:02 <misc> ennael: disk space and packager is like room and a gaz, it will fill the space
19:45:20 <misc> I am prety sure that if we give 1 t per packager, sooner or later, one will hit the limit
19:45:50 <ennael> sure but nothing prevents to check what minimum could be
19:46:03 <misc> and also, if we plan to do backup of the home, this must be taken in account ( if we don't the remark is moot )
19:46:32 <ennael> so
19:46:38 <ennael> can we decide about this tonight ?
19:47:25 <coincoin> boklm: the chipset of the server support virtualization? vmx for AMD (I ask as it's a cheap CPU, so perhaps a cheap chipset)
19:48:00 <misc> all processors nowadays support it, iirc, the question is rather to know if the BIOS permit it
19:48:13 <misc> ( ie, if the feature have been disabled :/ )
19:48:21 <coincoin> misc: I asked chipset, not CPU ;)
19:48:56 <boklm> how can we check this ?
19:49:24 <coincoin> on dell spec file and google :)
19:49:35 <coincoin> I can't launch a browser now :/
19:51:47 <ennael> ok... so can we get final proposal within 2 days ?
19:52:19 <boklm> ok
19:52:28 <ennael> and mail council about it ?
19:52:29 <ennael> thanks
19:52:31 <boklm> ok
19:52:48 <tmb> coincoin: chipset: AMD (SR5670 and SP5100) has support for AMD Vi
19:52:59 <ennael> #action boklm will mail about final specs for tests server for packagers
19:53:05 <ennael> #undo
19:53:05 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0xb73f9e8c>
19:53:17 <ennael> #action boklm will mail about final specs for tests server for packagers within 2 days
19:54:14 <coincoin> tmb: good point. I hope the CPU too (not all CPU are virt capable nowadays :()
19:54:29 <ennael> ok anything else on this point ?
19:55:33 <boklm> nothing for me
19:55:44 <tmb> coincoin: afaik all AMD server cpus are virt capable
19:58:04 <coincoin> tmb: great, I've got the PDF now. better to follow! :)
19:58:28 <ennael> ok let see next topic
19:58:47 <ennael> short one before wiki proposed by tmb
19:59:10 <ennael> #topic Proposal for postponing Mageia final release
19:59:13 <ennael> tmb: ?
19:59:18 <tmb> yep
20:00:08 <tmb> as mailed on council@, Olav Vitters asked about Gnome 2.4 for Mageia 2
20:00:33 <leuhmanu> 3.4*
20:00:33 <coincoin> s/2.4/3.4/
20:00:47 <tmb> yeah :)
20:01:01 <tmb> the thread was on -dev: https://mageia.org/pipermail/mageia-dev/2011-September/008502.html
20:01:09 <tmb> in short:
20:01:26 <tmb> Mageia release:
20:01:26 <tmb> Releases freeze : 06/03/2012
20:01:26 <tmb> RC : 09/03/2012
20:01:26 <tmb> Final Release: 04/04/2012
20:01:45 <tmb> Gnome 3.4 release:
20:01:45 <tmb> String freeze:	March 05 2012
20:01:45 <tmb> Code freze:	March 19 2012
20:01:45 <tmb> 3.4 release:	March 28 2012
20:02:15 <tmb> kde 4.8.x release:
20:02:15 <tmb> 1.22 Thursday, March 1, 2012: KDE 4.8.1 tagging
20:02:15 <tmb> 1.23 Tuesday, March 6, 2012: KDE 4.8.1 release
20:02:15 <tmb> 1.24 Thursday, March 29, 2012: KDE 4.8.2 tagging
20:02:16 <tmb> 1.25 Tuesday, April 3, 2012: KDE 4.8.2 release
20:03:02 <tmb> So by the above I suggest we postpone the Mageia 2 by ~1 month
20:03:26 <obgr_seneca> But that would still put GNOME and KDE some weeks after official version freeze
20:03:28 <tmb> that way we would get Gnome 3.4 and KDE 4.8.2 final before RC isos
20:03:38 <obgr_seneca> Do we have enough time for QA then?
20:04:04 <ennael> well usually we have already rc releases for KDE and GNOME in cauldron
20:04:07 <tmb> obgr_seneca: well, we would be running RCs of Gnome and KDE too
20:04:11 <ennael> so delta is not that big
20:04:27 <ennael> arf :)
20:04:28 <coincoin> if we do intagration in the time, will be ok (what we were doing @ mdv
20:04:29 <coincoin> )
20:04:49 <tmb> The thinking is that it would be good PR for Mageia 2
20:05:03 <coincoin> +1
20:05:07 <obgr_seneca> ok
20:05:07 <tmb> (assuming there are no stupid bugs like in Gnome 3.2)
20:05:19 <coincoin> s/3.2// :p
20:05:21 <ennael> others ? comment ?
20:05:33 * boklm agree
20:05:39 <coincoin> I agree with tmb
20:05:55 <obgr_seneca> shouldn't we ask mikala and whoever maintains GNOME about it?
20:06:10 <ennael> obgr_seneca: olav explained it about GNOME
20:06:24 <obgr_seneca> Then it's ok with me
20:06:36 <ennael> trishf42: ?
20:06:45 <obgr_seneca> Since the differences between KDE 4.8.1 and 4.8.2 shouldn't be all that big
20:07:04 <obgr_seneca> So integration shouldn't make that big a problem
20:07:06 <trishf42> hey, sorry - it's all fine with me; what would be the new date if we push it back?
20:07:30 <ennael> what about 3rd of may ?
20:07:56 <trishf42> Sounds just fine to me - and it'll be all shiny, too, with New Stuff!
20:08:22 <ennael> comments ?
20:08:37 <obgr_seneca> It's still well before Linuxtag, that's ok
20:08:38 <tmb> Hm, 3rd of may would be a thursday, so that would be good for final hicups
20:09:08 <ennael> just need to reorganize previous steps
20:10:02 <obgr_seneca> I wouldn't move alpha1 far, better have a more time between test releases
20:10:33 <ennael> #info because of KDE and GNOME development planning we will postpone Mageia2 final release on May, 3rd, 2012
20:11:14 <coincoin> did you check that it won't arrive in the same time as MDV (if still alive) or another distro?
20:11:24 <tmb> Maybe just drop in a Beta3
20:11:31 <ennael> yep
20:11:40 <ennael> will mail a proposal for full planning
20:12:46 <tmb> Fedora15: 2011-05-24
20:13:02 <obgr_seneca> And Ubuntu will be some days before us
20:13:14 <ennael> Mandriva 2012(assumed version name) will be the next major Mandriva release, scheduled to be released in 2012.
20:13:27 <ennael> nothing more
20:13:59 <ennael> so looks ok
20:14:05 <coincoin> yep
20:14:12 <ennael> ok next topic
20:14:17 <obgr_seneca> sorry phone, will be back shortly
20:14:45 <ennael> #topic finalizing doc for wiki migration
20:17:37 <obgr_seneca> back
20:17:59 <ennael> so boklm sent a mail to doc ML
20:18:12 <ennael> anybody to sum up discussion ?
20:19:05 <ennael> especially to speak about http://mageia.org/wiki/doku.php?id=web:wiki#formal_rules
20:20:23 <boklm> nobody seemed to disagree with those rules
20:20:36 <obgr_seneca> I like them
20:20:36 <rda> they seem simple enough and articulate to allow things to start
20:21:07 <obgr_seneca> divide the major things in Categories and have a flat structure underneath if I understand them correctly?
20:21:28 <boklm> yes, flat page names
20:21:29 <rda> flat naming + categories to structure, yes
20:22:34 <obgr_seneca> So to remind of our discussion two weeks ago: there would for example be a category "Contributors.", one "Planning.", one "Documentation." and so on?
20:23:24 <boklm> yes
20:23:41 <boklm> there was some comments about "What the wiki is not for"
20:24:06 <rda> yes?
20:24:37 <boklm> https://ml.mageia.org/wwsympa-wrapper.fcgi/arc/doc-discuss/2011-10/msg00006.html
20:26:06 <rda> well, the question is not clear. but the point of recommending against FAQ, in this case, was to push FAQ into a separate platform, if it ever is needed.
20:26:15 <rda> but that's a draft, and it's not a stone document.
20:26:49 <rda> the goal of squaring what the wiki is not for is to help not put everything in it (and bend it in a way that's not good)
20:27:01 <obgr_seneca> I would leave FAQ in the wiki, but under harsh control of docteam
20:27:13 <obgr_seneca> It shouldn't expand too much
20:27:43 <rda> well, a FAQ, at some extent, would better live into a stackoverflow spin off than a wiki, I guess
20:28:16 <obgr_seneca> sorry, a what?
20:28:28 <ennael> :)
20:28:36 <misc> obgr_seneca: a forum on steroid, with tagging, etc
20:28:49 <obgr_seneca> ah, thanks
20:28:52 <misc> obgr_seneca: http://stackoverflow.com/
20:28:59 * boklm think FAQ is just some kind of documentation
20:29:39 <rda> you have http://www.osqa.net/ or http://shapado.com/ as GPL equivalents
20:30:25 <boklm> rda: I think it looks more like forums than FAQ
20:31:04 <rda> boklm: it's both. It has the advantage that anyone can answer a new question, promote it, and the best recognized answer wins.
20:31:39 <rda> forums and FAQs (and wikis, etc.) are not stable or absolute concepts
20:31:39 <boklm> I think it does not replace FAQ that can be part of documentation
20:31:54 <rda> I'm only suggesting.
20:32:03 <rda> static documentation tends to die slowly.
20:32:48 <ennael> for now we have neither FAQ nor steroids
20:33:08 <ennael> so maybe we can start quickly with traditional FAQ and plan something else to extend it
20:33:16 <obgr_seneca> +1
20:33:52 <rda> not saying otherwise either
20:34:25 <ennael> just to write it down :) but keeping that proposal also
20:34:58 <ennael> so basically we have all rules to start migration ?
20:35:42 <rda> seems so
20:35:56 <boklm> yes
20:36:11 <ennael> anybody to specifically check all that wiki page and clean it maybe if needed ?
20:36:54 <obgr_seneca> I will invite to another docteam meeting tomorrow to keep the folks informed and get things started?
20:36:56 <ennael> next step is to organize start of migration to avoid big mess
20:37:47 <ennael> we have contacts for some teams for wiki
20:38:38 * ennael proposed last week at least to start with restricted number of people to setup basic structure
20:39:01 <ennael> comment? proposal?
20:39:12 <obgr_seneca> ok with me, whom did you have in mind?
20:39:14 <rda> sounds good to me. how many people does it make so far?
20:39:40 <boklm> list of people is on the page
20:39:43 <ennael> http://mageia.org/wiki/doku.php?id=web:wiki#teams_contacts_for_wiki
20:40:26 <obgr_seneca> ok
20:41:02 <ennael> boklm: can you create very temporary htaccess for those people ?
20:41:49 * boklm didn't have time yet to look at mediawiki upgrade discussed last week
20:42:04 <ennael> oups yes I forgot that point
20:43:37 <trishf42> ennael: I can go on that list for marcom, should I edit that in?
20:43:46 <ennael> yep
20:44:00 <obgr_seneca> And I think, we can add TeaAge for artwork
20:44:13 <ennael> ok
20:44:31 <ennael> boklm: whent do you think you can have a look on this ?
20:44:44 * boklm will try to have a look this week
20:45:24 <ennael> can we start working on it or shall we wait for that udpate
20:45:25 <ennael> ?
20:45:26 <obgr_seneca> One thing: we will mirror the same structure for localized wikis?
20:46:07 <obgr_seneca> Then we should have people (perhaps from i18n) keeping an eye on it, so it will be kept clean...
20:46:14 <boklm> I don't know if updating content from old mediawiki to new version is easy
20:47:13 <boklm> maybe we can upgrade to new version if it can be done easily, or stay with older version for now if not
20:47:36 <ennael> at least would be nice to start finally :)
20:47:44 <boklm> yes
20:48:31 <boklm> I don't know how long mediawiki 1.6.x is supported
20:49:06 <boklm> they say old release are supported for up to a year
20:50:34 <boklm> so we can start with mediawiki 1.6 if updating setup for 1.7 is not simple
20:51:13 * boklm will look during this week
20:51:24 <ennael> ok
20:51:36 <ennael> also if you can have a look on htaccess
20:51:46 <ennael> we will provide it to all wiki contacts
20:52:02 <ennael> still we need somebody in charge with the very first wiki page
20:52:05 <ennael> volunteer ,
20:52:06 <ennael> ?
20:53:28 * obgr_seneca would propose TeaAge, he is not here and can't veto it :D
20:54:04 <ennael> is he available these days ?
20:54:12 <obgr_seneca> Don't know
20:54:17 <obgr_seneca> To clarify it
20:54:38 <obgr_seneca> by the very first page, you mean the index page of the wiki?
20:55:18 <ennael> yep
20:56:02 <obgr_seneca> I just don't know, how much time I will have over the next two weeks
20:56:11 <obgr_seneca> trishf42: Shell we do it together?
20:56:30 <ennael> would be great
20:56:41 <trishf42> absolutely - that's a great idea. I'm a bit short of time too, so I think it could work for both of us
20:56:52 <obgr_seneca> ok, then let's do it
20:57:01 <obgr_seneca> I should have enough time...
20:57:01 <trishf42> okay - make an action someone!
20:57:11 <ennael> #action obgr_seneca and trishf42 will work on index page for wiki
20:57:17 <trishf42> 8-)
20:57:36 <obgr_seneca> :)
20:57:41 <ennael> #action boklm will check status of update for wiki and provide htaccess for wiki contacts
20:59:16 <ennael> can we make a review for all this on thursday by mail ?
20:59:25 <trishf42> sounds good
20:59:31 <boklm> ok
20:59:33 <obgr_seneca> yep
20:59:37 <ennael> ok
20:59:43 <ennael> anything else on wiki ?
21:01:26 <ennael> ok :)
21:01:33 <boklm> nothing for me
21:01:36 <ennael> other topic ?
21:01:43 <ennael> 'before dying all)
21:01:50 <boklm> there was a topic from leuhmanu
21:02:11 <boklm> about users discuss mailing lists
21:02:16 <leuhmanu> ah yes
21:02:26 <leuhmanu> add a localised ml
21:03:41 <leuhmanu> but that can wait, if everyone is sleeping
21:06:37 <obgr_seneca> what about blog posts, it was on ennael's agenda?
21:06:58 <ennael> well I guess it can wait after 2h meeting Offering some clear technical documentation about the installation/migration processes and setup helping for both small and wide computer infrastructures.
21:07:05 <ennael> oups
21:07:08 <ennael> touchpad
21:07:14 * ennael is tired :)
21:07:21 <ennael> well I guess it can wait after 2h meeting
21:07:23 <obgr_seneca> Who is not?
21:07:27 <obgr_seneca> Ok
21:07:41 <ennael> just to remind this page and ask for any proposals you can have
21:13:14 <ennael> ok Let's close the meeting
21:13:19 <ennael> #endmeeting