18:33:32 <misc> #startmeeting
18:33:32 <Inigo_Montoya`> Meeting started Mon Mar 28 18:33:32 2011 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:33:32 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:33:33 <ennael> so boklm is not there tonight, pactising coling favorite sport
18:33:43 <misc> #name council
18:33:49 <misc> #chair ennael wobo rda
18:33:49 <Inigo_Montoya`> Current chairs: ennael misc rda wobo
18:34:36 <misc> ok so let's start
18:34:46 <rda> #topic quick teams review
18:34:47 <misc> ( let's pretend I am hungry despites being full )
18:35:02 <ennael> :)
18:35:04 <rda> so, teams' reviews are here http://mageia.org/wiki/doku.php?id=meeting:council_notes_2011_03_28
18:35:22 <rda> did everyone had a look/updated it? and have questions/comments about it?
18:35:33 <wobo> #url http://mageia.org/wiki/doku.php?id=meeting:council_notes_2011_03_28
18:35:35 <misc> I think I didn't update the packager stuff
18:35:44 <ennael> neither do I :/
18:35:52 <coincoin> neither do I...
18:35:54 <ennael> will do after meeting
18:35:56 <rda> bad boys. bad girl.
18:36:02 <rda> ok
18:36:11 <ennael> so forums to be announced tomorrow ?
18:36:11 <misc> and also, marcom is not separated
18:36:15 <rda> I saw that sysadmin now have a representative (who is not here)
18:36:16 <wobo> Updated translator's stuff after today's meeting of i18n-de
18:36:45 <rda> misc: what do you mean?
18:37:01 <ennael> wobo: aware of jehane departure as fr team leadr ?
18:37:03 <ennael> leader
18:37:09 <wobo> no!
18:37:13 <ennael> arf
18:37:16 <ennael> there it is
18:37:19 <wobo> she did not tell
18:37:24 <ennael> on ML it seems
18:37:30 <misc> fr ml
18:37:35 <wobo> Aef!
18:37:37 <ennael> so it would be nice to find somebody to replace her quickly
18:37:42 <wobo> yes
18:37:48 <ennael> she will still contitribute as contributer
18:37:49 <misc> rda: well, marcom is still not a team, that's marketing and com afaik, until there was change in which case we need to change the various documentation
18:38:05 <rda> misc: marcom is marketing+communication.
18:38:15 <rda> so far, that's two teams that work as a single place for now.
18:38:21 <rda> which various doc?
18:38:50 <wobo> #action wobo will check with fr i18n team about new team leader
18:38:59 <ennael> wobo: if you need a hand I xan help you to shake people :)
18:39:07 <ennael> I know some of of french people in team
18:39:09 <misc> well, the one with the list of team etc, it would be clearer to either decide on merging the 2 team or to use their respective name
18:39:18 <wobo> ennael: :)
18:39:38 <misc> ( not that I am not again any solution, but I would prefer us to be consistent on what we do, and if we merge, then merge fully )
18:39:46 <misc> against
18:40:18 <rda> before it to be consistent, it needs both teams to start. so far, almost nothing happens there (had several false starts)
18:40:37 <rda> so I prefer for now we factor both teams together and still keep a note of distinct matters.
18:40:56 <rda> has anyone questions about the reviews or shall we start the topics? (beta1 planning/progress first)
18:42:27 <rda> #topic beta1 planning & progress
18:42:30 <rda> ennael: yours?
18:43:14 <ennael> ok
18:43:33 <ennael> so I've started dvd isos
18:43:43 <ennael> it's much cleaner than alpha2
18:43:57 <ennael> almost no more errors in packages and main big bugs fixed
18:44:05 <misc> the issue about kde etc are fixed ?
18:44:05 <ennael> ex: localization installation
18:44:12 <ennael> still have to check it
18:44:14 <misc> ( like extra requirement )
18:44:56 <ennael> so far so good
18:45:15 <ennael> still texlive which is huge and would need to be splitted
18:45:27 <ennael> but for now too big work and no time in dmorgan todo list
18:45:40 <ennael> unless somebody here wants to do it :)
18:46:33 <ennael> so I have 4Go iso to test
18:46:41 <ennael> and dual all fixed also
18:46:51 <ennael> blino told us he will be able to build live cd
18:46:59 <ennael> as soon as we have missing icons for draklive
18:47:11 <misc> we could arrange to have a http server on rabbit to distribute daily iso ?
18:47:18 <ennael> yep
18:47:37 <ennael> as it's much better now I can start to have automatic builds
18:47:41 <coincoin> oh, this will be good
18:48:01 <ennael> I just want to make last tests and fix last errors then it should be ok
18:48:15 <misc> #action boklm add a way to distribute daily build for iso by http ( or stuff like that )
18:48:26 <rda> :)
18:48:37 <ennael> poor missing people :)
18:48:52 <ennael> still we need upgrade tests
18:49:13 <ennael> looks like upgrade has improved a lot but it would be nice to have further tests
18:49:26 <wobo> question: these daily builds will not go to the mirrors, hopefully?
18:49:33 <misc> nope
18:50:02 <ennael> so I need piece of design to be integrated
18:50:12 <ennael> installer left background
18:50:13 <misc> ( unless there is rabid hord of tester wanting to dowload each up to the point we saturate the 1g link )
18:50:31 <ennael> and backgrounds as it still alpha2 printed
18:50:38 <wobo> misc: thx
18:50:50 <rda> ennael: yep, alex is working on it and I hope to see that land on Wednesday
18:51:03 <ennael> great
18:51:12 <ennael> including plymouth theme ?
18:51:24 <rda> #need left background for installer (beta label instead of alpha)
18:51:39 <ennael> and desktop background
18:51:40 <rda> hope so. plymouth is in TeaAge's hands
18:51:50 <rda> desktop backgrounds is more distributed in the artwork team
18:51:57 <ennael> we still have mine, the grey fantastic one :)
18:52:04 <ennael> rda: but no generic one
18:52:11 <ennael> would be nice to have mageia one
18:52:11 <rda> which artwork team would greatly benefit from a packager or too to help/guide/integrate the stuff
18:52:34 <rda> ennael: I'd need to have a recent test iso to check where it belongs
18:52:40 <rda> (if that's possible)
18:52:48 <ennael> sure
18:52:56 <ennael> will do tomorrow
18:53:01 <rda> cool, thx
18:53:22 <ennael> and I guess we need a mail to recall version freeze
18:53:45 <rda> ah yes. when is it expected already?
18:54:02 <rda> April, 20th
18:54:10 <rda> http://mageia.org/wiki/doku.php?id=iso_1_specifications#expected_milestones
18:54:21 <rda> so two weeks after beta1
18:54:30 <rda> and one week before beta1
18:54:33 <rda> beta2!
18:54:41 <ennael> yep
18:54:52 <ennael> btw would be nice also tio start thinking about secteam
18:54:54 <ennael> wdyt ?
18:55:35 <rda> yes
18:55:43 <misc> well, we need to find someone in the packaging team for that
18:55:58 <ennael> I guess stew can give a hand
18:56:01 <coincoin> we still have time for secteam no? we talked about it in the first QA meeting. I think we will need it arround rc, not before
18:56:05 <ennael> as he knows this job well
18:56:07 <coincoin> :)
18:56:24 <ennael> and he proposed help on that
18:56:32 <misc> ennael: well, we may have less ressources than what he had at mandriva, like no separate build system, etc :/
18:56:48 <ennael> yep that's why it's important to speak about it now
18:56:56 <misc> so this may reuires a different organisation too to scale better
18:57:07 <misc> but yes, that's important
18:57:19 <ennael> yep
18:57:29 <misc> ennael: for next packager meeting ?
18:57:42 <ennael> #action start working on secteam - see next packager meeting
18:58:03 <ennael> that's all for me on beta2
18:58:07 <ennael> beta1
18:58:55 <rda> ok. I hope to have time to update the home & download pages for the release
18:59:07 <rda> (and that's about it for me)
18:59:39 <rda> next?
18:59:49 <misc> yup
19:00:19 <rda> #topic nonfree firmware/drivers
19:00:28 <misc> mhh, it was on the agenda ?
19:00:37 <rda> yep
19:00:40 <rda> in open questions
19:00:46 <rda> http://mageia.org/wiki/doku.php?id=meeting:council_notes_2011_03_28#open_questions
19:01:01 <rda> so we had this ... lengthy discussion on mageia-dev
19:01:14 <rda> to frame the point here, I would say we need to distinguish two things:
19:01:16 <misc> didn't you wanted to have the meeting less than 1 hour ?
19:01:27 <rda> well, that's a wish, nothing more. :)
19:01:51 <misc> and well, if this is discussed on the ml, is this useful to discuss this here ?
19:01:55 <rda> 1) the policy for sw inclusion in core and nonfree. if we keep it as it is, we should cleanup core from non-free stuff and move these into nonfree media.
19:01:59 <rda> misc: yes, to decide.
19:02:18 <rda> 2) what we're going to put on ISOs (equivalent to One, Free, etc.)
19:02:20 <misc> rda: and decide how ?
19:02:53 <misc> because if we weren't able to decide in a thread ( that I didn't read yet ), I doubt we could now :/
19:02:57 <rda> misc: if there's a consensus during the meeting for the available people, shall we use that as a hint/vote? or should we hold a specific epoll instance for each?
19:03:10 <misc> rda: that's the question, I have no answer
19:03:20 <rda> well, then, all the open questions are toast for tonight and we can all go to sleep
19:03:47 <tmb> for core, it should be cleaned.
19:03:49 <rda> if the council is not able to decide on this, I'm not sure who can
19:03:58 <rda> tmb: that's my pov too.
19:04:14 <tmb> for isos, that's debatable
19:04:22 <Anssi> seems reasonable for core
19:04:35 <ennael> the point on isos is I cannot hardly add more stuff in it anyway
19:04:54 <ennael> while texlive cleaning is not done
19:04:56 <tmb> if we go the mdv way, dvd stayy without firmwares, and anyone needing firmwares should install using live isos
19:04:58 <Anssi> indeed.. I guess one big issue is that e.g. radeon free driver requires firmware which is not OSI/FSF free, plus many wired NICs, preventing using internet
19:05:12 <rda> yeah, but on ISOs then, the point would be to: provide an easy install ISO with nonfree stuff in it (equivalent to One), and provide at least one 100% Free ISO (equivalent to Free)
19:05:45 <shikamaru> FWIW debian provides a tar archive that can be used during install to access network
19:05:46 <wobo> or, as I suggested, a dvd plus a small driver cd
19:05:59 <rda> I'm not sure this is a big usability plus.
19:06:13 <MichaelSOG> i like the motion of wobo
19:06:21 <misc> personnaly, given my current opinion and given that I didn't read the thread, i do not think I can participate to the discussion as a packager representant ( as i didn't read anything of it, or just 10 mails )
19:06:23 <shikamaru> not necessarily a CD, just put the firmwares on some usb stick
19:06:24 <coincoin> with no "nonfree" on ISO, no wifi on most chipset (so hard to go on the Internet to add media after)
19:06:41 <rda> why handle two media when we can ship a single one?
19:06:50 <rda> I mean physical media (ISO or USB)
19:06:52 <ennael> ?
19:06:58 <Anssi> I agree with rda
19:07:16 <wobo> shikamaru: yes
19:07:18 <ennael> did you read my previous comment about room left on isos ?
19:07:41 <rda> ennael: yes, but can't you make One-like LiveCD ?
19:07:41 <coincoin> perhaps we can remove xmoto to have a few more free space on ISO :)
19:07:45 <misc> ennael: you try to add technical and useful information, it will not work :p
19:08:09 <shikamaru> rda: I’m not talking about media, just a tar archive
19:08:12 <ennael> rda: njot my jo I do not know draklive
19:08:22 <shikamaru> even on a fat formatted stick you could extract it
19:08:38 <rda> shikamaru: ok, but still, you have to manipulate two things to install your distribution
19:08:41 <shikamaru> the same way you can use a stick to save package selection
19:08:53 <tmb> rda: if we add firmwares on the "free" iso, we need to adapt the installer to ask people if they want nonfree stuff installed...
19:09:12 <rda> why add to the free iso and not make a distinct iso then?
19:09:16 <shikamaru> like in XFdrake ?
19:09:27 <ennael> rda: more isos more QA
19:09:39 <rda> sure but then what? only 100% core exclusive ISOs?
19:09:45 <rda> that won't be practicable
19:09:49 <ennael> and for now we did not have live cds
19:09:57 <Anssi> tmb: what about the distinction between firmware and software... I mean, many people want non-free firmware (for free radeon driver), but not non-free driver (fglrx)
19:10:01 <rda> yes, but the point is to decide where we want to go.
19:10:20 <wobo> exactly that was my point
19:10:51 <rda> ok. then. just to settle things.
19:10:55 <tmb> Anssi: well the installer already asks for ati/nvidia drivers..
19:11:04 <rda> do we agree we need to cleanup core by moving all nonfree parts into nonfree ?
19:11:10 <ennael> rda: what about poll ?
19:11:21 <Anssi> tmb: ah, I haven't seen that
19:11:31 <rda> ennael: no feedback from marcom about that and had no time to set it up either for this round.
19:11:32 <ennael> about what people really use in isos
19:11:45 <ennael> well then we have to handle it
19:11:46 <rda> but we can set this poll up for just after beta1 release
19:11:53 <misc> well, a poll do not say much , as we already said on -discuss for tux99
19:11:59 <ennael> it's hard to take decision without users
19:12:04 <rda> misc: won't work the same way
19:12:12 <ennael> misc: it's not about which isos
19:12:12 <misc> ennael: maybe you can ask to nrk.m for the poll ?
19:12:13 <rda> but even before a poll, we could make a proposal. It's not that hard.
19:12:18 <ennael> rather functionnalities and preferences
19:12:38 <ennael> we make isos for users not just because we like to make isos
19:12:39 <ennael> imho
19:12:55 <rda> ok. can we settle this down a bit to a few things?
19:13:12 <ennael> but I agreesome cleaning is needed in core packages
19:13:17 <rda> about the core/nonfree policy. do we agree to keep it clean and strict? (ie, moving non free firmware/drivers to nonfree)
19:13:35 <rda> that's a council decision, here, to take. at least to see if we can reach it by a clear consensus.
19:13:47 <tmb> +1 for clean/strict
19:14:00 <rda> +1 for clean/strict
19:14:07 <ennael> yep
19:14:15 <Anssi> (just to bring it up, pterjan thinks BSD without source code is free enough)
19:14:35 <misc> before asking to council anything, do we have a list of people who are in council ?
19:14:50 <misc> because so far, I have ennael, me, rda and boklm, as elected representant
19:14:57 <rda> misc: web page: http://mageia.org/wiki/doku.php?id=org:council
19:15:14 <rda> + wobo and tmb (as part of the board)
19:15:21 <rda> and dams
19:15:24 <coincoin> :)
19:15:25 <rda> coincoin: :-*
19:15:29 <coincoin> rda: :-*
19:15:36 <coincoin> misc: I don't love you anymore
19:15:40 <ennael> we spoke about founders also for first council if I remember well
19:16:09 <rda> yep, we can too. at least as long as the first council is not big enough
19:16:50 <ennael> but this needs to be fixed once for all
19:16:55 <misc> ok, I will update the ldap group, and as I said, I cannot vote as a packager representant cause i didn't asked to packager ( neither read the thread )
19:17:00 <rda> ennael: what needs to?
19:17:35 <rda> misc: but you can as a board member
19:18:03 <misc> rda: well, the whole point of vote is counting :/
19:18:31 <misc> so while I think we all agree to clean core
19:18:48 <misc> the problem will arise again later
19:18:54 <rda> that is? why?
19:19:15 <misc> well, how do we count people with multiple voice
19:19:45 <rda> well, then move this to board only (won't change much given the state of the council)
19:20:07 <rda> ok, I guess we're all lost here... we're mixing several things at once.
19:21:05 <rda> ok, let's move this topic to a later meeting then. or somewhere else. won't happen here this evening.
19:21:07 <wobo> ppl with multiple voice: 1. as a board member = his own voice. as a rep = the voice of his team, not necessarily his own opinion.
19:22:05 <ennael> okok
19:22:30 <ennael> what about council = 1 representative / team + board + founders
19:22:38 <ennael> 1 guy cannot have 2 voice
19:22:55 <ennael> ex: misc will be there as packager representative and I'm from board
19:23:00 <ennael> even if I'm in packager team
19:23:04 <ennael> is that ok ?
19:23:05 <rda> and what about the fact that current council members are almost all on the board?
19:23:24 <ennael> we should have 2representatives / team
19:23:28 <rda> ?
19:23:37 <ennael> it was written in wiki
19:23:40 <rda> no.
19:23:47 <rda> 1 representative + 1 leader + 1 deputy leader.
19:24:04 <ennael> that's same
19:24:11 <rda> not quite but well...
19:24:12 <ennael> meaning if board member is inside
19:24:14 <wobo> where first and second can be the same
19:24:19 <ennael> then he cannot represent in council
19:24:41 <rda> we're already having a hard time setting up teams and representatives for these.
19:24:57 <ennael> ok I will write a mail after meeting trying to make a proposal
19:24:58 <rda> so with this rule, only sur-populated teams can afford someone on council
19:25:07 <ennael> then all teams will agree or propose other names
19:25:10 <ennael> is that ok ?
19:25:24 <rda> ...
19:25:45 <rda> ok, so all other topics for this evening are for the next meeting as well.
19:25:51 <wobo> meaning that i18n has to find somebody else as rep because I'm on the board, right?
19:25:58 <ennael> wobo: yep
19:26:05 <ennael> wobo: olivier for example
19:26:11 <wobo> yes
19:28:33 <ennael> ok so we need to clarify this quickly
19:28:41 <ennael> I propose a deadline for thursday
19:28:59 <ennael> on thursday we will have definitive list
19:29:05 <misc> the 31 mars ?
19:29:21 <ennael> yep
19:29:42 <wobo> Is that Thursday 24:00 UTC?
19:29:44 <misc> that seems agressively optimistic
19:29:51 <ennael> misc: we need to move on
19:30:01 <misc> ennael: sure
19:30:13 <ennael> we have other things to do than decide a list of people :)
19:30:29 <misc> yes, like choosing between condorcet and regular voting
19:30:29 <rda> indeed
19:30:38 <ennael> ok
19:30:52 <ennael> I guess we do not need vote for core cleaning
19:30:54 <ennael> do we ,
19:30:55 <ennael> ?
19:31:10 <tmb> nope
19:31:13 <misc> well, did someone read the thread, did a consensus arise ?
19:31:18 <coincoin> I think no
19:31:23 <ennael> not for now
19:31:26 <misc> for core cleaning ?
19:31:31 <ennael> yes
19:31:37 <ennael> for core cleaning there ie
19:31:39 <ennael> s
19:31:45 <ennael> it's rather for isos content
19:31:58 <misc> yup, so let's at least act the stuff where there is a consensus
19:32:03 <ennael> yes
19:32:14 <ennael> also one point
19:32:23 <ennael> as we were speaking with rda
19:32:40 <ennael> we have now isos à la Free and One since ages now
19:33:01 <ennael> we may need to check if it's exactly what people need
19:33:14 <ennael> because we decided it at one time
19:33:18 <wobo> If we put non-free stuff on the DVDs we don'Ät neet to clean core. It's only needed if we make a difference in distribution media as well.
19:33:43 <ennael> wobo: if we put non free stuff in DVD we will keep non-free repo
19:33:46 <ennael> apart
19:33:49 <misc> ennael: what we could do is to gather requirement and ressources
19:33:59 <misc> ie, how much iso can we afford
19:34:15 <misc> what are the media we need to keep, their cost in term of QA, etc
19:34:25 <ennael> yep
19:34:33 <ennael> it's also important indeed
19:34:46 <ennael> no way to propose zillions of isos if we cannot test it
19:34:53 <ennael> coincoin: I guess you agree on this :)
19:35:01 <coincoin> if we can do automatic test as we planed, it's not a big task
19:35:09 <ennael> "if"
19:35:10 <ennael> :)
19:35:21 <ennael> but I can hardly see it before first stable release
19:35:27 <coincoin> ennael: yes I agree but I think that "most important" is as you said, fit with what ppl want and adapt work on it
19:35:37 <coincoin> yes, hard for me too :)
19:36:00 <ennael> so we need a view on people needs when using isos and on internal ressources
19:36:03 <ennael> is that ok ?
19:36:07 <coincoin> ok for me
19:36:13 <wobo> 2 views will emerge:
19:36:18 <wobo> 1. functionality: DVD must carry all firmware to make all hardware function (no non-free graphics or such but firmware for raid, wifi, etc.)
19:36:20 <wobo> 2. ideology: DVD only free software, everything else via internet or important hardware firmware on a iso for usb keys
19:36:55 <ennael> wobo: well maybe but at least we have clear view
19:37:09 <ennael> also we need to have people constraint about iso size
19:37:14 <ennael> network install...
19:37:26 <ennael> it's not only about isos content
19:37:27 <wobo> reading the ML thread we will not get a clear view, I fear :(
19:37:28 <ennael> I guess
19:37:31 <misc> people constraint about hardware ( no cdrom )
19:37:37 <ennael> also yes
19:37:47 <ennael> wobo: I hope we will not have only ML people
19:37:53 <ennael> at least those who speak loudly :)
19:38:09 <wobo> hmm...
19:38:34 <tmb> misc: ww just need to make sure our isos work on usb sticks
19:38:46 <wobo> yes
19:39:10 <misc> tmb: that's something that need to be checked, so there is a QA cost ( not a big one compared to other, but still need to be counted )
19:39:25 <misc> there is also the issue of localisation ( the big issue of One )
19:39:31 <tmb> true
19:40:43 <misc> #info need a view on avaliable ressources for creating iso ( ie, how much can we do )
19:41:08 <misc> #info need a view on what is needed ( live/non-live, size, medium, languages, content, etc )
19:42:22 <ennael> ok
19:42:34 <ennael> rda: can we work on poll together ?
19:42:47 <ennael> then we propose a list of questions on council list
19:42:57 <ennael> and see if it's exhaustive enough before publishing
19:43:28 <misc> btw, speaking of council list, they are setup but not tested yet
19:43:33 <rda> ennael: we can, but what would be the deadline?
19:43:38 <misc> ( or it was board )
19:44:05 <misc> ( ok, it was board who is setup minus test + bug fixes )
19:44:05 <ennael> rda: friday ?
19:44:15 <ennael> misc: needs test ?
19:44:50 <misc> ennael: well, I can do it, but I have some feare regading sympa, will explain later ( as you are a sympa expert )
19:44:58 <ennael> ahah
19:44:59 <ennael> ok
19:45:20 <misc> I wil create a list for council too, now that i have people to place inside
19:45:24 <ennael> #action rda and ennael will propose list of questions for users poll before end of week
19:46:19 <wobo> misc: after thursday (because of new team reps)
19:46:39 <misc> wobo: the list is synced with ldap group
19:46:46 <wobo> ok
19:47:23 <ennael> ok anything else to add on that topic ?
19:48:58 <misc> not for me
19:49:08 * wobo opens a second bottle of Bordeaux...
19:49:12 <wobo> ok
19:49:13 <ennael> han
19:49:36 <ennael> misc: next one ?
19:49:36 <tmb> not for me
19:49:43 <misc> #info consensus is for cleaning core
19:50:03 <ennael> oh
19:50:06 <misc> #info no consensus on isos content however
19:50:26 <ennael> who is taking care of firmwares ?
19:50:28 <misc> ennael: wasn't it what we said 20 minutes ago ?
19:50:45 <ennael> as it seems the one to be cleant quickly
19:51:08 <tmb> I will fix the firmware
19:51:13 <ennael> ok thanks
19:51:21 <misc> #action tmb fix the firmware
19:51:26 <misc> #undo
19:51:26 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Action object at 0xb74ec4ec>
19:51:42 <misc> #action tmb fix the location of concerned firmwares
19:52:07 <misc> well, next topic is arm
19:52:18 <ennael> rtp: wake up!
19:52:23 <misc> #topic arm
19:52:43 <misc> I see there is lots of question so I think that before we consider anything, we should answer them
19:52:55 <misc> and so I would gather the feedback of concerned team :
19:52:57 <misc> - packagers
19:53:00 <misc> - sysadmins
19:53:05 <misc> - QA
19:53:19 <misc> anybody see others involved team ?
19:53:36 <coincoin> marcom?
19:53:46 <misc> coincoin: mhh, why ?
19:54:21 <coincoin> for the marketing part of the product (not the communication part)
19:54:29 <tmb> I say marcom only if we actually do arm
19:54:29 <coincoin> perhaps I'm wrong :)
19:55:13 <misc> on one hand, it would make sens, at least, for the first question "what will be the use of it?"
19:55:18 <tmb> I'd like to provide arm, but do we have resources...
19:55:32 <ennael> it's a shame rtp is not around
19:55:47 <coincoin> :)
19:55:47 <ennael> he has been working on it these last months
19:55:48 <misc> well, I guess we can dispatch to the team and get answer for next week ?
19:55:58 <ennael> and still working on it now
19:56:09 <tmb> misc: "because we can..." or ... "everyone else is doing it..." :)
19:56:23 <ennael> he told us he could have something read for final one even before
19:56:38 <ennael> and proposed a build like we did in mdv when started with x86_64
19:56:39 <misc> #action boklm ennael dispatch questions to respective team
19:56:51 <misc> coincoin: you take care of asking to QA ?
19:56:57 <ennael> okok
19:57:00 <misc> rda: and you to marketing ?
19:57:01 <coincoin> misc: sure
19:57:11 <rda> misc: yep
19:57:13 <misc> #action coincoin dispatch questions to QA team
19:57:20 <misc> #action rda dispatch to marketing
19:57:30 <misc> #info answer for next meeting, if possible
19:57:41 <misc> ok so next topic ?
19:59:29 <misc> #topic Budget management
20:00:53 <rda> ok, so.
20:01:08 <coincoin> so, as you can see http://www.mageia.org/en/about/reports/2010/ and http://www.mageia.org/en/about/reports/2011/ (annual reports are now available - 2011 will be soon over)
20:01:23 <misc> coincoin: didn't we promise monthly report ?
20:01:24 <coincoin> we have money, so we have to spend it!
20:01:50 <misc> ( during fosdem )
20:02:17 <coincoin> misc: we promised monthly updates on donate page, for full monthly report it's now avalable on reports/2011 as it will be updated each day/week/month depending on money spent
20:02:19 <wobo> coincoin: shh: makes me remember you about mail to me :)
20:02:51 <coincoin> wobo: I don't see O:-)
20:02:52 * coincoin hides
20:03:15 <ennael> maybe we could post a short blog post on it
20:03:16 <wobo> coincoin: I see you!
20:03:19 <misc> coincoin: how do we handle a error in report ?
20:03:21 <coincoin> as misc highlighted in the past, we need to have public discussion about money
20:03:23 <ennael> it's important to inform people
20:03:32 <wobo> yes
20:03:40 <coincoin> ennael: yes, it's planned I jsut need one more day to finalize the 2011 report
20:03:52 <ennael> ok fine
20:04:15 <coincoin> misc: I gave an email address at the bottom on the page (I mailed sysadmin@ to ask for an alias, I didn't tried it yet)
20:04:33 <misc> coincoin: it should worked, it worked for me at last ( secretary@ )
20:04:46 <misc> ( maybe I also forgot to tell to people, not sure )
20:04:59 <coincoin> the aim of the report is to start spending money and call new donations to buy fiona, gnadi parts, nodes (in the first time)
20:05:12 <coincoin> misc: great, thank you
20:05:13 <ennael> #info financial monthly report will be ok in 1 or 2 days - a blog post will explain all bout it
20:05:20 <misc> well, I think that we do rather need faster harddrive than build node
20:05:42 <misc> ( especially now we do have xymon report )
20:05:45 <coincoin> misc: faster HDD will mean SAS HDD so... no the same cost (as we need SAS controller)
20:06:05 <rda> well, that's where the discussion comes in. we should allot for some teams a budget in advance.
20:06:14 <misc> coincoin: yes but currently, the cpu and memory are far from being used on ecosse and jonund
20:06:33 <rda> up for each team to discuss, decide and send it to the treasurer to check/apply within allotted budget.
20:07:05 <rda> (if a team goes beyond budget, that's the board to review/manage, but as long as a team expenses are in the budget, it's up to the team to decide how to allocate it)
20:07:07 <coincoin> misc: yes, but new nodes will prevent having BS freezed by a new kernel/libreoffice/kde during release time
20:07:25 <misc> coincoin: we can do compilation of 2 packages on the same node
20:07:26 <coincoin> but I can see the cost of having SAS and add it to the forecast
20:07:50 <tmb> coincoin: well for bs, one new disk per node will allow for one more iurt per node as the io load is hared...
20:07:56 <tmb> *shared...
20:08:16 <ennael> would be nice indeed
20:08:31 <coincoin> tmb: yep, good point, you can come to play again next week :)
20:08:41 <misc> http://xymon.mageia.org/xymon-cgi/hobbit-hostgraphs.sh?start-mon=3&start-day=28&start-yr=2011&end-mon=3&end-day=28&end-yr=2011&hostname=jonund.mageia.org&testname=la1&testname=memory&DoReport=Generate+Report
20:09:07 <rda> hey! :) the point of the meeting is not discussing the details of sysadmin needed expenses,
20:09:23 <rda> but to decide whether or not to allocate a budget to, among others, sysadmin (and which others)
20:09:24 <coincoin> but we at least need 1 new node to have a spare server as we onnly have "ecosse" and "johnund" without spare in case of emergency
20:09:26 <misc> ok so let's discuss sysadmin expenses on sysadmin ml first
20:09:42 <misc> and for the budget allocation, this is IMHO a board duty
20:09:54 <rda> indeed, as said in the introductory text
20:10:00 <misc> while this is likely the same people , we decided to wait on ml to discuss this
20:10:04 <coincoin> but the point now is to see how to discuss spending money as buying new gandi part as rda explained in a mail some weeks ago
20:10:41 <rda> misc: well, on ml or on the meeting - will be about the same and we can at least push the discussion some more and gather advice if any
20:11:42 <coincoin> meeting can help making things faster (for example, Gandi parts are waiting answers since 3 weeks)
20:11:47 <tmb> since meeting is logged and public, we can decide now
20:11:54 <coincoin> I agree
20:12:06 <misc> personnaly, I would be against allocating a budget before, as this would incitate to spend it
20:12:24 <rda> that's the point
20:12:44 <rda> it's up to the team to be responsible and come up with what would be best for the project, in her own scope.
20:13:07 <tmb> well atleast the Gandi parts could (should?) be decided now
20:13:20 <rda> and it's different to think "ok, I'd need that but I don't know how much I can spend, because I have to ask to board" and "ok, I'd need that and this, and I know have X to spend this year, let's see how I can do it"
20:13:45 <coincoin> misc: my forecast is just to have an idea of the 2011 needs, not the true about life :)
20:13:51 <rda> what we can't afford is to have money sleeping on the account and unfilled needs in the project
20:13:57 <misc> rda: why ?
20:14:16 <rda> misc: because that's a waste. people didn't gave money to the project so that it's not put to use.
20:14:39 <misc> rda: well, ennael spoke of keeping money in case of problem ( like LO decinding to not host us for free anymore )
20:14:40 <rda> and teams ought to be responsible enough to manage a small budget decidated to each. and ask for more if needed, to the board.
20:14:43 <ennael> do we have a list of "emergencies" ?
20:14:56 <rda> misc: that's not contradictory. that's called provisioning.
20:15:01 <coincoin> ennael: I called it "reserve fund"
20:15:10 <coincoin> in the forecast
20:15:17 <ennael> I'm not speaking about this
20:15:30 <ennael> a list of pending demands like gandi one
20:15:41 <coincoin> ennael: yep, my forecast :p
20:16:12 <ennael> needs to be validated by teams in term of emergency
20:16:25 <coincoin> emergencies are: gandi, fiona, hw for spare
20:16:33 <ennael> fiona ?
20:16:37 <coincoin> backup server
20:16:49 <ennael> what is global cost ?
20:16:53 <ennael> for all 3
20:17:22 <misc> if this is a emergency for sysadmin, maybe we could see with sysadmin team ?
20:17:54 <ennael> well do we have backups for now ?
20:17:54 <coincoin> rhaaa nobody reads my forecast? costs are on it :p
20:18:06 <misc> ennael: we don't
20:18:17 <coincoin> ennael: 4679,88 �
20:18:26 <misc> ennael: well, we do sync svn on alamut, and sync mirrors all over, and coincoin set up stuff for mysql db
20:18:55 <rda> well, the point was more about the principle of providing a budget (be it small) to such teams and let each decide (and move forward on this topic)
20:19:16 * misc already expressed his opinion on the subject
20:19:37 <rda> that is, no budget, right?
20:20:03 <misc> well, I am quite conservative when spending money, so maybe I am too conservative, but yes
20:20:09 <coincoin> without spending the budget, people won't make donation as in the past...
20:20:10 <misc> at least for the start
20:20:29 <ennael> what about other board members ?
20:21:24 <rda> ok, my opinion is that we can't afford to micromanage this completely, and that by showing we do micromanage this, we don't help teams to grow. and that designing a budget (and evaluating its use afterwise) is a sane and diligent practice for the project.
20:21:42 <misc> rda: well, did we first asked to team their opinion on that ?
20:22:25 <rda> this point was raised because of a need, in sysadmin. and because that need is likely to happen in marcom as well.
20:22:27 <coincoin> I agree with rda and I will add that we can't ask people to donate if they don't see that we spend money because we need it to help the project to grow
20:22:54 <rda> so although I didn't ask teams about that (but we can surely do it), I believe this is rather the kind of policy that can be pushed by the board (who is in charge of the money collected)
20:23:09 <misc> rda: well, can you point me to the discussion about that on sysadmin list and the people who said "we need a budget, we would prefer than asking to the board" ?
20:23:20 <rda> (and if the board can't even push some kind of directions for the project without asking first the whole world, the whole point of the board would be moot)
20:23:47 <rda> misc: that was pending the board list creation, since the question had been asked already directly (in private, indeed)
20:24:10 <wobo> IMHO rda's proposal about budgets makes sense, as coincoin says. We also have to trust people in a way to act responsible with the community's money.
20:24:13 <tmb> well, I think we need to decide a minimal "safe limit" for emergencies such as hosting and hw breakage first, then the rest could be split up in budgets
20:24:18 <misc> rda: privately....
20:24:48 <wobo> tmb: yes
20:25:00 <rda> misc: yeah, and we waited to discuss it again in public as you rightly expressed the need for a list that wans't there.
20:25:11 <rda> misc: so go ahead and manage this topic for the next time, please.
20:25:49 <rda> I'd rather stop the meeting now, I guess the next points won't go far either tonight.
20:26:13 <tmb> and budgets are then % of actual "extra money available" upto "yearly limit"
20:27:00 <misc> rda: ok
20:27:12 <coincoin> tmb: yes so we will keep a "reserve fund" for emergencies
20:27:20 <tmb> I'd say to do the decision aboun Gandi now...
20:27:55 <ennael> yep
20:28:21 <tmb> rda: can you give the suggestion here now, so it gets logged
20:29:33 <rda> tmb: the suggestion?
20:30:03 <tmb> rda: suggestion for Gandi upgrade...
20:30:17 <misc> for gandi, I have a question. Since we have lots of ressources on alamut, what is the point of keeping gandi vm, if we have to pay to have the same than we have on alamut ?
20:30:39 <rda> coincoin: do you have the rates grid?
20:30:43 <rda> wait, looking in mym ail
20:31:49 <rda> quoting:
20:31:56 <coincoin> misc: the idea (as decided as the beginning was to have an external hosting for www and al communication website (blog:planet...) not to have all at the same place
20:32:01 <rda> "A default part having only 256MB of RAM, our blogs setup swaps and is slow. We would like to add 3 RAM parts to improve on that."
20:32:01 <rda> "Note that Gandi.net provided us the most interesting price matrix for additional services to purchases; so one part of RAM (256MB) will be
20:32:02 <rda> 2,66 € a month for us, instead of 4 €."
20:32:12 <misc> coincoin: then how about hosting on rabbit ?
20:32:13 <coincoin> misc: gandi is VM so no hardware to manage
20:32:27 <coincoin> rabbit is our HW, not a VM
20:32:32 <misc> coincoin: and we do already manage alamut and rabbit
20:32:44 <misc> so the cost of managing is already counted
20:32:45 <ennael> misc: if we use it more intensively it may cause pb
20:32:57 <coincoin> and we have to remember that Gandi offer 2 parts from the beginning of Mageia
20:33:08 <misc> ennael: more intensively than hosting daily build of iso ?
20:33:25 <ennael> rtp was also thinking about packages rebuild
20:33:48 <coincoin> misc: the VM of Gandi will only cost 170�/year (nothing compared to a physical server where we need to have spare and other issues)
20:33:50 <ennael> which is not a bad idea
20:34:27 <misc> coincoin: so that's around like the travel from one packager to and back to FOSDEM, that's not much, but still
20:34:33 <tmb> and rabbit could also host torrents
20:34:38 <ennael> yep
20:35:16 * ennael is ok for gandi VM
20:35:18 <coincoin> yep
20:35:26 * coincoin is ok too but I'm not neutral :p
20:35:28 <misc> well so basically, alamut is bad because it is in marseille, and rabiit is unreliable ?
20:36:00 <rda> see it in the other way: we're experimenting several ways of hosting/delivering stuff.
20:36:51 <tmb> how easy is it to stop using a hosting if decided ?
20:37:00 <coincoin> MDV experience shown us that having all things hosted on the same place or to things on the same HW was very bad :)
20:37:36 <coincoin> tmb: just changing DNS and copying files/dump on the new host if it was a VM
20:37:46 <coincoin> so max 1 day?
20:37:53 <misc> coincoin: well, for the moment, krampouezh was down because gandi had a problem the 18/10, and it was also down when a upgrade stopped the server just before the meeting
20:38:29 <tmb> coincoin: I was thinking of "how long so we have to pay" after we stop using it...
20:39:15 <tmb> and if gandi is decided to be too unstable, we need to reconsider...
20:39:32 <ennael> looks so there is monthly or yearly payment
20:39:58 <coincoin> http://www.gandi.net/hosting/proposal/price/
20:40:18 <coincoin> "The minimal billing period (excluding GandiFlex) is 1 day."
20:40:19 <misc> I am also concerned that we cannot upgrade gandi vm as we want ( ie, they are still running 2010.0 for now :/ )
20:40:46 <coincoin> misc: Gandi is waiting for us to provide a final Mageia to propose it ASAP :)
20:41:40 <misc> coincoin: and so, they agree that they will devote people so we can upgrade our server as we see fit ?
20:41:44 <coincoin> http://www.gandi.net/hosting/proposal/price/   FYI we are "E Rates"
20:42:14 <rda> misc: I'm not sure any provider of this kind does so.
20:42:33 <misc> rda: well, so the problem will still exist in the futur
20:42:46 <rda> well, yes, of course.
20:42:50 <misc> ( i do not blame them, they do not have infinite ressources )
20:42:56 <tmb> I'd go for Gandi VM upgrade now, and after Mageia 1 is out and all our infra is put in place, re-eval the issue...
20:43:10 <ennael> sounds sensible
20:43:14 <coincoin> yep
20:43:18 <misc> so monthly paiement ?
20:43:24 <ennael> yep
20:43:41 <coincoin> yep, as writing in my forecast :p
20:43:48 <coincoin> s/ing/en/
20:44:06 <misc> coincoin: face it, nobody have read it
20:44:12 <coincoin> :(
20:44:17 <coincoin> :)
20:45:35 <ennael> ok everybody ok on it ?
20:45:43 <misc> #info upgrade gandi vm ( monthly paiment as said by tresurer ), reevaluate issues ( see log ) once mageia 1 is out
20:45:46 <misc> mhh
20:45:48 <misc> #undo
20:45:48 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Info object at 0x82a6a6c>
20:45:53 <misc> #info upgrade gandi vm ( monthly paiment as said by treasurer ), reevaluate issues ( see log ) once mageia 1 is out
20:46:06 <coincoin> thank, I prefer with a "a" :)
20:47:44 <misc> ok so next topic ?
20:48:07 <ennael> can we stop here for tonight ?
20:48:14 <ennael> already 22h45
20:48:30 <misc> we could
20:48:31 <rda> yep, let's stop now
20:48:38 <ennael> I guess we can speak about 2 last topics by mail as soon ML is up
20:48:42 <coincoin> or we stop for 1h and start again after? :p
20:48:44 * coincoin hides
20:48:48 <misc> do we schedule another meeting in the week, cause I think the other issue of rda are important too
20:48:56 <misc> ?
20:48:58 <ennael> if people can attend
20:48:59 <rda> won't have time this week
20:49:05 <misc> so on ml
20:49:21 <coincoin> I only can tomorrow
20:49:29 <ennael> ok by ML
20:49:34 <ennael> from thursday then
20:49:50 <rda> from thursday?
20:50:03 <ennael> when council list is finalized
20:50:17 <rda> ah, ok. but I won't be available before the next monday then.
20:50:19 <ennael> unless we can setup it before with existing members on wiki page
20:50:41 <ennael> rda: I will take my sword and fight for your topics :)
20:50:45 <misc> the list was done
20:50:49 <misc> i just didn't test
20:50:54 <ennael> ok
20:50:55 <rda> ennael: :D
20:51:09 <misc> ( which basically mean this do not work as sympa is a spawn of hell )
20:51:20 <misc> I will work on it tonight
20:52:32 <misc> #info others topic to be discussed on ml
20:52:35 <misc> #endmeeting