19:39:14 <rda> #startmeeting
19:39:14 <Inigo_Montoya> Meeting started Tue Feb 22 19:39:14 2011 UTC.  The chair is rda. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:39:14 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:39:15 <rda> then
19:39:46 <rda> #chair ennael misc damsweb t_m_b wobo
19:39:46 <Inigo_Montoya> Current chairs: damsweb ennael misc rda t_m_b wobo
19:40:00 <rda> so, by what do we start?
19:40:12 <misc> by the first topic
19:40:31 <misc> " Review on Alpha1 and coming alpha2: process, priorities, bugs (anne,
19:40:31 <misc> misc, ahmad)"
19:40:48 <rda> #topic alpha1 review, alpha2 planning
19:40:59 <rda> so, let's go guys
19:41:07 <misc> ennael: ?
19:42:16 <misc> ok so ennael timeout :)
19:42:27 <misc> so let's go on the 2nd alpha
19:42:49 <misc> ie, I think we should give ourself some objectives, and try to stick to it
19:43:06 <misc> so one of the stuff that we promised was :
19:43:09 <misc> - moe isos
19:43:23 <misc> - a bittorrent server ( asked by users )
19:43:43 <misc> and I do not know what could be done for the rest
19:44:10 <misc> I do not think we are ready to promises features, or stability yet, but maybe something regarding design ?
19:44:13 <rda> well, based on reported bugs, fix them; improve/cleanup of artwork
19:44:30 <damsweb> improve upgrade from MDV
19:44:42 <rda> we should open bugs for each of these, no?
19:44:43 <misc> that's not a short term goal :)
19:45:00 <misc> ie, we will work to improves this, but we cannot measure it
19:45:31 <misc> ( unless we say "for alpha 2, you will be able to upgrade without trouble", and I do not think we are ready to promises that )
19:45:46 <misc> the same goes for design, do we decide that for alpha 2, we will have a definite enough design ?
19:45:52 <misc> or that the cleaning should be finished ?
19:46:21 <damsweb> we can improve upgrade even if it's will not be the final step. upgrade should have work from alpha1
19:46:33 <rda> I guess that for alpha, that's still a target to be reached.
19:46:43 <misc> damsweb: well, upgrade work, so how do we see it work better ?
19:47:14 <rda> shall we keep a list on the http://mageia.org/wiki/doku.php?id=iso_1_specifications page?
19:47:18 <rda> (with priorities)
19:47:21 <damsweb> misc: not working as expected (see my bugs on bugs.mageia.org)
19:47:33 <misc> rda: a list, yes, bugs would also be good
19:47:43 <rda> misc: yes, I meant, both. :)
19:47:50 <misc> damsweb: so you propose that for alpha 2, we have 0 bugs left on upgrade ?
19:48:08 <damsweb> misc: where did I wrote it?
19:48:22 <misc> damsweb: well, nowhere, but then this is not a goal for alpha 2 :)
19:49:05 <damsweb> for me, it is! I've got enough feedback in QA about upgrade to know that this kind of feature must be fixed before beta ;-)
19:49:26 <misc> damsweb: well, the goal for alpha 2 is what exactly ?
19:50:14 <rda> artwork/design improvements - goal would be to totally replace the whole thing with almost final graphics
19:50:30 <rda> (maybe leaving some room for  improvements for the installer/bootloader)
19:50:42 <ennael> sorry
19:50:46 <misc> rda: ok so for alpha 2, having alost final design ?
19:50:46 <rda> website, release and communication improvements as well
19:50:51 <damsweb> +1
19:51:06 <rda> misc: yep
19:51:46 <misc> #info alpha2 should have final design
19:52:09 <rda> well, design freeze is for may, but still, we ought to have near final stuff here already
19:52:12 <ennael> all icons included ?
19:52:27 <rda> we can try at least
19:53:06 <ennael> will avoid bug reports on design :)
19:53:18 <rda> tsss
19:53:21 <rda> so, what else?
19:53:29 <ennael> georges !
19:53:49 <ennael> about technical process now
19:54:06 <ennael> we need to have triage team ready and active on bugzilla
19:54:20 <ennael> and we need to have regular review on critical one
19:54:34 <misc> for packages ?
19:54:59 <ennael> packages and some bugs that are just blocking
19:55:13 <ennael> as we do not expect lots of development for this first release
19:55:23 <misc> yup, but when do the review ?
19:55:26 <ennael> we should have something nearly bug free
19:55:35 <ennael> or at least clean them
19:55:52 <ennael> was thinking about a weekly report for example
19:56:05 <ennael> togive a big picture and kick maintainers
19:56:30 <ennael> we were doing this in mdv for RC releases
19:56:30 <misc> #info triage team to be active and ready for alpha 2
19:56:48 <rda> could we prepare automatic reports of such bugs? (dedicated page or count or list of these, directly accessible)
19:56:50 <misc> ennael: so someone should do it , I guess, question is "who"
19:57:25 <ennael> maybe that's triage team decision
19:57:42 <misc> ahmad78: ?
19:58:16 <blingme> do we need to try and get more focused testing?
19:58:30 <blingme> e.g. test days like adamw does for Fedora?
19:58:56 <misc> that would help yes, but that requires maybe more ressources in term of organisation
19:59:13 <blingme> but, it can generate more interest, more contribution
19:59:21 <ennael> sure
19:59:28 <ennael> but again triage team must be ready
19:59:34 <ennael> it means more bug reports
20:00:19 <blingme> it may mean fewer, if people don't test what we aren't prepared to have them test yet
20:00:36 <ennael> but for sure we should have to organize test days on development releases
20:00:51 <ennael> the point in  mdv is we had reports 3 or 4 days before the next one
20:00:57 <ennael> which is just not mangeable
20:01:02 <ennael> which is just not manageable
20:01:04 <misc> before the next what ?
20:01:05 <ahmad78> hi, sorry for being late
20:01:18 <ahmad78> triage team is now two persons, me and shikamaru
20:01:27 <ennael> misc: tests on alpha1 were done by contributer few days before alpha2
20:01:33 <misc> oh
20:02:10 <misc> so we should at least organize the test days so we give instruction to people "upgrade to cauldron"
20:02:26 <ennael> yes
20:02:36 <misc> another solution would be to ask to people to do update after installing the iso ( maybe directly in drakx )
20:02:41 <ennael> and we should test it on alpha 1 in coming days
20:03:28 <misc> so who is volunteer to manage a test day ( ie, post on relevant communication channel, propose a test scenario, and help to filter bugs ) ?
20:03:33 <ahmad78> misc: ? which iso?
20:03:47 <misc> ahmad78: the alpha , beta, etc
20:04:10 <ahmad78> misc: but how is that testing the upgrade?
20:04:34 <misc> ahmad78: nope, that's testing the rpms, testing the upgrade is a different beast
20:04:38 <ahmad78> ok
20:07:24 <misc> ok so no test days volunteer ?
20:08:30 <blingme> do we need to advertise that we need someone willing to do that?
20:09:12 <misc> well, we could try to find someone, yes
20:09:29 <misc> I can send a email for this
20:09:36 <ennael> yep
20:09:46 <rda> maybe we should then focus for the test days just after alpha 2?
20:09:51 <misc> #action misc send a email to find someone to manage test days
20:09:52 <blingme> or, is it something we should discuss on the forum?
20:10:08 * blingme is confused by misc's mail today, is forum ready or not yet?
20:10:23 <misc> blingme: not ready, but ready to be ready
20:10:29 <misc> is this more clear :) ?
20:10:53 <genomega> What is involved in testing the upgrade?
20:10:57 <misc> ( in short, it is installed, but requires last check and polish )
20:11:14 <misc> genomega: to do the upgrade, to see if everything work and report what doesn't
20:11:31 <misc> there is nothing complex, it just have to be done before we say "this is stable"
20:12:00 <misc> I think dams even gave a test procedure, meaning people just have to follow :)
20:12:35 <blingme> well, we may get more participation once the forum is up, so if there is a development and/or testing section of forum, maybe "job opening -> community test organizer"
20:12:44 <blingme> would be a good first post
20:13:43 <rda> yep
20:13:48 <misc> sot we report test days until later ?
20:13:56 <ennael> forums will help for sure
20:14:04 <ennael> they are used by "real" users
20:14:20 <ennael> and we usually find quite a lot of comments/reports on it
20:15:03 <ennael> misc: what could be the deadline for forums ?
20:24:58 <misc> ennael: I guess it can be ready for next week
20:25:00 <misc> ( but we are diverting from the planning of alpha 2 )
20:25:07 <ennael> what the date of alpha2 ?
20:25:08 <rda> March, 15th
20:25:09 <rda> #link http://mageia.org/wiki/doku.php?id=iso_1_specifications#expected_milestones
20:25:14 <ennael> it means we could have test day newt we for example
20:25:19 <ennael> as a first shot
20:25:49 <misc> well, yes, we could but who will do the job of organizing it ?
20:25:55 <rda> so that means that the forum ought to be up before next week end (next week end being March 5/6)
20:25:55 <damsweb> yep, I agree as QA is, for now, only 3 people
20:25:57 <damsweb> I can ask it on QA team
20:25:57 <ennael> I can give a hand also
20:26:07 <damsweb> 3 active members but 10 people in the team
20:26:07 <ennael> so that we can have this first try
20:26:10 <rda> well, it must be coordinated by one person in charge at least.
20:26:10 <rda> and others helping
20:26:18 <ennael> yep
20:26:19 <misc> I think we all agree
20:26:21 <damsweb> yep
20:26:22 <ennael> ahmad78: would you be ok to manage this first one ?
20:26:23 <ahmad78> ennael: first test day?
20:26:24 <ennael> yep
20:26:25 <ahmad78> no, I can deal with the bug reports, but can't organise the whole thing
20:28:10 <rda> so, should ahmad78 and damsweb ask on their respective teams about someone to take this in charge?
20:28:10 <ahmad78> shikamaru: ^
20:28:10 <ennael> damsweb seems ok to manage it globally
20:28:12 <misc> shikamaru is not here until the end of the week
20:28:15 <ennael> and ahmad78 and shikamaru can help a lot
20:28:15 <damsweb> yes I can do it
20:28:20 <ennael> misc: this is in 10 days at least
20:28:21 <ahmad78> misc: yes, he said so, I forgot
20:28:24 <misc> #info damsweb will organise the first test day
20:28:51 <misc> ennael: sure, but he cannot answer to ahmad78 query :)
20:28:57 <ennael> :)
20:28:57 <misc> ok, so next part of the planning ?
20:29:21 <rda> #info first test day would happen during March 5/6
20:29:34 <misc> ie, besides "having a bittorrent server", having more iso", "having done a test day" "having almost finall design", what is left ?
20:31:07 <ennael> mirrors
20:31:14 <misc> Nanar: ?
20:31:45 <Nanar> yup ?
20:32:16 * ennael takes the rabbit until Nanar finds more mirrors
20:32:19 <Nanar> I still have to seek more mirrors
20:32:50 <ennael> was thinking about a blog post to thank people about alpha welcoming and ask for mirrors contribution
20:32:53 <ennael> wdyt N
20:32:54 <ennael> ?
20:32:59 <Nanar> I was hopping new one come by themself
20:33:03 <Nanar> yup
20:39:51 <Nanar> I must ask on some french university mailing list
20:39:51 <ennael> ok
20:39:51 <ennael> #action ennael plans blog post about alpha1 and mirrors contribution
20:39:52 <Nanar> wee must ask to people to ask to their prefered mirror
20:39:52 <rda> if anyone has contacts in universities in russia, india, brazil/argentina, and west coast USA, that would be interesting as well
20:39:52 <Nanar> yeah, exactly
20:39:52 <ennael> we can ask blogdrake guys
20:39:52 <t_m_b> Nanar: what about mirrors.kernel.org ?
20:39:52 <Nanar> we can ask
20:39:54 <Nanar> but I think they already have a lot of things ?
20:39:54 <Nanar> well nothing deny to ask
20:39:54 <misc> well, I think people do not know they can register on the web interface, nor what it will do
20:39:54 <misc> so let's try to find 5 mirrors for 7 march ?
20:39:54 <damsweb> rda: for russia/india, I can ask old friends from my last job :-p
20:39:55 <Nanar> I have also to contact ibiblio about rsync share
20:39:55 <rda> damsweb: yes! :)
20:39:55 * ennael slaps damsweb
20:39:56 <Nanar> any mirrors can register themself
20:39:57 <rda> but maybe we can improve the site to make this more obvious.
20:39:58 <misc> #action Nanar contact ibiblio
20:39:58 <rda> Nanar: did you read my mail (not really exactly about this, but it comes to it, as for altering the design of the site)?
20:39:59 <Nanar> rda: yeah I read, planned to answer, think to a girl, then forgot to reply
20:39:59 <t_m_b> Nanar: yes, but kernel.org infra is _big_ so it can take the load, and is distributed worldwide
20:40:00 <Nanar> rda: I will reply ASAP
20:40:00 <ennael> t_m_b: would be nice indeed
20:40:00 <rda> Nanar: :) thanks
20:40:00 <ennael> t_m_b: do you have any contact ?
20:40:00 <t_m_b> ennael: nope
20:40:01 <ennael> I may have some here
20:40:01 <ennael> looks like erwan knows 2 of the admins
20:40:02 <ennael> do they already host other distros ?
20:40:02 <Nanar> yeah
20:40:02 <Nanar> a lot
20:40:02 <misc> #action ennael trick erwan into making kernel.org mirror mageia
20:40:02 <ennael> Nanar: any url ?
20:40:03 <t_m_b> ennael: http://www.kernel.org/faq/#mirror
20:40:03 <misc> http://mirrors.kernel.org/
20:40:25 <ennael> ok thanks
20:41:09 <misc> ok so next thing on the alpha 2 topic ?
20:41:29 <ennael> not for me
21:00:32 <misc> no problem
21:00:32 <misc> you didn't told anything about 2, on the other hand...
21:00:58 <misc> #action misc to complete log due to netsplit
21:01:16 <misc> #action blingme contact someone for mirror
21:01:25 <misc> #action misc do measurement for mirrors
21:01:45 <misc> so, anything else to discuss, or we can close the meeting ?
21:02:42 <damsweb> nothing more for me
21:04:06 <damsweb> ennael: marketing ? or next time ?
21:04:39 <ennael> marketing ?
21:04:40 <misc> ( there is other point on the agenda, but given the lack of vivacity of everyone involved, let's decide report this to later , I assume february took its toll )
21:04:43 <ennael> yep
21:04:45 <rda> and web apps status as well.
21:04:46 <rda> ok, let's see that next time then.
21:05:02 <rda> misc: about the items for alpha2, I will update the specs page. shall we open bugs for each one?
21:05:09 <misc> rda: yes
21:05:43 <rda> ouch
21:05:59 <blingme> what is the progress on mediawiki?
21:06:09 <blingme> or, should we discuss it some other time, or some other meeting?
21:06:33 <ennael> maybe rda can speak about it
21:06:44 <misc> if no one posted anything on ml, then I guess that no one started to do anything
21:06:57 <misc> I just took a quick look on it, and was about to work on it after forum
21:07:05 <rda> I didn't review the ml posts yet, about the wiki
21:07:40 <blingme> misc: ok, so Olivier Berger's package is as far as things are ?
21:07:58 <damsweb> yes and sent the package to sysadmin team
21:08:07 <blingme> I will try and have a look if I have time ...
21:08:13 <misc> blingme: yes, but that's a good start, it should be quite quick
21:09:18 <misc> #info end of meeting reported due to various freenode instabilitie and people being too tired
21:09:42 <ennael> misc: can't you have some help to setup all this
21:09:43 <ennael> ?
21:10:39 <blingme> we're all still behind on puppet :-/
21:11:01 <misc> ennael: will see later, need to go
21:18:20 <rda> shall we end the meeting now?
21:18:26 <damsweb> I think so...
21:19:00 <ennael> #endmeeting