19:16:00 <ennael> #startmeeting
19:16:00 <Inigo_Montoya> Meeting started Mon Dec 20 19:16:00 2010 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:16:00 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:16:19 * maat 's got nice warm sun and blue sky
19:16:30 <ennael> I propose to have kind of global review of pending subject before christmas break
19:16:45 * wobo throws snowball at maat
19:17:12 <misc> didn't rda sent a agenda ?
19:17:19 <ennael> yep
19:17:27 <ennael> but we may add review at the end
19:17:34 <ennael> quick one to see where we are
19:18:05 <misc> ok
19:18:12 <wobo> go
19:18:30 <ennael> ok
19:18:37 <ennael> #topic svn cleaning
19:19:01 <ennael> " the process is being started, the packaging
19:19:01 <ennael> team is being set up, but how/when do we move this cleaning process
19:19:02 <ennael> clear in the day"
19:19:29 <ennael> so the point is to give a clear public position about all this
19:19:41 <ennael> and explain the current process both on soft and packages
19:20:27 <ahmad78> on soft, the cleaning is ongoing, rather slowly but it's going
19:20:42 <ahmad78> in the mean time, the artwork team can start working on the icons already
19:20:53 <ennael> I guess they started already
19:21:05 <misc> can we see the artwork ?
19:21:12 <misc> do they need something on our side ?
19:21:27 <misc> ( because rda said he would ask them, but I didn't hear back )
19:21:32 <ennael> Will ask romain tomorrow about this
19:21:40 <ennael> he could not attend this evening
19:21:50 <ennael> dmorgan: any input on this ?
19:22:55 <ennael> ahmad78: about soft cleaning is it still in README file ?
19:23:21 <ahmad78> ennael: the procedures used, yes, pretty much
19:23:38 <ennael> what about progress on this ?
19:24:23 <ahmad78> There's a script to create a status html page, I don't know if it's published anywhere though. boklm?
19:24:38 <misc> the script is on github
19:24:42 <ennael> that would be nice indeed
19:24:51 <ennael> and update it regularly
19:24:53 <boklm> http://svn.mageia.org/soft-cleaning/status.html
19:25:13 * boklm will add it in cron
19:25:27 <dmorgan> ennael: sorry i was busy
19:26:10 <ennael> #action add in cron task update of http://svn.mageia.org/soft-cleaning/status.html to informabout progress
19:26:18 <ennael> dmorgan: any input on artwork ?
19:26:22 <ennael> icons work
19:26:35 <dmorgan> ennael: we have a meeting wednesday
19:26:43 <dmorgan> ennael: i will be able to tell more after it
19:27:09 <ennael> ok can you send a status about this on founders@ ?
19:28:41 <dmorgan> tomorow i can mail you w/o pbs
19:28:45 <ennael> ok
19:29:07 <ennael> ahmad78: who is mainly working on soft cleaning ?
19:29:17 <ennael> boklm, ahmad78, tv ?
19:29:56 <ahmad78> and dmorgan yes, (but I've seen any commits from tv, he's probably 20 times faster than me though)
19:30:10 <boklm> tv did not send his ssh key yet, I will remind him
19:30:12 <ahmad78> s/I've/ I haven't/
19:30:21 <ennael> ok I will ping him also :)
19:30:43 <ennael> what about packages cleaning ?
19:30:53 <dmorgan> ennael: i did but i will find time to start back on this task too
19:30:55 <ennael> about base system
19:30:55 <misc> boklm: did he create a account on identity ?
19:31:17 <boklm> misc: I didn't check, but he didn't tell me he created it
19:32:46 <ennael> what about packages cleaning ?
19:32:49 <ennael> about base system
19:33:51 * boklm will provide a repository tomorrow with repsys version to use to import packages on svn
19:34:17 <ennael> ok
19:34:36 <ennael> still some discussion to have about base_system components ?
19:34:58 <misc> i don't think
19:35:11 <ahmad78> (I don't touch rpm stuff, too complicated)
19:35:21 <ahmad78> (that is, for me)
19:35:36 <ennael> there was a discussion about "too many deps on base system package"
19:35:59 <ennael> #action boklm will provide a repository tomorrow with repsys version to use to import packages on svn
19:36:03 <misc> ennael: when ?
19:36:25 <ahmad78> ennael: that's a side issue, not related to the cleaning per se
19:36:30 <boklm> for packages cleaning, maybe that can be done with the help of all packagers team ?
19:36:56 <ennael> boklm: yep but still we wanted to have base system ready
19:37:29 <misc> yes
19:37:49 <ennael> so we need to decide who will work on it
19:39:56 <misc> guess no volunteer
19:39:58 <ahmad78> anyone who was already an mdv packager, and the group that already know how to package and are gonna be mentored first
19:40:17 <misc> tmb was not in charge of that ?
19:40:54 <ennael> okso we need to kick him
19:42:20 <ennael> #action check with tmb pending work on base system
19:42:30 * boklm forgot to send him repsys source package
19:42:48 <ennael> can you do it as soon as possible?
19:42:54 <boklm> yes
19:43:43 <ennael> ok
19:44:00 <ennael> anything to add regarding legal side on all this?
19:44:52 <misc> on what point of view ?
19:45:19 <ennael> well there was some imput from romain about svn import
19:45:30 <ennael> and discussion started with fredxx
19:45:45 <ennael> looks like things were just going nowhere
19:46:27 <wobo> as usual with legal issues :(
19:46:34 <misc> from my research, I do not think import of discrete component of the rpm should cause issue
19:46:48 <ennael> discrete ?
19:46:52 <misc> separate
19:47:41 <misc> ( mathematical sense, I become like CxO )
19:47:54 <ennael> :)
19:47:56 <boklm> :)
19:48:17 <ennael> ok we just need to conclude all this toavoid having somekind of running gag on this
19:49:01 <misc> well, I think the approach of rda brother converge with mine
19:49:22 <ennael> wobo: any opinion on this ?
19:49:30 <ennael> ahmad78, boklm
19:49:58 <ahmad78> I don't know about the legal issues, sorry :)
19:50:39 <boklm> I think what was said by rda's brother makes sense
19:51:36 <wobo> I am not familiar with the legal issues, so I can't say anything meaningful
19:51:51 <ennael> ok what about using it and just use it a sa conclusion?
19:51:59 <ennael> ok what about using it and just use it as a conclusion?
19:52:15 <misc> well, I think the people present agree
19:52:27 <misc> ( at least on svn import )
19:52:39 <wobo> yes
19:53:19 <ennael> ok so I can see with romain tomorrowabout this
19:53:50 <ennael> #action provide a final conclusion about legal aspects of svn import based on romain's brother statements
19:54:29 <ennael> anything toadd on this ?
19:54:40 <misc> not for me
19:54:45 <ahmad78> no
19:54:51 <boklm> not for me
19:55:15 <wobo> What about piblishing something on this?
19:55:20 <ennael> yep
19:55:24 <wobo> s/pib/pub
19:55:36 <ennael> that was the idea but we needed to agree on this
19:55:55 <ennael> #topic software inclusion policy
19:56:01 <ennael> next one, nice one
19:56:19 <ennael> "deciding what
19:56:19 <ennael> check-list to use to say that a package should go into core/non-free
19:56:20 <ennael> or tainted (or not at all anywhere)"
19:57:15 <misc> well, the same oone as PLF ?
19:57:34 <ennael> can we list repositories and conten ?
19:57:39 <ennael> t
19:57:40 <ahmad78> I have a question, the current mdv/plf, there're two ffmpeg, one in mdv and one in plf with extra stuff enabled
19:57:50 <ahmad78> how will that be handled in Mageia's case?
19:58:03 <misc> i think we could do the same
19:58:06 <wobo> same with mplayer and vlc
19:58:26 <misc> ie if there is a tainted and core, we can have 2 build
19:58:40 <ahmad78> misc: with different distro tag?
19:58:49 <boklm> misc: I think there are some packages from PLF that we could have in core
19:59:04 <boklm> like p2p software or emulators
19:59:12 <misc> boklm: yup
19:59:21 <ahmad78> what p2p software?
19:59:32 <boklm> ahmad78: any p2p software
19:59:49 <misc> what we can do is to agree to take in core what is in main/contribs, unless said otherwise
20:00:13 <misc> and decide for importing plf on a case by case basis, and choose rule based on this ?
20:00:13 <ahmad78> well, all torrent clients aren't in plf; ah, you mean stuff like amule?
20:00:19 <misc> ahmad78: yes
20:00:21 <AL13N> misc: how do you make sure during updates that the tainted one isn't updated to the core one?
20:01:07 <ahmad78> they'll be built one after the other, the chances of a tainted build reaching the mirrors before a core one will be slim, I think
20:01:26 <ahmad78> I meant s/before/after it with a long time/
20:01:30 <misc> we can also treat that like x86/x86_64 but this would requires change on  BS
20:01:44 <misc> but that's a technical question that could be discussed outside of the meeting :)
20:01:53 <AL13N> ahmad78: exactly; so if you installed a tainted one, you get a core one on update
20:01:59 <AL13N> misc: ok, sorry
20:02:00 <misc> so for software inclusiion policy ?
20:02:22 <ennael> we need to agree on this and work on something to be published to close that subject
20:04:23 <misc> if we start with current mdv policy, we can move package in core later
20:05:08 <ennael> could we write or reuse mdvpolicy to provide official mageia policy ?
20:05:09 <ahmad78> misc: I agree with both your points about plf packages inclusion and non-free inclusion
20:05:32 <misc> ennael: there is no official mdv policy :/
20:05:59 <ennael> that does not prevent us to write it
20:06:05 <misc> yup
20:06:06 <boklm> about patented software, I think we should include them in tainted repository only for enforced patents with no known prior arts
20:06:29 <misc> well, who will be in charge of deciding ?
20:06:47 <misc> ( who, or how )
20:06:47 <ennael> wht skills needed there ?
20:07:12 <misc> speaking legalese, good memory, hability to copy others distribution decision :)
20:07:13 <wobo> Knowledge of all laws in all countries
20:07:24 <ennael> ahah :)
20:07:34 <ennael> so I guess misc is a good candidate :)
20:07:38 <misc> if there is enforced patent, reading news should be enough
20:07:40 <ahmad78> knowledge about patents, and an eye out for what others distros do
20:07:52 <ahmad78> ennael: and Anssi
20:08:08 <ennael> we can start with them and ask for volunteers to join
20:08:11 <ennael> wdyt?
20:08:15 <misc> ok for me
20:08:39 <ennael> ok we need to check with Anssi
20:09:09 <ennael> how do you want to call that "committee"?
20:09:10 <misc> "from terrorism to legalese, life of a french python programmer"
20:09:14 <ennael> :)
20:09:28 * boklm would put as much as possible in core, and move to tainted only if someone complains with good reasons to move it
20:09:36 <ahmad78> (that's the new the Lord of the python eggs book?)
20:10:14 <misc> ennael: give me 24h, and I wil find a good name
20:10:17 <ennael> ok
20:10:32 <wobo> My POV in general: patented software (as well as other legally "foggy" software) must not be mixed with other software to allow users and mirror maintainers to decide how to deal with the issue (install or not, exclude or not)
20:10:49 <wobo> worldwide I mean
20:11:03 <ennael> #action a committee will make decision on packages to be moved on tainted (misc,Anssi if he agrees + ask for volunteers)
20:11:19 <misc> wobo: technically, most mirror are protected by safe haven laws, and indeed, if someone complain, that would be a reason
20:11:30 <boklm> wobo: problem is that almost all software could be patented
20:11:46 <wobo> could != is
20:11:52 <ennael> #action misc will find a name for this a committee
20:11:54 <boklm> probably is
20:11:59 <ennael> #undo
20:11:59 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x861cdac>
20:12:02 <ennael> #action misc will find a name for thiscommittee
20:12:05 <ennael> #undo
20:12:05 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x861c3cc>
20:12:08 <ennael> #action misc will find a name for this committee
20:12:09 <ennael> grrr
20:12:16 <AL13N> lol
20:12:49 <wobo> boklm: but different in different countries, so mirror maintainers and users can choose on their individual risk and country laws
20:12:57 <ennael> so still we should finalize an official page describing repositories,policy and committee
20:14:23 <misc> wobo: do you have a list of package that could be problematic in germany ?
20:15:18 <wobo> yes: only very few (3 or 4)
20:15:33 <wobo> well, strictly speaking: none
20:15:34 <misc> good, so we will see later :)
20:16:29 <wobo> There's a PLF mirror in Germany, never had problems
20:16:43 <ennael> so who/when can work on this page?
20:16:53 <ennael> maybe it's just summary of all our discussion
20:17:03 <misc> I guess I could for the next 2 weeks
20:17:13 <ennael> ok
20:17:16 <misc> that would change from sysadmin :)
20:17:19 <ennael> :)
20:17:36 <wobo> just start and we can refine it in founders@
20:17:38 <misc> ( trying to understand sympa source code or legal system is the same )
20:17:47 <wobo> LOL
20:17:51 <ennael> #action write formal page for Mageia repositories, content, policies and committee
20:17:54 <boklm> :)
20:18:19 <ennael> anything else to add ?
20:18:37 <olorin_> Steer clear of ACTA.
20:18:53 <ennael> ?
20:19:19 <olorin_> Anti-Counterfeiting Trade Agreement
20:19:29 <misc> olorin_: well, we will take care of newer treaties when they will be transposed in our local law :)
20:19:36 <ennael> ok
20:19:44 <ennael> next topic?
20:19:49 <misc> yup
20:20:00 <ennael> #topic brand/logo policy
20:20:31 <ennael> - having an official logo with strict guidelines and a community
20:20:46 <ennael> logo with more latitude + keeping a hand on logo derivations - or? - logo is decided, and we provide all versions needed for all uses
20:21:04 <ennael> as we have already communities asking for the way we will use it
20:21:35 <olorin_> If my voice counts, I'd go for the latter with readily made press sets.
20:21:44 <wobo> Can I give my view on that?
20:21:50 <misc> wobo: yup
20:21:56 <wobo> - one official logo to make known that "this comes from the real Mageia Association".
20:22:05 <wobo> - one (may be more colorful) logo for user organisations acknowledged by the Mageia Association.
20:22:13 <wobo> - Every other variation of the logo is not official, we can not control it anyway.
20:22:16 <wobo> done
20:22:41 <ennael> so basically second proposal ?
20:22:47 <wobo> yes
20:23:11 <ennael> misc, boklm,ahmad78 ?
20:23:20 <misc> that's a quite complex issue
20:23:30 <olorin_> And enforcement?
20:23:39 <misc> olorin_: that's part of the complexity
20:23:45 <ennael> meaning?
20:23:47 <olorin_> misc: The logos themselves is the easy part.
20:24:01 <ahmad78> ennael: second proposal too
20:24:07 <misc> ennael: if someone do violates our conditions of uses, what do we do ?
20:24:31 <ennael> indeed
20:24:32 <ahmad78> we can't control what anyone will do with the logo, so "what do we do" as misc said
20:24:33 <misc> i do not think we have either the cash, or the envy to sue
20:24:37 <olorin_> Obviously the cauldron and the name must be trademarked and protected.
20:24:41 <wobo> misc: we can only do something if somebody violates the rules about the one registered logo
20:25:03 <ennael> maybe the point is not to sue but question of recognizing communities or any use of logo
20:25:05 <misc> but if we do like debian, we will end like debian, ie a logo used by everybody, and one used by one one :)
20:25:25 <boklm> what is 2nd proposal ?
20:25:27 <olorin_> ahmad78: Na, but I think misc meant abuse in a commercial sense. Like the infamous Firefox socks or the Linux washing agent.
20:25:40 <misc> olorin_: nope
20:25:48 <ennael> boklm: we provide all needed logos
20:25:57 <olorin_> misc: So what did you mean?
20:26:09 <boklm> and first one we allow derivated logos by other people but we keep an eye on it ?
20:26:16 <misc> olorin_: well, if another distribution use our logo, or a pc maker
20:26:16 <ahmad78> Well, I think wobo summed up nicely; a set of logos that we offer, one official, and one for affliates
20:26:25 <ahmad78> anything else is "user-made"
20:26:30 <ennael> boklm: well keep an eye means we loose our eyes :)
20:26:41 <misc> but the logo value depend on its usage, and once it is good enough to be copied, it will be protected by itself
20:26:42 <boklm> :)
20:27:02 <ennael> I guess second is good,we do reference those who use official one as part as official mageia communities
20:27:05 <olorin_> misc: That would be infrigement, unless they have permission from us.
20:27:47 <misc> olorin_: well, then we need to sue, except this take time and money, and can be seen as a unpopular move ( ie more time lose )
20:28:10 <ahmad78> misc: we can dish it out in blogs too, which costs nothing :)
20:28:22 <wobo> It's more like, if used improperly we can state that the related contents is not from us.
20:28:29 <ahmad78> yep
20:28:32 <olorin_> misc: Exactly, therefore better to have a set of rules from the start. We can't do anything about the countries with lack of respect for copyright of course.
20:28:47 <wobo> yes
20:28:53 <misc> well, i would follow wobo's proposal too
20:29:21 <ennael> ok looks like everyone here agree
20:29:22 <boklm> we can ask people to not do something, even if we don't sue if they don't listen
20:29:44 <misc> ennael: how many issue did have mandriva on the topic of logo ?
20:30:08 <ennael> well the point is we had nearly no policy nor money to sue
20:30:14 <olorin_> At least one...
20:30:16 <misc> in fact, we should have chosed a ugly logo, no one would have copied it
20:30:31 <wobo> I myself reported several but Mandriva did not react, ennaelgave the reason
20:30:32 <ennael> so basically mdv used first proposal
20:30:41 <olorin_> Like I said, Firefox socks...
20:30:41 <misc> and did it cause big issues ?
20:30:59 <ennael> well it lacks kind of official line
20:31:19 <olorin_> Pingus never clashed with Tux AFAIK.
20:31:24 <ennael> and some communities were expecting us to provide some marketing stuff like logos
20:31:36 <wobo> in "my" cases we had to warn the users some times. Mostly on ebay
20:31:48 <olorin_> ennael: Yes, as part of the branding.
20:31:53 <ennael> yep
20:32:04 <ennael> so I reallythink second solution is the best one
20:32:08 <misc> ennael: for providing logos, we can ask to artteam to provides some variations
20:32:13 <ennael> not perfect but at least it gives guidelines
20:32:17 <misc> just not to label "official one"
20:32:17 <ennael> misc: sure
20:32:30 <olorin_> misc: Of course.
20:33:29 <olorin_> But based on the regular one, with specialized additions/variations.
20:34:15 <wobo> But pls no flags!
20:34:27 <ennael> ?
20:34:44 <misc> flag are country related, not language related, so indeed, that's a point
20:34:50 <wobo> For community logos, don't use flags of the community countries
20:34:51 <olorin_> Speaking of which, Christmas is up on us, but how about one for the new year?
20:35:04 <olorin_> wobo: Hehe, yeah, flags are so kitch.
20:35:05 <ennael> wellI guess we can ask for suggestions then artwork team work on it
20:35:21 <misc> yes, exact logo are better left for artteam meeting :)
20:35:26 <ennael> :)
20:35:33 <ennael> ok so we agree on second proposal?
20:35:41 <wobo> yes
20:35:43 <olorin_> Sure, but we can come with some suggestions and ideas.
20:35:53 <ennael> sure
20:35:55 <olorin_> Yep, second it is.
20:36:20 <ennael> #info mageia will provide official logos + all needed one for local communities
20:36:36 <ennael> #action see with artwork team all requirements
20:36:54 <ennael> anything to add N
20:36:55 <ennael> ?
20:37:33 <misc> who will see with art team ?
20:37:35 <olorin_> Well, I wish for us to have at least one ready before new years eve.
20:38:06 <ennael> olorin_: next topic :)
20:38:15 <olorin_> ennael: Ah, ok.
20:38:26 <ennael> misc: I will see romain tomorrow morning
20:38:30 <olorin_> Oh.
20:38:35 <ennael> I will explain him all what was said
20:38:40 <ennael> and he will manage this
20:38:50 <misc> that we gave him lot of task because he was not here :) ?
20:38:51 <olorin_> Speaking of which. Education, do we still plan to target it?
20:39:19 <ennael> misc: you bet :)
20:39:39 <ennael> olorin_: I guess so if we have people interested in
20:39:49 * wobo makes a note that he will never miss a meeting
20:40:01 <ennael> :))
20:40:02 * olorin_ want a logo for that as well, if the art team can.
20:40:19 <ennael> wobo: that does not prevent you to get a looooong todo list :)
20:40:19 <misc> olorin_: I can do it, a logo with kids in the cauldron
20:40:26 <ennael> :))
20:40:29 <ennael> miam
20:40:37 <AL13N> lool
20:40:38 <olorin_> ennael: Well, I'm dreaming of taking on DebianEdu and one of the key pieces would be the EducOOo packages.
20:41:07 <ennael> olorin_: we met one of the developpers last week
20:41:09 <misc> olorin_: IMHO, that's a topic for packagers team more than us :)
20:41:16 <ennael> he is very interested in it indeed
20:41:18 <olorin_> ennael: Who?
20:41:22 <ennael> Eric bachard
20:41:25 <olorin_> Ah!
20:41:29 <wobo> olorin_: side note: look at http://lerntux.de, based on mandriva
20:41:39 <ennael> anyway next topic
20:41:40 <olorin_> ennael: Yeah, I put him on it.
20:42:12 <olorin_> ennael: I'm on the council btw...
20:42:16 <wobo> next
20:42:17 <ennael> nice
20:42:30 <ennael> #topic quick review of pending tasks
20:42:50 <ennael> wobo: can you give us a quick picture of i18n team?
20:42:56 <wobo> yep
20:43:08 <wobo> ATM we are discussing the individual workflow of translators/groups  in
20:43:16 <wobo> the mailing list to agree on maximum 2 possible scenarios.
20:43:23 <wobo> hese will be sent to sysadmin team so they will know what we need.
20:43:35 <wobo> Agreed: work should be possible online and offline, only 2-3 people of one team should be permitted to commit.
20:43:44 <wobo> We postponed actions to reach teams/people who did not subscribe
20:43:52 <wobo> to the mailing list nor participated in meetings until
20:44:00 <wobo> the infra structure is set and translation work starts for real
20:44:08 <wobo> Requests for mailing lists are coming in and I'm ready
20:44:15 <wobo> to send them to sysadm when sympa is completely configured.
20:44:22 <wobo> We'll have a meeting on Thursday and then a break until first Thursday in January.
20:44:28 <wobo> Done Phew!
20:44:33 <ennael> nice job :)
20:44:58 <olorin_> I'm glad to see that the i18n infrastructure is coming together nicely.
20:45:20 <misc> well, transifex is not as smooth as I would have wanted too :)
20:45:45 <wobo> yes, looks like. Funda seems to know about it
20:46:13 <olorin_> misc: Transifex is less than desirable.
20:46:14 <wobo> I'll try to have Funda come to the mext meeting
20:46:23 <ennael> #info i18n: work should be possible online and offline, only 2-3 people of one team should be permitted to commit
20:46:38 <olorin_> Pootle?
20:46:49 <ennael> ok
20:46:55 <ennael> ahmad78: triage team?
20:46:58 <wobo> But we may end up with using svn as in Mandriva and use wiki pages and lists for collaborating
20:47:13 <boklm> is there a reason to allow commit for only 2-3 people per team ?
20:47:22 <olorin_> wobo: That's no problem with either solution.
20:47:37 * misc note "next time, do not ask to people after installing software"
20:47:45 <wobo> boklm: at least for the moment to enforce collaboration
20:47:49 <olorin_> misc: Good call.
20:47:54 <boklm> wobo: ok
20:48:03 <misc> anyway, the discussion about i18n is better for i18n meeting :)
20:48:09 <ennael> yep
20:48:19 <ennael> misc: can you kick ahmad78 ? :)
20:48:24 <wobo> boklm goes with the "menoring program"
20:48:39 <wobo> misc: yes
20:49:06 <misc> ahmad78: if you don't answer, we will make you head of pacakgers team
20:49:06 <ennael> ok  about packagers team
20:49:10 <ennael> :)
20:49:11 <olorin_> Well, you really want reliable people don't you?
20:49:25 <wobo> :)
20:49:26 <ennael> we had a quite successfull meeting
20:49:59 <ennael> we are cleaning list of contributers adding more information to be able to list first packagers,
20:50:13 <ennael> the one who should be mentored in priority
20:50:16 <ennael> and beginners
20:50:30 <ennael> work is starting on policies
20:50:49 <ennael> we still need to choose representatives
20:50:57 <misc> no one proposed
20:51:00 <ennael> I'm a bit afraid about this
20:51:06 <AL13N> were there any resume's submitted?
20:51:17 <ennael> because we really need experienced guys to start with
20:51:30 <ennael> 2 I guess were proposed
20:51:38 <olorin_> AL13N: You volunteered to do some of the lighter tasks didn't you?
20:51:48 <ennael> but even if they are enthousiastic :) they are still quite beginners
20:52:07 <olorin_> Hmm.
20:52:41 <AL13N> i would like team leader to be someone who is good with deciding and meetings; and the 2nd one a packaging expert
20:52:46 <olorin_> I'm no buff either.
20:53:01 <misc> well, people still need to start sometime
20:53:05 <AL13N> like: ennael or misc for 1st; and Annsi or tv or misc for second
20:53:13 <ennael> yes but start is important
20:53:14 <misc> and that's just for 5 months
20:53:36 <ennael> these 5 months are quite crucial for mageia
20:53:39 <AL13N> perhaps we can have olorin for team leader if he's backed up by an excellent packager?
20:53:46 <olorin_> Hehe
20:54:09 <misc> I can propose myself, but then only for 5 months
20:54:26 <misc> ( cause I think I am already too much present, being the one that end in all meeting :/ )
20:54:35 <wobo> yes!
20:54:46 <ennael> I'm ok also for 5 months
20:54:56 <olorin_> Na, misc can be the master package for life.
20:55:05 <ennael> but still this has to be accepted
20:55:08 <misc> yup
20:55:29 <ennael> misc: maybe we can post on -dev ML ?
20:55:54 <olorin_> AL13N: I would of course feel much more comfy with i18n issues over packaging.
20:55:57 <misc> ennael: like "take one of us" :)
20:55:59 <wobo> misc: don't forget to publish a CV!
20:56:08 <misc> wobo: i just say my name :)
20:56:18 <wobo> Too scary
20:56:21 <ennael> :)
20:56:23 <ennael> ok
20:56:38 * misc will let ennael post and forget for himself
20:56:43 <misc> ( that's a perfect trap )
20:56:48 <ennael> #info propose more names for packagers representatives (misc, ennael )
20:56:54 <ennael> it's logged now
20:57:16 <ennael> sysadmin team?
20:57:21 <olorin_> You two have the experience...
20:57:22 <ennael> boklm, misc
20:57:24 <ahmad78> I vote for misc too
20:57:31 <misc> ok so I will start
20:57:45 <misc> so transifex is installed, I have been testing it this morning
20:58:00 <misc> it use ldap, should work fine
20:58:12 <misc> sympa is also installed, fully integrated in puppet
20:58:14 <olorin_> And working with it?
20:58:26 <misc> we can use it for public ml, others type are not tested yet
20:58:36 <misc> and it work with ldap
20:58:56 <boklm> misc: what "others type" ?
20:58:58 <ennael> great
20:59:00 <olorin_> Ok, so LDAP integration is obviously no problem.
20:59:02 <misc> boklm: private list, announce list
20:59:06 <boklm> ok
20:59:14 <wobo> So I can send requests to you?
20:59:15 <ennael> misc: does it mean we can migrate existing one and create pending one?
20:59:40 <misc> ennael: for the moment, just create new one
20:59:44 <ennael> #info sysadmin team: transifex and sympa are installed, configured and tested
20:59:50 <misc> migration will be more problematic
21:00:02 <misc> since this 1) requires everybody to create a account on catdap
21:00:03 <ennael> misc: yep I mean can wobo spamyou with creation for ML?
21:00:33 <olorin_> misc: And the archive?
21:00:35 <boklm> so we probably will need to ask people to do manual migration ?
21:00:53 <misc> ennael: yup, but if someone could take a look at the currentsetup and see if I didn't forget anything, that would be better
21:01:18 <misc> olorin_: will be copied
21:01:32 <misc> boklm: yup, but catdap must be updated
21:01:44 <misc> ( will see later for this )
21:01:55 <ennael> ok so can we agree on todo list forall this
21:03:14 <olorin_> Ok by me, but I'm not of course responsible for anything of this.
21:03:18 <misc> for the forum, still nothing done
21:03:38 <misc> i am waiting on MLO for the vm
21:03:41 <ennael> ok
21:03:46 <ennael> on ML side
21:03:54 <Anssi> hi!
21:03:55 <ennael> what do we need exactly ?
21:03:56 <Anssi> sorry for being late
21:04:21 <olorin_> misc: Any particular forum solution in mind?
21:04:31 <misc> ennael: ?
21:04:41 <ennael> misc: you were speaking about checks
21:05:04 <misc> ennael: well, see if I didn't lock too much
21:05:15 * boklm can have a second look on sympa
21:05:19 <olorin_> Anssi: You're not the only one.
21:05:22 <ennael> ok
21:05:39 <ennael> #action boklm will check configuration for ML before creating first one
21:05:56 <misc> ( 2nd one, because first one is a test ml )
21:06:24 <boklm> about catdap, do we have a version that can be used by users ?
21:06:30 <misc> it can be used
21:06:37 <misc> except we will have more support to do
21:06:40 <boklm> ok
21:06:40 <ennael> wobo: so  you can send your demands :)
21:06:50 <misc> ( people who give their name instead of login :) )
21:06:57 <wobo> ennael: ok
21:07:05 <ennael> do we need specific explanations to be given for first use of catdap?
21:07:11 <misc> nope
21:07:22 <ennael> ok nice
21:07:24 <misc> and I fear that some people will not like the fact we ask name/surname
21:07:25 <boklm> misc: I think there was/is a translation error on this
21:07:37 <misc> boklm: possible
21:07:44 <boklm> for french version
21:08:03 <misc> mhhh
21:08:23 <boklm> (surname was translated to surnom)
21:08:25 <misc> i have redone the dialog : http://www.zarb.org/~misc/tmp/catdap.png so it is clearer to see where goes the first name and the name
21:08:25 <ennael> #action after last checks of configurations,first ML can be officially created
21:08:36 <AL13N> imho catdap works as long as you don't forget your password
21:08:40 <wobo> Can you put a list of services on top which people can register for in catdap?
21:08:44 <boklm> misc: ok :)
21:08:45 <olorin_> misc: Not asking for much else than that and maybe some e-mail addresses, so I don't see why. Not that it won't happen...
21:09:26 <misc> wobo: basically , everything that requires registration will requires a catdap account
21:09:52 <olorin_> AL13N: Err, no recovery?
21:10:07 <misc> recovery is not coded yet, AL13N is working on that
21:10:09 <wobo> misc: Hmm, where do you prevent people registering for a service they are not allowed to regiister for?
21:10:21 <misc> wobo: ie ?
21:10:26 <wobo> like svn access
21:10:46 <misc> wobo: registering do not imply access, they need to be accepted in the group by a admin
21:10:47 <boklm> wobo: you don't register for svn, you ask an admin to have your account upgraded
21:11:12 <wobo> ok, so it is only for public services, right?
21:11:13 <olorin_> Basically just a meta account.
21:11:15 <misc> ( later, we will add delegation, I guess, because sysadmin are lazy )
21:11:18 <misc> olorin_: yes
21:11:32 <misc> wobo: well, what would be "private service" ?
21:11:51 <wobo> svn access, blog admin, website editing
21:12:04 <boklm> wobo: some services may require you to be in a group to have some permissions
21:12:29 <olorin_> Nothing new.
21:12:47 <misc> for example, if you register and if I move you in mga-sysadmin, you will be able to be admin on sympa, and if I remove from the group, you will no longer be
21:12:55 <wobo> So, to get access to those permissions you have to ask sysadmin as before. I wanted to make sure.
21:12:59 <misc> wobo: yes
21:13:13 <misc> now, there is service where no permission would be required ( forum )
21:13:24 <misc> or ml subscription ( at least, the public one )
21:13:27 <olorin_> wobo: No, we'll just give world write access to everything for everyone.
21:13:47 <wobo> olorin_: as a REAL community shoudl do :)
21:14:00 <olorin_> wobo: :-p
21:14:22 <wobo> ok folks, I understood, thx
21:14:45 <misc> for the wiki, no on my radar yet
21:15:04 <misc> and so , i let either dmorgan for bugzilla, or boklm for buildsystem
21:16:22 <ennael> boklm,dmorgan ?
21:16:28 <boklm> so for buildsystem
21:16:54 <boklm> I am testing iurt/emi/ulri installed by blino
21:17:02 <boklm> and next step is setup of youri
21:17:34 <boklm> for youri, we can either use youri from mandriva, or youri from zarb
21:18:07 <dmorgan> ennael: for bugzilla i will answer to misc email about layouting. i would like this almost finished this week.
21:18:12 <boklm> youri from mandriva is an old version of youri from a few years ago that was patched with mandriva changes
21:18:30 <blino> boklm: I started to setup youri from Mandriva
21:18:39 <ennael> boklm: what would imply using the one from zarb?
21:19:00 <misc> some subtle bugfix missing
21:19:02 <blino> boklm: we can switch to upstream youri later, it means quite some work, migrating plugins
21:19:53 <misc> yup
21:20:08 <misc> there was quite some change, so there is some work to do on reviewing and integrating
21:20:15 <boklm> ok
21:20:22 <ennael> blino: how long do you think it's needed to have youri ready?
21:20:24 <blino> though, mdv-youri has soe hardcoded stuff
21:20:36 <boklm> yes, mdv-youri needs some changes to work for us
21:20:37 <blino> like "main", "contrib", "cooker"
21:20:46 <boklm> so it requires some work too
21:20:55 <blino> yep, but not much I guess
21:21:11 <blino> and I have started the config files for it already
21:21:13 <misc> we can do it mdv style, with symlink :)
21:21:19 <blino> ennael: probably 2 or 3 days full time
21:21:41 <ennael> ok so we can start with mdv one and plan migration?
21:21:51 <ennael> would allow to have bs ready faster
21:21:57 <misc> yup
21:22:16 <blino> I don't have time to help much about youri these days :/
21:22:29 <boklm> ok
21:22:39 <ennael> boklm: can you go on onthis ?
21:22:45 <boklm> so we need to import mandriva youri in svn somewhere to be able to make some changes
21:22:54 <boklm> ennael: yes
21:23:32 <blino> boklm: youri-submit (todo) is almost working on our BS, but it needs a tree with a few src + binary rpms so that you can try the real upload
21:23:46 <blino> then, ulri should be able to schedule the builds already
21:23:54 <blino> then iurt is working too
21:24:02 <blino> emi seems working too
21:24:13 <blino> but it needs a youri-submit queue config file
21:24:15 <boklm> blino: the version installed by iurt package ?
21:24:35 <blino> and then, we need the final youri-submit config file
21:24:39 <blino> (and setup crontabs for ulri + emi)
21:24:47 <blino> boklm: yes, from the iurt package I built manually
21:24:54 <boklm> ok
21:25:10 <boklm> I think we can start using a 2010.1 tree
21:25:41 <blino> check svn+ssh://svn.mageia.org/svn/soft/build_system/iurt/trunk
21:26:08 <boklm> ok
21:26:16 <blino> boklm: I started with a small cauldron tree, in /distrib/bootstrap/distrib/cauldron/
21:26:32 <ennael> #info bs: stil have to finalize youri configuration
21:26:41 <blino> but it is missing the src.rpms
21:26:46 <boklm> ok
21:28:18 <ennael> anything else to add on this ?
21:28:30 <boklm> not for me
21:28:56 <ennael> ok
21:28:59 <misc> neither
21:29:04 <ennael> any topic left ?
21:29:11 <misc> well, the other team :) ?
21:29:28 <misc> like, what about communication ?
21:29:32 <misc> and QA ?
21:30:24 <ennael> we will have to do it by mail.I will ping all these so that we can have a complete review
21:31:03 <misc> ( anywa off to eat )
21:31:16 <ennael> ok so I guess it waslast topic
21:31:20 <ennael> comment, question ?
21:31:41 <boklm> not for me
21:32:10 <boklm> 2h15
21:32:12 <ennael> btw looks like some of us will take a break in coming days
21:32:35 <ennael> so let say next meeting will be on 3d of january
21:32:37 <ennael> ok?
21:32:41 <boklm> ok
21:32:44 <wobo> ok
21:33:15 <ennael> so have nice christmas and new year's day
21:34:03 <wobo> Best wishes to all! Don't kill too many geese, though!
21:34:23 <ennael> #endmeeting