19:06:49 <misc> #startmeeting
19:06:49 <Inigo_Montoya> Meeting started Mon Dec  6 19:06:49 2010 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:06:49 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:06:59 <misc> #meetingname Founder's meeting
19:06:59 <Inigo_Montoya> The meeting name has been set to 'founder's_meeting'
19:07:09 <misc> #chair ennael t_m_b
19:07:09 <Inigo_Montoya> Current chairs: ennael misc t_m_b
19:07:42 <misc> ok so since no extra topic have been sent, let's start with the review
19:07:53 <misc> #topic soft/ cleaning
19:07:55 <misc> boklm: ?
19:08:12 <boklm> ok
19:08:36 <boklm> so mandriva soft svn has been imported in a temporary repository
19:09:49 <boklm> and now we need to look at all software to check what needs to be done
19:10:09 <ennael> is there any formalized process about it
19:10:16 <ennael> I guess there were sole questions about it
19:10:39 <boklm> to make 3 groups: obsolete software that we don't import, software that need cleaning (proprietary icons, logos, etc ...), software that don't need cleaning
19:10:52 <boklm> ennael: not yet
19:11:45 <ennael> so it's planned ? :)
19:12:37 <boklm> I can look (unless someone else have ideas for a formalized process)
19:12:57 <misc> i guess that guidelines would be enough ?
19:13:11 <boklm> yes
19:13:39 <boklm> guidelines about what need to be check / cleaned ?
19:14:07 <misc> yup
19:14:22 <boklm> ok
19:14:23 <misc> because we do not seems to all agree on what should be done :)
19:15:38 <boklm> something else to say about soft/ cleaning ?
19:15:55 <ennael> well misc can you just be more precise ? :)
19:16:10 <rtp> misc: is there any hope to reach an agreement ? /o\
19:16:56 <boklm> rtp: probably
19:17:35 <misc> ennael: from what I remind, we just didn't understand the same thing about the process
19:18:02 <ennael> can we just sum up for each side ?
19:18:14 * misc forgot
19:18:32 <ennael> great
19:18:57 <misc> but that's was not a disagreement more than people do not really knowing what to do exactly
19:19:05 <ennael> ok
19:19:14 <misc> like "writing in changelog was should be cleaned after having inspected the source"
19:19:26 <misc> or "should dbus interface be changed, etc"
19:19:59 <misc> or "what is exactly obsoletes for software than few people knew" ( fibric, aviator among others )
19:21:43 * misc killed the conversation or the network connexion
19:22:02 <ennael> :)
19:22:08 <boklm> ok, so I will try to write some guidelines about this to discuss
19:22:25 <misc> #action boklm add guideline about svn cleaning
19:23:19 <ennael> did you start work on cleaning already ?
19:23:43 <boklm> dmorgan started I think
19:23:58 <ennael> ok
19:24:03 <ennael> who is planned to work on it ?
19:24:08 <misc> amhad too
19:24:31 <boklm> ahmad78, dmorgan, tv, me
19:24:39 <ennael> ok
19:24:43 <boklm> and other people if they are intersted
19:25:48 <ennael> ok
19:25:54 <wobo> May I jump in with a non-tech question from userland which came up last week?
19:25:54 <ennael> anything else on this ?
19:25:59 <ennael> :)
19:26:02 <dmorgan> boklm: yes i started
19:26:05 <boklm> blino also did some cleaning
19:26:05 <ennael> wobo: shoot
19:26:08 <wobo> does the selection during svn import put the promised "upgrade ability" from mandriva to mageia in jeopardy? Some users fear that this may happen.
19:26:20 <wobo> what do I tell them?
19:26:22 <dmorgan> dmorgan: but i   don't know what to do about icons for now
19:26:26 <ennael> of course it does
19:26:32 <dmorgan> boklm:  but i   don't know what to do about icons for now
19:26:43 <ennael> I guess killed soft will concern only very old stuff
19:26:54 <ennael> that are not used anymore since years
19:26:59 <boklm> yes
19:27:10 <misc> or buggy :)
19:27:14 <wobo> If so, we should communicate it because it was promised in the FAQ (IIRC)
19:27:20 <ennael> sure no pb
19:27:22 <dmorgan> ahmad78: killed some like printerdrake, drakbt, ...
19:27:27 <dmorgan> ahmad78 killed some like printerdrake, drakbt, ...
19:28:12 <misc> i guess we can see after the cleaning how it will impact upgrade
19:28:22 <ennael> yep
19:28:26 <wobo> yes
19:28:30 <ennael> anything else on that topic ?
19:28:31 <dmorgan> boklm: for icons rda told to add some dummy icon, but someone need to do it :)
19:28:55 <ahmad78> dmorgan: well I think we should first finish moving from mdv-soft
19:29:14 <boklm> dmorgan: first we need a list of icons that need to be replaced
19:29:17 <ahmad78> then another pass on todo-cleaning, in that pass we remove the icons
19:29:40 <dmorgan> boklm: for the icon list rda did a script that told ALL about the icon name, the location , ...
19:29:55 <ahmad78> (fwiw, more stuff were killed, drakbackup, drakmsync and rfbdrake)
19:31:04 <ahmad78> hopefully the cleaning will be faster now that some rules have been laid out
19:31:29 <ennael> would be nice to publish these rules
19:31:38 <ahmad78> (I think rpm-* stuff should be cleaned by people familiar with rpm internals, so Nanar, blino, misc.. etc)
19:31:46 <boklm> ennael: yes, when they are done
19:31:47 <ennael> so that people can see what base we have for mageia and why
19:31:51 <ennael> yep ok
19:31:59 <ahmad78> ennael: they're published sort of, in the README file
19:32:10 <ennael> ok
19:32:14 <ennael> next topic ?
19:32:22 <dmorgan> hum so in 2 pass then, move in todo-cleaning,  clean mdv , and then clean the icons ?
19:32:23 <boklm> ah, I didn't see rda added some rules\
19:33:10 <ahmad78> dmorgan: in pass 2, stuff should already be in todo-cleaning, with a CLEANUP_PROGRESS.txt file stating what needs to be looked at
19:33:16 <rtp> dmorgan: while icons are important, it should not slow down too much our way to having a basic build chroot imho
19:34:19 <ahmad78> rtp: well, misc and rda had the idea of replacing all the icons with a big red square png
19:34:24 <ahmad78> just as a place holder
19:34:32 <dmorgan> rtp: i don't think build chroot use soft with icons
19:34:35 <dmorgan> i hope :)
19:34:52 <wobo> :)
19:35:22 <ennael> ok next topic then
19:35:55 <ennael> #topic ML migration
19:35:59 <ennael> misc: your turn
19:36:11 <misc> ennael: that's quite fast
19:36:23 <misc> I didn't have the time to do anything this week on the ml front
19:36:38 <ennael> ok so what do you plan for this week ?
19:36:56 <misc> do what I planned for last week :)
19:37:13 <ennael> ok need tests or help ?
19:37:56 <misc> well, I will ask for test once I have something to test
19:38:43 <ennael> ok
19:38:54 <ennael> #action misc postpones it for this week
19:39:35 <ennael> #topic forums setup
19:39:55 <ennael> so basically maat has now root pasword on server
19:40:06 <maat> yup
19:40:07 <ennael> but still server is shared with MLO team
19:40:20 <maat> (hi all)
19:40:23 <ennael> spaeking with misc we thought about using VM
19:40:42 <ennael> but enzolyte told me we could not have second IP address
19:41:24 <ennael> so we need to take decision about all this
19:41:32 <misc> we can try to work around thisusing a reverse proxy
19:41:34 <ennael> to avoid having forums ready on 2 or 3 years ;à
19:42:31 <misc> ie, having 2 vm, a reverse proxy on the host, and let people access to the vm using ssh + custom port + port forward from host
19:42:47 <maat> for seo optimization changing ip or url would be a bad thing
19:43:17 <maat> that also need to be thought of
19:43:44 <ennael> how can we go on that subject ?
19:44:00 <misc> maat: what has ip changing something to do with my proposal ?
19:44:02 <boklm> misc: setup apache on the real host to be a proxy for the apache inside the VM ?
19:44:10 <misc> boklm: yup
19:44:16 <boklm> I think that's a good idea
19:44:26 <maat> yup
19:44:42 <maat> misc well your proposal takes care of that point
19:44:43 <misc> apache, or varnish, or squid, after all
19:44:49 <boklm> ok
19:44:51 <maat> and that's a good thing
19:44:54 <misc> maat: for the moment, we have nothing to migrate :)
19:45:01 <ennael> ok can we write something about planning fot this ?
19:45:07 <maat> well yup also :-/
19:45:31 * maat asks for misc gpg key
19:46:17 <misc> 0xFC9DEA42
19:46:46 <misc> but I will likely need to revoke it sooner or later, too weak for today standards
19:47:25 <ennael> maat: as a reminder wobo asked Mageia to host german forums
19:47:46 <maat> ennael: np i think
19:47:53 <maat> if we can host one
19:48:00 <maat> we can also host 2 or three
19:48:51 <ennael> #action boklm, misc and maat will work on setting up apache on the real host to be a proxy for the apache inside the VM
19:49:00 <ennael> antyhing else on that topic ?
19:49:54 <misc> I would like to remind that forum requires catdap to be basic user" proof :)
19:50:18 <ennael> so?
19:50:40 <misc> I think catdap should be our priority
19:51:05 <misc> or maybe just put a "beta" tag on it
19:51:41 <misc> but buchan will be busy for some days :/
19:52:20 <ennael> who could help on this ?
19:52:51 <misc> people who know perl, better for people with catalyst skills
19:53:00 <misc> so jq, Nanar, i guess
19:53:11 <ennael> jq, Nanar : ping ?
19:53:11 <Nanar> yup, if I find time
19:53:23 <misc> ( i have also discussed with bmane who told to take alook and who did some remark )
19:53:27 <maat> got to go
19:53:30 <maat> i'll backlog
19:53:35 <maat> cya
19:54:25 <Nanar> I can have a look to catdap this week
19:55:19 <ennael> #action will have a look on catdap to go forward this week
19:56:02 <misc> i guess that's all for forum setup ?
19:56:06 <ennael> a  bit liked to next topic
19:56:07 <ennael> yep
19:56:14 <misc> epoll ?
19:56:23 <ennael> youri deployment, ssh/catdap integration
19:56:28 <ennael> we forgot epoll
19:56:48 <ennael> #undo
19:56:48 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x85b514c>
19:56:56 <misc> mhh ?
19:56:56 <ennael> #action Nanar will have a look on catdap to go forward this week
19:57:00 <ennael> thanks rtp
19:57:08 <rtp> :)
19:57:15 * ennael eating words like Nanar
19:57:34 <misc> ok so nothing on forum ?
19:57:40 <misc> +more
19:57:44 <ennael> nope
19:57:51 <misc> #topic epoll
19:57:52 <boklm> misc: you too ?
19:58:01 <Nanar> look like my decease is contagious
19:58:30 <misc> well, I do not know what was this point about, as epoll work fine ( I have comited various cosmetic fix this morning )
19:58:41 <wobo> Tested epoll for logo voting, works nicely
19:58:46 <Nanar> thanks, thanks, dont aplause me, thanks
19:59:07 * boklm aplause Nanar
19:59:08 <misc> # action do not applause nanar
19:59:21 <ennael> I guess it was about using it for logo vote
19:59:47 <misc> so let's go on next topic ( logo )
19:59:52 <ennael> yep
20:00:08 <ennael> #topic logo vote
20:00:16 <misc> so the vote was started
20:00:22 <misc> 8 peoples voted so far
20:00:38 <misc> and there is only 23h left for the others
20:01:03 <ennael> #info logo vote has started, still 8 people to vote
20:01:17 <boklm> 8 people who already voted, not to vote ?
20:01:30 <rtp> 8 people who have already voted
20:01:52 <ennael> argh
20:01:57 <ennael> how many remaining ?
20:02:02 <misc> 9
20:02:02 <ennael> #undo
20:02:02 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x8602c0c>
20:02:03 <wobo> :)
20:02:11 <ennael> #info logo vote has started, still 9 people to vote
20:02:32 <ennael> ok then we will see when vote is closed
20:02:33 <misc> ok so next topic ?
20:02:51 <ennael> #topic wiki page for meetings, coming topics + post on ML
20:03:06 <ennael> my bad, I did not post about tonight's meeting
20:03:11 <ennael> will do it from next one
20:03:23 <misc> no problem :)
20:03:32 <misc> we could write some script later to post
20:03:41 <ennael> why no
20:03:41 <ennael> t
20:03:59 <ennael> #topic youri deployment, ssh/catdap integration
20:04:15 <ennael> boklm, misc ?
20:04:41 <boklm> on BS, blino made package submit with repsys working
20:05:24 <boklm> next work is youri-submit I think
20:05:42 <misc> yup
20:05:54 <boklm> and for ssh/catdap integration, I don't know if something was done
20:06:04 <misc> nothing was done
20:06:24 <misc> it work, it is just non obvious, so the interface should be enhanced
20:06:39 <ennael> #info blino made package submit with repsys working
20:06:45 <ennael> so it's usable as it
20:06:49 <ennael> just need improvment ?
20:06:57 <ennael> "just"
20:07:02 <boklm> is the script to extract ssh keys from ldap installed ?
20:07:19 <misc> not yet, as it will break our own keys
20:07:30 <misc> but it was tested, and it is ready
20:07:32 <boklm> ok
20:08:09 <ennael> any time to deploy it ?
20:08:36 <misc> well, for the moment, I think that using password is fine
20:08:50 <misc> annoying, but it doesn't prevent people from working
20:08:55 <ennael> ok
20:09:21 <ennael> #info the script to extract ssh keys from ldap has been tested and is ready to be used
20:10:47 <ennael> anything to add ?
20:10:50 <misc> nope
20:11:07 <ennael> wobo: want to speak about translation team ?
20:11:27 <wobo> ok
20:11:36 <ennael> #topic translation team
20:11:41 <ennael> your turn
20:12:14 <wobo> First layout of the concept for i18n team building has been sent to the mailing list and copied to the wiki
20:12:30 <misc> url ?
20:13:01 <wobo> First meeting will be coming thursday, 2 meetings with identical topics, morning at 09:00 GMT+1 and 1900 GMT+1
20:13:11 <ennael> #info first setup for i18n team  available on wiki
20:13:22 <boklm> 2 meetings with identical topics ?
20:13:23 <misc> http://mageia.org/wiki/doku.php?id=team-build-i18n
20:13:33 <ennael> #info first meeting is planned on thursday
20:13:38 <ennael> #url http://mageia.org/wiki/doku.php?id=team-build-i18n
20:14:13 <wobo> 2 meetings because people are scattered all over the world. I am retired so I can do both. This is only for the first meeting
20:14:23 <boklm> ok
20:14:29 <wobo> language teams started to build
20:14:51 <wobo> German will have first meeting Wednesday
20:15:17 <wobo> Others ar ealready in place (like French, Spanish, etc.)
20:15:33 <wobo> I will send a reminder on Wednesday with the topic list
20:15:54 <wobo> This is only about program translation.
20:16:09 <wobo> will start doc translating teams together with doc teams
20:16:27 <wobo> although I gave a hint to look at Calenco
20:16:48 <wobo> For program translators I told them about transifex
20:16:55 <wobo> All for now
20:17:08 <ennael> ok
20:17:15 <ennael> great job :)
20:17:32 <ennael> ahmad78: want to speak about triage team ?
20:17:33 <wobo> # action don't applaud wobo
20:17:42 <ennael> :)
20:18:14 <ahmad78> ennael: most basic wiki pages haven been imported
20:18:20 <ennael> wait
20:18:26 <ennael> #topic triage team
20:18:36 <ennael> #info most basic wiki pages haven been imported
20:18:39 <ennael> ok
20:19:27 <ahmad78> still being refined, hopefully we'll be able to publish them by the end of this week (the problem is that it's much easier to read and apply what you read at once, we still have no bugzilla)
20:20:18 <misc> on the other hand, we do not have bugs yet /o\
20:20:21 <ennael> #action pages will be published by the end of this week
20:20:41 <ahmad78> misc: don't be sad, we will :/
20:20:47 <ahmad78> :)
20:21:08 <ennael> anything else ?
20:21:19 <wobo> sometimes people can be bugs as well.... (nobody present!)
20:21:24 <ennael> woot
20:21:58 <ahmad78> yep, hopefully Thierry will scare them off (kidding
20:22:01 <ahmad78> )
20:22:06 <ennael> ok
20:22:14 <ennael> #topic packagers team
20:22:28 <ennael> we had a meeting next week about various subject to start with
20:22:39 <ennael> #url http://meetbot.mageia.org/mageia-meeting/2010/mageia-meeting.2010-12-01-19.37.html
20:23:04 <misc> we know that time is relative, and do not exist, but the meeting was in the previous week, or it will happen next week ?
20:23:08 <ennael> I'm working on it since today and I'd like to have very first meeting in the beginning of next week
20:23:31 <ennael> misc: weeting was the one we had together last wednesday
20:23:55 <ennael> meeting
20:24:30 <misc> ok :)
20:24:32 <ennael> #info first packagers meeting should take place next week
20:24:51 <ennael> (guess what I'm drinking water only)
20:25:07 <dmorgan> ennael: you're ill ?
20:25:08 <ennael> any other topic to add ?
20:25:20 <misc> nope
20:25:36 <misc> ( for the first time, we will finish before the delay )
20:25:44 <ennael> ok :)
20:25:49 <ennael> #endmeeting