19:36:53 <ennael> #startmeeting
19:36:53 <Inigo_Montoya> Meeting started Mon Nov 15 19:36:53 2010 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:36:53 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:37:07 <ennael> #chair boklm rda ennael misc
19:37:07 <Inigo_Montoya> Current chairs: boklm ennael misc rda
19:37:47 <ennael> #topic build system progress
19:37:54 <ennael> boklm, misc : your turn
19:37:58 <boklm> ok
19:39:01 <boklm> so since last week, we worked on making iurt working, import some test packages on svn, test repsys with binary repository, bugzilla installation
19:39:33 <boklm> and started looking at youri and scheduler scripts
19:40:07 <boklm> but there is still a lot of work to be done before having a full build system
19:40:26 <misc> main problem is the level of indirection in the script ( ie, a first wrapper that cal a second sudo wrapper that call a trhird one that call a forked youri version )
19:40:56 <boklm> yes
19:41:03 <boklm> so it will require some cleaning
19:42:06 <ennael> needs some more help on this ?
19:42:19 <ennael> #info we worked on making iurt working, import some test packages on svn, test repsys with binary repository, bugzilla installation
19:42:26 <boklm> we need to spend some time on it
19:42:45 <ennael> #action clean iurt scripts to avoid indirections
19:42:59 <misc> ennael: the problem is that some help would likely mean someone to train, and this is likely consume time too :/
19:43:16 <ennael> who is wprking on it at the moment ?
19:43:25 <dmorgan> misc: yes you are right here
19:43:30 <misc> boklm and me
19:43:51 <misc> ( well, technically, for the 4 last day, no one, holidays, etc etc )
19:44:00 <ennael> can blino help on this if he is available?
19:44:02 <dmorgan> misc: do you have an ETA for this to be done ? ( about )
19:44:04 <misc> i guess i could try to make sure that I wake in time to meet boklm to work together more efficiently
19:44:05 <ennael> or titi ?
19:44:25 <dmorgan> ennael: titi would be good i think
19:44:26 <boklm> maybe priority now could be to finish setup of LDAP and SVN, to allow opening SVN accounts to other people to allow them to work on other things in parralel
19:44:35 <misc> boklm: yup
19:44:47 <ennael> what is missing in LDAP configuration ?
19:45:04 <Nanar> you mean we start commiting rpm even bs is not yet ready ?
19:45:16 <misc> Nanar: no
19:45:17 <ennael> Nanar: no cleaning svn rather
19:45:27 <ennael> switch to mageia tags...
19:45:33 <misc> ennael: afaik, catdap is not really primetime ready, and ldap and svn are not plugged together
19:45:39 <dmorgan> ennael: you mean we will reuse mdv svn directly ?
19:45:39 <blingme> nothing is missing in LDAP configuration itself
19:45:46 <coincoin> hello all sorry for being late
19:45:56 <boklm> we need to define groups in LDAP
19:46:01 <Nanar> because some rpms will need a lot of woork before starting bs (rpm, rpm-mdv-setup, ...)
19:46:04 <dmorgan> coincoin: you're apologized dear :)
19:46:05 <misc> ( group are the next topic )
19:46:06 <blingme> end-user contributor features are mostly sufficient in catdap
19:46:23 <blingme> sysadmin features not yet ... but for now I think we can get by
19:46:29 <ennael> ok so what we need to go on on svn ?
19:46:38 <boklm> we need to be added as ldap admins
19:46:51 <blingme> but, some questions I asked on -sysadmin list need answers, or I will just carry on, and expect no queries
19:47:01 <rda> blingme: forgotten password reset is implemented?
19:47:04 <misc> blingme: what questions ?
19:47:17 <blingme> boklm: that I can actually do with catdap now ...
19:47:24 <blingme> but, I need to know who
19:47:34 <blingme> what *does* need to be done is hosts configured for ldap auth
19:47:35 <boklm> blingme: I can send you the list
19:47:57 <blingme> and/or ssh key distribution from LDAP (or, switching to openssh with lpk patch, or both)
19:47:59 <boklm> for the svn, we need to see how we do the authentication part, and if we are using https:// or svn+ssh://
19:48:02 <misc> ( or better, add boklm and let him do the work for you )
19:48:03 <ennael> ok I guess we could start with sympa, forums and svn
19:48:19 <misc> ennael: this is not the BS :)
19:48:19 <dmorgan> ennael: sympa is 80% done
19:48:32 <blingme> misc: questions about uid / gid range for LDAP etc.
19:48:36 <ennael> misc: sure but this is about LDAP
19:48:39 <blingme> what groups to create
19:48:54 <misc> blingme: group is on tonight agenda
19:48:56 <rda> so the topic is different here
19:49:02 <blingme> rda: user-initiated password set is not yet implemented
19:49:38 <blingme> but admin-initiated password reset is
19:50:07 <rda> blingme: yep, but to scale, users should be able to ask a password reset. before going live, that is.
19:50:12 <Nanar> I have a question related to bs
19:50:19 <blingme> so, for svn and any other access that requires user accounts on OS/sshd, nss_ldap/pam_ldap and/or key distribution needs to be done
19:50:20 <misc> before scaling, we need to start
19:50:25 <Nanar> or dependent of bs
19:50:35 <ennael> okok can we try to sort tasks ?
19:51:01 <misc> yup
19:51:02 <ennael> looks like blingme questions have to be answered before all
19:51:36 <misc> well, the 2 questions are ( unless I am wrong ):
19:51:43 <misc> -create some groups
19:51:44 <misc> -decide on the UID/GID range we want to assign to users in LDAP
19:52:10 <Nanar> and ssh keys management ?
19:52:12 <misc> for the range, just take let's say start at 5000 or any number
19:52:24 <ennael> yep we can decide it here
19:52:28 <ennael> not that hard
19:52:38 <misc> for the ssh key, i think that we can alow people to change it
19:52:48 <blingme> Nanar: users are able to update their sshPublicKey in LDAP
19:52:50 <misc> and for the group, we need first a group for ldap admin
19:53:05 <blingme> misc: for groups, I am meaning unix groups
19:53:07 <Nanar> blingme: we can have more than one ? :)
19:53:16 <misc> blingme: ie ?
19:53:17 <blingme> there are pre-defined groups in mandriva-openldap-dit
19:53:21 <blingme> Nanar: yes
19:53:44 <blingme> so, I also need to know who needs to be in "LDAP Admins" and "Account Admins" "system groups"
19:53:59 <blingme> LDAP Admins allows access to almost anything
19:54:13 <misc> couldn't we simplify thing by using only one group for the moment ?
19:54:19 <blingme> Account Admins has write access to all of ou=People and ou=Group
19:54:45 <blingme> misc: we can use LDAP Admins
19:55:03 <Nanar> may I suggest, ldap admin: blingme, boklm, misc, damsweb at time ?
19:55:12 <blingme> but, I need a list of people to add, or at least add someone initially, and they can do the rest
19:55:18 <Nanar> I hope I forgot nobody ;)
19:55:19 <boklm> all sysadmin team should be LDAP Admins I think
19:55:28 <coincoin> I think so
19:55:36 <ennael> boklm: just check once again this list :)
19:55:43 <boklm> blingme: I will send you the list
19:55:54 <misc> ok so the group part is done ?
19:55:57 <blingme> ok, I am creating some accounts for use by nss_ldap/pam_ldap as proxy users
19:56:07 <misc> #action boklm send tthe list to blingme
19:56:15 <blingme> and I have done some basic tests
19:56:27 <blingme> but, then next is to test a node with nss_ldap / pam_ldap etc.
19:56:37 <boklm> ok
19:56:45 <ennael> #action create LDAP admin group, boklm will send a list
19:56:46 <blingme> then people will be able to log in with password they set on catdap
19:57:11 <blingme> ldap step for user access is login by ssh key
19:57:25 <Nanar> blingme: do you need we send something (password, ssh key, ...) ?
19:57:46 <boklm> Nanar: you need to create an account on https:?/identity.mageia.org
19:57:46 <blingme> Nanar: no, if you have registered in catdap, you have a password, you will be able to update your sshPublicKey from there
19:58:13 <ennael> on groups side do you need other information ?
19:58:17 * Nanar log action: create account for himself
19:58:48 <blingme> on promoting a user to posixAccount, the gidNumber needs to be set to the user's primary group
19:59:32 <blingme> so ... we should decide what to do here, put everyone in a common 'users' group, or whether we put them in a specific group
19:59:44 <blingme> and, we will probably need groups of some kind for authorization (ssh, repsys etc.)
20:00:00 <Nanar> I suggest one group for everyone, which is mostly unused
20:00:11 <blingme> so, we may want to define at least some groups (and their names, or how we intend naming them)
20:00:13 <Nanar> permission depend on group we are in
20:00:31 <misc> common users group to start seems enough
20:00:52 <misc> having one group for each users seems overkill ( and bad from a ressources pov, even if negligeable )
20:01:18 <blingme> I didn't suggest per-user groups ....
20:01:43 <Nanar> no gain to have several primary group
20:02:01 <Nanar> except for "system" user such as ldap, svn, mirrors....
20:02:21 <blingme> Nanar: except default permissions (gid bit on new files created in dir without setgid bit)
20:02:27 <boklm> we need one group for svn access, and later other groups for teams to allow access to specific parts of the svn
20:02:44 <misc> we do have already a group for svn access :)
20:03:02 <blingme> right, so if 'svn' is a 'system' group used by package, what name are we suing for svn group
20:03:05 * misc is also about to send a mail about svn layout
20:03:15 <boklm> misc: ah ?
20:03:20 <Nanar> what I think is:
20:03:30 <Nanar> - normal user in one primary group
20:03:35 <misc> blingme: commiters ?
20:03:47 <Nanar> - system user have specific primary group
20:03:51 <misc> blingme: as this will also work for git/hg/whatever
20:04:02 <blingme> ok
20:04:06 <boklm> yes, commiters sounds good
20:04:52 <Nanar> otherwise the question will come "in which primary I must be ?"
20:04:59 <blingme> we could prefix all groups with e.g. mg- to make it clearer and/or prevent collision
20:05:07 <misc> #action use commiters group name
20:05:26 <Nanar> I agree for mg- prefix
20:05:38 <boklm> what does "mg-" mean ?
20:05:41 * misc would prefer to have system group prefixed by _ like done on osx
20:05:57 <misc> ( but that would obviously be more longer and more complex to do )
20:06:02 <blingme> misc: we can do that, but not before we have a working build system ...
20:06:08 <Nanar> boklm: avoid conflict between ldap "svn" and passwd "svn"
20:06:31 <misc> blingme: yeah :/
20:06:43 <Nanar> misc: iirc '_' is deny in user/group name
20:06:45 <blingme> boklm: what is rpm suffix going to be? 'mg' ?
20:06:56 <misc> Nanar: tell that to steve J :)
20:06:58 <Nanar> even _ work in practice
20:07:03 <dmorgan> blingme: mga iirc
20:07:08 <boklm> blingme: it still needs to be discussed, maybe "mga"
20:07:17 <blingme> ok, so mga-xxxx
20:07:31 <boklm> ah, ok
20:07:44 <blingme> did we agree on uid range?
20:07:45 <misc> in any case, the group name can be changed, gid is the important thing, no ?
20:08:00 <misc> blingme: let's say we start at 5000 ?
20:08:01 <Nanar> does this mean we agree the shrotcut for mageia is "mga" ? :)
20:08:22 <rda> I guess so?
20:08:30 <blingme> misc: well, anything can be changed, if you put group 'svn' all over puppet config, you will have to change it ....
20:08:51 <coling> The group should rpobably be called committers (two t's)
20:08:59 <Nanar> nothing can't be solved by proper regexp
20:09:37 <rda> why should we change it if we name it correctly now?
20:09:56 <Nanar> rda: some works in puppet are already done
20:10:04 <misc> because we may not want to discuss all night about it to be sure that we are right on first try ?
20:11:22 <misc> #agreed call unix user group mga-foo to avoid name clash
20:11:33 <misc> anything else on the subject ?
20:11:43 <Nanar> bs ?
20:11:46 <Nanar> or ldap ?
20:11:54 <boklm> both
20:11:58 <Nanar> bs, one
20:12:16 <Nanar> currently rsync pointed to ryu.zarb
20:12:29 <Nanar> I'd like to change as soon as possible
20:12:44 <Nanar> I was waiting BS but it seems it will take some time
20:13:01 <Nanar> can I change it now to cleared the situation ?
20:13:20 <Nanar> so having everything on mageia server
20:13:27 <misc> ok for me
20:13:31 <boklm> ok for me
20:13:34 <Nanar> or you prefer to being to play with the tree ?
20:14:00 <Nanar> there is many solution to magically make any tree working
20:14:01 <boklm> Nanar: maybe you can create an empty tree in a temporary path
20:14:17 <boklm> and mirror this temporary path for now
20:14:23 <Nanar> boklm: done in... somewhere on vlastar
20:14:32 <boklm> and switch when the real one is ready
20:14:59 <Nanar> I sent a mail about it iirc, at least rsync config is in svn
20:15:59 <Nanar> /distrib/mirror/
20:16:01 <boklm> ok
20:16:43 <boklm> maybe we can copy /distrib to /distrib.empty, and edit rsyncd.conf to use /distrib.empty for now while we are doing tests with /distrib
20:16:50 <Nanar> misc: add action: nanar make rsync pointed to valstar, so
20:17:14 <Nanar> boklm: or mount -o bind, and change rsync config
20:17:20 <rda> #action nanar make rsync pointed to valstar
20:17:31 <Nanar> boklm: I don't mind about this, it's quite easy
20:17:42 <boklm> Nanar: ok
20:18:16 <misc> so, no more question on BS ?
20:18:16 <Nanar> I just hope you noticed top level must not be a top level partition
20:18:18 <boklm> something else on BS and LDAP topic ?
20:18:40 <misc> Nanar: you told it several time, and we setup lvm for this reason :)
20:19:05 <Nanar> misc: lvm does not matter at this point
20:19:13 <blingme> on LDAP ... how soon do we want to advertise https://identity.mageia.org?
20:19:38 <ennael> yesterday ? :)
20:19:49 <rda> blingme: I have a meeting with the webteam on wednesday about theming this (among other things)
20:19:51 <Nanar> what must still be done on catdap ?
20:19:52 <blingme> there are still some CSS issues ....
20:20:13 <blingme> Nanar: code-wise, only user-initiated password reset for now
20:20:22 <misc> i thik we should do a separate meeting for catdap,
20:20:27 <Nanar> making a rpm package ?
20:20:33 <blingme> on LDAP side, maybe an ACL tweak
20:20:52 <ennael> misc: can we plan this now? (meeting)
20:20:53 <blingme> Nanar: for our own deployment, or for wider audience?
20:20:57 <misc> ennael: yup
20:20:59 <rda> I would discuss catdap along with the webteam too (or at least, people from the webteam taking on parts of it), actually
20:21:04 <Nanar> blingme: our deployement
20:21:07 <Nanar> first
20:21:19 <misc> I am interested into using catdap for me too
20:21:34 <ennael> ok so when do you want to plan this meeting ?
20:21:41 <blingme> ok, I am happy as long as we can sort out theming issues before it goes live
20:21:55 <rda> webteam meeting is wednesday, 15:00 Paris time on #mageia-web
20:22:03 <misc> let's say wenesday evening, then ?
20:22:05 <wobo> rda: pls think about certificate, there's a warning about that on https://identity.mageia.org?
20:22:12 <blingme> rda: that should be ok with me, please ping me
20:22:14 <misc> so rda can ask to people from the webteam to come ?
20:22:17 <Nanar> wenesday is fine for me
20:22:21 <misc> wobo: this is a know problem, yes
20:22:25 <rda> I won't be available in the evening
20:22:26 <blingme> yes, certificate was the other issue I wanted to mention
20:22:32 <rda> blingme: ok
20:22:53 <misc> wobo: I have quickly deplyed a certificate because some encryption was needed , but that's not a definitive one
20:23:03 <Nanar> certificat => catdap meeting ?
20:23:12 <rda> Nanar: yep
20:23:26 <rda> we'll need a status/progress page for catdap
20:23:27 <wobo> misc: no pb but it should be fixed before going public
20:23:32 <Nanar> wenesday, what time ?
20:23:41 <rda> 15:00 Paris time
20:23:52 <Nanar> ouch
20:24:01 <Nanar> is 15:00 ok for everyone ?
20:24:03 <misc> wobo: well, by fixed, you mean "having a paid certificate" or "having a certificate that will make firefox still cry but slightly more correct on a technical pov" ?
20:24:27 <rda> or 1600 if you prefer not to be in the middle of the full webteam meeting
20:24:28 <wobo> misc: cost free from CACert ?
20:24:43 <misc> wobo: cacert is refused on firefox and ie, and likely on chrome
20:24:54 <rda> misc: we need a certificate that doesn't make firefox cry
20:25:02 <misc> rda: so we need to pay for it
20:25:02 <Nanar> cacert is not yet certified
20:25:05 <boklm> so we need to buy a certificate
20:25:05 <rda> misc: so be it
20:25:09 <misc> so that requires a account, etc
20:25:24 <rda> misc: that's where mageia.org comes into play
20:25:57 <misc> rda: that's also we will start to regret having used vhost eveywhere :)
20:25:58 <Nanar> FYI: even for CNRS it is hard to have a proper certificate
20:26:07 <misc> anyway, this is not related to BS
20:26:09 <ahmad78> (I gotta go, will read the log, g' night all)
20:26:11 <Nanar> CNRS is French National research center
20:26:13 <boklm> we can buy a wildcard certificate
20:26:17 <rda> misc: why? we can have a wildcaard
20:26:24 <blingme> wildcard certs are expensive
20:26:34 <Nanar> hum, well
20:26:40 <rda> less expensive that cert per vhost
20:26:40 <wobo> misc: I'm in contact with the CACert people (I'm an assurer), I will talk with them about it (I did not know that there is a pb in firefox)
20:26:54 <Nanar> can we push certificate issue on the proper meeting ?
20:26:58 <misc> yes
20:27:00 <wobo> yes
20:27:00 <ennael> wobo: that would be great indeed
20:27:06 <misc> so anything else on BS ?
20:27:10 <rda> Nanar: that is, which meeting?
20:27:19 <Nanar> catdap meeting ?
20:27:22 <wobo> ennael: will do tomorrow
20:27:24 <boklm> "Standard Gandi SSL certificate included for Free for one year with your domain name"
20:27:26 <ennael> misc: can you plan also days to meet boklm?
20:27:28 <Nanar> it's the main app needing it
20:27:30 <misc> rda: not this one :)
20:27:32 <ennael> that may help :)
20:27:41 <rda> Nanar: it's more generic issue than just catdap :) but ok, for webteam meeting
20:28:05 <misc> ennael: well, for the moment, I plan to leave to go eat on 10 but yes, I was planning this too
20:28:11 <rda> Nanar: bugzilla will need it. forums as well (for the auth part). actually, everything using authentication will need it.
20:28:12 <misc> so next topic
20:28:17 <Nanar> well, anyway certificate issue can't be solved by now
20:28:20 <rda> ok
20:28:22 <rda> next
20:28:27 <boklm> ok
20:28:34 <boklm> #topic SVN import and cleaning
20:29:19 <boklm> so we need to decide what we do with SVN and what we import
20:29:43 <misc> well, has something changed since we lastly discussed ?
20:29:56 <boklm> we need to have a final decision
20:29:58 <rda> not really. discussions with lawyers didn't go further
20:30:06 <rda> so we'd have to take the safest stance
20:30:31 <misc> the safest stance is to import nothing
20:30:55 <misc> as we cannot do a quantitative or qualitative import
20:31:05 <rda> yeah, cool, so don't do anything. the safest stance regarding our objective.
20:31:09 <misc> and importing enough to have a working system is a qualitative import
20:31:17 <rda> misc: we could import from a mirror. or do a svn export (not having history)
20:31:42 <Nanar> I'd like to say my POv one time for all
20:31:47 <Nanar> Mageia is ne distro
20:31:58 <boklm> ne ?
20:32:04 <misc> one
20:32:09 <Nanar> looosing history make me sad, but that's the lif
20:32:12 <Nanar> new
20:32:32 <ennael> (after eating words now he eats letters)
20:32:49 <Nanar> if not importing history can solve a lot of issue (patent, copyright...)
20:32:54 <Nanar> I am ready to it
20:33:02 <Nanar> so importing rpm by rpm
20:33:13 * Nanar slaps ennael
20:33:20 <rda> nothing related to patents. neither copyright.
20:33:28 <misc> importing rpm by rpm would still violate the database protection, as this is the rpm selection that should be protected.
20:33:46 <rda> misc: then the whole licenses are void.
20:33:49 <boklm> rpm selection is available on public mirrors in SRPMS directory
20:33:51 <misc> ( now, i personnaly thing that given the lack of substancial effort into selecting rpm, this would not be a issue )
20:34:19 <dmorgan> misc: i don't see your point for the rpm to rpm import
20:34:24 <rda> furthermore, the only thing that mdv could claim is that they host the svn. but they do not contribute to it exclusively, so they don't have an exclusive view on such a db.
20:34:32 <rda> so they wouldn't be able to claim st about it.
20:34:33 <Nanar> but there is an issue: bootstraping the distro
20:34:35 <rda> but still
20:34:49 <misc> rda: what is protected is not the content of the svn
20:35:03 <misc> ( well, it is, but that's covered by gpl, so that's not the issue )
20:35:25 <rda> misc: yes, but you have to be an exclusive owner of something to claim something over it.
20:35:31 <misc> what is covered is the "selection of what goes into the databas", with database meaning someonthing as large as a list of poems
20:35:52 <rda> yep
20:35:59 <misc> and I think that mandriva cannot claim to have done any selection efforts , since the svn was almost a free for all
20:36:03 <rda> but who selects what goes into the svn?
20:36:07 <rda> indeed
20:36:11 <misc> they could argue they carefully selected main, but even that
20:36:28 <misc> main never add any rules, main was filled by community, and no one cleaned it
20:36:57 <misc> and we do not plan into keeping main/contribs separation thus not requiring to copy it
20:37:08 <boklm> we will import both main and contrib in svn, so we don't keep the selection
20:37:21 <rda> ok. so?
20:37:31 <Nanar> we import everything ?
20:37:36 <dmorgan> and btw we will change the selection a bit
20:37:44 <dmorgan> Nanar: yes i think this is the better choice
20:37:49 <misc> importing everything will cause others problem
20:37:58 <misc> mainly du to non-free bit in the svn
20:38:06 <boklm> which ones ?
20:38:06 <misc> ( like icons, etc )
20:38:08 <Nanar> even rpm-mandriva-setup that need to be renamed ?
20:38:10 <boklm> ah yes
20:38:25 <dmorgan> Nanar: yes but for them we need to clean before importing i think
20:38:34 <dmorgan> we need to do a list of those rpms
20:38:40 <Nanar> so it is not import everything
20:38:52 <Nanar> it is mostly "redo it"
20:38:55 <rda> is that realistic to make an import, filter/replace/remove non-free stuff (with a placeholder, at worst) and importing this into a public rep ?
20:38:57 <dmorgan> Nanar: yes all except this list
20:38:58 * blingme notes rda, misc, boklm's LDAP accounts promoted to posixAccount users, members of LDAP Admins and Account Admins - they can promote other accounts
20:38:58 <boklm> I think we can import everything from src.rpms with repsys supporting separate binary repository, we clean everything, then we remove history on binary svn
20:39:12 <misc> rda: I do not understand :/
20:39:17 <rda> blingme: wow, me too?
20:39:20 <misc> dmorgan: the list was already started
20:39:37 <blingme> rda: I force you to see the menu CSS problem :-)
20:39:41 <rda> misc: do we automate (broadly) the removal of non free stuff in the import process?
20:39:45 <rda> blingme: \o/ :)
20:39:48 <ennael> misc: have a temporary svn to clean it before malking it public
20:39:50 <misc> boklm: indded
20:40:09 <blingme> another sysadmin can always remove you ....
20:40:17 <boklm> ennael: with separate binary repository, we can easily clean history on this part
20:40:34 <ennael> was more speaking about soft/
20:40:43 <boklm> ah yes
20:40:44 <rda> moreover, as this is relative to only a small/specific part, that does not block all the rest
20:40:45 <Nanar> ennael: ahhhhh
20:40:54 <misc> ennael: soft is a different beast
20:40:58 * rda paraphrases ennael
20:41:15 <misc> ( and I was about to send something about soft )
20:41:18 <Nanar> everything under mdv soft/ isn't gpl ?
20:41:31 <ennael> Nanar: mainly icons
20:41:32 <rda> Nanar: images/icons/sounds
20:41:38 <ennael> and it's all about mdv tags also
20:41:39 <misc> rda: no smell ?
20:41:45 <ennael> too bad
20:41:46 <Nanar> ennael: re- aaaahhhh
20:41:50 <ennael> smell would be funny
20:41:57 <rda> misc: smell was at St Martin.
20:42:00 <ennael> :)
20:42:03 <misc> ok so
20:42:08 <misc> for svn import
20:42:35 <rda> "what happened at St Martin stayed at St Martin"
20:42:36 <misc> we import all packages into svn so we have the separation between binary and source
20:43:26 <boklm> (importing from src.rpm to import old changelog)
20:43:31 <misc> yeah
20:43:39 <Nanar> I am not sure I want this
20:43:58 <boklm> Nanar: ?
20:44:16 <dmorgan> boklm: can't we start with a brand new changelog ?
20:44:33 <dmorgan> or a first one telling this is from mandriva
20:44:33 <Nanar> I am looking for the reason to be against, if I can't find, let's go
20:44:43 <boklm> dmorgan: why ?
20:44:50 <misc> well, we need to keep the current list of people who worked on this
20:45:03 <dmorgan> boklm: there is no legal issues by keeping it ?
20:45:04 <misc> for various copyright reasons
20:45:09 <ennael> yep
20:45:17 <misc> dmorgan: quite the contrary, dropping it would be a problem
20:45:17 <boklm> we didn't create the packages from scratch, so we should credit original authors
20:45:21 <Nanar> when I imported packages from others distro's I didn't keep changelog
20:45:40 <misc> Nanar: so I will have to spank you, but that's too late
20:45:45 <ennael> :)
20:46:13 <blingme> other forks, which continually re-base on Mandriva, remove *all* changelogs, on *every* release
20:46:18 <rda> the authors list is only in the changelog?
20:46:33 <misc> rda: in the distributed srpm, yes
20:46:40 <boklm> rda: and svn commit logs
20:46:43 <Nanar> rda: yes, it dedicated to this...
20:46:49 <ennael> blingme: does not mean they were good at doing this
20:46:53 <ennael> imho
20:46:59 <rda> Nanar: wouldn't a AUTHORS file make it (genuine question, beat me)
20:47:13 <Nanar> rda: not for spec files
20:47:17 <boklm> what is the problem with keeping changelog ?
20:47:19 <blingme> ennael: indeed, maybe I should start copyright infringement suit :-p
20:47:24 <ennael> :)
20:47:24 <rda> Nanar: k
20:47:39 <ennael> I don't see any pb in keeping changelog
20:47:39 <dmorgan> boklm: i was just thinking if there were some possible legal issues by keeping it
20:47:52 <Anssi> I don't see the need for removing changelogs
20:48:08 <dmorgan> ennael: ok so if there is no issue i am ok for keeping
20:48:15 <Nanar> mdvsys import keep changelog iirc
20:48:32 <boklm> yes
20:48:47 <misc> ( of course, we strip changelog in srpm generation so the problem is funny )
20:48:52 <Nanar> (I remember as I wrote it :)
20:48:59 <boklm> it saves them somewhere on svn
20:49:09 <Nanar> misc: it's rpm...
20:49:27 <rda> could this be a bug entry then? :)
20:49:27 <Nanar> so the fault remains to the team making those rpms
20:49:38 <rda> noooo, don't slip on rpm matters :)
20:49:51 <ennael> ok so can we sump svn topic ?
20:49:54 <boklm> so everybody agree about import from src.rpm (keeping changelog), and separate spec files and binary files ?
20:49:59 <ennael> I guess misc was going to speak about soft/
20:50:01 <ennael> layout
20:50:13 <misc> i was about to send a email about it
20:50:18 <misc> basically it was about
20:50:26 <ennael> ok
20:50:30 <Nanar> so ok for rpms
20:50:31 <misc> "let's have 1 svn for each project instead of a big soft/ svn"
20:50:34 <Nanar> then soft/
20:50:36 <boklm> #agreed we will import all packages from src.rpm into svn so we have the separation between binary and source
20:51:23 * Nanar have code under soft/
20:51:46 <boklm> Nanar: you are talking about soft/ under mageia svn ?
20:51:58 <Nanar> mdv one
20:52:14 <Nanar> it's what we are talking about ?
20:52:19 <boklm> yes
20:53:08 <boklm> so, one svn repository for each project ?
20:53:13 <ennael> misc: can you sum up things here ?
20:53:28 <Nanar> per project ?
20:53:28 <ennael> would be great to take a decision so that parallel work can be done
20:53:31 <misc> ennael: sum up my mail ? or sum up the meeting ?
20:53:47 <ennael> mail :)
20:54:00 <misc> ok so basically :
20:54:18 <misc> I think one separate svn for each project make more sense for the following reason
20:54:45 <misc> - the current layout is slightly messy, there is upper level project, and some project holding other porject ( rpm/ theme/ buildsystem/ )
20:55:03 <misc> - backup and restoration are more complex on big svn than on smaller one
20:55:17 <misc> - there is some push for git in the community ( i have links )
20:55:28 <misc> - separate svn will ease this migration if needed
20:55:43 <misc> - separate svn will allow use to clean backup after the migration
20:56:01 <misc> - a split would also make more sense when we speak of a forge
20:56:36 <misc> - a split would also allow use to start more slowly and import only what is needed
20:56:45 * boklm is ok to split
20:56:54 <Nanar> ok so, rpm-setup is a very small project
20:57:30 <Nanar> I was able to create it because I didn't need specific access to create this svn part
20:58:07 <Nanar> so needing to create one svn repository for this is a bit "too much"
20:58:11 <Nanar> I think
20:58:28 <boklm> Nanar: we plan to have some kind of forge later, to manage creation of projects
20:58:41 <rda> how do you measure it is too small for its own repository?
20:58:59 <Nanar> how do you mesure it's too big ?
20:59:06 <misc> his point is valid, we need to have a way to automate
20:59:37 <rda> point is to version code that holds together as one consistent entity
20:59:37 <rda> I guess
20:59:55 <Nanar> morevover, having to do svn co URL each time I want to check something don't make me "happy"
21:00:09 <Nanar> I am talking only about soft/
21:00:17 <misc> Nanar: we can have a big svn with svn:externals if needed
21:00:41 <misc> and since we already have trunk/tags/base, you cannot really checkout more than one project
21:00:50 <misc> s/base/branch/g
21:01:25 <Nanar> aren't the solution in one trunk/ for all project ?
21:01:41 <Nanar> then branches/<project>/
21:01:46 <Nanar> ?
21:02:12 * wobo has news from CaCert about certificate, will mail to rda now
21:02:13 <Nanar> just my 2 cents :)
21:02:21 <misc> Nanar: well, that's not really how we do it now, so at least we agree that something need to be changed
21:02:27 <rda> wobo: why me? :)
21:02:42 <wobo> rda:  so you have it for the meeting ?
21:02:54 <rda> wobo: oh yess. thx.
21:02:54 <misc> but i think we should discuss this outside of the meeting, as I would also have blino input on this
21:03:05 <wobo> rda:  :)
21:03:14 * Nanar agree with misc
21:03:43 <boklm> we also need to decide about how we do the cleaning
21:04:46 <rda> I started to discuss a bit about this with blino, but no progress so far (was more about migrating icons to use drakconf theme - or better than it is now - it may be overkill for this import filtering thing)
21:05:00 <misc> boklm: yeah, but at least, we agree that we cannot import the whole svn
21:05:12 <rda> misc: did you put it in the summary? :)
21:05:19 <misc> #action discuss the svn split of soft on mageai-sysadm
21:05:20 <rda> boklm: we can discuss this by email later maybe?
21:05:21 <boklm> maybe we can make a copy of svn.mandriva.com/soft in a temporary repository that we use for cleaning only, then import each project when it is ready
21:05:37 <ennael> looks sensible
21:05:53 <ennael> and allows people to go on
21:05:54 <boklm> maybe have it in svn.mageia.org/soft-cleaning
21:06:26 <boklm> used only to do the cleaning work
21:06:39 <rda> yep
21:06:57 <boklm> while we clean, we have time to decide about new soft structure, and import projects one by one when they are ready
21:07:03 <misc> ok
21:07:27 <misc> #agreed setup a temporary svn for cleaning purpose
21:08:02 * misc need to go
21:08:09 <misc> ( next topic is logo selection )
21:08:18 <boklm> something else on SVN topic ?
21:08:41 <dmorgan> on svn no but for git/gitorious, this will need an other meeting ?
21:08:55 <boklm> yes
21:09:06 <dmorgan> ok
21:09:49 <boklm> so, next topic ?
21:10:04 <boklm> #topic Logo selection
21:10:08 <rda> so
21:10:25 <rda> all proposals are on http://www.flickr.com/groups/mageia-art/pool/
21:11:08 <rda> Caroline, dams, rtp and me did a short list based on rather objective criterias regarding guidelines and whether the proposal was adequate
21:11:18 <rda> and reduced a list of ~420 to ~80 proposals
21:11:42 <rda> which is this one: http://www.flickr.com/photos/54262247@N07/tags/mgared/
21:12:04 <rda> I mailed founders@ and marketing team on Friday about this and the following process
21:12:11 <rda> - shortlisting a bit more proposals
21:12:14 <coincoin> http://www.flickr.com/photos/tags/mgared/
21:12:20 <coincoin> better
21:12:29 <rda> coincoin: thanks
21:12:43 <rda> - putting this on -discuss and proposing to debate about it, leaving artists in the short list to refine
21:13:02 <rda> - leaving the founding board decide (the mageia.org board in last resort) on the logo to take
21:13:25 <rda> decision should be take into account discussions/feedback from the whole community, but is not tied to it.
21:13:32 <rda> s/should be/should/
21:14:11 <rda> deadline for discussion (for the board to go into "decision mode") would be this week-end, so we can announce the decision next week
21:14:25 <rda> (after having made sure with original artist that all legal matters are cleared)
21:15:12 <rda> then, logo will be worked on, usage guidelines and policies will be designed as well
21:16:33 <wobo> "<rda> deadline for discussion (for the board to go into "decision mode") would be this week-end" - do we have a "board" by next week?
21:16:38 <rda> ok, once again, I killed them all...
21:16:53 <rda> wobo: association board is: ennael, rtp and damsweb
21:17:00 <rda> however, founding board is the full list of all founding members
21:17:14 <wobo> Ah, didn't know the first part
21:17:36 * wobo is ok for the procedure
21:17:56 <rda> wobo: that's what the statutes say. but unless most founding member prefer not that they, the founding board, decide on this, it's the way to go.
21:18:09 <rda> ok, that makes at least two of us. :) others?
21:18:24 <coincoin> same for me :)
21:18:27 <wobo> rda:  I did not complain, I just did not know :)
21:18:44 <rda> wobo: ;)
21:20:42 <boklm> ok for me
21:21:21 <ennael> ok
21:24:47 <ennael> (looks like everybody fell asleep
21:25:14 <boklm> nobody seems to disagree :)
21:26:52 <rda> ok, so ... I will mail -discuss tomorrow about this anyway.
21:26:52 <rda> ok for me
21:26:52 <rda> (obviously)
21:27:50 * wobo has to leave, bye
21:28:10 <boklm> something else to say about Logo ?
21:29:43 <boklm> if not, we can close meeting
21:29:50 <ennael> yep
21:30:13 <dmorgan> i think this is OK we will see the discuss  on -discuss and have the week to choose
21:30:16 <coincoin> nothing for me
21:31:01 <boklm> if we close it in 6 minutes, it will be a 2 hours meeting
21:31:57 <rda> argh
21:33:06 <coincoin> :)
21:33:15 <boklm> 3 minutes
21:36:06 <boklm> #endmeeting