20:05:44 <misc> #startmeeting
20:05:44 <Inigo_Montoya> Meeting started Tue Nov  2 20:05:44 2010 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:05:44 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:05:57 <blingme> ennael: yes
20:06:07 <misc> #meetingname Founders meeting
20:06:07 <Inigo_Montoya> The meeting name has been set to 'founders_meeting'
20:06:08 <ennael> great :)
20:06:17 <misc> #chair ennael rda
20:06:17 <Inigo_Montoya> Current chairs: ennael misc rda
20:06:36 <misc> ok, so first point
20:06:39 <MrTom> could we give all our names so to know who's here ?
20:07:05 <misc> MrTom: we could
20:07:10 <MrTom> Thomas Canniot
20:07:14 <misc> Michael Scherer
20:07:34 <tmb> Thomas Backlund
20:07:34 <rda> Romain d'Alverny
20:07:35 <wobo> Wolfgang Bornath
20:07:39 <coling> Colin Guthrie
20:07:44 <president_goom> Olivier Méjean
20:07:44 <ennael> Anne Nicolas
20:07:45 <coincoin> Damien Lallement
20:07:52 <blingme> Buchan Milne
20:07:52 <rtp> Arnaud Patard
20:08:31 <misc> ok so first point :)
20:08:38 <misc> #topic review on build system planning
20:08:44 <misc> boklm and me, i guess
20:08:47 <misc> so boklm :)
20:09:19 <misc> ( or not )
20:09:31 <misc> so blino worked on setting up buildnode
20:10:02 * maat|alt opens an eye
20:10:06 <misc> he installed iurt, we have setup a dns alias
20:10:07 <boklm> oops, sorry, I was away
20:10:27 <misc> and I think he has updated the iurt package
20:11:05 <coling> cool
20:11:14 <boklm> and misc setup puppet on all nodes
20:11:59 <misc> #info iurt is installed, blino is working on finishing the setup and test
20:13:04 <misc> boklm: nothing to add on that ?
20:13:17 <boklm> maybe something about ldap ?
20:13:30 <misc> yeah
20:13:34 <boklm> misc: I think you setup ldap, but web interface is still missing ?
20:13:38 <misc> yep
20:13:53 <misc> i should have worked on it this weekend, but I was too busy for the moment
20:14:03 <misc> ( and I have some question for blingme )
20:14:04 <rda> what's needed on it?
20:14:05 <blingme> I was too busy coding
20:14:23 <misc> rda: basically, to set it up
20:14:47 <misc> i guess that's less than 1 day of work
20:14:58 <blingme> misc: are the questions too detailed for the meeting?
20:14:59 <rda> ok
20:15:13 <ennael> we could list the questions here ?
20:15:14 <blingme> or should we handle them later by email or on irc outside the meeting?
20:15:14 <misc> blingme: well, that's more about asking for password :)
20:15:28 <blingme> ah, for that I need to create an account for the application ...
20:15:28 <ennael> this is important enough to be soled here
20:15:30 <misc> and i do not have a list of questions
20:15:52 <blingme> misc: has ldap been migrated from where it was?
20:15:52 <misc> ennael: soled ?
20:15:58 <boklm> solved ?
20:16:11 <misc> blingme: the ldap directory is migrated on valstar yes
20:16:11 <boklm> or sold ?
20:16:24 <misc> blingme: and I also didn't received your ssh keys :)
20:16:28 <ennael> solved :)
20:16:53 <blingme> misc: I usually try and avoid accounts/access not in some ldap :-p
20:17:13 <blingme> misc: you can use what is on mandriva's ldap, or I will mail you now ...
20:17:19 <misc> blingme: ok
20:18:01 <blingme> are there any obstacles to getting CatDap running somewhere (besides dn/password/acls for app)?
20:18:53 <misc> nothing, I was planning storing the password outside of svn, that requires a puppet update that I have done 2 hours ago
20:19:28 <misc> only thing left is to decide how we interface it with apache, but that can be quite quick ( as i assume that everything will work equally )
20:19:32 <blingme> ah, ok
20:19:44 <blingme> misc: I've use mod_perl and fastcgi I think ...
20:20:26 <blingme> (screen and the built-in server doesn't work that well :-p)
20:21:03 <misc> blingme: well, I will go for mod_perl i guess, as I had issue in the past with fastcgi
20:21:44 <misc> anything to add on this topic ( boklm ) ?
20:21:53 <boklm> nothing for me
20:22:11 <misc> ok, so next topic
20:22:20 <misc> #topic review of mirror setup
20:22:41 <misc> so nanar gave me a paper, telling he could not be there because he went to the swimming pool
20:22:49 <misc> and so he asked me to take his place
20:23:03 <boklm> good excuse :)
20:23:07 <coling> Time for his annual bath then?
20:23:14 <ennael> :))
20:23:14 <misc> basically, nothing new, everything is in place, ibiblio started to mirror our empty tree
20:23:26 <misc> #info ibiblio mirror our server
20:23:40 <misc> everything still point on ryu, as there is nothing to share and no news
20:24:26 <misc> and so, i thik there is nothing to add, unless there is questions ?
20:24:27 <ennael> is it possible to write a planning for build system / mirrors for 2 coming weeks ?
20:24:35 <ennael> at least an estimation
20:24:49 <misc> writing it, yes, following it wil be more difficult :)
20:24:55 <rda> misc: is there a doc somewhere summarizing the whole thing?
20:25:00 <ennael> give us an idea at least :)
20:25:03 <misc> rda: i fear not
20:25:10 <misc> boklm: you have something ?
20:25:11 <ennael> that would be great
20:25:19 <rda> would be good to sum up something, from emails and current plans
20:25:22 <boklm> misc: no
20:25:43 <misc> for the mirror, the only thing left is to setup the web application afaik ( mga::mirrors )
20:25:45 <rda> so we can get more feedback on something clear
20:25:58 <rda> misc: what will be the role of the web app ?
20:26:07 <ennael> boklm: can you write it ?
20:26:08 <misc> rda: let people register their mirror, afaik
20:26:23 <ennael> boklm: or at least ask your slav^w^wmisc
20:26:26 <boklm> ennael: summary of things to do ?
20:26:29 <blingme> misc: where will the data go?
20:26:35 <rda> ok and is there something planned for exploiting/publishing the list of valid mirrors?
20:26:42 <misc> rda: afaik, yes
20:26:44 * blingme wonders if mirror maintainers aren't just like contributors ...
20:26:49 <rda> (like mirrorbrains or st else?)
20:26:58 <ennael> boklm: summary and planning
20:27:02 <boklm> ennael: ok
20:27:12 <ennael> boklm: we can hardly read in your brain
20:27:14 <misc> let me hack Nanar's computer to see :p
20:27:18 <ennael> or maybe with a fork :)
20:27:25 <boklm> :)
20:27:53 <ennael> again estimation but gives the big picture for this
20:28:06 <boklm> ok
20:28:27 <misc> #action boklm write a estimate on the planning for the next 2 week
20:30:14 <misc> blingme: so the application give a map of the mirror, a graph of the link, and let people filter by country, protocole
20:30:34 <misc> but nanar would be better to answer question on this
20:30:56 <blingme> where is the VCS for it?
20:32:38 <misc> blingme: no idea :/
20:33:19 <misc> #action misc ask Nanar for the information regarding his application
20:33:22 <ennael> misc: can you check with Nanar ?
20:33:45 <misc> ennael: yup, once he is back from swimming pool
20:34:22 <misc> what should I check, besides the location of the vcs ?
20:34:42 <ennael> is it already installed ?
20:35:00 <misc> nope
20:35:11 <misc> only on his workstation
20:37:09 <misc> he spoke of it at various time, but I cannot find where, so maybe I dreamed, or maybe I no longer see the difference between irc and irl
20:37:30 <ennael> maybe :)
20:37:34 <ennael> ok things to be checked then
20:39:46 <ennael> is that all ?
20:39:53 <misc> for me, yes
20:40:04 <ennael> ok
20:40:11 <misc> ( next topic is for stormi, but he is not here ? )
20:40:20 <misc> so I propose we go on logo review ?
20:40:23 <ennael> he will be there in1/2h
20:40:25 <ennael> yep
20:40:37 <misc> #topic planning for logos and design for Mageia
20:41:07 <misc> rda: up to you :)
20:41:14 <rda> well... we announced last week that submission deadline for logo proposals was further delayed to November 9th
20:41:17 * blingme was still going to put some magii onto a camel to enter ....
20:42:09 <rda> the founding board will then decide against requirements and after discussion on the best fit proposal
20:42:23 <rda> that should be reworked and integrated into the first alpha release, in December
20:42:39 <rda> official announcement of the logo would then happen on this alpha release occasion
20:43:08 <coling> Sounds sensible.
20:43:15 <rda> can't say much more to this point, unless you have questions
20:43:26 <ennael> about icons and so ?
20:43:36 <rda> ah yes
20:43:37 <president_goom> colors theme ?
20:43:49 <rda> colors will be derived from logo proposals,or added afterwise
20:43:49 * misc have lots of likely stupid suggestions and questions
20:43:54 <coincoin> :)
20:44:17 <rda> about icons: there will be huge work for the artwork team to redesign icons to replace Mandriva specific ones
20:44:37 <rda> a list has been created for the artwork team and they have been warned about this already.
20:44:43 <rda> but it still needs to be further organizee
20:44:45 * rda organized
20:45:06 <rda> ho, by the way, artwork team asked whether they could have some webdav space
20:45:13 <misc> i was about to ask this
20:45:15 <president_goom> icons will be created ?
20:45:18 <rda> president_goom: yes
20:45:27 <president_goom> care of the licence then ;)
20:45:29 <rda> guidelines to be gathered/written first
20:45:32 <blingme> how long is logo adoption on web sites expected to take?
20:45:34 <rda> president_goom: that is?
20:45:46 <misc> rda: they requirement is webdav, or just "a way to share files" ?
20:45:49 <rda> blingme: official mageia.org website will adopt the logo on release day
20:45:50 <president_goom> free license for created icons
20:45:55 <rda> misc: a way to share files
20:46:00 <rda> president_goom: well, yes
20:46:33 <misc> rda: can we have a contact to discuss requirement ?
20:46:34 <rda> #info mandriva specific icons to be replaced by new ones, to be designed by the artwork team
20:46:52 <misc> ( ie, do they need acl, versionning, something working on various os, etc ) ?
20:47:03 <rda> #action rda to relaunch artwork team about icons/colours guidelines/schemes
20:47:24 <rda> misc: various os is a must; versioning, not at this stage
20:47:34 <rda> misc: acl, no idea. will ask further and return to sysadm team
20:47:52 <rda> #action rda to ask further details to artwork team about sharing space
20:48:02 <misc> rda: also ask the expected size of file and total space
20:48:05 <rda> #info logo submission deadline on Nov 9th
20:48:28 <rda> maybe they will get along with a dropbox account as well, who knows
20:48:29 <misc> if they need passwords, this will requires some kind of ssl
20:48:58 <rda> #info official logo release to happen with the first alpha release
20:49:36 <misc> rda: well, I would have hoped to use a free software solution, but I guess that my requirements are not the one of others peoples :/
20:49:51 <tmb> apache + ssl + webdav
20:50:18 <rda> misc: that does not prevent people to use what they have at hand, saas stuff included
20:51:08 <misc> anyway, something to add on that topic ?
20:51:13 <rda> not for me
20:51:28 <misc> next one being the review of various events ( ennael, coling )
20:51:37 <rda> next then
20:51:40 <ennael> I have one not listed
20:51:43 <ennael> about wiki
20:51:45 <ennael> sorry for that
20:51:55 <rda> ok, go for wiki first?
20:52:00 <ennael> yep
20:52:20 <misc> #topic wiki and stuff
20:52:41 <ennael> MrTom: want to start ?
20:52:44 <MrTom> no please go ennael :)
20:52:50 <ennael> arf :)
20:53:01 <ennael> ok MrTom is coming from Fedora community
20:53:11 <ennael> and proposed us to give a hand on some various topics
20:53:15 <ennael> as wiki one
20:53:46 <ennael> so after having a look on mdv wiki he listed all topics inside and proposed a document
20:54:08 <ennael> trying to propose also a better way to organize things as we are starting from blank wiki
20:54:34 <ennael> ryu.zarb.org/~ennael/Mageia.org.pdf
20:54:48 <ennael> other task was to choose a wiki
20:54:59 <ennael> I added some items about this in document
20:55:08 <misc> ( canonical url would be http://www.zarb.org/~ennael/Mageia.org.pdf )
20:55:12 <ennael> as misc said it's kind of bullshit :)
20:55:20 <misc> i didn't say like this :/
20:55:38 <ennael> but that said in fact mediawiki seems to be the one to be chosen
20:55:55 <ennael> because of functionnalities, available languages
20:56:09 <ennael> misc: was just a short way to say it :)
20:56:16 <misc> does it support easyly to be installed as a wiki farm ?
20:56:27 <ennael> in fact I spoke with rda today
20:56:33 <ennael> as he was maintaining it in mdv
20:57:01 <ennael> we need to write some scripts to install instances in quite automatic way
20:57:04 <rda> well, somehow
20:57:16 <ennael> I let rda about this :)
20:57:18 <rda> I'm reviewing more recent releases and alternative ways to install it
20:57:22 <misc> so that's mhh, "no, unless we hack"
20:57:34 <rda> we always will have to hack
20:57:42 <rda> I don't see that as an issue
20:58:00 <misc> well, I do
20:58:02 <rda> or we can too stay on a single-language wiki
20:58:11 <rda> that will ease things a lot
20:58:34 <misc> not much
20:58:41 <rda> misc: why not?
20:58:54 <misc> from my discussion with some people who contribute to the wiki, some of them expect to have different and separated wiki
20:59:04 <misc> some people expect to have different language wiki
20:59:20 <rda> so?
20:59:20 <blingme> misc: why should they have different content?
20:59:22 <misc> and so, that's why I asked for requirement of the various people
20:59:31 <blingme> aren't there plugins for localising specific pages?
20:59:36 <rda> ok, but how does that oppose to this?
20:59:46 <misc> rda: i also assume that different team with different need will take care of them
21:00:02 <misc> which usually mean different plugin, different people taking care of this
21:00:29 <rda> so? I don't see your point
21:00:47 <rda> blingme: there can be, depends on the platform you choose
21:00:51 <misc> rda: well, not everybody is on the same wavelength regarding the wiki
21:01:09 <rda> blingme: as for any wiki, you have to balance the platform localization itself, and the content localization
21:01:10 <misc> so either everybody is since I lastly discussed since 2 days
21:01:26 <misc> or we need to be prepared to handle this flexibility
21:01:32 <rda> misc: ok, then, did all these people write down their requirements somewhere?
21:01:50 <misc> rda: maybe because we didn't ask them to do it ?
21:02:12 <misc> ( someone wrote it, but it was on a napkin in a pub that's mhh not qualifiable for requirement )
21:02:12 <ennael> if we ask everybody for what they want it will be just a hell
21:02:14 <rda> maybe
21:02:36 * MrTom agrees with ennael
21:02:52 <MrTom> give them a tool, they'll make the best of it
21:02:55 <misc> ennael: sure, but not asking at all would be like the old mandriva way
21:02:56 <rda> we can as well start with one platform that is decent/flexible enough for a specific direction (dev/tech docs) and let it open for other needs
21:03:20 <ennael> misc: can't you just share the ideas you already hear ?
21:03:46 <MrTom> misc moreover, the more plugins you add, the less updates to future are possible
21:04:10 <misc> MrTom: yup, that's why we should explain why we will not add them
21:04:35 <MrTom> misc it's just communication then, not asking people what they want
21:04:38 <rda> misc: or why they could have a different platform for a specific need
21:04:53 <misc> I have no problem to say no to anybody who request anything, with various level of insults. but that doesn't mean that's the thing to do to make sure that people are heard
21:05:20 <rda> it's not about saying no, it's about starting on something decent
21:05:41 <ennael> btw we speak about a wiki
21:05:41 <rda> and getting feedback for improving on this base or using others if useful
21:05:51 <ennael> we cannot make coffee with coffee...
21:06:28 <ennael> features list of mediawiki is one of the longest one...
21:06:34 <rda> anyway. misc, could you ask people that you discussed with to provide a list of their requirements?
21:06:39 <coincoin> can we make chocolate with chocolate? :p
21:06:47 <MrTom> and mediawiki is more than just a decent start
21:07:02 <misc> ennael: does it have ldap support ?
21:07:12 <rda> yes
21:07:30 <misc> so people who want to register are redirected to our server ?
21:07:39 <rda> yes
21:07:59 <president_goom> users that contribute to mandriva wiki knows how to use mediawiki, they will not have to relearn syntax
21:08:06 <misc> is it properly packaged ?
21:08:21 <misc> can it be installed several time without ugly hack ?
21:08:32 <Stormi> Hello
21:08:47 <ennael> misc: rda said it was possible
21:08:53 <rda> misc: it could be packaged, but in a specific way for mageia then
21:09:12 <rda> as for the multi-lingual setup, there are pre-config routines to write/execute
21:09:19 <rda> so that won't be a regular mediawiki package
21:09:26 <misc> ennael: well, you did the trick for wordpress once, and I fall for it :)
21:09:31 <ennael> :)
21:09:55 <rda> again, as a side note, not _all_ webapps will be packaged and released as such
21:10:15 <misc> rda: except that for the moment, no web application is
21:10:31 <misc> so again, we need to know who take care of what
21:11:03 <blingme> does that include plugins for the webapps ?
21:11:07 <rda> misc: it's not a matter of black/white responsibilities, but that will need to be shared between sysadm and webdevs
21:11:15 <rda> blingme: that is?
21:11:43 <misc> rda: well, it is a matter of what I am personnaly willing to do, and tarball is not on my whitelist, that's all
21:11:55 <blingme> will e.g. mediawiki plugins be packaged as well?
21:12:00 <misc> there is other sysadmins
21:12:21 <ennael> misc: you are not the only one in team :)
21:12:22 <misc> so I am only speaking for me
21:12:23 <rda> misc: it's not a tarball either :)
21:12:28 <boklm> it would be svn checkout, not tarballs
21:12:59 <rda> or it could be a capistrano-based script (or some equivalent)
21:13:26 <rda> blingme: it can, but again, it depends how we will manage the wiki (and what changes have to be applied for a multi lingual setup)
21:14:07 <misc> ennael: i never said I was, and I do not really intend to change anything, I just warn for less surprise
21:15:38 <ennael> rda: ok can we finalize technical requirement for wiki ?
21:15:38 <rda> ok, then, let's get this list of requirements if possible and dig this further.
21:15:51 <rda> for myself, I will keep on digging this multilingual setup
21:15:53 <rda> just in case
21:15:57 <ennael> ok
21:16:00 <rda> ennael: opening a page for that
21:16:12 <misc> anyway, i need to go, as the meeting started later than I expected :/ and I have nothing to eat
21:16:14 <ennael> about wiki structure is there any comment ?
21:16:31 <misc> ennael: this is *hum* heavily inspired from fedora :) ?
21:16:48 <ennael> #action rda will dig in multilingual setup for wiki
21:16:50 <ennael> misc: ?
21:16:50 <MrTom> misc you sure ?
21:16:57 <rda> http://mageia.org/wiki/doku.php?id=wiki_requirements
21:17:06 <misc> MrTom: at least the wording
21:17:24 <misc> but I need to go
21:17:24 <ennael> #info wiki requirementes page created http://mageia.org/wiki/doku.php?id=wiki_requirements
21:17:34 <rda> I'm ok about the structure, but I would still favor a flat layout (page titles, that is)
21:17:37 <misc> ennael: can you take care of the end of the meeting for me ?
21:17:44 <ennael> misc: yep
21:18:10 <ennael> rda: ok so we need to complete setup
21:18:31 <ennael> I can add wiki strcuture in dokuwiki
21:18:42 <rda> ennael: wiki structure, that is?
21:18:42 <wobo> rda: I've been opposing this flat layout years ago, I'm still opposing it today :)
21:18:50 <president_goom> rda: yes, that what we had for mandriva wiki
21:18:55 <ennael> rda: doc content
21:19:15 <rda> wobo: the issue is a non-flat layout will make unreadable page titles
21:19:41 <rda> ennael: ok
21:20:06 <coling> Is the order proposed in that wiki pdf the order it will be listed in menus etc?
21:20:14 <MrTom> coling no
21:20:21 <ennael> coling: just a list
21:20:26 <coling> Cool
21:20:33 <MrTom> this has not been defined as such
21:20:35 * coling felt that starting with bugs was a bit negative :D
21:20:36 <rda> coling: it's a list. it does not determines how things are being presented
21:20:56 <ennael> coling: :)
21:20:58 <MrTom> and it's not take it or leave it way of organizing the wiki
21:21:04 <boklm> on the main page, we will have the "Featured bug of the day !"
21:21:09 <rda> hmmm as a side note, one could consider two ways of using the/a wiki:
21:21:19 <rda> 1. having a wiki.mageia.org place or
21:21:20 <ennael> #action add a wiki page about organization (from document)
21:21:41 <rda> 2. having focused places (developer.mageia.org, doc.mageia.org, etc.) using a wiki
21:21:59 <rda> we're going for the former at this time
21:22:08 <rda> (won't prevent to move bits to the latter later)
21:22:10 <coling> I think in broad strokes the list looks good, but I'm not a massive consumer (nor contributor) to wikis so I'm not the most experienced in that area. But on the whole seems logical and sensible.
21:22:13 * boklm likes 2nd one
21:23:05 <ennael> outch 2d one means as many wiki as places ?
21:23:05 <president_goom> coling: the advantage with a wiki is that you can just write something, and ask someone else to help for layout
21:23:07 <coling> I'm not convinced lots of separate wikis on separate sub-domains necessarily really help matters (not intrinsically anyway)
21:23:07 <blingme> 2nd one could be an idea, but aspects you don't specifically cater to may feel rejected .....
21:23:09 <ennael> and more for translation ?
21:23:41 <rda> not more for translation
21:23:47 <coling> president_goom, oh I know, I do use them at work etc., but just not so much in the wider community (mainly due to my own time constraints)
21:23:52 <rda> that means more focused spaces, so indeed, more platform to deploy.
21:23:59 <rda> look at mozilla how they do that
21:24:45 <dmorgan> rda: or http://wiki.kde.org/
21:24:48 <rda> https://developer.mozilla.org/
21:24:57 <dmorgan> rda: this show 3 sections, for user, dev, community
21:25:11 <rda> dmorgan: yes, per target.
21:25:19 <rda> but that could be per focus/activity as well
21:25:25 <MrTom> i have to go, good night everybody!
21:25:38 <dmorgan> rda: yes we can't do differently for the sections
21:25:42 <dmorgan> rda: yes we ca do differently for the sections
21:25:46 <dmorgan> rda: yes we can do differently for the sections
21:25:49 <dmorgan> sorry
21:26:04 <blingme> the other project that may be worth looking at (how they do things) is meego
21:26:10 <coling> Thanks MrTom even if you likely wont see this :D
21:26:29 <tmb> (he can read the logs)
21:26:45 <rda> yep
21:27:00 <rda> thing is, anyway, to carefully build landing pages, especially the main home page
21:27:52 <boklm> it seems mozilla has both developer.mozilla.org and wiki.mozilla.org
21:28:07 <rda> so, let's try to do that with a single multi-lingual wiki setup first and we can see if we can evolve later, if needed
21:28:19 <rda> boklm: yep, but not same purpose
21:28:31 <tmb> well, start with wiki.mageia.org
21:28:33 <rda> boklm: developer is targetted to platforms and web developers
21:28:38 <boklm> wiki.mozilla.org seems to be used for meeting summaries and roadmaps
21:28:46 <rda> wiki.m.o is for the whole project organization
21:29:34 <boklm> ok
21:29:38 <rda> we could need to build a separate developer.m.o place later. it's important because it helps people to see we focus on them as developers on our platform.
21:29:47 <rda> not only as user or contributors.
21:29:47 <boklm> developer.m.o doesn't look like a wiki
21:29:58 <rda> boklm: it is. it was at least.
21:30:00 <dmorgan> boklm: no this doesn't
21:30:07 <dmorgan> seems like to be one
21:30:25 <president_goom> i fear that having various focused places could create unecessary barriers around different groups
21:30:32 <rda> https://developer.mozilla.org/en/Storage
21:31:13 <rda> why barriers? on the contrary, it focuses things where needed.
21:31:38 <rda> anyway. we can see this way later.
21:31:44 <president_goom> mediawiki has category, it could be used : category:user category:dev so on
21:31:44 <ennael> ok
21:31:49 <rda> other topic ? ennael ?
21:31:53 <ennael> yep
21:31:54 <rda> president_goom: that's still different
21:32:12 <ennael> #topic introducing mageia-app-db
21:32:24 <ennael> it's Stormi turn now
21:32:32 <Stormi> well
21:33:03 <Stormi> I proposed to build a web application dedicated to packages
21:33:22 <Stormi> dedicated mainly to end-users
21:33:59 <dmorgan> Stormi: with which goal ?
21:34:02 <Stormi> with a special focus on notifications (new update / new soft version)
21:34:30 <Stormi> I tried to explain this there : http://mageiacauldron.tuxfamily.org/MageiaAppDb
21:35:21 <wobo> don't they get notice of updates by an update applet?
21:35:28 <Stormi> yes of course
21:35:29 <dmorgan> Stormi: seems something i saw and loved on other distro like opensuse
21:35:45 <Stormi> here there's a special focus on user / tester / packager interaction
21:35:59 <dmorgan> wobo: seems from what i understood to see the new apps in a web page, with links to the bugreports of the app, etc...
21:35:59 <Stormi> like notifications when a new package needs testing
21:36:16 <Stormi> backports requests (and votes on backport requests), new softs requets
21:36:34 <wobo> yes, that's a good idea
21:36:50 <dmorgan> Stormi: ok nice but we should avoid to ask request for some apps as backports ( like KDE, dbus, ... )
21:36:53 <blingme> should we consider making information on packages available from within desktop tools
21:36:56 <dmorgan> Stormi: like a "blacklist"
21:37:15 <blingme> e.g., allow "rating" of packages on this app, and show this in rpmdrake ?
21:37:25 <Stormi> dmorgan: we'll see, packagers could indeed flag some packages as non backportable
21:37:26 <ennael> #info proposal for a web application dedicated to packages http://mageiacauldron.tuxfamily.org/MageiaAppDb
21:37:49 <dmorgan> Stormi: but your idea is really good
21:37:51 <Stormi> blingme: this is possible, in fact specs are not totally complete
21:38:08 <president_goom> that's a nice idea
21:38:12 <Stormi> here a roadmap proposal for now : http://github.com/agallou/mageia-app-db/wiki/ROADMAP
21:38:16 <ennael> Stormi: who is going to work on it ?
21:38:29 <ennael> # info roadmap proposal for now : http://github.com/agallou/mageia-app-db/wiki/ROADMAP
21:39:01 <dmorgan> we could ask on -dev for a work team for this, and with Stormi as manager as this is his idea )
21:39:04 <dmorgan> :)
21:39:08 <Stormi> ennael: me, ttp, several people proposed to test, and I hope more contributors as soon as I have announced the project on the MLs
21:39:32 <rda> Stormi: you can talk about this on the webteam@ mailing-list
21:39:40 <rda> as well, I mean
21:39:47 <Stormi> ttp and me alread started to build a database schema, and tried to see with Nanar how we can gather information on RPMs
21:40:11 <rda> Stormi: but first focus on it the two of you, not being too many to jump in the works
21:40:20 <Stormi> the basic idea would be mageia-app-db would focus on main package information + user interaction, and would ask sophie for more complex requests
21:40:22 <ennael> #info announcement will be done on ML to ask also some contributions
21:42:04 <ennael> rda: can we give access on svn for it ?
21:42:30 <rda> ennael: sure, but I'm not the one in charge here. :) however, I believe they are based on git already?
21:42:49 <dmorgan> rda: http://github.com/agallou/mageia-app-db/
21:42:49 <Stormi> rda: we can use git or svn either I guess
21:43:05 <rda> Stormi: up to you, it's your project first
21:43:06 <Stormi> we set up a github project in order to start, but the project's home can move
21:43:11 <boklm> we can wait for the svn/git server to be setup I think
21:43:21 <ennael> ok
21:43:36 <ennael> anybody here to give a hand on this project ?
21:43:42 <Stormi> rda: is it possible in some future to have svn + wiki + ticket tracking system ?
21:43:48 <ennael> #info project is hosted on http://github.com/agallou/mageia-app-db/
21:44:04 <rda> Stormi: something like trac? or does gitorious handle issues?
21:44:07 <dmorgan> ennael: in some years for me ( need to learn php :) )
21:44:15 <Stormi> rda: maybe, I don't know
21:44:28 <rda> Stormi: we'd have to see if we use mageia bugzilla for that or some separate forge
21:44:30 <Stormi> trac is good, redmine too
21:44:48 <rda> Stormi: as well as Mageia wiki (or a more specific for projects wiki)
21:45:22 * coling will have to go in 15mins
21:45:28 <Stormi> I'd be in favor of using mageia wiki as soon as it is available, and moving the project to a mageia git or svn server
21:45:32 * ennael would like a github or whatever so that we can have a better way to promote all Mageia projects
21:45:49 <rda> define better
21:45:56 <dmorgan> ennael: what the advantage of github ?
21:46:01 <rda> because there's a tradeoff to mix all within a single wiki
21:46:05 <boklm> ennael: you mean gitorious ?
21:46:13 <ennael> arf yes gitorius sorry
21:46:33 <rda> here, that's an example where we could gain from not mixing too many different topics within a single wiki
21:49:03 <blingme> or a forge setup?
21:49:29 <rda> that would be a gitorious instance, then
21:49:37 <ennael> anything like that
21:49:47 <ennael> we had a discussion in mdv about this
21:49:55 <ennael> gitorious and redmine were in short list
21:50:04 <rda> gitorious does repository+wiki, per project
21:50:15 <Stormi> redmine too afaik
21:50:21 <rda> but seems not to have issue tracking
21:50:33 <rda> redmine does git and svn or?
21:50:48 <Stormi> rda: git for sure, and I heard a colleague had it work with svn
21:50:55 <rda> k
21:51:03 <rda> well, that's another topic for a list of requirements
21:51:13 <rda> but having a place to better display separate projecfts within mageia is a must
21:52:05 <ennael> yep
21:52:39 <wobo> Another "must" is that whatever we do, all this must be reachable from the main Mageia start page (as a side note).
21:52:44 <blino> the commit/log interface is not very user friendly on gitorious
21:52:48 <blino> gitweb is better
21:52:49 <rda> wobo: sure
21:53:02 <rda> wobo: well, maybe with one or two levels of access
21:53:11 <rda> we can't list everything on the single start page
21:53:31 <ennael> gitorious is not only about brosing git repository it's a web portal for a project
21:53:36 <wobo> rda: I know :)
21:53:44 <ennael> browsing
21:53:49 <ennael> anyway that's another topic :)
21:54:01 <ennael> anything else on magiea-app-db ?
21:54:34 <Stormi> there will be hosting questions, and I may need security reviews when a first version is ready
21:54:59 <blino> but the browsing part of gitorious seems to be perfectible, for example http://qt.gitorious.org/~jeffwannamaker/qt/jeffwannamakers-qt/commits/4.7 does not work, because the log is too big
21:55:00 <ennael> mmm coling ? rda ? can you help on this ?
21:55:00 <Stormi> not sure yet, but the app may have to have access to a local mirror structure
21:55:18 <coling> Yeah perhaps, depending on my day job work constraints.
21:55:24 <Stormi> (or get everything from sophie, that's also an option)
21:55:25 <ennael> ok
21:55:46 <ennael> #action find people for security reviews when a first version is ready
21:55:54 <rda> ennael: Stormi: sure I can review
21:56:05 <ennael> great
21:56:09 <ennael> #undo
21:56:09 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x828d6cc>
21:56:09 <rda> Stormi: be sure to graph (mindmap or other) requirements for your app
21:56:24 <ennael> #action find people for security reviews when a first version is ready (coling, rda)
21:56:44 <Stormi> we'll need also guidelines for application design if we want some coherency with the mageia websites
21:56:59 <rda> Stormi: that's the UX/design thing
21:57:12 <rda> and that can come later - first focus on your app usability
21:57:12 <coling> I presume you mean not so much application design per-se as the views
21:57:34 <Stormi> coling: yes, I mean the apparence
21:57:48 <Stormi> I suck at making things pretty :)
21:57:52 <ennael> #action contact web team and design team for guidelines about design policies
21:58:12 * coling too :D
21:58:22 <Stormi> there are also some parts of the project which will have impacts on processes
21:58:29 <Stormi> (backports, testing, ...)
21:58:48 <Stormi> we'll have to reach agreements on this before they're put in an app
21:59:01 <rda> well... yes, but try to have a flexible system
21:59:07 <Stormi> rda: yes also
21:59:11 <rda> so that processes are neither constrained by your app, and your app by processes
21:59:22 <rda> because your app will likely be a proposal platform for processes evolution
21:59:28 <Stormi> indeed
21:59:28 <rda> and may be updated afterwise as well
22:00:52 <Stormi> for example, we need to differentiate security/bugfix updates from version updates
22:00:59 <Stormi> (ie today updates vs backports)
22:01:17 <rda> Stormi: AFAIK, these are differentiated in update packages
22:01:17 <ennael> ok maybe this can be discussed on ML to complete specifications
22:01:26 <rda> (at least they were in the old mandriva online service)
22:01:34 <Stormi> ok
22:01:53 <ennael> unles there are some questions we can end the meeting
22:01:59 <ennael> (2h already)
22:02:02 <Stormi> :)
22:02:30 <ennael> ok thanks all
22:02:34 <ennael> #endmeeting