18:04:30 <misc> #startmeeting
18:04:30 <Inigo_Montoya> Meeting started Mon Oct 18 18:04:30 2010 UTC.  The chair is misc. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:30 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:04:36 <misc> #meetingname Founders meeting
18:04:36 <Inigo_Montoya> The meeting name has been set to 'founders_meeting'
18:04:48 <misc> #chair misc ennael
18:04:48 <Inigo_Montoya> Current chairs: ennael misc
18:05:01 <misc> #topic hosting
18:05:08 <misc> ennael, you may start
18:05:12 <ennael> ok
18:05:20 <misc> 'hosting organization, first expenses (anne, boklm dams)' in fact
18:05:38 <ennael> so as you may have seen, we have now a full hosting solution
18:05:57 <ennael> ielo.net will sponsorise all hosting cost for all of our servers
18:06:26 <wobo> 3 cheers to ielo.net!
18:06:28 <ennael> the thing now is to bring the server to datacenter which is in Marseille (south of france)
18:06:32 <ennael> yes :)
18:06:40 <ennael> it's about 900 km from paris
18:07:16 <ennael> so damsweb and boklm are looking for power switch to be able to manage reboot
18:07:28 <ennael> also ielo.net can change disks if needed
18:07:33 <misc> no IPMI on the server ?
18:07:43 <ennael> finally maat|alt is ok to help us if needed
18:07:51 <maat|alt> yup
18:07:52 <ennael> he lives at 40 km from datacenter
18:08:14 <ennael> so first expenses for now will be to change all disks on servers
18:08:19 <ennael> to avoid any pb
18:08:27 <ennael> buy a power switch
18:08:39 <misc> #info servers need to be moved to marseille in ielo.net datacenter, 900 km from paris
18:08:40 <ennael> and pay for travel for 3 guys
18:08:48 <ennael> misc, boklm and damsweb
18:09:00 <ennael> we need also to buy a backup server
18:09:19 <ennael> so DD + power switch + server should be about 2500 €
18:10:10 <misc> #info we need to buy some hardware ( hardrive, power switch by ethernet, a backup server), for 2500 e
18:10:16 <ennael> damsweb plans to buy disks tomorrow
18:10:34 <ennael> and install servers with boklm on wednesday
18:10:52 <ennael> if it's possible they will leave thursday to Marseille
18:11:02 <ennael> and finalize installation in datacenter on friday
18:11:16 <ennael> this is the first plan
18:11:29 <ennael> now we have big strikes in france and gasolin is missing...
18:11:41 <misc> and there is even bigger strike in Marseille
18:11:41 <ennael> so all will depend on how we can manage  travel
18:12:50 <misc> for the backup server, I assume it will not be ready for the end of the week, what is the plan ?
18:13:20 <ennael> looks like damsweb knows somebody who is going back to marseille in 3 weeks
18:13:33 <ennael> so we could install it and she will bring it in marseille
18:13:40 <ennael> maat|alt could install it then
18:13:44 <ennael> if he is ok
18:14:12 <maat|alt> i'll force him to cooperate if needed ;)
18:14:37 <misc> well, how long does it take to be bought ( given the strike ), is it easy to move ( cause I fear the size of a beast with lots of disk )
18:15:11 <misc> and since we do not have yet a bank account, how can this be payed without legal problem ?
18:15:53 <ennael> I spoke with regine from AUFML
18:16:04 <ennael> she told me she will manage this
18:16:14 <ennael> the only thing we have to do is to keep all documents
18:16:20 <ennael> so no pb on that side
18:16:21 <misc> ok
18:16:47 <misc> but my main issue will be with the weight
18:17:01 <ennael> in car ?
18:18:10 <misc> depend on the car, on the server, but I guess that's up to damsweb to take care of this
18:18:25 <ennael> yep
18:18:32 <ennael> we will rent a car for this
18:18:51 <ennael> we found some cheap price for this
18:19:32 <ennael> ah speaking about duck
18:19:44 <coincoin> hello all, sorry to be late (subway #13 is a pain)
18:19:44 <ennael> coincoin: what about servers weight in car ?
18:20:19 <coling> cool. That sounds like it's all in hand (more or less). Thanks to misc damsweb and boklm for the work needed to install+install physically.
18:20:23 <coincoin> ennael: will be ok, arround 10 kg each server
18:20:52 <coincoin> and we have 4 servers so...
18:21:03 <misc> only ?
18:21:42 <coincoin> yes, as written on the wiki
18:22:02 <coincoin> + 2 VMs (gandi) and 1 server to buy for backup
18:22:50 <misc> ok, i tought the 6U would be much heavier than that
18:23:12 <coincoin> we don't have any 6U anymore
18:23:32 <coincoin> but yes, the 6U were 40kg each one
18:24:10 <misc> good, I didn't dream last time I had to rack a server :)
18:24:24 <ennael> :)
18:24:27 <coincoin> :)
18:24:40 <misc> so anything to add on this topic ?
18:25:07 <ennael> I guess not
18:25:26 <ennael> coincoin will mail to inform about Marseille travel ok ?
18:25:53 <coincoin> yes, I just have to be sure with my "cousine" first ;)
18:26:08 <coincoin> she called me tonight, I must phone her again after the meeting
18:26:19 <misc> #action coincoin take care of the travel
18:26:26 <ennael> ok
18:26:33 <misc> so, next topic, ldap
18:26:42 <misc> #topic LDAP and GUI for registration
18:26:50 <misc> bgmilne, maat ?
18:26:50 <ennael> unfortunatelly seems buchan is not there
18:27:02 <coling> Indeed, could be a short topic :D
18:27:13 <ennael> can we postpone for now ?
18:27:16 <misc> we can
18:27:18 <ennael> maybe he will appear
18:27:23 <misc> #info topic postpone for the moment
18:27:39 <misc> #topic first official pieces/tendances for Mageia roadmap
18:27:46 <misc> ( this one is gonna take time I fear )
18:28:16 <misc> ennael: no one was listed, so it is up to you :)
18:28:16 <ennael> yep
18:28:17 <rda> :)
18:28:49 <ennael> well I listed it as many discussions are implying roadmap and I guess we should have some official position
18:29:00 <ennael> at least think about it this week
18:29:29 <misc> well, I think that "first, let's setup the infra, then discuss" would have been a good roadmap :)
18:30:16 <ennael> why do we need to wait for infra ?
18:30:19 <tmb> yeah, but the users want something to debate :)
18:30:21 <ennael> as it's on the way
18:30:23 <rda> misc: yep, however, you see how discussions are going :)
18:30:32 <misc> like intel proc, it seems that most people use OoOE
18:31:11 <misc> ennael: by infra, I mean the whole system, ie once we have lists, and a release out there
18:31:35 <ennael> I mean have  a plan for 6 coming months
18:31:50 <rda> and laying down topics for improvements for the next months.
18:32:00 <rda> (topics, formal procedures)
18:32:12 <ennael> we need to give some answers about what software to be included in diostro
18:32:13 <rda> so, if we were to detail a roadmap until, say, end of december?
18:32:15 <ennael> licenses, ....
18:32:34 <rda> this, for instance, could be designed before releasing an ISO: http://mageia.org/wiki/doku.php?id=policies
18:33:01 <wobo> roadmap depends on ressources. We will know all ressources not before we need them, so a real roadmap is not possible before that.
18:33:25 <misc> rda: designed before, or designed in th same time ( ie, in a decoralated way, side by side ) ?
18:33:35 <rda> misc: side by side.
18:33:44 <misc> k
18:34:11 <misc> so by roadmap, you mean more a task list ?
18:34:37 <ennael> if you want
18:34:44 <rda> yes, plus tasks more specific to teams, plus expectations for the december iso ?
18:34:49 <ennael> what people can expect in 6 coming months
18:35:33 <misc> so, the big question is "who write it" ?
18:36:39 <ennael> we should be several guys on it
18:37:00 <coincoin> I'm ok to take part on this group
18:37:09 <misc> ideally, each team could take care of the roadmap part of the team ?
18:37:12 <coincoin> I hope I won't be alone :p
18:37:26 <ennael> we need all teams
18:37:32 <ennael> not only us
18:37:34 <misc> yeah
18:38:21 <misc> well, I would maybe help, but I am not sure that I can find much time for this :/
18:38:48 <misc> but i am ok to help for the packaging part and so on
18:39:05 <ennael> I can help also
18:39:08 <rda> I can help too
18:39:14 <ennael> rda: we need a mkting guy
18:39:20 <rda> ennael: :)
18:39:24 <ennael> and some representatives from communities
18:39:26 <ennael> wobo: ?
18:39:39 <coincoin> me too assaid, and I think rtp can be part of the forum team to help for the roadmap :)
18:39:43 <rda> ennael: have an idea about it
18:40:00 <misc> so, the deadline for the roadmap would be ?
18:40:06 <wobo> ennael: yes
18:40:11 <rda> ideally, this would be made of council people, if they were elected. but we can bootstrap it this way.
18:40:38 <ennael> misc: what about end of next week ?
18:40:39 <rtp> coincoin: stop trolling. please remember that this meeting is logged :)
18:40:45 <coincoin> rtp: :)
18:41:12 <misc> ennael: around 30 october ?
18:41:20 <ennael> yep
18:41:54 <coincoin> for a draft or for the final version?
18:42:07 <ennael> good question :)
18:42:13 <coincoin> :)
18:42:14 <rda> final I'd say.
18:42:14 <ennael> I guess final draft ? :)
18:42:17 <rda> so we keep it short.
18:42:41 <coincoin> so 30 october for a RTM? :)
18:42:48 <misc> #action ennael rda coincoin misc write a roadmap for the next 6 months ( final draft for 30th october )
18:42:50 <rda> moreover, the roadmap should allow to prioritize items in it, so we know what to focus on absolutely, and what could wait
18:43:02 <ennael> wobo: can you help on this ?
18:43:10 <wobo> in what part?
18:43:40 <misc> #undo
18:43:40 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x827cc6c>
18:43:46 <ennael> working on a roadmap for coming months
18:44:02 <wobo> yes, but in what respect?
18:44:17 <ennael> aspect ?
18:44:23 <wobo> yes :)
18:44:26 <ennael> :)
18:44:37 <ennael> well as user community representative
18:45:02 <ennael> it will deal with iso, repositories, communication, spread mageia in local communities...
18:45:47 <wobo> yes, ok, as for the Germans we are prepared for all this :)
18:45:55 <ennael> ok great
18:46:13 <misc> #action wobo ennael rda coincoin misc write a roadmap for the next 6 months ( final draft for 30th october )
18:46:53 <misc> ok so anything to add on that part ?
18:47:19 <ennael> nope
18:47:23 <misc> good
18:47:30 <misc> so, next topic
18:47:45 <misc> #topic Review of repository structure / License management
18:47:51 <misc> Anssi: up to you :)
18:48:14 <Anssi> right
18:48:34 <Anssi> there are actually quite a few things to decide
18:48:57 <Anssi> as seen in http://mageia.org/wiki/doku.php?id=software_inclusion_policy
18:50:03 <Anssi> should we keep the main/contrib separation, for instance?
18:50:11 <misc> i think the question was a little bit too broad on the ml
18:50:21 <misc> so the discussion was "fragmented"
18:50:31 <Anssi> misc: true, I noticed that too late :)
18:51:13 <misc> so I would start by categorizing the various question ( as some of them are interleaved and depend on each others )
18:51:31 <rda> a first question could be: if we use 100% free software, do we end up with something easily installable/usable?
18:51:38 <rda> misc: like?
18:52:10 <misc> let me seek
18:52:38 <wobo> misc: this question depends on what kind of distribution Mageia wants to be :)
18:52:43 <Anssi> rda: well, there are two related issues to that... proprietary firmware and proprietary drivers
18:52:53 <misc> for example, the discussion about decss is someone linked to the one of patent
18:53:20 <rtp> rda: you can have trouble with network drivers needing firmware
18:53:31 <rda> misc: yes, so does the list on the wiki page makes valid categories, to manage each separately, in some way?
18:53:37 <rda> (to have a progressive thinking)
18:53:48 <Anssi> yep.. it is difficult to download the firmware afterwards if you do not have network out-of-the-box
18:53:53 <rda> rtp: trouble like, not working without a non-free driver you mean?
18:53:57 <rda> Anssi: sure :)
18:54:13 <Anssi> rda: not working without a firmware (like TG3, which is quite common)
18:54:24 <rda> ok, so that means that, although we could ship a pure free software release, we neeed to release at least one with non-free stuff.
18:54:55 <misc> well, I personnally think that the mdv approach was good ( if we could have cleaned the policy with regard to patent to be at least consistent )
18:54:58 <tmb> well that's like free/one...
18:55:05 <rda> (I mean, we need to be explicit in choices, from the very bottom, to avoid any useless discussions)
18:55:16 <Anssi> rda: another thing is that the open source radeon drivers require non-free firmware as well
18:55:21 <rtp> misc: the mdv approac was quite "blurry" imho
18:55:22 <misc> rda: you are optimistic about avoiding useless discussion :)
18:55:26 <rda> misc: :)
18:55:29 <Anssi> (at least if acceleration, that is)
18:55:33 <Anssi> s/if/for/
18:55:40 <rda> misc: about the patent issue, in general, I don't know if we can have a consistent policy. having read the VLC legal FAQ, I wonder...
18:56:30 <rda> we can have a basic rule stating: use Free Software whenever possible. Use non-free when needed, still promote/fund alternative developments.
18:56:31 <rda> for a start.
18:56:34 <president_goom> to have a consistent policy we must decide under which law the project lives
18:56:49 <misc> rda: well, we can also have a policy of case per case basis decided by council after listening to community
18:56:52 <rda> president_goom: first, decide what we want to do, then check the law setup.
18:57:07 <president_goom> i mean, for debian, fedora, RH, OpenSuse it is clear, they are in USA then they follow US laws
18:57:23 <rda> misc: yep, too. but it can be a good stance to have a claimed policy, with an explicit process, and in last resort, council decision.
18:57:30 <ennael> president_goom: proprietary drivers stays proprietary whatever the country
18:57:39 <Anssi> president_goom: yes, but their patent policies differ anyway
18:57:45 <president_goom> that's very noticeable on RH policies when they talk about exportation restriction due to US Laws
18:57:47 <tmb> well, if we split firmware in separate tree, and keep it disabled on a "Free Install", and then people can choose to install the wanted firmware ...
18:57:52 <rda> ok, so that's the point: we must discuss issues separately. do not mix patent issues with non-free ones.
18:57:54 <misc> rda: we can also o the reverse, start with case by case and then, based on decision, flesh out a policy
18:58:04 <president_goom> ennael: i don't talk about proprietary softwares
18:58:17 <rda> misc: yes. but I would be quite extreme, then. but that's me. :-p
18:58:25 <boklm> are you talking about ISO or repository ?
18:58:34 <misc> rda: well, that worked quite well for most legal system, in fact
18:58:37 <rda> boklm: both, we're speaking at the general level.
18:58:38 <president_goom> i talk about free softwares that might break software patents
18:58:52 <misc> anyway, I think we are heading to repeating the same discussion on ml
18:58:57 <rda> yes
18:59:00 <misc> and I still plan to finish under 2h, so
18:59:01 <rda> let's take issues one by one.
18:59:03 <tmb> I'd like the "core" repo to be GPL-only...
18:59:12 <rda> first, discuss the free vs. non-free.
18:59:12 <president_goom> they break patents if patents on software are legal, if not you can't break illegal patent
18:59:21 <Anssi> tmb: or OSI-free only, I guess
18:59:23 <rda> second, discuss patent issues.
18:59:31 <rda> tmb: what would the "core" there?
19:00:25 <rda> ok. I suggest we don't repeat the discussion here.
19:00:44 <rda> and that we lay it down step by step on the wiki, plus adhoc discussions.
19:00:48 <misc> yup
19:00:50 <rda> first, what do we include in the distribution at large.
19:00:53 <president_goom> free vs non-free (proprietary) : if redistribution is allowed, non-free softwares goes to non-free repo
19:00:56 <rda> then, how do we map this on medias.
19:01:30 <misc> we could also decide to keep the same medias than mandriva to start and then change after the first release
19:01:48 <rda> that could have the advantage of not delaying the first ISO, yes.
19:01:49 <tmb> maybe core/firmware/non-free/games
19:02:04 <misc> ( as one goal were everybody agreed so far is to ave a release soon, and I fear this discussion is likely to delay release )
19:02:05 <rtp> misc: you're talking of non-free/restricted ?
19:02:12 <rda> tmb: games need a full dedicated media? :)
19:02:15 <misc> rtp: i am talking of everything
19:02:19 <ennael> uh ?
19:02:32 <misc> rda: for size reasons, this was discussed
19:02:48 <rda> oh ok
19:02:56 <tmb> rda: yep. we have a lot of gamers, that maybe all dont want to mirror
19:03:10 <misc> ( i am against it for consistency reasons, but I understand the reasoning )
19:03:26 <rda> hmm maybe stupid idea, but following this, why not split media per type of activity? (for specialized apps)
19:03:29 <Anssi> well, currently on mandriva non-free firmware location is arbitrary (some are in main, some in non-free)... but I guess it could be accepted as a temporary solution..
19:03:58 <tmb> Anssi: well, we can clean that up.
19:04:01 <misc> rda: then this will become hellish from a rpm deps point of view
19:04:11 <rda> misc: probably, yes
19:04:18 <misc> if we can clean now, we can clean later too /o\
19:04:24 <rda> :)
19:04:30 <misc> ( procrastination FTW )
19:04:35 <rtp> :)
19:04:56 <rda> ok, I can help laying down the structure for the work on software inclusion, if someone can help too and others provide input.
19:05:10 <misc> no one found urgent to clean mess on mandriva mirror in the past, and so I think we can still wait a little for this now
19:05:23 <rda> (I'll likely only check that the work document looks consistent and structured)
19:06:18 <tmb> do we need a "unmaintained" tree too ?
19:06:42 * tmb looking on many unmaintained rpms in mdv repo
19:06:50 <misc> well, we could one :)
19:06:57 <rtp> misc: my guess is rather lack of time or lack or will
19:07:19 <rda> shall we go on next topic?
19:07:31 <misc> well, so what do we decide on this ?
19:07:37 <wobo> One remark: As for the ISOs: there's but one type of proprietary software needed on all ISOs: firmware for WiFI - number of WiFi-only machines/networks are increasing.
19:07:46 <misc> ( except the obvious, ie that's a little it messy )
19:07:46 <rda> I'd say, work on it this week, let's review progress next monday)
19:08:04 <misc> and so who work on this ?
19:08:18 <Anssi> wobo: and firmware for graphics cards? or ethernet cards? :)
19:08:21 <rda> and keep existing layout for the first release most probably (unless we come up with something quick and easy)
19:08:22 <ennael> carefull roadmap doc can take time also
19:08:32 <misc> yup
19:08:51 <misc> well, Anssi, tmb, president_goom , you can work on the document ?
19:08:51 <ennael> I guess we have enough people to share wok
19:08:54 <ennael> work
19:08:58 <ennael> wok is for diner
19:08:58 <rda> ennael: so we review progress in two weeks then?
19:09:00 <coincoin> :)
19:09:20 <wobo> Anssi: firmware for graphics can be taken over the network, network cards - do they need a non-free firmware?
19:09:27 <tmb> ennael: ok for me
19:09:32 <Anssi> wobo: some do
19:09:43 <president_goom> ok for me
19:09:48 <rtp> wobo: yeah, there are ethernet drivers which need  firmware
19:09:50 <wobo> Anssi: ok, so all firmware needed for net access
19:10:08 <erwan_taf> wobo: +1
19:10:24 <misc> ok so Anssi tmb president_goom work on the document ?
19:10:24 <tmb> wobo: I think any "One" type iso needs all firmware for net access and graphics...
19:10:25 <Anssi> misc: I think so
19:10:42 <ennael> yep
19:10:48 <rtp> tmb: as long as we're allowed to dribute them imho
19:10:56 <rtp> err distribute
19:11:11 <tmb> rtp: of course, that goes without saying...
19:11:12 <wobo> tmb: I'm talking about ALL isos.
19:11:22 <Anssi> yes, of course, I think everyone agrees that we shouldn't distribute non-distributable firmware
19:11:28 <Anssi> (ubuntu does, though)
19:12:12 <misc> president_goom: ok to work on the document with Anssi and tmb ?
19:12:18 <tmb> wobo: well, IMHO a ISO marked "Free" should be free only...
19:12:18 <president_goom> yes misc
19:12:48 <misc> #action Anssi tmb president_goom work on the various questions for 30th october
19:12:51 <wobo> tmb: yes, but it's not usable with a WiFi only machine
19:13:15 <misc> next topic ? ( association creation )
19:13:18 <rtp> wobo: you can use usb storage to install the firmware, no ?
19:13:39 <ennael> misc: ok
19:13:49 <misc> #topic association creation review
19:14:03 <misc> coincoin, up to you :)
19:14:06 <coincoin> go go go
19:14:30 <coincoin> so, the file is now in the hand of the administation
19:14:31 * misc also redirect rtp and wobo to discuss of technical detail on -dev :p
19:14:59 <coincoin> I receive a paper yesterday saying that the process is officialy launched
19:15:23 <coincoin> we still need to wait 3 weeks to have the association created
19:15:25 <rda> I received today the paper confirming the Mageia trademark registration in France
19:15:39 <rda> (need to extend it now)
19:15:49 <wobo> rda registered on whose name?
19:15:51 <Fredxx> coincoin: have you read my comments ont the statutes
19:15:53 <coincoin> during this time ennael and I will go the the bank to open (next week as I will be in Marseille) a bank account for Mageia.org
19:16:00 <misc> #info Mageia trademark is official
19:16:05 <rda> wobo: mine for the time being. will be transfered to the association as soon as possible.
19:16:13 <wobo> rda thx
19:16:17 <misc> #info ennael and coincoin will go to the bank
19:16:24 <coincoin> Fredxx: yes but too late as the file was already at the prefecture (we will see for an AGE)
19:16:34 <Fredxx> coincoin: yes, sure
19:16:42 <misc> #info process is launched for association review
19:17:08 <coincoin> I have the number of registration which allow us to open a bank account
19:17:39 <coincoin> but we won't be able to use the money on this bank account before the end of the process of the creation of the association
19:17:59 <wobo> coincoin: what exact kind of association was founded, what legal form of association?
19:18:15 <coincoin> wobo: a non for profit association
19:18:17 <rtp> coincoin: please remember to ask me for the paper before going to the bank :)
19:18:29 <coincoin> wobo: "loi 1901" in french
19:18:34 <misc> wobo: law 1901
19:18:36 <coincoin> rtp: yes sure
19:18:40 <Fredxx> wobo: non profit organisation
19:19:01 <wobo> coincoin: yes, but what is the exact name (to be translated in future)
19:19:10 <ennael> Mageia.org
19:19:28 <wobo> ennael: no, the kind of association?
19:19:31 <coincoin> wobo: ennael was to reactive :p
19:19:32 <ennael> erf
19:20:07 <rda> wobo: "une association à but non lucratif qui relève de la loi du 1er juillet 1901"
19:20:17 <ennael> :)
19:20:21 <rda> that's how we call them in France
19:20:22 <ennael> say it in german :)
19:20:23 <coincoin> "a non-profit association" (loi 1901 in french)
19:20:29 <wobo> to explain: in Germany we have GmbH, Stiftung (Foundation), etc.
19:20:48 <rda> wobo: it's not a foundation (would need a big pack of money to start)
19:21:01 <coincoin> wobo: http://en.wikipedia.org/wiki/Non-profit_organization
19:21:01 <rda> wobo: I believe GmbH is more like SARL or SA for companies in France
19:21:06 <wobo> rda: yes, I wanted to give examples
19:21:24 <rda> wobo: so "association loi 1901" is a type like this in itself.
19:21:25 <wobo> examples for what I was asking for
19:21:33 <Fredxx> wobo: we have some details to fix after the creation
19:21:54 <wobo> Fredxx: so I heard, yes
19:22:03 <coincoin> wobo: in France we just say "Association" so "Mageia.org Association"
19:22:07 <teuf> associations loi 1901 are more or less described in http://en.wikipedia.org/wiki/1901_French_law_on_associations
19:22:23 <coincoin> teuf: thank you sweety
19:22:34 <wobo> coincoin: teuf: thx, that helps :)
19:22:43 * boklm was going to past the same link :)
19:22:48 <misc> well, so while I do not want to deprive wobo of explanation and so on, is there anything to add on the topic, or we can switch on next one ?
19:22:59 <coincoin> misc: not for me
19:23:17 <misc> ok
19:23:22 <misc> #topic code of conduct
19:23:29 <misc> ennael: up to you
19:23:37 <ennael> erf
19:23:39 <ennael> oups
19:23:40 <ennael> ok
19:24:01 <ennael> so we did not discuss it yet but I guess it would be nice to have one
19:24:10 <ennael> as we did wih cooker-chef group
19:24:35 <ennael> to help managing  relations and underline potential pb
19:24:57 <ennael> so I took the one we did for Mandriva
19:25:08 <ennael> and put it on wiki to propose for Mageia
19:25:17 <misc> the mageia wiki ?
19:25:21 <ennael> not yet
19:25:27 <ennael> valstar one
19:25:36 <misc> #action put the code of conduct on the wiki
19:25:40 <ennael> it would be for Mageia all teams
19:25:47 <ennael> it would be for all Mageia teams
19:26:04 <ennael> I guess wobo read it
19:26:19 <wobo> yes, back when I was in MUGs :)
19:26:50 <wobo> ennael: yes, read it today again
19:27:12 <misc> well, we published it afaik http://wiki.mandriva.com/en/Code_of_Conduct
19:27:23 <wobo> yes
19:27:47 <misc> ( and the coc was in turn adapted from gnome or kde one, I do not know )
19:28:25 <ennael> mageia.org/wiki/doku.php?id=codeofconduct
19:28:28 <ennael> first paste
19:28:39 <ennael> improving format
19:28:46 <misc> #link http://mageia.org/wiki/doku.php?id=codeofconduct
19:30:15 <misc> ok so the next step is ?
19:31:01 <ennael> proof reading
19:31:16 <ennael> and see if we can make it more generic not only for devs a
19:31:25 <ennael> and make it fit with Mageia organization
19:31:37 <rda> isn't it already quite generic?
19:31:47 <wobo> Can we use it without changing (except for the names)? Will it not remember too many people of Mandriva and the problems with CoC, due to the company?
19:32:03 <ennael> rda: just a question
19:32:26 <misc> wobo: well, afaik, we never enforced the CoC, and it was just a set of guideline , not a hard requirement, unlike ubuntu, we do not ask people to sign it
19:33:32 <wobo> misc: it was published as reaction to the complaining users in the forum, so although not enforced it had a meaning
19:34:06 <misc> wobo: mhh from what I remind of the cooker-chef meeting, it was not the case ( at least, that's not how I perceived it )
19:34:50 <wobo> yes, it may have been different on the cooker side but it was a big thing on the MUGs and user side
19:35:49 <misc> then maybe a FAQ along the CoC to ease the publication ?
19:36:53 <wobo> It may help to explain that the situation is different, now not being restricted by company orders, etc.
19:37:12 <ennael> a big thing ?
19:37:13 <misc> well, the goal was not really to restrict people with company order
19:37:32 <rda> a faq to say what?
19:38:28 <rda> the CoC is like a netiquette, talking about person-to-person relations, no?
19:38:36 <misc> rda: "someone do not respect the code of conduct, should I contact plf to get him killed" "I feel the FAQ is looking like the one of mdv, is it normal" "we have no conduct issue, so why have a CoC"
19:38:40 <misc> yeah
19:39:09 <ennael> well imho coc is just a set of "normal statements"
19:39:25 <ennael> any registration on Mageia project should come together with accpeting it
19:39:30 <rda> misc: ah, yes. :)
19:39:51 <rda> misc: well, that's a generic FAQ issue, then. we can update the existing faq.
19:39:53 <wobo> yes, but once published we are measured by this set of statements as we are by the "values"
19:40:20 <ennael> so ?
19:40:38 <ennael> we should not publish it if we do not want to follow it :)
19:40:59 <rda> well.. I should re-read it again, but I don't see, not sure, why I wouldn't follow it.
19:41:13 <wobo> same here
19:41:42 <ennael> so it could apply to forums, ML,...
19:41:45 <rda> ennael: I wouldn't make it mandatory to accept it to register, but to invite/welcome people to follow it closely.
19:41:48 <rda> ennael: yes
19:41:54 <misc> yup, like rda
19:42:13 <misc> because people should not feel forced to follow it, but follow it because they think it it is the right thing to do
19:42:14 <ennael> looks weird but ok
19:42:25 <wobo> misc right
19:42:34 <rda> misc: yep
19:42:51 <ennael> it's a very optimistic view of world :)
19:42:57 <ennael> but hey we can :)
19:43:22 <wobo> we ARE optimistic, otherwise none of you would have started all this :)
19:43:28 <coling> hehe
19:43:33 <rda> ennael: that doesn't leave out the possibility to kick (IRC-style) someone because she does not follow the CoC, yes?
19:43:59 <ennael> misc: wan you write on inof that wobo made us optimistic (otherwise we die)
19:44:02 <ennael> :)
19:44:06 <misc> we do not have CoC and that doesn't prevent kicking person :)
19:44:35 <coling> But at least with CoC, kicking has legitimacy rather than just the "will of misc"
19:44:42 <ennael> :)
19:44:42 <coling> (which I wouldn't dare doubt!)
19:45:03 <wobo> misc: having a fixed base for one foot makes kicking much more efficient
19:45:17 <Fredxx> do u mean that CoC could be like the "règlement interieur" of the association ?
19:45:24 <rda> Fredxx: no
19:45:29 <misc> I would fear that people would take the CoC as a excuse to kick others more than anything
19:45:34 <Fredxx> k
19:45:54 <wobo> depends on who are the people with a right to kick
19:45:59 <misc> ie, kicking someone should a last resort measure, so rare than people should not think of it
19:46:08 <wobo> yes
19:46:08 <rda> misc: saying, like "you're not considerate, get out!" "hey, no, _you_ are not respecting me, you get out" ? :)
19:46:19 <misc> rda: yup, this kind of thing
19:46:24 <rda> misc: yes, should be escalated to council I guess
19:46:33 <ennael> misc: this is not very optimistic :)
19:46:34 <misc> and most of the time, kicking is not realy enforcable
19:46:42 * rda slaps ennael
19:46:46 <ennael> :)
19:46:50 <ennael> aie
19:46:55 <ennael> hey this is not in CoC
19:46:58 <wobo> :)
19:47:00 <ennael> please kick rda
19:47:19 <rda> ennael: tsss, you don't recognize a kindly kick from a bad one?
19:47:23 <coincoin> :)
19:47:41 <ennael> ok so to summarize ?
19:47:51 <misc> we need to proofread the CoC
19:48:20 <rda> ok
19:48:30 <misc> #action proofread the CoC
19:49:12 <wobo> maybe after that we should publish it on the website along with the values? Because the CoC also tells about us who want to follow it
19:49:52 <coling> Sounds valid.
19:49:53 <misc> we can also ask to translate it ?
19:50:03 <rda> wobo: yes
19:50:19 <ennael> yep would be nice
19:50:23 <wobo> already done in many languages (at least the Mandriva version)
19:50:25 <rda> I would even say that it would be nice to have some illustration of both. but... ennael will smile at it.
19:50:46 <ennael> please rda draw me a CoC :)
19:50:54 <coincoin> :D
19:51:01 <coincoin> and not a grey one
19:51:12 <wobo> you can use the logo of the company CoC
19:51:25 * rda gently slaps ennael with consideration
19:51:35 <misc> wobo: in fact, asking to translate is a trick to make sure people read it :)
19:51:46 <wobo> misc: :)
19:51:49 <ennael> rda: walt signature :)
19:52:06 <misc> #action translate CoC after being proof read
19:52:12 <misc> and then publish it ?
19:52:17 <ennael> yep
19:52:17 <rda> ennael: :p
19:53:28 <misc> #action publish the coc
19:53:41 <misc> so anything else to add on this ?
19:53:55 <ennael> nope
19:54:00 <misc> great
19:54:02 <coincoin> niet
19:54:19 <wobo> non
19:54:26 <misc> this was the last topic, so thanks for being there
19:54:30 <misc> #endmeeting