18:01:52 <ennael> #startmeeting
18:01:52 <Inigo_Montoya> Meeting started Tue Oct 12 18:01:52 2010 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:52 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:02:09 <ennael> #chair ennael rda boklm
18:02:09 <Inigo_Montoya> Current chairs: boklm ennael rda
18:02:46 <ennael> some of us are not there tonight (misc, nanar)
18:03:08 <ennael> looks like blingme got access to freenode finally :)
18:03:30 <blingme> only by using ssh port forward to svn.mageia.org
18:03:36 <ennael> woot
18:03:45 <boklm> :)
18:04:27 <ennael> ok let's start then
18:04:32 <ennael> #topic trademark and logos guidelines
18:04:35 <ennael> rda ?
18:04:50 <rda> yep
18:05:02 <rda> that's two things.
18:05:25 <rda> now that we have Mageia values doc published, we are going to "re" launch the logo production serie
18:05:35 <rda> that is, we updated already guidelines for the logo
18:05:47 <rda> http://mageia.org/wiki/doku.php?id=artguide
18:05:57 <ennael> #info logo guidelines have been updated http://mageia.org/wiki/doku.php?id=artguide
18:06:05 <rda> and we will post tomorrow morning a mail to reexplain how to do for the coming days.
18:06:13 <rda> submission deadline will be October 28th.
18:06:34 <ennael> #action rda will post a mail for logo contest - deadline is October 28th
18:06:51 <rda> and this will be handled/driven by Caroline, a ex-Mandriva staffer for communication and marketing, in coordination with comm/market teams
18:07:19 <ennael> #info Caroline will drive logo contest with comm/market teams
18:07:24 <rda> in the same time, we are going to draft trademark & logo policy: how should the "Mageia" name be used, when, why, and by who
18:08:22 <rda> this is pretty tricky and sensitive, and indispensable to make sure the "Mageia" name is not used against or in diverging interests of the project (values, mission, etc.)
18:08:43 <rda> we may be looking a lot at what others did about that (Debian, Mozilla, Ubuntu, Apache)
18:09:15 <ennael> #action rda and marketing team will draft trademark & logo policy to ensure proper use of Mageia name
18:09:24 <rda> this is still at a rough state, and will be coordinated through communication team as well (Caroline too, me, maybe someone else?)
18:09:53 <ennael> anyone interested here ?
18:09:55 <rda> comments? ideas? objections?
18:10:18 <rda> ennael: I guess it's alright then :-p
18:10:40 <tmb> no objections so far
18:10:53 <rda> or we can move on and discuss this further as a Q&A session at the end?
18:11:38 <ennael> #action plan Q&A session about all this
18:12:16 <ennael> anything else on that topic ?
18:12:47 <rda> "qui veut épouser mon fils ?"^Wnext !
18:12:55 <ennael> :)
18:12:57 <ennael> ok
18:13:04 <ennael> #topic ldap and web apps to manage users
18:13:11 <ennael> blingme:
18:13:23 <ennael> rda: may I introduce you buchan :)
18:13:27 <coling> sorry I'm late. here now :)
18:13:34 <rda> ennael: :-p
18:13:43 <blingme> Well, any feedback on what I sent today regarding GOsa?
18:13:44 <ennael> hi coling
18:13:58 <blingme> If people *really* want GOsa, we can continue with it
18:14:21 <blingme> but there isn't much documentation on what access the gosa web app's user needs to have etc.
18:14:21 <ennael> well if it's not secure enough I guess it's not such a good idea...
18:14:29 <blingme> seems they just assume they will have rootdn
18:14:40 <blingme> it has lots of features .... but how many of them do we need?
18:14:43 <rda> blingme: your mail made pretty much sense
18:15:06 <blingme> ok, so any concerns with a web app for which we are the primary users for now?
18:15:10 <rda> blingme: and, apart from features, I think we must have a personal account management that closely fits users needs
18:15:19 <blingme> which was written from scratch in one day
18:15:35 <rda> I did not try it yet, neither reviewed the code. hope to do so tomorrow.
18:15:52 <blingme> ok, I might try and finish one or two pieces tonight
18:15:59 <rda> and I have to answer your mail. apart from that, it sounds very good to me on this track.
18:16:11 <blingme> cool
18:16:11 * tmb havent seen any mail..
18:16:42 <blingme> tmb: sorry, you weren't on the thread that I replied to ....
18:16:56 <blingme> I will forward to you if you're interested
18:17:14 <blingme> rda: ok, so at some stage we will need to put it somewhere it can access LDAP
18:17:23 <rda> hmmm did we get the founders@ alias?
18:17:24 <tmb> blingme: yep, please do...
18:17:37 <rda> blingme: yep, I guess on the webserver next to it would be fine?
18:17:39 <blingme> and also let others at it (e.g. if we want any web design work, localisation)
18:17:44 <rda> boklm: ldap is hosted @ gandi, right?
18:17:54 <blingme> yes, on svn at present
18:17:55 <boklm> rda: yes
18:18:13 <rda> blingme: yes, we can structure that. no secret key or anything like that in the code?
18:18:15 <ennael> #info questions about Gosa security problems requiring rootdn to access data
18:18:27 <blingme> rda: there are no credentials anywhere in the code
18:18:46 <blingme> with catalyst, configuration can go in code, in config, and in local config
18:18:51 <rda> ok, that will help distributing work on it for translation and design
18:18:58 <ennael> #info Buchan sent an email to explain all alternatives and proposed a beginning of interface using catalyst in 1 day
18:19:06 <blingme> so, there is in svn a catdap.yml default config file
18:19:21 <blingme> if you want to customise it, copy to catdap_local.yml, and make mods there
18:19:47 <blingme> so, I have my local directory settings/credentials in catdap_local.yml in the same tree as is in svn
18:20:02 <blingme> (this is a very nice feature of catalyst compared to some other frameworks)
18:20:13 <rda> cool, indeed
18:20:46 <blingme> who should I coordinate with in putting this up?
18:20:58 <blingme> e.g., do we want some code review before it is available?
18:21:11 <boklm> URL for svn: svn://svn.mageia.org/soft/identity (anonymous) or svn+ssh://svn.mageia.org/svn/soft/identity
18:21:30 <ennael> #info code is available in svn://svn.mageia.org/soft/identity
18:22:02 <blingme> you will probably need quite a lot of Catalyst packages, all should now be available for 2010.0, but I have only tested on 2010.1
18:22:17 <rda> blingme: I would like to try to install it and review, but I'm not as fluent in Perl as many others.
18:22:24 <ennael> guillomovitch ?
18:22:28 <ennael> jq ?
18:22:30 <blingme> I will create spec file etc. shortly, to at least allow others to install it more easily
18:22:31 <rda> so I would welcome a third person here :)
18:22:53 <rda> blingme: not sure if we should deploy it that way (through rpm) though
18:22:55 <blingme> Nanar has also done some work in Catalyst, but he's probably too busy
18:23:17 <blingme> rda: not yet .... but just getting all the packages installed could take a bit of time by trial and error
18:23:28 <rda> ah, right, yes :)
18:23:40 <blingme> I might just make a list ... or META.yml ...
18:23:53 <ennael> #action review identity app before going on line: rda, see with guillomovitch or jq
18:24:34 <rtp> blino is also fluent in perl iirc :)
18:24:55 <ennael> sure :)
18:25:03 <ennael> blino: don't hide :)
18:25:23 <blino> rtp: but too busy with fun things like perforce, cmake, libcurl, webkit :/
18:25:40 <blingme> ok, so, my next steps are to finish the last bits of user login from URL sent by mail, some work on ACLs for LDAP to make sure the app works, and running some code checking tools
18:25:52 <blingme> and add password changing
18:26:14 <blingme> boklm: you said you wanted to look at sympa ....
18:26:19 <boklm> blingme: yes
18:26:29 <blingme> do I need to do anything for that, besides create account for you and for sympa?
18:26:50 <rda> blingme: for my proxy thing, I will explain by email, tomorrow.
18:26:57 <ennael> #action Buchan has to finish user login, LDAP ACLs, code checking tools
18:26:59 <blingme> rda: np
18:27:20 <boklm> blingme: I'm not sure, I can check and tell you later
18:27:34 <ennael> #action boklm has to describe buchan what he is looking for for sympa to be plugged
18:27:45 <blingme> ok, I will create accounts for you and sympa after meeting
18:27:51 <boklm> ok, thanks
18:28:14 <boklm> blingme: is there an email field in the LDAP database ?
18:28:37 <blingme> boklm: yes, default one is 'mail', but this can be multi-valued
18:28:41 <boklm> ok
18:29:13 <blingme> we need to consider what we require email address storage for, and choose a schema for it
18:29:25 <blingme> depending on whether we want aliases etc. in LDAP
18:30:06 <blingme> but, afaik, with sympa you can make mailing lists based on ldap searches, e.g a sysadmin group could have all members of sysadmins group as subscribers
18:30:08 <rda> blingme: email would be for auth and contacting the user (directly or through subscriptions)
18:30:25 <blingme> so, adding a user to sysadmin group results in them being on ml without any other changes
18:30:56 <blingme> is there a sysadmin ml ?
18:31:10 <boklm> blingme: yes, mageia-sysadm@mageia.org
18:31:25 <boklm> blingme: you are subscribed to it now
18:31:46 <blingme> ok, fine, then I might send some info on how people can see what is currently in LDAP
18:32:01 <boklm> ok
18:32:17 <ennael> #action Buchan will sned more information to sysadmin team to explain how things work
18:32:36 <blingme> anything else?
18:32:39 <boklm> for mageia.org email alias, I don't know if we want to provide this to all users, or only some users
18:32:58 <ennael> what about active members ?
18:33:03 <rda> some
18:33:07 <blingme> are we open to using "cloud" services?
18:33:21 <rda> blingme: yes, but then maybe on a different domain
18:33:26 <blingme> e.g. Google ?
18:33:36 <blingme> where is pterjan when you need him
18:33:38 <rda> oh, I was thinking "our own" :-p
18:34:23 <coling> I think we can just provide aliases @mageia.org for now.
18:34:26 <blingme> I think Google apps is free for some classifications of organisations
18:34:51 <boklm> for which services do you think about using this ?
18:34:52 <coling> IIRC GA is free up to 100 users... for general purpose use, but perhaps charities/non-profits etc. can get more.
18:35:02 <coling> (but could be wrong)
18:35:10 <rda> what do you want to use google apps for?
18:35:27 <blingme> just if we want to provide contributors with mailboxes
18:35:35 <ennael> outch
18:35:39 <coling> I would imagine mail accounts, but IMO we should just start off with aliases
18:35:40 <blingme> (really just an idle idea)
18:35:45 <ennael> do we really want to manage mailboxes ?
18:36:05 <blingme> ennael: by "manage", you mean?
18:36:07 <blingme> host, no
18:36:14 <tmb> not mailboxes, only forwarding...
18:36:20 <ennael> ok
18:36:24 <coling> ennael, IMO no. 99% of contributors would likely rather have their mail forwarded anyway.
18:36:27 * ennael was a bit frightened
18:37:00 <ennael> #info a mail alias mageia.org will be provided to all active members in Mageia
18:37:29 <rda> beware, not in the sense of "association active members" :-p
18:37:49 <ennael> yep sorry
18:37:57 <rda> don't be
18:38:32 <rda> have to leave guys, good evening all!
18:38:54 <ennael> anything else on that tpoic ?
18:38:59 <blingme> not me
18:39:19 <ennael> ok
18:39:25 <ennael> #topic sysadmin review
18:39:30 <ennael> boklm: ?
18:39:53 <boklm> hmmm, not a lot of news since friday meeting for me
18:40:54 <boklm> anyone wants to say something about sysadmin ?
18:41:26 <tmb> nope
18:41:38 <coling> nothing from me.
18:41:48 * coling has been very busy with work stuff of late :(
18:41:54 <ennael> great that was fast :)
18:42:03 <ennael> #topic hosting news
18:42:07 <coling> :)
18:42:16 <ennael> ok my turn
18:42:32 <ennael> so we received a negative answer from Free foundation
18:42:42 <ennael> as they host only 2 servers max
18:42:57 <tmb> ouch
18:43:01 <ennael> so we are working on 2 other solutions
18:43:09 <ennael> first is Lost Oasis
18:43:19 <coling> Bummer :(
18:43:19 <ennael> they use to host some open source projects like PLF
18:43:45 <ennael> I sent then server list today we should have an answer by tomorrow
18:44:03 <ennael> one other is MLO hosting (Nfrance)
18:44:29 <ennael> whatever the answer is we have a backup solution for coming months with kazar.net assocation
18:44:44 <ennael> they could host us for free or at least very cheap fees
18:45:01 <ennael> so we will decide things after Lost-Oasis answer
18:45:31 <coling> OK, not all bad news then :)
18:45:45 <ennael> nope but we would like to hurry things a bit :)
18:46:10 <ennael> #action looking for other solutions for hosting, waiting for answer tomorrow
18:46:23 <tmb> what kind of bw can/will NFrance or kazar.net provide?
18:46:29 <ennael> #info backup solution for bs is available
18:46:46 * coling will have to go soon. Sorry :(
18:47:00 <ennael> tmb: 3 of them, Lost-Oasis, NFrance and Kazar have symetric bw
18:47:13 <ennael> I cannot remember the exact figures but quite enough for us
18:48:16 <ennael> so we should send an email about what we will do tomorrow
18:48:29 <tmb> ok, just dont want to end up in a situation where we will pay us sick..
18:48:52 <ennael> yep
18:49:31 <ennael> anyway we will have to estimate hosting costs to manage a security funds amount in case of any problem in future
18:50:08 <tmb> do we get physical access to those 3 hosting providers?
18:50:24 <ennael> for the backup solution yes
18:50:34 <ennael> for 2 others datacenters are not in paris
18:50:55 <ennael> but at least for Lost-Oasis it was working quite well with PLF
18:51:07 <ennael> and boklm will look for remote management for our servers
18:51:51 <guillomovitch> pong
18:51:55 <guillomovitch> sorry for the delay
18:52:34 <guillomovitch> no pb for a code review, but probably not before this WE
18:52:36 <tmb> ok, if we get remote/ lights-out access it will be better.
18:52:41 <ennael> yep
18:52:51 <erwan_taf> coincoin: does your servers have IPMI built-in options ?
18:52:52 <ennael> this is a task for super-boklm :)
18:52:54 <guillomovitch> Lost-Oasis has some reasons to be quite upset about mandriva
18:53:10 <tmb> like ?
18:53:11 <ennael> guillomovitch: yes they have
18:53:19 <guillomovitch> tmb: non-paid bills
18:53:21 <ennael> something like 100.000 euros
18:53:36 <guillomovitch> it might influence their answer about mageia
18:53:49 <ennael> well first contact was quite friendly
18:53:54 <guillomovitch> cool
18:53:54 <ennael> we will see
18:54:54 * coling gtg now, take care
18:55:00 <ennael> bye coling
18:55:05 <boklm> maybe being upset about mandriva could be a reason to help mageia :)
18:55:51 <ennael> boklm: any information about IPMI on our servers ?
18:56:08 <boklm> I don't know, I have to check with damsweb
18:56:12 <ennael> ok
18:56:20 <ennael> any other question on that topic ?
18:56:44 <tmb> not for now...
18:56:50 <ennael> ok
18:56:58 <ennael> any other topic that was not in list ?
18:57:17 <erwan_taf> when do we share a drink ? :p
18:57:22 * erwan_taf hides
18:57:27 <tmb> :)
18:57:38 <tmb> not from me...
18:57:47 <boklm> at fosdem for the people who come ? :)
18:57:54 <ennael> ok
18:57:59 <ennael> #endmeeting