18:48:18 <filip__> #startmeeting
18:48:18 <Inigo_Montoya`> Meeting started Thu Sep 25 18:48:18 2014 UTC.  The chair is filip__. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:48:18 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:48:37 <filip__> #chair Akien papoteur
18:48:37 <Inigo_Montoya`> Current chairs: Akien filip__ papoteur
18:49:24 <filip__> thx for beeing around
18:50:19 <papoteur> It's a long the last meeting happened
18:50:27 <papoteur> s/long time
18:50:34 <Akien> Indeed :)
18:50:46 <filip__> I guess we'll add more topics for today but basically it's about L10N and DOC status, merge of those team and a long list from doc team ;)
18:51:23 <lebarhon> I thought th idea of merging was given up
18:51:35 <filip__> why?
18:51:54 <lebarhon> It was said during a meeting
18:52:08 <filip__> I'll reread it
18:52:23 <lebarhon> may be a council meeting
18:53:00 <Akien> I think last time we spoke about it the discussion was lengthly, and we more or less agreed to continue it on the MLs, what we did not do ;)
18:53:05 <papoteur> I don't remember that something was acted.
18:53:31 <filip__> and AFAIK council supports us to merge
18:53:56 <Akien> Yep we told them about this idea during the last council meeting, and they were interested in it
18:54:09 <filip__> yeah
18:54:11 <Akien> Should we start with this topic?
18:54:13 <lebarhon> So, let's merge
18:54:31 <Akien> #topic i18n/l10n and docteam merge
18:54:48 <filip__> I'm for merge to. should we vote again?
18:54:55 <Akien> From what I could gather, I think most of us are not opposed, or are in favour of merging the teams.
18:55:33 <papoteur> We said that we can have a ml for doc+i18n and a ml for l10n
18:55:43 <Akien> +1 for the merge, but I still have difficulties to grasp how it will/should change our current organization
18:55:45 <lebarhon> It was also suggested to split i18n and i10n
18:56:32 <Akien> IMO, we should have a big team with the three subteams that we already discussed: i18n, l10n and doc
18:56:35 <filip__> mix of I18N on ML is mostly my "fault"
18:56:53 <lebarhon> Akien: it may help to have more people knowing Calenco and TX
18:57:05 <filip__> Akien: I guess that makes the most sense
18:57:18 <Akien> I don't think there is an issue with the topics on the MLs
18:57:23 <papoteur> Akien: filip__I agree
18:57:37 <Akien> The flow is quite low, on i18n-discuss it's mostly about Tx translations to push
18:57:55 <Akien> I don't think it an issue when filip__ keeps us posted about his work on some tools :-)
18:58:20 * filip__ didn't do that for long time anyway ;)
18:58:37 <Akien> If we had to discuss lots of complicated i18n stuff, then we could have a separate ML, but most of the time heavy i18n discussions happen on IRC or on the sysadmin ML
18:58:56 <filip__> or atelier ML
18:59:27 <Akien> Yep
18:59:49 <Akien> So the question is: what should change in the current organization/MLs/workflow when we merge?
18:59:56 <papoteur> I don't feel flooded by the ML i18n
19:00:05 <Akien> Should we have only one ML for the whole team?
19:00:32 <Akien> I think the main motivation for the merge at first was that all doc translation related mails had to be cross-posted to both MLs
19:00:33 <filip__> I guess we should decide for merge first and than talk about technical side of it shouldn't we?
19:00:37 <lebarhon> It may avoid double mails
19:01:06 <Akien> filip__: Sure, but we need to know why we merge :-)
19:01:12 <filip__> true
19:01:34 <Akien> I think merging the MLs would be the most noticeable change
19:01:37 <lebarhon> How many active people on doc team ?
19:01:52 <lebarhon> Not enough to have a team
19:01:55 <filip__> some overlap of work speaks yes for merge
19:02:08 <Akien> Of course we would also have a change in leadership too, but that can be discussed later
19:03:00 <filip__> let's ask ourself different question:
19:03:11 <filip__> why _not_ merge
19:04:29 <filip__> as I don't see such reason in our current situation
19:04:35 <filip__> does anybody?
19:04:49 <filip__> hi napcok
19:05:18 <lebarhon> Another question : how much work for docteam ? what is on the TODO list ?
19:05:25 <papoteur> filip__: I don't understand your last assertion.
19:05:28 <napcok> hi
19:05:40 <Akien> filip__: I think we should merge too. Mageia has reached a relatively steady state, and it's plain that we don't have enough contributors to warrant so many teams
19:06:28 <Akien> i18n/l10n is pretty calm too, because most active contributors have already translated most of the content
19:06:54 <filip__> papoteur: let me rephrase. number of active contributors in both team combined is not huge and it overlaps a bit
19:06:57 <Akien> The next big step will be the wiki (don't hit me, I didn't mean to bring up this topic :-P )
19:07:09 <papoteur> Akien: A large part of the wiki could be translated if infra was OK.
19:07:15 <Akien> papoteur: Yep
19:07:56 <papoteur> filip__: yes, it's not too big, at least.
19:08:18 <Akien> How many are we actually? Maybe 20 active contributors in i18n/l10n + 5-10 in docteam?
19:08:24 <filip__> I guess tmb and others sysadmins need some more time. There are some serious HW issues with servers.
19:08:50 <filip__> Akien: I guess the number depends on a definition of "active"
19:08:52 <Akien> Yes, I don't think we should count on it before the Mageia 5 release.
19:09:00 <Akien> filip__: Yes of course.
19:09:19 <papoteur> filip__: ;)
19:09:22 <Akien> If the definition is "comes to meetings", then we are not legion :-D
19:09:36 <yurchor> For me, it does not matter what the team list is, as long as it does not hinder to obtain the result.
19:09:52 <filip__> yurchor: good point. thx
19:10:03 <Akien> Yes that's a valid point.
19:10:29 <Akien> That sums up most of Mageia btw. We're doing a great distro with a really small team compared to other distros.
19:10:39 <Akien> s/doing/making/
19:10:50 <filip__> and we're very open at the same time
19:11:05 <filip__> not all small community distros are
19:11:34 <Akien> Yes, I think those who really want to contribute find a great community.
19:11:39 <yurchor> I can help with some diffrent simple tasks here and there regardless to the team name, if needed.
19:11:40 <filip__> +1
19:12:05 <filip__> +1 to yurchor too
19:12:14 <Akien> Ok, so I think we reach a consensus for merging the teams :-)
19:12:23 <filip__> I think soo
19:12:27 <yurchor> +1
19:12:29 <papoteur> +1
19:12:56 <papoteur> lebarhon: ?
19:13:01 <lebarhon> +1 I asked for it a long time ago
19:13:19 <filip__> should we change ML at all. I don't see a need for that but my view is limited ;).
19:13:50 <papoteur> #info We agree to merge doc and i18n teams
19:14:14 <filip__> thx papoteur. you beat me ;)
19:14:34 <Akien> filip__: I think there are pros and cons.
19:14:40 <papoteur> filip__: ;)
19:14:51 <Akien> It would be nice for newcomers if there was only one entry point: join the ML.
19:14:52 <filip__> Akien: can we expose them now?
19:15:19 <lebarhon> We could wait a while before merging the ML
19:15:24 <filip__> +1
19:15:25 <papoteur> I receive the two lists, for my usage, it's better with one list.
19:16:19 <lebarhon> One list may push i18n members to doc writing
19:16:42 <papoteur> lebarhon: good idea !
19:16:44 <filip__> it might
19:17:11 <filip__> those who're bored can pick more work ;)
19:17:22 <Akien> Maybe we can merge the MLs when the wiki can be translated? :-P
19:17:49 <filip__> and hopefully soon ;)
19:17:52 <Akien> Or decide on a proper translation workflow with the current infrastructure, and do the transfer when infra is there
19:18:34 <papoteur> Qilaq: psyca: blingme: napcok do you use the 2 mailing lists ?
19:18:39 <filip__> most of us are on both lists now anyway. aren't we?
19:19:11 <lebarhon> Is the transfer a hard/long job ?
19:19:30 <psyca> iam only in doc and i18
19:19:52 <Akien> lebarhon: I guess that would be copy-paste of existing pages in the new infra
19:19:56 <filip__> I think not. sysadmins will open a new one ane make old read only I guess
19:20:03 <papoteur> psyca: thx
19:20:03 <psyca> both
19:20:13 <Akien> But yes, if the old one is read only, it's doable I think
19:20:16 <lebarhon> Akien: what about the links between languages ?
19:20:32 <filip__> lebarhon: what link?
19:20:52 <lebarhon> filip__: links between languages in the wiki
19:21:26 <filip__> ah. we should disscuss that later when wiki will be that way
19:21:55 <filip__> what name should we choose ;)?
19:22:02 <Akien> Hehe
19:22:10 <filip__> doc/l10n?
19:22:35 <papoteur> multidoc ?
19:22:36 <Akien> I think the i18n can be left out, it's too technical to be relevant for normal contributors :-)
19:22:39 <papoteur> ;)
19:22:39 <lebarhon> doc is obviouly translated
19:22:49 <lebarhon> *obviously
19:23:10 <Akien> "Documentation and Localization team" could be good.
19:23:31 <lebarhon> DL in short
19:23:34 <filip__> that is the long name and I like it
19:24:03 <papoteur> localisation?
19:24:43 <papoteur> Akien: yes, it's explicite
19:25:13 <filip__> do we agree?
19:25:52 <lebarhon> yes
19:26:07 <Akien> On the principle yes, then for the actual change I would like to ask our contributors first for their opinion
19:26:15 <Akien> We're only a handful here :-)
19:26:20 <filip__> true
19:26:41 <filip__> we can bring todays concensus on our ML
19:27:04 <Akien> Agreed
19:27:06 <filip__> and give it a week or two
19:27:49 <lebarhon> Is it worth a blog post ?
19:28:15 <filip__> I think it is. when we decide.
19:28:33 <Akien> Once it's agreed upon and validated by the council (I don't see what they would have against, but just to do things right), we should do a blog post yes
19:28:35 <filip__> it's big news ;)
19:28:40 <Akien> It's a good opportunity to talk about us :-)
19:28:48 <papoteur> lebarhon: I think it is better after to have decided for the name.
19:29:15 <Qilaq> very late hi + I've nothing against merge of MLs or even teams as such
19:29:18 <lebarhon> Why not a blog post to ask opinions ?
19:29:29 <filip__> hi Qilaq
19:29:31 <papoteur> Qilaq: :)
19:29:59 <Qilaq> khm, it'd be nice to merge Estonian i18n translation team with Estonian doc translation team - me with me! ;-)
19:30:28 <papoteur> Qilaq: lol
19:31:10 <filip__> #action we ask on i18n and doc ML for objections on team merge and a name "Documentation and Localization team"
19:31:11 <Akien> lebarhon: I think most people with an opinion are the ones in our current MLs (+ Transifex)
19:31:14 <papoteur> lebarhon: not sure to have answers.
19:31:15 <filip__> ok?
19:31:30 <Akien> filip__: Sounds good
19:31:30 <papoteur> filip__: yes
19:31:42 <filip__> let's move on ;)
19:32:19 <Akien> We have 15 minutes left ;-)
19:32:27 <Qilaq> both MLs have so few real messages (i.e apart from commit messages) that merge shouldn't be overkill anyway
19:33:20 <lebarhon> who is in docteam and not in i18n ?
19:33:33 <lebarhon> very few I think
19:33:33 <filip__> #topic about L10N and DOC status
19:34:22 <papoteur> L10n first?
19:35:06 <Akien> The main question for l10n is: are git and Tx in sync, or do we need to do plan a mass push of Tx translations in the coming weeks?
19:35:49 <Akien> Or should it be done on a per team basis, asking each team about the status of their translation
19:36:01 <filip__> that's tough question as some of us push to git directly and some use tx
19:36:31 <psyca> i think too that some push directly to git and some to tx
19:37:12 <filip__> sadly many people on tx doesn't respond on pings :(
19:37:28 <lebarhon> Are all Tx
19:37:53 <lebarhon> workers present in the wiki list ?
19:38:06 <Akien> lebarhon: Nope, the wiki list is really outdated IMO
19:38:20 <Akien> Let's give it another try maybe. We can ping everyone and ask whether translations need to be pushed.
19:38:21 <filip__> unfortunately I agree
19:38:38 <Akien> I guess if we don't get an answer for a given locale, we can consider that nothing has to be done.
19:38:40 <Qilaq> I've of opinion that Tx should always be secondary source for translations - at least until we have some magic what would take translations directly from Tx
19:38:42 <lebarhon> Marja asked to stop subscribers on Tx before they are on the wiki list
19:38:47 <psyca> some people say in the ml. to push tx to git... but some dont
19:39:14 <Akien> We're a community-based distro, so it's normal that the properly translated locales are the ones for which we have active contributors participating in the community.
19:39:22 <filip__> psyca: yeah
19:39:45 <Akien> Qilaq: Well translations can be retrieved from Tx (or pushed to Tx) with one command with transifex-client
19:40:05 <filip__> Akien: yeah
19:40:12 <Akien> That's why I'd like to have a commit hook on git that automatically pushes new .po files to Tx
19:40:23 <Qilaq> yes, but software packages are still based on git, i.e. they take also tranbslations from git not from Tx
19:40:24 <Akien> If they come from Tx, nothing happens, and if they are new, Tx gets updated
19:40:27 <psyca> isnt there an command to check if there are translations already on tx and git and if not write them over?
19:40:52 <Akien> Maybe a simple script could do that yes
19:41:15 <Akien> Qilaq: Basically git is the production base, and Tx is the workplace.
19:41:22 <filip__> tx have some hooks for that but it's beyond me
19:42:08 <filip__> maybe yurchor knows but he left w/o goodbye :(
19:42:17 <psyca> the problem would be if there are 2 different translations in git and tx too.
19:42:53 <filip__> if you don't use --force client handle that
19:43:10 <filip__> but it's too manual
19:43:16 <filip__> ;)
19:43:53 <filip__> should we ask that on i18n ML and move on today?
19:44:01 <Akien> filip__: +1
19:44:40 <Akien> I have to go, I'll let your finish :-)
19:44:54 <psyca> yurchor is subscibed in tx.
19:44:55 <filip__> #help how to handle synch of translations in git and tx
19:45:06 <Akien> (We're at ~1h btw, time to end the meeting ;-)
19:45:15 <filip__> Akien: good night then
19:45:34 <filip__> we should give doc team a chance before we stop
19:45:48 <filip__> please doc team
19:46:03 <papoteur> If not, I ask to divorce ;)
19:46:38 <Akien> :-D
19:46:57 <papoteur> info: I added this page on wiki https://wiki.mageia.org/en/Kernel_flavours
19:46:58 <Akien> Maybe the meeting time can be 1h15 now that we merged ;-)
19:47:09 <papoteur> Akien: Sure
19:47:27 <papoteur> This can be proofread.
19:47:49 <papoteur> lebarhon asked for some topics:
19:48:00 <papoteur> Installateur compatibility with UEFI ?
19:48:02 <papoteur> - Btrfs ?
19:48:03 <papoteur> - Grub2
19:48:05 <papoteur> - IPv6
19:48:06 <papoteur> - draktools improvements ?
19:48:31 <papoteur> In relation to the coming Mageia 5
19:48:36 <lebarhon> the question was if doc was needed about these news features
19:49:01 <lebarhon> *new
19:49:26 <papoteur> For UEFI, I did see any improvements yet.
19:49:55 <papoteur> We have 2 pages in wiki, but there is draft
19:49:57 <lebarhon> doc to create or to modify
19:50:19 <papoteur> https://wiki.mageia.org/en/UEFI_how-to
19:50:32 <papoteur> https://wiki.mageia.org/en/UEFI_booting
19:51:03 <papoteur> I think one is to delete, and one is to improve.
19:51:11 <lebarhon> these pages don't say if UEFI will be taken in charge by the installer
19:51:29 <papoteur> the second is to delete.
19:52:05 <filip__> papoteur: I think you can mark it for deletion
19:52:13 <papoteur> I follow the dev ML, and I see nothing about that.
19:52:57 <papoteur> filip__: the information is perhaps to transfer. I did shecked.
19:53:16 <filip__> #info: papoteur added this page on wiki https://wiki.mageia.org/en/Kernel_flavours
19:53:46 <filip__> you can mark it later then
19:54:01 <filip__> papoteur: info ok?
19:54:13 <papoteur> filip__: OK
19:54:22 <filip__> you forgot to prefix it with #
19:54:36 <papoteur> ;)
19:54:57 <papoteur> On btrfs, I haven't info
19:55:20 <papoteur> lebarhon: What do you want to know about grub 2
19:55:49 <lebarhon> what will be the default loader for Mageia 5
19:56:01 <papoteur> #todo Improvement in https://wiki.mageia.org/en/UEFI_how-to
19:56:43 <filip__> I didn't notice much on grub2 on dev ML lately
19:56:53 <lebarhon> we will have a Mageia 5 release with the Mageia 4 doc
19:57:23 <filip__> lebarhon: does it need to change?
19:57:26 <papoteur> lebarhon: At this state, there is no change; It's grub legacy
19:57:44 <lebarhon> Grub2 and UEFI compatibility were promised for Mageia 5
19:58:28 <filip__> I don't think that grub2 will be the default soon
19:58:37 <papoteur> lebarhon: Yes, I know. But TMB was out during 2 monthes
20:00:29 <lebarhon> So nothing new between Mageia 4 and 5
20:00:52 <papoteur> Thus, I don't see stuff to modify the documentation yet.
20:01:40 <filip__> so we can improve existing one ;)
20:02:00 <papoteur> there a new version of rpm which induces lot of problem with build system and need the energy of our devs.
20:02:07 <filip__> you're doing great in wiki
20:02:23 <filip__> whole doc team ;)
20:02:51 <papoteur> essentially
20:03:31 <lebarhon> The problem is that the wiki isn't known by many users
20:03:46 <lebarhon> it needs a lot of publicity
20:04:15 <filip__> napcok linked it in his welcome work
20:04:35 <lebarhon> good idea
20:04:47 <filip__> can we do more for wiki on www.mageia.org?
20:05:30 <psyca> Maybe on the Downloadpage or Mainpage directly a link on the right side for Documentation and Wiki (not only the top link)
20:05:31 <papoteur> We have a entry in the nav bar
20:05:50 <psyca> With booklogo for documentation and an wiki logo for wiki
20:06:03 <filip__> psyca: can you post that on atelier ML?
20:06:07 <lebarhon> I think the wiki is lacking a sexy landing page, like it was with Mandriva
20:06:16 <filip__> +1
20:06:31 <filip__> pretty plain right now :(
20:06:58 <filip__> but that is out of scope for todays meeting
20:07:39 <papoteur> For today we can point out also https://wiki.mageia.org/en/Wiki_TODO_page
20:07:55 <filip__> #link https://wiki.mageia.org/en/Wiki_TODO_page
20:08:48 <papoteur> I would like to create a page on systemd on default services.
20:09:00 <papoteur> s/on/and
20:09:04 <filip__> papoteur: good idea
20:09:29 <papoteur> Yes, but it is only idea yet ;)
20:09:29 <filip__> there are a lot of forum questions about it
20:10:16 <filip__> #idea to create a page on systemd on default services.
20:10:37 <papoteur> #topic documentation publication
20:11:09 <papoteur> Carolyn did screenshot for Swedish MCC
20:11:29 <papoteur> I don't know if there yet published?
20:12:01 <filip__> I think that marja notified us on ML
20:13:27 <papoteur> filip__: Yes
20:13:32 <papoteur> marja said:
20:13:34 <papoteur> Done, and in all html pages in http://docteam.mageia.nl/sv/MCC/content/
20:13:35 <papoteur> the paths to still missing Swedish screenshots were changed into the
20:13:37 <papoteur> paths of the matching and available English screenshots, again
20:14:15 <papoteur> lebarhon: have you other questions
20:14:42 <lebarhon> Could we come back with meetings on a periodically basis
20:14:54 <filip__> I would like too
20:15:07 <filip__> I prefer regular and short meetings ;)
20:15:30 <papoteur> Yes, it will be good.
20:15:34 <filip__> let's talk about that next time
20:15:40 <lebarhon> half an hour every other week ?
20:15:48 <filip__> sound excellent
20:16:02 <lebarhon> next time? in December :)
20:16:38 <papoteur> ;)
20:16:41 <filip__> #idea have a meeting for half an hour every other week
20:16:56 <filip__> anything else?
20:17:27 <papoteur> We can fix yet the next meeting date
20:18:00 <filip__> that was the purpose of the idea ;)
20:18:13 <lebarhon> on thursday the 9th october ?
20:18:29 <filip__> sound ok
20:19:05 <filip__> #action next meeting on thursday the 9th october
20:19:13 <papoteur> OK, what time?
20:19:28 <filip__> 19:30 utc?
20:19:50 <lebarhon> ok if it is for 1/2 h
20:20:11 <filip__> we can ask that on ML together with merge topics
20:20:21 <filip__> for exact time
20:20:33 <papoteur> OK
20:20:39 <filip__> should we close?
20:21:24 <filip__> 3
20:21:29 <lebarhon> 2
20:21:41 <filip__> 1
20:21:50 <filip__> #endmeeting