19:06:16 <Akien> #startmeeting
19:06:16 <Inigo_Montoya`> Meeting started Thu Apr 24 19:06:16 2014 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:06:16 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:06:20 <filip_> maybe council things first so we can pass them there
19:06:26 <Akien> #chair filip_
19:06:26 <Inigo_Montoya`> Current chairs: Akien filip_
19:07:01 <Akien> Hi everyone and welcome to this i18n/l10n team meeting
19:07:41 <filip_> and sorry fto forget on the meting previus month from me too
19:07:56 <Akien> #topic Council question: i18n budget
19:08:25 <Akien> During the last council meeting, we discussed the needs of the various teams in terms of budget
19:08:59 <Akien> The sysadmins will probably need new hardware, and atelier could do with some more marketing stuff. As for our team, I did not see any particular need.
19:09:13 <filip_> me neither
19:09:29 <yurchor> +1
19:09:49 <Akien> That settles it, i18n needs no money, just love :-D
19:09:57 <papoteur> +1
19:10:10 <papoteur> and clear water ?
19:10:10 <filip_> and attention ;)
19:10:30 <Akien> #topic Council question 2: Team objectives
19:10:59 <Akien> For the reference I'm looking at:
19:11:03 <Akien> #link http://meetbot.mageia.org/mageia-meeting/2014/mageia-meeting.2014-04-14-19.42.html
19:11:51 <Akien> Council asks us to define our main objectives as a team for the coming months (i.e. for the Mageia 5 release cycle, but it can extend further)
19:12:43 <Akien> I put this forward because I thought it would be nice to clearly define and follow team objectives, and not only "Features" for the next release
19:13:11 <Akien> By team objectives, I mean changes in the organisation, the workflow, etc., such as moving to the Transifex platform during the last release cycle
19:13:31 <lebarhon> our objectives are connected to docteam ones
19:13:40 <filip_> yeah
19:13:50 <Akien> Most of them would be yes
19:13:52 <papoteur> I hope this time to have the internationalization of wiki.
19:14:02 <yurchor> It's a vague thing to be honest. After tv changes it is hard to extract strings. At least we have to settle the new translation system to rebuild catalogs...
19:14:35 <filip_> yurchor: what new translation system?
19:15:06 <yurchor> Not the new system but incorrect scripts after GTK 3 conversion.
19:15:23 <yurchor> ~50% of strings are unextractable. :(
19:15:41 <filip_> ouch
19:16:10 <Akien> Ah I hadn't noticed this
19:16:15 <papoteur> yurchor: is this a problem specific to GTK3?
19:16:18 <filip_> I think that this is very important objective to us
19:16:47 <yurchor> papoteur: It is better to say that this is Perl/Shell scripts problem.
19:16:48 <filip_> we need to know what to translate and it should be fresh ;)
19:17:00 <papoteur> Do tv manage the string catalog?
19:17:14 <yurchor> I do not know.
19:17:28 <filip_> how can we improve that?
19:19:11 <yurchor> Listen to the yells in dev@ and help to find the problems. Akien patch to msec with new strings is not applied for > 2 months, btw... :(
19:19:59 <Akien> yurchor: I think we can push this patch, we are also "devs". If it was wrong it can be reverted, but it seems better than the current status.
19:20:10 <yurchor> But I hope we can figure it out somehow...
19:20:26 <yurchor> Akien: Thanks.
19:20:29 <Akien> yurchor: Did you start discussions about the gtk3 conversion issue?
19:20:57 <Akien> I must admit I did not specifically notice a i18n-related topic on the dev ML
19:21:07 <yurchor> No. Not yet. I have waited for somebody else to notice.
19:21:55 <yurchor> Now, when it is noticed for msec, I will try the next days.
19:22:00 <Akien> Ok. If you please, I think you can start a topic sent to the dev ML, with tv in CC as usual.
19:22:13 <yurchor> Will do.
19:22:14 <Akien> So the current translation catalogs are broken?
19:22:21 <yurchor> Yes.
19:22:33 <yurchor> Not all but many of them.
19:22:37 <Akien> Is there a loss of translation, or it is just not up-to-date?
19:23:03 <yurchor> Just not up-to-date/synced with the code.
19:23:30 <yurchor> And there is no easy syncing technique.
19:23:52 <yurchor> make update_n_merge does not work anymore.
19:24:33 <lebarhon> Is this problem the reason for which modifications in Calenco don't appear in Tx ?
19:25:06 <yurchor> lebarhon: No. Totally unrelated.
19:25:14 <lebarhon> Ok thanks
19:25:21 <Akien> #action yurchor sends an email to dev+tv regarding the fact that translation catalogs can't be updated anymore since the Gtk3 conversion
19:25:40 <yurchor> Just send the message when docs will be ready and I will sync them with tx.
19:26:20 <Akien> So, going back to the topic, this broken translation catalog is a big issue, and should be one of the focus of these weeks
19:26:32 <filip_> btw: did anybody noticed any mga3 branch in git?
19:26:37 <Akien> Hopefully we'll find a solution soon
19:27:31 <Akien> #info Team objective: Get the translation catalog fixed and synced with the code
19:27:48 <Akien> #info Team objective: Internationalised wiki
19:28:08 <Akien> We'll discuss the wiki in a little while, maybe we can first finish listing our objectives
19:28:47 <Akien> filip_: I did not notice any branch, neither for mga3 nor for mga4
19:29:17 <filip_> #info Team objective: refresh the list of translation catalogs
19:29:42 <yurchor> The development was almost linear, DVCS's do not work this way.
19:30:13 <Akien> Yes that's my feeling too, I never really used the mga1 branch when there was one
19:30:17 <papoteur> DVCS?
19:30:37 <yurchor> Distributed Version Control systems.
19:31:08 <Akien> Branching can be interesting for near-complete or complete translations, that could get slightly updated and hopefully included in a bugfix update of the package
19:31:08 <papoteur> yurchor: txs
19:31:12 <yurchor> No branches = No need to branch...
19:31:55 <Akien> But I fear that if we have branches, some translators will lose time duplicating there translation work, without being sure that the mga3 or mga4 translations will be used in the end
19:32:14 <filip_> true
19:32:42 <filip_> but such translators can work safely in tx
19:33:01 <Akien> It seems there are tags for new versions of our software, so I'd suggest that people who want to provide a more complete translation can get the old po file from the tag
19:33:36 <Akien> But even there, we don't have any process to make use of these translations, as far as I can tell
19:34:19 <filip_> you mean translations from branches?
19:34:25 <Akien> Yes
19:34:55 <Akien> If people translate, say, draklive-install for mga3, it's likely that it will never be packaged and pushed as an update through QA
19:35:07 <filip_> I think that drak tools devs know that
19:36:25 <Akien> So altogether my feeling is that we shouldn't bother too much with maintaining branches, and focus on Cauldron. The life cycle of the distro is short enough
19:37:09 <filip_> right
19:37:39 <Akien> Do you see other objectives? Even big organisational changes, that we might not be able to do soon, but could start thinking about
19:37:57 <filip_> my wife said why you change so quickly? what's wrong? ;)
19:38:10 <Akien> Hehe :-)
19:38:37 <Akien> There is the question of our Transifex contributors, and how we can best let them be a part of the community
19:39:06 <filip_> our pages on wiki needs us. that could be our objective too.
19:39:24 <Akien> That's true.
19:40:02 <filip_> and linking tx to git and back
19:40:27 <Akien> #info Team objective: Rewrite and reorganise the i18n wiki pages
19:41:13 <filip_> I think we can reanimate tx usage page. it's in archive.
19:41:29 <papoteur> Akien, do you mean at an evalution of the objectives at end? ;)
19:41:36 <Akien> And probably refresh it somewhat, since Tx changed a lot
19:41:39 <filip_> we should have a new contributor in mind
19:41:48 <filip_> Akien: yeah.
19:42:02 <filip_> on the better I might add.
19:42:16 <Akien> filip_: Yes, I'd like a portal such as the QA portal :-)
19:42:31 <filip_> +1
19:42:38 <Akien> With clear explanations to guide newcomers
19:42:51 <filip_> any volunters?
19:43:29 * yurchor ducks
19:43:34 <Akien> papoteur: I think the objectives should be reviewed regularly, a bit like the Features
19:44:47 <Akien> filip_: I think a few volunteers should come up with a design idea: which pages, with what content and where, etc.
19:44:58 <filip_> yurchor please get up as you write excellent pages.
19:45:03 <papoteur> Akien: OK
19:45:16 <Akien> And then let other contributors work on a given page
19:45:43 <Akien> So basically we should (not yet) brainstorm about how the portal should be, which pages to write
19:45:48 <Akien> And then split the work
19:46:07 <Akien> I tried doing this by myself for Atelier, and it was a huge work
19:46:41 <Akien> So if there can be a small group of volunteers for the brainstorming work, I think it would be better, than letting one person do it all
19:47:50 * lebarhon Pages for i18n are already in docteam portal
19:47:59 <filip_> true. we're team.
19:48:24 <lebarhon> Why not only one portal ?
19:48:45 <filip_> I'm ok with that
19:48:49 <Akien> This could be an idea, yes
19:49:10 <lebarhon> it is there https://wiki.mageia.org/en/Doc_Team_Portal
19:50:10 <lebarhon> What i18n pages are missing ?
19:50:58 * filip_ is impressed
19:51:19 <Akien> The portal looks great :)
19:51:32 <Akien> Well most i18n pages that are not directly related to the documentation are missing
19:52:14 <Akien> But let's all think about it and maybe discuss this informally another day
19:52:28 <Akien> The show must go on, and the meeting should not be longer than 1 hour :-)
19:52:31 <papoteur> papoteur: I think it is a good idea to join the portal.
19:52:47 <filip_> maybe we need to start a thread about that on ML
19:53:02 <lebarhon> We should perhaps start by a list of the pages
19:53:02 <Akien> papoteur speaks with itself :-)
19:53:08 <Akien> s/itself/himself/
19:53:11 <filip_> hehe
19:54:04 <Akien> lebarhon: Yes good idea - a list of the existing pages, a list of the content that might be missing, and of the content that is obsolete
19:54:06 <filip_> Latte: are you around?
19:54:36 <Akien> Should we continue with the wiki topic?
19:54:38 <filip_> Akien: I agree
19:54:47 <Latte> filip_: hi
19:55:03 <filip_> let's create a thread about that on ML
19:55:29 <Akien> #action filip_ or Akien starts a topic about the i18n wiki pages on the ML
19:55:41 <Akien> #undo
19:55:41 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Action object at 0x85e828c>
19:55:45 <filip_> Latte you can join us on meeting
19:55:46 <Akien> #action filip_ or Akien (or anyone) starts a topic about the i18n wiki pages on the ML
19:55:48 <Akien> :-)
19:56:03 <filip_> where Akien gives jobs away
19:56:17 <Latte> just by chance
19:56:21 <Akien> And... the loooong awaited.....
19:56:22 <Akien> #topic Internationalised wiki
19:56:24 <Latte> today yes :)
19:56:30 <Akien> Wiki is coming.
19:56:37 <Akien> At least we hope so :-)
19:56:48 <filip_> n
19:56:51 <filip_> great news
19:57:27 <papoteur> O_O
19:57:30 <lebarhon> unbelievable
19:57:43 <papoteur> Who is working on?
19:57:48 <Akien> Well, it's not there yet! :-P
19:58:04 <Akien> But there is a strong will to make it happen, and tmb said he will work on it
19:58:11 <Akien> marja started this draft to help tmb: https://wiki.mageia.org/en/Mageia_Wiki_upgrade
19:58:29 <Akien> I had to have a look at it and try to improve it, but I haven't got the time to do it yet
19:58:50 <Akien> Basically the idea is to state _clearly_ what docteam and i18n need so that it works
19:59:24 <Akien> i.e.: which MediaWiki version, which TranslateWiki version, etc.
19:59:42 <Akien> s/TranslateWiki/Translate extension/
20:00:42 <Akien> So basically, there isn't much you have to do right now. Maybe have a look at the draft and improve it if you can.
20:01:17 <Akien> Then marja and I will discuss it with tmb to know how things will go on
20:02:51 <Akien> Checking a sysadmin-discuss mail about the Heartbleed issue, I see that our Alamut server is running Mageia 1
20:03:05 <Akien> (The wiki is on alamut, as told by "ping wiki.mageia.org")
20:03:19 <Qilaq> any, even very approximate timetable for translatable wiki? a week o wait? a month half year? a year?
20:04:24 <Akien> I can't tell for sure, but I'll discuss it together with marja and tmb. Only sysadmins can tell us when and how.
20:05:26 <Akien> Damien tried to upgrade some servers to Mageia (they were running Mandriva 2010), and some servers are now broken, so I suppose it will depend if they want to upgrade Alamut to Mageia 4 before upgrading the wiki, or not
20:05:52 <Akien> I'll see with tmb and pterjan soon and report back on the doc and i18n MLs
20:06:36 <papoteur> Akien: Thank you for you work.
20:07:05 <Akien> I won't do any promises as was done during those last years, but I'll try to help make it really happen this time :-)
20:07:07 <filip_> I think that priority is now release of mga 4.1 and then they'll plan upgrade
20:07:33 <Akien> Yes but for now mga 4.1 can't be released because the ISO building server is broken
20:07:51 <filip_> and QA team is flooded ;)
20:07:59 <Akien> Indeed
20:08:11 <Akien> Next topic, if there is one?
20:08:35 <Akien> #action Akien and marja discuss the wiki upgrade with tmb and try to define a precise upgrade planning
20:08:36 <filip_> hour has passed ;)
20:09:09 <Akien> So let's call it a day and continue discussions informally or on the ML
20:09:25 <lebarhon> At a former mageia meeting, ennael said she was thinking to merge doc+i18n
20:09:30 <filip_> I'll try to remind colin about his offer helping us
20:09:36 <lebarhon> any news?
20:10:03 <papoteur> No news for me.
20:10:19 <filip_> lebarhon: from colin?
20:10:40 <papoteur> filip_: from merging i18n and doc
20:10:52 <lebarhon> filip_: I don't understand
20:11:04 <Akien> I haven't heard about a doc/i18n merger. We discussed it a while ago and decided not to do it then, but we can rethink about it if you want :-)
20:11:09 <filip_> papoteur: we need to decide and agree
20:11:20 <filip_> lebarhon: never mind
20:11:29 <papoteur> filip_: or not ;)
20:11:29 <lebarhon> filip_: sorry
20:12:12 <filip_> papoteur: true. thx for a bug fix ;)
20:12:21 <lebarhon> it was the meeting 3 weeks ago
20:13:10 <papoteur> filip_: bug fix? Which one?
20:13:32 <filip_> papoteur: agree or not
20:13:54 <papoteur> ;)
20:14:01 <filip_> should we close the meeting?
20:14:06 <Akien> Yep
20:14:17 <yurchor> Yes.
20:14:18 <Akien> #endmeeting