19:08:28 <Akien> #startmeeting
19:08:28 <Inigo_Montoya> Meeting started Thu Nov  7 19:08:28 2013 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:08:28 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:08:43 <Akien> #chair filip__ yurchor
19:08:43 <Inigo_Montoya> Current chairs: Akien filip__ yurchor
19:09:07 <Akien> Now that's half the attendants are chaired... :p Let's start :)
19:09:24 <Akien> Welcome to this exclusive Fall 2013 i18n team meeting!
19:09:44 <marja> :-)
19:10:01 <yurchor> :)
19:10:06 <Akien> Okay, as I posted on the ML this morning, we have a few things to discuss.
19:11:01 <Akien> #topic Git migration
19:11:52 <Akien> From what I understand, the soft/ SVN repo has been completely migrated to git, but we don't have the i18n-specific repo yet
19:12:14 <yurchor> Akien: Web is on SVN.
19:12:17 <Akien> The web repo is still on SVN too.
19:12:50 <Akien> Indeed
19:13:05 <filip__> #info The web repo is still on SVN.
19:13:25 <Akien> Actually https://wiki.mageia.org/en/Git_Migration talks only about the software repo, so it can be that it was not planned to move the web part for now
19:13:38 <Qilaq> is there a plan to migrate web also? and timetable or something for that?
19:14:11 <Akien> Maybe we can ask colin about it
19:14:12 <filip__> Qilaq: we have asked syadmins already but no response yet
19:14:32 <marja> not even all software things have been moved yet, mageia-doc is still in SVN (contains stuff for the MCC-help package)
19:14:38 <Akien> It's not needed for now, but it's good to know if SVN will stay in our workflow for another year or more
19:15:09 <filip__> web question: https://ml.mageia.org/l/arc/sysadmin-discuss/2013-11/msg00000.html
19:15:57 <Akien> Yes I remember; it's easy to miss it though, I'll ask directly on sysadmin-discuss about it.
19:16:10 <filip__> Akien: please do
19:16:39 <Akien> #action Akien asks sysadmins about the git migration: web, i18n repo
19:16:57 <Qilaq> OTOH web is not concerned about freesing and all the stuff, so it may be migrated anytime without too much trouble
19:17:25 <Akien> Apart from that I have the feeling that our community managed the migration quite well, thanks to the tutos you and docteam wrote on the wiki, and filip's script
19:17:50 <Akien> Which would lead to our second topic, unless you have more to discuss on the git migration?
19:18:29 <filip__> remmy is original author and contributor
19:19:01 <Akien> :)
19:19:35 <Akien> #topic remmy and filip's check_for_translation.sh script
19:20:12 <Akien> #undo
19:20:12 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Topic object at 0x84dc9ac>
19:20:15 <Akien> #topic remmy and filip's check_for_translation_work.sh script
19:20:45 <Akien> I think you all read about it and got to play with it a bit
19:21:18 <Akien> It does a nice job to clone/checkout the relevant sources and list the translations which need work
19:22:22 <Akien> I think we now have a howto on the wiki for the script?
19:22:51 <Akien> https://wiki.mageia.org/en/How_to_write_and_translate_Mageia_doc#The_script_.22Check_for_translation_works.sh.22
19:22:51 <filip__> #link https://wiki.mageia.org/en/How_to_write_and_translate_Mageia_doc#The_script_.22Check_for_translation_works.sh.22
19:23:04 <Akien> Exactly :)
19:23:12 <filip__> ;)
19:23:32 <lebarhon> filip__: has still a job to do :)
19:23:40 <Akien> I think (and I read about it on the ML too) that it should have it's own page
19:23:50 <Akien> Linked both in the i18n/l10n and docteam resources
19:24:01 <Akien> s/it's/its/
19:24:01 <filip__> lebarhon: anybody can help.
19:24:47 <Akien> The config file is already quite well commented, but the more we explain on the wiki, the better it will be for those of us who don't like editing config files.
19:25:24 <filip__> which is most of us ;)
19:25:41 <marja> :-)
19:26:06 <Akien> Once all working translations are copied into their specific directory, what would be the workflow?
19:26:25 <Akien> Translate them, and then copy them manually back into the git/svn tree, to commit/push?
19:26:53 <filip__> yes.
19:27:19 <filip__> #link https://wiki.mageia.org/en/Translating_with_Lokalize
19:27:54 <Akien> #info Howto: run the script (see wiki for configuration), translate in the working directory, copy the translations back to their git/svn tree and commit.
19:27:54 <filip__> renaming is needed (for safety reasons)
19:28:02 <Akien> #undo
19:28:02 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x821d26c>
19:28:11 <Akien> #info Howto: run the script (see wiki for configuration), translate in the working directory, copy and rename the translations back to their git/svn tree and commit.
19:29:06 <Akien> That's great, it's a valuable tool for translators
19:29:14 <lebarhon> And copy the screenshots in Calenco
19:29:32 <filip__> Akien: until tx or something online
19:29:53 <Akien> Indeed, that's the next topic :)
19:30:13 <Akien> Everybody managed to use the script?
19:30:28 <marja> yes
19:30:32 <napcok> yes
19:30:43 <Akien> Great :)
19:30:54 <Akien> Let's go on with the burning topic then.
19:31:11 <Akien> #topic Transifex strikes back
19:31:52 <lebarhon> When I saw it in the topics, I thought it was a joke
19:31:58 <Akien> Okay, the actions of our last meeting were supposed to really do this migration to Tx
19:32:01 <Akien> lebarhon: :p
19:32:13 * yurchor wonders who is a victim of the strike...
19:32:43 <marja> yurchor: lol
19:33:00 <Akien> I didn't do mine, both because I was waiting for our i18n git repo and because I forgot and eventually did other things
19:33:04 <Akien> And Oliver went MIA
19:33:15 <marja> what is "MIA"?
19:33:20 <Akien> Missing In Action :)
19:33:22 <marja> ah, missi
19:33:24 <marja> yes :-)
19:33:54 <Akien> It seems to be for happy reasons, so that's great for him :)
19:34:07 <marja> it is :-)
19:34:21 <Akien> But now we have to take the Tx case into our hands and leave Oliver be, if we want Tx, we have to make it happen.
19:34:26 <filip__> true, but a short notice would be great
19:34:31 <Akien> I agree
19:35:54 <Akien> So first question, do we still want to switch to Tx? (We don't have to discuss this for hours, but I just want to take the temperature before going forward)
19:36:13 <filip__> I do
19:36:35 <lebarhon> We had tx and stop it, why go back ?
19:36:35 * filip__ married
19:36:39 <yurchor> It will bring us more translators.
19:37:03 <filip__> old version was broken
19:37:07 <Akien> lebarhon: A bit of history: our first instance of Tx was self-hosted and managed by misc, one of the sysdamins
19:37:27 <Akien> It was eventually broken, and misc left the project (not because of our Tx :p), so noone could fix it, and we dropped it
19:37:47 <lebarhon> but each time we change our procedure, we lose translators
19:37:47 <Akien> Then we talked about alternatives, nothing happened, and decided to use tx.com
19:38:01 <marja> Akien: if nothing was really done yet to move to tx, why not take a fully opensource project instead?
19:38:07 <lebarhon> po is a good alternative
19:38:22 <yurchor> lebarhon: Those who wnat the old way will not siffer.
19:38:27 <Akien> So we created mageia-test on tx.com to see if it fits our needs.
19:38:29 <yurchor> *suffer
19:38:43 * marja forgot about the test
19:39:13 <filip__> Akien: who manage it?
19:39:43 <Akien> filip__: Oliver, a few others, and I since last meeting, when I started looking at it again
19:40:13 <Akien> I wanted to conceptualise how should the tree look like, to start working on a script to push/pull
19:40:41 <Akien> lebarhon: Tx does not replace the po system and git, it's just a web interface to help us see the progress
19:40:47 <marja> .
19:40:53 <Akien> Basically it's like filip's script, but with more eye-candy
19:41:14 <filip__> Akien: I think way more
19:41:17 <Qilaq> I'm quite confident that now we have real experienced translators who can master SVN and Git, so bringing Tx back can only widen translators' base
19:41:17 <Akien> marja: I don't know much about the opensource alternatives.
19:41:22 <filip__> tranlation memory
19:41:35 <filip__> it's also much easier to use
19:42:29 <Akien> Qilaq: I feel the same.
19:42:42 <filip__> +1
19:42:53 <lebarhon> it is yet another system
19:42:54 <marja> http://translatewiki.net/wiki/Main_Page
19:43:15 <Akien> The work done by our current translators to understand how git works, how to work with lokalize or other tools is not lost - we need people with this knowledge to make sure everything works
19:43:29 <Akien> And then Tx is an easy access for more translators joining the project
19:43:29 <filip__> lebarhon: but you don't have to change your workflow. There is only bigger choice
19:43:34 <Qilaq> yeah, I didn't mean especially Transifex, it may be also antoher web translation system
19:43:47 <marja> Akien: ^^^ one of its developers is also the developer of the translate extension we want to use for our wiki
19:43:56 <lebarhon> we keep changing the translation tools and don't have a multilanguage wiki !
19:44:03 <filip__> can someone please paste a link
19:44:10 <lebarhon> I don't understand the priorities
19:44:32 <marja> lebarhon: the translate extension for the wiki needs a higher wiki version than we use
19:44:44 <Qilaq> priority should be translation more easier and comfortable
19:44:50 <filip__> +1
19:45:07 <yurchor> marja: TW extension is somewhat slow. TM does not work well. Tested on kde userbase wiki. It's very good for translating docs but not much good for software, imho.
19:45:08 <marja> lebarhon: as soon as that is done, we'll have a multi language wiki, but now we don't have a good tool for it
19:45:28 <Qilaq> so far few of us have mastered svn and git but as seen (e.g. Russian translators) not all feel themselves comfortable with that
19:45:28 <lebarhon> marja: Mandriva had such a wiki
19:45:42 <Qilaq> so some web translation system may help
19:46:18 <Akien> lebarhon, marja: For the wiki, we need a translator willing to look into it, and do it.
19:46:29 <marja> yurchor: you mean translatewiki.net is not good?
19:46:54 <yurchor> marja: It's good. But it's not a silver bullet.
19:47:07 <marja> yurchor: sorry, what is "TM"
19:47:21 <yurchor> marja:  Translation memory.
19:47:28 <marja> Akien: a translator can't update the wiki
19:47:30 <lebarhon> Akien: We have nobody for the wiki but peoples for Tx ?
19:47:55 <yurchor> marja: Switched off on Userbase because it really slows down wiki.
19:48:01 <marja> Akien: and oliver wanted to only start with wikis in other languages when we had the translate extension
19:48:08 <Akien> lebarhon: Tx is easy, we register on a website, upload our resources... the only hard part it to make a script to have everything in sync
19:48:13 <filip__> #link https://www.transifex.com/projects/p/mageia-test/
19:48:18 <Akien> lebarhon: But the wiki requires a dev, and a sysadmin
19:48:33 <marja> lebarhon: for the wiki upgrade sysadmin help is needed
19:48:38 <filip__> lebarhon: please take a look for a few minutes
19:48:54 <marja> yurchor: OK, thx
19:49:20 <lebarhon> I know Tx, I used it
19:49:58 <Qilaq> we don't need to use one and only one system for everything, do we?
19:50:37 <Qilaq> it may be very well Tx for software and maybe for doc and that other one for wiki?
19:50:57 <Akien> My main concern is not really about priorities, it's about actually doing it. We have been discussing the localised wiki and Tx for ages
19:51:15 <Akien> I think you feel like I that if we don't _do_ something now, it will _never_ happen
19:51:34 <marja> indeed
19:51:43 <Akien> That's probably what's driven filip__ into enhancing this helpful script :)
19:52:05 <marja> some translators have been busy on the mageia-test tx
19:52:14 <marja> and translated everything
19:52:35 <Akien> marja: Not too many I think, apart from Umeaboy
19:53:03 <Akien> The up-to-date translations result from my tests (the mageia-test has old pot files, and not all translations uploaded)
19:53:32 <marja> Akien: 3 fully translated languages and 1 more than half, and that is *not* including Swedish
19:54:28 <filip__> just a question. What if we update pot files and start to use it?
19:54:39 <marja> well, I count 98% as full, too
19:55:02 <Akien> marja: I mean, if you update one pot file and it's corresponding fr.po file, you will get such as score.
19:55:12 <Akien> It does not mean someone used Tx to translate
19:55:19 <Akien> s/update/upload/
19:55:23 <marja> Akien: ah, OK
19:55:33 <Akien> But it would be nice to check that we are not losing actual translations, yes
19:55:47 <Akien> I know Umeaboy translated on this test instance, so at one time his work should be pushed to git
19:56:19 <Akien> filip__: Then it will be ready to use, it will just have an unneeded "-test" in its name :)
19:56:41 <filip__> but it is a test isn't it ;)
19:57:20 <filip__> later we can change the name if we accept it
19:57:23 <Akien> In last meeting Oliver was supposed to ask if we can have a mageia.transifex.com subdomain
19:57:33 <filip__> exactly
19:57:51 <Akien> Should I proceed with that?
19:57:51 <filip__> in the mean time we can do "real" test
19:57:58 <Akien> Maybe we can do both yes
19:58:16 <Akien> Update the mageia-test instance to the current state of our translations
19:58:24 <yurchor> +1
19:58:30 <filip__> a+1
19:58:31 <Akien> And if we get the subdomain, migrate it if possible
19:59:58 <Akien> Once the instance is up-to-date and our translators start playing around with it, the i18n/dev guys can think about how to get Tx in sync with git/svn
20:00:24 <filip__> Akien: great lets do some # action
20:00:30 <marja> :-)
20:00:51 <Akien> #action Akien mails Tx.com about the possibility of having a mageia subdomain (with i18n-discuss in CC)
20:01:32 <filip__> who can help with updating pot files and stuff?
20:01:34 <Akien> Who wants to help me manage the Tx instance?
20:01:40 <filip__> ;)
20:02:15 <yurchor> Akien: Ican do some things.
20:02:17 <Akien> filip__ and yurchor?
20:02:32 <filip__> I don't have experience but I guess I can try
20:02:54 <Akien> #action Akien grants admin priviledges to filip and yurchor on tx.com/mageia-test
20:03:09 <Akien> #action The admins upload the latest pot files and translations to tx.com
20:03:14 <filip__> what about other current maintainers: Yaron Piratu ?
20:03:37 <Akien> They were quite silent recently, so I suppose they lost interest (for now)
20:03:37 <yurchor> No need to upload. Just use correct links on gitweb
20:04:01 <Akien> yurchor: What do you mean? You can link a resource which is online?
20:04:10 <yurchor> Tx will pull files automatically.
20:04:14 <Akien> Wow
20:04:14 <filip__> Akien: probably because of our (non)response
20:04:26 <Akien> That's the awesome feature we've been looking for :)
20:04:58 <filip__> for that we can use translation_projects.dat
20:05:13 <yurchor> It's just for POT. POs should be uploaded by txclient
20:05:21 <Akien> Ok
20:06:49 <filip__> a side wish: I would like unofficial list to be as short as possible. Can we discuss it?
20:07:51 <Akien> Yes, are we done with tx?
20:07:52 <filip__> #info Tx pulls files automatically from correct links on gitweb
20:08:04 <filip__> #undo
20:08:04 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x83594ac>
20:08:11 <filip__> #info Tx pulls pot files automatically from correct links on gitweb
20:08:26 <filip__> that is connected
20:08:40 <yurchor> filip__: Thanks.
20:08:49 <filip__> do we want unofficial list to be there
20:10:01 <filip__> copyiso2usb, drakx_help, indexhtml_about, net_monitor, usbdumper
20:10:08 <filip__> are there
20:10:52 <yurchor> net_minitor is official now. Packages are in Cauldron.
20:11:37 <yurchor> Thanks napcok for fixing a bug. ;)
20:11:37 <filip__> #action filip will move net_monitor to the official list
20:12:14 <filip__> usbdumper is unmaintained AFAIK
20:12:55 <yurchor> It's in github now. Ruled by papoteur.
20:13:04 <Akien> No that's isodumper
20:13:18 <yurchor> It's the same thing.
20:13:49 <yurchor> usbdumper should be removed.
20:14:11 <yurchor> Moreover, it's POT is outdated.
20:14:15 <Akien> yurchor: It's the same purpose but I don't think it's the same software.
20:14:24 <Akien> usbdumper is an old project from mandriva times
20:14:33 <Akien> We imported it but nobody touch it I think
20:14:37 <Akien> s/touch/touched/
20:15:25 <yurchor> No nedd for the second thing that do not work when we have a maintaned working thing.
20:15:33 <Akien> Indeed
20:15:48 <Akien> I think we should have a "unmaintained list" more than an "unofficial list"
20:16:02 <filip__> good idea
20:16:03 <Akien> We can just drop usbdumper translation-wise
20:16:20 <filip__> #idea we should have a "unmaintained list" more than an "unofficial list"
20:16:23 <Akien> I think drakx_help is unmaintained to?
20:17:28 <filip__> we asked tv already IIRC
20:17:39 <Akien> What is it actually? The former installer help, but now we use another system based on XML files?
20:17:56 <filip__> I think so
20:18:36 <Akien> Then it's unmaintained too
20:19:15 <filip__> but maybe some strings are used. if tv doesn't know how can we
20:19:52 <Akien> Then we'll send him another mail _on dev_ and a second one to know what to do with it.
20:20:17 <Akien> And if some strings are used, we'll ask him to remove the unused ones.
20:20:36 <Akien> Or at least comment them out
20:20:41 <filip__> Akien: I think you're the best person for that action
20:20:57 <Akien> :D
20:21:08 <Akien> What's the quota, one issue with tv per contributor per year? :p
20:21:35 <Akien> #action Akien asks tv about drakx_help
20:22:13 <filip__> It's not easy but we as a team need you
20:22:33 <Akien> Well it's my role, I'm okay doing it :)
20:22:46 <filip__> nice
20:23:06 <marja> :-)
20:23:11 <Akien> And if I can't get an answer I can ask council to get me an answer
20:23:43 <filip__> yes. but I believe that tv will answer
20:23:56 <Akien> I think so, too.
20:24:40 <Akien> copyiso2usb will probably go to the official list, we should ask Dave about it
20:24:58 <Akien> Does it also use gettext?
20:25:06 <filip__> it does
20:26:09 <Akien> Then if it's on git we can consider it an official Mageia resource
20:26:19 <filip__> ok
20:26:20 <Akien> Dave is just searching for some help packaging it IIRC
20:27:05 <filip__> #action filip will move copyiso2usb to the official list
20:28:34 <filip__> we're upstream anyway
20:28:40 <Akien> Yes
20:29:18 <Akien> Do you want to discuss communication with the dev team shortly, or should we stop the meeting there?
20:30:26 <filip__> maybe we should do another meeting next week?
20:30:58 <marja> +1
20:31:08 <Akien> We could, if we take it as a deadline to prepare mageia-test for the l10n fellows :)
20:31:38 <Akien> (By l10n I mean those who do translation both in i18n and doc teams)
20:31:47 <yurchor> Stop. I want to sleep. ;)
20:31:53 <Akien> :D
20:32:05 <Akien> Then, thanks for attending everyone!
20:32:12 <Akien> It's good to do a meeting once in a while :p
20:32:17 <yurchor> Thanks.
20:32:18 <marja> Akien: thx a lot for the meeting!
20:32:24 <Akien> #stopmeeting
20:32:33 <marja> Akien: it is #endmeeting
20:32:36 <Akien> #endmeeting