19:03:37 <obgr_seneca> #startmeeting
19:03:37 <Inigo_Montoya`> Meeting started Thu Jul 25 19:03:37 2013 UTC.  The chair is obgr_seneca. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:37 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:45 <obgr_seneca> #chair Akien
19:03:45 <Inigo_Montoya`> Current chairs: Akien obgr_seneca
19:03:59 <obgr_seneca> Welcome to the first pre Mga4 i18n meeting
19:04:50 <obgr_seneca> We have the following agenda tonight:
19:04:55 <obgr_seneca> - team status
19:05:09 <papoteur> Hello
19:05:14 <obgr_seneca> - web translation platform
19:05:27 <obgr_seneca> - git migration
19:05:34 <obgr_seneca> - i18n vs. l10n
19:05:39 <obgr_seneca> - other
19:05:46 <obgr_seneca> Did I forget anything?
19:06:23 <Akien> Maybe a small topic on Mga4 agenda, and what concerns our team
19:06:35 <obgr_seneca> Yep
19:07:37 <obgr_seneca> So, let's begin with that one
19:07:49 <obgr_seneca> #topic Mga4 development planing
19:07:55 <Akien> #url https://wiki.mageia.org/en/Mageia_4_Development
19:08:02 <obgr_seneca> Thx Akien
19:08:47 <obgr_seneca> The most important dates for us are
19:09:10 <obgr_seneca> the new strings freeze on 2013-10-15
19:09:30 <obgr_seneca> and the translation freeze on 2013-12-14
19:10:33 <Akien> I don't understand what is the date-less "i18n freeze". I suppose it's an error, unless it really means i18n and not l10n
19:10:34 <obgr_seneca> #info After the "new strings freeze" on 2013-10-15 we should have no string changes
19:11:13 <obgr_seneca> That means, we will have time do work on translations without having to redo everything all the time
19:11:41 <filip_> I like new "new strings freeze" date ;)
19:12:14 <obgr_seneca> #info The "translation freeze" on 2013-12-14 is the last date to push translatiopns that will definitely be in Mga4
19:12:49 <obgr_seneca> Of course, if there should be string fixes after the official freeze date, we can still try and push the translations for them
19:13:07 <obgr_seneca> Akien: I don't know, but I think it slipped in...
19:14:16 <papoteur> ;)
19:14:29 <obgr_seneca> Are there questions about the development planning?
19:14:53 <marja> not here
19:14:55 <filip_> to me "i18n freeze" seems that dev stop changing strings for us
19:17:20 <obgr_seneca> Iirc it was not in the council discussions, so I think somebody forgot to delete that line when copying the Mga3 planing
19:17:30 <Akien> Back in a minute.
19:17:41 <obgr_seneca> filip_: That's more the "new strings freeze"
19:18:33 <papoteur> We have time to know that precisely.
19:18:39 <obgr_seneca> Yes
19:19:32 <filip_> I think that changes of old strings are meant
19:20:15 <obgr_seneca> I just looked into the last mail on council ml about the planing, and the date is not in there, but I'll ask ennael
19:21:02 <obgr_seneca> #action obgr_senecafind out about "i18n freeze date" in planing
19:21:35 <obgr_seneca> So, next topic?
19:21:37 <kiki-syahadat> maybe "i18n freeze" is no additional language will be added after that date.
19:22:39 <Qilaq> usually i18n freeze means that (visible, translatable) strings are not allowed to change anymore
19:22:45 <obgr_seneca> kiki-syahadat: Adding languages is not so big a problem, so we wouldn't need another date for it
19:22:58 <obgr_seneca> As I said, I'll ask ennael
19:24:26 <obgr_seneca> #topic team status
19:24:51 <obgr_seneca> Ok, as I see it, there's not much to say
19:25:08 <obgr_seneca> It has been quiet for a while mainly due to me not having all that much time
19:25:32 <obgr_seneca> So, we should brainstorm about getting the team to life
19:25:48 <obgr_seneca> But I think that's something to be done on the ml
19:26:05 <marja> OK
19:26:09 <obgr_seneca> As it might end in a longer discussion, and we migth have more people on the ml
19:26:14 <obgr_seneca> Comments?
19:26:57 <marja> just out of curiousness.... did we ever contact schools for translators?
19:26:58 <Qilaq> as I can not be here long - football European championship semi-final what I very much want to see - so I just say that Estonian team (in mine person :-) ) is still there and will be active again in month or so
19:27:17 <obgr_seneca> Qilaq: ok!
19:27:23 <marja> Qilaq: enjoy the game and thx for your hard work so far
19:27:47 <obgr_seneca> (Might I ask, who is playing against whom?)
19:28:27 <Qilaq> I may occasionally say something more yet, as TV and computer are both quite near :-)
19:28:42 <Qilaq> Norway vs Denmark
19:28:56 <marja> ah :)
19:29:16 <obgr_seneca> Ok...
19:29:41 <obgr_seneca> #action obgr_seneca and Akien start a ml discussion about bringing the team to life...
19:30:11 <obgr_seneca> Ok, next topic?
19:30:44 <obgr_seneca> #topic Git migration
19:31:08 <filip_> obgr_seneca: I was cut off for a few minutes. was there previous team report?
19:31:32 <obgr_seneca> filip_: Freenode seems a bit instable tonight
19:32:22 <marja> there was an anouncement: 2013:07:25:21:11 [freenode] -mist(~mrmist@freenode/staff/mist)- [Global Notice] There may be some join/part noise for a while as we need to re-hub a few servers for some maintenance.  Those of a nervous disposition may wish to take a break and grab a beverage. Thanks for flying freenode.
19:32:29 <obgr_seneca> I'd like to have a brainstorming about the teams status and the possibilities we have to get more life in the team on the ml
19:32:34 <Akien> I'm back
19:32:49 <filip_> obgr_seneca: great
19:33:10 <obgr_seneca> So back to git
19:33:23 <obgr_seneca> There's not much I can say, there will be changes in the workflow
19:33:49 <obgr_seneca> And I forgot to ask colin about the status of the migration
19:34:19 <obgr_seneca> As soon as I know more, I will tell
19:34:34 <marja> OK
19:34:55 <Akien> Should we try to catch boklm for some update on this?
19:35:24 <obgr_seneca> Akien: I just pinged him
19:35:57 <Akien> Basically we will have to learn a new workflow with git, but it should be quite similar to what we do with SVN.
19:36:08 <Akien> If it's well documented in the wiki, there should be no problem.
19:36:11 <obgr_seneca> But if he does not answer, we will just carry on and see to get those informations on the ml
19:36:45 <Akien> From the discussions with coling and boklm on i18n-discuss, we can also infer that they will do something nice for us :)
19:37:04 <marja> :)
19:37:08 <obgr_seneca> I think it won't be that much of a change for us translators
19:37:33 <Akien> (The latest news were that they were looking into having the po folders for all project in the same git repository.
19:37:52 <Akien> So we'll just have to check out the whole repository, without being encumbered from software files.
19:38:11 <marja> nice
19:38:57 <Akien> boklm is not answering yet, so I guess we can go on.
19:39:16 <obgr_seneca> Yep...
19:39:18 <Akien> He and coling will keep us informed when they make progress I suppose.
19:39:21 <filip_> I'll wait with the changes of the script for i10n changes
19:39:41 <obgr_seneca> i18n or l10n? :D
19:39:44 <marja> filip_: i10n ;-)
19:40:06 <Akien> And coling seems willing to make the move quite smooth for us, so we'll get a detailed and dated process I guess.
19:40:31 <obgr_seneca> If colin does the work, it will be
19:41:07 <obgr_seneca> Ok, next one?
19:41:28 <Akien> Yep
19:41:30 <obgr_seneca> #topic i18n vs. l10n
19:41:47 <obgr_seneca> Ok, actually we are a l10n team, not i18n
19:41:58 <obgr_seneca> See that wiki page, Akien posted on the ml
19:42:14 <Akien> #url https://wiki.mageia.org/en/Whats_is_i18n,_what_is_l10n
19:42:23 <obgr_seneca> But historically, the two names get mixed quite a lot.
19:42:57 <obgr_seneca> KDE renamed its translation team and packages from i18n to l10 when they switched from 3 to 4 iirc
19:43:24 <obgr_seneca> Mdv was calling the translation team "i18n", we just continued to do so
19:43:49 <obgr_seneca> So the question is: Do we care enough about wrongly using the name or should we rename the team?
19:44:04 <filip_> but I do some i18n work with web report ;)
19:44:23 <obgr_seneca> I'd like not to do that, as it will add more confusion...
19:44:27 <marja> the question is also, should there be two mailing lists, to seperate issues
19:45:05 <filip_> renaming the team means also rename this channel ;)
19:45:20 <obgr_seneca> Actually, the real "i18n" work is done by the devs, and we don't have enough of them to create an extra i18n team
19:45:40 <obgr_seneca> So I am leaning towards keeping the status quo
19:46:03 <marja> obgr_seneca: I've been told those issues are discussed on i18n ml, and that some got irritated, did I misunderstand?
19:46:19 <filip_> renaming seems fine to me but not for sysadmins
19:46:24 <marja> obgr_seneca: the issues for developers, I mean
19:47:00 <Akien> I agree that most i18n work actually happens on dev, and the few of us who are willing/capable to dive in the code, are most probably already part of the dev team.
19:47:23 <obgr_seneca> It would mean renaming the mls, rename this channel, mooving arround wiki pages
19:47:51 <marja> Akien: so there could be a SIG i18n for the dev part?
19:47:59 <obgr_seneca> And I don't think it's woth the effort
19:48:12 <marja> obgr_seneca: sounnds like a lot of work :-/
19:48:14 <Akien> marja: That sounds sensible.
19:48:50 <Akien> marja: Or maybe a SIG dev in the i18n part ;)
19:48:57 <filip_> we can include some explanation on all wiki pages now named i18n
19:48:59 <marja> Akien: l0l
19:49:20 <obgr_seneca> We can do it slowly...
19:49:32 <marja> Akien: I think it was agreed that the SIGs should put their mails on dev ml....correct?
19:49:34 <obgr_seneca> First by mving all our wiki pages, but keeping links
19:49:51 <obgr_seneca> Then by creating new irc channels
19:50:06 <Akien> srtxg2: ping
19:50:08 <obgr_seneca> And then by renaming the mls
19:50:17 <marja> obgr_seneca: step by step sounds OK
19:50:22 <obgr_seneca> And running fast enough, so the sysadmins won't catch us
19:50:24 <filip_> this sounds much easier
19:50:46 <Akien> Hehe
19:51:05 <obgr_seneca> Wiki and IRC are quite easy, we can do it on our own
19:51:17 <obgr_seneca> Only the mls need sysadmin assistance
19:51:49 <Akien> Another solution would be to keep "i18n" for the short name of our team, and have the long name be "Internationalisation and localisation team"
19:52:22 <obgr_seneca> Akien: That would be the easier part
19:52:25 <Akien> And then have some kind of subgroup who knows about i18n and keeps in touch with the devs.
19:52:28 <filip_> Akien: I'm not sure if long name is technicaly correct
19:52:43 <Akien> As is already done by filip_ or yurchor presently.
19:53:06 <marja> nice, for the forums it doesn't make a difference... no i18n there, just translating and translators
19:53:57 <Akien> So I mean we can keep the current names, and just update the wiki and website now that we better understand the difference between i18n and l10n.
19:54:39 <obgr_seneca> Yep
19:55:05 <obgr_seneca> Let's slowly update the wiki pages, we can see after other things then
19:55:15 <obgr_seneca> Further comments?
19:55:42 <Akien> But apart from the naming issue, it's right that we need to have a real i18n branch.
19:55:54 <Akien> Since most of us are actually doing or wanting to do l10n.
19:56:16 <filip_> I volunter for checking website for i18n
19:56:37 <Akien> Maybe some brainstorming about it could go with the general brainstorming about bringing more life to the team?
19:56:39 <filip_> and changing it to i10n when apropriate
19:56:50 <obgr_seneca> Ok then...
19:57:08 * lebarhon thinks like akien
19:57:18 <Akien> obgr_seneca: I'm writing an #agreed on this
19:57:25 <obgr_seneca> yep
19:57:57 <Akien> #agreed We currently use i18n wrongly, as most i18n stuff is done by the devs, and we do mostly l10n.
19:58:12 <obgr_seneca> #topic web translation platform
19:58:37 <obgr_seneca> Ok, I am sorry to say, but I did not get anywhere with pootle
19:58:41 <Akien> #undo
19:58:41 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Topic object at 0x837e40c>
19:58:42 <Akien> #agreed Changing i18n for l10n would be quite a hassle, so for now we'll keep the name but better explain which part of our work is i18n, and which part is l10n.
19:58:46 <Akien> #topic web translation platform
19:59:03 <obgr_seneca> So, we have have two choices now
19:59:22 <obgr_seneca> First: Someone else tries to get a pootle rpm up and running
19:59:34 <obgr_seneca> Second: We use tx.net after all
19:59:49 <obgr_seneca> So, which way shall we go?
20:00:20 <Akien> Well we held a meeting a month ago, and the consensus was to try with tx.com
20:00:26 <Akien> (It's .com now IINM)
20:00:35 <obgr_seneca> Ah, ok
20:00:45 <Akien> We already have a test instance running.
20:00:55 <obgr_seneca> So, shall we try to get a subdomain of our own like Fedora has it?
20:01:01 <lebarhon> we could use Tx actually ?
20:01:07 <obgr_seneca> Meaning mageia.tx.com?
20:01:38 <Akien> obgr_seneca: That would be great.
20:02:28 <obgr_seneca> #action obgr_seneca talk to tx people and see if we can get a subdomain there
20:02:28 <Akien> I did not know Fedora was using tx.com, but then we could probably import some nice documentation from them.
20:02:43 <papoteur> Who owns tx.com? Have we garranty about long term?
20:03:02 <obgr_seneca> It's a greek com pany I think
20:03:11 <Akien> papoteur: tx.com is owned by the Transifex (or is it still Indifex) company
20:03:14 <obgr_seneca> The same people that are developing tx
20:03:36 <Akien> papoteur: They provide a paid-for service to companies, but open-source projects get free access to all their tools.
20:04:19 <obgr_seneca> So we have the same warranty as we do have, when we are using a self hosted solution
20:04:22 <obgr_seneca> none
20:04:59 <obgr_seneca> But they are arround for some time now
20:05:07 <filip_> well in theory we can fix self hosted solution ;)
20:05:13 <obgr_seneca> SO I think it#s worth a try
20:05:25 <papoteur> Ok.
20:05:36 <Akien> filip_: In theory, but they have more workforce as we do :)
20:05:36 <obgr_seneca> filip_: As misc couldn't I'm not sure we have anyone who can do it
20:05:49 <Akien> obgr_seneca: I think he meant generally speaking, not our broken Tx
20:06:41 <Akien> Basically, if we want to migrate to mageia.tx.com, the migration process would be:
20:07:05 <Akien> 1) Write scripts for import of data from git to tx.com, and from tx.com to git.
20:07:33 <Akien> 2) Import the data to tx.com
20:07:46 <obgr_seneca> 2) should be rather easy
20:08:20 <Akien> 3) Have a detailed workflow described on the wiki, backed up with jobs and hooks on the git side.
20:08:55 <Akien> The third point has to be discussed, to see what level of automation we want.
20:09:07 <obgr_seneca> Yep
20:09:21 <obgr_seneca> As I said, 2) is rather easy, I think
20:09:33 <obgr_seneca> 1) needs some work, but I think we can manage
20:09:51 <Akien> Ah actually: Step 0) Check that the syntax of .pot and .po files generated by tx.com pleases us.
20:10:01 <obgr_seneca> 3) needs some discussion
20:10:03 <Akien> We had some issues with this with our old Tx IIRC.
20:10:14 <obgr_seneca> And yes, 0 is important as well
20:10:20 <filip_> but our tx was ancient
20:10:26 <obgr_seneca> Yep
20:10:26 <Akien> Indeed
20:10:39 <Akien> And the company has been more active lately, than when we were using it.
20:10:41 <Akien> (I fonud)
20:10:43 <Akien> *found
20:11:15 <Akien> There's at least no reason it's worse, so it's probably better.
20:11:16 <obgr_seneca> #action Akien write a mail with those four points and some explanation
20:11:21 <Akien> Ok
20:11:39 <obgr_seneca> #action everyone discuss it on the ml
20:11:46 <Akien> The main discussion should be on what level of automation we want.
20:11:51 <obgr_seneca> #action obgr_seneca get it running
20:12:10 <Akien> e.g. daily pushes and pulls to keep everything in sync, or only reports on i18n-reports and manual pushes and pulls;
20:12:58 <Akien> I fear that e.g. automatically importing an updates .pot file from git to tx.com might break things when it's a typo fix.
20:13:14 <obgr_seneca> Akien, we have to see
20:13:17 <Akien> Yes
20:13:28 <obgr_seneca> Further comments?
20:13:54 <marja> not about this topic
20:13:56 <obgr_seneca> #topic other
20:14:15 <obgr_seneca> So, what else is going on?
20:14:44 <Akien> Well, it's good to see you around :D
20:14:46 <marja> about dev mails for i18n, shouldn't they go on dev ml?
20:14:53 <filip_> new license and mga4 alpha page  to transate
20:15:18 <filip_> yes obgr_seneca. nice to see you here
20:15:33 <marja> because about the SIGs it was stated that those should go on dev ml, too http://meetbot.mageia.org/mageia-dev/2013/mageia-dev.2013-06-04-19.05.log.html
20:15:47 <obgr_seneca> Thx everyone
20:16:07 <obgr_seneca> marja: I'll have a look and will come back to you
20:16:20 <marja> obgr_seneca: OK
20:16:54 <marja> obgr_seneca: of course I'm glad to see you here, too :-D
20:17:03 <obgr_seneca> filip_: Are there new pages or will there be
20:17:27 <Akien> Apart from the two filip_ named, I don't think there are.
20:17:35 <filip_> there already are. see http://www.mageia.org/langs/report.php
20:17:45 <Akien> But Atelier needs web wizards to improve the website.
20:17:51 <obgr_seneca> #info there are new web pages about license and mga4 alpha to translate
20:18:13 <obgr_seneca> Akien: I do that for a day job, let's see
20:18:52 <obgr_seneca> But I'm usually not the "graphics guy", so I need some one else on that
20:19:29 <obgr_seneca> #action obgr_seneca See, if we need to do anything about SIGs concerning i18n/l10n and devs
20:19:38 <obgr_seneca> Anything else?
20:20:23 <filip_> no
20:21:12 <Akien> I just wanted to say, that we should not sleep too long on our respective actions :)
20:21:12 <obgr_seneca> Ok, then I will go to bed :-)
20:21:20 <obgr_seneca> Yep
20:21:33 <obgr_seneca> But sleep is a good word right now
20:21:36 <Akien> Particularly for the potential move to tx.com, we should do it soon, so that it's working for Mageia 4.
20:21:39 <Akien> Sure :)
20:21:46 <obgr_seneca> So have a good night!
20:21:53 <obgr_seneca> #endmeeting