18:25:01 <Akien> #startmeeting
18:25:01 <Inigo_Montoya`> Meeting started Thu May 30 18:25:01 2013 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:25:01 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:25:08 <Akien> #chair filip_
18:25:08 <Inigo_Montoya`> Current chairs: Akien filip_
18:25:34 <Akien> So, welcome everyone to our i18n meeting
18:25:35 <filip_> thx Akien. will need some assistance ;)
18:25:43 <tarakbumba> Thx.
18:26:15 <Akien> As you all know, we released Mageia 3 two weeks ago
18:26:36 <Akien> The reviews are quite nice, so we can be proud of it :)
18:27:10 <tarakbumba> :)
18:27:20 <Akien> Still the process was not always easy, especially in some teams like QA, so it's good now to take some time and do the post-mortem of this release.
18:27:59 <Akien> We have a few other topics that might be worth discussing afterwards
18:28:08 <Akien> But we'll see, depending on the time we take for the post-mortem
18:28:25 <Akien> #topic Mageia 3 Post-mortem
18:28:49 <Akien> You can have a look at https://wiki.mageia.org/en/Mageia3_Postmortem#i18n
18:29:13 <yurchor> For me, everything was very nice thanks to filip_ announces. :)
18:29:46 <filip_> yurchor: what do you mean exactly?
18:30:13 <yurchor> The annonces about string changes when we are in freeze.
18:30:51 <filip_> but now that we have ML for reports I have one less obligation ;)
18:31:16 <tarakbumba> Everything was ok for my part.
18:31:19 <Akien> Indeed, the string translation went pretty smoothly at least for the veteran translators
18:31:25 <yurchor> To be honest it would be better if developers make these announces.
18:31:48 <filip_> yurchor: they can be automatic
18:32:07 <yurchor> Just some keyword in the commit message, right?
18:32:08 <filip_> as long as they come on ML form is not so important
18:32:16 <tarakbumba> I agree with yurchor. It is a *must* developer announce a string modification
18:32:32 <filip_> not realy sure. booklm is the man
18:32:43 <yurchor> Ok. Thanks.
18:32:45 <tarakbumba> filip_:how it would be automated?
18:33:13 <filip_> each commit is already announced on ML
18:33:25 <filip_> at least for web pages
18:33:34 <filip_> don't know for soft
18:33:38 <yurchor> I think something similar to that : http://techbase.kde.org/Policies/SVN_Commit_Policy#Special_keywords_in_SVN_log_messages
18:33:56 <filip_> I added a point on our post mortem page about that
18:34:23 <filip_> Akien: should we go thrue the list on wiki
18:34:38 <Akien> filip_: That sounds good.
18:34:48 <filip_> lets focus on short and effective meeting ;)
18:34:53 <Akien> \o/
18:35:10 <Akien> So first point: What worked well.
18:35:35 <Akien> - blog: I think all blog translators have by now found an efficient system to manage their blogs.
18:36:27 <tarakbumba> We are two people in our team. I working on string translations and Firat (Osifa) is working on web translations, blog, site etc.
18:36:27 <Akien> At least in the French team, we rely on pad to translate and proofread the translations together. It helps to overcome the inertia of having to translate, then send your work, then wait for someone to proofread it, and so on.
18:37:18 <Akien> So I don't see a need for improvement with regards to how we manage the blogs.
18:37:30 <Akien> We also have reports on i18n-reports for each new blog post.
18:38:05 <yurchor> Some tips on efficient proofreding PO files from KDE teams: http://lists.kde.org/?t=136977327100001&r=1&w=2
18:38:06 <Akien> - website with lang files.
18:38:36 <filip_> yeah booklm gived us great tool with those reports
18:39:27 <Akien> So as I said on the wiki, I find we manage quite well with the .lang system.
18:39:37 <Akien> Apart from the rush after the release, which was mainly an Atelier issue.
18:40:10 <Akien> But we'll have to address our concern to Atelier if we want something better for the next release ;)
18:40:31 <filip_> lets do info on that
18:40:40 <Akien> filip_: Go on :)
18:41:10 <Akien> I think the .lang system is quite good, though simple, since we have such a great report interface.
18:41:22 <Akien> (Namely http://www.mageia.org/langs/report.php)
18:41:45 <filip_> #info We need web pages for Mageia 4 a few weeks before the release (preferably in alpha and beta stage)
18:41:53 <filip_> ok?
18:42:11 <Akien> It sounds good yes.
18:42:15 <yurchor> Ok. But it is not critical.
18:42:41 <Akien> I'd say we should at least have the pages a week before the release.
18:42:51 <filip_> yurchor: the hourly visit was about 2000 in that weekend
18:43:16 <yurchor> filip_: Nice. :)
18:43:43 <filip_> so they saw a messed pages if there wasn't translated yet
18:43:59 <Akien> It also figures in the Atelier postmortem though, so hopefully Atelier will manage better for the next release.
18:44:23 <filip_> Akien: it also involves doc team
18:44:26 <Akien> They'll probably try to set up a test instance of the website, thus enabling them to create new content and see it live.
18:44:34 <filip_> nice
18:44:52 <tarakbumba> Also, some teams more time to translate, it would be good looking into new pages before first alpha...
18:44:53 <Akien> I suppose we can then easily add this test instance to the report page and translate their stuff before it's pushed on www.mageia.org
18:45:25 <filip_> yes. we can
18:45:36 <tarakbumba> yep...
18:45:45 <Akien> tarakbumba: We're talking about the new pages for the day 1 of the release, so I think having it when the beta starts is enough.
18:45:54 <filip_> Akien: is that decided yet?
18:45:55 <Akien> It leaves at least 2 months time to translate.
18:46:05 <Akien> filip_: Not decided, but I'll push for it :)
18:46:24 <Akien> leuhmanu hosted his own instance the day before the release and we did everything there, it was awesome.
18:46:39 <Akien> We did not have time to sync the translations though.
18:46:53 <filip_> why that was not announce in atelier ML?
18:47:10 <Akien> I think it was.
18:47:14 <tarakbumba> Akien: Sorry, i'm not involved with web translations. It is job for Firat but he missing meeting
18:47:54 <Akien> tarakbumba: No problem. Firat is doing great for the website, the Turkish translation is 100% done.
18:48:16 <Akien> So what do you think as a whole about the lang system?
18:48:33 <Akien> filip_ improved our scripts and report page a lot! Thanks for that
18:48:51 <filip_> thx. my pleasure ;)
18:48:58 <Akien> It's now way easier to update the *.en.lang files without having to worry that some strings will be forgotten.
18:49:29 <filip_> it would be ideal if we could use a kind of svn hooks for lang2po conversion
18:49:56 <filip_> then we could switch to po files for web too
18:50:10 <Akien> That could be interesting, since docteam will most probably switch to po too.
18:50:21 <Akien> It would make sense to rely only on po files.
18:50:43 <Akien> Then new translators would only have this system to learn, and not juggle between po/lang/xml.
18:50:52 <filip_> yurchor: Qilaq: what do you think about that?
18:51:13 <tarakbumba> If gettext will in use, we also can push them a web interface: https://wiki.mageia.org/en/Mageia3_Postmortem#What_we_should_improve.2C_how_.3F_2
18:51:34 <yurchor> filip_: It is up for the translation teams to decide. Pull through the mailing lis?
18:51:39 <yurchor> *list
18:52:04 <filip_> is there anything a like in KDE ..?
18:53:09 <yurchor> No. Neither KDE nor GNOME use web push. All translatable KDE and GNOME sites are translated using gettext.
18:53:26 <filip_> directly?
18:53:52 <filip_> do they have web interface for that?
18:55:02 <filip_> yurchor: is perl our only option for svn hooks?
18:56:10 <yurchor> No. Just a billboards.
18:56:24 <Akien> Maybe we can start discussing this matter on the ML, and decide further in the coming weeks? (we'll also have to take into account what Atelier envisions for Mageia 4's website)
18:56:36 <yurchor> Sure.
18:57:02 <Akien> If we want to keep the meeting short, I suppose we should discuss the postmortem a bit together, and it will already be over an hour :D
18:57:05 <filip_> AFAIK they are atalking about using some framework
18:57:31 <Akien> Then we can start talking about those topics on the ML (and the wiki), and talk about it further in our next meeting
18:57:35 <Akien> (In two weeks maybe?)
18:57:36 <filip_> Akien: that shows how badly we need meetings
18:57:41 <Akien> Indeed
18:57:45 <yurchor> +1
18:57:57 <tarakbumba> +1 too...
18:58:25 <Akien> Let's go on with debriefing our works (string translation, website, blog is done, doc is left)
18:58:37 <Akien> And then we'll address the other topics (meetings, pootle,...)
18:58:46 <Akien> - Doc translation
18:58:54 <Akien> ping marja if she's around
18:59:09 <Akien> But some of you can talk about it I think :)
18:59:34 <tarakbumba> Marja is away, seen at #mageia-mentoring
18:59:35 <lebarhon> What do you want to know ?
18:59:39 <filip_> Akien: deadline for post mortem is on Monday
18:59:48 <Akien> Ok
19:00:16 <tarakbumba> Akien: It should be very good to put web pages and docs translations into po files
19:00:48 <Akien> Up to the release, it was quite difficult for new translators to jump in with the doc translation I think.
19:00:57 <tarakbumba> It is eaiser and using an spell checker is and advantage
19:00:59 <Akien> I see two factors:
19:01:14 <Akien> * Having to use Calenco, so get credentials, and then translate XML files.
19:01:16 <tarakbumba> s/and/an/g
19:01:35 <Akien> * The doc was still being writing, so it's easily confusing for people who only want to translate.
19:01:56 <Akien> Thus from what I saw, most translators were also full-fledged docteam members, and participated in proofreading and writing the doc.
19:02:20 <yurchor> Installer is relatively stable. Worth to translate.
19:02:31 <Akien> Now with docteam switching to po files for the translation, I think it will be may easier for translators to help.
19:02:47 <filip_> of course
19:03:15 <Akien> We still need a good communication between docteam and i18n, but from what I saw, we'll be able to assume our own roles :)
19:03:23 <Akien> Translators will translate, and docteam members will docate :p
19:03:28 <yurchor> marja has asked if we include installer PO into the general checking script.
19:03:59 <Akien> yurchor: I think it would be interesting.
19:04:18 <Akien> I'd like that doc translation is at the same level as our other tasks.
19:04:30 <filip_> just one line in translation_projects.dat
19:04:39 <Akien> So when I talk about i18n to newcomers, I list what we do: strings, website, blog and doc.
19:04:58 <Akien> And not: "There's also doc, but for this you have to join the docteam"
19:05:34 <Akien> (Though in itself it would be nice that translators interesting in the doc join doc-discuss)
19:05:41 <Akien> *interested
19:06:03 <Akien> So I think the doc translation will go quite smoothly using this new system.
19:06:03 <filip_> #info we're trying to consolidate as much as possible of i18n workflow to gettext
19:06:14 <Akien> Good point
19:07:00 <filip_> what about merging with doc team?
19:07:01 <Akien> #info Doc translation switches to Gettext, and we should investigate further if we want to use gettext for the website too
19:08:04 <Akien> I don't know about merging. I think it would be better to stay specialised, but we have to improve the communication between the teams.
19:08:11 <Akien> The same with Atelier by the way.
19:08:27 <filip_> true
19:08:47 <filip_> how to improve communication?
19:09:06 <Akien> If docteam should concentrate on improving and writing the doc, and reviewing and polishing the wiki, they don't need to be flooded with translation matters and lang files to be commited :)
19:09:11 <lebarhon> Since doc writer must speak English, either they are English or knowing two languages, so
19:09:30 <lebarhon> doc writers are always also translators
19:09:45 <Akien> That's a good point
19:10:43 <Akien> But yeah, if we merge with docteam because we have to work together, we'll also have to merge with Atelier because we're closely related for textual material.
19:11:10 <Akien> And I fear that new contributors might be lost when they try to join the communication/marketing/website/i18n/documentation team :D
19:11:19 <lebarhon> Translators ans Atelier doen't need the same skills
19:12:04 <Akien> lebarhon: But i18n and docteam do not use the same skills either, apart for the language.
19:12:24 <Akien> In an ideal world (the one we are building), i18n relies on po files, docteam relies on mediawiki and xml.
19:12:32 <filip_> lebarhon: I'm not sure if this is true: "Ninety per cent of the mails in the i18n ML are about software problems"
19:12:34 <lebarhon> Akien: the language is 80% of the job
19:12:52 <filip_> can you explain that a bit
19:13:01 <papoteur> Hello everybody, I come late. Translation is a step to go to docteam.
19:13:11 <Akien> Hello papoteur
19:13:23 <tarakbumba> Welcome papoteiur
19:13:25 <filip_> hi papoteur
19:13:30 <lebarhon> if 90% isn't true, it is because it is over
19:13:46 <lebarhon> hello papoteur
19:14:07 <Akien> lebarhon: When you write software problems, you mean typos and errors in the pot file?
19:15:41 <lebarhon> No I mean, gettext or transifex or pootle or lang files or Po files, all this stuff no translator is unsderstanding sth
19:15:44 <Akien> As for improving the communication, it's already better, because of i18n-reports (which is also used for the doc translation) and the fact that marja cross-posts info relevant to both teams.
19:15:53 <marja> good evening all (you seem to be doing extremely well without me)
19:16:18 <tarakbumba> Welcome marja. Discussion may interesting for you...
19:16:27 <filip_> no, marja we need you always;)
19:16:31 <marja> tarakbumba: it is, thx :)
19:16:34 <marja> filip_: :)
19:16:51 <yurchor> marja: papoteur: Hi!
19:17:04 <marja> yurchor: :)
19:17:05 <papoteur> Hello marja.
19:17:30 <marja> papoteur: hi ... the rest of the meeting I'll greet everyone ;)
19:17:33 <filip_> lebarhon: we desperatly need online translation tool
19:17:54 <tarakbumba> I agree with filip_
19:17:56 <filip_> so we talk about that a lot
19:17:56 <lebarhon> still another one :)
19:18:16 <lebarhon> wasn't po this one ?
19:18:21 <tarakbumba> Without an online tool we' re in a desperate position
19:18:43 <filip_> not another. it doesn't really matter as we don't have any working one for a year and a half
19:19:12 <filip_> po is just a form. it's not a tool
19:19:34 <tarakbumba> Virtaal or poedit...
19:19:35 <lebarhon> What is funny, I first subscribed to i18n because I wanted translate (no other skills)
19:20:01 <Akien> The question is, do we need a new software for that (Tx.net, Pootle...), or should we try to improve our current system based on SVN/scripts?
19:20:09 <filip_> online tool is very conveniant for translation. especially in big teams
19:20:23 <lebarhon> When I saw what i18n job was, I subscribed to doc team and there I could doing translations :)
19:20:41 <Akien> lebarhon: Well, if you can manage Calenco and XML files, you can't say you have no other skills :)
19:20:54 <filip_> Akien: should we vote about such a need?
19:20:54 <tarakbumba> For small teams, it provides an easy way to expand the team :)
19:20:59 <lebarhon> Marja is a good coach
19:21:01 <yurchor> Maybe I should contact Acid Jack to have the same translation billboard as it was for Mandriva?
19:21:50 <filip_> tarakbumba: I'm came here for that reason ;)
19:21:50 <Akien> filip_: I guess we could discuss it on i18n-discuss and doc-discuss, and see what it would bring to the team.
19:22:14 <tarakbumba> Me too, despite the situation at home, you know...
19:22:45 <tarakbumba> I have opened a topic at i18n-discuss but get few answers
19:22:59 <filip_> I suggest we put a fixed deadline for pootle
19:23:03 <Akien> #info We should discuss the idea of merging i18n and docteam on our MLs. Pros and cons?
19:23:07 <tarakbumba> I proposed using tx at transifex.com
19:23:12 <papoteur> I used transifex first. then I never translated anything else except in Calenco.
19:23:44 <tarakbumba> papoteur: did you used old mageia tx or transifex.com tx?
19:23:45 <Akien> Well I'm a bit sorry that Oliver is not here tonight :/
19:23:54 <papoteur> I am already on the the 2 ml
19:24:06 <filip_> after that we can go for tx.net
19:24:27 <Akien> Should then the doc translation go to tx.net too?
19:24:28 <marja> Akien: about merging the mls, I have the feeling that both already have too many mails for subscribers to read
19:24:34 <papoteur> tarakbumba: Mageia tx, before it was down.
19:25:02 <marja> Akien: merging them will make the avalanche even bigger
19:25:05 <Akien> marja: That's my feeling too, I'd like better that we manage to keep translation in i18n and stuff writing in marja.
19:25:06 <tarakbumba> Akien:It is a good idea
19:25:10 <Akien> s/marja/docteam/
19:25:10 <Akien> :O
19:25:19 <marja> Akien: lol
19:25:23 <filip_> +1
19:25:49 <Akien> tarakbumba: What do we have on tx.net up to now?
19:26:11 <tarakbumba> I'm currently contributing many projects at tx
19:26:30 <Akien> In my opinion, the biggest issue that we have in tx, is that we'll never manage to have the devs pulling changes to Tx.
19:26:37 <tarakbumba> Chakra, Arch, Razor-Qt, transifex itself etc.
19:26:54 <Akien> At least in SVN, we were not notified about changes, but they were there to be taken into account.
19:27:00 <tarakbumba> In my opinion it can be done a server side script.
19:27:25 <Akien> We could discuss this with the sysadmins.
19:27:36 <filip_> Akien: but if we receive pot files update on ML reports we can commit them manually
19:27:45 <filip_> at least for some time
19:27:46 <tarakbumba> I have my own script for svn and it updates translations for one or two days for example
19:27:59 <Akien> Maybe some job which would look for commits including .pot files, and "tx pull" the corresponding files?
19:28:16 <tarakbumba> Akien: exactly.
19:28:30 <tarakbumba> A cron job resolves this issue, i think.
19:28:44 <tarakbumba> It is eaiser for many
19:29:08 <filip_> Akien: can you ask them?
19:29:10 <tarakbumba> For example, i do many translations at work while i go for smoking
19:29:13 <Akien> So I'll ask Oliver if he did any progress on Pootle, and if he did not, then we could look into moving to tx.net.
19:29:16 <Akien> filip_: Sure.
19:29:29 <filip_> nice
19:29:37 <tarakbumba> good
19:29:38 <Akien> #action Akien talks with the sysadmins about scripts and cron job for coordination with Tx.net
19:29:53 <filip_> so let's talk about it in 2 weeks
19:29:57 <Akien> Please note that the sysadmins starting to talk about moving the soft repo on git.
19:30:13 <filip_> Akien: not today ;)
19:30:23 <tarakbumba> :)
19:30:27 <Akien> *started
19:30:37 <Akien> filip_: It was just as an information :)
19:31:03 <filip_> just a joke ;)
19:31:04 <Akien> Another topics was to have more regular meetings.
19:31:10 <Akien> *topic
19:31:20 <Akien> I think it's a good idea :)
19:31:46 <Akien> Should we try to have a meeting every two weeks?
19:31:50 <tarakbumba> For me, it is hard to take a part at an irc meeting
19:31:57 <filip_> sounds great
19:32:05 <filip_> tarakbumba: why
19:32:12 <Akien> tarakbumba: Because of the time, or personal issues?
19:32:21 <yurchor> I think it was better to meet when there are important things to discuss, not just every two weeks with no significant reasons.
19:32:24 <tarakbumba> Time.. and some personal issues
19:32:34 <tarakbumba> yurchor: +1
19:33:04 <Akien> yurchor: So maybe no policy change, but we should still try to meet more often?
19:33:19 <tarakbumba> Job consumes too much time. Most of time i steal from my sleep... and family...
19:33:23 <yurchor> Akien: Sure.
19:33:24 <filip_> yurchor: at least this channel will live for an hour each two weeks ;)
19:34:02 <Akien> Maybe we could have non regular meetings each time we have something important to discuss.
19:34:03 <filip_> Akien: more important then often is regular
19:34:31 <Akien> And then try to hang out together more regularly for those who have time for it.
19:34:33 <tarakbumba> Please look how many attend this meeting. And then decide...
19:34:47 <yurchor> filip_: It will be hard for a chairman to concentrate all his attention on topics and type kilobytes of text without a reson... ;)
19:35:05 <yurchor> *reason
19:35:15 <Akien> Like "Let's have a virtual beer on #mageia-i18n tomorrow and chat about how frustrated we are with Tx.net :p"
19:35:27 <tarakbumba> :)
19:35:39 <filip_> let's do that in 2 weeks ;)
19:35:46 <Akien> Sure :)
19:36:17 * marja likes the beer :)
19:36:24 <tarakbumba> I' ll try to attend. But please do that at weekends. May be Friday nights
19:36:43 <Akien> But we'll probably have a real meeting in the coming weeks, I'll keep you informed.
19:37:01 <filip_> * filip_ doesn't like beer belly but has one still ;)
19:37:26 <marja> :)
19:37:49 <Akien> tarakbumba: The problem with weekends is that most people want to dedicate their evenings to other things that Mageia.
19:38:15 <Akien> But we could ask about it actually.
19:38:38 <filip_> true. there are many calendars for that purpose exactly
19:38:41 <Akien> We chose Thursday evenings a long ago, it won't hurt to make sure it's still the best time for everyone.
19:39:02 <Akien> Or to chose another one.
19:39:25 <Akien> Since we have many new translators now, and others who left, so maybe another day would be more convenient.
19:39:51 <tarakbumba> Please...
19:39:55 <Akien> #info Meeting time and frequency (regular or only when something important should be discussed) to be addressed on the ML.
19:39:55 <yurchor> For me, "Let's have a virtual beer on #mageia-i18n tomorrow and chat about how frustrated we are with Tx.net :p" is better than long lectures about things that can be shared with mailing list, Google circles, Facebook or something else.
19:40:50 <Akien> yurchor: We could try something like that when we don't absolutely need a real meeting.
19:41:06 <filip_> Akien: let's wrap up with some concluision about pootle, tx
19:41:11 <Akien> Just give an hour and a day of a peak in frequentation of #mageia-i18n :)
19:41:12 <yurchor> firat: Hi!
19:41:23 <firat> Hi :)
19:41:28 <tarakbumba> Welcome my friend...
19:41:30 <filip_> hi firat
19:41:31 <Akien> filip_: Yes, and then close the meeting, we're over the hour! :)
19:41:34 <Akien> Hi filip_
19:41:40 <tarakbumba> At last you see my messages :)
19:42:50 <Akien> #action Akien will see what is the progress on Pootle. If obgr_seneca did not have time for it, we'll start looking into tx.net as tarakbumba suggested.
19:43:07 <filip_> thx Akien
19:43:18 <tarakbumba> thx akien
19:43:20 <yurchor> Thanks.
19:43:21 <Akien> Do we have other topics?
19:44:22 <Akien> Let's call it a day, and discuss everything further on the ML.
19:44:29 <filip_> I just have a question. What about web translation in pt? should we copy it from pt-br?
19:45:22 <Akien> Hm. It seems pt and pt-br are culturally really different.
19:45:29 <yurchor> There are differences in orthograpy, better ask in ML.
19:45:49 <filip_> yurchor: ok
19:45:54 <Akien> An idea could be to forward pt to pt-br, but to add a line on the website indicating that this is Portuguese from Brazil
19:46:16 <Akien> And that we'll welcome Portuguese translators from Portugal if they want to help us
19:47:05 <filip_> I asked in the forum and Brazilians said that orthograpy is the same. just a few words
19:47:24 <filip_> but lets stop at this point
19:47:41 <Akien> Thanks everyone for joining in :)
19:48:03 <yurchor> Akien: Thanks for the meeting.
19:48:10 <Akien> I'll re-read the logs and make sure what we discussed here can be further discussed on the ML
19:48:10 <filip_> +1
19:48:30 <Akien> (But feel free to start a topic about those points before me, if I don't)
19:48:45 <Akien> #endmeeting