18:11:16 <Akien> #startmeeting
18:11:16 <Inigo_Montoya`> Meeting started Thu Apr 11 18:11:16 2013 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:11:16 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:11:37 <Akien> Welcome everyone to our i18n team meeting
18:11:47 <Akien> The topics for today should be:
18:11:52 <Akien> 1- Mageia 3 release
18:12:03 <Akien> 2- Status of the team
18:12:15 <Akien> 3- Discussion about tx.net vs Pootle
18:12:17 <Akien> 4- Others
18:12:54 <papoteur> HI everybody
18:12:56 <Akien> Since I don't release what Oliver wanted to say, we'll try to figure out together what is important to be shared to the team :)
18:13:00 <Umeaboy> Hi papoteur!
18:13:09 <Remmy> Good evening all :)
18:13:10 <Akien> s/release/really know/ :o
18:13:19 <Umeaboy> Hi Remmy!
18:14:06 <Akien> So feel free to complement what I say :)
18:14:13 <yurchor> Ok.
18:14:16 <Akien> #topic Mageia 3 release
18:14:17 <filip_> hi all
18:14:24 <Umeaboy> My first thought about Mageia 3 is that it's still missing GDM Manager.
18:14:40 <Akien> Umeaboy: This is _i18n_ meeting. Thanks.
18:14:58 <Umeaboy> Akien: Right. Sorry.
18:15:04 <Akien> You may know that Mageia 3 is due on May 3rd ( https://wiki.mageia.org/en/Mageia_3_development )
18:15:19 <Akien> That is to say, three weeks from now.
18:16:01 <Umeaboy> Uuuuhm. Nothing to say about the release, anyone?
18:16:22 <Akien> We are now past the release freeze, which means that the chances for new translations to be added in the packages are quite low.
18:16:23 <Umeaboy> On to the next topic then?
18:16:35 <Akien> Umeaboy: Can you let me run the meeting, perhaps?
18:16:42 <Umeaboy> Even for the installer?
18:16:55 <yurchor> :)
18:17:05 <Remmy> Akien: Is there anything we need to do before then still? I know there will be release notes coming, and hopefully more than a day before the release :)
18:17:47 <Akien> So, I know that Atelier (mostly trish actually) is supposed to write some press content for the release.
18:18:44 <Akien> We were supposed to receive some official content to translate around three weeks before the release, i.e. now, but I'm not aware of such content being already written.
18:19:06 <Akien> I'll see with Atelier what is the status on this, and what will i18n have to do precisely.
18:19:34 <Qilaq> added, yeas but if translators will made some modificatins or updates yet, are they going in Mageia 3 or not? Id est, will there be translations update in packages before RC?
18:19:34 <filip_> AFAIK packagers are invited to add text about important changes for their packages
18:19:43 <Remmy> With Mageia 1 and 2, I think rda wrote most of the content for the release notes
18:21:07 <Akien> Qilaq: I don't know precisely, but I understand it as "we don't build new versions of the packages"
18:21:43 <papoteur> for the installer help, I heard we have up to RC.
18:21:48 <Akien> ennael: If you are around here, could you give us some precisions? Is it still possible that new translations commited to SVN are included in Mageia 3, or we should not count on it?
18:21:59 <Qilaq> ahah ... sad, then I am too late to translate sound card new text?
18:22:39 <Akien> Qilaq: I guess you can still do it, at least for Mageia 4, and who knows, if a critical bugs has to be fixed in this package :)
18:23:06 <Akien> #info Installer help translation can be done until RC.
18:23:16 <filip_> Qilaq: you're not to late acording to Oliver recent statment on ML
18:24:41 <Akien> filip_: That is? Did he gave a deadline?
18:25:16 <filip_> he wrote something similar as you did: "until RC"
18:25:28 <Akien> Ah: "Anne told me, everything we commited until shortly before the repos are frozen for the rc will be used!"
18:25:54 <Akien> So if we have still strings to translation, we can take the chance :)
18:26:27 <Akien> The development roadmap says that the release freeze for the RC was on April 7th, but I don't know how strictly it is enforced.
18:26:57 <Akien> #info We have no guarantee that new strings commited to SVN will be included in the release, but it might still be possible until RC is released.
18:27:13 <Remmy> Nothing is lost by trying :)
18:27:30 <Akien> #action Akien sees with Atelier about Release notes and press content.
18:28:30 <Akien> I'll also suggest what we could not do for the last two releases: have the content of the blog post a day or two before the release, to be able to translate it and post the translated announcements only shortly after the original one.
18:29:29 <Akien> Apart from this I don't think there's much work for us. Keep up with the blog translation for those who translate it :)
18:29:52 <Akien> Anything else on this topic?
18:30:00 <Remmy> Not from me.
18:30:12 <Qilaq> I don't remember if there was solution to the problem that at the installation time release notes were in English even if they are translated in wiki? - or, otherwise said, how much should I concentrate to the translation of release notes if they are ready?
18:31:13 <Akien> Ah, that is a good question.
18:32:07 <Akien> #action Akien will see if the release notes can be included in the media, and will notify the ML afterwards.
18:32:39 <Akien> There are actually already release notes: https://wiki.mageia.org/en/Mageia_3_Release_Notes
18:32:53 <Akien> I'll try to see when we can consider that they are the definitive release notes.
18:33:29 <Qilaq> yes but are they final? i'm not sure ...
18:33:40 <Akien> #info The current release notes are here: https://wiki.mageia.org/en/Mageia_3_Release_Notes  It is still possible to start translating it and to correct the translation if changes are made to the original afterwards (use the diffs on the wiki for this)
18:34:06 <Akien> Qilaq: Maybe not final, but they likely won't change too much, or at least the existing content won't be removed.
18:34:38 <Akien> But I will try to get us a deadline for the "official" release notes.
18:35:58 <Akien> So, next topic I suppose.
18:36:05 <Akien> #topic Status of the team
18:36:35 <Akien> I don't really know what Oliver wanted to talk about on this topic, so let's find out :)
18:36:55 <Akien> First of all you probably noticed that we have a new ML: i18n-discuss@ml.mageia.org
18:37:35 <Akien> There are also two news ML which were created for our team: i18n-bugs@ml.mageia.org and i18n-reports@ml.mageia.org
18:38:18 <Remmy> Has everyone with an identity account and on the old list been subscribed to both?
18:38:22 <Akien> The first one can be used as assignee in Bugzilla, thus assigning bugs to our team. I suspect the traffic won't be too high, so don't hesitate to join it to stay informed about i18n bugs.
18:38:35 <Akien> Remmy: No, only to i18n-discuss.
18:38:45 <Remmy> Akien: Ok, subscribing myself then :)
18:39:11 <Akien> i18n-reports is for now used for Calenco's translation reports (i.e. for the doc translation)
18:39:50 <filip_> what about string changes? where should they go?
18:39:54 <Akien> I didn't clearly understood the form of the report, maybe one of you could explain it to the team?
18:40:33 <Akien> filip_: Ah indeed, good question.
18:40:47 <Akien> I think all web related changes will be sent to atelier-commits@ml.mageia.org.
18:41:22 <Akien> For the strings in soft/, it is soft-commits@ml.mageia.org
18:41:48 <filip_> are those ML automatic?
18:42:21 <Akien> I guess so. I'm subscribed to atelier-commits and received notifications about xlin adding Russian translation to the website.
18:42:33 <filip_> great
18:43:12 <Akien> Does anyone know what such a report means? DIFF el doPartitionDisks.xml 1.19 en
18:43:51 <Akien> Does it mean that the doPartitionDisks.xml was edited for Greek, and that it is based on the EN version 1.19?
18:44:48 <Akien> #info The new i18n ML is i18n-discuss@ml.mageia.org. Please subscribe to it if you were not automatically subscribed.
18:45:00 <yurchor> No. This only means that its version is not equal to the version in English file.
18:45:45 <Akien> #info There are also i18n-bugs@ml.mageia.org for bugs assigned to i18n and i18n-reports@ml.mageia.org for documentation's translation reports.
18:45:46 <yurchor> If you change the version (even not touching the content) it will send no message.
18:46:15 <Akien> Ah ok, so it means that there are only a dozen of files which are not up-to-date?
18:46:38 <Akien> (There are only 11 entries in the report)
18:47:01 <yurchor> No. This means tha 11 files _with version marks_ are not up-to-date.
18:47:04 <Qilaq> diff reports show modified lines in Calenco; first new and then old text
18:48:10 <Akien> yurchor: Ok I understand. So it would be a good practice to use these version marks if we want an accurate report.
18:48:54 <Akien> Apart from the MLs, I guess Oliver wanted to raise the issue that we have no idea which member of the team are still alive :)
18:49:03 <yurchor> I will not use them because they should be corrected everytime you change the file manually. ;)
18:49:15 <Akien> But it has always be hard to keep track of incoming and silently leaving contributors, so I have no idea how we could improve it.
18:49:37 <Akien> yurchor: Yes I remember talking with you about it in a docteam meeting :)
18:50:13 <Akien> yurchor: As long as you're a one-man team, it seems quite reasonable.
18:50:32 <yurchor> No. Not because of that.
18:51:06 <yurchor> It's because the current workflow misses TM.
18:52:09 <yurchor> Mario Blättermann in a private discussion shares the same opinion for German team.
18:52:59 <filip_> yurchor: TM?
18:53:07 <Akien> Translation memory I suppose
18:53:12 <yurchor> Translation memory.
18:53:21 <Akien> (Wikipedia rules :P )
18:53:28 <yurchor> :)
18:54:09 <Qilaq> In Estonian team all the members- it be me - are still alive :-)
18:54:29 <filip_> Qilaq: +1 for Slovenian ;)
18:54:35 <yurchor> +1 :)
18:55:15 <yurchor> But I cannot stop thinking what I can give to my ancestor.
18:56:01 <Akien> The same. There was reallylittle to do for string translation for the French language :)
18:56:05 <yurchor> *successor
18:57:16 <yurchor> Can I make a little branch in SVN for those who want to translate POs?
18:57:34 <Akien> So, unless we have a revolutionary idea to keep track of who's active in the team, who's reading the ML and so on, I think we have to accept the idea that we are a team with blurred edges :)
18:57:38 <Akien> yurchor: You mean for the doc?
18:57:44 <yurchor> Yes.
18:58:18 <Akien> yurchor: Well it would be worth discussing on the ML, together with the docteam.
18:58:29 <yurchor> Akien: Ok.
18:58:53 <Akien> As long as Calenco stays the reference, and that the SVN is just a storage place for POs, I suppose it would bring no harm.
18:59:18 <Qilaq> yeah, I'm little worried about docs, too because I've found time to make missing pictures for MCC manual but it is probably better to discuss the possibility to make freeze exception if I'll do them, in the docteam channels
19:00:11 <Akien> Qilaq: We have until the RC for the translation, so maybe also for the screenshots?
19:01:21 <Akien> Should we proceed the the third topic?
19:01:46 <Qilaq> ahah, good to know
19:02:43 <Akien> #topic tx.net vs Pootle
19:03:27 <Akien> So there was some discussion on the ML about the possibility of using tx.net for Mageia's string translation workflow instead of trying to setup our Pootle instance.
19:04:04 <Remmy> Hell freezes over before we have a web interface for translation of .po's :P
19:04:29 <Akien> As a reminder, when our instance of Tx broke and we started talking about a replacement, we rejected this possibility because of the flaws of Tx.
19:04:32 <Akien> Remmy: :P
19:05:15 <Qilaq> it was some time ago - probably tx,net has evolved, too?
19:05:38 <Akien> Sadly I don't see anyone of those who advocate the use of tx.net here :/
19:05:43 <yurchor> Tx will not work without .tx folders and tx pull/tx push from developers. So now it's just testing. But looking into the previous efforts it's the best solution now.
19:06:17 <Akien> Qilaq: Probably, but there stays some problems that Oliver explained on the ML (no synchronisation to SVN, so everything should be done manually=)
19:07:28 <filip_> Akien: that is nasty but if there won't be Pootle soon I think we should reconsider
19:07:29 <yurchor> Akien: To be honest, it will work as soon as POT is up-to-date even without manual work. ;)
19:08:08 <Akien> yurchor: If the devs use tx pull/push you mean?
19:08:50 <yurchor> Akien: Pull will be done automatically through anonimous account by TX itself.
19:09:10 <yurchor> *I mean puul to tx.net
19:10:11 <yurchor> But Oliver is right and it will break the direct SVN translations.
19:10:14 <Akien> Indeed: "Transifex can also be set to check svn for updates in the pot file and it will auto update all po files with the new entries in the pot file, if any"
19:10:36 <Akien> That's right, it was already the case with our Tx instance.
19:11:44 <yurchor> Perfect description of such systems by Chusslove Illich: http://lists.kde.org/?l=kde-i18n-doc&m=136491694506090&w=2
19:12:25 <Akien> #info Comparison of various translation methods: http://lists.kde.org/?l=kde-i18n-doc&m=136491694506090&w=2
19:15:51 <Akien> So, let's continue discussing possibilities on the ML, but it would be also interesting to document the advantages and drawbacks of the differents alternatives on the wiki.
19:16:21 <Akien> ML discussions tend to get forgotten if a consensus is not directly reached.
19:17:17 <Akien> The main question is: will Oliver find time for Pootle, or should we use a simpler alternative, though it is more flawed?
19:17:47 <filip_> yes
19:17:57 <Akien> (actually someone else could find time for Pootle, but I personally have no clue, what should be done...)
19:18:21 <Remmy> Are we missing out on anything with our current process / workflow?
19:18:23 <Akien> I know that the first step would be to package Pootle for Mageia, but that's far above my packaging skills.
19:19:46 <Akien> Remmy: Taking into account the low quantity of files that we have to translate and the rate at which they are modified, I don't think so.
19:20:25 <Akien> filip_ warns us when strings are modified, and it's a matter of 10 minutes to download all .po files for your language and check their status
19:20:46 <Remmy> I'm not sure if we would get substantially more contributors by using transifex or pootle... sure, it might not be ideal, but we seem to be able to work as it is now
19:20:50 <Akien> But it might seem frightening for new translators who are not used to using SVN.
19:21:18 <Qilaq> only missing part is IMHO notifications about changes
19:21:21 <Remmy> We have quite a few people sending in translations on the mailing list, which is great
19:21:56 <Akien> So an alternative would be to stop "waiting for change", and to better document our workflow with SVN
19:22:41 <Akien> And find a sysadmin who can write a script so that we get automatic notifications on i18n-reports
19:23:14 <Remmy> I wouldn't be opposed to that
19:23:56 <filip_> or ask them if they can use base of "our script" for that purpose
19:24:24 <Remmy> filip_: I think it would even be possible (perhaps) for us to adapt our script and put it on cron
19:24:33 <Remmy> and email to list
19:24:57 <filip_> Remmy: that would be great
19:25:03 <Akien> That sounds nice :)
19:25:23 <Akien> The last things which could be missing would then be a global overview of the translation status, as we have for the website.
19:25:34 <Akien> But I guess it could also be done through a script.
19:25:37 <Remmy> Let me think about it once sobered up
19:25:42 <Remmy> :)
19:25:57 <Akien> Running msgfmt -c on all known resources once a day/week or so.
19:26:37 <Qilaq> yean, I've recommended at least once to look how it is done in KDE, both notofications about changes in SVN and statistics on the web - IMHO they do both great
19:26:56 <Akien> #info Alternatives to be discussed for the string translation workflow: Pootle / tx.net / Well-documented SVN-based workflow (as now) using scripts for automated notifications sent to i18n-reports@ml.mageia.org
19:27:43 <filip_> Qilaq: can you point us with link or something
19:28:22 <Qilaq> Mandriva used to use KDE web statistics not very long ago - the code is open (though it is gone now, as sadly much of Mandriva ...)
19:30:26 <Akien> http://i18n.kde.org/stats/gui/trunk-kde4/team/
19:30:31 <Akien> That looks great indeed
19:30:46 <Qilaq> http://websvn.kde.org/trunk/kde-common/svn/hooks/ for hooks and http://i18n.kde.org/about-stats.php for web statistics
19:32:20 <Akien> #info KDE statistics for string translation: http://websvn.kde.org/trunk/kde-common/svn/hooks/ for hooks and http://i18n.kde.org/about-stats.php for web statistics
19:33:14 <Qilaq> probably both code need a lot customization because KDE uses a bit different system for translations (all translation for a language in one place - so the base is the language, not the software, as it is in Mageia) but I'm sure that someone who understands basically what it is to be done can also understand how to customize
19:34:25 <Akien> Anyone want to dive into it? :D
19:34:37 <Akien> (Oliver will be angry if I don't give a few #actions :p)
19:35:14 <Akien> s/want/wants/
19:36:16 <filip_> sound interesting to me but I'm no expert and I'm currently flooded with tasks
19:37:11 <filip_> I'm talking about statistics not hooks (they are way beyond me)
19:39:00 <Akien> Well, I suppose some documentation might be found, so I'll see with Oliver and the sysadmins if we could adapt the KDE system or script our own simple system.
19:39:24 <Akien> Should we go on? I said it would be a quick meeting :p
19:40:18 <Akien> #topic Other topics
19:40:28 <Akien> Anything you would like to talk about or discuss?
19:40:32 <Youp3> We have not the same notion of quick ;)
19:40:57 <yurchor> +1
19:41:36 <Akien> So I guess we can conclude the meeting
19:41:46 <Akien> Thanks everyone for attending!
19:41:49 <Akien> #endmeeting