19:33:12 <obgr_seneca> #startmeeting
19:33:12 <Inigo_Montoya> Meeting started Thu Feb 28 19:33:12 2013 UTC.  The chair is obgr_seneca. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:33:12 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:33:25 <Qilaq> pong ... though I may be slightly disturbed to participate fully ...
19:33:29 <obgr_seneca> Welcome to our newest i18n meeting
19:33:37 <obgr_seneca> Hi Qilaq, hi yurchor
19:33:53 <obgr_seneca> Here is the list of topics for tonight
19:33:54 <yurchor> Hi obgr_seneca
19:33:58 <filip_> hi everybody
19:34:10 <marja> obgr_seneca: nice that you have time for a meeting :)
19:34:20 <filip_> +1
19:34:28 <obgr_seneca> #1 Team status reports
19:34:28 <obgr_seneca> #2 Translation of Mageia documentation (marja, the leader of doc team
19:34:28 <obgr_seneca> will be present for this)
19:34:28 <obgr_seneca> #3 Mga3 translations - what's to be done
19:34:30 <marja> filip_: hi
19:34:42 <obgr_seneca> #4 status of online translation platform
19:34:45 <obgr_seneca> #5 other
19:34:49 <obgr_seneca> hi filip_
19:35:08 <obgr_seneca> So let's start
19:35:17 <obgr_seneca> #topic team status reports
19:35:36 <obgr_seneca> So, is there anything we should know about your teams right now?
19:36:19 <filip_> we're still here ;)
19:36:25 <obgr_seneca> Beginning with the german team, it has fallen a bit asleep
19:36:27 <yurchor> +1
19:36:47 <obgr_seneca> They answer when I call for blog translations, but most things are actually translated by me right now
19:37:08 <obgr_seneca> I will try to revive the team in the coming weeks
19:37:36 <filip_> obgr_seneca: just a side note: I noticed that German constituiton is not fully translated yet
19:37:43 <obgr_seneca> Most others that are here are one man teams as I recall, so not much to tell, I think is there?
19:37:52 <obgr_seneca> filip_: yes, I didn't finish yet
19:38:07 <obgr_seneca> it's hard to translate that legal stuff
19:39:00 <filip_> very
19:39:07 <obgr_seneca> So shall we procede with the next topic as marja is here for that?
19:40:10 <Qilaq> Estonian team is, as it has always been, one-man-team and even if I don't have committed anything almost a month, I think, mostly I am on positive side ...:-)
19:41:36 <obgr_seneca> yurchor: nice to hear that
19:41:43 <obgr_seneca> #topic translation of the mageia doc
19:41:51 <obgr_seneca> So marja, your turn
19:42:32 <marja> First I need to apologise, for not having kept our internal doc-team documentation in a good shape
19:43:28 <marja> we are working on that, but the information we had about writing and translating our official  (Calenco) documentation must have been quite overwhelming and confusing for many
19:44:24 <marja> About what needs to be translated, the installer help files are most important, because for many people there is no way to find help while installing Mageia, if it isn't available in installer itself
19:44:56 <obgr_seneca> #info most important is translating the installer help files
19:45:14 <marja> The files here go into installer (without the screenshots) and are shown when pressing the related help button http://docteam.mageia.nl/en/MCC/content/index.html
19:46:15 <marja> link https://wiki.mageia.org/en/Calenco_translations_report
19:46:40 <marja> #link https://wiki.mageia.org/en/Calenco_translations_report this is the report table that Akien has greatly improved
19:47:58 <obgr_seneca> so how do we organise it?
19:48:00 <marja> #info when the translations of drakx-installer-help was started, there was no way to get a warning when an original English file was changed
19:48:31 <obgr_seneca> Do we have a way of finding changed files then?
19:48:34 <marja> but now we do have a way to get notifications, by adding a few lines to the code of the file
19:48:45 <obgr_seneca> For those languages who did have translations for Mga2?
19:48:53 <obgr_seneca> ah, ok
19:49:33 <marja> obgr_seneca: it is probably best to set those files to the oldest version they can have.. that'll give a diff with too many changes, but at least all the real changes will be in it
19:49:55 <obgr_seneca> ok
19:50:14 <obgr_seneca> so any translator who wants to help, can contact doc team about it?
19:50:21 <obgr_seneca> by ml, I suppose?
19:50:32 <marja> obgr_seneca: or, if someone else did the translation, to check the entire translation (you found an error in a German file that had been checked by at least 5 Germans)
19:50:41 <marja> obgr_seneca: yes, please
19:50:55 <obgr_seneca> #info to get all changes that happened between mga2 and now, do a diff of the English file
19:51:29 <obgr_seneca> #action everybody please do contact doc team about calenco credentials and information
19:51:40 <marja> #info don't hesitate to ask for help on doc-discuss ml, if you do not understand our instructions. Our instructions are still complicated and confusing
19:52:39 <Qilaq> as I've translated them, I can say approx workflow to use (or at least what I used): a) request user on Calenco (with e-mail to doc-discuss), b) download file from Calenco, c) translate it ( I did with Kate), d) check, check and check if all is correct, incl header for version and data about yourself as translator, e(upload it to Calenco, and f) enjoy translated file at docteam.mageia.nl sute :-)
19:53:04 <obgr_seneca> Qilaq: thx
19:53:24 <marja> Qilaq: if you don't want your name to show in the file, you can replace it by a space
19:53:36 <obgr_seneca> #info workflow is as Qilaq described: a) request user on Calenco (with e-mail to doc-discuss), b) download file from Calenco, c) translate it ( I did with Kate), d) check, check and check if all is correct, incl header for version and data about yourself as translator, e(upload it to Calenco, and f) enjoy translated file at docteam.mageia.nl sute :-)
19:53:58 <Qilaq> f1) for full enjoyment at docteam.mageia.nl make needed screenshot, too :-)
19:54:08 <marja> Qilaq: and if you do not want your e-mail address to be visible, I can create i18n-et@mageia.eu for you and give you the login codes
19:54:28 <marja> Qilaq: thx
19:54:29 <yurchor> I can help if somebody wants to translate all files of installer altogether using PO file.
19:54:30 <Qilaq> no need, I can take full responsibility :-)
19:54:43 <marja> #info for the online installer help, screenshots are needed to
19:54:58 <marja> Qilaq: :)
19:55:01 <obgr_seneca> yurchor: a kind of bridge between calenco and gettext?
19:55:12 <yurchor> obgr_seneca: Yes.
19:55:29 <obgr_seneca> That's great as it is more the normal i18n workflow
19:55:30 <filip_> yurchor: sounds interesting
19:55:50 <obgr_seneca> #info yurchor can help on translating using po files
19:55:50 <marja> https://wiki.mageia.org/en/Translation_with_Calenco_and_Gettext
19:56:16 <marja> https://wiki.mageia.org/en/Translation_with_Calenco_and_xxe is another method
19:57:52 <marja> and I don't see the information about the lines that should be added for the translation notifications :/
19:57:55 <Qilaq> IINM, xxe does mean some fiddling with Java versions - I didn't get it to work but somebody with more knowledge surely can
19:58:18 <obgr_seneca> I can have a look
19:58:31 <marja> https://wiki.mageia.org/en/How_to_write_and_translate_Mageia_doc#Translate_an_English_doc
19:58:54 <obgr_seneca> #action obgr_seneca find out how to get xxe working (what java version and so on)
19:59:17 <lebarhon> You need Sun Java instead of OpenJava
19:59:31 <marja> #info in https://wiki.mageia.org/en/How_to_write_and_translate_Mageia_doc#Translate_an_English_doc it is desctribed which lines to add for the translation notifications
19:59:43 <obgr_seneca> marja: as I read it, Akien knows quite a bit about the whole procedure, too?
19:59:56 <marja> #info for the xxe add-on, Subn Java is needed
20:00:23 <marja> obgr_seneca: he has been looking into it, and had some very smart ideas that I don't manage to reproduce now
20:00:38 <pasmatt> a small note on-the-fly about the previous topic (team status report): 1 active user (me/matteo), 1 less active (stblack/stefano) and 1 quite sporadically active (killer1987/marcello)
20:00:55 <obgr_seneca> #action Akien describe to the ml what your ideas about doc translations are
20:00:59 <marja> #info some of Akiens ideas can be read in the full logs of last docteam meeting http://meetbot.mageia.org/mageia-doc/2013/mageia-doc.2013-02-25-18.01.html
20:01:15 <pasmatt> it was about italian tr team, sorry
20:01:23 <obgr_seneca> pasmatt: it's ok
20:01:55 <obgr_seneca> Anything else about the doc topic for now?
20:02:31 <lebarhon> With have problem to obtain Calenco credentials
20:02:43 <obgr_seneca> lebarhon: yes?
20:02:51 <lebarhon> indeed
20:03:01 <marja> #info for languages for which installer help files have been translated and updated, it is OK to continue with MCC help
20:03:40 <marja> #info JohnR is not available for the time being, so only Camille can give Calenco credentials
20:03:54 <papoteur> Hello i18n team. For java-sun, there is a page in French :/ http://www.mageialinux-online.org/wiki/activer-java-d-oracle-sur-mageia
20:04:13 <lebarhon> Camille isn't there either
20:04:24 <marja> lebarhon: :(
20:04:39 <papoteur> I do not know if some equivalent is available in English.
20:04:59 <obgr_seneca> papoteur: could you (and the rest of i18n-fr) try to translate that into English? For the mageia wiki?
20:05:46 <marja> lebarhon: he is in #mageia-doc ... I hope he sees my question
20:05:59 <papoteur> obgr_seneca: yes, but not yet. I will leave in hollydays during a week :/
20:06:09 <obgr_seneca> papoteur: ok
20:06:21 <obgr_seneca> could you ask other french translators?
20:06:46 <papoteur> Yes, to lebarhon :)
20:06:57 <obgr_seneca> :D
20:06:57 <marja> #info http://www.mageialinux-online.org/wiki/activer-java-d-oracle-sur-mageia needs to be translated into English
20:07:11 <lebarhon> It is already in the Java webpage
20:07:31 <obgr_seneca> lebarhon: url?
20:07:36 <marja> obgr_seneca: ^^^ it seems my info needs to be undone
20:07:43 <obgr_seneca> #undo
20:07:43 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x8331c8c>
20:07:45 <lebarhon> a moment please
20:08:49 <filip_> one question about great Calenco report:https://wiki.mageia.org/en/Calenco_translations_report there isn't any possibility for automatization in Calenco itself?
20:09:07 <obgr_seneca> marja: ?
20:09:25 <marja> filip_: not as far as I know, but I never asked Camil
20:10:04 <yurchor> filip_: Calenco can compare versions so it can make a report (potentially).
20:10:43 <filip_> as we all see web page report helps a lot for faster translation. we all like to see green there ;)
20:11:22 <filip_> maybe this can help for Calenco too
20:12:44 <obgr_seneca> ok, can we procede?
20:13:00 <obgr_seneca> #info having automatic reports would be good
20:13:37 <lebarhon> I found it http://www.java.com/en/download/help/linux_install.xml
20:13:42 <marja> #info Calenco is in the process of developing automated reports
20:14:25 <obgr_seneca> #info see http://www.java.com/en/download/help/linux_install.xml for installing sun jdk
20:14:30 <obgr_seneca> #topic Mga3 translations - what's to be done
20:14:46 <obgr_seneca> Ok, actually we are in freeze for some time
20:14:57 <marja> lebarhon: dune needs to provide his full name
20:15:19 <obgr_seneca> But you can still update your translations and hope for a rebuild of the tools involved before Mga3
20:15:37 <lebarhon> Marja: why him and not others
20:15:49 <obgr_seneca> And of course, if string changes occur, you should update your translations as well
20:16:45 <marja> lebarhon: because now Camille is in charge (before it was JohnR) ... and I suppose it also makes a difference that macxi had already written a lot of documentation, we already knew him
20:16:49 <filip_> lebarhon: I tried to follow that sun instructions recently but they are not working 100%
20:17:11 <marja> obgr_seneca: sorry for being off-topic
20:17:29 <obgr_seneca> filip_: I will check
20:17:35 <lebarhon> filip_: I never had problems with that, may be something elsewhere ?
20:17:36 <Qilaq> shouldn't it be done as requirement to (silently) rebuild packages for every release (I mean also betas, RCs and so on) which have modified original strings after freeze?
20:17:48 <obgr_seneca> #info important is now the website translation
20:17:54 <obgr_seneca> and of course the blog posts
20:18:17 <obgr_seneca> Qilaq: Actually it should, but devs are devs...
20:18:37 <Qilaq> I mean they are of course rebuilded but if may occur that rebuild is just after change and not anymore before release
20:18:43 <obgr_seneca> I will ping the involved people about it
20:19:22 <obgr_seneca> #action obgr_seneca see to it, that mga tools with string changes are rebuild before mga3 release so i18n can follow up
20:19:29 <filip_> lebarhon: I helped relative in Ubuntu. We then used one script from the net for adding repository and it worked.
20:20:16 <obgr_seneca> filip_: lebarhon: I installed sun java recently in the office, I will write something about it
20:21:36 <obgr_seneca> ok, next topic?
20:22:46 <obgr_seneca> #topic status of web translation platform
20:22:58 <filip_> obgr_seneca: please notify us on status about rebuild
20:23:07 <obgr_seneca> filip_: will do
20:23:25 <obgr_seneca> #info obgr_seneca is still trying to install pootle
20:23:39 <obgr_seneca> There are some problems on Mageia systems
20:24:18 <obgr_seneca> The way described in the pootle doc (using pip) doesn't work and we can not use it anyway since our sysadmins want a rpm package
20:24:42 <obgr_seneca> I'm right now trying to rebuild the fedora package
20:24:58 <obgr_seneca> But it is not yet working
20:24:58 <filip_> nice
20:25:14 <obgr_seneca> #action obgr_seneca do contact fwolff about it
20:25:24 <obgr_seneca> I know I should have done that some time ago
20:25:53 <obgr_seneca> Questions on it?
20:26:09 <Qilaq> Qilaq: is still wondering how e.g. Fedora does continue to use Transifex? Have they older version or have they so much man-power to overcome problems which were fatal to us?
20:26:10 <filip_> obgr_seneca: it's ok. real life is tough. Just notify us more
20:26:11 <lebarhon> What was using Mandriva
20:27:04 <obgr_seneca> They were (or are) using transifex like we did, but we don't have anyone with enough knowledge about it to fix our installation
20:27:30 <lebarhon> OK thanks
20:27:37 <yurchor> Qilaq: They use the platform that is created by third-party. Fedora/Red Hat own platform is Zanata.
20:27:43 <obgr_seneca> filip_: yes and since my new job is working out nicely and I'm way ahead of my boss's expectations, I really do have some time now :D
20:28:02 <marja> obgr_seneca: \o/
20:28:04 <Qilaq> Mandriva was also experimenting Transifex but it was, I may say, still-born ...
20:28:32 <obgr_seneca> yurchor: isn't fedora using tx?
20:28:42 <yurchor> Qilaq: They are also (as ROSA) moving their translations to tx.org.
20:28:47 <filip_> obgr_seneca: \o/
20:29:21 <yurchor> obgr_seneca: There are deep streams in Fedora... ;)
20:29:29 <obgr_seneca> yurchor: :D
20:29:29 <Qilaq> :-)
20:30:04 <obgr_seneca> ok, can we go on to next topic?
20:30:27 <obgr_seneca> #topic other
20:30:32 <Qilaq> that was "other topic"? :-)
20:30:37 <obgr_seneca> Ok, first about elections
20:30:50 <obgr_seneca> I sent the time table to the ml
20:31:21 <obgr_seneca> As I said, Akien and me will candidate again, promising to be more active in the future then we were in the last months
20:31:32 <obgr_seneca> But if any of you wants to candidate, do so
20:31:52 <obgr_seneca> we will not have any harsh feelings or any other stupid reaction
20:32:10 <obgr_seneca> Just consider it and send an email to the ml, if you decide to candidate
20:32:35 <obgr_seneca> I will send follow up mails about the epoll usage as we (i18n) have not used it before
20:33:08 <obgr_seneca> Important for now is having the list of people, who can vote up to date
20:33:19 <obgr_seneca> That is the team leaders of the language sub teams
20:33:52 <obgr_seneca> #action Check the wiki if the language team leaders are listed correctly there
20:34:11 <obgr_seneca> Any questions for now?
20:34:38 <obgr_seneca> (my train leaves at 6.25 in the morning so I'm a bit in a hurry right now)
20:35:40 <obgr_seneca> Any other things for the other topic?
20:35:51 <marja> not here
20:36:14 <obgr_seneca> ok, then...
20:36:17 <obgr_seneca> #endmeeting