17:32:10 <obgr_seneca> #startmeeting
17:32:10 <Inigo_Montoya> Meeting started Thu Aug  2 17:32:10 2012 UTC.  The chair is obgr_seneca. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:32:10 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:32:22 <obgr_seneca> Hi everyone and welcome to i18n meeting
17:32:54 <obgr_seneca> As I said in the mail I'd like to propose a short status meeting only
17:33:20 <obgr_seneca> Because I have to finish my thesis till end of August and thus I am a bit busy...
17:33:28 <obgr_seneca> #topic website status
17:33:46 <obgr_seneca> filip_k: would you want to give us a bit of information?
17:34:18 <filip_k> there is not much to report besides info I already gave on ML
17:34:42 <filip_k> I'm willing to continue but I would like some sugestions
17:35:02 <obgr_seneca> suggestions about what?
17:35:07 <filip_k> and maybe some more feedback
17:35:26 <filip_k> about what pages we should convert first
17:35:36 <obgr_seneca> From my point of view, it's great what you are doing
17:35:44 <obgr_seneca> What pages do we have left?
17:36:05 <obgr_seneca> I think the 1/ pages have low priority, most people won't go there nowadays
17:36:41 <filip_k> I don't have an exact report about that but I can come back in 3 minutes with something
17:36:50 <obgr_seneca> would be good
17:36:52 <obgr_seneca> About those check pages, yurchor what does not work?
17:37:04 <filip_k> Remi asked about changing one string
17:37:32 <yurchor> obgr_seneca: On report page: http://www.mageia.org/langs/report.php
17:37:49 <obgr_seneca> yurchor: that's a bit ambiguos...
17:38:09 <obgr_seneca> check page leads you to the page in your locale so you can see if everything is all right
17:38:24 <filip_k> I didn't convert that page. I'm trying to include as much as possible to lang files as that offers us flexibility
17:38:27 <yurchor> Wait... Click on "check page" in the CoC or Values column for the ready translations.
17:38:44 <obgr_seneca> if you want to have the report about a page, you have to click the "foo missing" thing
17:39:08 <filip_k> if we agree I can do some changes on older lang files but that will mark some string untranslated
17:39:12 <yurchor> obgr_seneca: Ok. But if I want to check page?
17:39:28 <yurchor> Other pages are working.
17:39:48 <filip_k> you can check page by normal browsing
17:39:50 <obgr_seneca> yurchor: let's take the code of conduct
17:40:08 <obgr_seneca> you get a 404 :-/
17:40:11 <obgr_seneca> I see...
17:40:20 <filip_k> only pages below /en/about/ don't work
17:40:34 <yurchor> A-ha... Thanks.
17:41:02 <filip_k> I can take a look in the following days as this is not big deal really
17:41:34 <obgr_seneca> I asked rda to join us, perhaps he has some information...
17:42:08 <filip_k> please discuss about those changes of strings as I look for pages to translate
17:42:18 <obgr_seneca> we will do...
17:42:25 <filip_k> I'll report later
17:43:25 <obgr_seneca> so let's see, what Akien wanted to change...
17:45:01 <obgr_seneca> I'd say best we make 3 strings out of it
17:45:05 <obgr_seneca> Subversion
17:45:08 <obgr_seneca> Git
17:45:10 <obgr_seneca> and
17:45:23 <obgr_seneca> -Code-Repositories
17:45:35 <obgr_seneca> so we don't have any html tags in them
17:45:46 <obgr_seneca> yurchor: any thoughts about it?
17:46:39 <yurchor> I don't know how it works, maybe some linebreaking can help?
17:47:00 <obgr_seneca> good question...
17:47:15 <yurchor> Or strip some formatting...
17:47:29 <Qilaq> hi, and sorry for being late
17:47:34 <obgr_seneca> If I read Akien's mail correctly, the problem is the html tag in Git</a>-Code-Repositories
17:47:37 <obgr_seneca> Hi Qilaq
17:48:24 <Qilaq> If the question is what pages should be (more) prioritized then maybe reports and its subpages - money is the ting people are always interested of :-)
17:48:44 <obgr_seneca> Qilaq: good thinking!
17:50:11 <obgr_seneca> About that string Akien asked about, I have to check the php source...
17:50:16 <filip_k> all pages left for conversion: 1(for-you, index.php, next,  notes), calendar, thank-you, charter, 2010-sept-announcement.html,  constitution,  founders.html, media,  reports (2010,  2011,  2012,  index.php)
17:50:25 <obgr_seneca> I will do that and write a proposal by mail
17:50:48 <obgr_seneca> As Qilaq said, maybe reports first
17:51:19 <obgr_seneca> then media, constitution, thank-you
17:51:39 <Qilaq> and initial announcement is also important - though it's maybe already translated by some teams in html
17:51:58 <obgr_seneca> yes, maybe
17:52:01 <filip_k> I think the question is more should be expand strings for translation as much as possible arther then talk about those two strings
17:52:35 <obgr_seneca> hm?
17:52:36 <filip_k> there are many pages in html already
17:53:26 <filip_k> I suggest an idea for rda as I would need to setup a development server to code and test that
17:53:48 <filip_k> I hope he'll do that soon
17:54:27 <obgr_seneca> I suggested some "staging" server to test website changes before they go live some time ago
17:54:34 <filip_k> we need some info points in report ;)
17:54:44 <obgr_seneca> And I still consider it a good idea
17:54:51 <filip_k> me too
17:55:29 <filip_k> I missed navigation on one page for 10 minutes becuase of that ;)
17:55:56 <obgr_seneca> As long as rda is not here, should we go on with other topics?
17:56:21 <filip_k> please we should info those two decisions
17:56:27 <filip_k> about strings
17:56:38 <filip_k> and order of conversion
17:56:48 <obgr_seneca> oh sorry
17:57:13 <obgr_seneca> #info order of lang file coversion: report, media, constitution, thank-you
17:57:23 <obgr_seneca> #info then the rest as we go along
17:58:06 <obgr_seneca> ok?
17:58:26 <filip_k> yes. can I do with pages with less work before those?
17:58:43 <obgr_seneca> of course you can
17:58:49 <filip_k> great
17:58:51 <obgr_seneca> #action obgr_seneca look into that string change request done by Akien
18:00:14 <obgr_seneca> ok, next?
18:00:15 <filip_k> I still think the question is more should be expand strings for translation as much as possible rather then talk about those two strings as that will "broke" existing translations of those strings
18:00:39 <filip_k> but we should be as flexible as possible
18:00:50 <obgr_seneca> filip_k: good question
18:02:15 <filip_k> I think it's not too late to do that now. I need to look but I think that there is not much of such strings.
18:02:17 <obgr_seneca> should be considered with rda and others
18:02:43 <obgr_seneca> #undo
18:02:43 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x84825ac>
18:02:45 <filip_k> I think that is our decision as it shouldn't affect rda
18:02:49 <MrsB> hello :)
18:03:10 <obgr_seneca> #idea check for strings that could be changed to give translators more flexibility
18:03:13 <obgr_seneca> right?
18:03:17 <filip_k> I can take a look and report about that on ML
18:03:19 <obgr_seneca> Hi MrsB :)
18:03:45 <MrsB> i was hoping somebody would attend from the en subteam
18:03:59 <obgr_seneca> filip_k: yes, but I would like to keep him informed
18:04:00 <MrsB> looks like it's me!
18:04:08 <filip_k> obgr_seneca: of course
18:04:11 <obgr_seneca> MrsB: you are welcome
18:04:40 <yurchor> obgr_seneca: It is always tradeoff: more flexibility=more formatting inside of strings, imho.
18:04:53 <obgr_seneca> yurchor: yes, I know
18:05:15 <filip_k> yurchor: exactly. so we need to go deeper for good decision
18:05:23 <obgr_seneca> but sometimes you need to reorder strings so they don't sound strange in your language
18:06:07 <filip_k> I'l take a look but I won't be so productive after this week as I go back to work ;)
18:06:15 <obgr_seneca> filip_k: :-(
18:06:32 <obgr_seneca> it would be so much better if we didn't have to work ;-)
18:06:38 <filip_k> ;)
18:07:11 <filip_k> but that php conversion is much easier for me than translating
18:07:23 <obgr_seneca> ok then
18:07:52 <obgr_seneca> but don't stop translating, would be a big whole in your team
18:08:00 <obgr_seneca> :D
18:08:19 <filip_k> I know. it's my priority #1
18:08:42 <obgr_seneca> ok, shall we go on?
18:08:48 <filip_k> please
18:09:08 <obgr_seneca> #topic leftover actions
18:09:50 <obgr_seneca> I know, I had pootle on my list, but I didn't get to it
18:10:07 <obgr_seneca> I will sit down with fwolff and the sysadmins about it
18:10:26 <obgr_seneca> yurchor: have you by any chance written that workflow thing about indifex tx?
18:11:09 <Qilaq> well, as a rule one should not break a sentence if there is no good reason
18:11:10 <yurchor> obgr_seneca: Is my message to ML not enough?
18:11:25 <obgr_seneca> yurchor: oups, I'' check
18:11:39 <Qilaq> sorry, it was about previous subject ...
18:12:20 <obgr_seneca> Qilaq: yes?
18:12:36 <filip_k> Qilaq: I'll try to post more info on ML about that and then we can decide better
18:13:40 <yurchor> obgr_seneca: https://www.mageia.org/pipermail/mageia-i18n/2012-July/003183.html
18:13:41 <obgr_seneca> Any other actions we missed?
18:13:56 <obgr_seneca> yurchor: thx, must have slipped my attention
18:14:49 <obgr_seneca> About wiki: I did ask for help on dev and discuss ml
18:14:56 <obgr_seneca> I hope somebody will react
18:15:10 <MrsB> I was going to try and help with that, sorry
18:15:27 <obgr_seneca> I have to finish my thesis for end of august and time has gotten a bit less then I thought
18:15:48 <obgr_seneca> #info MrsB will try and help with wiki
18:15:50 <obgr_seneca> thx
18:15:56 <Qilaq> I meant if there is a sentence/phrase like "Git, Subversion code repositories", it should not be broken in two- wasn't it the problem or have I understood something not right?
18:15:58 <MrsB> I'm away next week but if i get a chance I will have a look, not sure i will be much help though
18:16:52 <MrsB> is it uploads are the problem obgr_seneca?
18:17:15 <obgr_seneca> Qilaq: yes
18:17:29 <obgr_seneca> MrsB: uploads (and by extension of that math)
18:17:59 <MrsB> does that use a temp directory or something?
18:18:26 <obgr_seneca> MrsB: yes, it is in the readme urpmi of the package in testing
18:19:28 <filip_k> about pootle: fwolff just needs answers on those questions on ML and he said that he can put demo server in a few spare days
18:19:55 <obgr_seneca> yes, I will do, I promise!
18:20:35 <obgr_seneca> btw I did rewrite https://wiki.mageia.org/en/Internationalisation_Team_(i18n) a bit
18:20:47 <obgr_seneca> Any comments on it?
18:21:27 <MrsB> there isn't much in the way of basic docs for people new to i18n
18:22:12 <MrsB> I need to ask you about that but doing too many things at once at the moment :\
18:22:30 <obgr_seneca> MrsB: you can always ask us in this channel
18:22:55 <obgr_seneca> (and if you want to be good, write our answers to some kind of i18n faq :D )
18:22:59 <MrsB> yep
18:23:13 <MrsB> just need another hour in the day though please
18:23:35 <MrsB> where is a good place to start for the en menu's and things?
18:24:13 <MrsB> and if we download the pot and create a new po should we just email it to the list?
18:24:24 <obgr_seneca> MrsB: yes, please
18:24:35 <obgr_seneca> we will see to it, you get access to the svn
18:24:55 <obgr_seneca> About menu translations, the menu entries are created from  the applications themselves
18:25:04 <MrsB> ok thanks, I'll try to organise an en team leader
18:25:07 <obgr_seneca> I'm not sure, what you are looking for exactly
18:25:46 <filip_k> in wiki: "Teams meetings of the Mageia internationalisation team are on Thursday evenings at 18:30 UTC ..." ;)
18:25:48 <MrsB> me either to tell the truth. There are some pot's somewhere for MCC and things like that we could translate to en_GB etc though presumably
18:26:56 <yurchor> MrsB: Can it be drakx tools?
18:27:04 <obgr_seneca> filip_k: should be fixed
18:27:18 <obgr_seneca> MrsB:  or control-center?
18:27:19 <MrsB> probably so yes yurchor. I need to find more time to look into this :\
18:27:25 <MrsB> that too :)
18:27:38 <filip_k> can someone tell me if Drakx-help.pot is not really needed anymore?
18:28:21 <obgr_seneca> filip_k: Damn it, I knew I wanted to ask
18:28:29 <MrsB> sorry, brb
18:28:48 <obgr_seneca> #action obgr_seneca ask devs about Drakx-help.pot, is it needed?
18:28:59 <filip_k> wiki now: "...are on every second Thursday ...
18:29:07 <obgr_seneca> #action filip_k ping obgr_seneca in two days about that
18:29:13 <obgr_seneca> ok?
18:29:17 <filip_k> great
18:29:46 <obgr_seneca> ok, other things?
18:30:02 <filip_k> good news: not from me ;)
18:30:11 <Qilaq> in Mandriva there was menu-messages-contrib/main/nonfree which made easy to have translated menu entries for programs not translated in your language upstream
18:30:38 <obgr_seneca> Qilaq: Yes I remember
18:30:49 <obgr_seneca> we should look into that
18:31:21 <obgr_seneca> #action ask devs about menu-messages pot for translating menu entries not translated upstream
18:31:59 <filip_k> it would be rally nice if there would be a list of things to translate in wiki
18:32:22 <Qilaq> though they had also strings from programs translated upstream
18:32:34 <obgr_seneca> filip_k: https://wiki.mageia.org/en/Translation_resources_in_svn
18:32:36 <obgr_seneca> ?
18:32:44 <yurchor> filip_k: There is no doc/ManualB in my system or on the site, so I guess they are not used.
18:32:59 <obgr_seneca> Qilaq: I'm not sure how it was done, I'll have to check with some devs
18:33:15 <Qilaq> imho menu-messages-* were just collection of strings extracted from packages headers or something
18:33:34 <obgr_seneca> must be something along those lines
18:33:55 <filip_k> obgr_seneca: "Please note! This list is most certainly incomplete. ... Ask on the i18n ml if you are unsure."
18:34:01 <filip_k> I'm unsure ;)ć
18:34:11 <Qilaq> there are fields Name and Description what were extracted imho
18:34:22 * obgr_seneca too, that's why I put that line there
18:34:54 <obgr_seneca> Qilaq: probably, but I don't know for sure
18:35:14 <filip_k> yurchor: what about liveCD and DVD?
18:35:38 <yurchor> Nothing either.
18:35:51 <obgr_seneca> That's why I wanted to check with the devs
18:36:03 <obgr_seneca> filip_k: where can that pot file be found?
18:36:15 <yurchor> There are no special packages for Live only, imho.
18:36:50 <yurchor> obgr_seneca: http://svnweb.mageia.org/soft/drakx/trunk/perl-install/install/help/po/
18:37:18 <filip_k> obgr_seneca: http://svn.mageia.org/svn/soft/drakx/trunk/perl-install/install/help/po/
18:37:19 <obgr_seneca> #link http://svnweb.mageia.org/soft/drakx/trunk/perl-install/install/help/po/
18:37:31 <obgr_seneca> thx, I didn#t find it
18:37:38 <Qilaq> which was not used already in Mandriva and most probably also in Mageia
18:38:08 <obgr_seneca> Qilaq: probably not, but then we could remove it from svn so we know for sure
18:38:59 <obgr_seneca> Ok, can we close for now, I should leave
18:39:01 <obgr_seneca> sorry
18:39:05 <filip_k> developers should decide if help will be online only
18:40:24 <filip_k> obgr_seneca: I can add resources for mga2 to wiki. Should I do that?
18:40:29 <obgr_seneca> yep, we will ask them
18:40:35 <obgr_seneca> filip_k: yes please
18:41:09 <filip_k> it's on my todo but I'll just mirror svn
18:41:27 <obgr_seneca> ok, thx
18:41:43 <filip_k> and info for that drax-hlp
18:42:05 <obgr_seneca> #info see if drakx-help is still needed
18:42:22 <obgr_seneca> #action filip_k add mga2 resources to wiki
18:42:30 <filip_k> without mga 1 ;)
18:43:18 <obgr_seneca> mga1 is end of life in a few months, I think we don't need much more translations there
18:43:29 <MrsB> Yay \o/
18:43:29 <obgr_seneca> #chair filip_k
18:43:29 <Inigo_Montoya> Current chairs: filip_k obgr_seneca
18:43:43 <filip_k> can we please close
18:43:43 <obgr_seneca> could you end the meeting then? I have to go
18:43:48 <obgr_seneca> #endmeeting