17:39:26 <obgr_seneca> #startmeeting
17:39:26 <Inigo_Montoya> Meeting started Tue Jul 17 17:39:26 2012 UTC.  The chair is obgr_seneca. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:39:26 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:39:31 <obgr_seneca> #chair Akien
17:39:31 <Inigo_Montoya> Current chairs: Akien obgr_seneca
17:39:54 <coincoin> hello all
17:40:01 <filip_> hi coincoin
17:40:04 <obgr_seneca> Hi coincoin
17:40:06 <Akien> Hi :)
17:40:09 <filip_> and others
17:40:30 <xxblx> hello
17:40:41 <obgr_seneca> #topic wiki and translate extension
17:40:58 <obgr_seneca> ok, we have some technical problems here
17:41:12 <obgr_seneca> our mediawiki package is not working
17:41:21 <obgr_seneca> meaning the new 1.19.1 version
17:42:05 <obgr_seneca> if any one of you has some php skills, the packages are available in the cauldron core/updates_testing repo
17:42:22 <obgr_seneca> the problems occur with file upload and math extension
17:42:39 <obgr_seneca> as soon as I solve that, I can build the translate extension
17:42:53 <coincoin> only "our" package is broken or it's a mediawiki issue?
17:43:09 <obgr_seneca> coincoin: it's only our package
17:43:33 <obgr_seneca> we have then the possibility to translate wiki pages using either the extension's online tool or we can export normal po files
17:43:55 <obgr_seneca> so we have a translator friendly way for doing it :)
17:44:01 <Akien> Both possibilities are provided by the extension?
17:44:12 <obgr_seneca> Akien: yes
17:44:15 <Akien> Nice
17:44:54 <Qilaq> sry fo being late, Doctor Who just ended :-) - and hi!
17:45:04 <obgr_seneca> The extension's developer is available at #mageia-doc and some of our translators do know it from kde userbase
17:45:10 <obgr_seneca> Qilaq: hi
17:45:35 <coincoin> Qilaq: :) hi
17:45:38 <obgr_seneca> any questions about it?
17:45:59 <lebarhon> it's about the sync pages ?
17:46:30 <obgr_seneca> sync pages?
17:46:42 <lebarhon> synchronized
17:46:46 <obgr_seneca> yes
17:47:01 <Qilaq> I heard a presentation about the extension and translation of KDE Userbase at Akademy and it impressed me quite well, so it'd be very nice if we can have same possibility
17:47:29 <obgr_seneca> we have the possibility to "mark pages for translation" but we can also add pages that are only available in one language
17:48:04 <obgr_seneca> so e.g. a French page about the i18n-fr team's organization can just stay like it is
17:48:27 <lebarhon> we could start multi-language wiki without sync pages
17:49:01 <obgr_seneca> lebarhon: we have to update the mediawiki non the less, 1.16 is end of life
17:49:10 <lebarhon> OK
17:49:21 <obgr_seneca> and it shouldn't need more then a week to finish it (I hope)
17:50:09 <obgr_seneca> next topic?
17:50:42 <Akien> Fine by me.
17:50:47 <obgr_seneca> #topic blogs
17:51:00 <obgr_seneca> coincoin: now that you are here...
17:51:13 <obgr_seneca> Do you have a status about the blogs in general?
17:52:52 <obgr_seneca> hm, seems not :-(
17:53:12 <coincoin> back
17:53:13 <coincoin> yes
17:53:15 <coincoin> sorry
17:53:23 <coincoin> so, we have new translators
17:53:33 <coincoin> ru and pl blogs should live again!
17:53:43 <obgr_seneca> great!
17:54:01 <obgr_seneca> any ones that are "asleep" right now?
17:54:07 <coincoin> I'm also working on WP theme to upgrade it to feat WP 3.4.1 API
17:54:21 <coincoin> for now: nl...
17:54:33 <coincoin> and uk
17:54:43 <coincoin> I'm wondering what to do with those 2 blogs
17:55:10 <obgr_seneca> ok, can we disable them? their last entries are so old, it's not really worth keeping them online imho
17:55:23 <coincoin> I agree with you
17:55:36 <coincoin> so bad, uk is just a new blog... but
17:56:22 <coincoin> that's all for blogs I think (I will do some work on puppet but not things for i18n)
17:56:42 <obgr_seneca> ok, thanks
17:56:43 <coincoin> planet? :)
17:56:53 <obgr_seneca> yes?
17:57:00 <coincoin> topic? :�
17:57:07 <obgr_seneca> #topic planet
17:57:07 <coincoin> #topic planets
17:57:12 <coincoin> he he
17:57:20 <obgr_seneca> #undo
17:57:20 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Topic object at 0x835b78c>
17:57:23 <obgr_seneca> #topic planets
17:57:45 <coincoin> so, I talk to Pascal Chevrel, the new main moonmoon dev (our planet framework)
17:58:19 <coincoin> I gave him my opinion on the work and he told me what will arrive (he use it for Mozilla planet)
17:58:37 <coincoin> he advised me to deploy git-moz snapshot for Mageia
17:58:44 <coincoin> so, I will do on Friday or on Monday
17:58:58 <obgr_seneca> ok
17:59:07 <coincoin> moreover, I will update wiki page to better explain planet and how be on it
17:59:29 <obgr_seneca> #info coincoin will deploy git-moz snapshot of our plante framework
17:59:30 <coincoin> and... I will add it to SVN (FYI, now, moonmoon can be translated! \o/)
17:59:41 <obgr_seneca> we do have planets for what languages?
17:59:55 <coincoin> en, it, de, es, fr, pt for now IIRC
18:00:04 <obgr_seneca> ok
18:00:23 <coincoin> that's all for me
18:00:39 <obgr_seneca> ok, thx for reporting about it
18:01:03 <obgr_seneca> #topic website translation
18:02:12 <obgr_seneca> Akien: You did some work there together with rda, I think?
18:02:20 <Akien> Indeed
18:02:53 <Akien> I had a look at the way .lang files are generated and used in the html files.
18:03:42 <Akien> With a few explanations from rda I managed to proofread the existing .lang and to generate new ones, with a few changes to the previous pages.
18:04:07 <obgr_seneca> is there a way to merge new translations into existing lang files?
18:04:13 <obgr_seneca> And how is that done?
18:04:26 <obgr_seneca> I notice, there are strings missing in the de lang files
18:04:41 <filip_> yes. it would be nice if it would be documented in wiki
18:05:02 <Akien> Hum, I did most changes by hand since I don't understand much of PHP :)
18:05:06 <Akien> rda made two scripts
18:05:26 <obgr_seneca> ok, I'll ask him when he is back
18:05:27 <yurchor> obgr_seneca: it should be easy to write some script (rewrite of my early work) but some php are scrumbled a lot...
18:05:32 <Akien> One to generate translated .lang files from the locales.php files we used previously.
18:05:41 <filip_> obgr_seneca: did you check http://www.mageia.org/langs/report.php lately?
18:05:48 <Akien> And one to generate name.en.lang files from the main pages.
18:06:13 <obgr_seneca> ok
18:06:17 <Akien> The link filip_ gave is quite useful to know if the translations are up to date or if some strings are missing.
18:06:33 <obgr_seneca> yes, I looked at it some days ago
18:06:41 <Akien> But there is no automated way to add new strings to a translation, for now the .lang file should be edited by hand.
18:07:24 <yurchor> rda said that this should be static pages...
18:08:14 <yurchor> Moreover, it is easy to copy strings from the pages mentioned above.
18:08:22 <filip_> Akien: will you continue with other pages?
18:08:37 <obgr_seneca> yurchor: yes, but I don't understand where the 38 missing string in one of the de files are coming from
18:09:28 <Akien> filip_: Yes, I intend to when I find the time.
18:09:38 <yurchor> obgr_seneca: Ok. it's not esy to do this even if the strings are ordered. ;)
18:09:44 <filip_> Akien: great!
18:09:48 <Akien> If someone has PHP skills, rda's scripts could use a little work.
18:09:55 <obgr_seneca> yurchor: ;)
18:10:12 <obgr_seneca> Akien: I do but I have a wiki to get running :/
18:10:19 <filip_> I admit I have them too but I'm one man band still
18:10:32 <Akien> Namely some strings are badly handled by the scripts, the regexps don't handle quotes or "%s" well.
18:10:34 <Qilaq> obgr_seneca: these 38 missing, I guess, are for page talking about how great is Mageia 2 for your PC
18:10:42 <obgr_seneca> Akien: when do you come back from your holidays?
18:10:53 <Akien> I'm back :)
18:10:57 <obgr_seneca> Ah ok
18:11:07 <obgr_seneca> rda will be back in about a week
18:11:15 <Akien> Though I will go again on Saturday, but I can work a bit on www in the following days.
18:11:20 <obgr_seneca> we can work on it together then?
18:11:26 <Akien> Ah ok, I'll have to do without him then.
18:11:42 <obgr_seneca> Akien: would be graeat
18:11:58 <Qilaq> most wanted and still missing is probably translation of Community page ...
18:12:03 <obgr_seneca> #help rda scripts for lang file creation need some work
18:12:03 <Akien> Well I'll play a bit with the scripts, I think I already know what is going wrong.
18:12:09 <filip_> Qilaq: yes http://www.mageia.org/en/for-pc/
18:12:33 <obgr_seneca> #info Akien will do some work on web the next few days
18:12:44 <Akien> When I know precisely I'll ask on the ML, filip_ or obgr_seneca you may find the time to have a look at it. I think it is an easy fix for someone who knows PHP and regexps.
18:12:57 <obgr_seneca> Akien: can do
18:13:11 <filip_> Akien: I'll try my best
18:13:27 <filip_> I'm good for nitt picking ;)
18:13:35 <coincoin> I will code for food!
18:13:51 <Akien> I'll try to write what the script is supposed to do, how I understood it works, and what doesn't behave as expected. It should simplify your work :)
18:13:58 <obgr_seneca> coincoin: just come wisit me, I will cook something :D
18:14:04 <coincoin> he he :)
18:14:55 <filip_> what about transition to po files? at least on the long run.
18:15:22 <obgr_seneca> filip_: we have to ask rda, he has some reservations about it, but I don't know for sure
18:16:03 <Akien> IIRC he said he had a bad first impression with gettext and doesn't really want to try it again (even though he knows it has evolved since then).
18:16:13 <obgr_seneca> :D
18:16:33 <filip_> he was mainly tlaking about server side IIRC
18:16:53 <Qilaq> well, KDE has experimented with translation of web pages through the PO files but it seems to be not very popular ...
18:16:54 <filip_> maybe yurchor can add something to this?
18:17:15 <obgr_seneca> #action ask rda about long term transition to po files and what is to say against it
18:17:36 <yurchor> filip_: It is done through scripty, so it must be unusable here.
18:17:50 <obgr_seneca> I know e.g. drupal does support po files, but we would have to completely rewrite www to switch to drupal
18:18:34 <filip_> Qilaq: how KDE is doing translation of web pages now?
18:18:40 <yurchor> Scripty extracts and scripty merges the translation. It needs significant process time.
18:19:17 <Qilaq> I don't mean to use .lang files, at least so far, as Mageia has quite a few web pages still - but looking to future it may be good to think about alternatives
18:19:18 <filip_> yurchor: but it needs them only at commit time doesn't it?
18:20:01 <Akien> Qilaq: Though if we write a few good scripts .lang files are even simpler than .po files.
18:20:30 <obgr_seneca> Akien: yes, but po files can be edited with standard tools like lokalize
18:20:30 <yurchor> filip_: There are perl extragtion scripts in any www folder. It extracts to strings just like from code and merges them in similar way using cron.
18:20:33 <Akien> But that does feel a bit like reinventing the wheel :)
18:20:36 <Qilaq> as I'm quite computer illiterate I don't know specifics, olny that so far only edu.kde.org and okular.kde.org have used such system
18:21:31 <yurchor> If someone is interested, he can contact tsdgeos on #kde-i18n
18:22:13 <obgr_seneca> #info if someone is intersted in the kde way, contact tsdgeos on #kde-i18n
18:23:02 <obgr_seneca> shall we go on to the next topic then?
18:23:26 <filip_> not yet
18:23:30 <obgr_seneca> ok
18:23:36 <filip_> I have some questions ;)
18:23:41 <Qilaq> or look at KDE svn at http://websvn.kde.org/trunk/www/sites/ -somebody who knows what to look could probably understand how it is done
18:23:42 <obgr_seneca> go ahead
18:24:09 <filip_> I asked about few resources not listed in wiki yet
18:24:22 <filip_> on ML but no anser about them
18:25:07 <obgr_seneca> filip_: only rda knows enough about it
18:25:14 <obgr_seneca> I'm afraid
18:25:15 <Qilaq> well, I answered about probably obscured for now install help :-)
18:25:36 <filip_> sorry. I'm talking about soft svn ;)
18:25:55 <filip_> Qilaq: yes mainly those
18:25:57 <yurchor> filip_: If you cannot find them on hard drive, it must be they are obsolete.
18:26:22 <filip_> yurchor: what about LiveCD?
18:26:51 <yurchor> filip_: Help for Draktools?
18:27:14 <Qilaq> that install help PO files were abandoned at Mandriva when writing and translating went to, hmm, Calenco it is now?
18:27:28 <obgr_seneca> yes
18:27:28 <filip_> I can take a look but it's not about web page transl.
18:27:38 <Qilaq> but the files themselves just stayed ...
18:27:48 <obgr_seneca> filip_: contact marja, she knows more about that
18:28:11 <filip_> then someone should remove them from trunk?
18:28:33 <Qilaq> I myself was surpprised to discover helt at install time is not translated any more and asked and they asnwered that it is abandoned
18:28:40 <obgr_seneca> #action ask devs for removing unused translation files of help from trunk
18:28:56 <Qilaq> I guess it was just copied from Mandriva when Mageia started
18:29:05 <obgr_seneca> probably
18:29:17 <coincoin> I've got a point to on Website translation
18:29:25 <obgr_seneca> yes?
18:29:38 <coincoin> in the past, I made http://svnweb.mageia.org/web/www/trunk/langs.php?r1=189&r2=235
18:29:48 <coincoin> it was preventing 404 when missing pages in locales
18:29:59 <coincoin> it has been removed... why not re using it?
18:30:16 <coincoin> why was it removed? :)
18:30:26 <obgr_seneca> Good idea, better have the english page then a 404
18:30:38 <obgr_seneca> about why you have to ask rda
18:31:01 <coincoin> yes, I will but I would like to have this in the meeting log :)
18:31:45 <obgr_seneca> #info coincoin asks, why langs.php was removed from the website for not having 404s when the page is not available in one language
18:32:04 <obgr_seneca> coincoin: better?
18:32:07 <coincoin> not langs.php but locale_path() function (from langs.php)
18:32:21 <coincoin> obgr_seneca: yes :)
18:32:23 <obgr_seneca> ok
18:32:49 <obgr_seneca> filip_: anything else?
18:32:57 <filip_> no
18:33:04 <obgr_seneca> ok
18:33:10 <obgr_seneca> #topic tx replacement
18:33:19 <obgr_seneca> I was looking into weblate
18:33:41 <obgr_seneca> it's still quite basic but I like the way it is using a vcs
18:34:00 <obgr_seneca> the problem is we would need a git repo with a two way bridge to our svn
18:34:32 <obgr_seneca> and pushing and pulling changes should be done automatically between the two of them
18:34:50 <obgr_seneca> this needs some clever scripting on past commit hooks
18:35:25 <obgr_seneca> You can look at it at http://www.weblate.org/
18:35:48 <obgr_seneca> there is a demo, but its contents is so simple you don't really see much there
18:36:08 <obgr_seneca> I would like to setup a demo instance somewhere so we can have a deeper look into it
18:36:55 <filip_> sorry obgr_seneca: what about last meeting action: ask fwolff about summarizing pootle for us
18:37:10 <obgr_seneca> ouch should I have done that?
18:37:28 <filip_> no. it was unasigned.
18:37:37 <obgr_seneca> good
18:37:56 <obgr_seneca> or no, not really good, but it's not completely my fault then ;-)
18:38:11 <obgr_seneca> did anyone have a look at pootle?
18:38:49 <filip_> I wanted to do it locally but it's not in mga2
18:39:11 <yurchor> I have some experience with Pootle in past.
18:39:20 <obgr_seneca> yurchor: any comments on it?
18:40:18 <yurchor> It is not very fast when connected directly to Subversion. The experience was awful...
18:40:24 <Qilaq> me too but only as casual user (Libreoffice is translated through Pootle) - and it seems quite similar to Transifex
18:40:51 <obgr_seneca> ok
18:41:18 <obgr_seneca> is anyone willing to discuss it with fwolff?
18:41:30 <yurchor> Big subversion instances like OOo and Opera were very slow (may be because of Subversion nature).
18:41:44 <obgr_seneca> I have quite a full plate of things myself
18:41:53 <yurchor> Can we ask him directly?
18:42:04 <obgr_seneca> he's here, but away
18:42:08 <obgr_seneca> fwolff: ping
18:42:53 <obgr_seneca> he is connected from a .za tld, what country is that?
18:43:10 <filip_> zairo?
18:43:14 <Qilaq> maybe there is possibility to synchronize Pootle and svn not instantly but, say, once or twice in a day?
18:43:16 <yurchor> Zambia
18:43:47 <obgr_seneca> Qilaq: we will have to look into it, so we don't get conflicts
18:43:56 <obgr_seneca> that was always a problem with tx
18:44:12 <filip_> Qilaq: I like that or better still it should me manual to commit
18:44:21 <obgr_seneca> I had to do some regexp string replacement every time I updated a resource
18:44:26 <Akien> yurchor: I think it is South Africa.
18:44:31 <filip_> only checkout should be automatic
18:45:24 <Qilaq> for them who understand: http://translate.sourceforge.net/wiki/pootle/version_control
18:45:33 <obgr_seneca> as what I saw from weblate is still very basic, I will find some server to set up a pootle instance
18:45:41 <obgr_seneca> and we can have a look there, ok?
18:45:49 <yurchor> Akien: Yes, you are right. Sorry.
18:45:57 <obgr_seneca> #link http://translate.sourceforge.net/wiki/pootle/version_control
18:47:57 <filip_> I think we should repair or abandon TX ASAP
18:48:13 <filip_> we need decision about that
18:48:38 <obgr_seneca> I am for abandoning it
18:48:44 <Akien> Me too.
18:48:48 <filip_> me too
18:48:48 <Qilaq> me too
18:49:00 <yurchor> +1
18:49:03 <obgr_seneca> ok
18:49:10 <obgr_seneca> #agreed abandon tx
18:49:33 <obgr_seneca> #action obgr_seneca ask sysadmin team to abandon tx
18:49:38 <Akien> If we don't find a replacement for it, we will have to define a precise workflow with Lokalize/Poedit/other + SVN, but I don't see how we could fix Tx. We don't really know where it is broken ;)
18:49:51 <obgr_seneca> Akien: yep
18:50:26 <filip_> for now we shoul document workflow in wiki
18:50:31 <obgr_seneca> misc did invest quite some time into it, but he couldn't get it running again
18:50:33 <yurchor> There is an option though... Can we use indifex instance in a way Fedora do?
18:50:44 <obgr_seneca> yurchor: we could
18:50:54 <obgr_seneca> we should talk to fedora people about it
18:51:15 <obgr_seneca> about how they are managing it and how they do the commit stuff and so on
18:51:45 <yurchor> I am sto the some extent Fedora man... ;)
18:52:16 <filip_> yurchor: you're multitask man ;)
18:52:20 <Akien> :)
18:52:22 <obgr_seneca> yurchor: great
18:53:06 <obgr_seneca> yurchor: is there some wiki page about fedora workflow?
18:53:31 <yurchor> Indifex get free pages for free projects but the new Transifex should be used by our developers.
18:54:16 <obgr_seneca> that might be... difficult to achive
18:54:23 <yurchor> Some Fedora developers forget to pull translations for the releases regularily.about
18:54:32 <obgr_seneca> I'm not sure we can get our devs to use it :/
18:55:11 <filip_> yurchor: why dev should use it?
18:56:03 <yurchor> filip_: Translations are in Indifex cloud. Nothing in repository itself, just tx script.
18:56:52 <yurchor> If noone push pot on TX.net and pull translations, application will be untranslated. :'(
18:57:01 <obgr_seneca> ok
18:57:07 <filip_> nasty
18:57:17 <filip_> we should avoid that
18:57:39 <filip_> or do some automation if possible
18:57:39 <Qilaq> Fedora has quite large Wiki page for translation: https://fedoraproject.org/wiki/L10N/Guide
18:58:06 <obgr_seneca> #link https://fedoraproject.org/wiki/L10N/Guide
18:58:30 <obgr_seneca> we should explore both options
18:58:49 <obgr_seneca> Shall we summarize what we have?
18:59:39 <filip_> we should
19:00:28 <obgr_seneca> #info four possibilities: pootle, weblate, svn workflow and indifex instance of transifex
19:00:40 <Qilaq> No Tx as we have had so far but hope we will find something better? :-)
19:00:53 <obgr_seneca> #info svn workflow is always possible
19:01:13 <obgr_seneca> #action obgr_seneca set up a pootle somewhere to play arround with it
19:01:52 <obgr_seneca> yurchor: are you willing to write some workflow for the indifex tx way?
19:02:08 <yurchor> obgr_seneca: Ok.
19:02:14 <obgr_seneca> #action explore weblate and git-svn bridge more closely
19:02:26 <filip_> it would be nice if svn workflow (not comfortable but safe one) would be in our wiki as well
19:02:37 <obgr_seneca> #action yurchor write up some workflow for using indifex more closely
19:02:52 <obgr_seneca> #action describe svn workflow in the wiki
19:02:57 <obgr_seneca> ok?
19:03:15 <yurchor> obgr_seneca: I'm going into vacation for a week. Can I write in about 6 days?
19:03:23 <obgr_seneca> yep
19:03:29 <yurchor> thanks.
19:03:35 <obgr_seneca> our next meeting would be at august 2nd
19:03:42 <obgr_seneca> can you do it till then?
19:03:50 <yurchor> Surely.
19:03:56 <Akien> I can write something about SVN workflow, but I would prefer to dedicate my time to www translation, so I'd be glad if someone else would step forward.
19:04:35 <obgr_seneca> filip_: could you? I can help you with it
19:05:03 <Qilaq> essentially it would be very similar to https://wiki.mageia.org/en/Packagers_svn ?
19:05:16 <obgr_seneca> yep
19:05:17 <filip_> I need some time for that decision
19:05:23 <obgr_seneca> ok
19:05:28 <obgr_seneca> just think about it
19:05:46 <obgr_seneca> Can you ping me in about a week?
19:05:52 <filip_> I prefer to help Akien with web pages translation
19:06:05 <obgr_seneca> ok
19:06:17 <filip_> Qilaq: what about you?
19:06:17 <obgr_seneca> I will try to not forget it then
19:06:57 * Akien finds that remmy has been pretty silent. :þ
19:07:13 * filip_ too
19:07:18 <obgr_seneca> we can always do an action for him :D
19:08:08 <Akien> I should be going... Set the action for me if no one is available for svn workflow, I should be able to do it quickly.
19:08:15 <Akien> See you :)
19:08:15 <Qilaq> hmm, I'm quite busy (deadline for book translation is getting nearer and nearer with unbelievable speed :-) ) but let's say if nobody doesn't write it in a week or so I can think about it :-)
19:08:39 <obgr_seneca> thx
19:09:12 <obgr_seneca> ok, can we end the meeting then?
19:09:38 <filip_> great to start it and great to end it ;)
19:10:03 <obgr_seneca> #endmeeting