17:37:39 <obgr_seneca> #startmeeting
17:37:39 <Inigo_Montoya> Meeting started Thu Jun 28 17:37:39 2012 UTC.  The chair is obgr_seneca. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:37:39 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:37:47 <obgr_seneca> #chair Akien
17:37:47 <Inigo_Montoya> Current chairs: Akien obgr_seneca
17:38:04 <obgr_seneca> So, welcome to the i18n postmortem meeting for Mga2
17:38:40 <obgr_seneca> First of all, I see, we have some new people arround. Would you like to say a few words?
17:38:59 <obgr_seneca> Who you are, what language you are translating and so on?
17:39:07 <Oleg> yea
17:39:44 <obgr_seneca> Oleg: Go ahead
17:39:46 <Oleg> My name is Oleg, nickname - xxblx. I am from i18n-ru
17:39:53 <agron_sq_team> Hi, my name is Agron, I like to translate Mageia into Albanian
17:40:23 <obgr_seneca> Ok, so we have revived the ru team and we have an albanian one now
17:40:31 <Akien> \o/
17:40:32 <obgr_seneca> Welcome aboard
17:40:33 <filip_> nice to see new members
17:40:37 <Oleg> thx
17:40:49 * obgr_seneca has to look up the acronym for albanian though :D
17:40:56 <yurchor> sq
17:40:59 <agron_sq_team> sq
17:41:06 <obgr_seneca> ok, thx
17:41:15 <Akien> obgr_seneca: You could have guessed :p
17:41:24 <obgr_seneca> Who is JLP? I don't know the nickname...
17:41:37 <obgr_seneca> Akien: My chrystal ball is in repair
17:42:02 <Akien> We also have fwolff which represents the one-man team i18n-af (Afrikaans).
17:42:08 <yurchor> JLP is one of driving forces of KDE. ;)
17:42:33 <obgr_seneca> Ah, I see
17:42:41 <filip_> yes, I spoke to him as ex Slovenian translator in MDV
17:42:47 <obgr_seneca> agron_sq_team: Oleg: Did you enter your names here: https://wiki.mageia.org/en/I18n_teams
17:43:04 <Akien> I believe so.
17:43:12 <filip_> but he'll stay there for now until 4.9
17:43:19 <obgr_seneca> Yes, just saw both
17:43:45 <obgr_seneca> Ok
17:43:52 <obgr_seneca> #topic post mortem
17:43:56 <Oleg> yea, I already entered name to wiki page
17:44:06 <obgr_seneca> #link https://wiki.mageia.org/en/Mageia2_Postmortem#i18n
17:44:20 <obgr_seneca> I scanned the emails and entered the contents to that wiki page
17:44:39 <obgr_seneca> Let's do this in a bit of order
17:45:18 <obgr_seneca> I'd add a seperate topic for the online translation system
17:45:32 <obgr_seneca> So, does anyone have to add points to that list?
17:45:58 <Akien> Hi lebarhon :)
17:46:09 <lebarhon> Hi, sorry I'm late
17:46:17 <Akien> obgr_seneca: The lists is good, but we should go more in-depth about those points.
17:46:52 <obgr_seneca> ok
17:47:02 <obgr_seneca> so first the meetings
17:47:32 <obgr_seneca> filip_ did remark we should have more regular meetings
17:47:48 <obgr_seneca> And I concur, it was just hard to find the time for me
17:48:14 <filip_> but you're not alone ;)
17:48:19 <obgr_seneca> So, I propose again to have short biweekly meetings but perhaps at different times
17:48:29 <obgr_seneca> See the mail I just sent to i18n ml
17:49:04 <obgr_seneca> It is a bit unfair of us Europeans to choose the time that is best for us
17:49:15 <obgr_seneca> Comments about that?
17:49:51 <yurchor> Fedora makes two meetings: one for hemisphere.
17:50:07 <obgr_seneca> possible
17:50:08 <Akien> I think it would be good to have meeting at different times yes.
17:50:38 <Akien> Based on the results of the mail your sent to mageia-i18n we will know to what frequency.
17:50:42 <obgr_seneca> Either we go for that or we do one meeting in the European evening and one in the European morning
17:50:57 <obgr_seneca> I'd like to attend both, but I will have to see with my boss
17:51:50 <filip_> maybe another on weekend not usual working days?
17:51:59 <yurchor> We can have some half-coordinator for non-european regions, if there will be enough teams there.
17:52:27 <obgr_seneca> Could do too, I would wait for the result of my mail
17:52:37 <obgr_seneca> then we can decide on the further proceeding, ok?
17:52:45 <Akien> Yes.
17:52:59 <yurchor> yes.
17:53:03 <Oleg> UTC 17:30 is very convenient
17:53:30 <Oleg> because it's 21:53 in Moscow now
17:53:57 <obgr_seneca> it's ok for me, I am home between 16.30 UTC and 18 UTC but let's see, what people in UTC-x say...
17:54:02 <Oleg> so if metting will be start later, it will be at night for russians
17:54:54 <Akien> So we stay with 17.30 UTC for now, with a meeting every two weeks?
17:55:16 <obgr_seneca> I'd say so, we can always plan another one for the rest of the world in between
17:55:29 <Akien> Ok.
17:55:33 <filip_> ok for me
17:55:46 <Oleg> 17:30 UTC is ok for me too
17:56:10 <obgr_seneca> #agreed i18n meetings should happen every two weeks at 17.30 UTC, perhaps a second meeting for the Asians/Americans
17:56:16 <obgr_seneca> Next point?
17:56:19 <Akien> Ok.
17:57:13 <Qilaq> yep 17.30 or 20.30 for me is good enough - might be an hour earlier, though, but 17.30 is almos as same good
17:57:56 <obgr_seneca> So let's go to the next one
17:58:07 <obgr_seneca> svn change notifications
17:58:19 <obgr_seneca> Akien: Do you remember the bug number about it?
17:58:22 <Akien> https://bugs.mageia.org/show_bug.cgi?id=1095
17:58:25 <Akien> Always :)
17:58:44 <obgr_seneca> As a good deputy should :D
17:58:59 <Akien> This bug is release_critical, so it might get some attention.
17:59:19 <Akien> We just have to move it a bit more under the sysadmins noses.
17:59:25 <obgr_seneca> We should push it a bit more.
17:59:31 <obgr_seneca> It's important to have that
17:59:48 <obgr_seneca> Anyone ever done something like that here?
18:00:39 <Qilaq> sadly no - I just know pre- and postcommit hooks work in KDE but not in Mandriva/Mageia ...
18:00:53 <obgr_seneca> KDE does use git or svn?
18:01:03 <Qilaq> for translations svn
18:01:16 <obgr_seneca> Perhaps we can steal something there
18:01:20 <Akien> misc was investigating https://github.com/theory/svn-notify/
18:01:43 <obgr_seneca> #action obgr_seneca search for misc's code about those notifications and compare with KDE one
18:02:05 <obgr_seneca> #info Bug #1095 should be fixed (svn notifications)
18:02:06 <Qilaq> KDE is mostly in git now but translations are still in svn
18:02:16 <obgr_seneca> Ok, that's a starting point
18:02:27 <yurchor> obgr_seneca: KDE does not have notification either.
18:02:39 <obgr_seneca> ah, too sad
18:02:46 <filip_> Remco once send a script for svn checkout which I'm changing to see changed files in svn and to better organize myself.
18:03:21 <obgr_seneca> filip_: Could you put it in the wiki somewhere? In i18n section?
18:03:23 <filip_> I can try to notify by hand in the mean time
18:03:35 <Qilaq> well, that's not true - KDE has some postcommit hooks, at least when i do commit there will be send an email to Estonian list
18:03:38 <filip_> it's not fully tested yet
18:03:49 <filip_> but good idea
18:03:54 <obgr_seneca> We have some pre commit hooks in packaging
18:04:03 <obgr_seneca> so we should be able to find a way for us!
18:04:26 <Akien> That's another point which is not in the postmortem BTW.
18:04:38 <obgr_seneca> Akien: ?
18:04:38 <yurchor> Main DE projects have feeds of commits, which can be parsed in some way. But it is hard to find if developer commit something into i18n string.
18:04:38 <Akien> The precommit hooks don't work either (namely msgfmt -c)
18:04:54 <obgr_seneca> Ah yes
18:05:06 <obgr_seneca> #info also look into pre commit hooks (msgfmt)
18:05:17 <obgr_seneca> Next point?
18:05:20 <filip_> Akien: we should fill a bug report
18:05:31 <yurchor> What if we just recreate PO catalogs once for a month or a week?
18:05:36 <obgr_seneca> Yep
18:05:51 <filip_> more then 10 pot files don't pass it
18:06:12 <obgr_seneca> #action obgr_seneca file a bug report about not working pre-commit hooks
18:07:05 <obgr_seneca> #action report pot files not passing msgfmt to obgr_seneca
18:08:05 <obgr_seneca> (my girlfriend just opened a bottle of sparkling wine, she's half italian so she can't loose in tonight's match)
18:08:19 <Akien> :)
18:08:32 <Akien> You'll be fighting over it ;)
18:09:09 <Akien> Switching to the list of webpages topic?
18:09:11 <obgr_seneca> anything to add on those svn hooks?
18:10:03 <Akien> No.
18:10:06 <obgr_seneca> So let's go for the webpages?
18:10:27 <Oleg> how about teams without active commiters?
18:11:16 <obgr_seneca> Oleg: just send me or Akien an email
18:11:27 <obgr_seneca> our nicknames @mageia.org will do
18:11:45 <obgr_seneca> The same goes for agron_sq_team
18:11:54 <Oleg> okay, thx
18:12:04 <Akien> I have already added agron_sq_team to the commiters.
18:12:15 <Akien> The sysadmins promoted his account to POSIX account this morning.
18:12:35 <obgr_seneca> ok
18:12:45 <obgr_seneca> so for the web pages
18:12:46 <obgr_seneca> #action talk to atelier team about web pages
18:12:55 <obgr_seneca> I am not sure about the status there
18:13:09 <obgr_seneca> atelier should put a list somewhere and maintain it
18:13:12 <obgr_seneca> So we do know
18:13:21 <Akien> There is: http://www.mageia.org/langs/report.php
18:13:36 <Akien> Romain has been redesigning the translation system using .lang files.
18:13:50 <Akien> And his script to check the status of the different languages is quite useful.
18:13:59 <obgr_seneca> (FYI: atelier is the newly combined artwork marketing communication and web team)
18:14:10 <Akien> But he has not added more pages for a while, so I'll see with him what can be done.
18:14:42 <Akien> #action Akien will see with atelier team about generating more .lang files (see http://www.mageia.org/langs/report.php)
18:14:48 <obgr_seneca> #action Akien see with rda about web pages
18:14:54 <Akien> #undo
18:14:54 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x8434aac>
18:14:56 <Akien> :)
18:15:08 <obgr_seneca> :)
18:16:28 <obgr_seneca> Comments here? We can forward those to atelier team
18:16:55 <filip_> Akien: this is not yet prepared for translation: https://www.mageia.org/en/for-pc/
18:17:13 <Akien> Yes, actually only the pages listed on the report.php can be translated.
18:17:29 <Akien> I will see with rda if I can be of some help to generate those .lang files.
18:17:43 <Oleg> "page_title" at /for-pc/
18:18:35 <Akien> obgr_seneca: I think we should move on since we still have a few points on the agenda.
18:18:35 <obgr_seneca> Akien: do you collect those points?
18:18:46 <Akien> Yes.
18:19:03 <obgr_seneca> thx
18:19:09 <Akien> Actually if rda shows me how I can help with the website localisation I will proofread a bit all the content.
18:19:22 <Akien> He's been quite busy so it looks like www is on hold.
18:19:47 <obgr_seneca> ok next point: list of software to translate
18:20:23 <obgr_seneca> We have a list on the wiki
18:20:29 <Akien> Basically, we need to revamp and update https://wiki.mageia.org/en/List_of_Mageia_transifex_projects
18:20:32 <obgr_seneca> (Akien could you look it up?)
18:20:42 <obgr_seneca> Ha, you are fast
18:21:00 <obgr_seneca> #action obgr_seneca and Akien revamp and update https://wiki.mageia.org/en/List_of_Mageia_transifex_projects
18:21:01 <Akien> I have a search engine for Mageia's wiki :p
18:21:06 <obgr_seneca> :D
18:21:07 <filip_> I did :svn list -R svn://svn.mageia.org/svn/soft/ | grep .pot
18:21:18 <filip_> and noticed a few "new"
18:21:39 <obgr_seneca> filip_: Nixe, could you send it to the ml?
18:21:49 <obgr_seneca> s/Nixe/Nice/
18:22:02 <filip_> I will right now ;)
18:22:07 <obgr_seneca> Thx
18:22:36 <obgr_seneca> So for the last point of this topic: more coordination with other teams
18:23:21 <obgr_seneca> #action Do bug devs more about coordination
18:23:28 <Akien> This is a general statement but is quite important.
18:23:44 <Akien> I think that if we have SVN notifications it will be better with regards to dev team.
18:23:57 <obgr_seneca> Akien: You are doing some things in atelier iirc?
18:24:13 <Akien> We need to work more closely with Atelier, but it will be simpler now that it's only one team.
18:24:17 <obgr_seneca> Akien: we still need the to tell us about new pot files
18:24:38 <Akien> Indeed.
18:24:53 <obgr_seneca> #action obgr_seneca coordinate with doc, Akien coordinate with atelier
18:25:13 <Akien> Yes, that's what I was thinking about. We need one or two coordinators with a foot in each team.
18:25:32 <filip_> what about branched files?
18:25:43 <obgr_seneca> filip_: good point
18:25:58 <obgr_seneca> #info don't forget branched files, list them in wiki
18:26:04 <obgr_seneca> #undo
18:26:04 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x848250c>
18:26:09 <obgr_seneca> #info don't forget branched files, list them in the wiki
18:26:23 <Akien> What is the policy about branches?
18:26:26 <obgr_seneca> filip_: Or did you mean anything else?
18:26:38 <obgr_seneca> Akien: we have a branch for each released Mga version
18:26:58 <obgr_seneca> so at the moment there's trunk (cauldron) and one branch each for 1 and 2
18:27:04 <filip_> this is it!
18:27:07 <Akien> So, as long as the branch is supported, we push the changes to all branches?
18:27:20 <obgr_seneca> yep...
18:27:22 <filip_> but not everything is branched
18:27:34 <filip_> especially in 2
18:27:46 <obgr_seneca> filip_: can we look into that together in the next days?
18:28:03 <filip_> mga 1 is not in my reach ;)
18:28:10 <filip_> obgr_seneca: of course
18:28:14 <Akien> filip_: Yep branching is still undergoing. I saw dmorgan was branching rpm in the afternoon.
18:28:16 <obgr_seneca> ok
18:28:49 <obgr_seneca> anything to add on that topic?
18:29:10 <Akien> #agreed Whenever possible, we should commit changes to both trunk and the branches of the still supported releases (currently 1 and 2).
18:29:29 <obgr_seneca> (soccer starting in 16 minutes :D )
18:29:58 <Akien> We can move on.
18:30:23 <obgr_seneca> #topic web translation system
18:30:32 <obgr_seneca> So, we do have three options:
18:30:57 <obgr_seneca> revive transifex (install the current version and try to keep it running)
18:31:07 <obgr_seneca> use pootle or weblate as alternative
18:31:19 <obgr_seneca> use tx.net (like Fedora does)
18:31:49 <obgr_seneca> Since there is no really working vcs bridge for tx I don't prefer that
18:32:08 <obgr_seneca> So I would go for pootle or weblate
18:32:16 <obgr_seneca> but I did not really look into them
18:32:20 <obgr_seneca> did anyone?
18:32:21 <Qilaq> are they coworking with svn?
18:32:38 <filip_> I'm more on pootle but didn't invest much time in it
18:32:49 <obgr_seneca> Qilaq: weblate is working with a git repo and I asked one of the sysadmins who said, that could be done
18:32:57 <obgr_seneca> but I don't remember who it was
18:33:26 <filip_> obgr_seneca: I think that this is in past minutes already
18:33:30 <obgr_seneca> So could we agree to look into both in the next two weeks and summarize our findings for next meeting?
18:33:55 <obgr_seneca> I would investigate weblate further, I already did a bit there
18:33:56 <Akien> I would not advise to revive our instance of Tx, since it was mostly misc who had been working on it, and he's not part of the project anymore. I don't think the other sysadmins would like to debug it.
18:33:59 <Qilaq> that would be good - I'm not against committing manually after translatiing in web interface but if it could be avoided then I'm for it :-)
18:34:03 <obgr_seneca> anycone can look at pootle?
18:34:26 <Akien> I'd be willing but I will be away for two weeks, so I won't be efficent.
18:34:41 <yurchor> We now have fwolff (one of the pootle developers) it will be good to hear something from him in ml.
18:34:48 <filip_> http://translate.sourceforge.net/wiki/pootle/version_control : CVS Supported :)
18:34:52 <obgr_seneca> #action obgr_seneca look into weblate and summarize for the next meeting
18:35:00 <Akien> yurchor: That's great!
18:35:29 <obgr_seneca> #action ask fwolff about summarizing pootle for us
18:35:35 <obgr_seneca> Ok?
18:35:37 <Akien> It could be nice to find the minutes of previous meeting when we were talking our needs that Tx did not supply to.
18:35:48 <obgr_seneca> Akien: yes
18:35:55 <Akien> Like versioning system, discussion system and so on.
18:36:02 <obgr_seneca> #info look into last meeting minutes for tx flaws
18:36:04 <Akien> To have it in mind while testing other software.
18:36:41 <obgr_seneca> I can do the needed packaging for whatever we chose
18:36:45 <obgr_seneca> Comments?
18:36:57 <filip_> we need to remember that we need sysadmin and some translation admin also
18:37:29 <obgr_seneca> yep
18:38:17 <obgr_seneca> #info need to coordinate with sysadmins, have one translation admin for it
18:38:36 <obgr_seneca> filip_: anything against Akien and me filling the translation admin slot?
18:38:59 <filip_> you're my hero ;)
18:39:27 <obgr_seneca> thx
18:39:45 <obgr_seneca> more comments here?
18:40:04 <Akien> Yep
18:40:12 <Akien> The wiki needs to be rewritten a bit.
18:40:25 <obgr_seneca> #action Akien rewrite the wiki a bit
18:40:27 <obgr_seneca> :D
18:40:39 <Akien> For it is all about how to use Tx and all, so our new translators are a bit lost when we tell them "Have fun with Localise"
18:40:41 <filip_> we should remove tx as soon as possible from wiki
18:40:53 <obgr_seneca> yep, I agree
18:41:17 <Akien> I'll try to have a look at it in the next two days (I go on holidays on Sunday)
18:41:53 <Akien> If I don't have the time to do it I'll post about it on the ML saying that anyone who knows our current process could rework our pages a bit.
18:42:06 <obgr_seneca> Akien: you go on holiday while I have to work?
18:42:41 <Akien> Er, no, actually... I'll work in a manner which differs from the conceptual view we have of work :)
18:42:49 <filip_> we all work hard so we need holidays ;)
18:43:17 <obgr_seneca> :)
18:43:20 <obgr_seneca> I do know that
18:43:21 <Akien> My last "student" holidays (i.e. during more than 5 weeks ^^)
18:43:38 <obgr_seneca> so...
18:43:40 <obgr_seneca> #topic next meeting
18:43:53 <obgr_seneca> As we agreed on bi weekly meetings
18:44:05 <Akien> We should discuss about wiki translation on the next meeting.
18:44:20 <obgr_seneca> #info next meeting will be on Thursday July 12th at 17.30 UTC
18:44:34 <obgr_seneca> Akien: Yes, since I don't have a status right now
18:44:49 <obgr_seneca> #action obgr_seneca see with sysadmin and doc about wiki translation status
18:45:12 <obgr_seneca> There's an open bug about intra wiki links
18:45:22 <Akien> #info Please join the mageia-doc ML to discuss the new localised wikis and the translation processes.
18:45:27 <obgr_seneca> so we can link between the languages like it's done in Mdv
18:45:41 <obgr_seneca> or look into translation extension for mediawiki more closely
18:46:00 <Akien> Ok.
18:46:01 <obgr_seneca> Anything to add for tonight?
18:46:21 <Oleg> like wiki.mageia.org/en/ wiki.mageia.org/ru/ etc?
18:46:31 <Akien> That's fine by me, QA meeting in 15 min :)
18:46:34 <obgr_seneca> Oleg: yes
18:46:49 <obgr_seneca> right now we have /en/ and /de/ (as a test instance)
18:46:54 <Oleg> it will be best solution as i think
18:47:15 <obgr_seneca> but we can't easily link between those two and we need a formal translation process
18:47:31 <obgr_seneca> ok then...
18:47:40 <obgr_seneca> #endmeeting