17:35:04 <obgr_seneca> #startmeeting
17:35:04 <Inigo_Montoya`> Meeting started Thu Apr 12 17:35:04 2012 UTC.  The chair is obgr_seneca. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:35:04 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:35:11 <obgr_seneca> #chair Akien
17:35:11 <Inigo_Montoya`> Current chairs: Akien obgr_seneca
17:35:23 <obgr_seneca> Welcome to i18n meeting
17:35:51 <obgr_seneca> First let me excuse, I actually wanted to keep a two week rhythm, but things didn't work that way
17:36:03 <obgr_seneca> Release hell is starting early this year
17:36:27 <filip_k> and it's burning hot ;)
17:36:35 <obgr_seneca> yep ;)
17:36:56 <obgr_seneca> Ok, out topics for tonight:
17:37:01 <obgr_seneca> - team status
17:37:26 <obgr_seneca> - website translations
17:37:37 <obgr_seneca> - doc translations
17:37:40 <obgr_seneca> - other
17:38:03 <obgr_seneca> #topic team status
17:38:50 <obgr_seneca> so, avtually we are doing quite fine
17:39:30 <obgr_seneca> we do have the same problems as before, we need more languages
17:39:57 <obgr_seneca> but that can only be solved in time
17:40:04 <yurchor> Ukrainian is the same as in Qilaq report. Moreover, month ago I've sent a letter to Damien (one guy wanted to translate blog) but have no response so far.
17:40:10 <obgr_seneca> if you have ideas about it, tell me
17:40:37 <obgr_seneca> yurchor: please send it to me
17:40:41 <obgr_seneca> I will look after it
17:41:03 <yurchor> Ok. No plans to translate docs, as pure Calenca translations is just a waste of time.
17:41:09 <dglent_> Hi all, yes from Greek team is a little difficult, we are missing some persons, but the status is not very away from being complete
17:41:36 <obgr_seneca> Akien: how is french team going?
17:41:36 <filip_k> hi dglent_
17:41:36 <Akien> I guess we can suggest to marcom a nice blog post about contributing to the community a week after Mageia 2's release, with a word about i18n.
17:41:53 <Akien> French team is efficient when it comes to blog translation.
17:42:06 <Akien> They manage to work even when I'm not around, so that's great :D
17:42:39 <Akien> When it comes to string translation, there wasn't much to do so I did most of it, I didn't bother to organise the work for a dozen strings.
17:43:01 <dglent_> I did nt understand why the Greek web page have 3-4 untranslated pages, while i show these translations in the mailing list already sent
17:43:06 <obgr_seneca> German team has gone a bit quiet, people are helping when called, but I have to call loud every time
17:43:07 <Akien> There may still be a bit of work though, I noticed a few mails about changes in some pot files and didn't have the time to catch up.
17:43:13 <dglent_> No, sorry, in the Greek ml not in the i18
17:44:01 <obgr_seneca> Ok, whoever reads this log has to sort it :)
17:44:54 <obgr_seneca> any more on team status?
17:45:21 <filip_k> As I'm still alone in Slovenian team web site and blog are low priority but SW is 100% proofread what is on TX
17:45:24 <dglent_> I see that for the Greek version the missing pages are: http://www.mageia.org/el/2/ http://www.mageia.org/el/support/ http://www.mageia.org/el/contribute/ http://www.mageia.org/el/about/
17:45:38 <obgr_seneca> #topic website translations
17:45:48 <dglent_> and 3-4 articles from the blog
17:46:32 <obgr_seneca> ok, about missing translations on website:
17:46:38 <yurchor> obgr_seneca: PHP arrays again?
17:46:45 <obgr_seneca> I noticed, rda did add some strings
17:47:02 <obgr_seneca> I will sort them out and send an email about it
17:47:08 <obgr_seneca> yurchor: I'm afraid so
17:47:34 <obgr_seneca> I would have preferred some pot/po file solution, but you know how it is?
17:47:42 <obgr_seneca> Never enough time...
17:48:49 <filip_k> is there already any tool to "transform" php strings to po files?
17:49:16 <obgr_seneca> But as I told in the ml, marketing is working on texts for the release and romain is working on a redesign of the website
17:49:17 <yurchor> I do not know what the source is. If the pages are constructed as PH arrays loaders, then I can write a Python script toconvert PO <->PHP
17:49:29 <yurchor> *PHP arrays
17:49:43 <obgr_seneca> yurchor: that would be great
17:49:55 <obgr_seneca> you can see how it's done in svn
17:50:09 <yurchor> Ok I will try.
17:50:39 <obgr_seneca> e.g. here: http://svnweb.mageia.org/web/www/trunk/en/contribute/
17:51:33 <obgr_seneca> but coming back to what I wanted to say
17:51:34 <dglent_> I have two pages translated (contribute.php and support.php) i will send them to the i18 ml , right ?
17:51:45 <obgr_seneca> dglent_: yes
17:51:59 <obgr_seneca> #info marketing has promised
17:52:22 <obgr_seneca> #info to have the texts ready at April 23rd
17:52:48 <obgr_seneca> we have three weeks time for the translation then since the release was pushed back to May 15th
17:52:55 <obgr_seneca> Ok?
17:53:20 <dglent_> what is the size of these translations ?
17:53:39 <obgr_seneca> will be about two or three web pages
17:53:50 <dglent_> is about the help text during installation right ?
17:53:55 <dglent_> ok
17:54:05 <obgr_seneca> Trish (marketing team leader) wanted to have first drafts on monday, I can tell you more then
17:54:18 <obgr_seneca> dglent_: no, website
17:54:35 <obgr_seneca> dglent_: we are coming to doc texts next topic
17:55:08 <obgr_seneca> so next topic?
17:55:15 <Akien> Ok
17:55:51 <obgr_seneca> #topic doc texts translation
17:56:10 <obgr_seneca> As I told you in the ml, doc team asks for translators
17:56:32 <obgr_seneca> The work is done in a platform called calenco provided by neodoc
17:57:06 <obgr_seneca> Questions about it are best asked on doc ml or you ask JohnR directly
17:57:16 <yurchor> This platform has no tools for translation. It's even worser that Rosetta.
17:57:16 <obgr_seneca> I gave you his mail address in the ml
17:57:29 <obgr_seneca> yurchor: I don't know it
17:58:22 <obgr_seneca> I myself would have waited till after Mga2 and done translations right then
17:58:31 <yurchor> It's better wait them to finish then convert xml to po with po4a.
17:58:44 <obgr_seneca> But doc team (especially John) wanted me to ask you now
17:59:16 <obgr_seneca> yurchor: perhaps yes
17:59:18 <yurchor> Thanks him for the ask.
18:00:06 <obgr_seneca> I'll do
18:01:05 <yurchor> okapitools (plugin to WebDAV) can handle the translations, but I think it does not worth to install and maintain it now.
18:01:10 <obgr_seneca> ok more questions about it?
18:01:26 <dglent_> The 15 May is definitive, or maybe the mga 2 release might be repushed ? Because i see many things to do with stress the last time
18:02:04 <dglent_> or i dont have to stress ... :)
18:02:16 <obgr_seneca> dglent_: we don't really want to push it further
18:02:21 <obgr_seneca> This has two reasons
18:02:53 <obgr_seneca> First: when pushing the release again and again, we might get bad press about it
18:03:30 <obgr_seneca> Although the comments in the blog were all rather positive, I read some ugly comments about Fedora pushing their release...
18:03:44 <yurchor> I think, Debian was never afraid by the first reason. ;)
18:03:50 <obgr_seneca> The second is:
18:04:28 <obgr_seneca> There's LinuxTag in Berlin from May 23rd till May 26th and since it's one of the largest European events it would be good to have Mga 2 then
18:05:05 <obgr_seneca> As I see it, we won't release, when there are still release blocking bugs arround, but we try
18:05:56 <obgr_seneca> yurchor: debian was never afraid of anything, but they target another audience then us
18:06:30 <dglent_> It is marketing :D
18:06:40 <obgr_seneca> yep
18:06:58 <filip_k> not only that, it's also a reputation
18:07:01 <yurchor> obgr_seneca: So, after the Kubuntu release with so many prominent bugs, it will be definitely success. ;)
18:07:09 <obgr_seneca> :D
18:07:30 <obgr_seneca> *buntu has driven itself in a mess with its all too fixed release dates I think
18:08:11 <filip_k> Mandriva was famous with some "Vista" releases. I hope and believe that we're different.
18:08:26 <obgr_seneca> filip_k: /me too
18:08:32 <dglent_> i hope too ....
18:08:48 <dglent_> please keep the mandrake philosophy
18:09:03 <obgr_seneca> I am confident, we can release a stable distro and if we can't keep the 15th then we won't...
18:09:36 <obgr_seneca> but I would hate to explain to visitors, other projects and people from the press in Berlin, that we couldn't make it
18:09:37 <dglent_> i am sure that will release the 15th
18:09:41 <obgr_seneca> We will see
18:09:44 <filip_k> please back on topic
18:09:49 <obgr_seneca> yes
18:10:17 <obgr_seneca> Are there questions about the doc texts?
18:10:35 <dglent_> wait
18:10:45 <dglent_> the doc texts in installer ?
18:10:49 <dglent_> sorry i confuse
18:11:14 <yurchor> There will be no text in the installer, just links to Calenca.
18:11:28 <Akien> Well, in the end, is it worth to start translating the work in progress, or should we wait some more?
18:11:29 <obgr_seneca> dglent_: yes, the files in Calenco are used to create the help texts in the installer as well as a full html documentation
18:11:55 <Akien> And can we hope that a translation-friendly tool will be set up?
18:11:58 <dglent_> ah ok, i dont have a clear image in my mind for what it consist yet
18:12:05 <Akien> Like the pages turned into pot files, or whatever.
18:12:09 <obgr_seneca> Calenco works using xml files and those can be converted into many other formats
18:12:22 <obgr_seneca> You can have a look at them in beta3
18:12:31 <Akien> I don't mind working on a work-in-progress if it's in a pot file: the changes are easily spotted.
18:12:53 <yurchor> No pot files.
18:12:53 <obgr_seneca> Akien: I will ask for it
18:13:25 <yurchor> It's truncated version of commercial tool.
18:13:32 <Akien> yurchor: It can be another means of translating; we just need it to be efficient and editing-friendly.
18:13:46 <Akien> yurchor: What do you mean?
18:14:17 <dglent_> if it is like transiflex ... i did nt like it at all
18:14:22 <yurchor> Calenco has commercial version with full fledged goodies, but it's a free one.
18:14:44 <obgr_seneca> actually we are working on the full version directly on neodoc servers
18:14:53 <yurchor> A-ah...
18:14:56 <obgr_seneca> neodoc has kindly offered us to use it
18:15:38 <yurchor> Then sorry for my mistake.
18:16:17 <yurchor> dglent_: It's not like Transifex, it's rather Zanata.
18:16:51 <dglent_> i have to be informed because i dont know zanata either , sorry :(
18:17:07 <obgr_seneca> but as I said, best ask doc ml or JohnR
18:17:42 <dglent_> me its ok i already asked, i'm waiting for instructions
18:17:45 <yurchor> dglent_ have already done this in their ml. No response so far, right?
18:18:17 <yurchor> General instructions are here: https://wiki.mageia.org/en/Mageia_Calenco
18:18:34 <dglent_> no but in mageia-doc told me i will be contacted soon
18:19:19 <yurchor> dglent_: So theu have no general instructions?
18:19:21 <obgr_seneca> Well, JohnR is living in New Zealand, so he might not answer instantly but half a day later
18:19:56 <dglent_> yurchor: no as i know
18:20:32 <obgr_seneca> ok, can we go on?
18:20:40 <dglent_> ok
18:20:42 <Akien> Yes
18:20:46 <yurchor> yes
18:21:29 <obgr_seneca> #topic other
18:22:03 <obgr_seneca> Ok, I'd like you to ask to keep looking for tx replacement
18:22:19 <dglent_> svn
18:22:21 <dglent_> :)
18:22:34 <obgr_seneca> Either using svn directly or use pootle or something else
18:22:53 <obgr_seneca> We will discuss it
18:23:00 <yurchor> Weblate: http://weblate.org/ looks promising.
18:23:05 <obgr_seneca> But I'd like to do that after the release...
18:23:31 <obgr_seneca> #action everybody consider a replacement for tx
18:23:54 <dglent_> for my experience tx was like dropbox
18:24:31 <dglent_> i stopped use it very soon, and i feel comfortable with svn, where i can track changes etc
18:24:36 * obgr_seneca has never used dropbox :)
18:25:03 <dglent_> i mean a depot of files , not something special for translations
18:25:33 <dglent_> with no features, except a control while uploading of the po file
18:25:59 <dglent_> with svn we know what happens
18:26:24 <dglent_> what is changed, when , who ...
18:26:31 <obgr_seneca> dglent_: as I said, we will discuss it
18:26:39 <dglent_> ok
18:28:02 <filip_k> I have a question: will beta3 have updated po files at least the one recently changed?
18:28:15 <obgr_seneca> But if it's ok with you, we'll discuss it after Mga2 release
18:28:34 <obgr_seneca> filip_k: As far as I know the drakxtools and the installer have been rebuilt, yes
18:29:07 <filip_k> obgr_seneca: yes, after release is realistic ;)
18:29:12 <dglent_> for me, as i can use svn, i have no problem for other usages, and new translation plattforms
18:30:45 <filip_k> I hope that mageia-gfxboot-theme is updated too. it was older then december in m2b2. We'll see that soon :).
18:31:13 <obgr_seneca> ennael did work on gfxboot in the last days, so yes, I think so
18:31:33 <dglent_> what about the translation of the wiki ? (or we discuss it another time)
18:32:21 <obgr_seneca> I'd rather discuss it another time
18:32:29 <dglent_> ok
18:33:05 <obgr_seneca> anything else?
18:33:14 <yurchor> no
18:33:20 <dglent_> no
18:33:42 <filip_k> no
18:33:45 <Akien> no
18:34:06 <filip_k> only this: when is next meeting?
18:34:14 <Akien> (Sorry I didn't talk much, I was reading the ~300 mails I received lately.
18:34:26 <obgr_seneca> one more information from me:
18:34:48 <obgr_seneca> I'm very busy with the release right now, hell started early this time
18:35:06 <obgr_seneca> that's why I'm trying to push things to after release when possible
18:35:34 <obgr_seneca> about next meeting: I'd say in two weeks, ok?
18:35:43 <yurchor> ok
18:35:47 <Akien> Ok
18:35:49 <dglent_> ok
18:35:59 <obgr_seneca> Then thank you for being here!
18:36:07 <filip_k> thank you obgr_seneca
18:36:07 <obgr_seneca> 'endmeeting
18:36:11 <dglent_> and no stress Oliver everything will be done fine
18:36:14 <obgr_seneca> #endmeeting