17:32:46 <Akien> #startmeeting
17:32:46 <Inigo_Montoya> Meeting started Thu Jun 16 17:32:46 2011 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:32:46 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:32:52 <Akien> #chair TeeAge
17:32:52 <Inigo_Montoya> Current chairs: Akien TeeAge
17:32:55 <Akien> #chair TeaAge
17:32:55 <Inigo_Montoya> Current chairs: Akien TeaAge TeeAge
17:33:09 <TeaAge> :)
17:33:12 <Akien> Okay, there's a non existant person as a chairman, alright.
17:33:15 <Akien> #chair TeeAge
17:33:15 <Inigo_Montoya> Current chairs: Akien TeaAge TeeAge
17:33:19 <Akien> #unchair TeeAge
17:33:19 <Inigo_Montoya> Current chairs: Akien TeaAge
17:33:22 <Akien> ah :)
17:33:26 <Remmy> Sweet, lol
17:34:00 <Akien> So, today's meeting will be about software localisation, and specifically the part Tx plays in it.
17:34:16 <Akien> Unless you have other things to discuss, this will be the only topic.
17:34:25 <Akien> But it should be a tough one.
17:34:51 * Akien searches for his notes...
17:35:00 <TeaAge> depends on how many people are really present here ^^
17:35:08 <Akien> Okay, let's improvise.
17:35:18 <Remmy> Three plus a bot it seems.
17:35:28 <Qilaq> I'll be, at least half of me :-)
17:35:29 <Akien> Do we ping everyone?
17:35:31 <MrBarman> i'm here also
17:35:36 <Akien> ah nice
17:35:37 <filip_> me to
17:35:39 <Remmy> 5 then, sorry guys :)
17:35:40 <Remmy> 6
17:35:44 <TeaAge> cool
17:35:54 <Akien> My my, it's improving exponentially.
17:36:13 <Akien> #topic Debriefing: string translation with Transifex.
17:36:21 <Akien> Hi pasmatt
17:36:35 <Akien> We're just starting the debriefing about Tx
17:36:38 <pasmatt> Hi Akien
17:37:02 <Akien> So, we used Tx for a while, and we now have some experience with it.
17:37:28 <Akien> It would be nice to discuss what should be the general process for string translation, preferably using Tx.
17:37:58 <TeaAge> I think the current process worked very well
17:38:05 <Remmy> For me it has worked fine so far, but then again, it's been only me and I haven't experienced using it together with others.
17:38:19 <Qilaq> I'd like to say that after initial triubles Tx worked very well (that translator's credits issue aside)
17:38:22 <MrBarman> me too, for a one man team works fine
17:38:51 <filip_> i had some troubles with accepting files from svn
17:39:09 <Qilaq> now, I've read, this credits issue is also resolved, so future seems to be bright one :-)
17:39:13 <Remmy> I think it would be perfect though with a few more features: Integration with svn (possible at all?), the possibility to see which project needs work instead of going through them one by one
17:39:20 <Akien> #info Issue: Translation credits are erased (is or will be corrected upstream IIRC)
17:39:21 <filip_> similar than in email todaytoday
17:39:32 <Remmy> and the credits fix of course
17:39:57 <TeaAge> Remmy: you can see all projects in an overview
17:40:12 <filip_> i solved it by spliting file
17:40:19 <filip_> one part worked
17:40:38 <filip_> and later I splited non working one
17:40:47 <Remmy> TeaAge: Ah, must have overlooked that then
17:40:47 <Akien> filip_: That's strange, I never had an issue with uploading files.
17:40:57 <filip_> so it is down to few string
17:41:04 <filip_> nothing unusal
17:41:12 <filip_> i can send them
17:41:22 <Remmy> I wouldn't be opposed to have .po files for the website too and use transifex for them
17:41:26 <filip_> or should I report upstream
17:41:59 <MrBarman> filip: what error do you get?
17:42:00 <Remmy> filip_: Unless someone beats me to it, I want to look into your files from your mail and figure out why it won't take them
17:42:05 <TeaAge> Remmy: https://transifex.mageia.org/projects/p/mageia_i18n/r/mga1/
17:42:12 <Akien> filip_: I saw you send us your files on the ML IIRC, I'll try to upload one of those to see what the problem is.
17:42:13 <TeaAge> https://transifex.mageia.org/projects/p/mageia_i18n/r/mga1/l/nl/
17:42:24 <filip_> email was not mine
17:42:36 <filip_> but I think similar problem
17:42:37 <Akien> Remmy: If you have the time to do it before me, I won't be angry at you :p
17:43:06 <Remmy> filip_: Ah, ok... can you put your files somewhere too, or perhaps mail them to me? remco@webconquest.com
17:43:36 <Remmy> Might not get to it till saturday though, just so you know.
17:43:42 <Akien> #info We should look into synchronisation between SVN and Tx.
17:43:54 <Remmy> TeaAge: Thanks, very useful link :)
17:44:18 <filip_> will email then
17:44:26 <Remmy> Merci
17:44:27 <Akien> The general feeling we have on the French team is that Tx is useful (that's already something :p), for it centralises our work.
17:44:55 <Akien> It is simpler to use Tx than to send our translations via emails so that others can proofread them.
17:44:57 <filip_> i miss some comment section
17:45:03 <Akien> filip_: true.
17:45:17 <Akien> It has no feature for proofreading.
17:45:37 <TeaAge> Does someone know the whole release management is solved? I mean what if we want to fix an translation issue in a stable release. Should we have to do that onlx via SVN or will there be a ressource a transifex for cauldron and every release?
17:46:20 <Akien> TeaAge: I don't know, but this is an interesting question.
17:46:25 <Remmy> Proofreading would be useful. Especially if one could see what strings were changed since a given date
17:46:53 <Qilaq> Yeah, by now Tx has only suggestions, not whatever kind of comments
17:47:25 <Akien> Suggestions can be used for proofreading comments, but they really are not a good solution.
17:47:39 <Akien> There is no way to browse through strings which have an attached suggestion.
17:47:52 <Akien> So you have to look at each string individually to see if there is a comment.
17:48:01 <TeaAge> yeah proffreading is very stressful
17:48:19 <Akien> That's something Tx lacks, and it is really annoying.
17:48:26 <Remmy> A sort of built in diff function would be awesome
17:48:37 <TeaAge> Oliver and me (as the commiters of the german team) are proofreading every string before we commit (and it was really needed to do)
17:48:46 <Remmy> I think tx works for us, is of use, but some improvements would make it several times more powerful to us
17:48:56 <Akien> TeaAge: But how did you do it with Tx?
17:49:00 <Qilaq> I cannot to check it myself but the possibility to show translations by users - is it only for translations itself of for suggestions, too?
17:49:19 <filip_> more verbose error on rejecting files would be useful
17:49:28 <Akien> There is no way to know which strings were modified at a given time.
17:49:41 <TeaAge> Akien: we didn't checked only the modified string but really all strings (one by one)
17:50:08 <Akien> Hum... And if an already commited file was modified on Tx, you rechecked everything?
17:50:10 <Remmy> filip_: Aye, I second that. It would be nice to see what makes it err out.
17:50:33 <TeaAge> but it's also possible to download and do an diff with the latest SVN version
17:50:52 <Remmy> Akien: In that case I'd diff the two files
17:50:55 <Qilaq> Well, there is: if you click on Details you can see who and when translated the string
17:50:56 <Akien> TeaAge: BTW, if you have some #info, #action or #agreed to post, don't hesitate. I may miss some important things.
17:51:15 <Akien> Qilaq: could you provide a URL?
17:51:20 <Qilaq> e.g. Last Translation: 2 months, 2 weeks by mareklaane
17:51:36 <Akien> Hum yes, but you don't have the details.
17:51:43 <Akien> You don't know what was modified in the file.
17:52:06 <Qilaq> you open file for translation and there is by every string little tab Details
17:52:41 <Akien> #info Issue: No features for proofreading (no proper comment system – there are "suggestions", but it is hard to browse through those; no string indexation with numbers for reference)
17:52:41 <Qilaq> yeah, that's right, you have no idea what was modified
17:52:52 <filip_> diff in svn is very useful. it would be nice to have something like that
17:53:29 <Akien> We can do manual diffs yes. But the issue is that most translators don't know SVN or how to make a diff, so it would be great to have something like that in Tx.
17:53:56 <Akien> #info Nice to have: diffs between different versions, to ease proofreading.
17:54:15 <TeaAge> yeah, that would be really great
17:55:00 <Akien> (Go on, I'm on the phone :S)
17:55:21 <Remmy> Sister calling your already eh?
17:56:05 <Qilaq> Iõ've read Mandriva will move translation to Tx, too, and their plan is to make traffic between SVN and Tx almost automatic, i.e. it's responsibility of translation leader (or was it even automatically?) to transfer files from Tx to SVN, not the translation teams resposibility
17:56:34 <Remmy> Given our comments here, will they be taken upstream, or are we supposed to come up with our own patches for these things (if we even have the needed skills in our team for that) ?
17:57:16 <TeaAge> before string are going to the SVN, they have to be proofreaded ... so it shouldn't be automatic
17:57:25 <TeaAge> at least not complete automatic
17:58:28 <Akien> I'm back, sorry.
17:58:34 <Qilaq> well, of course, but if it is automated, there is no difference when you translate or proofread - in any case your modifications will be in SVN, too
17:58:54 <Akien> I think it should be at least one-way
17:59:08 <Akien> I mean, things which are modified on the SVN should be forwarded to Tx
17:59:18 <Akien> But not necessarily the other way.
17:59:27 <filip_> +1
17:59:31 <Remmy> Qilaq: I think TeaAge means you don't want last minute fixes / breakages end up in the release without the language coordinator signing off on it
17:59:50 <Akien> It's not too big a deal to download our files and to commit to Tx when we are a commiter
18:00:00 <Qilaq> Mandriva has chosen other way: Tx is primary, no SVN anymore for translators (or at least it's a rule)
18:00:27 <TeaAge> #info Issue: How do we handle releases and trunk on TX (one ressource for every release?)?
18:00:36 <Akien> But it is really annoying when .pot files change on the SVN, because Oliver should update the .pot file on Tx and make sure no translations are lost.
18:01:18 <TeaAge> I think this should be handled by a script, so Oliver hasn't to take care of pot changes
18:01:29 <Akien> Yes, that would be really great.
18:01:45 <Remmy> Yes, then he has more time free to argue with Ze :)
18:01:50 <Akien> :D
18:02:03 <TeaAge> :D
18:02:16 <Akien> It should be easy to script something which updates the .pot file when there is a change on the SVN.
18:02:24 <Akien> But what can be done about lost translations?
18:02:47 <Akien> e.g. when a given string changes in the .pot file, Tx erases the corresponding translation in every .po file.
18:03:19 <TeaAge> would be better if TX shifts them as a suggestion
18:03:26 <Qilaq> couldn't it be done with msgmerge?
18:03:29 <Akien> So every translator has to translate again what was possibly already correct (if it was a typo which was corrected in the .pot file).
18:04:03 <Akien> Qilaq: I don't have much experience with .po translation, so I don't know how msgmerge works, but if that's possible that would be great.
18:04:19 <Remmy> Then tx should provide a way to handle 'fuzzy' strings too
18:04:56 <TeaAge> I think it would be great if, everytime a .pot-file has changed, a automated mail to the i18-list will be send which lists the changed file and the appropriate string
18:05:09 <Remmy> TeaAge: Agreed
18:05:27 <Qilaq> yeha, that may be remedy for Tx's incapabilities :-)
18:05:58 <Akien> #agreed SVN modifications should be automatically forwarded to Tx (update of .pot files, etc.). On the contrary, commits should not be automatic.
18:06:21 <Akien> TeaAge: +1
18:06:50 <Akien> Yeah, I suppose we could extract the modified strings with a diff to send a mail.
18:07:02 <Remmy> Our wishes for tx almost turn into a bigger task than building a Mageia release :)
18:07:10 <Akien> :)
18:07:25 <Akien> Remmy: about your question on wether we should patch Tx or report upstream, I don't know.
18:07:53 <Akien> It would be better that Tx is fixed upstream, for what we want is not particular to Mageia.
18:08:02 <filip_> +1
18:08:02 <TeaAge> do we have the knowledge and skills to patch tx on our own?
18:08:06 <Akien> Every project needs means to ease proofreading.
18:08:08 <Qilaq> about msgmerge: http://www.gnu.org/s/hello/manual/gettext/msgmerge-Invocation.html
18:08:13 <Akien> SVN automation is more specific, though.
18:08:29 <Akien> TeaAge: I don't... :/
18:08:53 <Remmy> Me either, but it'll be an interesting study project
18:09:01 <Remmy> Now to win the lottery and quit my daytime job...
18:09:02 <TeaAge> small Mageia-specific changes maybe can handled by us (the mageia devs)
18:09:05 <Akien> Qilaq: Thanks, I'll have a look at it.
18:09:15 <TeaAge> global changes should be made upstream
18:09:21 <Akien> Yep
18:09:30 <TeaAge> but of course we can create patches and send them upstream
18:10:04 <Akien> Maybe we could list again our grievances which should be addressed upstream?
18:10:29 <Akien> I'll write #actions for them so that we created tickets on Tx's trac.
18:10:35 <Akien> s/created/create/
18:10:46 <Akien> There is:
18:11:05 <Remmy> That would be useful... but it would also be nice if we are able to contribute in some way too, so it doesn't turn into an all demand thing.
18:11:18 <Akien> Remmy: That's right.
18:11:29 <Akien> - string indexation
18:11:56 <Akien> - browsable suggestions (no real need to implement comments if suggestions are already there, but they are hard to use for now)
18:13:03 <Akien> SVN automation is Mageia specific, so it should not be addressed to Tx (and it would be a really demanding request)
18:13:24 <filip_> comments are useful for noting what's need to be done
18:13:37 <Akien> - 'fuzzy' strings handling
18:13:46 <TeaAge> what about .pot-file modification
18:14:35 <Akien> TeaAge: What should we propose?
18:14:47 <Akien> filip_: I didn't get the meaning of your last sentence.
18:15:00 <filip_> like a kind of bookmark
18:15:18 <TeaAge> - mark translations as fuzzy if a string in the .pot-file has been changed
18:15:22 <filip_> or if I dont have time right now
18:15:30 <TeaAge> fuzzy/sugestions
18:15:44 <Remmy> - diff functionality
18:15:49 <filip_> but I know what needs to be done
18:16:10 <Akien> filip_: ah okay I get it. I read "for nothing" on your first sentence, so it meant nothing :p But with "noting" I get it ^^
18:16:43 <Akien> filip_: I agree, but there is no way to find a string which has a comment without looking individually at each string.
18:16:56 <filip_> exactly
18:16:57 <Akien> There should be a search function for strings with comments.
18:17:13 <filip_> I mean separate comment
18:17:29 <Akien> filip_: Where do you put those?
18:17:43 <filip_> now nowhere ;)
18:18:07 <Remmy> heh, .po files do allow comments on entries though, so would be nice if we had that in tx and easily accessible
18:18:13 <filip_> but they would be useful
18:18:30 <Akien> In the French team, we used to wiki as a tool for proofreading.
18:18:58 <Akien> For each project, we had a table listing: English string / Current translation / New translation / Comments
18:19:28 <Akien> It helped when some translations had to be reviewed, but that was suboptimal.
18:19:29 <Remmy> Akien: Sounds like an excellent feature to have in tx :)
18:19:35 <Akien> Remmy: exactly.
18:20:13 <Akien> Plus, it gave me a lot of job because some translators did modify the strings on Tx, but put every possible modification on the Wiki page.
18:20:14 <Qilaq> Akien, wiki is nice but really usable only for bigger teams because it needs probably quite a lot work...
18:20:28 <Akien> So I had to edit the files on Tx to implement the suggestions, it took me some time.
18:20:50 <Akien> But it was more a problem of communication, the translators didn't really know they had the right to modify the strings without asking me :)
18:21:20 <TeaAge> Remmy: "comments" in TX are accessible via details, but we can't modify or add them
18:21:30 <Akien> That's right.
18:21:57 <TeaAge> so, probably would be nice to add comments in the details section in tx
18:22:07 <filip_> we don't see them also if we dont click them explictly
18:22:27 <filip_> some kind of tag woul be nice
18:22:27 <TeaAge> yep
18:23:16 <TeaAge> a lot of wishes, we have
18:23:21 <filip_> a mark if comment or sugestion is present
18:23:48 <Akien> Yes, but we should also check on the live instance of upstream Tx if some of our needs aren't already implemented.
18:23:51 <Remmy> Akien: Time for you to get going :)
18:24:19 <Akien> For example, I saw that you could start discussion threads on the projects.
18:24:34 <TeaAge> right
18:24:45 <Akien> It could be useful to have something like that in each project, where we could say "I reviewed the 300 first strings", etc.
18:25:00 <Akien> It would be better to have it right on Tx than on a wiki or the ML.
18:25:11 <Remmy> yup
18:25:18 <Akien> So that before you start translating, you check this file.
18:25:19 <TeaAge> yeah, we are doing that in the wiki for the moment, would be nice to have that in tx
18:26:00 <Akien> So, before sending our request to Tx upstream, we should browse their live instance and maybe ask the sysadmins that our Tx is updated.
18:26:31 <Akien> Remmy: You're right, I'm putting my shoes on :p
18:27:15 <TeaAge> enjoy the concert and send our regards to your sister :)
18:27:18 <Akien> I suggest that we send a mail on i18n which recapitulates all our wishes.
18:27:32 <Akien> Then we could add some more, or discussing some of them.
18:27:51 <Akien> And we should compare our Tx to the upstream Tx before requesting new features.
18:27:52 <filip_> and put them in wiki
18:28:14 <Remmy> Yup
18:28:16 <TeaAge> #action Send our wishes to the i18n list, for further discussions
18:28:23 <Remmy> Check their feature list and bug tracker
18:28:36 <Akien> And when we've discussed enough, we will create some tickets on their Trac.
18:28:50 <Akien> Yep, it's highly probable some of those features are being added right now :)
18:29:12 <Akien> (Or waiting for a contributor to add those, with a bug report untouched for a few months :p)
18:29:34 <Akien> Well, I'm going, I'll let you finish the meeting.
18:29:37 <Akien> See you :)
18:29:40 <TeaAge> cu
18:30:29 <TeaAge> does someone wants to summarize our wishes for the mailinglist?
18:31:23 <TeaAge> hmm I see ...
18:31:26 <Remmy> lol
18:31:32 <pasmatt> :)
18:31:34 <Remmy> I will volunteer if it can wait till sat?
18:31:43 <TeaAge> for sure
18:32:12 <TeaAge> #undo
18:32:12 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x82cb0ec>
18:32:26 <TeaAge> #action Remmy will send our wishes to the i18n list, for further discussions
18:32:28 <TeaAge> :)
18:32:31 <Remmy> :)
18:32:33 <Remmy> #endmeeting
18:32:35 <Remmy> lol
18:32:51 <TeaAge> are there further comment to the work with tx?
18:33:14 <Remmy> I think we covered most of the findings we've all had
18:33:30 <TeaAge> I think so too
18:33:36 <TeaAge> ok
18:33:39 <TeaAge> #endmeeting