17:33:58 <obgr_seneca> #startmeeting
17:33:58 <Inigo_Montoya> Meeting started Thu May  5 17:33:58 2011 UTC.  The chair is obgr_seneca. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:33:58 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:34:34 <obgr_seneca> So welcome to the last pre freeze meeting
17:35:12 <obgr_seneca> On our agenda are a few shorter topics and a larger one
17:36:02 <obgr_seneca> 1) Translator names in po files
17:36:27 <obgr_seneca> 2) Pre-freeze status
17:36:37 <obgr_seneca> 3) TODO for freeze
17:36:41 <obgr_seneca> 4) other
17:36:50 <obgr_seneca> 5) one thing that just slipped my mind
17:37:02 <obgr_seneca> #topic Translator names in po files
17:37:02 <Remmy> You also wanted to discuss mail aliasses I think
17:37:11 <obgr_seneca> Remmy: Thanks
17:38:03 <obgr_seneca> So, as most of you might know, there is a problem in Tx with the names of translators in po files
17:38:48 <obgr_seneca> We had discussed that earlier and decided, that someone (me) should save the pre Tx files for reinclusion of those names, when it's solved upstream
17:39:20 <obgr_seneca> Now it came up on the -dev ml by Thierry writing an email, when he saw, names were removed
17:39:36 <obgr_seneca> In that mail discussion the following idea came up
17:40:11 <obgr_seneca> Perhaps we could add a TRANSLATORS file to the svn separate from the po files
17:40:19 <obgr_seneca> What do you think?
17:40:54 <Youp3> Why not, but one file per team or one global file ?
17:40:59 <Remmy> I like that idea if no upstream fix is forthcoming. Perhaps we can change our transifex to include an automatic pointer to that file in all .po files.
17:41:16 <yurchor> Upstream thinks that anybody can resolve names through SVN history: http://trac.transifex.org/ticket/675
17:41:21 <obgr_seneca> Thierry's idea was a central file
17:41:36 <obgr_seneca> yurchor: I know the bug report
17:41:58 <dtsiamasiotis> what's the meaning of a central file?
17:42:01 <obgr_seneca> but I have discussed this over at #fedora-l10n
17:42:48 <obgr_seneca> dtsiamasiotis: not having that much files on svn I think
17:43:14 <Remmy> dtsiamasiotis, one TRANSLATORS or AUTHOR file saying: Greece: This person, That person  German: This, That, That   Dutch: etc.
17:43:32 <dtsiamasiotis> ok but that would be a temporary fix
17:43:41 <Remmy> Instead of having a TRANSLATORS.he TRANSLATORS.de etc.
17:43:43 <obgr_seneca> The fedora guys - among them Glezos from Tx - discussed if removing those names without replacement isn't a GPL problem
17:44:27 <obgr_seneca> dtsiamasiotis: I do hope it's getting fixed upstream and Glezos is surely doing his best
17:45:04 <obgr_seneca> I would prefer one file for all teams a better solution as well
17:45:27 <Remmy> We might be able to even script that
17:45:41 <dtsiamasiotis> anyway I don't really care much about names as long as I could find somewhere an email( ?) of the translator I'm looking for
17:45:42 <obgr_seneca> Remmy: script what?
17:45:58 <Remmy> obgr_seneca, generating such a file for all projects from the .po files
17:46:45 <obgr_seneca> dtsiamasiotis: The problem is: the GPL says, that copyright notices may not be removed, and translator names might be seen as copyright notices
17:46:55 <obgr_seneca> Remmy: I thought of that
17:47:06 <yurchor> Remmy: it is reasonable, but is there any common form in all translations?
17:47:25 <obgr_seneca> And since we do have all files in svn, it should not be a problem
17:47:38 <obgr_seneca> But I would postpone that till after Mga1
17:47:49 <Remmy> yurchor, I think one can take the top lines of the file up to a common line appearing in all files
17:48:04 <obgr_seneca> yurchor: that is the problem Glezos sees iirc
17:48:04 <Remmy> Then do a visual check on the files before committing them, and presto
17:48:21 <yurchor> Remmy: Glezos and bug 675 do not think so. ;)
17:48:35 <dtsiamasiotis> we already have removed names from po files and substitute with new ones.I didn't know GPL would be a problem
17:48:39 <Remmy> I'm willing to give it a go, but I need to finish the translations first
17:49:26 <obgr_seneca> Shell we say, the more scripting affine people among us will look for a way and we will discuss that after Mga1?
17:50:24 <yurchor> obgr_seneca: It may be late. After updates these lines will be already lost.
17:50:30 <Remmy> Sounds fine to me, but that leaves a lot of manual checking (for you?) this time around
17:50:50 <obgr_seneca> yurchor: Yes, but after all, they are in svn and we will move them back
17:52:45 <obgr_seneca> Does anyone have a problem, if those names are only in older revisions of svn till some time after string freeze?
17:53:18 <obgr_seneca> We don't have to wait till after Mga1, but I think translations have a priority before string freeze
17:53:30 <Remmy> Not I, but it would help if perhaps the committers can fix this as much as possible before committing the new versions
17:54:20 <Remmy> What I do myself, open the old .po and the new one from tx, and just copy those few lines at the top over, then commit
17:54:29 <obgr_seneca> Remmy: Would be a possibility
17:55:07 <obgr_seneca> It 'd be difficult for those who already commited and are not all that svn affine...
17:55:20 <Remmy> I'm even willing to assist with that by watching the soft commits list
17:55:26 <obgr_seneca> As I said, I personally don't see a problem if it's only a few weeks
17:55:33 <Remmy> Aye
17:56:06 <obgr_seneca> So let's get a vote?
17:57:03 <Remmy> What happens to any changes between freeze and release? (If that is possible at all)
17:57:45 <obgr_seneca> Remmy: They might be used for updates later ( /me has to check if it's possible )
17:57:59 <obgr_seneca> Or they will be used for next release
17:58:21 <obgr_seneca> #action obgr_seneca ask, what will happen to i18n changes between freeze and release
17:58:36 <Remmy> I vote for deal with it later, or any earlier should one of us come up with a workable solution in time.
17:59:04 <obgr_seneca> I second Remmy's proposal
17:59:10 <dtsiamasiotis> I agree, the freeze is near and the translation is importand
17:59:28 <obgr_seneca> Other opinions?
17:59:30 <dtsiamasiotis> *important
17:59:36 <Dan-Marian> i think for RO team there is no problem to solve this inside the team
17:59:49 <Youp3> I'm also agree
17:59:57 <yurchor> agreed with any variant
18:01:32 <obgr_seneca> #agreed i18n team will deal with the 'tx removing translator names' issue after freeze/Mga1 release or as soon as one of us comes up with a workable solution
18:01:35 <obgr_seneca> ok?
18:01:41 <Remmy> Yes
18:01:46 <yurchor> ok
18:01:57 <obgr_seneca> ok, next topic?
18:02:05 <Remmy> Quick question while we are on the subject of translator credits
18:02:18 <Remmy> My mail on the FSF copyrights of yesterday, any opinions?
18:02:23 <obgr_seneca> yes?
18:02:37 <obgr_seneca> I must admit, I have not read it
18:02:46 <Remmy> Most of the Dutch files have a copyright notice to the free software foundation in them
18:03:01 <Remmy> I think these were included as boiler plate copyright notices
18:03:12 <Remmy> inserted by whatever translation tool was initially used
18:03:26 <obgr_seneca> Must have been added by some former translators, I think
18:03:26 <Remmy> and that the .po files never were copyrighted FSF
18:03:39 <obgr_seneca> I think so, too
18:03:54 <Remmy> So, I thought I could take them out, but it might be a sensitive subject
18:04:11 <Remmy> I checked a few other languages, they didn't seem to have them... only the Dutch ones
18:04:42 <Remmy> Translator names and Mandriva copyrights I've kept in place
18:04:48 <obgr_seneca> Opposite to US law, the copyright of anything can't be given to someone else in Germany, you can only license it to others
18:04:59 <obgr_seneca> But I don't know about other countries
18:05:22 <obgr_seneca> Remmy: Should I bring this problem to the council's attention?
18:05:30 <obgr_seneca> Perhaps someone has an idea?
18:05:48 <Remmy> Well, perhaps also "deal with it later", but it would be nice to have an agreement on it later on
18:06:01 <Remmy> I can also ask the guy who did the Dutch translations at Mandriva
18:06:09 <Remmy> and see what he knows about these notices
18:06:16 <obgr_seneca> That would be an idea
18:06:25 <Remmy> Lemme do that and revert back on it later.
18:06:50 <obgr_seneca> #action everybody: think about the copyright notices in dutch po files
18:07:04 <obgr_seneca> ok, next topic?
18:07:08 <Remmy> Thanks
18:07:36 <obgr_seneca> #topic (short) pre freeze status report
18:08:18 <obgr_seneca> I wanted to ask all teams if they have some things to discuss
18:09:03 <obgr_seneca> I know, some of you have quite a lot to do, so I won't press you to do anything
18:09:03 <Youp3> no for the french team.
18:10:13 <obgr_seneca> If no one has anything to report just now, I think we can move on
18:10:14 <Remmy> I try to get everything done in time. Biggest inconvenience for me is that it's just me and in case of doubt on semantics I don't have a Mageia box right now to check the actual texts in use on.
18:10:56 <Remmy> Otherwise, no news.
18:11:01 <dtsiamasiotis> I have a question
18:11:02 <obgr_seneca> Remmy: Just ask on the ml, there always should be someone there who can answer the question
18:11:03 <yurchor> Remmy: You can ask. ;)
18:11:12 <obgr_seneca> or ask in IRC
18:11:20 <obgr_seneca> dtsiamasiotis: yes?
18:11:32 <dtsiamasiotis> we changed some translator names in po files.Is that ok?
18:11:53 <dtsiamasiotis> I mean the names from the mandriva import
18:11:54 <obgr_seneca> In the Last translator tag: no
18:12:20 <obgr_seneca> The list of former translators at the head of the files should not be changed
18:12:27 <obgr_seneca> But since Tx does remove them...
18:12:29 <obgr_seneca> No
18:12:36 <obgr_seneca> let's deal with those lists later
18:12:43 <dtsiamasiotis> ok,thanks
18:13:10 <obgr_seneca> ok, anybody else?
18:13:11 <Remmy> People who worked on the files any time in the past should be credited still. Either now, or after the tx fixup later.
18:13:59 <obgr_seneca> Remmy: yes, and they won't get lost, we can always check earlier revisions out from svn
18:14:08 <dtsiamasiotis> ok, It's clear
18:14:25 <Remmy> :)
18:14:35 <obgr_seneca> next topic?
18:14:40 <Youp3> yes
18:14:41 <Remmy> ::nods::
18:15:10 <obgr_seneca> #topic TODO list for freeze
18:15:37 <obgr_seneca> Most important thing is to commit our work before freeze
18:16:23 <obgr_seneca> I will add some procedures for that to the wiki for those of us who are not as svn affine as others
18:16:44 <obgr_seneca> Since I had an exam today, I did not have the time
18:17:30 <obgr_seneca> Ok?
18:17:37 <Remmy> Yes
18:17:54 <Youp3> ok
18:17:56 <yurchor> Is "Congratulation..." problem from 1122 solved? Nothing left unextracted from modules?
18:18:09 <Youp3> when will the freeze exactly ? 10 May at 23h59 ?
18:18:48 <Remmy> youp3: Would be nice if we have sunday to do some last work on too.
18:18:57 <yurchor> 1112, sorry...
18:19:05 <dtsiamasiotis> sounds so scary, like the apocaypse
18:19:35 <Remmy> dtsiamasiotis, haha
18:20:14 <Youp3> No problem, I try to finish tonight fr last translations
18:20:46 <obgr_seneca> sorry, had to answer the door
18:21:04 <Remmy> ::grumbles:: Inquisitive doors
18:21:29 <obgr_seneca> :D
18:22:29 <obgr_seneca> about #1112, I'll put it on my todo
18:22:45 <obgr_seneca> (me had to read up, what it was about)
18:23:14 <obgr_seneca> #action obgr_seneca make sure #1112 is fixed BEFORE freeze
18:23:39 <obgr_seneca> #action obgr_seneca ask, when exactly freeze will happen
18:24:35 <obgr_seneca> ok?
18:24:45 <yurchor> ok
18:25:13 <Youp3> ok
18:25:24 <Remmy> ko
18:26:09 <dtsiamasiotis> ok
18:26:29 <obgr_seneca> oh and I forgot:
18:26:45 <obgr_seneca> #action obgr_seneca write that wiki page about commit to svn
18:27:23 <Remmy> We need a script to randomly reassign some actions to others too :)
18:27:43 <obgr_seneca> :D
18:28:11 <obgr_seneca> #topic TODO for release
18:28:43 <Youp3> finish translation ? :)
18:28:48 <obgr_seneca> rda and some others are working on the release pages and associated things
18:29:15 <obgr_seneca> We will try to get them to i18n a few days before release
18:29:28 <Remmy> That'd be good
18:30:35 <obgr_seneca> It would be good, if the release pages (and their translations) would be ready at relases day
18:30:58 <Remmy> If there is going to be a release candidate, can we at that time also explicitly ask for proofreading volunteers? I would really appreciate a last chance to get some feedback before my typo's are kept for eternity.
18:32:08 <obgr_seneca> Remmy: Why should your's not be, when mine already are?
18:32:38 <Remmy> Touche
18:32:58 <obgr_seneca> And of course, if you should find any preefreaders, I will try and get corrections into final release
18:33:08 <Remmy> I know we have some Dutch users / testers, even though they are not on i18n
18:33:28 <obgr_seneca> (even if some prominent project member should threaten again to burn me)
18:33:50 <Remmy> haha
18:33:53 <obgr_seneca> s/preef/proof/ what did I type up there?
18:34:10 <Qilaq> hi, sorry I haven't before time to join
18:34:14 <Remmy> You just preved my point
18:34:19 <Remmy> Heya Qilaq  :)
18:34:23 <obgr_seneca> Qilaq: hi
18:35:21 <obgr_seneca> ok, next?
18:36:22 <Remmy> yup
18:36:26 <Youp3> next
18:36:43 <obgr_seneca> #topic mail aliases
18:36:48 <obgr_seneca> Now...
18:37:03 <obgr_seneca> WHo shell have @mageia.org aliases?
18:37:11 <obgr_seneca> team coordinators?
18:37:15 <obgr_seneca> all members?
18:37:32 <obgr_seneca> people that pribe me with enough chcocolate and red wine?
18:37:51 <obgr_seneca> (but please not at the same time)
18:37:55 <Qilaq> probably all who have Mageia's account?
18:38:41 <Youp3> all contributors who want an alias ?
18:38:48 <obgr_seneca> Qilaq: Since everybody can join there, we would loose all control
18:38:57 <dtsiamasiotis> team coordinators
18:39:19 <Remmy> I have no real opinion on that. It'd be nice if it would be anyone registered and on one or more ldap groups, but then I realise that having such an alias might make one look like officially representing mageia, which you perhaps do not want.
18:39:39 <Qilaq> wekk, if he/she want to join why can't he/she have an alias?
18:40:36 <obgr_seneca> Qilaq: because having an "@mageia.org" email alias does make you look like a representant of the project
18:41:13 <obgr_seneca> This is why the council decided to give those aliases only to active contributors
18:41:36 <Remmy> Has the council defined 'active' ?
18:41:48 <obgr_seneca> In packaging team, all full packagers have such an alias, padawans have not
18:41:57 <Youp3> so in this case only team coordinators, and the people donate chocolate to Oliver
18:41:58 <Qilaq> hmm, that's the point, yes... so, some criteria after which alias can be assigned - e.g. 10 commits or something?
18:42:34 <obgr_seneca> In web team, 'peers' get one, loose members not
18:42:43 <Qilaq> yeah, criterium may be rank in the hierarchy, too...
18:43:18 <obgr_seneca> (web team peers are (or should be) all who are actively working on one of the projects)
18:43:55 <obgr_seneca> Since all of the i18n people are actively contributing, we could give aliases to all translators
18:43:59 <Remmy> Then for us, perhaps those with commit access, as they already have a certain responsibility towards the team and the project anyways... but whatever we decide, anything is arbitrary.
18:44:03 <obgr_seneca> I just don't know, what is best
18:44:37 <obgr_seneca> I have an idea:
18:45:12 <obgr_seneca> Every one of us discusses this in his/her team and we will find a solution on the ml?
18:45:33 <Youp3> Ok
18:45:41 <dant3> obgr_seneca:  I will discuss it with myself :D sorry for being afk, I will read logs later
18:45:53 <obgr_seneca> dant3: it's ok
18:46:13 <Remmy> Perhaps the team leaders get it, and they can propose team members for getting an alias?
18:46:31 <Remmy> 
18:46:32 <Remmy> b
18:46:32 <obgr_seneca> #action everybody discuss the mail alias topic with his/her team
18:46:39 <Remmy> That was my cat, sorry
18:46:42 <obgr_seneca> Remmy: That's another idea
18:48:44 <obgr_seneca> ok?
18:48:49 <obgr_seneca> next topic?
18:49:10 <Remmy> Yes
18:49:28 <dant3> yep
18:49:30 <obgr_seneca> #topic other
18:49:33 <dtsiamasiotis> insert coin and press continue
18:49:45 <Remmy> dtsiamasiotis: Free game
18:49:45 <obgr_seneca> #info we now have overall statistics in Tx
18:49:50 <obgr_seneca> https://transifex.mageia.org/projects/p/mageia_i18n/r/mga1/
18:49:54 <Qilaq> as I was missing at the beginning I just want do add
18:49:58 <Youp3> nice thing
18:49:59 <Qilaq> about these headers: I tried msgmerge but either I didn't have knowledge to do it right or it has no such possibility but former translators were not merged (though even obsolete translation in the end of file were...)
18:50:13 <dant3> ah, now I can see how far I am behind :)
18:50:33 <Remmy> dant3, prolly not as far as me :)
18:50:55 <obgr_seneca> I only excluded catdap and epoll from this because they are not really parts of the distribution
18:51:05 <obgr_seneca> But I can always readd them
18:51:36 <obgr_seneca> Qilaq: we discussed that
18:51:41 <obgr_seneca> See the logs afterwards
18:51:52 <Qilaq> I saw already
18:51:54 <dant3> obgr_seneca: can we have per distibution and overall statistics as well?
18:52:15 <obgr_seneca> per distribution?
18:52:29 <dant3> yes, mga1, then mga2 then time will came
18:52:42 <dant3> per version*
18:52:57 <Qilaq> I just thought maybe we can do it manually with help of the msgmerge but it seems to be no solution
18:53:31 <obgr_seneca> dant3: I think so, this should be possible by just adding another "release" to that project
18:54:20 <dant3> nice
18:54:41 <obgr_seneca> Qilaq: As disscussed, we will search for solutions, but maybe after freeze/Mga1 release
18:55:07 <Remmy> I also have an 'other' topic to bring up.
18:55:10 <Qilaq> mhmh, I just hoped I can have one but alas... :-(
18:55:17 <Remmy> (surprise surprise)
18:55:44 <obgr_seneca> Remmy: ?
18:55:59 <Remmy> You guys have good spam filters, or my messages are not very clear... but my mail from Apr 30th...
18:56:20 <Remmy> draklive-installpot
18:56:32 <Remmy> Seems to contain a lot of Mandriva strings still, in all languages
18:56:44 <Remmy> See for example https://transifex.mageia.org/projects/p/draklive-install/resource/draklive-installpot/l/de/view/j
18:56:51 <Remmy> What do we do with those?
18:57:23 <yurchor> Remmy: Not all of these strings should be changed.
18:57:38 <Remmy> yurchor, they talk about installing Mandriva to your disk etc.
18:57:43 <obgr_seneca> Every string that is about copyright notices must stay
18:58:14 <obgr_seneca> You speak of strings in translation, not in the original languages?
18:58:26 <Remmy> "Mandriva Live" , "Install your Mandriva live system to disk"
18:58:41 <Remmy> obgr_seneca, well, both the English and the translations refer to Mandriva
18:58:46 <dtsiamasiotis> we translated this as Mageia Live
18:59:10 <Dan-Marian> us too
18:59:11 <Remmy> What I'm saying... shouldn't the source text have been changed to read Mageia?
18:59:16 <obgr_seneca> I will have another look and ask the devs...
18:59:27 <Remmy> That's what seems to have been done for all the other .pot files but this one.
19:00:10 <Remmy> Thanks. The German texts read Mandriva too :)
19:00:26 <obgr_seneca> #action obgr_senecalet some of the devs check draklive-install for Mandriva strings
19:00:34 <obgr_seneca> #undo
19:00:34 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0xb7552b4c>
19:00:39 <obgr_seneca> #action obgr_seneca let some of the devs check draklive-install for Mandriva strings
19:00:56 <obgr_seneca> ok
19:01:05 <obgr_seneca> I'm sure there was something else...
19:01:12 <obgr_seneca> But it again slipped my mind
19:01:57 <Remmy> Your dep?
19:02:19 <obgr_seneca> Remmy: dep?
19:02:22 <obgr_seneca> deputy?
19:02:25 <Remmy> deputy team leader
19:02:32 <Remmy> or commit messages?
19:02:34 <obgr_seneca> Oh yes...
19:02:38 <Remmy> Just guessing, lol
19:03:00 <obgr_seneca> I asked a bit arround, but did not really find a volunteer
19:03:43 <obgr_seneca> So if anybody should find someone looking nice and like he could be a volunteer...
19:03:53 <Remmy> or she
19:04:11 <obgr_seneca> Yep, of course
19:04:49 <Youp3> with time akien...
19:05:07 <Youp3> But I say nothing O:)
19:05:38 <obgr_seneca> I would like to have him or piratu or Remmy or Mareek, but none of those felt like he could do it
19:06:19 <Youp3> I spoke of this subject yesterday with him.
19:07:01 <obgr_seneca> ok, one more thing
19:07:11 <obgr_seneca> I can't do a meeting next week
19:07:33 <obgr_seneca> I will be on my way to Berlin for Linuxtag
19:08:25 <Youp3> It's not a problem I think
19:08:44 <Youp3> as we will already in freeze
19:08:45 <obgr_seneca> ok
19:08:55 <obgr_seneca> Then let's end the meeting?
19:09:06 <Youp3> Yep
19:09:08 <obgr_seneca> #endmeeting