18:34:33 <wobo> #startmeeting
18:34:33 <Inigo_Montoya> Meeting started Thu Feb 10 18:34:33 2011 UTC.  The chair is wobo. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:34:33 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:34:45 <wobo> #name International Mageia-i18n Meeting
18:34:55 <wobo> #chair ennael misc
18:34:55 <Inigo_Montoya> Current chairs: ennael misc wobo
18:35:07 <wobo> First, thx for coming
18:35:24 <TeaAge> nP ^^
18:35:33 <wobo> We have only one real topic on the agenda, so this will be a long meeting :)
18:35:49 <wobo> #topic transifex
18:36:10 <wobo> misc could you give an overview of the conversation about Tx at Fosdem?
18:36:16 <misc> wobo: mhh, no :)
18:36:40 <misc> i do not really remind what exactly we told
18:37:03 <wobo> Well, there seems to be a problem, IIRC
18:37:40 <wobo> A problem related to svn and transifex collaboration
18:37:49 <misc> I remember the conclusion, about string freeze, people pushing to svn , but not how we went there :)
18:38:06 * misc start to remind
18:38:12 <wobo> what was the conclusion?
18:38:26 <misc> that either dev or the head of translation push .po to svn
18:38:46 <Jehane> we have said that transifex can not commit in svn in the way we want to work
18:38:51 <misc> yup
18:38:55 <wobo> yes
18:39:04 <TeaAge> why?
18:39:08 <Jehane> 'cause we are planning to have proofread of the string before commit
18:39:26 <misc> so the idea is to use transifex as a staging area
18:39:44 <Jehane> and it's not possible to have a "to proofread" status in transifex (as far as I know)
18:40:03 <misc> let's say that a developper create a shiny new software that display duck
18:40:11 <misc> drakeduck
18:40:22 <wobo> drakeducksoup
18:40:23 <misc> so he create the software, tx fetch the .po
18:40:27 <Jehane> nicename
18:40:42 <TeaAge> what about using transifex for translation and after string freeze the commiiter have to push the .po to svn manually
18:40:44 <TeaAge> ?
18:40:51 <misc> TeaAge: that's what we proposed, yes
18:41:36 <wobo> That does not seem a problem to me
18:41:38 <misc> so translators send their work in progress on transifex
18:42:05 <misc> once the .po is ready ie have been proofread, either someone from the team commit the .po ( using tx-client )
18:42:16 <misc> or the developpers fetch it ( usig tx-client again )
18:42:36 <wobo> the appointed committers of the teams can do this
18:43:00 <Jehane> misc: commit in "general" svn/git , not transifex one
18:43:45 <Jehane> misc: how do you plan to synchronise transifex svn and general svn ?
18:43:46 <misc> Jehane: commit to the code repositry, yes
18:43:52 <wobo> yes, using either the tx-client or old-fashioned svn co
18:43:53 <misc> Jehane: tx do not use svn
18:44:09 <Jehane> misc: ok, what tx is using ?
18:44:11 <misc> tx store the .po in a postgresql databse
18:44:31 <misc> ( or anything supported by the django framework, ie mysql/sqlite/oracle/pgsql )
18:44:55 <misc> the previous version was using svn to store everything, but it was inflexible, IIRC
18:45:09 <Jerzy> The problem is tx does not preserve comments above file header in .po files. It doesn't even store them in db
18:45:38 <Jehane> ok; so how tx is updating .po files when they are updated in the source repository ? (news strings, etc)
18:45:49 <misc> Jehane: it depends
18:46:25 <misc> either it can fetch them using tx-client, or people can update by hand ( ie upload using the web )
18:46:35 <Jehane> ok
18:46:36 <misc> ( tx-client just being a commandline to go on the web )
18:46:43 <misc> Jerzy: can you be more explicit ?
18:47:22 <Jerzy> Well, strings are updated acc. to modified pot/en.po file
18:48:17 <Jerzy> This may be done by maintainer of the project only
18:48:51 <Jerzy> .po files are updated repectively (by tx)
18:49:44 <Jerzy> misc: you mean comments?
18:50:00 <misc> Jerzy: well, I do not understand the "do not preserve comment"
18:51:24 <Jerzy> ok. each pot files stars with comments, like: some descrpitive title, translators and so on. It is generic.
18:51:40 <misc> yup, but this part is managed by tx , iirc
18:51:46 <misc> ( ie, it fill this automatically )
18:52:50 <Jerzy> yes, but after editing some entrie are added by translators (their names, email, year)
18:53:31 <Jerzy> tx reverts all comments to its generic form
18:53:48 <Jerzy> from pot file
18:54:04 <misc> mhh, it doesn't simply add the information as given by the date and username ?
18:54:06 <Jerzy> history of translators is lost
18:54:57 <TeaAge> how does Fedora manage that?
18:55:27 <misc> mhh, mrtom is not here
18:55:36 <misc> someone who want to contact fedora about this ?
18:55:45 <wobo> who is mrtom?
18:55:57 <Jehane> they do all in the ML and the committers send it to transifex
18:56:01 <misc> french fedora coordinator, and someone from the french team
18:56:08 <wobo> ok
18:56:11 <Jerzy> Here is ticket http://trac.transifex.org/ticket/675
18:56:21 <Jehane> but they're still using transifex 0.8 (or 0.9)
18:56:41 <TeaAge> I tried to contact an "Dimitris", he manages afak transifex for fedora but he didn't reply so far
18:56:42 <Jerzy> tx 1.0 is doing the same
18:57:31 <wobo> What we should do (IMHO):
18:57:46 <wobo> 1. compile a list of the problems
18:58:17 <wobo> 2. get in touch with Fedora's tx guys and show them the list
18:58:42 <wobo> 3. Ask them kindly if they can help and then either do it by mail or IRC meeting
18:58:50 <wobo> WDYT
18:59:07 <TeaAge> agree
18:59:12 <misc> well, they are still using a old version of tx, so the issue are likely to be different
18:59:28 <misc> apart from fedora, whose community is using tx that could be contacted ?
18:59:32 <TeaAge> or we could contact the Tx developer?
18:59:36 <Jehane> agree wobo
18:59:42 <wobo> Anybody knows who is using the current version?
18:59:50 <misc> #info tx do not preserve comment and history
18:59:56 <Qilaq> last time I heard they are planning to move on to Transifex, i.e. Transifex proper
18:59:57 <misc> #url http://trac.transifex.org/ticket/675
19:00:26 <Jehane> #agree compile problem and contact Fedora's tx guy to share XP
19:00:37 <Jehane> arf, not chair
19:00:46 <misc> so who volunteer for the task ?
19:01:02 <Jehane> misc: you've spoken the first
19:01:31 <wobo> #agree compile problem and contact Fedora's tx guy to ask for help
19:02:12 <misc> Jehane: ok so I decide
19:02:14 <dtsiamasiotis> TeaAge: you mean Dimitris Glezos?
19:02:18 <misc> so Jehane , you contact fedoa
19:02:37 * Jehane should have keep her mouth closed
19:02:52 <wobo> Jehane: I think Oliver will help
19:02:56 <TeaAge> dtsiamasiotis: yes, I that coulb be his name
19:03:01 <TeaAge> have to check
19:03:04 <Jehane> wobo: ok
19:03:38 <wobo> Oliver has problems staying online for discussions but is available on the list
19:03:58 <dtsiamasiotis> TeaAge: he's famous in greek open source community,try to find other mails of him,I think he's still active
19:04:46 <misc> so Jehane, ok or not to contact fedora ( if you do not want, just say it ) ?
19:04:52 <TeaAge> dtsiamasiotis: I send the mail two days ago ... I will give him a few more days :)
19:05:28 <wobo> #action Jehane and obgr_seneca will compile a list with tx problems and contact Fedora's tx guy and/or Dimitrios
19:05:31 <Jehane> misc: ok, no problem, but just don't except a quick reaction, I'm a bit overloaded
19:05:35 <TeaAge> dtsiamasiotis: I used the contact form on his homepage
19:06:08 <misc> #actionn Jehane contact fedora to see how they cope with the list of problem
19:06:12 <misc> #action Jehane contact fedora to see how they cope with the list of problem
19:06:23 <misc> who is volunteer to compile a list of issue ? Jerzy ?
19:06:42 <Jerzy> oh, it's almost ready
19:06:51 <Jerzy> oh/ok
19:07:06 <misc> #action Jerzy compile a list of issue, post it on i18n and the wiki
19:07:20 <wobo> you are fast! :)
19:07:37 <misc> a quick google search showed me no other obvious installation of tx besides fedora :/
19:08:07 <dtsiamasiotis> TeaAge: he doesn't have recent posts in his personal blog, ask in the #fedora about him
19:08:11 <misc> http://trac.transifex.org/wiki/ProjectsUsingTransifex
19:08:13 <wobo> that's what Im thought, Fedora was the only name which came up related to tx
19:08:35 <misc> well, there is xfce and openinkpot
19:08:46 <misc> ( someone should think to add our name once we use it )
19:08:52 <wobo> yes
19:09:10 <misc> so maybe someone could contact xfce and openinkpot ?
19:09:29 <misc> xfce is using 0.9
19:09:36 <TeaAge> I saw meego using transifex, but I don't know if they run it on there server ...
19:09:36 <misc> openinkpot is using 0.8
19:09:43 <misc> TeaAge: hosted on tx.net
19:09:48 <TeaAge> ok
19:10:12 <misc> http://meego.transifex.net/projects/p/meego/
19:10:35 <misc> meego is reusing obs, gitorious.org and tx.net, and likely provides funding for them
19:11:55 <wobo> xfce and openinkpot may not have the same problems because of the different version of tx
19:12:12 <misc> yup
19:12:27 <misc> but xfce seems to have patched tx ( according to the version number )
19:12:55 <misc> and contacting them would stil be good to have contact :)
19:13:04 <wobo> Didn't Dmitrios say something about a patch at Fosdem?
19:13:22 <misc> i didn't spoke to dmitrios
19:13:59 <wobo> Then I used the wrong name - the greek guy who was there when we discussed tx
19:15:11 <misc> panau
19:15:31 <wobo> http://www.flickr.com/photos/wobo/5424617421/in/set-72157625996574898/
19:15:44 <wobo> the one talking with Remy on that pic
19:16:40 <misc> yup, p christeas
19:17:03 <wobo> Ah, ok, didn't he say something about a patch?
19:17:32 <misc> yes, but this was not related to the comments, no ?
19:18:00 <wobo> ok, but to the exchange between svn and tx, no?
19:18:11 <misc> oh yes
19:18:34 <wobo> would it help us?
19:18:46 <misc> well, we solved the issue of tx/svn, no ?
19:18:56 <wobo> yes, ok
19:19:42 <wobo> so, anything more about tx at the moment?
19:20:01 <misc> well, contacting xfce / openinkpot, maybe upstream ?
19:20:41 <wobo> show them the same list as to Fedora, right?
19:21:29 <wobo> and tx devel
19:21:32 <misc> yes
19:22:29 <wobo> ok, will do via the tx wiki and the links there
19:22:48 <wobo> to xfce and openinkpot
19:23:32 <wobo> #action wobo will contact xfce and openinkpot with list of tx problems
19:24:36 <wobo> So, this wraps up tx for the moment?
19:24:53 <Jerzy> yes
19:25:32 <misc> so next topic ?
19:25:37 <wobo> We may get more input from Oliver tomorrow
19:25:44 <wobo> #topic Other
19:26:10 * misc raise hand
19:26:13 <wobo> #info Fosdem report is out in the blog, if you
19:26:34 <wobo> #undo
19:26:34 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Info object at 0x85a818c>
19:26:58 <wobo> #info Fosdem report is out on the blog
19:27:15 <wobo> If you haven't translated yet, pls do, it's important
19:27:45 <Jehane> we're waiting proofreading
19:27:53 <misc> ( and that's just the start, as I plan a big article on crypto stuff :p )
19:28:21 <TeaAge> noooooooo
19:28:23 <TeaAge> :D
19:29:01 <Jehane> misc: please send me the draft before publication :
19:29:12 <Jehane> so we can begin translation
19:29:50 <misc> Jehane: well, if the process need to be changed, i would rather have this discussed first
19:30:22 <wobo> as a side note: German translators used PiratePad for translating the blog post - a good experience
19:30:32 <Jehane> misc: I was joking because I know your habit to do very very long post
19:30:39 <misc> we used it to redact the blog post
19:30:59 <wobo> Well, we can "forget to translate all the boring stuff
19:31:14 <Jehane> wobo: it can be interesting but we must be all online in the time
19:31:37 <wobo> Jehane: ?
19:31:43 <misc> Jehane: we do it for framalang, it work quite well
19:32:02 <Jehane> wobo: all translator must be connected in the same time no ?
19:32:08 <wobo> no
19:32:36 <wobo> you can set revisions if needed, you can come and leave, etc.
19:34:05 <misc> Jehane: see with vincent_k, for lqdn or april
19:34:05 <Jehane> ha ok, we should try perhaps
19:34:05 <wobo> I used it for the first time while compiling the fosdem report with misc and others - I liked it, introduced it to the Germans, they liked it as well
19:34:26 <TeaAge> yeah, was quit a nice experience
19:34:42 <wobo> next:
19:34:49 <wobo> next?
19:34:52 <misc> yes
19:35:05 <wobo> I have no next
19:35:09 <misc> I do
19:35:14 <wobo> go
19:35:18 <misc> I have seen a presentation given by a kde translator about their tools, and he mentionned pology
19:35:51 <misc> which is it seems a online community for travel, but not only
19:35:55 * misc seek the english website
19:36:13 <misc> this is a tool to apply some rules to .po, to check them and so on
19:36:20 <misc> http://techbase.kde.org/Localization/Tools/Pology
19:36:36 <misc> so my question is two fold : 1) do people know and use this tools
19:36:48 <misc> 2) would it be interesting to package it ?
19:37:45 <Jerzy> let's check and continue discussion on ML
19:37:51 <Jehane> I've only see the same presentation than you so no opinion
19:38:30 <misc> Jerzy: well, if there is any tools that translator would need to be packaged in mageia, it would be nice to know so we can work on it :)
19:38:45 <wobo> #action all look at pology and evaluate, report back to the mailing list
19:38:47 <Jerzy> I mean so :)
19:39:01 <wobo> #url http://techbase.kde.org/Localization/Tools/Pology
19:39:21 <misc> in fact, it would be also nice to have some kind of official contact with others big teams
19:39:29 <misc> ( ie, kde, gnome, mozilla, etc )
19:40:30 <wobo> yes
19:40:51 <Jerzy> In kde all translations are committed by coordinators, no online translations like tx
19:42:44 <Jehane> Jerzy: organisation is differente in each language team
19:42:48 <wobo> I will write a mail in the ML about this. Some people already have contacts here and there, we can use them as a start
19:43:12 * misc wanted to do the same for packagers
19:43:21 * misc forgot to propose it
19:43:39 <wobo> We can have contact on different levels, personal, language based, official project level
19:45:08 <wobo> #action wobo will propose contacts with large projects, using existing personal contacts for start
19:45:21 <wobo> #undo
19:45:21 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x863332c>
19:46:06 <wobo> #action wobo will write in the mailing lsit about proposition to contact large projects, using existing personal contacts for start
19:46:32 <wobo> misc: more?
19:47:30 <wobo> #info Alpha1 is due next week, be prepared for announcements
19:47:42 <Jehane> ok
19:47:59 <wobo> after you translated misc's oevre
19:48:29 <misc> well, I didn't start writing, and I think we should not push too much blog at a time
19:48:40 <misc> so this will likely be after the announce
19:49:09 <wobo> There's also the financial report int he pipeline
19:49:24 <wobo> to be published
19:50:05 <wobo> so, more?
19:50:55 <wobo> Then close meeting?
19:50:56 <misc> not for me
19:51:00 <Jehane> nothing
19:51:27 <wobo> #endmeeting