19:01:04 <wobo> #startmeeting
19:01:04 <Inigo_Montoya> Meeting started Thu Jan  6 19:01:04 2011 UTC.  The chair is wobo. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:04 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:06 <numand> ok
19:01:18 <wobo> #chair obgr_seneca misc
19:01:18 <Inigo_Montoya> Current chairs: misc obgr_seneca wobo
19:01:48 <wobo> First let me wish you all a great healthy and prosperous New Year!
19:02:20 <numand> Thank you wobo , same for you.
19:02:31 <kosmas> Happy New Year
19:02:32 <wobo> Let's make this one be remembered as the year Mageia took off into the Linux sky
19:02:33 <Jehane> thank you, same for you and everyone here
19:02:57 <wobo> #topic Mailing lists
19:03:11 <wobo> Let's start with the easiest topic:
19:03:14 <Remmy> Happy new year guys and gals
19:03:23 <wobo> Mailing lists have been created but are not yet open
19:03:33 <wobo> misc is working on a "HowTo" and we should wait until he gives the green light
19:03:43 <wobo> There have been additional requests after I sent the first list of requests
19:03:57 <wobo> We should wait until the lists are open for use and then send a second list of requests
19:04:11 <wobo> misc: anything to add to this?
19:04:35 <misc> wobo: well, no, except that I am more working on answering the mail than writing howto :)
19:04:51 <wobo> yes, I saw that.
19:04:59 <wobo> In the i18n list jehane asked about moderation of the lists
19:05:12 <wobo> 1. Moderation like in a forum should be done by the team leaders - if necessary at all
19:05:29 <wobo> 2. Moderation in case of mails to the list from not subscribed people needs
19:05:38 <wobo> - proper permissions in the mailing list system
19:05:44 <Jehane> wobo: I was more thinking to the second case
19:05:50 <wobo> - time
19:06:00 <wobo> - knowledge of the respective language
19:06:11 <wobo> First point depends on the sysadmins
19:06:22 <wobo> Third point seems to indicate that people from each list should be involved
19:06:28 <misc> well, people just need to be added in the proper group
19:06:46 <wobo> Jehane: yes, it was my own misunderstand which brought up point 1.
19:06:55 <misc> and from what I see on moderating current list, you do not need to speak german to remove spam, as they are quite language agnostic
19:07:06 <wobo> yes
19:07:15 <misc> viagra is the same all around the world :)
19:07:31 <Remmy> I think it would be useful that if postings from non subscribed persons get forwarded to a moderator, that somehow there could be some pre filtering done on outright spam from possible spam and other mail
19:07:34 <wobo> Sildenafil as well?
19:07:35 <ajunior> I Agree
19:07:41 <misc> Remmy: that's what is done
19:07:52 <Remmy> misc: Ok, so no viagra for the moderator then? Awesome.
19:08:27 <ajunior> I think 90% of spam are in English.
19:08:57 <Qilaq> they are clever now and use Google Translate or something...
19:09:22 <wobo> So, in the end it is a decision how we want to handle this best. I think the decision should be based on what is easiest from the technical point of view and the time consumption
19:09:35 <cfrussen_RO_team> Google Translate is a little dool, you still need some brains :)
19:09:41 <misc> i think we should first see what kind of spam will be sent
19:09:54 <misc> ie, i never seen spam in spanish on all ml i moderate
19:10:07 <wobo> I was more talking about mails from not subscribed people
19:10:12 <misc> oh
19:10:21 <Remmy> As long as the moderator doesn't get "Dear beloved" emails from MRS SOMETHING from Ghana, I'm fine with this.
19:10:22 <misc> wobo: that's still spam :p
19:10:29 <Qilaq> usually spammers are not subscirbed :-)
19:10:43 <ajunior> Certainly most of the spam are in English.
19:10:51 <wobo> yes, I think you know what I meant :9
19:11:18 <misc> from what I see, there is like 2 people per month that forget to subscribe
19:11:38 <misc> that's a rather low volume, so it may not warrant a quite complex setup
19:11:42 <cfrussen_RO_team> so, with a spam asassin it would be asy to reject all mail not coming from subscribers?
19:11:55 <misc> cfrussen_RO_team: yes, but that's annoying
19:12:17 <wobo> misc: you propose to let sysadmin do that?
19:12:26 <misc> wobo: for now, yes
19:12:42 <wobo> I mean in general for all lists, not only i18n?
19:12:46 <ajunior> I thinks that spam isn't a big problem
19:12:53 <misc> wobo: yes
19:13:11 <wobo> #agreed Mailing list moderation will be done by sysadmin for the time being
19:13:30 <wobo> Anything more on this?
19:13:51 <Remmy> Not from me... looking forward to these lists :)
19:13:54 <numand> Nothing.
19:14:08 <Jerzy> It's OK
19:14:19 <Jehane> nothing more
19:14:36 <kosmas> sorry, if you mentioned that in previous meetings, but do you need unsubscribed people to send messages to lists?
19:14:42 <wobo> #info sysadmin will notify us when we can start using the i18n language lists
19:15:17 <wobo> kosmas: no. but it happens from time to time
19:15:49 <Remmy> kosmas, I guess it can also be useful if a packager or web person can ask a team for an updated translation without having to join the list.
19:16:16 <wobo> #topic Transifex
19:16:26 <Remmy> Though that is possibly tackled differently by the workflow / transifex
19:16:35 <wobo> obgr_seneca: Jehane?
19:16:47 <obgr_seneca> I created a (small) wiki page: http://mageia.org/wiki/doku.php?id=transifex_sumup
19:17:08 <wobo> #url http://mageia.org/wiki/doku.php?id=transifex_sumup
19:17:12 <Jehane> I still to complete the page
19:17:44 <Jehane> well, there is CLI tool for using transifex for people who don't want to use the web page
19:17:51 <obgr_seneca> My opinion is, we should go for it
19:18:17 <Jehane> mine too
19:18:17 <Remmy> I have a question on the offline workflow
19:18:46 <obgr_seneca> It gives statistics, several language groups, two kinds of team membership, online and offline translation
19:18:54 <Remmy> "Download via web page" and "Using command line tools", do they go hand in hand, or can one choose to solely use one or the other?
19:19:00 <obgr_seneca> website or cli tools
19:19:02 <cfrussen_RO_team> and for the people who want to use the onlike Transifex?
19:19:19 <obgr_seneca> Remmy: I wanted to write more on both topics
19:19:31 <misc> Remmy: the command line download using the web page ( ie, wget or curl )
19:19:36 <obgr_seneca> But I didn't get it done
19:20:00 <wobo> cfrussen_RO_team: there's an online editor lotte
19:20:07 <Jehane> I hope can look more inside this week-end
19:20:08 <Remmy> Ok, sounds good. As long as one doesn't *have* to visit the website to see what URL to use for wget etc.
19:20:25 <ajunior> I read about transifex and I think that is a good tool
19:20:48 <Jehane> It used by other distribution like Fedora
19:21:21 <cfrussen_RO_team> and how do Fedora configured their Transifex?
19:21:38 <Remmy> If program x uses transifex for it's files, how does that fit into various distributions using transifex for translations?
19:22:03 <Remmy> s/it's/its
19:22:20 <obgr_seneca> Sorry guys, could you clarify your questions?
19:22:26 <Jehane> cfrussen_RO_team: I'm not a fedora translator
19:22:40 <wobo> Transifex is a collaboration tool, it is not bound to a distribution
19:22:57 <wobo> It is installed on the Mageia server
19:23:00 <cfrussen_RO_team> do you know a Fedora translator? just to get an answer to the projet organisation question
19:23:03 <Remmy> obgr_seneca, say, we change a Dutch text for a given program. How would that affect Fedora which also packages program x?
19:23:20 <wobo> Remmy: Not at all
19:23:20 <Jehane> cfrussen_RO_team: MrTom is one of their french translator
19:23:29 <obgr_seneca> Remmy: Not at all
19:23:36 <misc> Remmy: if you change the translation it should sent upstream
19:23:41 <Jacendb> Remmy: we work on the translation for the program X for mageia's version only. We don't touch fedora's version
19:23:42 <obgr_seneca> As usual we won't translate upstream programs
19:23:43 <misc> like when we change code on our side
19:23:47 <Jehane> Remmy: they have a instance on fedora server, we will have our
19:23:50 <obgr_seneca> that has to be done upstream
19:24:25 <Remmy> Ok... so Mageia's transifex is seperate from Fedora's transifex, which in turn is seperate from the programs transifex which might be on the "public" transifex server?
19:24:26 <obgr_seneca> Our translations don't affect anyone outside mageia
19:24:42 <obgr_seneca> transifex is
19:24:45 <obgr_seneca> 1. a software
19:24:48 <misc> Remmy: mageia tx server is for program where we are the upstream
19:24:51 <cfrussen_RO_team> I'll try to get an answer from the Romanian translator comunity to see how Fedora organized its translation projects
19:24:51 <obgr_seneca> 2. a web service
19:24:58 <numand> As I have read Jehane's wiki page about Transifex, we have two choice: first one is"to create one big project (mageia)..."; and other one is "to create a project for every tool containing ..."
19:25:02 <misc> fedora tx server is for the software where they are the upstream
19:25:31 <Remmy> Ok, I think I understand. Thanks.
19:25:36 <obgr_seneca> numand: yes, that was how I understood that
19:25:43 <numand> I think first choice is better because of the fact that we do not need to search any tool to be translated.
19:25:52 <obgr_seneca> perhaps the devs could point us into the right decision
19:26:26 <cfrussen_RO_team> thein, Mageia Transifex server will host a project per Mageia software, I think it's better
19:26:35 <Jehane> numand: it's depend, some mageia related software can be hosted by mageia and we can manage the translation
19:27:17 <numand> I got it Jehane , thank you.
19:27:30 <Remmy> One further question... to use transifex we register with mageia ldap, and not with transifex.net?
19:27:53 <Jehane> Remmy: yep, with CatDap, but misc can say more on this subject
19:27:54 <obgr_seneca> Remmy: We will use transifex on our own server
19:28:00 <obgr_seneca> Not on transifex.net
19:28:15 <obgr_seneca> misc: correct?
19:28:30 <misc> obgr_seneca: yes
19:28:40 <Remmy> Ok, I was concerned about becoming dependant on transifex.net's availability. If it's all under Mageia's control, then that's not an issue.
19:28:48 <misc> it can be seen on transifex.mageia.org, even if the url may change
19:29:02 <misc> ( and IIRC, it also would need some tweak to be faster )
19:29:56 <misc> ( and some bugs may need to be fixed too, like missing templates :/ )
19:30:06 <wobo> misc: is it possible to use a training section?
19:30:44 <misc> wobo: mhh, we can do a 2nd tx instance for that
19:31:02 <misc> that would be quite easy in fact, we just need to find a server
19:31:06 <Jacendb> thats a good idea
19:31:10 <wobo> just for a couple of months to get people used to it
19:31:30 <obgr_seneca> wobo: could that be done on our diva?
19:31:47 <wobo> obgr_seneca: why not?
19:32:22 <wobo> obgr_seneca: would you set it up to take some work off misc ?
19:32:41 <obgr_seneca> I could
19:32:59 <wobo> If youmcouold then you can :)
19:33:07 <wobo> misc: ok?
19:33:33 <misc> wobo: I just took a look at our setup, it would be easier
19:33:55 <wobo> misc: which would be easier?
19:33:56 <obgr_seneca> misc: maybe I will have to aks you some questions, I'll see
19:34:06 <misc> wobo: for me, to not do anything :)
19:34:13 <wobo> :)
19:34:22 <misc> obgr_seneca: ok, we have the various configuration in our svn
19:34:23 <Remmy> misc: Usually that's my job, lol
19:34:42 <obgr_seneca> misc: ok
19:35:03 <wobo> #action obgr_seneca set up a transifex training instance on mandrivauser.de
19:35:32 <obgr_seneca> (me should learn to keep my mouth shut)
19:35:50 <cfrussen_RO_team> great, this way we can train the newcomers
19:35:58 <wobo> A singer can't shut his mouth
19:36:23 <misc> well, if the instance is made to last, then in the long term, we should host it
19:36:56 <misc> because for security reason, ldap and account are restricted to our instance and so a external server would use a different set of account, etc, etc
19:37:19 <wobo> yes
19:37:25 <obgr_seneca> misc: yes, I thought about that, too
19:37:41 <wobo> So we are back to setting it up on Mageia ground
19:37:52 <misc> well, we can do it on mdvuser.de for now
19:38:09 <misc> and later, once we know what is needed to train people , install it on mageia server
19:38:21 <wobo> yes
19:38:41 <cfrussen_RO_team> does Transifew dispose of a sandbox?
19:38:41 <misc> ie, differents looks for different templates, releaxed permission so people can see what is the admin side
19:39:05 <misc> or automated resintalllation of the server database every night etc
19:39:08 <wobo> #info Transifex training center will be on mandrivauser.de only temporarily
19:39:08 <cfrussen_RO_team> if it's to train people, lets train them on true files, but in a sandbox
19:39:26 <obgr_seneca> I'll try till next meeting, ok?
19:39:33 <cfrussen_RO_team> then, when validates, the coordinator will submit it in production
19:39:49 <misc> cfrussen_RO_team: if you want to help obgr_seneca , i am sure he will be happy to be helped :)
19:40:17 <Remmy> cfrussen_RO_team, I think it would be nice indeed if the playground had a periodical copy of the official version.
19:40:35 <obgr_seneca> Let me have a look at it first. I will tell you, if I need anything on the ML
19:40:38 <cfrussen_RO_team> why not, I would gladly help with anything I can
19:40:44 <Remmy> But maybe we're overasking now :-)
19:41:29 <cfrussen_RO_team> You're French , right? So it's normal to "overask" :)
19:41:37 <wobo> #action cfrussen_RO_team will help obgr_seneca
19:41:58 <wobo> More on that?
19:42:16 <numand> Nothing.
19:42:26 <wobo> obgr_seneca: you will talk with ole about it?
19:42:28 <cfrussen_RO_team> I'll wait for instructions from obgr_seneca
19:42:39 <obgr_seneca> wobo: of course
19:42:46 <obgr_seneca> cfrussen_RO_team: ok
19:43:05 <obgr_seneca> wobo: but I do think the diva can handle it
19:43:11 <wobo> explanation: ole is the other sysadmin at mandrivauser.de
19:43:32 <wobo> obgr_seneca: our diva runs on Debian, it can handle everything!
19:43:58 <obgr_seneca> explanation2: he is the main sysadmin, I'm just some kind of poor substitute
19:44:02 <Remmy> cfrussen_RO_team, ha, Dutch... but I guess we are known for wanting as much as we can get for as little as possible :)
19:44:17 <obgr_seneca> Remmy: Aren't we all?
19:44:36 <misc> wobo: i fear that it may not be as easy as it sound, given the relative number of deps that tx requires
19:44:37 <wobo> ok, now we've also touched the other main topic: Workflow.
19:45:14 <Remmy> obgr_seneca, as the Belgians like to say: Copperwire was invented by two Dutch, fighting over a penny.
19:45:45 <wobo> misc:  we'll see how deep the water is.
19:46:25 <wobo> obgr_seneca will check and then come back with information
19:46:41 <obgr_seneca> will do!
19:47:32 <wobo> Anything more on workflow and transifex at the moment?
19:48:07 <wobo> obgr_seneca: misc: ?
19:48:12 <misc> me, no
19:48:19 <obgr_seneca> me, neither
19:48:47 <wobo> so, that's all from the topic list except
19:48:58 <wobo> #topic Other
19:49:11 <wobo> Anybody?
19:49:18 <obgr_seneca> not me...
19:49:32 <misc> obgr_seneca: you learned how to stay silent :p
19:49:34 <cfrussen_RO_team> wait, which workflow you're talking about?
19:49:34 <Remmy> No sir.
19:49:47 <cfrussen_RO_team> I'm affraid I didn't geit it
19:49:51 <wobo> cfrussen_RO_team: the translating workflow
19:50:02 <Jacendb> nop
19:50:08 <obgr_seneca> misc: nothing teaches better then pain...
19:50:09 <Jehane> nothing to say right now
19:50:16 <misc> in fact, i have a question
19:50:27 <misc> I am looking at the meeting log
19:50:29 <wobo> Not eating time yet?
19:50:40 <misc> and there is some people who use #mageia-i18n-$CODE
19:50:47 <misc> and some that use #mageia-$CODE
19:51:06 <wobo> where?
19:51:08 <obgr_seneca> you mean for the team meetings?
19:51:16 <Qilaq> not much, but i've plearusse to say epoll is now translated into Estonian so for time being i'm so idle... :-)
19:51:18 <cfrussen_RO_team> it's simple for the workflow
19:51:20 <misc> http://meetbot.mageia.org/
19:51:27 <misc> obgr_seneca: yeah
19:51:32 <cfrussen_RO_team> you translate, you test then you submit
19:51:46 <wobo> cfrussen_RO_team: no
19:52:12 <obgr_seneca> misc: expmanation in the German case: #mageia-de is a general discussion and support channel for the coming German mageia users
19:52:25 <Remmy> I'd say we should use i18n for translation meetings... and the ones without perhaps are better suited for user targeted channels and communities
19:52:32 <obgr_seneca> #mageia-i18n-de is a channel dedicated for the German translation team
19:52:44 <Jehane> for french team, #mageia-fr is used for general discussion
19:52:46 <ajunior> wobo, #mageia-i18m-code is correct... I think
19:52:59 <Jehane> #mageia-i18n-fr for french translation team
19:53:14 <cfrussen_RO_team> wobo, why no?
19:53:19 <wobo> I will post a message about that on the i18n mailing list
19:53:23 <misc> well, that sound logical indeed, so am i too psychorigid to ask for some standard to follow ?
19:53:51 <wobo> cfrussen_RO_team: pls read backwards in teh mailing list discussion about workflow
19:53:57 <Remmy> misc: For the meetbot, I think you're right.... ru and tr should use i18n versions instead.
19:54:34 <Jehane> misc: you are psychorigid some times but I agree with you on this point
19:55:00 <numand> For tr, we have only #mageia-tr channel but I will create a new channel named #mageia-i18n-tr.
19:55:40 <wobo> #action wobo will write a mail in teh i18n mailing list about naming conventions
19:56:10 <wobo> More "Other"?
19:56:29 <cfrussen_RO_team> OK, so who can create the channel #mageia-ro ?
19:56:40 <numand> İf so, do we have to transport old logs to new channel?
19:56:55 <misc> numand: well that's quite easy to do
19:56:56 <wobo> wait!
19:57:10 <misc> numand: but first see if this is needed :)
19:57:27 <numand> misc, ok, thanks.
19:57:32 <wobo> #mageia-ro would be for general mageia discussions in your language - no meetbot needed
19:57:44 <cfrussen_RO_team> right
19:58:06 <ajunior> misc, mediawiki... installed?
19:58:08 <wobo> #mageia-i18n-ro would be for meetings of the romanian translation team - meetbot advised
19:58:26 <cfrussen_RO_team> then we'll create a subchannel per need (translation, dev, ...)
19:58:47 <misc> ajunior: not yet
19:58:53 <wobo> cfrussen_RO_team: depends on you
19:58:55 <cfrussen_RO_team> wobo: yes, right
19:59:15 <Remmy> I just want to apologise in case I should come across as being obnoxious. Though I might have an opinion or tons of questions on almost any topic discussed, I'm actually not too bad in RL :)
20:00:18 <wobo> We all know how to whip people who become too noisy - don't sweat, your ok :)
20:00:37 <Remmy> lol, phew
20:00:53 <cfrussen_RO_team> I thnik we must have as much communications channels as we can afford to help users getting to us
20:00:57 <obgr_seneca> wobo: you mean "just wait till they propose sth. and give them work"?
20:01:10 <wobo> obgr_seneca: that's the scheme
20:01:40 <obgr_seneca> I should have known you long enough...
20:01:47 <Remmy> lol
20:02:21 <wobo> Well, wehnever in mandrivauser.de offers an idea, my answer may be: ok, do it!
20:03:11 <wobo> Sorry for the typing, my flue/fever is getting in my way
20:03:44 <wobo> Anything else? Last round Gentlemen & Ladies, pls!
20:03:49 <cfrussen_RO_team> I wish you fasssst recovery
20:03:49 <Jerzy> HTML pages are translated into Polish and sent to ML, but not committed to the server, except one - Epoll
20:04:03 <wobo> obgr_seneca: ?
20:04:18 <obgr_seneca> I commited everything I got
20:04:34 <obgr_seneca> Jerzy: you meant: epoll is commited but not the rest?
20:04:45 <Jerzy> right
20:04:56 <obgr_seneca> teh rest is rda's job I think, or damsweb's?
20:05:05 <misc> well, i think rda is working on a better system to handle translation of the web site
20:05:15 <wobo> good!
20:05:19 <misc> now, I have no idea of the system to be used
20:05:34 <wobo> Any system will be better :)
20:05:38 <misc> and I think he didn't yet pass the planning stage, as we received no request on sysadmin side
20:06:12 <wobo> obgr_seneca: can you ask in next webteam meeting?
20:06:27 <obgr_seneca> can do
20:06:42 <Remmy> Any system would be an improvement over the current one :)
20:07:19 <misc> I can think to some system worst , ask ennael about "lealinux" :)
20:07:27 <wobo> Simple description how we did it some years back:
20:08:21 <Remmy> misc: Where does her nick come from anyways? I thought it is "Le Anne" backwards, but shouldn't that be "La" then?
20:08:31 <wobo> Gaël or Kdjo sent a diff of the changes to the translator mailing list, people scp'd the page, changed it and scp'd it back - done
20:08:32 <misc> Remmy: ask her :)
20:09:50 <wobo> Can I end the meeting?
20:09:50 <Remmy> wobo: diff's would work for me
20:10:04 <misc> ok for ending for me
20:10:09 <ajunior> that's ok for me
20:10:24 <Jacendb> agree
20:10:29 <cfrussen_RO_team> OK for ending
20:10:33 <Qilaq> OK
20:10:33 <wobo> #endmeeting