18:35:48 <Akien> #startmeeting
18:35:48 <Inigo_Montoya> Meeting started Tue Jun  7 18:35:48 2011 UTC.  The chair is Akien. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:35:48 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:35:53 <Akien> #chair Youp3
18:35:53 <Inigo_Montoya> Current chairs: Akien Youp3
18:36:02 <Akien> Bonjour à tous.
18:36:11 <mammig> bonsoir
18:36:25 <Youp3> bonjour
18:36:26 <Akien> Le but de la réunion d'aujourd'hui est de faire le debriefing de ce qui s'est passé durant les neuf derniers mois.
18:36:53 <Akien> Nous allons aborder les différents processus mis en place pour la traduction, en faisant état de leurs défauts et des suggestions d'amélioration.
18:36:58 <Youp3> un bébé qui a grandi ?
18:37:05 <Akien> :p
18:37:29 <Akien> Il serait intéressant de définir plus clairement notre fonctionnement pour repartir sur de bonnes bases vers Mageia 2.
18:37:47 <Akien> Et accessoirement pour pouvoir expliquer facilement nos méthodes aux nouveaux contributeurs qui ne manqueront pas de nous rejoindre.
18:37:51 <Akien> (si si)
18:38:09 <Akien> Voici l'ordre du jour que j'avais proposé dimanche :
18:38:10 <Akien> 1) État des traductions et tâches restantes à accomplir
18:38:10 <Akien> 2) Retour sur les processus de traduction
18:38:12 <Akien> a) Traduction des logiciels (Transifex + SVN)
18:38:14 <Akien> b) Traduction du blog (Etherpad + Wordpress)
18:38:16 <Akien> c) Traduction du site Web (Etherpad + template PHP)
18:38:18 <Akien> 3) Communication interne (ML, wiki)
18:38:20 <Akien> 4) Autres points
18:38:29 <Akien> Je n'y ai pas reréfléchi donc il n'a pas bougé, mais s'il ne vous plait pas on peut le changer :)
18:38:45 <Youp3> c'est bon pour moi
18:38:47 <Akien> (je pensais peut être qu'on pourrait faire la partie 2 avant la partie 1)
18:39:04 <mammig> c'est toi le chef, c'est toi qui décide
18:39:11 <Youp3> vala :)
18:39:44 <Akien> #topic Debriefing – Traduction des logiciels (Transifex + SVN)
18:39:48 <Akien> huhu
18:40:09 <Akien> Bonjour lebarhon
18:40:24 <mammig> pou ma part je ne me suis inscrite sur transifex que très recemment et je n'ai donc pas encore testé
18:40:26 <lebarhon> Bonjour, un peu en retard, désolé
18:40:28 <Akien> on vient de démarrer, et on va parler de la traduction des logiciels via Tx
18:40:41 <Akien> (doléances, suggestions, etc.)
18:40:49 <Youp3> Quelques soucis avec Tx
18:40:56 <mammig> il me semble qu'une fois il avait été question de mettre sur le transifex une espece de doc de test pour ceux qui n'y connaissent rien
18:41:02 <mammig> histoire de se faire la main
18:41:15 <Youp3> 1/ la fonction lock ne fonctionne pas
18:41:34 <Youp3> je n'ai toujours pas ouvert de bug sur ce sujet
18:41:49 <lebarhon> je l'ai vue fonctionner
18:42:03 <lebarhon> j'ai même "locké" abusivement
18:42:13 <Akien> pour ma part j'avoue que je ne sais pas trop si elle fonctionnait ou pas, vu que je peux délocker toutes nos traductions
18:42:20 <Youp3> et moi avec Jehane j'ai vu qu'elle pouvait modifier un fichier que j'avais locké
18:42:45 <lebarhon> Et moi Akien m'a demandé de délocker
18:42:54 <Youp3> que ce soit via la modif en live ou via l'upload de fichier
18:43:06 <Akien> oui, il y a donc probablement un lien avec les permissions de l'utilisateur qui a locké/qui traduit
18:43:13 <Youp3> donc il va falloir revérifier ça
18:44:03 <Akien> #info La fonction de verrouillage des traductions ne semble pas toujours efficace.
18:44:15 <Youp3> Je peux m'en occuper, mais il me faudra de l'aide
18:44:50 <Akien> #action Youp3 s'occupe de rapporter le bug relatif au verrouillage des traductions, mais il faudra au préalable identifier plus précisément le problème (avec l'aide d'autres).
18:44:55 <Akien> bonjour yogilou
18:45:02 * Jehane arrive, désolée pour le retard
18:45:35 <Akien> Jehane, yogilou: on en est au premier point de la réunion (debriefing sur l'utilisation de Transifex), et on a évoqué le problème du verrouillage des trad
18:45:43 <Youp3> 2/ pour le moment le process quand un fichier est modifié sur le dépôt est flou.
18:45:43 <mammig> bonsoir yogilou :)
18:45:49 <Jehane> j'ai pas regardé transifex plus que ça
18:45:57 <yogilou> bonsouir tous
18:46:02 <Youp3> Les dev annoncent des modifs, mais après ?
18:46:42 <Akien> c'est à définir en effet
18:47:03 <Akien> de manière générale, c'est Oliver qui s'est chargé de répercuter les changements des fichiers .pot sur les sources de Tx
18:47:27 <Akien> tout en essayant (parfois sans succès) de ne pas perdre les traductions quand il s'agissait simplement de corrections de typos
18:47:44 <Akien> le manque de synchronisation entre Tx et le SVN est assez gênant
18:48:36 <Youp3> Il faudrait peut-être automatiser le process.
18:48:53 <Akien> ça serait bien en effet
18:49:00 <lebarhon> Les plus apportés par Tx ne sont pas flagrants
18:49:01 <Youp3> Les chaînes modifiées ne sont pas totalement perdues, puisqu'il y a l'historique du dépôt subversion
18:49:15 <lebarhon> on pourrait traduire directement les .pot ?
18:49:55 <Youp3> je suis presque d'accord avec lebarhon. Par contre Tx nous permet de voir l'avancement de la traduction.
18:49:59 <Akien> hum, Tx nous permet tout de même de traduire à plusieurs de mêmes fichiers (en différé, mais ça facilite quand même pas mal une procédure qui devrait sinon passer par des envois de fichier .po par mail)
18:50:06 <Akien> et ça nous donne une vision générale de l'avancement
18:50:29 <lebarhon> jusque là les longues traductions sont rares
18:50:41 <Akien> drakx-net était assez costaud tout de même :)
18:50:47 <lebarhon> en général on termine le .pot commencé
18:51:04 <mammig> mais on ne pourrait pas utiliser tout simplement un forum sur lequel on a un topic par trad à faire et sur lequel on met les trad en pièce jointe ?
18:51:19 <mammig> ca permet de conserver l'historique et de savoir facilement ou on en est
18:51:37 <mammig> enfin d'un autre coté, je ne connait pas transifex
18:51:46 <Jehane> mammig: et qui refait tout le formatage des fichiers derrière ?
18:51:52 <lebarhon> forum ou wiki, pour Mageia 1 on a fini sur le wiki
18:51:58 <mammig> ça a peut etre des fonctionalités très pratiques pour les trads
18:52:20 <Akien> il est clair que pour l'instant nous sommes obligés d'avoir quelque chose en supplément de Tx
18:52:26 <mammig> ben pour le blog, c'est celui qui met en ligne
18:52:37 <Akien> mais je pense tout de même qu'il est intéressant d'avoir Tx comme base
18:52:40 <mammig> je ne sais pas à quoi il ressemble ton formatage de tes doc de transifex
18:52:46 <lebarhon> Tx ne gère pas la relecture
18:52:46 <Jehane> c'est des .po
18:53:00 <lebarhon> autant pour moi
18:53:00 <mammig> et ça ressemble à quoi un .po ?
18:53:10 <stef74> a rien!
18:53:12 <Youp3> c'est un fichier texte
18:53:13 <mammig> ca ades balises genre html ?
18:53:18 <Jehane> à du texte avec des balises
18:53:29 <stef74> ca ressemble a mes fesses?
18:53:33 <mammig> ben si c'est juste un fichier texte avec des balises, il suffit de trad dans les balises
18:53:51 <mammig> juste remplacer l'anglais par le français
18:53:57 <mammig> comme on a fait avec les trucs php
18:54:02 <Jehane> mammig: il y a des outils d'éditions spécifiques pour les .po, c'est bien que c'est nécessaire
18:54:23 <Akien> prenons la question autrement
18:54:30 <Akien> quel avantage aurait-on à ne pas utiliser Tx ?
18:54:36 <Jehane> aucun
18:54:58 <Akien> c'est aussi mon avis
18:54:59 <lebarhon> pour les commiters
18:55:26 <Akien> Tx manque cruellement de fonctionnalités, mais si nous pouvons les satisfaires à l'aide d'un autre outil (comme le Wiki ou la ML), ça nous donne une base déjà appréciable.
18:55:59 <lebarhon> si tx ne vérouille pas, c'est dangereux
18:56:03 <Akien> en tant que commiter, je préfère récupérer le fichier sur Tx dont je sais qu'il est à la dernière version que d'attendre qu'un fichier ait terminé son ping pong par mail entre les différents relecteurs
18:56:07 <Akien> lebarhon: je sais d'accord
18:56:11 <Akien> s/sais/suis/
18:56:11 <mammig> mais actuellement, c'est quoi transifex ? une espece de traitement de texte en ligne pour des .po ? ou ça sert à autre chose ?
18:56:44 <Akien> mammig: c'est a peu près ça. ça te présente la chaîne en anglais, tu traduis en français en regard.
18:57:09 <Akien> et il y a certaines fonctionnalités comme le verrouillage (bien qu'il semble y avoir un problème dans notre version)
18:57:20 <yogilou> cela permet de garder en mémoire les chaines déjà traduites : il les repropose
18:57:36 <Akien> globalement ça présente le même intérêt pour la traduction de po que Etherpad pour la traduction du blog je trouve
18:57:44 <lebarhon> je n'ai pas constaté cela
18:57:51 <Akien> ça permet un travail collaboratif sans trop se prendre la tête
18:58:24 <Akien> lebarhon: j'ai eu cette fonctionnalité en effet pour les chaînes qui avaient été supprimées quand on a remplacé "Mandriva" par "Mageia" dans les fichier .pot
18:58:28 <yogilou> là il s'agissait d'une première traduction, donc le phénomène mémoire ne s'est pas produit j'imagine
18:58:39 <Akien> Tx me reproposait tout seul la chaîne d'avant (avec "Mandriva")
18:59:18 <lebarhon> j'ai rencontré des chaines identiques, j'ai fait un copier/coller de mémoire
18:59:43 <lebarhon> il y a un truc que je ne sais pas utiliser ?
18:59:55 <Akien> J'ai une question d'ordre général sur la réunion : est-ce que vous souhaitez qu'on soulève les problèmes et qu'on les résolve, ou que l'on fasse une liste de nos problèmes/suggestions/doléances pour pouvoir orienter le débat de nos prochaines réunions ?
19:00:37 <Akien> plus concrètement, est-ce que l'on cherche à définir maintenant un process viable, ou est-ce que l'on constate que le process et moisi et que l'on commence à en débattre sur la ML en attendant la prochaine réunion ?
19:00:48 <Akien> (parce que le temps passe vite en fait)
19:01:16 <mammig> ben deja dire que le process est moisi est une bonne chose
19:01:19 <lebarhon> pour le débat de fond, la ML est mieux
19:01:32 <mammig> ensuite on ne va pas forcement trouvé une autre solution dès ce soir
19:01:41 <Akien> #info Tx seul n'est pas suffisant pour les traductions (manque de fonctionnalités, comme le suivi des relectures, etc.)
19:01:52 <mammig> on va peut etre tester plusieurs trucs avant de trouver le bon
19:02:19 <lebarhon> Tx permet les annotations, mais cela n'est pas utilisé, une raison ?
19:02:38 <Akien> lebarhon: probablement parce que l'on ne sait pas encore trop comment les utiliser
19:02:42 <Akien> c'est à creuser
19:02:55 <Akien> j'avoue que personnellement j'ai cherché à aller au plus direct pour les traductions, comme on était pressés
19:02:57 <lebarhon> ca pourrait servir aux relectures
19:03:05 <Youp3> Le truc de Tx qui ne fonctionne pas et qui est dommage au moins pour Akien et moi-même c'est le système de notification
19:03:35 <lebarhon> c'est à dire ?
19:03:48 <Youp3> car pour savoir qu'un fichier a vu sa traduction modifiée et qu'il faut potentiellement le pousser sur le dépôt, cela peut être bien
19:03:48 <yogilou> de meme que l'utilisation des fils RSS qiui est à mettre en oeuvre
19:04:25 <Akien> jusqu'à maintenant j'ai utilisé la date de dernière modification, en sachant à quelle date j'avais commité
19:04:30 <Akien> mais en effet c'est un peu archaïque :)
19:04:35 <Youp3> c'est une alternative en effet yogilou
19:04:37 <mammig> des rss pour dire quoi ? on n'a pas deja assez de trucs pour communiquer avec irc et la mailing list ?
19:05:15 <Akien> mammig: pour dire: "La traduction de bidule.po a été modifiée. Il faudra donc la commiter un jour ou l'autre sur le SVN."
19:05:15 <Youp3> si c'est automatisé mammig, c'est mieux non ?
19:06:01 <yogilou> cela permet de savoir si qq a touché un fichier et qui
19:06:09 <Akien> #action Sur la ML : lister les fonctionnalités inexploités/non implémentées dans notre Tx (mais présentes upsteam, pour faire part de nos doléances aux sysadmins)
19:06:12 <Jehane> et demander aux admins ?
19:06:24 <Jehane> (leur opinion sur comment faire)
19:06:25 <mammig> ben si 1à trads travaillent sur des doc differents, ca risque d'etre dur à suivre...
19:06:48 <mammig> 10*
19:06:48 <Akien> #action Sur la ML : définir un processus de traduction qui nous permette de compléter les manquements de Tx (ou proposer une alternative viable sans Tx)
19:07:07 <yogilou> ou mieux documenter tx
19:07:43 <yogilou> j'ai bcp appris à fréquenter les traducteurs  de fedora
19:08:11 <Akien> je pense que notre instance de Tx est beaucoup plus limitée que ce qu'elle pourrait être
19:09:11 <Akien> c'est pour ça qu'il peut être intéressant de comparer avec le Tx de Fedora par exemple pour voir quelles sont les fonctionnalités absentes, et demander aux sysadmins si elles peuvent être implémentées
19:09:34 <lebarhon> SVP, on continue Tx sur la ML ?
19:09:40 <Akien> ça me va
19:10:10 <Akien> #topic Debriefing – Traduction du blog (Etherpad + Wordpress)
19:10:31 <yogilou> j aime bien l utliser
19:10:37 <Akien> Personnellement je trouve que ça marche assez bien, même si ça sera mieux quand Youp3 aura son compte Wordpress.
19:11:05 <yogilou> historique des modif et collaboration + chat en direct = OK
19:11:22 <Youp3> j'ai fait une relance à ce sujet cette semaine. Akien : tu étais en copie si je ne me suis pas raté
19:11:31 <Akien> Youp3: j'ai vu oui.
19:12:01 <yogilou> cela fait longtemps maintenant que la demande en ai faite
19:12:12 <Akien> oui, on a pas eu de réponse de Damien.
19:12:23 <mammig> oui, j'aime bien moi aussi etherpad
19:12:24 <Akien> j'essaierais de lui en parler sur IRC s'il ne donne pas suite à la relance.
19:12:40 <Akien> Bon, pour ce topic on peut considérer que le process est OK ?
19:12:45 <Youp3> pour etherpad
19:13:03 <Youp3> Je n'ai pas compris la récente polémique sur la double traduction
19:13:03 <mammig> juste une remarque
19:13:15 <mammig> c'est pas une polémique
19:13:22 <yogilou> moi non plus
19:13:24 <mammig> juste qu'avec julia nous avions fini une trad
19:13:25 <Akien> ah, je n'ai pas suivi ça
19:13:36 <mammig> mis un message sur la ML fr pour dire qu'il fallait le relire
19:13:43 <mammig> et visiblement ce message n'a pas été lu
19:13:54 <mammig> et d'autres personnes ont commencé à trad la meme chose
19:14:09 <mammig> http://piratepad.net/2uiyfORWSm
19:14:35 <mammig> suffit d'aller là et de regarder le chat
19:14:46 <Youp3> justement, le process est clair : création du bloc note piratepad puis annonce de ce dernier sur la ml française
19:15:05 <Youp3> et pour moi ce process a bien été suivi
19:15:06 <lebarhon> On ne peut toujours pas utiliser le chat de Etherpad ?
19:15:27 <mammig> ben oui, mais une 20 trad a quand meme ete commencé
19:15:28 <Youp3> donc le fautif est celui qui n'a pas suivi la ML avant de commencer sa trad
19:15:28 <Jehane> peut-être parce que le message était urgent que anne n'est pas sur la liste des trads fr
19:15:35 <Jehane> +et
19:16:20 <mammig> enfin le pb est surtout d'eviter que ce genre de chose se reproduise
19:16:42 <mammig> pas de savoir qui est coupable ni pourquoi et patati et patata
19:17:27 <mammig> pas de savoir qui est coupable ni pourquoi et patati et patata
19:17:34 <Akien> excusez-moi, je viens d'avoir un crash de mageia en bonne et due forme
19:17:39 <Youp3> Ce que j'ai vu c'est un reproche qu'aucune annonce n'avait été faite sur la liste internationnale. Or le travail français doit uniquement utiliser la ML française
19:18:01 <mammig> oui aussi, sur le chan de i18n
19:18:07 <lebarhon> Pas fiable Mageia :)
19:18:13 <Youp3> c'est bien défini sur le wiki
19:19:07 <mammig> hors effectivement, si chaque team commencait à dire sur i18n "je commence à trad ca", "j'ai fini faut relire","j'ai relu je passe au voisin" pour chaque document... on ne s'en sort pas
19:19:07 <Youp3> pour moi le moyen de communication prioritaire doit être la ML
19:19:16 <Akien> bon, je n'ai pas suivi toute l'intrigue mais en gros c'était un malentendu ?
19:19:24 <Youp3> car IRC n'est pas toujours accessible suivant où l'on se trouve
19:19:29 <mammig> je pense oui, un malentendu
19:19:33 <mammig> ou une précipitation
19:19:41 <Akien> Youp3: je confirme, toujours prévenir sur la ML
19:20:03 <Akien> pour donner le lien notamment, que l'on ne commence pas deux traductions à deux endroits différents
19:20:32 <lebarhon> quel problème avec le chat de Etherpad ?
19:21:01 <Youp3> de mon côté je n'en ai pas vu
19:21:01 <yogilou> le lien de traduction avait ete donné dès le départ
19:21:35 <Akien> sur IRC si j'ai bien compris ?
19:21:47 <Youp3> non, sur la ML fr
19:21:49 <Akien> parce que le lien donné par mammig n'apparaît pas sur la ML
19:21:54 <Akien> ah ?
19:21:56 <mammig> oui dans le mail signalant une nouvelle trad à faire si je me souvient bien
19:22:10 <mammig> non, c'est celui de la 2° trad
19:22:37 <Akien> bon, vous m'expliquerez plus tard :)
19:22:39 <Akien> on passe à la suite ?
19:22:49 <mammig> http://bn.parinux.org/mageia1 => donné dans la mailing liste
19:23:02 <lebarhon> Pourquoi ne pas utiliser le chat d'Etherpad ?
19:23:11 <mammig> l'autre est celui que d'autre on commencé après
19:23:12 <Akien> personnellement je l'utilise
19:23:21 <Akien> il est logué, donc tous ceux qui participent à la traduction peuvent le lire
19:23:22 <Youp3> il a été utilisé dernièrement lebarhon
19:23:36 <lebarhon> la consigne est d'utiliser IRC
19:23:42 <Akien> quelle consigne ?
19:23:56 <Youp3> c'est vrai que c'était une consigne
19:24:06 <Youp3> je pense qu'il faut la modifier
19:24:08 <mammig> quand c'est possible
19:24:19 <Akien> ah peut être
19:24:31 <yogilou> IRC ce n'est pas tjs possible dans tous les cas ....
19:24:32 <Akien> je pense qu'il faut utiliser prioritairement le chat d'etherpad
19:24:40 <Akien> et si on veut, on peut utiliser IRC en supplément
19:24:46 <mammig> et la 2° trad a été commencé sur i18n ( et non sur i18n-fr )
19:24:49 <lebarhon> Il a été demandé ne pas utiliser le chat d'Etherpad parce qu'il ne fonctionne pas, or je constate que certains l'utilise
19:25:00 <Youp3> d'accord avec Akien
19:25:12 <lebarhon> OK
19:25:15 <Akien> ah peut être qu'il ne marchait pas quand on utilise PiratePad
19:25:22 <Akien> avec le bloc notes de Parinux ça semble pas mal
19:25:37 <Youp3> donc favoriser parinux :)
19:25:39 <yogilou> cje trouve cela très pratique
19:26:14 <Akien> #info Les discussions "live" sur une traduction en cours doivent se faire de manière prioritaire sur le chat d'EtherPad, s'il fonctionne. Dans le cas contraire, se rabattre sur IRC.
19:26:20 <Akien> nouvelle consigne :)
19:26:43 <Akien> (je sais pas si je suis toujours chairman par contre)
19:26:44 <Akien> #chair
19:26:44 <Inigo_Montoya> Current chairs: Akien Youp3
19:26:46 <Akien> ah si
19:26:55 <Akien> on passe au topic suivant ?
19:27:02 <mammig> oui chef
19:27:05 <Youp3> non, pas sur etherpad mais sur parinux
19:27:10 <Youp3> ;)
19:27:21 <Akien> Youp3: EtherPad est le nom du logiciel, Parinux est le site :)
19:27:31 <Youp3> oups :p
19:27:45 <Akien> #url bn.parinux.org
19:27:53 <Akien> (je crois)
19:27:55 <Akien> #topic Debriefing – Traduction du site Web (Etherpad + template PHP)
19:28:15 <Akien> J'ai déjà deux points à évoquer :
19:28:31 <Akien> 1) Ce système de traduction est un peu complexe et est appelé à changer (l'équipe Web y réfléchit)
19:28:35 <Youp3> attention au \' ?
19:28:44 <Akien> 2) Je n'ai pas été assez clair dans mes instructions pour la traduction du template PHP
19:29:08 <Akien> Il y a en effet certaines règles à connaître, propres au langage de programmation, ou à HTML.
19:29:19 * Youp3 se propose de fouetter Akien ^^
19:29:42 <Akien> #action Akien va rédiger une page sur le wiki pour expliquer les règles de la traduction des template PHP.
19:30:12 <mammig> avec tous les trucs des \ avant '
19:30:18 <mammig> les espace insécables et tout
19:30:34 <mammig> et qu'il ne faut pas trad les label et les array :)
19:30:35 <Akien> (notamment, échapper les apostrophes (ou utiliser de vraies apostrophes et pas des single quotes), ne pas traduire les labels, faire attention à laisser une single quote en début et en fin de chaîne, et une virgule ensuite, etc.
19:30:47 <mammig> :)
19:31:11 <Akien> j'ajouterais quelques trucs intéressants à connaître en HTML (&nbsp; pour un espace insécable, etc.)
19:31:11 <neggwada> Slt people
19:31:25 <Akien> bonsoir neggwada
19:31:25 <yogilou> salut mehdi
19:31:49 <neggwada> Akien quelles differences entre vraie apostrophe et signe quote stp?
19:31:57 <Akien> Sinon, pour le système actuel, ça vous va d'utiliser toujours EtherPad ?
19:32:12 <mammig> moi oui, j'aime bien
19:32:20 <Youp3> pour les gros fichiers oui.
19:32:27 <mammig> pas très lisible le php dans etherpad
19:32:29 <lebarhon> On ne va pas changer de suystème à chaque fois
19:32:32 <neggwada> Etherpad est largement suffisant pour moi aussi
19:32:39 <mammig> mais je trouve qu'etherpad est sympa comme truc
19:32:52 <yogilou> si Akien nous fait un beua copier collé dansetherpad de Parinux on a tout de suite les balises et les signes , non ?
19:33:08 <mammig> on peut facilement papoter avec les autres qui trad en meme temps que nous
19:33:26 <Akien> neggwada: je ne suis pas sur à 100% mais je crois qu'on est censés utiliser l'apostrophe typographique (’ - pas facile à trouver sur un clavier non BÉPO) et non pas l'apostrophe droite (' - touche 4 du clavier AZERTY)
19:33:35 <yogilou> nous avon sjuste à les respecte comme telles...
19:33:48 <Akien> voilà, il faut y faire attention
19:34:18 <Akien> je verrai avec misc si on peut récupérer son script qui teste la mise en forme
19:34:26 <Akien> (pour vérifier qu'on a pas oublié d'échapper une apostrophe, etc.)
19:34:34 <lebarhon> Il faut écrire un nouveau driver pour le clavier
19:34:35 <misc> le script qui fait php -l ?
19:34:40 <Akien> voilà :p
19:34:44 <neggwada> Et sur un clavier non bepo quelqu un connait la combinaison de touche ?
19:35:24 <neggwada> Sinon un *vrai* parseur php
19:35:39 <Akien> topic suivant ?
19:35:44 <lebarhon> Etherpad ne saurait pas modifier les apostrophes et ajouter les /, etc...
19:36:04 <Akien> attention, ce sont des antislash \ qu'il faut ajouter
19:36:19 <lebarhon> en plus tu chipotes
19:36:57 <mammig> c'est pas lui qui chipote, c'est php ;)
19:37:11 <lebarhon> je lui dirait
19:37:13 <Akien> #topic Communication interne (ML, wiki)
19:37:22 <Akien> je sais plus trop pourquoi j'ai prévu ce topic :p
19:37:42 <Akien> le wiki n'est pas utilisé de façon optimale, mais j'ai du mal à me motiver pour l'améliorer tant qu'il est temporaire
19:37:47 <lebarhon> Est ce que le Wiki français avance ?
19:37:57 <yogilou> hors sujet mais : on réfléchit à, quoi pour traduire la doc, quand elle sera faitre ?
19:38:16 <Youp3> pas de date de sortie pour le wiki définitif
19:38:27 <Akien> lebarhon: pas pour l'instant, mais je pense qu'il est sage d'attendre le wiki définitif pour commencer à traduire, car les pages temporaires vont sûrement changer
19:38:36 <Youp3> je suis d'accord
19:39:18 <mammig> le wiki temporaire existe depuis deja un certain temps il me semble et je crois que nous n'avons pour le moment aucune info sur le wiki definitif
19:39:31 <mammig> j'espère que nous n'allons pas avoir du provisoire qui dure
19:39:33 <Akien> yogilou: j'ai entendu parler de Pootle
19:40:07 <Akien> je poserai la question lors de la réunion i18n, je crois qu'il était prévu à la base qu'on ait un autre outil en ligne comme Tx (à savoir Pootle) pour les traductions de doc
19:40:28 <Akien> mais ça va faire l'objet de discussion sur la ML i18n prochaînement je pense
19:40:39 <yogilou> oui mais pas vraiment regardé car mmisc a dit =difficile à installer ou à configurer ?
19:40:43 <Akien> pour Tx on a pas eu trop le choix parce qu'il fallait vite mettre en place quelque chose, mais là on a un peu plus le temps de se retourner
19:40:49 <Akien> ah c'est possible
19:42:07 <Akien> Pour ce qui est de la communication en général, des remarques ?
19:42:08 <yogilou> pour le wiki temporaire ce serait bien d'avoir une arborescence depuis la racine.... je n'ose pas m'en charger trop ignorante des choses dokuwi que je suis
19:42:43 <Akien> yogilou: c'est vrai, mais j'avoue que j'ai du mal à me motiver pour faire tout ce travail dans le wiki temporaire
19:43:06 <Akien> j'ai plutôt tendance à me dire qu'une fois le wiki définitif mis en place, on pourra se réunir pour discuter d'une structure globale à donner à notre partie du wiki
19:43:19 <Akien> pour structurer nos process / tutos / outils
19:44:15 <Akien> (après il faudra voir si on aura le droit d'utiliser le Wiki comme outil pour nos traductions ou s'il devra rester statique avec des tutos, des process, mais pas de contenu dynamique)
19:44:44 <lebarhon> pourquoi pas 2 wikis
19:44:45 <misc> ( perso, je pense que le wiki est pour tous, ensuite, faut pas que ça parte en bordel )
19:45:17 <Akien> oui, je pense qu'on pourra faire une belle partie statique que tous les curieux pourront voir comme référence quant à la traduction de Mageia
19:45:19 <lebarhon> J'espère que Skiper sera de retour, il est génial pour maintenir un wiki
19:45:52 <Akien> et avoir quelques pages plus utilitaires, que les curieux pourront toujours regarder s'ils le souhaitent, mais qui seront plus destinées à notre équipe
19:46:10 <Youp3> je ne comprends pas trop ce que vous entendez par dynamique et statique pour le wiki
19:46:36 <lebarhon> archives dormantes ou données en évolution
19:46:42 <Akien> par statique, j'entends des pages dont le contenu ne va pas vraiment varier : des tutoriels, des process, etc.
19:46:58 <Akien> par dynamique, c'est plus des pages comme ce qu'on a utilisé pour la traduction des fichier .po
19:47:12 <Youp3> Ok
19:47:22 <Akien> mieux structurées probablement, mais pour indiquer l'évolution de notre travail si nos outils (Tx et Pootle ou autre) ne sont pas suffisants pour ça
19:48:15 <Akien> sinon j'ai une question : Est-ce que tout le monde suit la liste i18n ?
19:48:30 <lebarhon> oui
19:48:38 <Akien> (je n'ai pas prévu de châtiment corporels pour ceux qui répondraient que non, ne vous inquiétez pas ^^)
19:48:44 <Youp3> non
19:48:52 <mammig> je la suis de loin, et de beaucoup plus pres celle de i18n-fr avec les trad à faire
19:48:53 * Youp3 plaisante, bien sûr
19:49:07 * Akien souffle un bon coup.
19:49:10 <Akien> :p
19:49:49 <Akien> bon, même si on doit être beaucoup à la suivre (et c'est important), je pense qu'il est bien de continuer à relayer les infos utiles pour nous sur la ML i18n-fr
19:50:01 <Akien> du genre: "nouvelle traduction à faire", etc.
19:50:09 <mammig> oui oui :)
19:50:09 <misc> oui, c'est l'idée d'avoir des couches
19:50:18 <Akien> misc: comme les oignons ?
19:50:38 <Akien> par contre n'hésitez pas à relayer l'info avant moi si vous la voyez plus tôt
19:50:49 <yogilou> Oui
19:50:55 <mammig> ok
19:51:03 <yogilou> j'avoue ne l'avoir jamais fait..
19:51:11 <mammig> moi non plus
19:51:54 <Akien> en gros, pour l'exemple des template PHP, il faut faire un copier coller du contenu envoyé par Oliver dans un EtherPad, et nous envoyer le lien sur la ML.
19:52:15 <yogilou> oui tout le monde peut le faire
19:52:53 <Akien> Encore une fois n'hésitez pas à envoyer des mails sur i18n-fr pour débattre de diverses choses, comme ce qui vous déplait dans le process actuel, etc.
19:53:26 <Akien> on fait un bref état des lieux de nos traductions pour terminer ?
19:53:44 <Akien> #info Toujours pas de date pour le wiki définitif.
19:53:57 <yogilou> Certes, mais ne pas oublier de proposer des solutions ou des alternatives, histoire de se montrer constructif ou positif
19:54:06 <Akien> #info Utiliser la ML i18n-fr pour relayer les informations qui nous concernent de la ML i18n.
19:54:16 <mammig> Assistance => http://www.mageia.org/fr/support/
19:54:20 <Akien> yogilou: tout à fait
19:54:25 <mammig> " You can follow this hardware requirements list:"
19:54:32 <mammig> j'avais vu ça
19:54:42 <mammig> l'autre truc était pour la page de chargement
19:54:50 <mammig> ha oui d'ailleur
19:55:15 <Akien> mammig: une seconde, je change le topic :p
19:55:24 <Akien> #topic État des traductions et tâches restantes à accomplir
19:55:29 <Akien> voila :)
19:55:54 <mammig> dans certain navigateur le menu du haut est trop long et du coup les dernière lettre sont masquée par la liste de déroulante du choix des langues
19:56:16 <mammig> j'ai fait un rapport de bug et le plus simple serait de "raccourcir" un peu le menu
19:56:29 <mammig> je suggere de remplacer "telechargement" par "chargement"
19:56:51 <Akien> mammig: enfin la solution décrite par rda est plutôt de changer complètement ce système de menu, ce qui sera fait prochainement
19:56:57 <lebarhon> dans quelle page dite vous?
19:57:01 <Akien> on y perdrait à changer "Téléchargement" pour "Chargement"
19:57:16 <yogilou> oui c'est le terme compris par tous
19:57:32 <mammig> prochainement, c'est dans un avenir dont la date est indéterminée mais bon
19:57:42 <Akien> lebarhon: c'est un problème sous certains navigateurs, le menu horizontal en haut des pages du site www.mageia.org est parfois coupé par la liste déroulante pour changer de langue
19:58:49 <lebarhon> heu, je n'ai pas de menu déroulant...
19:58:50 <Akien> mammig a compilé un bon nombre de petites modifications à faire ou de bugs à corriger dans un mail envoyé récemment (en réponse au mail pour prévenir qu'on aurait une réunion ce soir)
19:59:01 <Akien> pour changer de langue ?
19:59:28 <Akien> Il y a : Mageia | Blog | Téléchargements | Assistance | Forum | Contribuer | Wiki | Dons | À propos puis Français dans un menu déroulant normalement
19:59:51 <lebarhon> Mille excuses, j'étais sur le blog, OK merci
20:00:53 <lebarhon> Firefox 4 coupe A propos
20:01:04 <Akien> ah, chez toi aussi
20:01:09 <lebarhon> oui
20:01:10 <Akien> alors que chez moi Firefox 4 ne coupe rien
20:01:12 <mammig> bha non, celui de Akien ne coupe pas
20:01:21 <Akien> ça dépend peut être de la résolution d'écran ?
20:01:22 <mammig> t'es 4.0.1 Akien
20:01:28 <Akien> vous avez quelle résolution ?
20:01:34 <lebarhon> si je dézoom, c'est bon
20:01:36 <Youp3> ça ne coupe pas chez moi
20:01:43 <mammig> konqueror ne coupe pas
20:01:45 <Akien> je pense que c'est une histoire de largeur d'écran tout simplement
20:01:55 <lebarhon> 1600x ??
20:02:01 <Akien> moi j'ai 1280x800
20:02:07 <Akien> ah
20:02:10 <mammig> atta
20:02:10 <Akien> ça confirme pas la théorie :p
20:02:20 <mammig> la largeur de la partie texte est fixe
20:02:34 <Youp3> si tu diminues la largeur de la fenêtre, cela ne coupe pas Akien
20:02:47 <lebarhon> 1920x1080, ça coupe suivant le zoom
20:03:08 <Youp3> donc c'est l'utilisation du zoom le problème
20:03:11 <Akien> moi ça ne coupe qu'en dézoomant à mort, ou en rendant la page toute petit en largeur
20:03:14 <Akien> *petite
20:03:42 <lebarhon> Affichage/zoom/normal ne coupe pas
20:03:51 <Akien> ça vous va si on essaie de trouver une solution à ce bug après la réunion (qui est bientôt terminée) ?
20:03:57 <Akien> comme ça ceux qui veulent aller faire autre chose le pourront
20:04:20 <Youp3> oui
20:04:26 <mammig> quand j'agrandi le logo de mageia est tout pixélisé
20:04:42 <Akien> c'est normal ça c'est un zoom numérique, pas optique :p
20:04:53 <mammig> et je ne suis plus coupée dans le menu
20:04:56 <Akien> Donc, où en sommes-nous des traductions ?
20:05:03 <Akien> - Blog : à jour.
20:05:22 <Akien> - Site : quelques corrections d'erreurs relevées par mammig
20:05:31 <Akien> et certaines pages qui ne sont pas traduites du tout, mais ne peuvent pas encore l'être
20:05:35 <yogilou> mageia est tout pixélisés: utiliser du svg ?
20:05:57 <Akien> (le système de template PHP doit encore être mis en place pour ces pages)
20:06:10 <Akien> sinon, pour toutes les traductions qui peuvent être mises en ligne, nous sommes à jour.
20:06:32 <Akien> - Logiciels : tous traduits à 100% si je ne m'abuse ?
20:07:09 <mammig> en gros, on est en vacances :)
20:07:32 <Akien> (par contre, il est possible que certaines traductions n'aient pas été prises en compte dans Mageia. En effet pour qu'elles soient prises en compte, une fois mises sur le SVN, il faut que les packageurs fassent une nouvelle release du paquet concerné. Et ça n'a pas été fait pour tous les paquets)
20:08:05 <Akien> on en parlera probablement à la réunion i18n de jeudi, mais la communication avec les packagers n'a pas été optimale
20:08:28 <Akien> on a un peu été oubliés dans le process de la release :p
20:09:02 <Akien> Voila, donc pour nos traductions c'est pas mal :)
20:09:08 <Akien> S'il y en a qui s'ennuient, vous pouvez :
20:09:15 <lebarhon> Bravo Akien :)
20:09:41 <Akien> - relire les traductions existantes, car il y a des erreurs (notamment dans la traduction des release notes, j'ai repéré quelques corrections typographiques à faire, mais je n'ai pas encore tout relu)
20:10:21 <Akien> - commencer à traduire les pages qui ne peuvent pas encore être localisées, pour qu'il ne reste qu'à copier coller les paragraphes traduits au bon endroit dans les templates PHP
20:10:32 <Akien> (bien que cela engendre une légère perte de temps du coup)
20:11:01 <Akien> #info Nous sommes à jour dans tout ce qui peut l'être, à peu de choses près.
20:11:10 <lebarhon> Est ce qu'on se donne un lexique ?
20:11:12 <Akien> #action Relire :)
20:11:22 <Akien> ah, c'est vrai
20:11:27 <Akien> #topic Glossaire anglais-français
20:11:58 <lebarhon> Il y en a un dans le wiki Mandriva
20:12:08 <Akien> mammig avait commencé à en faire un je crois, mais beaucoup de personnes ont suggéré que l'on cherche plutôt un glossaire déjà existant, comme celui de KDE par exemple, ou de Mandriva, pour plus d'efficacité
20:12:30 <Akien> (parce que le libre c'est aussi ne pas avoir à refaire tout le boulot à chaque nouveau projet)
20:12:53 <mammig> on les trouve où les glossaires des autres ?
20:12:55 <lebarhon> Yaka choisir
20:12:55 <Youp3> il me semble que celui commencé ne partait pas de zéro
20:13:30 <Akien> voilà celui de Mandriva : http://wiki.mandriva.com/fr/Table_d%27%C3%A9quivalence_des_termes_anglais/fran%C3%A7ais
20:13:34 <yogilou> j'ai commencé à modifier celui de Mandriva ; puis j'ai arreté et recommencé sur un tableur maison issu de drupa l ou je ne sais plus quoi avec les mots que je rencontre à mes temps perdu ; il faut un outuil facile l
20:14:00 <yogilou> celui de mandriva est bien mais il peut disparaitre ?
20:14:18 <lebarhon> on peut le sauvegarder
20:14:31 <yogilou> il y a aussi ceux recensé sur traduc.org
20:15:28 <Akien> le dictionnaire de KDE: http://fr.l10n.kde.org/dict/
20:15:34 <lebarhon> Est ce qu'il y en a des interactifs ?
20:16:14 <yogilou> et mon préféré car a tendance transversale : http://fr.open-tran.eu/ mais qui n'a pas encore de api avec transifex (dixit les gens de fedora)
20:17:08 <lebarhon> On pourrait peut-etre les tester sur des cas épineux
20:17:30 <lebarhon> upgrade/update  Inline/online flavour...
20:17:50 <Akien> open-trans à l'air pas mal
20:18:17 <yogilou> oui il contient kde mandriva et puis qq autres
20:18:27 <Akien> par exemple: http://fr.en.open-tran.eu/suggest/upgrade
20:18:43 <Akien> il donne des suggestions de traduction avec la liste des endroits où cette traduction est utilisée
20:18:54 <yogilou> il existe : yapuka le faire grandir
20:19:18 <Akien> ça peut être un bon outil oui
20:19:36 <Akien> il faudra voir s'il peut référencer les traductions utilisées dans Mageia aussi
20:19:42 <mammig> bonne fin de réunion et à demain
20:19:52 <yogilou> bonne nuit
20:20:00 <Akien> bonne nuit mammig
20:20:05 <mammig> merci
20:20:11 <Youp3> bn mammig
20:20:15 <Akien> #url http://fr.en.open-tran.eu/
20:21:03 <Akien> #info Open-Tran est un outil qui permet de comparer les traductions dans divers logiciels (libres à ce que j'ai constaté) comme GNOME, les outils d'OpenSUSE, etc.
20:21:46 <Akien> Quelqu'un avait-il un autre sujet à aborder ?
20:22:13 <Youp3> oui
20:22:47 <Youp3> lors de la réunion internationnale à laquelle j'avais assisté, j'avais un point à vous remonter
20:22:57 <yogilou> nous ecoutons
20:23:02 <neggwada> Oui
20:23:16 <neggwada> Rapidement sur les pages de man
20:23:29 <Youp3> il nous est demandé de donner notre avi sur les personnes qui peuvent bénéficier d'une adresse en mageia.org
20:23:36 <neggwada> On s en occupe ?
20:24:19 <Akien> neggwada: après le point de Youp3 oui
20:24:35 <Youp3> des suggestions ont été faites
20:24:46 <Youp3> tous les contributeurs
20:25:01 <Youp3> ceux désignés par les représentants des équipes
20:25:11 <Youp3> juste les représentants des équipes
20:25:20 <Youp3> autres propositions à définir
20:25:40 <misc> les gens aprés un temps de présence ?
20:26:13 <Youp3> par exemple
20:26:41 <Akien> dans quels cas ces adresses seront elles amenées à servir ?
20:27:00 <Akien> il y a l'entête des fichiers po
20:27:03 <misc> c'est principalement cosmétique
20:27:18 <misc> ç'est comme le tabard de guilde dans wow :)
20:27:22 <Akien> héhé
20:27:32 <Youp3> c'est un peu comme le dit misc oui
20:27:49 <Akien> misc: qu'est-ce que ça implique du point de vue technique ?
20:27:50 <Youp3> et donc tu peux ensuite l'utiliser dans ton profil mageia
20:27:53 <Akien> utilisation des ressources, etc.
20:28:04 <misc> Akien: rien
20:28:19 <Youp3> cela masque ton adresse réelle et effectue une redirection vers elle
20:28:26 <misc> voila, un simple alias
20:28:53 <Akien> donc la question est donc de savoir sur quels critères baser l'attribution de ces alias qui reflètent l'image de Mageia
20:29:10 <Youp3> oui
20:29:26 <Akien> je pense qu'il faudrait que ce soit pour des contributeurs "validés"
20:29:26 <misc> je reconnait que c'est pas facile pour l'équipe de traduction
20:29:36 <Youp3> faut-il les distribuer à tous ceux disant participer, ou restreindre aux actifs
20:29:46 <Akien> voilà
20:29:55 <Youp3> ou réduire aux représentants pour ne pas faire de jaloux
20:30:12 <misc> en sachant qu'on retire pas les aliases normalement
20:30:23 <Akien> ah
20:30:33 <misc> ( vu que des gens peuvent s'en servir, et c'est pas sympa de retirer ça en douce )
20:30:59 <Youp3> sauf si cela redirige vers une adresse n'existant plus j'imagine ?
20:31:26 <misc> si l'addresse existe plus, on change l'addresse :)
20:31:39 <Akien> qu'en pensent nos membres actifs ?
20:31:45 <Akien> est-ce que vous voulez un tabard ? :p
20:31:52 <misc> mais bon, l'alias, c'est un peu le seul truc qu'on peut offrir facilement en fait
20:32:34 <yogilou> cela a aussi des visée promotionnelle
20:32:40 <yogilou> de mageia
20:33:29 <Youp3> concernant l'équipe de traduction, j'aime bien l'idée de donner les noms de ceux qui participent régulièrement
20:35:02 <Akien> moi aussi, reste à définir les critères pour savoir ce qu'est "participer régulièrement"
20:36:02 <Akien> mais de toute manière c'est une décision qui devra être prise pour toutes les équipes i18n-blabla donc ça sera probablement débattu jeudi (si on a le temps)
20:36:27 <Youp3> participer aux réunions, participer aux traductions et ce sur une période d'au moins 3 mois par exemple.
20:36:50 <Akien> de manière générale, on s'accorde à dire qu'on veut des alias pour les membres actifs, avec "actifs" à définir ?
20:36:54 <Youp3> les différentes participations ne sont pas toutes obligatoires
20:37:19 <Youp3> oui, l'idée est là
20:37:26 <Akien> on pourra déjà dire ça à la réunion i18n
20:38:00 <Akien> neggwada voulait parler des pages de man, mais il est parti
20:38:02 <Youp3> je ne pourrais pas y assister, car je suis au SSTIC à Rennes les 3 prochains jours
20:38:08 <Akien> ok
20:38:14 <Akien> moi j'y serais, bien qu'en plein partiels :)
20:39:33 <Akien> pour les pages de man, c'est upstream qu'il faut traduire non ?
20:39:40 <Youp3> Pour moi oui
20:39:41 <Akien> à part pour les outils de Mageia peut être
20:39:57 <Akien> je ne sais pas comment fonctionne man pour tout dire
20:40:02 <lebarhon> qui utilise les pages de man ?
20:40:11 <lebarhon> les geeks
20:40:26 <Akien> moi j'utilise --help ^^
20:40:42 <lebarhon> c'est bien ce que je disais, les geeks
20:40:42 <Akien> lebarhon: je suis d'accord, ce n'est pas une traduction prioritaire
20:40:53 * Youp3 doit être un geek alors :p
20:40:59 <lebarhon> Ils parlent tous anglais
20:41:16 <Akien> bah il faut être un peu geek pour utiliser la ligne de commande déjà
20:41:25 <Akien> donc encore plus pour taper man :)
20:41:30 <misc> on peut lire les pages de man dans konqueror
20:41:45 <lebarhon> les super geeks alors
20:41:47 <Akien> pour des outils graphiques ?
20:41:53 <misc> ou les developpeurs
20:42:08 <lebarhon> c'est pareil
20:42:11 <Youp3> les admins système aussi
20:42:27 <misc> parce que bon, faut arreter d'utiliser le terme geek, ça veut rien dire de défini, faut être un minimum clair
20:42:29 * Akien souffle à Youp3 : « C'est le moment de sortir le chocolat. »
20:42:31 <lebarhon> la trad, c'est pour les newbies
20:42:46 <Youp3> fin bref, c'est plutôt upstream
20:42:51 <Akien> ouep
20:42:57 <misc> Youp3: traduc.org gére ça, je crois
20:43:05 <Akien> Fin de la réunion ?
20:43:06 * Youp3 sort les chocolats
20:43:19 <lebarhon> et pas des virtuels
20:43:39 <Youp3> lebarhon: non, non. Des restes de pâques
20:43:48 <Akien> #endmeeting