20:05:14 <papoteur_> #startmeeting
20:05:14 <Inigo_Montoya> Meeting started Mon Jan 22 20:05:14 2018 UTC.  The chair is papoteur_. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:05:14 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:05:44 <papoteur_> #chair lebarhon apb yurchor Kernewes
20:05:44 <Inigo_Montoya> Current chairs: Kernewes apb lebarhon papoteur_ yurchor
20:06:06 <lebarhon> hello docteam
20:06:16 <apb> Hello
20:06:32 <papoteur_> Hello lebarhon
20:06:50 <Kernewes> hello
20:06:55 <papoteur_> which topics today?
20:06:57 <simonnzg> Gorthugher da
20:07:10 <papoteur_> simonnzg: hello
20:07:18 <Kernewes> simonnzg: gorthugher da :)
20:07:18 <simonnzg> Good evening all
20:07:47 <simonnzg> Hi Carolyn. Trying out my Cornish.
20:08:29 <Kernewes> simonnzg: Very good
20:08:41 <papoteur_> I suggest one: managing releases.
20:08:48 <simonnzg> Not sure how Meetbot is going to take this, so what's on the Agenda?
20:09:18 <simonnzg> papoteur_: Is this managing documentation for several releases at the same time?
20:09:55 <papoteur_> We discussed the last time  about collaborative work
20:10:05 <papoteur_> simonnzg: or not ;)
20:10:39 <simonnzg> papoteur_: I doubt that we could do much more than manage the current OR upcoming release
20:10:40 <papoteur_> other topic : apb credentials
20:11:10 <lebarhon> that one is done
20:11:58 <papoteur_> lebarhon: yes, this was only to say that it's OK naw.
20:12:05 <papoteur_> s/now
20:14:19 <papoteur_> #topic managing releases
20:15:15 <papoteur_> I send a mail today which was a reply to a discussion in spring, before Mageia 6 release.
20:17:45 <papoteur_> sorry bbl
20:18:05 <simonnzg> papoteur_: Just been trying to read it
20:20:25 <simonnzg> I remember the conversation now. The way the Calenco directory is structured is that the default text and images are in the root (let's call it the "International" language) and all variants are in named subdirectories.
20:21:00 <simonnzg> That way the default is served if there is no IDENTICALLY NAMED file withe local language conten in the named subdirectory.
20:21:27 <simonnzg> I'm not at all sure how we'd handle more than one version without creating seperate workspaces.
20:22:46 <papoteur_> Coming back, sorry. My question is essentially, do we need to manage release.
20:23:17 <papoteur_> This seems heavy, and I do't know the benefits.
20:23:55 <lebarhon> Suppose Mageia n is released, doc for n+1 is in progress
20:24:19 <lebarhon> and we need to fix a bug on Mageia n
20:24:22 <simonnzg> papoteur_: I would need to get back on Calenco and see what can be done. I'm sure it's a workspace, or maybe publication change that's needed.
20:24:43 <lebarhon> We don't have its doc any more
20:26:04 <papoteur_> What will the be the process to come back on a previous release?
20:26:27 <lebarhon> we can't
20:26:35 <papoteur_> simonnzg: we can do som workpaces.
20:27:05 <simonnzg> lebarhon: papoteur_: I was looking at Workspace Releases to see what is usful there
20:29:29 <simonnzg> http://mageia.calenco.com:8284/docs/2.9.3/user/en/content/help-workspace-versions.html
20:29:30 <[mbot> [ Creating Workspace Releases ]
20:29:34 <simonnzg> That would do it
20:29:46 <papoteur_> simonnzg: yes, but I don't know how to use it.
20:30:11 <simonnzg> It's just like Git. EVERYONE can use Git, surely?? ;)
20:31:34 <Kernewes> I've never used Git.
20:31:58 <lebarhon> you are not the only one :)
20:32:23 <simonnzg> I meant the concept. Simple but wrapped up in a very complex process
20:32:36 <papoteur_> simonnzg: can we with it regenerate all our publications with such a workspace?
20:34:05 <simonnzg> papoteur_: As far as I can see, and I would have to test it, we create a Version, which is a copy of the workspace, that we can switch to it to edit if we need to.
20:35:53 <papoteur_> Thus, we can create ones for Mageia 6, and then play with it to know what we can do.
20:36:22 <papoteur_> Know that pictures are not versionned.
20:36:54 <lebarhon> We said we should version them
20:37:40 <papoteur_> OK
20:38:25 <lebarhon> but we didn't find how
20:38:42 <simonnzg> Only problem is that old versions are not editable, but at least we can get at the data. I don't know if we can create new workspaces. I can't but maybe someone can?
20:39:38 <lebarhon> I think I can and papoteur_also
20:40:02 <simonnzg> Someone created a Version (You can call it a snapshot) called TEST a few months ago. You can switch to it from the "Release" box on the top tool bar.
20:40:05 <papoteur_> Yes, I have opened the window
20:42:02 <papoteur_> Ah, Test is a snapshot?
20:42:50 <lebarhon> no, a workspace
20:43:31 <papoteur_> If we can edit a release, I don't think that it is of some interest.
20:45:26 <papoteur_> We need to correct some string then publish them. If not, there is no interest
20:45:44 <simonnzg> Correct
20:45:56 <simonnzg> We need editable versions
20:48:23 <papoteur_> I think we can create a release today, to be sure to have it, but I doubt we can exploit it.
20:48:57 <papoteur_> And then we can start to revise, with apb work.
20:49:11 <lebarhon> We have only one workspace called Documentation, we could have more
20:49:55 <lebarhon> One workspace for each Mageia release
20:50:26 <simonnzg> Maybe we need one workspace per release? It is certainly possible to export and import workspaces, so the last thing to do to a workspace before migrating would be to copy it and import it into a new one.  Camil might choke on the space we'll use, though!
20:51:07 <lebarhon> export and import are indeed possible
20:52:15 <lebarhon> In fact we need 2 workspaces, as we have never more than 2 Mageia versions at the same time
20:52:59 <lebarhon> When a Mageia release is EOL we can delete the workspace
20:53:23 <apb> Reuse?
20:53:51 <lebarhon> or reuse
20:54:08 <papoteur_> We have to kno more about export/import
20:54:15 <simonnzg> apb: If we copy the workspace to the new one, all we're really doing is leaving a fully functional snapshot behind.
20:55:13 <simonnzg> The copy process SEEMS to result in the person doing it getting an archive of some sort to import. My Cornish broadband is so good it would take weeks to download it so someone else will have to do it. :)
20:55:49 <Kernewes> he's not lying :(
20:56:23 <papoteur_> ;-(
20:57:14 <apb> simonnzg: Reuse/modify
20:58:05 <papoteur_> We don't know enough. I propose to continue to collect information and to reopen the subject in another meeting.
20:58:18 <simonnzg> Kernewes: Allegedly, I get fibre later this year. Brexit notwithstanding as it's paid for by the EU. ;)
20:58:46 <simonnzg> papoteur_: I will read the docs. I'll try to make an export.
20:58:58 <simonnzg> apb: Yes. Can be done.
20:59:53 <apb> 103.76 Mbps here :)
21:00:20 <simonnzg> apb: 1.8 here!
21:00:35 <apb> Woohoo!
21:01:13 <lebarhon> s for second or siecle ?
21:02:11 <simonnzg> lebarhon: Megacycles per second?
21:04:17 <lebarhon> The workspace Documentation is about 200 MB, not so big
21:04:49 <papoteur_> Sorry, connection pb.
21:05:12 <simonnzg> 170MB download for me. Ouch. Might take a while.
21:05:18 <papoteur_> did you see my last topic?
21:05:38 <lebarhon> no
21:05:45 <papoteur_> #topic Collaborative tools
21:05:54 <simonnzg> papoteur_: Your last post I saw was proposal to look at versioning at another meeting.
21:05:57 <Kernewes> Sorry, I have to go now.  This is all too technical for me anyway :(
21:06:02 <Kernewes> Goodnight everyone
21:06:14 <simonnzg> Kernewes: Night Night!
21:06:17 <papoteur_> #action simonnzg and other learns about workspaces managing in Calenco.
21:06:19 <Kernewes> \quit
21:06:20 <lebarhon> Goodnight
21:06:23 <apb> Kernewes: Night.
21:06:23 <Kernewes> oops
21:06:33 <papoteur_> Kernewes: good night
21:08:02 <papoteur_> apb and lebarhon tested framapad as collaborative tool
21:08:22 <lebarhon> Framapad seems to be Ok ffor text editing
21:08:30 <papoteur_> https://mensuel.framapad.org/p/s2Vg42GZ2a
21:08:31 <[mbot> [ Framapad mensuel ]
21:09:05 <papoteur_> lebarhon: do you mean with or without tags?
21:09:11 <lebarhon> but isn't fine for layout changes (section and sub-sections aren't visible)
21:09:50 <lebarhon> tag aren't really disturbing as long as we don't need them to unserstand the text
21:10:11 <lebarhon> *understand
21:10:46 <lebarhon> it seems impossible to work the layout on Framapad
21:11:10 <papoteur_> lebarhon: it needs some manipulation to keep trace of suppressed strings, isn't it?
21:11:59 <lebarhon> For that we couls agree to never delete text but to cross it instead
21:12:05 <lebarhon> *could
21:12:16 <papoteur_> OK
21:12:42 <simonnzg> I'm worried that we're just making it even more complex...
21:13:19 <lebarhon> I didn't find a collaborative tool for xml
21:14:20 <lebarhon> fortunately we don't modify the layout very often
21:14:41 <simonnzg> lebarhon: Apart from Claenco. Problem is the lack of the online Java-based editor.
21:15:30 <papoteur_> I just think to Lyx, but I can be sure its work.
21:16:27 <papoteur_> s/it
21:17:31 <papoteur_> simonnzg: we lack of modifications track.
21:18:43 <apb> How did people work together to decide on the content for the manuals as they were being developed?
21:19:03 <apb> .... initially
21:19:05 <simonnzg> papoteur_: Yes. I see documents about using oXygen editor and SVN to achieve collaboration, but that looks complex. oXygen is expensive, too. I have a copy. :(
21:19:21 <lebarhon> apb: With Calenco
21:19:34 <apb> Oh.
21:20:00 <lebarhon> But Calenco had tools it has no more
21:20:06 <apb> From scratch?
21:20:15 <papoteur_> apb:  xml files was drafted directly on Calenco, and modified by other if needed.
21:20:39 <lebarhon> apb: From scratch r from Mandriva doc
21:20:46 <lebarhon> *or
21:20:57 <apb> lebarhon: Ah
21:21:11 <simonnzg> apb: XML is great. It has a steep learning curve and I would prefer to use restructuredText, but it would mean a lot of changes.
21:22:24 <papoteur_> simonnzg: I don't think we can change or format;) Really to much work.
21:22:35 <simonnzg> What we have is what we have :)
21:22:41 <apb> simonnzg: I know nothing about xml - need to learn.
21:22:46 <lebarhon> except if a script can do it
21:23:24 <simonnzg> apb: It's like HTML, but more complex. The docs are more web pages than pure XML documents, really.
21:24:02 <simonnzg> apb: Formatting is done by tags, defined in a stylesheet. Quite easy to write if you know what tag looks like when rendered.
21:24:14 <papoteur_> simonnzg: is it similar to Latex?
21:24:23 <apb> simonnzg: ...or about HTML
21:24:39 <simonnzg> papoteur_: XML or resT?
21:25:19 <papoteur_> simonnzg: restruturedText
21:25:21 <simonnzg> simonnzg: Neither, really. I look at LaTeX as more like Wordperfect for DOS in non-WYSIWYG mode
21:25:34 <lebarhon> I we change I would rather use the wiki, publications are also possible from Wiki
21:26:21 <simonnzg> lebarhon: Wiki is easier, definitly. restructuredText is just like Markdown - a text-based human readable markup.
21:26:50 <papoteur_> I think changing our format is not yet the topic.
21:26:57 <simonnzg> lebarhon: It's possible to render the text as PDF documents or HTML and other formats.
21:28:10 <simonnzg> Regarding collaborative tools, what kind of tools? Some interesting stuff coming out of Nextcloud at the moment.
21:29:20 <lebarhon> wysiwyg, real time, who changed what
21:30:04 <papoteur_> and xml output.
21:30:14 <lebarhon> of course
21:30:47 <lebarhon> or a good converter xml - odt
21:30:57 <papoteur_> It seems a quadrature or circle
21:31:15 <papoteur_> s/of
21:33:07 <lebarhon> and better if it could display png images
21:36:27 <papoteur_> For what I see, framapad lacks only the wysiwig.
21:36:47 <lebarhon> and the screenshots
21:36:53 <papoteur_> Rendering is different according to export format
21:37:04 <papoteur_> lebarhon: OK
21:37:20 <simonnzg> How about Markdown editing? https://apps.nextcloud.com/apps/files_markdown
21:37:21 <[mbot> [ Markdown Editor - Apps - App Store - Nextcloud ]
21:37:41 <simonnzg> I don't know yet if it is multi user or planned to be.
21:38:16 <simonnzg> Markdown is very much like restructuredText so easy to learn.
21:38:20 <papoteur_> simonnzg: it is a diffrent format. We have to get finally the xml format.
21:38:40 <papoteur_> at least today.
21:41:31 <papoteur_> Do we agree on framapad or not, today?
21:42:22 <simonnzg> papoteur_: So long as I can still do any editing I do within Calenco as I don't need wysiwyg.
21:42:35 <simonnzg> Not that I ever seem to get time to do anything
21:43:45 <lebarhon> XXE is still worrking and is wysiwyg but isn't collaborative
21:43:58 <lebarhon> but we can use it
21:44:21 <papoteur_> Calenco has also its web ediitor, which is similar to XXE.
21:45:05 <simonnzg> papoteur_: I guess I still have my oXygen licence. Maybe I should check if I'm due an upgrade.
21:45:20 <lebarhon> I don't find it similar, I am unable to add a word with  the Web Editor
21:46:31 <papoteur_> lebarhon: ah?? This is not normal, we can sure improve that.
21:47:05 <lebarhon> it a way of talking
21:47:14 <lebarhon> *it is
21:47:34 <lebarhon> a word I can, but move a title, I really can't
21:48:27 <lebarhon> I suggest to use famapad to work on the tree structure alone and when it is Ok, we add the text
21:48:40 <apb> Try framapad for now - in the absence of something more suitable? Keep looking in the meantime?
21:49:03 <papoteur_> apb: yes, probably
21:50:15 <apb> Need something for deciding content. So, framapad for now then?
21:50:27 <simonnzg> I can't even open a docment in the web editor they all throw an error
21:51:13 <papoteur_> I didn't try recently, but never had such problems.
21:51:46 <lebarhon> it works now for me
21:53:32 <papoteur_> OK, let's go for framapad.
21:53:43 <simonnzg> I get XML format errors. Never mind. I don't use it.:)
21:54:03 <papoteur_> But using longer time than 1 month. At least 6 months I think.
21:54:18 <apb> yes
21:54:26 <lebarhon> Where do you manage that
21:55:49 <apb> Initial creation? Can be modified later as well maybe?
21:55:50 <papoteur_> When ceating the pad, the next field is the duration.
21:56:12 <papoteur_> apb: I don't know
21:56:25 <apb> Max seems to be 1 year.
21:56:41 <lebarhon> Ok,
21:56:50 <papoteur_> apb: I hope this is too much ;)
21:56:58 <apb> Yes :)
21:57:53 <apb> But .... the expiry is after last edit to doc.
21:57:58 <papoteur_> #action we will use Framapad as collaborative tool.
21:58:07 <papoteur_> apb: yves
21:58:11 <papoteur_> yes
21:58:18 <apb> yes
21:58:57 <papoteur_> I propose to stop here. What do you mean?
21:59:16 <apb> Nothing, sorry.
21:59:27 <lebarhon> we have a submission agenda now
21:59:54 <papoteur_> lebarhon: yes?
22:00:05 <lebarhon> could we agree fot the third line, if apb want to work on it
22:00:21 <lebarhon> DrakX-odtV3-comments-apb.odt
22:00:42 <lebarhon> we finished last we isn't it ?
22:01:15 <lebarhon> *last week
22:01:31 <apb> lebarhon: ok with me.
22:01:31 <papoteur_> I think so, yes
22:02:54 <lebarhon> next meeting ? I am away for 8 days
22:03:29 <papoteur_> lebarhon: OK
22:03:34 <apb> I am ok with whatever is convenient for others.
22:03:42 <simonnzg> Me too.
22:03:51 <lebarhon> or we decide to try framapas before the nex meeting
22:04:11 <simonnzg> I have my Framapad account
22:04:14 <papoteur_> I prefer to fix a date
22:04:38 <papoteur_> In two weeks ?
22:04:40 <lebarhon> in two weeks then ?
22:04:44 <simonnzg> ok
22:04:48 <lebarhon> Ok
22:04:54 <apb> Ok.
22:05:24 <papoteur_> Thus, 5th Februar
22:05:40 <papoteur_> OK.
22:05:40 <apb> Ok.
22:05:48 <lebarhon> fine, good night
22:05:53 <papoteur_> Can we close ?
22:06:04 <apb> Y
22:06:13 <lebarhon> yes i am tired and doing much errors
22:06:37 <papoteur_> #endmeeting