20:03:40 <papoteur> #startmeeting
20:03:40 <Inigo_Montoya`> Meeting started Thu Mar 10 20:03:40 2016 UTC.  The chair is papoteur. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:40 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:03:52 <papoteur> #chair lebarhon
20:03:52 <Inigo_Montoya`> Current chairs: lebarhon papoteur
20:04:02 <papoteur> #topic improve how we handle changes that do not need a translation update
20:04:58 <papoteur> Thanks to Lebarhon who send us a topic list
20:05:25 <lebarhon> I found the questions and you the answers :)
20:05:59 <papoteur> We discussed last meeting how to unbreak translations when changing source files.
20:06:09 <papoteur> lebarhon: ;)
20:06:38 <papoteur> yurchor: has the answer ;)
20:06:45 <lebarhon> we discussed but decided nothing
20:08:24 <papoteur> I think there is nothing to decide, but to aware of what to do.
20:09:08 <yurchor> What can I say? What is good for docs is good for users. Not that translators mindset should be taking into acoount much.
20:09:46 <lebarhon> We could say that any change must be discussed in ML
20:09:46 <papoteur> http://meetbot.mageia.org/mageia-doc/2016/mageia-doc.2016-02-18-20.05.log.html
20:09:47 <[mbot> [ #mageia-doc log ]
20:10:03 <yurchor> Just write a message into the list and we regenerate templates then update the translations.
20:11:07 <lebarhon> Is there a wiki page where to write that ?
20:11:48 <papoteur> lebarhon: I think there is something already written.
20:12:32 <papoteur> https://wiki.mageia.org/en/Fixing_strings_in_code_without_breaking_translations
20:13:49 <papoteur> yurchor: are the only one who knows how to do that ?
20:14:18 <papoteur> yurchor: (it's fine for me) ;)
20:14:34 <yurchor> That was tv-inspired page. I just made a wikification.
20:15:11 <yurchor> But yes, I can do those things taht are written on that page. ;)
20:15:21 <papoteur> yurchor: is this page what you apply ?
20:15:32 <yurchor> papoteur: Yes.
20:15:37 <papoteur> s/what/that
20:15:41 <papoteur> OK
20:15:56 <lebarhon> If it is clear for everyone, next topic
20:16:05 <papoteur> lebarhon: OK.
20:16:31 <papoteur> # topic team vote for docteam leader and deputy
20:16:41 <papoteur> #topic team vote for docteam leader and deputy
20:16:59 <papoteur> We have to organize election.
20:17:22 <papoteur> First : who is candidate ?
20:17:54 <papoteur> I'm candidate
20:18:04 <lebarhon> papoteur: congratulations
20:18:28 <yurchor> +1
20:18:37 <harms_> +1
20:18:52 <lebarhon> you are also candidates ?
20:19:00 <papoteur> We can have a deputy too.
20:19:10 <yurchor> No, we are supporters. :)
20:19:44 <lebarhon> So, papoteur is our leader :-)
20:20:01 <papoteur> We ahve to vote yet, but we have to vote on ml.
20:20:05 <yurchor> Go, go, papoteur!
20:20:11 <papoteur> :)
20:20:35 <lebarhon> who is candidate to be deputy ?
20:20:58 <papoteur> 3
20:21:06 <papoteur> 2
20:21:12 <papoteur> 1
20:21:23 <papoteur> nobody :(
20:21:26 <lebarhon> I am if there is no one else
20:21:42 <harms_> this is a good suggestion
20:21:42 <papoteur> Yes !
20:22:23 <papoteur> #info lebarhon is candidate as deputy
20:22:41 <papoteur> #info papoteur is candidate as leader
20:23:07 <lebarhon> do we have to vote on ML ?
20:23:53 <papoteur> this is not mandatory, but I think it can be more open, isn't it?
20:24:14 <papoteur> even if we know the results.
20:24:20 <lebarhon> Indeed, linuxero or doktor aren't here
20:25:05 <papoteur> I will organize the vote on the ML.
20:25:15 <papoteur> Closing in one week ?
20:25:36 <lebarhon> #action papoteur organize the vote on ML
20:26:15 <lebarhon> one week should be enough
20:26:32 <papoteur> #info closing in one week.
20:26:47 <papoteur> Ok, next topic
20:26:54 <lebarhon> after there is the board election
20:27:11 <papoteur> #topic
20:27:13 <papoteur> Boot.iso manual, do we need one, a wiki page already exists:
20:27:14 <papoteur> https://wiki.mageia.org/en/Boot.iso_install
20:28:01 <papoteur> The usage of such a solution is less frequent than classical install
20:28:25 <papoteur> But this is stable
20:29:21 <harms_> That goes a little bit with my question on the complementarity
20:29:31 <harms_> between wiki and "official doc". What arguments one way or the other
20:29:35 <lebarhon> Does anybody know if we can use boot.iso and dowload all the packages before installing them ?
20:29:48 <papoteur> We can have a manual which starts with something like wiki page and continue with the following pages.
20:30:50 <papoteur> lebarhon: I don't know well. I think not.
20:31:22 <papoteur> harms_: good question. At start, we done the same as Mandriva had.
20:31:37 <lebarhon> the problem with boot.iso is to have a reliable connection
20:32:11 <harms_> That is an excellent principle. Are there new arguments?
20:32:19 <papoteur> The installer part was useful with such method because it embbed the documentation.
20:33:13 <lebarhon> the advantage for the manual is to have it translated in several languages, the wiki isn't
20:33:26 <marja> sorry, last time I looked at my clock it was only 20:15hr /o\
20:33:28 <papoteur> harms_: the official doc can be translated on transifex and with larger
20:33:52 <papoteur> marja: no problem ;)
20:34:18 <papoteur> harms_: coverage in languages
20:34:24 <harms_> Yes. I think booot.iso belongs to the class "official doc", maintained and translated
20:35:05 <marja> lebarhon: I use boot.iso with a local mirror
20:35:45 <lebarhon> marja: what is a local mirror?
20:35:55 <lebarhon> a mirror on a lan?
20:36:15 <marja> lebarhon: for me: one on an external HD, but for most: on LAN
20:36:28 <marja> or WLAN
20:36:44 <harms_> A wiki page would have the charm not to be stricly limited to
20:36:59 <lebarhon> Ok, but is it possible to use an official mirror and download everrything before installation?
20:37:12 <harms_> boot iso, would allow to be somewhat more general (booting methods)
20:37:20 <papoteur> lebarhon: yes
20:37:55 <lebarhon> it is not explained in the wiki pge
20:37:55 <harms_> I download the first time I need the packages, keep them for then booting on the LAN
20:38:00 <lebarhon> *page
20:38:15 <papoteur> lebarhon: but a copy of official mirror is large. This is not always the best solution.
20:38:45 <lebarhon> I don't mean a copy of the mirror
20:39:02 <papoteur> lebarhon: yes the page is not perfect, it should be improved first.
20:39:18 <papoteur> hi psyca
20:39:32 <psyca> Hi papoteur
20:39:57 <papoteur> For example
20:39:59 <papoteur> "The boot.iso and boot-nonfree.iso files can be used to launch a network install only over a wired network." not true.
20:40:00 <papoteur> It can be also used to install from a image strored on HDD.
20:40:54 <papoteur> There is also a all.img which can be used via the same way.
20:40:55 <papoteur> <mirror url>/Mageia/distrib/cauldron/$ARCH/install/images/
20:41:12 <papoteur> pub/linux/Mageia/distrib/cauldron/x86_64 could be on the screenshot.
20:41:13 <papoteur> Installation from Hard disk
20:41:15 <papoteur> Option "Use directory as tree mirror" to developp
20:42:20 <lebarhon> The wiki page isn't the right one
20:42:21 <papoteur> But we have first to agree to write it as a new manual or not.
20:42:49 <papoteur> lebarhon: have you another one?
20:43:01 <lebarhon> https://wiki.mageia.org/en/User:Lebarhon
20:44:56 <papoteur> It's just better ;)
20:45:20 <lebarhon> isn't it :)
20:46:37 <papoteur> \o/
20:47:15 <yurchor> Nice, really...
20:47:29 <papoteur> My first remark is stil valid.
20:48:13 <papoteur> The seconf also, but not the third.
20:48:20 <papoteur> s/second
20:48:45 <lebarhon> papoteur: could you repeat them
20:49:15 <papoteur> 1.
20:49:17 <papoteur> "The boot.iso and boot-nonfree.iso files can be used to launch a network install only over a wired network." not true.
20:49:18 <papoteur> It can be also used to install from a image strored on HDD.
20:49:41 <papoteur> 2.
20:49:43 <papoteur> There is also a all.img which can be used via the same way.
20:49:44 <lebarhon> Yes, it is what is written
20:49:44 <papoteur> <mirror url>/Mageia/distrib/cauldron/$ARCH/install/images/
20:50:15 <lebarhon> You can't use a wireless network
20:50:48 <marja> wireless never worked for me, either, even if I think it should with boot-nonfree.iso
20:51:05 <papoteur> lebarhon: not a with a WPA key, but I heard it was possible with a WEP.
20:51:19 <marja> ah, we have WPA
20:51:28 <lebarhon> I will try with Wifi
20:51:37 <papoteur> marja: Yes, it's the standard today.
20:51:50 <marja> papoteur: indeed
20:52:24 <papoteur> 4.
20:52:26 <papoteur> Installation from Hard disk
20:52:27 <papoteur> Option "Use directory as tree mirror" to developp
20:53:16 <papoteur> thus do we agree to launch a new manual on installation with boot.iso et al.
20:53:23 <papoteur> ?
20:54:27 <papoteur> I think it will be a plus.
20:54:35 <harms_> agree
20:54:39 <lebarhon> papoteur: what do you mean by "mirror url>/Mageia/distrib/cauldron/$ARCH/install/images/"
20:55:53 <papoteur> lebarhon: it's the place where we can find images like boot.iso, but also all.img
20:56:43 <papoteur> I found also  hd_grub-nonfree.img but I don't know what is its usage.
20:58:15 <lebarhon> I take them from here https://www.mageia.org/fr/downloads/
20:58:17 <[mbot> [ Télécharger Mageia 5 ]
20:58:30 <papoteur> lebarhon: I suppose also that your are OK to have this new manual?
20:58:47 <papoteur> lebarhon: Yes, it is also a good way.
20:59:25 <lebarhon> I will add the other path to fetch the ISOs
20:59:52 <lebarhon> the advantage of the manual is the multilanguages
21:00:41 <lebarhon> when the wiki is OK, it is not a problem to create a manual in Calenco
21:00:46 <papoteur> lebarhon: Yes, and we are waiting for an internationalized wiki since some yaers.
21:01:02 <papoteur> OK
21:01:32 <papoteur> #info we will write a new manual for boot.iso installation method.
21:01:57 <lebarhon> even with  an internationalized wiki, there is not much translators, many less than in Tx
21:02:04 <papoteur> harms_: it can be a good exercice ;)
21:02:57 <harms_> One thing after the other, dont overcommit. BUt I will at least participate
21:03:15 <papoteur> our weakness is to have screen shot in each language. But for this manual, this isn't needed ;)
21:03:30 <papoteur> harms_: ;)
21:04:29 <papoteur> next topic ?
21:04:32 <harms_> OT: can sceenshot translation on technical documents been relaxed
21:04:54 <lebarhon> #action lebarhon will try boot.iso with a wireless network (WPA and WEP)
21:05:09 <marja> lebarhon: thx :-)
21:05:17 <papoteur> harms_: what do you mean with relaxed?
21:05:56 <harms_> made non-necessary - somebody who reads this kind of document should understand
21:06:25 <marja> harms_: I agree
21:07:17 <marja> harms_: that is, if any screenshots you use are in English ;-)
21:07:34 <papoteur> I think that we can't suppress the need of some screen shots, at least.
21:08:23 <harms_> I did not want to drop screenshots; with the same effort you can have 2x as many, but not translated
21:09:23 <marja> code is code, it doesn't change when switching language (as long as you don't switch from eg perl to python)
21:09:32 <papoteur> harms_: it's possible yes.
21:10:25 <papoteur> #topic Installer doc update for Mageia 6
21:10:34 <harms_> Contradicting myself: I had always problems understanding purely french (not franglay) captions
21:10:54 <papoteur> harms_: ;)
21:11:34 <lebarhon> we are often accused to have English doc only
21:11:36 <papoteur> Thus, what will be new?
21:12:01 <lebarhon> that is the question
21:12:03 <papoteur> sorry, I'm to quick ;)
21:12:38 <lebarhon> Mageia 6 features isn't documented
21:12:39 <papoteur> What I know is that we will have Plasma5 instead of KDE4
21:12:53 <papoteur> lebarhon: yes, it's a shame ;)
21:13:05 <lebarhon> Plasma isn't docteam problem
21:13:53 <papoteur> Except if a screenshot change in installer. But I didn't try yet
21:14:02 <harms_> I see a question of timing: before documenting Plasma, we will need to get knowledgable
21:14:39 <papoteur> harms_: yes, it's a problem
21:14:41 <harms_> (assuming that plasma runs well enough to understand what it is doing). This level of expertise
21:15:17 <harms_> i doubt whether we will reach it before Mageia6 release
21:15:24 <papoteur> harms_: Or documentation is not impacted by this.
21:16:01 <papoteur> Some page on wiki, perhaps, but it's not our priority.
21:16:17 <yurchor> Nothing new in Plasma 5. Just a new theme (Breeze). Judging on Release notes (I have translated all of them).
21:16:43 <papoteur> We will have a new design for MCC icons and Mageia tools.
21:17:13 <harms_> and - for instance - file support for plasma, still the same directory tree?
21:18:03 <papoteur> harms_: ??
21:18:50 <harms_> I we document plasma, doc should say where Plasma stores its properities
21:18:58 <harms_> I -> If
21:19:17 <lebarhon> KDE settings and Plasma settings are similar
21:19:32 <yurchor> lebarhon: No.
21:19:46 <lebarhon> I didn't find differences
21:19:46 <papoteur> harms_: we have no such document yet for KDE.
21:19:50 <yurchor> There were some dramatic changes.
21:20:23 <yurchor> Settings were moved to ~/.config and ~/.local
21:20:56 <harms_> Yes, but having something like that would be nice.
21:21:02 <lebarhon> Ok but to configure the DE, it is similar
21:21:10 <papoteur> harms_: sure
21:21:19 <yurchor> lebarhon: Sure.
21:21:23 <harms_> BUt I understand: there is a need to document - and early - what all the change from
21:21:39 <harms_> KDE to Plasma means for the user
21:22:01 <yurchor> harms_: Not much for the end user.
21:22:10 <papoteur> harms_: a migration help?
21:22:40 <yurchor> I propose to rely on KDE teams for this.
21:23:12 <yurchor> Our team is rearranging techbase and community wikis write now
21:23:35 <yurchor> To make them more up-to-date and reliable.
21:23:50 <papoteur> yurchor: great news
21:24:00 <harms_> Before defining what to do, we should have a chance to install cauldron (for that means have the snapshot iso)
21:24:15 <papoteur> ;)
21:24:38 <lebarhon> Cauldron works fine today
21:24:54 <papoteur> It's coming. tmb will spin new ISO this weekend, I think.
21:25:11 <harms_> I know, but upgrading from Mga5 is time I do not want to spend
21:26:27 <papoteur> I don't remember other changes
21:27:02 <harms_> Not ranting, just spelling out what I see as a strong contingency for those who did not keep a working cauldron
21:28:44 <papoteur> https://wiki.mageia.org/en/Category:ProposedFeatureMageia6
21:29:15 <harms_> But the ordinary end-user will want to know what the new buzzword "Plasma" means for him. Maybe it
21:29:26 <harms_> is enough to put this into the release info
21:30:04 <yurchor> Sigh... KDE marketing team's new dragons...
21:30:09 <lebarhon> May be it is worth a blog post
21:30:15 <papoteur> harms_: no, it could be good to have specific info.
21:31:01 <harms_> just wanted to get the discussion back to here. Yes, I guess so: need specific info
21:31:05 <papoteur> I propose you to examine this topic atthe next meeting.
21:31:23 <lebarhon> is it official that dual arch and live CD are given up?
21:31:32 <papoteur> lebarhon: yes
21:31:49 <lebarhon> papoteur: thx
21:32:35 <lebarhon> other topics ?
21:32:58 <papoteur> There was a feature about ising network manager by default.
21:33:27 <papoteur> But I didn't see any progress on that.
21:34:22 <harms_> What I have seen about that sounded slightly like talking about religion, not much solid arguing
21:34:32 <papoteur> No more topic, and no more nrj to propose else ;)
21:35:00 <papoteur> harms_: ;)
21:35:44 <papoteur> Only whu rite the code have the steering wheel in hands ;)
21:35:58 <papoteur> s/rite/write
21:36:20 <papoteur> I think it's time to close :(
21:36:28 <marja> totally off-topic ...is it possible in 6dev1 to select /boot/EFI from the drop down list in diskdrak in installer (when there's no ESP mounted)
21:37:04 <lebarhon> I think so
21:37:10 <papoteur> marja: didn't try today
21:37:21 <marja> (asking because of https://bugs.mageia.org/show_bug.cgi?id=17926 which is for Mga5
21:37:23 <[mbot> [ Bug 17926 /boot/EFI option not available ]
21:37:48 <papoteur> Other thing?
21:38:07 <marja> sleep :-)
21:38:14 <papoteur> #endmeeting