20:05:48 <papoteur> #startmeeting
20:05:48 <Inigo_Montoya`> Meeting started Thu Feb 18 20:05:48 2016 UTC.  The chair is papoteur. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:05:48 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:06:08 <papoteur> #chair lebarhon marja harms_
20:06:08 <Inigo_Montoya`> Current chairs: harms_ lebarhon marja papoteur
20:06:14 <marja> :=)
20:06:36 <harms_> inventive!
20:07:04 <papoteur> We can perhaps start with the topics marja sent.
20:07:27 <marja> papoteur: fine
20:07:48 <papoteur> #topic publications
20:08:07 <papoteur> marja said: regenerate all publications as they are, and push them to svn/soft/mageia-doc?
20:08:19 <marja> papoteur: thx, I didn't manage to c&p
20:08:28 <papoteur> ;)
20:09:16 <papoteur> marja: what will be the usage of these publications?
20:09:23 <marja> tbh, I think we can have another build of mageia-do
20:09:48 <marja> papoteur: that is MCC help (with the updated boot* files)
20:09:58 <marja> papoteur: live installer and tradional installer
20:10:09 <marja> papoteur: all 3 of them to be packaged
20:10:13 <marja> papoteur: and installable
20:10:48 <marja> it makes sense to add the draklive-install help files to the Live isos
20:10:53 <papoteur> We have not numerous translation of live installer.
20:11:20 <marja> papoteur: MCC-help started with En, Et and Uk only, iinm
20:12:00 <papoteur> But yes, it could help to prepare the work of packaging.
20:12:01 <lebarhon> the worst is that amonst the reasons, there is long screen exposure :(
20:12:03 <lebarhon> first topic then ?
20:12:38 <marja> lebarhon: ah, among the reasons for migraine?
20:12:50 <marja> lebarhon: sorry t read that
20:13:06 <marja> lebarhon: we already started the topic
20:13:09 <lebarhon> IRC isn't well either, I had ten lines in a row
20:13:18 <marja> lebarhon: :-(
20:13:38 <papoteur> lebarhon: oops
20:14:40 <papoteur> OK, thus I agree when can regenerate the publications, push them on svn
20:14:57 <papoteur> s/when/ we
20:15:11 <marja> ok
20:15:34 <papoteur> marja said:or first grab all changes from the git and tx po files?
20:16:11 <lebarhon> do we still have smething on svn ?
20:16:25 <papoteur> I think that of course, we have to get the most uptodate translations first.
20:16:55 <papoteur> lebarhon: yes, the last part which is not migrated as software.
20:17:18 <marja> waiting saves half the time... it'll only get later updated
20:18:00 <marja> lebarhon: yes, the source for the package for our manuals is still in svn/soft
20:18:48 <papoteur> marja: it seems to be a good reason.
20:19:41 <marja> lebarhon: harms_: agreed to first update the translations?
20:20:13 <harms_> sure
20:20:53 <marja> I think lebarhon will agree, too, but that he doesn't see what we say
20:20:58 <lebarhon> yes, it should be light
20:21:02 <marja> ok
20:21:28 <marja> #agreed update the translations first, before pushing all manuals to svn/soft/mageia-doc
20:21:36 <papoteur> marja: who can do that? I'm not sure to know how to do that.
20:21:58 <lebarhon> it will be in Tx
20:22:45 <marja> papoteur: we can ask yurchor to fetch tehm from Tx
20:22:54 <papoteur> OK
20:23:34 <papoteur> marja said:
20:23:36 <papoteur> improve how we handle changes that do not need a translation update
20:23:37 <papoteur> -- we shouldn't  assume that yurchor knows when the changes are only in tags, file names and not-to-be-translated commands, links or screenshot names.
20:23:38 <papoteur> -- such non-l10n changes should maybe be done in smaller steps, to make updating .pot and .po files without change in fuzzies more easy?
20:24:22 <marja> #topic better handle non-language changes in our manuals
20:24:38 <papoteur> marja: what do you name "smaller steps"?
20:24:45 <lebarhon> I didn't understand what smaller steps change :-(
20:24:57 <papoteur> ;)
20:25:05 <marja> papoteur: only if yurchor or whoever updates the .pot and .po files needs that
20:26:06 <papoteur> marja: sorry, I don't understand well.
20:26:14 <lebarhon> :-(
20:26:24 <marja> there were many changes to three xml files for the changes to boot.xml etc.
20:26:49 <papoteur> yes
20:27:03 <marja> that was maybe too many for anyone to be able to change the .pot and .po files without fuzzying them
20:27:47 <papoteur> Ah, OK.
20:28:05 <marja> so, I was thinking about next time something like that happens, to do only part of the changes => update .pot and .po, do another part => update, etc
20:28:46 <lebarhon> it is a lot more work
20:28:49 <papoteur> But if we do that step by step, wil we have lesser fuzzyed translation?
20:29:39 <marja> papoteur: I don't know what would be best for yurchor.... maybe we do not need to wait after every step, but only to tell step by step what got changed
20:29:51 <lebarhon> did we have fuzzyed translation last time ?
20:29:59 <marja> lebarhon: yes, quite a lot
20:30:19 <lebarhon> I didn't know, from where ?
20:30:29 <marja> lebarhon: all the strings in the files that got a different name, were fuzzied
20:30:39 <papoteur> harms_: do you understand what we say?
20:31:06 <marja> lebarhon: that is normal, when the original files change, any involved string gets fuzzies
20:31:16 <harms_> The big lines - swimming with details
20:31:25 <papoteur> ;)
20:31:25 <lebarhon> it's
20:31:57 <marja> but that can be workarounded, if the one who recreates the pot and po files know there are no real changes to be translated
20:32:11 <marja> tv showed on dev ml how to do that for drakx
20:32:26 <lebarhon> could you show me an example where a problem is shown ?
20:32:36 <marja> I'm sure yurchor knows how to do that, too, because he did it before
20:33:29 <lebarhon> could we find a way without fizzling ?
20:33:52 <papoteur> yes sure. What we have to do is perhaps to said him what we changed and we think it can be unfuzzied?
20:35:15 <lebarhon> I don't know what precisely are the fuzzies
20:35:20 <papoteur> lebarhon: Not in editing the files. But there is a need a work the apply to po and pot file to retablished good files.
20:35:32 * marja is amazed to see that other translations don't look fuzzied
20:36:21 <lebarhon> so for a same file, a langagecan be fuzzied and not the other ?
20:36:55 <papoteur> lebarhon: gettext uses the source phrase as reference. If we change a letter in it, the translation can not be linked to the changed phrase.
20:37:02 <marja> lebarhon: I had to remove a lot of fuzzies after the po files were updated http://gitweb.mageia.org/software/i18n/tools/commit/docs/mcc-help/nl.po?id=49fdc02ed27431d0f83f2898e6919759a6a7a436
20:37:33 <marja> lebarhon: but, to my surprise, i don't see the same fuzzies in some other languages i checked
20:38:29 <papoteur> marja: it's perhaps a yurchor's effect? ;)
20:39:21 <papoteur> marja: is tv's trick in our documentation?
20:39:43 <papoteur> harms_: tv is for Thierry Vignaud.
20:40:31 <harms_> one of the fundamentals easy to learn
20:40:31 <marja> papoteur: I'll try to remember to add it (or maybe better ask yurchor to add his trick)
20:41:58 <marja> next topic?
20:42:10 <papoteur> OK. What we should remember is that our modification can fuzzyed some translation, be this can be corrected by an adequate traetment before pushing pot file on transifex.
20:42:27 <papoteur> marja: yes
20:42:28 <marja> indeed
20:42:51 <papoteur> #topic harm's progress ;)
20:43:42 <harms_> I did very little the last days - improved the emacs doc, and
20:43:51 <lebarhon> Does yuri know how to modify without fuzzing ?
20:43:59 <marja> lebarhon: yes
20:44:16 <lebarhon> he sells it ?
20:44:16 <harms_> froze asking question about "the process" - seeing the questions
20:44:30 <marja> lebarhon: and apparently he did it now, too, only it failed for Dutch, so I thought it wasn't done
20:44:35 <harms_> you are discussing here.
20:45:05 <marja> harms_: sorry for interrupting what you were saying :-[
20:45:35 <lebarhon> because we could do it ourselves.
20:45:43 <lebarhon> sorry harms, I stop
20:45:57 <harms_> 2 principle issues are: (1) fully understanding "the process" and
20:46:43 <harms_> (2) deciding on a "constructive exercise".
20:47:09 <harms_> May be I should add (0): dig - again into the doc on the process
20:47:37 <harms_> and make some private doc for me - might maybe help to
20:47:46 <papoteur> harms_: what do you mean with the process
20:47:51 <marja> harms_: whenever you see something in our team documentations, please shout loud: there's a good chance things got outdated
20:47:56 <marja> oops
20:48:08 <marja> in our team documentation that you do not understand
20:48:18 <harms_> complement the official doc.
20:48:42 <lebarhon> harms, we are exactely at the same level
20:49:16 <harms_> Yes - but your fingertips have more expertise and experience than mine
20:49:29 <marja> harms_: or update/improve it when you see something that needs to be enhanced, instead of adding another doc
20:49:37 <marja> ?
20:49:39 <papoteur> harms_: there is some tools lacking documentation
20:50:51 <lebarhon> we are "bidouilleurs"
20:51:24 <marja> harms_: maybe I misunderstood... the private doc: in the wiki, or in Calenco?
20:52:01 <marja> harms_: it is fine to play with the files in Calenco test, you can do with them whatever you want
20:52:03 <harms_> Private doc: internal summing up on my machine, documenting
20:52:14 <marja> harms_: ah, OK
20:52:37 <marja> harms_: we could probably learn from it, too
20:52:46 <harms_> making pointers to existing documents.
20:52:54 <marja> ok
20:53:24 <harms_> Maybe - but I have serveral times realised that I just did not see
20:53:24 <papoteur> What I propose you is to choose a tool, write something and submit us
20:53:38 <harms_> pointer - need another iteration.
20:54:09 <marja> ok
20:54:32 <harms_> Yes. You mentioned several issues that lack documentation. Most
20:54:41 <papoteur> You have choice here https://wiki.mageia.org/en/Docteam_Todo_list#What_is_urgent_3
20:55:05 <harms_> are no go (not by  competence, not the necessary hardwar). The only\
20:56:00 <marja> harms_: no problem.... we had the same issues
20:56:20 <harms_> one that I could do sense the network profile manager - not very
20:56:56 <marja> fine if you can work on it
20:57:17 <marja> np if you can't
20:57:17 <lebarhon> when you don't keep speaking about something, you end up by knowing what you say
20:58:25 <harms_> Si on n'a rien a dire, il n'est pas necessaire de le faire savoir (voltaire)
20:58:30 <marja> lebarhon: is that a hint to talk less?
20:58:48 <marja> ah, the French is easier to understand :-)
20:58:55 <marja> in French it is
20:59:20 <lebarhon> no it a quote from a former Renault CO
20:59:32 <lebarhon> *CEO
20:59:34 <marja> lebarhon: not the one harms gave?
20:59:52 <lebarhon> no harms is more litterated
21:00:36 <harms_> Maybe slightly misquote (on a pas besoin de le faire savoir )
21:01:27 <harms_> sticks somewhere in the back of my memory
21:02:01 <harms_> I will give priority to getting more knowledge about calenco
21:02:24 <harms_> and exercise will be more profitable once that is done
21:02:33 <marja> harms_: fine, thanks
21:02:35 <papoteur> harms_: sure. But when we started to document, we didn't all things about draktools. We discovered them and then writing about our discover.
21:03:23 <papoteur> harms_: it's fine.
21:03:55 <papoteur> next topic?
21:04:19 <marja> harms_: tbh, I've never written a file with xxe or the advanced editor in Calenco, for me it was less confusing to write in vim (no wysiwyg for me) ... I only used xxe to check the validity of the files
21:05:12 <harms_> That is how I proceed if I have problems. So far, I stuck with my
21:05:46 <harms_> fluency with the wiki editor - the quickest way, but not helpful here.
21:06:29 <harms_> These are detailed questions I keep for later - for instance: how
21:06:48 <marja> harms_: well, maybe the new advanced editor that Calenco will get will work very well for you :-)
21:07:18 <marja> how?
21:07:32 <harms_> do I specify tables in vi for xxe? Yes I have much hope on the
21:07:43 <harms_> calenco editor.
21:09:14 <marja> harms_: I find a file where there's such a table and look at the xml code how it is done .... I do currently not remember ever having done that, only having added lists... but I'm sure papoteur or lebarhon have added one or more tables
21:09:54 <harms_> Yes - finding an example is the best approach. I find tables an
21:10:34 <marja> harms_: here's a small table http://docteam.mageia.nl/en/MCC/content/rpmdrake.html
21:10:35 <[mbot> [ Software Management (Install and Remove Software) ]
21:10:41 <papoteur> harms_: in xxe, insert after, table(HTML)
21:10:54 <marja> harms_: so in rpmdrake.xml
21:11:15 <papoteur> harms_: I think it's the same codes as xHTML
21:11:21 <harms_> ok
21:11:22 <lebarhon> Oh yes, it mine
21:11:51 <lebarhon> it is not that difficult to use Calenco, Marja just don't like it
21:12:39 <marja> lebarhon: well, I don't like oracle java
21:13:16 <lebarhon> You prefer Java alone :)
21:13:18 <papoteur> ;)
21:13:23 <marja> lebarhon: I should have asked camille whether that's still needed for the new editor
21:13:28 <marja> lebarhon: no :-รพ
21:14:12 <harms_> I skipped java - invested into gtk
21:14:16 <lebarhon> I think it is, because if Java isn't OK, Calenci isn't either
21:15:17 <papoteur> We don't use java, we  use Calenco and xxe ;)
21:15:58 <papoteur> I propose you to skip to the last topic.
21:16:03 <marja> harms_: so you understand why every gtk+3 change gets us unto trouble?
21:16:44 <harms_> I think gtk3 got pushed too early, before it was mature - it is quite
21:16:50 <papoteur> marja: </troll>
21:17:12 <harms_> OK now - and there is the big dependency on the styles, Adwait
21:17:25 <harms_> made many things better.
21:18:09 <marja> harms_: so after fixing the current issues, everything should be fine? (That gives hope :-) )
21:18:40 <marja> papoteur: :-)
21:19:00 <papoteur> #topic netinstall documentation
21:19:46 <papoteur> Net install is not yet in our official documentation.
21:19:58 <papoteur> Do you thing it is needed?
21:20:08 <marja> but we could just add this page https://wiki.mageia.org/en/Boot.iso_install
21:20:38 <lebarhon> Net install isn't imho for beginers
21:20:46 <marja> papoteur: maybe referring to that page would be enough?
21:20:51 <marja> lebarhon: indeed
21:22:26 <lebarhon> may be the page need to be improved, but a page should be enough
21:22:43 <marja> I think I've done UEFI boot iso installs, when I still had an UEFI laptop, but don't really remember whether there was anything special about it
21:22:47 <papoteur> lebarhon: in the wiki, mean you?
21:23:28 <lebarhon> I don't know
21:24:03 <lebarhon> If not for biginners, translation is less usefull
21:24:20 <marja> true
21:24:30 <papoteur> A page in the wiki is perhpas enough. In this case I think thet the title of this one is not adapted.
21:24:58 <marja> papoteur: which title do you propose?
21:25:07 <lebarhon> We can start with a wiki page
21:25:31 <papoteur> Installation from network sources
21:25:58 <marja> papoteur: well, I use boot.iso to install from a mirror on a USB-disk
21:26:07 <harms_> I just looked at the page: it lacks an introduction:
21:26:11 <marja> papoteur: so without a network
21:26:14 <lebarhon> boot.iso means nothing
21:26:26 <marja> boot.iso is the medium
21:26:42 <harms_> Some words summarizing what it does, and when it is of interest
21:26:44 <lebarhon> everything is an iso to boot
21:27:10 <marja> harms_: what would you like to add?
21:27:17 <papoteur> harms_: yes, you're right
21:27:32 <lebarhon> +1
21:27:44 <marja> lebarhon: true, but other isos do not have the name "boot(-nonfree).iso
21:27:48 <marja> admel: wb
21:28:00 <lebarhon> admel, awake :)
21:28:34 <harms_> chinese to me
21:29:05 <lebarhon> you will soon make the chinese translations
21:29:23 <marja> ah, the summary isn't even correct, because a local disk can be used too, as mirror
21:29:32 <papoteur> admel: it's too late ;)
21:29:58 <papoteur> admel: we discuss about https://wiki.mageia.org/en/Boot.iso_install
21:30:03 <lebarhon> admel is volunteer to re-write the boot.iso page
21:30:28 <papoteur> #action admel will rewrite https://wiki.mageia.org/en/Boot.iso_install
21:30:35 <papoteur> ;)
21:30:37 <marja> lol
21:30:42 <papoteur> #undo
21:30:42 <Inigo_Montoya`> Removing item from minutes: <MeetBot.items.Action object at 0xb694e44c>
21:30:57 <harms_> I start understanging chinese
21:31:05 <marja> harms_: \o/
21:31:17 <lebarhon> congratulations
21:31:59 <papoteur> the summary could discuss which ways are possible. And in which cases it is useful.
21:32:43 <papoteur> OK. I'm tired, I think we have to conclude.
21:33:03 <lebarhon> as admel hide, I will wrrite a draft for boot.iso
21:33:13 <papoteur> #info there is no need of a new manual on boot.iso installations.
21:34:09 <marja> lebarhon: thx
21:34:24 <papoteur> lebarhon: on the wiki?
21:34:34 <lebarhon> yes
21:34:49 <papoteur> #action lebarhon will write a draft for boot.iso on the wiki
21:35:05 <marja> lebarhon: improve the existing page, or do you want to start from scratch?
21:35:13 <lebarhon> and admel will write down on Calenco
21:35:22 <marja> lebarhon: https://wiki.mageia.org/en/Boot.iso_install
21:36:34 <lebarhon> improve, I must learn myself
21:36:34 <papoteur> admel: OK?
21:36:49 <marja> :-)
21:37:22 <lebarhon> admel is dead
21:37:31 <marja> lebarhon: current cauldron boot.iso won't boot (unless that already got fixed)
21:37:33 <papoteur> admel: You have the choice. You can also translate it in French.
21:38:08 <papoteur> He can use the Mageia 5 one.
21:38:11 <lebarhon> I can do it with Mageia 5, then update for Mageia 6 when it is released
21:38:15 <marja> papoteur: you want him to translate it before it's written
21:38:37 <papoteur> marja: no, of course ;)
21:38:54 <marja> papoteur: I was trolling
21:39:07 <papoteur> OK i think we can close, isn't it ?
21:39:13 <marja> yes, please
21:39:33 <papoteur> 3
21:39:34 <lebarhon> thanks everyone, bye
21:39:37 <papoteur> 2
21:39:40 <marja> harms_: don't hesitate to write the ml when you have more questions
21:39:44 <papoteur> 1
21:39:44 <marja> lebarhon: bye
21:39:50 <papoteur> #endmeeting