19:00:55 <papoteur> #startmeeting
19:00:55 <Inigo_Montoya`> Meeting started Thu Apr  9 19:00:55 2015 UTC.  The chair is papoteur. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:55 <Inigo_Montoya`> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:07 <marja> lebarhon: I used one, years ago, until I lost my data in it ;-)
19:01:13 <papoteur> #chair marja lebarhon
19:01:13 <Inigo_Montoya`> Current chairs: lebarhon marja papoteur
19:01:28 <marja> nice, all attendants are chairs
19:01:33 <papoteur> lebarhon: :/
19:01:45 <papoteur> marja: ;)
19:01:50 <marja> :=)
19:02:06 <papoteur> Ok, we have topics?
19:02:08 <marja> we didn't anounce any topics on the ml, did we?
19:02:32 * marja should have checked installer help
19:02:45 <marja> does installer help tell us to check the errata?
19:02:47 <papoteur> I think we have "adapting the documentation to UEFI installation"
19:03:15 <marja> papoteur: yeah, but we're still wrestling with some loose ends
19:03:58 <marja> papoteur: if, in installer help, we tell the users to check the errata, we could maybe add a line to check the uefi page for the latest about uefi
19:04:35 <marja> tv is still pushing lot of fixes to installer.... I think he pushed at least 50 changes to it since less than two weeks ago
19:04:44 <marja> and I think he hasn't finished, yet
19:04:59 <papoteur> for errata, I think there is already present.
19:05:09 <marja> that is reassuring
19:05:28 <lebarhon> I think errata have nothing to do in th help
19:05:47 <marja> in that case, we could also put a note in the errata that our inline documentation is not up-to-date, and refer to the correct wiki page
19:05:48 <papoteur> it's intersting that TV does that.
19:06:05 <papoteur> but it's really at end of the cycle.
19:06:42 <marja> it is.... but at least the diskdrake fixes were really pterjan's task
19:06:49 <papoteur> I look for the mention
19:06:53 <marja> papoteur: thx
19:07:25 <lebarhon> let's write in the help everything is really working
19:08:36 <marja> lebarhon: everything that really works... yeah, and warn against things that do not work.. like using free space on a windows partition
19:09:12 <papoteur> marja: should we write about bugs in our documentation?
19:09:16 <lebarhon> yes, it will be for Mageia 6
19:09:43 <papoteur> when the bugs are worked
19:10:02 <marja> papoteur: well, we should warn that there can be bugs, and advise to read the errata
19:10:22 <papoteur> marja: ok for that.
19:10:37 <marja> lebarhon: yeah, if it doesn't look like it'll get fixed, it would be nice to have it permanently in the doc
19:12:07 <papoteur> not yet found mention for errata...
19:12:30 <lebarhon> two kind of features, the one that are working and the one that are going to work
19:12:46 <marja> nor did I.... but searches in Firefox didn't work well here recently, maybe that affects the search button
19:12:50 <lebarhon> *I forgot some s
19:14:24 <marja> lebarhon: the worst problems are with partitioning, correct?
19:14:34 <papoteur> We haven't mention of errata. I mixed with MageiaWelcome.
19:14:43 <lebarhon> There are work arounds for each problem
19:14:59 <marja> papoteur: np..... just wondering where we should put it
19:15:17 <marja> papoteur: at the beginning of installer help is the most logical place
19:15:25 <papoteur> It should be at first step
19:15:31 <marja> but inline installer doesn't show that
19:16:01 <papoteur> marja: inline installer?
19:16:12 <marja> papoteur: oops ...... inline installer help
19:16:34 <marja> papoteur: inline installer help only shows the help for the current installer screen
19:16:51 <marja> papoteur: starting with the selectLanguage screen
19:17:19 <papoteur> marja: yes. Thus we should add it in the first one and where we think there is problems.
19:17:25 <lebarhon> but read the errata is implicit, whatever the release
19:17:46 <marja> lebarhon: true... but 90% don't
19:18:13 <lebarhon> we didn't write it for the previous releases
19:18:34 <marja> 90% of users (tbh, I wasn't even aware there was an errata before I started contributing to Mageia)
19:18:42 <papoteur> We have indication to read errata in MageiaWelcome. It's good for Live media
19:18:59 <marja> I've never seen Mandrake or Mandriva errata, but of course they existed back then, too
19:19:14 <lebarhon> When the installer starts, it is too late to read the errata
19:19:53 <lebarhon> or we should write it where are the downloads
19:20:07 <papoteur> https://www.mageia.org/fr/downloads/
19:20:09 <[mbot> [ Télécharger Mageia 4.1 ]
19:20:21 <papoteur> there is a link to errata
19:20:50 <papoteur> But no invitation to read them.
19:20:53 <marja> maybe we could ask for the errata to be displayed in red
19:21:34 <lebarhon> or a sentence like for unetbootin
19:22:05 <papoteur> lebarhon: yes, I just think to that
19:22:05 <marja> yes, e.g. adding "Read before installing!"
19:22:38 <papoteur> We should propose that to atelier
19:22:43 <marja> leuhmanu: would that be possible?
19:23:04 <lebarhon> leuhmanu: is away :(
19:23:15 <marja> leuhmanu: making the errata link red, and adding "Read this before installing!"
19:23:24 <marja> lebarhon: he'll read it later
19:23:57 <lebarhon> hello leuhmanu
19:24:06 <marja> filip_: the question is to you, too, of course ;-) ^^^
19:24:11 <papoteur> I propose that we write what is to be and send it to atelier ml.
19:24:45 <marja> papoteur: lebarhon: is one of you a member of that list?
19:24:56 <papoteur> not me
19:24:57 <lebarhon> Atelier ? No
19:25:33 <marja> nor me
19:25:40 <lebarhon> it is not mandatory to write them
19:26:00 <lebarhon> who is the leader ?
19:26:01 <marja> let's wait to see whether filip or leuhmanu sees this
19:26:20 <papoteur> lebarhon: who have the keys to write on the site?
19:26:31 <papoteur> marja: OK
19:26:33 <marja> lebarhon: sebsebseb and ...
19:27:10 <marja> and schultz
19:27:23 <papoteur> #action ask to filip or leuhmanu to adapt https://www.mageia.org/fr/downloads/ to read the errata.
19:27:24 <marja> sebsebseb won't have any web rights
19:27:24 <[mbot> [ Télécharger Mageia 4.1 ]
19:27:44 <marja> papoteur: and the /en/ etc version, too ;-)
19:28:37 <papoteur> marja: ;) sorry, I was automatically on the French part.
19:28:48 <papoteur> marja: of course
19:29:10 <marja> papoteur: np.... they'll understand :-) (and also,t hat we need it for Mga5, too)
19:29:44 <lebarhon> mainly for Mageia 5
19:29:52 <marja> lebarhon: true
19:29:54 <papoteur> marja: yes it should be permanent.
19:30:11 <papoteur> OK
19:30:29 <marja> lebarhon: even if the bug you discovered for using free space on a windows partition may have existed longer than just for Mga5 :-/
19:30:43 <papoteur> lebarhon: you wrote some things to adapt the documentation.
19:30:57 <lebarhon> This bug was not there for Mageia 4 non EFI
19:31:04 <papoteur> lebarhon: do you want we review that?
19:31:42 <marja> lebarhon: ah, good to know ....then it is caused by a more recent change
19:31:46 <lebarhon> everything I know about EFI is there https://wiki.mageia.org/en/Installation_using_a_UEFI_firmware
19:31:59 <lebarhon> You can comment it of course
19:33:08 <lebarhon> This page is about uefi but what are the other changes ?
19:33:34 <lebarhon> mostly MCC
19:33:52 <marja> lebarhon: isodumper-0.41-1.mga4 was moved to core/release on april 3
19:34:25 <marja> lebarhon: do you want to adjust the page (so it is no longer in 4 updates_testing)
19:34:58 <lebarhon> Ok, it misses a help
19:35:29 <papoteur> lebarhon: there is an help inside.
19:35:49 <lebarhon> I did see it !
19:36:21 <lebarhon> it said the USB stick must not be mounted for formating ?is t
19:36:37 <lebarhon> */I didn't see it
19:37:15 <papoteur> lebarhon: I don't remember
19:38:01 <lebarhon> not mounted for formatting but mounted for copy
19:38:56 <marja> I don't see that in the help.... I never had a problem using it, though, so maybe isodumper takes care of unmounting/mounting when needed?
19:39:44 <lebarhon> no it doesn't
19:39:52 <marja> I didn't try isodumper with a USB-key that's in use, though... that's a different situation
19:40:06 <papoteur> marja: lebarhon Yes, the key is unmounted before formatting
19:40:15 <marja> papoteur: nice :-)
19:40:22 <lebarhon> not automatically
19:40:37 <marja> lebarhon: well, it cannot unmount if it is in use
19:40:55 <papoteur> there is no ask to unmount befaore formatting in inline help.
19:41:29 <lebarhon> the error message says an error occured but not wich one
19:42:30 <marja> lebarhon: when does that happen? when it is in use (e.g. the file browser looks at the contents of the USB-key)?
19:43:14 <lebarhon> Yes, for example, I connect a key and accept Dolphin opens to read into it
19:43:37 <lebarhon> then I launch isodumper to format the key, I have a message
19:43:58 <lebarhon> An error occured preventing to format. (full stop)
19:44:05 <marja> papoteur: would it be possible to detect that the key is in use, and tell the user that it can't be formatted for that reason?
19:44:07 <papoteur> lebarhon: It's because it can't be unmounted.
19:44:14 <lebarhon> I don't know what to do
19:44:46 <marja> papoteur: or to add to the help that the key must not be in use?
19:44:51 <lebarhon> The help should say: check the key is unmouted
19:45:49 <marja> lebarhon: it does not need to be unmounted, but it needs to not be used... Dolphin must no longer read it
19:46:21 <lebarhon> If I unmount the key it doesn't work either
19:46:36 <lebarhon> The key must be detected and not mounted
19:47:02 <papoteur> lebarhon: no, if the key is mounted, this is not the problem.
19:47:06 <marja> ah, yes, when I unmounted a key, I had to plug it back in
19:47:09 <lebarhon> once mounted, I must unmount, disconnect, reconnect
19:47:23 <lebarhon> it is not obvious
19:47:28 <marja> lebarhon: no, you must close Dolphin without unmounting
19:48:08 <marja> lebarhon: and not have a file or directory of the USB key open in any other application, not even in a terminal
19:48:09 <lebarhon> I will try, but whatever we must do, it is not obvious
19:48:39 <papoteur> I have no problem to format even if the key is open in dolphin :/
19:49:11 <marja> papoteur: ah, never tried that, because I thought that wouldn't work.......will try now
19:49:20 <lebarhon> I often had problems to format, may be the keys are different
19:49:40 <papoteur> Can we discuss about UEFI documentation.
19:49:47 <papoteur> ?
19:49:52 <lebarhon> yes
19:49:56 <marja> yes
19:51:21 <marja> so the errata should tell that our official documentation has not been updated for UEFI installs, because so much is still changing, and advise to read the wiki page before installing
19:51:36 <marja> correct?
19:51:54 <lebarhon> it is a solution
19:52:01 <papoteur> marja: yes, it's a good option
19:52:27 <lebarhon> UEFI still experimental
19:52:35 <papoteur> lebarhon: You mean that there is another option?
19:53:03 <lebarhon> to update documentation for working options
19:53:20 <lebarhon> but indeed, the time will be short
19:53:47 <papoteur> lebarhon: but you have already prepared some texts and SC
19:54:21 <lebarhon> only the wiki page, but it is copy/paste
19:54:51 <marja> lebarhon: there are new RC isos on the way, if we both do an EFI install with those tomorrow, we can maybe update the page this weekend?
19:55:04 <marja> lebarhon: QA RC isos
19:55:24 <lebarhon> the problem is that SC will have RC written
19:55:34 <lebarhon> is it important ?
19:56:15 <papoteur> marja: after that, we have to package the doc to include in the ISOs?
19:56:50 <marja> lebarhon: I'll ask on dev ml how to create an iso from an existing iso, with adjusted stage2 (I know how to change stage2, to remove "mageia 5RC", but don't know how to build an iso
19:57:49 <marja> papoteur: yes... and I didn't recreate the German publications (there were updates pushed from Tx to git, but they weren't in Calenco soon after that)
19:58:10 <admel> It always good to read you, but i've to leave (i know that i'll create a lack here but... ;-) ). See you soon Docteam !
19:58:11 <lebarhon> We could in the help add only two or three ways to install UEFI mode
19:58:26 <papoteur> marja: SC are not so urgent, there are not in ISO, or can be updated.
19:58:53 <papoteur> admgood night
19:59:11 <papoteur> too late ;)
19:59:13 <marja> papoteur: true
19:59:47 <papoteur> but we will have only English version.
20:00:06 <papoteur> (perhaps French too ;) )
20:00:11 <marja> #action marja check whether the German updates got pushed from git to Calenco, and recreate new German publications
20:00:23 <marja> :-)
20:00:34 <psyca> :D
20:00:35 <marja> probably French, too :-D
20:00:54 <lebarhon> Another problem, translators will have difficulties to create SC with UEFI
20:01:18 <lebarhon> not everybody is equipped with UEFI
20:01:37 <lebarhon> and Stage 1 SC aren't easy
20:01:51 <lebarhon> VM UEFI either
20:01:54 <papoteur> lebarhon: are the SC specific to UEFI installations
20:02:01 <marja> lebarhon: yeah, but many translators are already translating without seeing the screens (which is wrong, imho)
20:02:09 <lebarhon> Yes
20:02:26 <marja> papoteur: e.g. the bootloader screen in installer is very different
20:02:32 <lebarhon> May be we could cheat for some
20:02:49 <marja> papoteur: https://wiki.mageia.org/en/File:KO-grub2-installer1.png
20:03:12 <marja> but it already changed: now it has options for install from USB, too
20:03:52 <lebarhon> this one also specific https://wiki.mageia.org/en/File:EFI-solo6_1.png
20:04:07 <marja> lebarhon: indeed
20:04:35 <lebarhon> So marja, your first idea is the best
20:04:53 <lebarhon> we can't translate the official doc about UEFI
20:06:19 <marja> lebarhon: what was my first idea? (just so I won't misunderstand)
20:06:23 <papoteur> lebarhon: not before Mageia 5 Release
20:06:50 <lebarhon> marja: so the errata should tell that our official documentation has not been updated for UEFI installs, because so much is still changing, and advise to read the wiki page before installing
20:07:14 <lebarhon> papoteur: Yes, telling it will be for Mageia 6
20:07:42 <lebarhon> We could perhaps have the text with SC in English
20:07:58 <marja> lebarhon: yeah, ... and also, that won't drive our translators crazy by many last minute changes
20:08:47 <lebarhon> Could we add just a line in the help, saying UEFI is working but experimental?
20:09:10 <lebarhon> because we said everywhere that Mageia 5 will be UEFI able
20:09:58 <marja> lebarhon: I do no longer consider it to be experimental, tbh
20:10:20 <marja> lebarhon: but maybe I'm biased :-)
20:10:43 <lebarhon> then working but documentation still in progress
20:11:10 <marja> lebarhon: yes, I agree with that
20:11:35 <papoteur> Yes
20:12:00 <lebarhon> with a link to the wiki page
20:12:06 <marja> yep
20:12:08 <papoteur> Yes
20:13:01 <papoteur> #action adapt our documentation adding a link to wiki page for UEFI installations
20:13:27 <papoteur> #action https://wiki.mageia.org/en/Installation_using_a_UEFI_firmware
20:14:00 <papoteur> Is it all for the topic ?
20:14:08 <lebarhon> next topic then ?
20:14:16 <marja> do we already have an action for tjhe errata?
20:14:50 <papoteur> marja: yes
20:15:11 <marja> papoteur: the last one?
20:15:11 <lebarhon> who is the writer ?
20:15:29 <marja> papoteur: the one-but-last-one?
20:16:05 <papoteur> marja: yes
20:16:27 <papoteur> lebarhon: we can share the load.
20:16:59 <marja> and where should it go?
20:17:00 <marja> https://wiki.mageia.org/en/Mageia_5_Errata
20:17:06 <papoteur> lebarhon: I can do something this week-end
20:17:22 <marja> Maybe better in the installer part, even if it is documentation?
20:17:37 <lebarhon> I think the sentence marja wrote is good enough
20:18:34 <lebarhon> papoteur: you write the errata and me the documentation
20:19:41 <papoteur> lebarhon: the errata
20:19:54 <papoteur> ?
20:20:16 <lebarhon> we must add something in the errata
20:20:34 <marja> I suggest adding it here https://wiki.mageia.org/en/Mageia_5_Errata#Installer_Issues
20:21:02 <marja> maybe with a header "EFI-installs"
20:21:12 <lebarhon> who volonteers ?
20:21:21 <marja> I can do that
20:21:36 <lebarhon> Thx
20:22:00 <papoteur> OK
20:22:00 <lebarhon> I write the documentation in Calenco
20:22:56 <papoteur> lebarhon: OK
20:23:44 <papoteur> It is late, I think we could stop yet?
20:24:24 <lebarhon> next meeting then ?
20:24:59 <papoteur> Yes, it two weeks?
20:25:12 <papoteur> or sooner ?
20:25:17 <lebarhon> I will be in Solutions Linux (at least, I hope to be there...)
20:25:34 <papoteur> Which date is it?
20:25:40 <marja> https://wiki.mageia.org/en/Mageia_5_Errata#UEFI-installs
20:26:08 <marja> lebarhon: I heard there won't be SL (or was that an april fool's joke?)
20:26:29 <marja> april 23
20:26:30 <papoteur> marja: perfect
20:26:38 <lebarhon> Mageia doesn't go there ?
20:26:56 <marja> lebarhon: I heard no one goes there... but maybe it was a joke :-/
20:27:34 <papoteur> marja: Ah?
20:27:34 <lebarhon> no one ? from Mageia or SL is canceled ?
20:27:35 <marja> lebarhon: it is still anounced
20:27:47 <marja> lebarhon: I guess it was a bad joke
20:28:02 <lebarhon> I don't know
20:28:11 <marja> lebarhon: http://www.solutionslinux.fr/ May 19 + 20
20:28:12 <[mbot> [ Solutions Linux / Open Source - le Salon européen dédié à Linux et aux Logiciels Libres ]
20:29:03 <marja> papoteur: do you have time for a meeting in RL 2nd half of May or June (as lebarhon suggested)?
20:29:09 <lebarhon> I mixed april and may, sorry, in two weeks I will be present
20:29:25 <marja> lebarhon: no problem :-)
20:29:44 <lebarhon> wednesday April 23
20:30:04 <marja> wednesday instead of thursday?
20:30:30 <marja> wednesday would be 22
20:30:36 <lebarhon> another mistake 23 is thursday !
20:30:45 <papoteur> :)
20:30:49 <marja> lebarhon: np.... it is late :-)
20:31:10 <marja> Thursday 23, 19h UTC, 21h CEST
20:31:15 <lebarhon> yes but it is summer time, not so mate
20:31:21 <lebarhon> *late
20:31:32 <papoteur> OK
20:32:03 <papoteur> I must check for May.
20:32:14 <marja> papoteur: we'll hear it when you know
20:32:23 <papoteur> OK
20:32:51 <marja> so if there is SL, it could be then, too
20:33:28 <marja> close meeting?
20:33:41 <papoteur> marja: Yes, we can
20:33:59 <papoteur> lebarhon: ?
20:34:02 <marja> lebarhon: OK with closing the meeting?
20:34:06 <lebarhon> ok
20:34:10 <marja> #endmeeting