20:47:24 <papoteur> #startmeeting
20:47:24 <Inigo_Montoya> Meeting started Tue Feb 10 20:47:24 2015 UTC.  The chair is papoteur. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:47:24 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:47:43 <marja11> Inigo_Montoya: doesn't seem to like typos ;-)
20:47:43 <Inigo_Montoya> marja11: Error: "doesn't" is not a valid command.
20:47:47 <marja11> lol
20:48:30 <lebarhon> l'arroseur arrosé :)
20:48:35 <papoteur> which topic first?
20:48:36 <marja11> papoteur: after you did your topic, I'd like to add one : what about deleting epub and pdf publications with few screenshots
20:48:55 <marja11> after your topics
20:49:00 <papoteur> OK
20:49:31 <papoteur> #topic who's new?
20:49:56 <marja11> Ard1t: have you ever been in a docteam meeting before?
20:50:24 <papoteur> Is there someone who is not yetin our meeting
20:51:14 <papoteur> No one ?
20:51:26 <marja11> barjac: diogenese: leuhmanu: MrsB: pasmatt: Qilaq: feel free to join our meeting
20:52:39 <papoteur> # I have not yet access to my emails, which topic I have announced?
20:52:48 <marja11> papoteur: no one is used to a docteam meeting on Tuesday, I guess you weren't the only one for which this is very new
20:53:08 <marja11> papoteur: What's new for Mageia 5? Anything do document?
20:53:08 <marja11> What's to package?
20:53:08 <marja11> Please ask for other topic to add.
20:53:18 <lebarhon> topics :What's new for Mageia 5? Anything do document?
20:53:18 <lebarhon> What's to package?
20:53:23 <marja11> :-)
20:53:42 <lebarhon> sorry
20:53:42 <papoteur> Ok
20:53:59 <marja11> filip_: oops, I missed you, you're welcome, too, of course
20:54:18 <papoteur> #topic what new in Mageia 5 to document?
20:54:45 <marja11> the changed way to EFI install
20:54:52 <marja11> but I need to investigate more
20:55:00 <lebarhon> We need material for that
20:55:02 <papoteur> I think that something is changed in the installer.
20:55:27 <papoteur> But I have not yet tested it.
20:55:28 <marja11> it worked very much out of the box for me, but that may have been because it was just upgrade-installs I ded
20:55:31 <marja11> did
20:56:00 <lebarhon> It seems, no need to mount /boot/efi and installer can create the partitions
20:56:10 <marja11> papoteur: are you referring to EFI, or to something else?
20:56:10 <papoteur> marja11: do you noticed changes in screens?
20:56:29 <papoteur> EFI at least
20:56:42 <marja11> lebarhon: yes, pterjan added gpt support to drakx
20:57:38 <papoteur> Also the default partitionning (use all the place) changed.
20:57:40 <marja11> lebarhon: it cannot, of course, create gpt partitions on a legacy disk (but no partioner can do such a mix)
20:58:01 <lebarhon> A large part of the documentation needs to be re-written
20:58:02 <marja11> papoteur: yes, I hope it'll be better again, soon
20:58:27 <marja11> papoteur: Akien said that screen was good again in vm, with last night's iso
20:58:34 <papoteur> lebarhon: can you be more accurate?
20:59:17 <lebarhon> doc installer doesn't talk about the two partition options DOS/UEFI
20:59:30 <marja11> true
20:59:33 <papoteur> lebarhon: OK
20:59:40 <lebarhon> there is also the default Btrfs
21:00:16 <marja11> lebarhon: papoteur: I think we should add to the errata that it doesn't, and first get the Mageia 5 UEFI wiki page correct
21:00:19 <lebarhon> and the default partitions size (50Go for /)
21:00:19 <papoteur> I did not experienced that. And you ?
21:00:32 <marja11> lebarhon: forgot about that :-/
21:00:56 <marja11> lebarhon: I've only seen default Btrfs in Live installs
21:01:06 <marja11> lebarhon: not in traditional
21:01:12 <papoteur> lebarhon: Yes, this should be a new item, as we have nothing about that yet
21:02:02 <lebarhon> marja11: I don't know about traditionnal
21:02:12 * marja11 wonders how much we should change at this point..... maybe better to contact l10n team, before driving them crazy
21:02:51 <lebarhon> We can start with Wiki page until Mageia 6 when things are clearer
21:03:00 <marja11> lebarhon: the only time I got btrfs partitions, was with a Live install, it never happened to me with traditional iso
21:03:13 <papoteur> marja11: we couldn't document before, because the options wasn't stabiilized
21:03:22 <lebarhon> I can't says as I can't install
21:03:26 <marja11> lebarhon: yes, that would be my preferred way, even for the default partitions size
21:04:04 <lebarhon> We could write and translate a wiki page about news in Mageia 5
21:04:08 <papoteur> Ah?
21:04:13 <marja11> lebarhon: forget what I just said, I nearly never let installer choose
21:04:39 <marja11> lebarhon: the release notes
21:04:58 <marja11> lebarhon: usually the packagers put in it what they think is important
21:05:17 <papoteur> I think we need at least some explanation from devs.
21:05:25 <lebarhon> marja11: do you say realease not are enough as documentation ?
21:05:30 <lebarhon> notes
21:05:36 <marja11> lebarhon: I think so
21:05:44 <marja11> lebarhon: and, of course, the errata
21:06:21 <lebarhon> release notes have no screenshots
21:06:44 <lebarhon> release notes imho aren't for newcomers
21:06:51 <marja11> lebarhon: true
21:07:17 <papoteur> marja11: can you say what is your point of view about the cycle of official documentation?
21:07:26 <marja11> lebarhon: I know you're very capable of writing something about what's new for newcomers
21:07:55 <lebarhon> if I have materials
21:08:01 <marja11> papoteur: it would have been nice to have the changes in it, before Mga5 release, but we're too late for that, I think
21:08:49 <papoteur> Ok, thus at which time should we publicate a new set?
21:09:06 <marja11> papoteur: so I think we should indeed have an errata for what is no longer up to dat in our documentation, linking to wiki pages with correct information
21:09:21 <marja11> papoteur: and update asap after Mga5 release
21:09:56 <marja11> papoteur: lebarhon: the only exception is if something is needed for the inline help for traditional installer
21:10:11 <marja11> papoteur: lebarhon: because that can't be updated after release
21:10:21 <marja11> however, MCC help can
21:10:39 <marja11> and online installer help can, pdf and epub can
21:11:17 <papoteur> there is no screenshots for the inline documentation
21:11:30 <marja11> papoteur: indeed
21:11:35 <papoteur> Thus we need only text.
21:11:37 <marja11> papoteur: and not all pages are visible
21:11:53 <marja11> papoteur: only the ones that are called from a help button
21:12:15 <papoteur> Is only the English version availble inline or also the translated versions?
21:12:48 <marja11> papoteur: also the translations, and the partly translated if I added them
21:13:15 <marja11> papoteur: I think we currently have 20 or more languages
21:13:49 <papoteur> marja11: thus, we need also translations about new matter.
21:14:19 <lebarhon> I thing we will have many changes after Mageia 5 release
21:14:41 <lebarhon> because we have not many UEFI testers
21:14:43 <marja11> papoteur: all blue directories here are for a different language, and then there is English http://gitweb.mageia.org/software/drakx-installer-help/tree/?id=5.2
21:14:45 <[mbot> [ drakx-installer-help - Mageia Installer Help ]
21:15:07 <marja11> papoteur: yes, everything we write needs to be translated
21:16:02 <marja11> so 22 translations + English (well, in fact pt and pt_BR are the same, currently)
21:17:04 <marja11> lebarhon: we won't get bored..... and then there is manapan (AdminPanel) to start on
21:17:35 <lebarhon> never heard of
21:17:41 <papoteur> I don't figure exactly which work is needed to adapt for the new stuff
21:18:22 <marja11> lebarhon: that is the libyui port of DrakX..... it allows for 21st century looks of our tools
21:18:40 <marja11> lebarhon: but also to use all tools with ncurses, so without X
21:19:07 <lebarhon> so we can put MCC help in the trashbin
21:19:20 <marja11> lebarhon: no, we can re-use most of it
21:19:37 <lebarhon> but hopefully it is for Mageia 23
21:19:58 <marja11> lebarhon: I don't think it'll be ready for Mageia 6, or even 7
21:20:21 <lebarhon> well, come back to 5
21:20:28 <marja11> lebarhon: but I'll create a separate workspace in Calenco to work on it
21:20:51 <marja11> lebarhon: yeah, let's focus on Mga5
21:21:02 <lebarhon> Can we write an updated installer help in 22 languages before march ?
21:21:14 <lebarhon> *update
21:21:46 <marja11> lebarhon: is there anything you can think of, now, that is connected with a help button in installer and needs to be updated before release?
21:22:32 <marja11> lebarhon: for the tranlations, we should ask l10n, or filip_ if he hears us now
21:22:39 <papoteur> I will review the installer documentation and see what is to adapt.
21:22:50 <lebarhon> format, main partitions, size, FS...
21:23:11 <marja11> papoteur: wb
21:23:23 <lebarhon> papoteur is blinking
21:23:36 <marja11> papoteur: lebarhon just mentioned "format, main partitions, size, FS..."
21:23:44 <papoteur> sorry, the connection seems weak
21:23:59 <marja11> but I don't even know what of that really changed :-(
21:24:15 <marja11> ah, yes, gpt
21:24:19 <lebarhon> that is the problem
21:24:20 <papoteur> marja11: me too :/
21:24:48 <papoteur> HI psyca
21:24:48 <lebarhon> We could write a list on the wiki and each one try to complete
21:24:55 <psyca> Hi papoteur
21:24:56 <marja11> akien will know about the default partitioning
21:25:10 <papoteur> psyca: we have doc meeting. You can join us.
21:25:13 <marja11> psyca: hi
21:25:20 <psyca> k... hi marja11
21:25:37 <marja11> psyca: you might even be able to help, we are wondering what changed for traditional installer
21:25:40 <papoteur> marja11: Yes, but I saw the exchange. It's not a problem.
21:25:58 <marja11> papoteur: good
21:26:37 <papoteur> but about btrfs, I don't know anything
21:26:41 <psyca> marja11: compared to mga4?
21:26:41 <marja11> papoteur: thx for having offered to review the installer documentation
21:26:49 <marja11> psyca: yes
21:27:26 <lebarhon> We could write a list of what changed on the wiki and each one try to complete
21:27:29 <marja11> psyca: and we don't really know when which installer defaults to btrfs partitioning, and when to ext4 (if still)
21:27:58 <marja11> lebarhon: or ask dev team?
21:28:18 <lebarhon> they have no time for us
21:28:34 <papoteur> Yes, we should ask dev list.
21:29:05 <marja11> tbh, I think we should add in installer help that there are languages for which the keyboard choice screen at the beginning of install is not shown
21:29:06 <psyca> hm... i selected btrfs manualy.. didnt recognised that it switch automaticly... doesnt it use ext4 as default yet in beta2
21:29:14 <lebarhon> I think it is Btrfs for new partitions but the existing ones stay ext4
21:29:24 <papoteur> #info ask dev team about changes on default partitionning (size, fs).
21:29:53 <psyca> if i select autocreate (empty disk) for full drive it uses ext4
21:30:16 <lebarhon> psyca: Btrfs came with M5B3
21:30:27 <marja11> and that if you don't see that screen, then try adding an additional language at the beginning of install
21:30:40 <psyca> ok... i only test the iso releases... no M5B3 on Servers :(
21:30:44 <papoteur> marja11: keyboard, is it a bug or a feature?
21:31:13 <psyca> public servers
21:31:33 <marja11> papoteur: it has been like that since at least 10 years ago, but I consider it to be a bug, except for like in Chinese, when it is impossible to have a different keyboard
21:32:02 <marja11> papoteur: https://bugs.mageia.org/show_bug.cgi?id=12348
21:32:04 <[mbot> [ Bug 12348 Classic installer does not offer keyboard layout for some languages until summary screen ]
21:32:04 <papoteur> marja11: OK.
21:32:38 <lebarhon> Bug 12348 for Gnome only
21:33:24 <marja11> papoteur: it was fixed for Turkish recently, but won't be fixed for other languages before Mga5 release (and only if the Tr fix doesn't show regressions)
21:33:25 <papoteur> Is it all for the installer for the moment?
21:33:52 <marja11> lebarhon: that's a different bug https://bugs.mageia.org/show_bug.cgi?id=14476
21:33:54 <[mbot> [ Bug 14476 gdm and gnome fail to use the right keyboard layout ]
21:34:06 <lebarhon> OK Thanks
21:34:13 <marja11> lebarhon: and now valid for KDE, since it was fixed for Gnome :-/
21:34:19 <marja11> papoteur: yes, I think so
21:34:52 <papoteur> Is there something new in the MCC?
21:35:12 <marja11> papoteur: isodumper should have been in it
21:35:22 <papoteur> marja11: :)
21:35:39 <lebarhon> it will be in manapan
21:35:41 <marja11> papoteur: maybe we can ask anaselli and pasmatt to add it to AdminPanel/ManaPan
21:35:50 <marja11> lebarhon: yes :-)
21:36:12 <papoteur> yes, it's possible.
21:36:21 <lebarhon> but isodumper isn't good for UEFI
21:36:47 <papoteur> I proposed a patch to add Isodumper in MCC, without success :/
21:37:14 <papoteur> lebarhon: error, you don't see the new version.
21:37:22 <marja11> lebarhon: ah, you mean you want a way to copy the contents of an iso to a USB-stick?
21:37:57 <marja11> papoteur: yeah.... can you remind me of the bug report number which contains your patch?
21:38:00 <lebarhon> Yes, can isodumper do it?
21:38:41 <papoteur> lebarhon: Yes, but this version is not yet packaged. In some days.
21:38:49 <marja11> papoteur: \o/
21:39:00 <lebarhon> BTW why is it possible to use dd to copy an ISO on USB stick with Ubuntu and not Mageia?
21:39:01 <papoteur> marja11: It was a message in dev-list
21:39:11 <pasmatt> marja11: do you mean adding isodumper to adminpanel?
21:39:18 <marja11> papoteur: if you have time, then please file a bug report for it
21:39:21 <marja11> papoteur: yes
21:39:26 <marja11> oops
21:39:29 <marja11> pasmatt: yes
21:40:17 <papoteur> lebarhon: I don't know.
21:41:10 <papoteur> #todo papoteur file a bug for isodumper in MCC or adminpael.
21:41:26 <marja11> lebarhon: I don't know, either, but have been told I should use cp and not dd
21:41:32 <papoteur> Other new thing in MCC
21:41:34 <papoteur> ?
21:41:58 <marja11> the security stuff was already updated by you guys, IINM
21:42:27 <marja11> msec and such
21:43:00 <lebarhon> Can MCC write in Grub2 ? boot order for ex
21:43:06 <marja11> I think there is nothing new, only the risk of losing things
21:43:28 <marja11> lebarhon: you can choose Grub2, but the next screens are meaningless
21:43:44 <marja11> lebarhon: like in installer, they don't do anything for Grub2
21:44:08 <papoteur> OK
21:44:28 <marja11> lebarhon: so no, you cannot change the Grub2 boot order in MCC
21:44:52 <papoteur> If you detect something, you can expose it on ML or to the next meeting.
21:44:52 <lebarhon> grub-customizer is always there
21:45:25 <marja11> lebarhon: yes, it would be good, if it isn't mentioned in our MCC help, to mention that
21:45:45 <lebarhon> I don't think we talk about it
21:46:17 <marja11> I don't remember having seen it
21:46:21 <lebarhon> grub-customizer can manage grub2-efi ?
21:47:01 <marja11> lebarhon: I don't know, never tried.... but I manage efi boot order with efibootmgr
21:47:14 <marja11> lebarhon: efibootmgr is a cli tool, though
21:47:40 <lebarhon> So we need to doc efibootmgr somewhere
21:48:00 <marja11> lebarhon: yes, indeed.... I should :-/
21:48:23 <papoteur> wiki or doc?
21:48:26 <lebarhon> you or someone else
21:48:39 <marja11> papoteur: start on wiki, when good add in doc
21:49:02 <lebarhon> if we say that doc have all is needed to install and configure Mageia, ...
21:49:23 <papoteur> #info marja will start a wiki page about efibootmgr.
21:49:29 <marja11> papoteur: thx
21:49:31 <papoteur> OK?
21:49:36 <marja11> yep
21:49:48 <lebarhon> lewis write a wiki page about it
21:49:57 <papoteur> ?
21:50:08 <marja11> lebarhon: ah, that saves me work :-)
21:50:29 <lebarhon> #link https://wiki.mageia.org/en/About_EFI_UEFI
21:50:55 <lebarhon> I didn't understand much
21:51:17 <marja11> I wrote this, about when it goes wrong with efibootmgr https://wiki.mageia.org/en/EFI:_can_no_longer_boot_into_Mageia
21:52:13 <lebarhon> I tried Supergrub2, did not boot :(
21:52:42 <marja11> lebarhon: did you set it as boot-first device?
21:53:02 <papoteur> OK, you have just to check that lewis has a good level ;)
21:53:03 <lebarhon> yes, it is automatic
21:53:07 <marja11> lebarhon: tbh, I only tried it on CD and DVD, never on USB
21:53:32 <lebarhon> USB is often a problematic method
21:53:39 <marja11> lebarhon: :-/
21:54:33 <lebarhon> nest topic ?
21:54:43 <papoteur> What else?
21:54:44 <marja11> fine with me
21:55:21 <marja11> papoteur: pdf and epub publications with few screenshots ...... delete them on docteam.mageia.nl ?
21:55:39 <marja11> papoteur: ah, and we still need to use your front page!
21:55:40 <papoteur> #topic What's to package?
21:56:04 <marja11> the front page you made
21:56:19 <papoteur> #undo
21:56:19 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Topic object at 0xa4bd16c>
21:56:35 <papoteur> #topic publications
21:57:21 <marja11> I have the feeling that, especially for newcomers, publications with many missing screenshots are no good
21:57:26 <lebarhon> what are the advantages?
21:57:32 <papoteur> marja11: I think docteam.mageia.nl is a tool to work.
21:57:40 <lebarhon> too late
21:57:51 <marja11> papoteur: yes, but now it is linked to from the new documentation page in the wiki
21:57:54 <papoteur> marja11: we have no obligations to have all on it.
21:58:09 <papoteur> ?
21:58:19 <marja11> no, there is no obligation
21:59:05 <marja11> it is nice, for translators, to see the webhelp, and the webhelp can be adjusted on mageia.nl to  use the En screenshots for missing localised ones
21:59:13 <marja11> so the webhelp is no problem
21:59:15 <papoteur> I don't find the links
21:59:34 <marja11> papoteur: in red squares
21:59:54 <marja11> papoteur: the pdf/epub links are to docteam.nl
22:00:08 <marja11> papoteur: because they aren't on docteam.org, yet
22:00:12 <lebarhon> marja11: you means thre are doc that is translated without the screenshots?
22:00:52 <marja11> lebarhon: we miss an incredible amount of screenshots
22:01:18 <marja11> lebarhon: just compare the sizes of the publications http://docteam.mageia.nl/PDF/MCC/
22:01:19 <[mbot> [ Index of /PDF/MCC ]
22:01:25 <papoteur> marja11: sorry I don't find
22:01:33 <lebarhon> I can't understand someone did the hard work, translate, and not the easy one
22:02:16 <marja11> papoteur: https://wiki.mageia.org/en/Documentation
22:02:22 <papoteur> I get screenshots for romanian, done by Dune.
22:02:38 <lebarhon> why don't put the English screenshot instead?
22:02:54 <marja11> papoteur: click on epub format or pdf format in a red box
22:03:10 <marja11> lebarhon: then the script to find missing screenshots won't work any longer
22:03:34 <papoteur> marja11: OK,
22:03:42 <marja11> lebarhon: the only thing I can do (and do) is run a script to change links to missing screenshots in the webhelp, to link to En screenshots
22:04:02 <marja11> lebarhon: then the missing screenshot script still works
22:04:47 <marja11> apart from that, we need to create new pdfs with papoteur's front page
22:05:18 <papoteur> marja11: Yes, it's possible to withdraw incomplete documents.
22:05:51 <lebarhon> No SC is better no no help at all
22:06:51 <marja11> OK, I'll remove all that are remarkably smaller than 10MB (10Mo) for MCC pdf
22:06:59 <papoteur> marja11: do you lack space?
22:07:22 <marja11> and I'll try to grab the missing stage2 installer screenshots soon
22:07:30 <marja11> papoteur: remmy didn't complain
22:07:42 <papoteur> ;)
22:08:18 <marja11> papoteur: but he hopes we'll move to mageia.org, he always intended this to be a temporary solution
22:08:18 <papoteur> for -cover, what is to do?
22:09:01 <papoteur> I don't remember.
22:09:36 <marja11> papoteur: well, either I should merge * and *-cover, and add some tags so that the correct part is used when the different publications are made
22:10:04 <marja11> or I should remove all pdf publications and redo them with *-cover
22:10:18 <marja11> papoteur: do you have access to docteam.mageia.nl?
22:10:27 <papoteur> marja11: no.
22:11:00 <marja11> papoteur: give me an #Action to fix the pdf's, please
22:11:12 <papoteur> marja11: do we need -cover for each language?
22:11:38 <marja11> papoteur: yes, I think it's already translated, isn't it?
22:11:47 <papoteur> #action marja will fix the PDF publications.
22:11:48 <marja11> papoteur: at least, that's what I thought I saw
22:11:54 <marja11> papoteur: thx
22:12:41 <papoteur> not sure
22:13:03 <marja11> I'll login to Calenco and look
22:13:20 <papoteur> #action papoteur check that *-caover are available for each publication.
22:13:57 <papoteur> lebarhon: do you know what is *cover?
22:14:10 <marja11> my fingers are too twisted, don't manage to type my password :-/
22:14:14 <lebarhon> no, a cover I suppose
22:14:16 <marja11> oh, but I can look in git
22:15:54 <papoteur> lebarhon: A PDF publication with a cover. I modfied Drakx.xml in DrakX-cover.xml
22:16:28 <marja11> papoteur: I see it for DrakX.cover, but not for MCC-cover
22:17:02 <papoteur> #todo papoteur creates MCC-cover
22:17:27 <marja11> papoteur: thx
22:17:46 <papoteur> Ok, I think it is late. I propose to stop yet.
22:17:58 <marja11> papoteur: good idea :-)
22:18:07 <lebarhon> Why keep Drakx.xmll
22:18:12 <marja11> papoteur: thx for having called for the meeting
22:18:25 <marja11> lebarhon: for the non-pdf publications
22:18:38 <lebarhon> Thx and good night everyone
22:18:45 <papoteur> We should have a next meeting before months.
22:18:52 <marja11> lebarhon: good night
22:18:58 <marja11> papoteur: yes, indeed
22:19:15 <papoteur> in two weeks?
22:19:22 <marja11> papoteur: fine
22:19:36 <lebarhon> before Mageia release
22:19:59 <papoteur> we will say the day on ML.
22:20:10 <marja11> lebarhon: that'll be before release, beta3 release and rc will come first
22:20:13 <lebarhon> not a monday
22:20:16 <marja11> papoteur: OK
22:20:29 <marja11> lebarhon: fine with me
22:20:48 <marja11> papoteur: lebarhon: again on Tuesday?
22:20:56 <lebarhon> yes
22:21:15 <papoteur> marja11: no, I am in genral in train at this time.
22:21:22 <marja11> papoteur: ouch
22:21:39 <papoteur> le jeudi, c'est mieux pour moi.
22:21:45 <marja11> papoteur: d'accord
22:21:50 <lebarhon> Ok for jeudi
22:21:51 <marja11> lebarhon: jeudi?
22:21:54 <marja11> :-)
22:22:08 <papoteur> OK
22:22:15 <papoteur> #endmeeting