19:00:48 <marja> #startmeeting
19:00:48 <Inigo_Montoya> Meeting started Mon Nov 11 19:00:48 2013 UTC.  The chair is marja. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:48 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:18 <marja> #topic transifex.com
19:01:24 <marja> #link https://www.transifex.com/projects/p/mageia/
19:01:25 <[mbot> [ Mageia localization ]
19:02:08 <marja> yurchor: sorry, I didn't get around to testing it.... but then, is it ready for testing?
19:02:36 <yurchor> Yes. It's even ready for the prime time now.
19:02:46 <marja> yurchor: perfect
19:03:28 <marja> #info our transifex instance is ready to be used
19:03:33 <yurchor> ~10 packages are not fully uploaded. I work on it now.
19:03:41 <marja> yurchor: thx a lot
19:03:46 <yurchor> Docs packages are ready.
19:03:58 <yurchor> np.
19:04:10 <marja> #info all docteam translations are in transifex.com now
19:04:34 <swecarp> this new translation thing looks easy to use havent tryed it and has lost all the mail about it
19:04:51 <Kernewes> ditto
19:05:01 <yurchor> oops...
19:05:18 <marja> swecarp: Kernewes: if it isn't in the wiki yet, we'll get a how to in the wiki
19:05:48 <yurchor> Register, join the team, translate... Have no time to write about it yet.
19:05:55 <yurchor> Sorry...
19:06:08 <Akien> It's quite straight forward for translators
19:06:18 <marja> swecarp: Kernewes: btw, old i18n and docteam mails can be read over the archives https://ml.mageia.org/l/home
19:06:19 <[mbot> [ Mailing lists service - home ]
19:06:20 <Akien> It's just as yurchor said
19:06:27 <swecarp> at the moment im qa testing the isos so i will start when the b1 is out
19:06:36 <marja> yurchor: np, someone else can do that
19:07:03 <swecarp> remember i nead an idiots guied
19:07:13 <Kernewes> ditto
19:07:52 <Kernewes> I have to tell you, though, I have a very busy 2 or 3 months coming up
19:07:57 <yurchor> swecarp: I am a lecturer at the local university. I know anything about idiots...
19:07:58 <Akien> Until there's a guide feel free to ask me (maybe not during the meeting), I can guide you through the starting steps
19:07:59 <Kernewes> major changes at the club that I'm secretary of
19:08:20 <Kernewes> so i probably won't be able to do anything much for Mageia for the rest of this release cycle
19:08:38 <marja> Kernewes: no problem, thanks for all you have done so far!
19:08:53 <Kernewes> Once that's over I won't be secretary any more
19:09:05 <Kernewes> so then I hope I can do more for docs and QA teams again
19:09:05 <swecarp> yurchor:  hehe
19:09:28 <yurchor> Kernewes: This gives us some time to write good guides before you will have some time. ;)
19:09:36 <Kernewes> yurchor: :)
19:09:52 * swecarp will be the test person Kernewes
19:10:13 * Kernewes thinks swecarp is very brave
19:10:38 * marja is signing up now
19:12:15 <Akien> Basically, you have to: register an account on transifex.com, go to https://www.transifex.com/projects/p/mageia and search for the language team that interests you
19:12:17 <[mbot> [ Mageia localization ]
19:12:39 <marja> I'm probably too much in a hurry, can't find nl_NL, only nl_BE (which would be fine with me, too)
19:12:44 <Akien> The ask to join this team, and once you are approved by an admin (e.g. yurchor or I), you're ready
19:13:36 <Akien> marja: https://www.transifex.com/projects/p/mageia/language/nl/
19:13:39 <[mbot> [ Dutch Translation for Translation | Transifex ]
19:13:46 <marja> ah, shouldn't have looked at the drop down list
19:14:18 <marja> Akien: yes, I had seen that, but thought that for joining a team I needed to choose from the drop-down list
19:15:41 <Akien> marja: You mean the drop-down list at the bottom of the page? It's for the language of the Tx interface
19:16:18 <Akien> Ah no I understand
19:16:29 <Akien> It's when registering your account, you can chose your language
19:17:01 <Akien> I find nl, nl_BE and nl_NL there.
19:17:34 * swecarp has created a acount
19:17:55 <marja> Akien: the drop-down menu at the top of this page https://www.transifex.com/projects/p/mageia/
19:17:56 <[mbot> [ Mageia localization ]
19:18:19 <marja> Akien: next to "language"
19:19:12 <marja> Akien: I should have ignored that drop down list , and gone to Dutch further down the page
19:19:18 * yurchor approved swecarp and lebarhon
19:19:55 <marja> Akien: sorry, it never was a menu, but just a list .... I guess only for languages we don't use
19:19:56 <Akien> Akien: I don't see the drop-down list, but I trust you :p
19:19:59 <swecarp> ty
19:20:19 <Kernewes> what drop-down list at the top of the page?
19:20:23 <Akien> When you click "Add a language" maybe?
19:20:23 <Akien> Then it's probably for the languages we don't have yet
19:20:42 <marja> Kernewes: maybe one only sees it when not accepting a lot of JS
19:21:15 <Kernewes> marja: maybe
19:21:25 <Akien> Ah could be. Either way, yurchor imported most translations today, so all our language team already exist.
19:21:32 <Akien> You can sort the list by name to find your language.
19:21:39 <Kernewes> marja: so this includes all the Calenco docs?
19:21:42 * Kernewes is confused
19:21:51 <marja> Akien: did you receive my request to join the Dutch team?
19:22:06 <marja> Kernewes: yes, the translations
19:22:09 <yurchor> Kernewes: Yes. Installer and MCC docs.
19:22:37 <Kernewes> In Calenco there seemed to be a longer list of MCC docs
19:22:52 <yurchor> marja: What is your username?
19:22:56 <marja> Kernewes: here we only have the po
19:23:10 <marja> yurchor: it is marja
19:23:16 <Akien> marja: I don't see your request
19:23:30 <marja> yurchor: I'll accept all JS and try again
19:23:33 <Kernewes> marja: you mean the others will be added later?
19:23:39 <Akien> The resources can be seen here: https://www.transifex.com/projects/p/mageia/resources/
19:23:40 <[mbot> [ Resources - Translation Project ]
19:23:48 <Akien> There is installer-doc and mcc-help
19:24:21 <Kernewes> Akien: are those two very long files with everything in them?
19:24:29 <yurchor> marja: No need to apply. I have already added you.
19:24:37 <Akien> Kernewes: Indeed
19:24:41 <marja> yurchor: thx
19:25:19 <Kernewes> Akien: but a person can translate only a small bit at a time?
19:25:58 <marja> Kernewes: every single line helps, no need to do all
19:26:06 * Kernewes is glad to hear that
19:27:17 <marja> #action marja write a few lines in the wiki about joining a language team in transifex.com, and about accepting JS while doing so
19:27:40 <marja> Is there more about this topic?
19:28:23 <lebarhon> how is tx sync with calenco and git ?
19:28:34 <swecarp> just 1 question is it on line translating ore can i dl the part id like to translate a doit lokaly
19:28:57 <Akien> swecarp: You can do both, either online or offline
19:29:34 <swecarp> ok off line i prefer then i can do some on my brakes at work
19:30:06 <Akien> I'm a bit concerned about the size of the files though.
19:30:24 <Akien> yurchor: Do you know if it is now possible that several work on the same file at the same time?
19:30:37 <marja> yurchor: do you mind answering lebarhon's question... I know the intention is to get an automatic sync, but we don't have that yet,do we?
19:30:39 <Akien> s/several/several persons/
19:31:05 <Akien> marja, lebarhon: It's not synced for now.
19:31:09 <yurchor> lebarhon: Sorry, still uploading translations...
19:31:37 <Akien> For git <> Tx, the idea would be to commit the .tx folders for each subproject in git, so that it's easy to just use tx client to pull/push to/from git
19:31:55 <yurchor> lebarhon: Yes, it just need one additional command (tx pull/tx push).
19:31:56 <Akien> We can then write a pretty simple job that could do the sync
19:32:09 <Akien> For Calenco I don't know
19:32:18 <yurchor> Akien: Yes. It's wiki style tool.
19:32:51 <yurchor> For docs everything is in its place.
19:32:58 <marja> oops, I still have some uncommitted strings I translated on the train yesterday
19:33:13 <yurchor> For soft we should make some conversation with devs.
19:34:04 <yurchor> marja: Upload them directly to transifex.
19:35:18 <marja> yurchor: can I upload the entire po to tx?
19:35:55 <papoteur> What is the tx client?
19:36:08 <marja> yurchor: sorry, I'm wasting your time because I didn't read up enough on it
19:36:13 <yurchor> marja: Sure.
19:36:33 <lebarhon> So, for now, Tx is only a po editor
19:36:41 <marja> yurchor: I'll reread all the mails
19:36:57 <yurchor> papoteur: It's a simple script to work with transifex directly from command line.
19:37:17 <yurchor> lebarhon: Actually no.
19:37:32 <lebarhon> yurchor: what more ?
19:38:06 <yurchor> lebarhon: It's your mailing list, notification system and TM.
19:38:15 <Akien> (translation memory)
19:38:38 <lebarhon> Lokalize is a po editor with TM
19:38:58 <papoteur> For tx client : http://support.transifex.com/customer/portal/articles/960804-overview
19:38:59 <[mbot> '[ Transifex |\r \r Overview ]'
19:39:25 <marja> papoteur: thx for the link
19:40:07 <Akien> lebarhon: But with Tx you get everything at hand, since a few persons did the work to upload everything
19:40:28 <Akien> So new translators can access the translations directly, and the TM, without having to set up a Lokalize project
19:40:39 <Kernewes> do you have to use transifex with the command line?
19:40:53 <Akien> The idea is to make things simple to newcomers, and also simpler for us
19:41:30 <Akien> Kernewes: No, it's only needed to handle the whole project easily
19:41:53 <Akien> e.g. if we want to push _all_ translations to git, it's easier with the command line than to download each file from the web interface
19:41:58 * Kernewes will need all her brain cells to remember the foreign words and won't have any memory left for CLI commands
19:42:08 <Akien> But regular translators just take care of one file at a time normally
19:42:35 <Akien> Basically, you can leave the CLI to yurcho, filip and I
19:42:42 <Akien> s/yurcho/yurchor/
19:43:41 <Akien> Ideally, the translators will only have to use Tx (and their local translation software if they prefer to work offline)
19:43:56 <Akien> Only a handful of i18n warriors will do the link with git
19:44:34 <marja> Akien: so no git and svn commit rights are needed anymore for most translators?
19:44:40 <lebarhon> Who does the link with Calenco ?
19:45:06 <marja> lebarhon: ideally, the one who commits the MCC-help or installer-help po to git
19:45:15 <yurchor> lebarhon: Anybody who wants to do this.
19:45:21 <Akien> marja: We'll have to think a bit more about it, but I think you are right
19:45:33 <Akien> marja: It depends how we manage to sync git and Tx
19:45:37 <yurchor> E.G. me as an owner of the repo.
19:45:46 <lebarhon> marja: yurchor, there is the problem with the screenshots
19:46:01 <marja> lebarhon: what is the problem?
19:46:19 <yurchor> lebarhon: Sure. But it's a general problem, not Tx-related.
19:46:22 <marja> lebarhon: it should be possible again to upload them
19:46:39 <lebarhon> it isn't the same people to upload xml and screenshots to Calenco
19:47:15 <yurchor> H-m-m... What prevents people from uploading screenshots?
19:47:17 <lebarhon> It isn't a new problem, I agree
19:48:03 <lebarhon> moreover, when translating po strings, you don't know which xml file they belong
19:48:16 * Kernewes brb, got to put some more washing in the machine
19:48:31 <marja> well, if we do put them in the same directory as the .xml files, we have the original-size backup AND they'll get uploade to calenco along with the .xml files
19:49:43 <marja> lebarhon: well, the line above the en string tells where it comes from
19:50:04 <marja> e.g: "en/scannerdrake.xml:38"
19:50:32 <lebarhon> marja: I never saw such a lline ?
19:50:55 <marja> lebarhon: ah, I'm not sure lokalize shows it... I translate in vim
19:51:28 <lebarhon> Nothing in Lokalize
19:52:13 <marja> Akien: do you know whether that can be turned on in Lokalize... and whether transifex show it? ^^^
19:52:32 <yurchor> lebarhon: Look at the left pane please.
19:52:33 <papoteur> lebarhon: You must click on "Plus de détails"
19:53:07 <Akien> marja: I don't know for Lokalize, I translate with nano/kate :)
19:53:21 <marja> Akien: you're just as bad as me ;-)
19:53:39 <yurchor> Akien: It is shown on Unit metadata pane.
19:53:50 <lebarhon> Ok, in the matedata, I got it
19:53:54 <yurchor> Akien: In Lokalize
19:54:02 <lebarhon> *metadata
19:54:07 <papoteur> In lokalize, this is displayed at left, second panel.
19:54:09 <Akien> Tx shows it too
19:54:28 <Akien> When clicking on "More details", as papoteur said
19:55:14 <papoteur> lebarhon is right, it is easier to translate with the full text at screen.
19:55:57 <Akien> For the doc indeed, it's a valuable asset to have access to the context.
19:56:05 <papoteur> For now, I always translated XML files in xxe, either local or in Calenco.
19:57:08 <marja> I try to look at both the original en help file + at the Dutch MCC screen a help text is about
19:58:05 <swecarp> brb the kitchen neads a clean upp
19:58:13 <marja> swecarp: OK
19:58:18 * Kernewes back now
19:58:24 <marja> Kernewes: wb
19:59:00 <marja> is there more on transifex? (we can talk about Calenco as next topic)
19:59:11 <Kernewes> not from me
19:59:32 <papoteur> marja: No
19:59:38 <lebarhon> The easyest way should be to have the screenshots in the xy language first, and translate after
19:59:47 <marja> lebarhon: indeed
19:59:57 <lebarhon> bur ufortunately, we are doing the opposite
20:00:11 <yurchor> lebarhon: :'(
20:00:18 <marja> lebarhon: I just received 92 German screenshots from Alf
20:00:32 <marja> lebarhon: they only need to get the correct names :-/
20:00:53 <papoteur> marja: Outch!
20:01:12 <lebarhon> who is Alf ?
20:01:33 <lebarhon> a translator ?
20:01:52 <marja> lebarhon: he is often in the German channel, i know him from the En forum where he helped me with plymouth
20:02:13 <marja> lebarhon: I think he has helped translating installer help
20:02:34 <marja> lebarhon: and he was at OpenRheinRuhr this weekend
20:02:35 <yurchor> lebarhon: It's an alien, don't you know? https://en.wikipedia.org/wiki/ALF_(TV_series)  ;)
20:02:43 <marja> yurchor: grinz
20:02:47 <Kernewes> :)
20:02:57 <lebarhon> I never watch TV, sorry
20:03:24 <Kernewes> lebarhon: I don't now, that was a long time ago
20:04:17 <marja> but Latte (also at ORR) intends to try to translate part of MCC help
20:04:25 <marja> and Latte is in QA
20:05:29 * marja wonders whether anyone wants to talk about Calenco
20:05:44 <marja> if not, then it is maybe better to end the meeting
20:05:51 <yurchor> +1
20:06:11 <marja> yurchor: +1 for endmeeting, I suppose? ;-)
20:06:22 <yurchor> marja: Yes.
20:06:37 <Kernewes> marja: what did you want to say about Calanco?
20:06:42 <Kernewes> Calenco
20:06:49 <marja> Kernewes: I'll mail about it :-)
20:06:55 <marja> #endmeeting